Servicios de redes de aplicaciones : Cisco Cache Engines de la serie 500

Ejemplo de configuración del cambio de dirección de la política del WCCP del Cache Engine 500 Series

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (23 Abril 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra que demuestre cómo configurar un redireccionamiento de políticas del protocolo web cache communication versión 2 (WCCPv2) en un Cisco 500 Series Cache Engine. En esta configuración de muestra, usted utiliza el comando table-map en la configuración BGP y asociar la etiqueta del atributo de entrada externa WCCP en la tabla de ruteo para clasificar los paquetes con los atributos del Border Gateway Protocol (BGP) asociados a la fuente o al IP Address de destino de un paquete.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco 7513 Router que funciona con el Software Release 12.0(14)S de Cisco IOS�

  • Cisco Cache Engine 550 que ejecuta el Software Cisco Cache versión 2.3

  • Cisco 2600 Router que funciona con el Cisco IOS Software Release 12.0

  • Servidores Web del Windows NT

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Refiera a los convenios de los consejos técnicos de Cisco para la información sobre las convenciones sobre documentos.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/12658/wwcp_2_policy.gif

Trafique solamente que los viajes al destino PC2 (que pertenece al AS30) están reorientados al motor del caché, mientras que no es el otro tráfico del sistema (RouterD, servidor HTTP 3.3.3.3 en el AS33).

Configuraciones

En este documento, se utilizan estas configuraciones:

RouterA
!
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/1
ip address 172.17.241.27 255.255.255.0
!
router bgp 10
bgp log-neighbor-changes
network 2.2.2.0
network 172.17.241.0
redistribute connected
neighbor 2.2.2.1 remote-as 20

RouterB
!
ip wccp web-cache password ww policy destination 60
ip cef distributed
!
interface Serial0/0
ip address 1.1.1.2 255.255.255.0
no ip directed-broadcast
!
interface Ethernet5/0
ip address 2.2.2.1 255.255.255.0
no ip directed-broadcast
ip wccp web-cache redirect in
ip route-cache same-interface
!
router bgp 20
table-map dst
network 2.2.2.0
redistribute connected
neighbor 1.1.1.1 remote-as 30
neighbor 2.2.2.2 remote-as 10
!
ip classless
!
access-list 1 permit 3.0.0.0 0.255.255.255
route-map DST permit 10
match ip address 1
set ip wccp 60
!
route-map DST permit 20

RouterC
!
interface Serial0/0
ip address 1.1.1.1 255.255.255.0
no ip directed-broadcast
clockrate 64000
!
interface Ethernet5/0
ip address 3.3.3.1 255.255.255.0
no ip directed-broadcast
!
router bgp 30
network 3.3.3.0
redistribute connected
neighbor 1.1.1.2 remote-as 20
neighbor 1.1.1.2 send-community
neighbor 1.1.1.2 route-map setcomm out
neighbor 3.3.3.3 remote-as 33
!
ip classless
ip bgp-community new-format
!
access-list 1 permit 77.0.0.0 0.255.255.255
route-map setcomm permit 10
match ip address 1
set community 4433:1050
!
route-map setcomm permit 20
!

RouterD
!
interface Ethernet0
ip address 3.3.3.3 255.255.255.0
!
router bgp 33
bgp log-neighbor-changes
network 33.33.33.0
redistribute connected
neighbor 3.3.3.1 remote-as 30
!
ip classless
ip http server

Comandos relacionados

Usted puede configurar los ejemplos del router a estos escenarios:

tabla de mapeo

Utilice el comando table-map para cambiar la política del WCCP del destino a la fuente. El tráfico se reorienta que ahora es representado por cada pedido de HTTP con la dirección IP de origen especificada en el src del route-map.

!
router bgp 20
table-map src
network 2.2.2.0
redistribute connected
neighbor 1.1.1.1 remote-as 30
neighbor 2.2.2.2 remote-as 10
!
ip wccp web-cache password WW policy source 60
!
access-list 1 permit 172.0.0.0 0.255.255.255
route-map src permit 10
match ip address 1
set ip wccp 60
!
route-map src permit 20
!

match as-path

Cambie la condición que aplica la etiqueta WCCP a las rutas anunciadas BGP. En la configuración del RouterC, la etiqueta WCCP se aplica a las rutas BGP que pertenecen a la comunidad determinada 4433:1050. Usted puede utilizar el comando match as-path para seleccionar otros criterios en el routerB tal como la como-trayectoria.

ip as-path access-list 121 permit ^30$
!
route-map setlist permit 10
match as-path 121
set ip wccp 60
!

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 12658