Módulos e interfaces de Cisco : Módulo de switching de contenido de Cisco

Configuración del balance de carga del servidor FTP por medio deL IOS SLB

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra para el Equilibrio de carga del servidor FTP con la ayuda del Equilibrio de carga de servidores (SLB) de Cisco IOS.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Software Release 12.1(8)E del ½ del ¿Â de Cisco IOSï del supervisor del Catalyst 6000 Family para el Supervisor Engine 1 con MSFC1 (c6sup11-jsv-mz.121-8a.E)

  • Servidores FTP de Microsoft Windows 2000/IIS

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

La característica del Cisco IOS SLB es una solución basada en IOS de Cisco que proporciona el Server Load Balancing. Esta característica permite que usted defina a un servidor virtual que represente a un cluster de los servidores reales, conocido como bloque de servidores. Cuando un cliente inicia una conexión al servidor virtual, la carga IOS SLB equilibra la conexión a un servidor real elegido, dependiendo del algoritmo o del calculador configurado de la balanza de la carga.

Cuando usted utiliza IOS SLB, usted debe configurar el Equilibrio de carga del servidor FTP para actuar en el modo del envío. En este modo, conocen a la dirección virtual a los servidores FTP. Usted debe configurar a cada uno de los servidores FTP con los Loopback Address para su Loopback Interface único. Este paso es necesario dar a cada máquina en el servidor FTP en la granja la misma dirección IP que la dirección virtual. El servidor FTP puede entonces responder directamente a los clientes con el Loopback Address, apenas pues el servidor respondería para su propia dirección IP. El IOS SLB reorienta los paquetes al servidor real en la capa 2 en el capa de control de acceso de medios (MAC). La dirección IP del servidor virtual no se modifica en el modo enviado. Por lo tanto, los servidores reales deben ser la capa 2-adjacent a IOS SLB. Si no, los routeres intermedios no pueden rutear al servidor real elegido.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/12577/config_ftpserver_lb.gif

Configuraciones

Este documento usa esta configuración:

  • Configuración FTP SLB del IOS usando el Catalyst 5509

Configuración FTP SLB del IOS usando el Catalyst 5509
Current configuration: 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot buffersize 126968 
boot system flash slot0:c6sup11-jsv-mz.121-8a.E.bin 
! 
redundancy 
 main-cpu 
  auto-sync standard 
ip subnet-zero 
! 

!--- FTP Serverfarm configuration.
 
ip slb serverfarm FTPFARM 
 real 10.1.1.3 
  inservice 
 !  
 real 10.1.1.4 
  inservice 
! 

!--- FTP Virtual configuration. 
!--- Important: Config Loopback address on FTP Server's with Virtual address.
 
ip slb vserver FTPSERVER 
 virtual 172.17.63.241 tcp ftp service ftp 
 serverfarm FTPFARM 
 inservice 
! 
interface GigabitEthernet1/1 
 no ip address 
 shutdown 
! 
interface GigabitEthernet1/2 
 no ip address 
 shutdown 
! 
interface FastEthernet2/1 
 description "Uplink to the Default Gateway" 
 no ip address 
 switchport 
 switchport access vlan 100 
! 
interface FastEthernet2/2 
 no ip address 
 shutdown 
! 
interface FastEthernet2/3 
 description "Connection to FTP server" 
 no ip address 
 switchport 
 switchport access vlan 200 
! 
interface FastEthernet2/4 
 description "Connection to FTP server" 
 no ip address 
 switchport 
 switchport access vlan 200 
! 
interface FastEthernet2/5 
 no ip address 
 shutdown 
! 
interface FastEthernet2/48 
 no ip address 
 shutdown 
! 
interface Vlan1 
 no ip address 
 shutdown 
! 

!--- Client Side Vlan. 

interface Vlan100 
 ip address 172.17.63.240 255.255.255.192 
! 

!--- FTP Server Vlan. 
!--- Important: Configure the default gateway of the FTP Server to this address.

interface Vlan200 
 ip address 10.1.1.250 255.255.255.0 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
line con 0 
line vty 0 4 
 login 
! 
end

Nota: Además de IOS SLB, el módulo content switching está también disponible para el Cisco Catalyst 6500 Series Switch y el Cisco 7600 Series Router. Este módulo proporciona las conexiones de alto rendimiento entre los bloques de servidores de los dispositivos de red en base de los paquetes de información de la capa 4 a 7. Para otros detalles, refiera al Cisco Content Switching Module.

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  • muestre el vserver del slb del IP — Visualiza la información del servidor virtual. Aquí está un ejemplo que visualiza el estado del servidor virtual y el número de conexiones:

    cat#show ip slb vserver 
    
    slb vserver    protocal   virtual                 state         conns 
    ----------------------------------------------------------------------
    FTPSERVER      TCP        172.17.63.241/32:21     OPERATIONAL    4
  • muestre el reals del slb del IP — Visualiza la información de la red de servidor. Este comando muestra el predictor usado para el balance de carga. Este ejemplo utiliza el ordenamiento cíclico (valor por defecto). “Ninguno” aparece bajo el NAT porque el dispositivo está en el modo enviado.

    cat#show ip slb serverfarm 
    
    server farm     predictor       nat        reals        bind id 
    ----------------------------------------------------------------- 
    FTPFARM         ROUNDROBIN      none          2           0

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

precaución Precaución: Asignan la salida de los debugs prioritario en proceso de la CPU. Por lo tanto, el hacer el debug de puede hacer el sistema inutilizable. Por esta razón, sólo use los comandos de depuración para resolver problemas específicos o durante sesiones de resolución de problemas con el equipo de soporte técnico de Cisco. Cisco recomienda que usted utiliza los comandos debug durante los períodos de flujos de red inferior y de menos usuarios. El debugging durante estos períodos reduce el efecto de estos comandos sobre otros usuarios sobre el sistema.

Comandos para resolución de problemas

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

  • haga el debug del slb del IP {conns | reals | vservers | todos} — mensajes del debug de las visualizaciones. No utilice la ninguna forma de este comando para inhabilitar el debugging. Aquí está la descripción de la sintaxis:

    Sintaxis Descripción
    conec Mensajes del debug de las visualizaciones para todas las conexiones que el IOS SLB maneja actualmente.
    vservers Mensajes del debug de las visualizaciones para todos los servidores virtuales definidos a IOS SLB.
    reals Mensajes del debug de las visualizaciones para todos los servidores reales definidos a IOS SLB.
    todos Visualiza todos los mensajes del debug para IOS SLB.

    Las sesiones FTP consisten en dos conexiones entre el FTP cliente y el servidor FTP, a saber, el control y los datos.

  • conexiones del slb del IP del debug

    Aquí está un ejemplo que utiliza el FTP pasivo. En los términos más simples, éste es cómo el FTP pasivo trabaja:

    • Una conexión para la conexión inicial del control FTP, que el cliente inicia al servidor:

      2d22h: SLB_CONN_DEBUG: TCP event= SYN_CLIENT,
       state= INIT -> SYNCLIENT 
      2d22h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d22h:  client= 171.70.24.233:35006 
      2d22h: SLB_CONN_DEBUG: TCP event= SYNACK_SERVER,
       state= SYNCLIENT -> ESTAB 
      2d22h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d22h:  client= 171.70.24.233:35006 
    • La otra conexión para la conexión de datos FTP, que se inicia del cliente al servidor:

      2d21h: SLB_CONN_DEBUG: TCP event= DATA_CLIENT,
       state= ESTAB -> ESTAB 
      2d21h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d21h:  client= 171.70.24.233:34999 
      2d21h: SLB_CONN_DEBUG: TCP event= DATA_SERVER,
       state= ESTAB -> ESTAB 
      2d21h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d21h:  client= 171.70.24.233:34999

Note que en el FTP pasivo, el cliente inicia el control de conexión y la conexión de datos. El modo pasivo refiere al estado de los servidores, en que el servidor valida pasivo ambas conexiones. En el modo pasivo, el destino y los puertos de origen son puertos “efímeros” (mayor de 1023). El cliente conduce los modos, como en cada caso el cliente debe publicar el comando passive, o el comando port, de iniciar la configuración de la conexión de datos. En cada caso el beneficiario de la conexión de datos (servidor para el modo pasivo, el cliente para el modo activo) debe suministrar el número del puerto en el cual están atenta esta conexión específica. No es SIEMPRE el puerto 20 para la conexión de datos, incluso en el modo activo FTP. Nada en los RFC especifica que los puertos que se utilizarán son 20 y 21, él es apenas convenio. Muchos servidores utilizan los puertos efímeros para la conexión de datos.

% no pueden habilitar el servidor nacional porque el vserver [chars] tiene FTP habilitado

Se visualiza este mensaje de error porque el IOS SLB no soporta el FTP en el modo NAT. La solución alternativa es utilizar el modo y los loopback del envío en los servidores. Para más información, vea la sección del loopback del modo enviado.

Loopback del modo Enviado

Después de que usted haya configurado el FTP Serverfarm y la característica del vserver en el Catalyst 6500, usted debe configurar a cada servidor real con un dispositivo del Loopback o interconectar. Configure la dirección IP del servidor virtual como el Loopback IP Address, con un netmask de 255.0.0.0.

Route Table 
     =========================================================================== 
     Interface List 
     0x1 ........................... MS TCP Loopback interface 
     0x2 ...00 60 b0 87 dc 1a ...... AMD PCNET Family Ethernet Adapter 
     0x1000004 ...02 00 4c 4f 4f 50 ...... MS LoopBack Driver 
     =========================================================================== 
     Active Routes: 
        Network         Destination     Netmask       Gateway   Interface Metric 
        0.0.0.0         0.0.0.0         10.1.1.250    10.1.1.3      1 
        10.1.1.0        255.255.255.0   10.1.1.3      10.1.1.3      1 
        10.1.1.3        255.255.255.255 127.0.0.1     127.0.0.1     1 
        10.255.255.255  255.255.255.255 10.1.1.3      10.1.1.3      1 
        127.0.0.0       255.0.0.0       127.0.0.1     127.0.0.1     1 
        172.17.63.241   255.255.255.255 127.0.0.1     127.0.0.1     1 
        224.0.0.0       224.0.0.0       10.1.1.3      10.1.1.3      1 
        224.0.0.0       224.0.0.0       172.17.63.241 172.17.63.241 1 
        255.255.255.255 255.255.255.255 10.1.1.3      10.1.1.3      1 
     ===========================================================================

Examine a la dirección de red en cada fila de la tabla, donde usted ve que aparece el Loopback Address. Para que los servidores comuniquen correctamente, usted necesita una referencia a una dirección de red de multicast conocida. Esto está en la octava fila en el ejemplo, así que usted necesita borrar el Default Route adicional. Éste es el cuya dirección de red comienza con el mismo primer dígito que la dirección del clúster, y es seguido por tres ceros. En este ejemplo, la ruta adicional está en la segunda fila.

Éstas son direcciones de red de multicast conocida:

224.0.0.0      224.0.0.0    172.17.63.241      172.17.63.241       1

Aquí están las rutas predeterminado automático-instaladas quitadas de la tabla en el ejemplo:

0.0.0.0          0.0.0.0    172.17.63.193   172.17.63.241          1

Usted debe borrar la ruta adicional para permitir la comunicación correcta con el servidor virtual SLB.


Información Relacionada


Document ID: 12577