Administración de redes y automatización : Cisco Network Registrar

Instalación básica de cablemódem con Cisco Network Registrar

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El propósito de esta nota técnica es proporcionar una guía completa de la configuración para una red del Cable Modem (CM) en un ambiente de laboratorio. Esta configuración puede utilizarse como un primer paso, antes de la implementación en la red de un cliente. Es importante observar que una configuración sin problemas en el laboratorio no significa necesariamente una configuración sin problemas en la red de un cliente. En un ambiente de laboratorio controlado, el ruido puede no ser un problema; mientras que en la vida real, puede ser muy el contrario. Sin embargo, este procedimiento se puede utilizar para eliminar los problemas que se presentan de la versión de software del ½ del ¿Â de Cisco IOSïÂ, de la configuración, del hardware, y del Radiofrecuencia (RF).

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Topología de laboratorio

Cuadro 1 – Configuración de la red de laboratorio

basic_bridged_setup_01.gif

En este diagrama, hay un Sistema de terminación del cablemódem (CMTS) que consiste en estos componentes:

  • uBR7246 que funciona con el Cisco IOS Software Release 12.1(2)T con las placas del módem MC16C

  • UBR904 CM que funciona con la versión 12.0(7)T de la versión de Cisco IOS Software

  • Upconverter

  • Filtro de Diplex para separar el de alta frecuencia de las frecuencias bajas

  • Versión 3.5(3) del Cisco Network Registrar (CNR)

  • Divisor de tres vías

  • Customer Premises Equipment (CPE) que, en este caso, es una laptop

Nota: La configuración RF en ese diagrama se puede utilizar como punto de referencia que comienza; sin embargo, esto pudo cambiar una vez que usted lo despliega en un sitio del cliente. Las medidas RF están fuera del alcance de este documento; refiera a conectar al Cisco uBR7200 Series Router con la cabecera del cable para la configuración apropiada y las medidas RF.

Suposición

  • El convertidor ascendente ya se encuentra instalado y configurado correctamente. Refiera a la documentación del vendedor para la configuración. Recuerde que, si usted es el usar convertidor ascendente de GI, esto se debe fijar en 1.75 MHz más bajos que la frecuencia central del canal NTSC en la pregunta.

  • Hay un CPE correctamente configurado que se sienta detrás del CM, para obtener específicamente una dirección IP vía el servidor DHCP.

  • El CNR se utiliza como el DHCP y los servidores TFTP, con la misma dirección IP: 172.17.110.136.

  • El software del servidor del Time Of Day (ToD) se está ejecutando en el mismo servidor NT que el CNR.

Las secciones en este documento explican los pasos que son necesarios configurar estos componentes:

  • Cisco Network Registrar (CNR)

  • Archivo de configuración del Data-Over-Cable Service Interface Specification (DOCSIS)

  • Sistema de terminación del cablemódem (CMTS)

  • Cablemódem (CM)

Diagrama de la red

Cuadro 2 – Diagrama de la red con los IP Addresses y los nombres usados en esta nota técnica

/image/gif/paws/12547/basic_bridged_setup_02.gif

Configuración de Cisco Network Registrar

Siga este procedimiento para configurar el CNR:

  1. Ponga en marcha el menú CNR desde el principio.

  2. En la barra de menú, haga clic la lengueta del agregar para agregar un nuevo cluster.

    1. Ingrese el nombre del agrupamiento.

      En este caso, una dirección IP se utiliza como el nombre.

    2. Marque la conexión con este checkbox una vez agregado del cluster.

    3. Haga clic en OK.

    Cuadro 3 – Ventana del nombre de clúster o de la dirección IP en el CNR

    /image/gif/paws/12547/basic_bridged_setup_03.gif

  3. Cuando le indican para el nombre de usuario y contraseña, utilice el admin y el changeme.

    Cuadro 4 – Ventana del nombre de usuario y contraseña en el CNR

    /image/gif/paws/12547/basic_bridged_setup_04.gif

  4. Haga clic en OK.

    Una ventana aparece que es similar figura 5, que contiene los nombres o los IP Addresses de los clusteres configurados.

    Cuadro 5 – Ventana de administrador de servidor en el CNR

    basic_bridged_setup_05.gif

  5. Clic doble DHCP@172.17.110.136, traer para arriba la ventana de pPropiedades de DHCP@172.17.110.136.

  6. Haga clic la lengueta de las directivas y después haga clic nuevo, para crear una nueva directiva.

    Cuadro 6 – Agregando una directiva llamada “Cable módems” y copiado de los atributos de la directiva “predeterminada”

    basic_bridged_setup_06.gif

  7. Ingrese el nombre de la política.

    En este ejemplo, el nombre es Cable módems.

  8. Si esto es una nueva directiva, fije la copia del campo para omitir.

  9. Haga clic en OK.

  10. El tecleo edita las opciones, para especificar las opciones DHCP.

    Para la directiva llamada Cable módems, agregue las opciones siguientes (véase el cuadro 7):

    • el Dhcp-lease-time es activo por abandono y determinado a 604800 segundos, que es el número de segundos en una semana.

    • routers es la dirección IP de la interfaz de cable CMTS, en este caso 10.1.1.10. Vea configurar el headend (CMTS).

    • desplazamiento del tiempo del CM del Universal Coordinated Time (UTC; Opción de desplazamiento de tiempo 2). Esto es utilizada por el CM para calcular la hora local, para los registros de error del grupo fecha/hora.

    • dirección IP de los servidores de tiempo para el Servidor TOD, que es 172.17.110.136.

    • el paquete-siaddr es la dirección IP del servidor TFTP, que es 172.17.110.136.

    • el packet-file-name es el archivo de configuración de DOCSIS configurado con el DOCSIS CPE Configurator (clientes registrados solamente). Este archivo debe residir en el directorio tftpboot del servidor TFTP.

    Cuadro 7 – Edite la ventana de opciones con los atributos dados a la política de cable módem

    basic_bridged_setup_07.gif

    Nota: Asegúrese de que usted marque el envío a casilla de verificación de clientes BOOTP, si usted tiene los clientes BOOTP. También se recomienda altamente que usted marca siempre el envío al checkbox de los clientes DHCP.

  11. Cree otra directiva asociada al CPEs detrás del CM, como las laptopes, y así sucesivamente.

    En este ejemplo, el nombre de la directiva es Clientes de cablemódem.

    Siga el mismo procedimiento que fue utilizado para la directiva del Cable módems excepto, este vez, fijó la copia del campo a la directiva del Cable módems en vez a la política predeterminada.

    Cuadro 8 – Agregando una directiva llamada “Clientes de cablemódem” y copiando los atributos de la política existente nombrada “Cable módems”

    /image/gif/paws/12547/basic_bridged_setup_08.gif

  12. Haga clic en OK.

  13. Haga clic el botón Option Button del editar, para seleccionar las opciones activas.

  14. Para la política de CPE, quite todas las opciones de la lista activa excepto el Dhcp-lease-time y las opciones del Routers.

    Para hacer así pues, seleccione la propiedad para borrar en la lista activa y para hacer clic el botón Remove Button.

  15. Cambie la dirección IP para la opción del Routers a 192.168.1.1, que es la driección IP secundaria configurada en el router CMTS.

    Vea configurar el headend (CMTS).

    Cuadro 9 – Agregando la dirección IP para el atributo del Routers, que es la driección IP secundaria configuró en la interfaz del cable a la cual esta directiva se aplica en el CMTS

    basic_bridged_setup_09.gif

    Nota: Este ejemplo utiliza un IP Address privado como la dirección secundaria en el CMTS y en la política de cliente del Cable módems. En un entorno de producción, los dispositivos CPE deben utilizar a un IP Address público, para poder acceder Internet (a menos que la traducción de dirección de red [NAT] se utiliza).

  16. Cree los alcances para asociarse a las directivas del Cable módems y de los Clientes de cablemódem.

    1. Para hacer un nuevo alcance, haga clic en DHCP@172.17.110.136 en el menú principal, y después haga clic la lengueta del agregar.

      Esto le permitirá agregar un nuevo alcance.

    2. Ingrese el nombre del nuevo alcance y después seleccione la directiva apropiada.

      En este ejemplo, el alcance para el Cable módems se fija para utilizar el rango de IP Addresses de 10.1.1.20 a 10.1.1.30.

      Cuadro 10 – Alcance para el Cable módems llamado “Cable módems”

      /image/gif/paws/12547/basic_bridged_setup_10.gif

    3. Relance los pasos 16a y 16b para el alcance de los Clientes de cablemódem.

      En este caso, el rango de IP Address privado de 192.168.1.20 a 192.168.1.30 se utiliza.

      Cuadro 11 – El alcance para el equipo CPE detrás del Cable módems llamó a los “Clientes de cablemódem”

      /image/gif/paws/12547/basic_bridged_setup_11.gif

    4. El alcance usado para los dispositivos CPE requiere la configuración adicional.

      1. Una vez que usted ha creado a los Clientes de cablemódem alcance, usted necesita hacer doble clic el alcance para abrir el cuadro de diálogo que se muestra en el cuadro 12.

        Cuadro 12 – Ventana Scope de los Clientes de cablemódem

        /image/gif/paws/12547/basic_bridged_setup_11.gif

      2. Haga clic la ficha Avanzadas, para relacionarse el alcance secundario con el alcance primario.

      3. Marque hacen este alcance una casilla de verificación secundaria.

      4. Una vez que la lista desplegable muestra un valor en blanco, seleccione el alcance primario apropiado.

        En este ejemplo, se selecciona el alcance del Cable módems.

        Cuadro 13 – Haciendo el alcance de los “Clientes de cablemódem” secundario y relacionarse lo con el alcance primario

        basic_bridged_setup_12.gif

  17. Finalmente, usted necesita recomenzar a su servidor DHCP de modo que sus cambios puedan ocurrir.

    En el menú principal, DHCP@172.17.110.136 selecto y hace clic la lengueta del control en el top, para conseguir el cuadro de diálogo mostrado en el cuadro 14. Este cuadro de diálogo permite que usted recargue al servidor DHCP.

    Cuadro 14 – Ventana de la recarga para confiar los cambios en el CNR

    /image/gif/paws/12547/basic_bridged_setup_13.gif

Archivo de configuración de DOCSIS

El siguiente paso que se requiere poner una red de cable es componer el archivo de configuración. Para que un módem de cable venga en línea, necesita descargar su archivo de configuración vía el TFTP de un servidor DHCP. En el ejemplo de este documento, el CNR se utiliza para proporcionar el TFTP y a los servidores DHCP. Refiera al DHCP y al archivo de configuración de DOCSIS para el Cable módems (DOCSIS 1.0) para más información sobre los requerimientos mínimos de poner el archivo de configuración. El archivo se pone con la herramienta basada en Web, DOCSIS CPE Configurator (clientes registrados solamente), o con una descarga de la versión autónoma. En encendido la sección CM (uBR904) de este documento, el archivo de configuración de DOCSIS se utiliza que se llama platinum.cm.

Nota: Una vez que se crea el archivo de configuración, asegúrese de que esté copiado al servidor TFTP. En el caso del servidor TFTP CNR, usted también debe asegurarse de que enciendan al servidor TFTP:

  1. Seleccione TFTP@172.17.110.136 y después haga clic la lengueta del control.

    Esto trae para arriba el cuadro de diálogo del control de TFTP@172.17.110.136, donde el servidor puede ser encendido.

  2. La funcionalidad del servidor TFTP está apagada por abandono. Para hacer que el servidor TFTP comienza automáticamente en el bootup, el comienzo NRCMD (la interfaz de línea de comando para el CNR) y publica estos comandos:

    server tftp set start-on-reboot=enabled
    
    save
    

Configuración de la cabecera (CMTS)

Esto es una configuración básica para el CMTS (el uBR7246):

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Sydney
!
boot system flash ubr7200-ik1s-mz_121-2_T.bin
no logging buffered
enable password <deleted>
!
no cable qos permission create

!--- Default.

no cable qos permission update

!--- Default.

cable qos permission modems

!--- Default.

!
!
!
ip subnet-zero
no ip domain-lookup
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/0
 ip address 172.17.110.139 255.255.255.224

!--- The IP address of the interface in the same LAN segment as CNR.

!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Ethernet1/4
 no ip address
 shutdown
!
interface Ethernet1/5
 no ip address
 shutdown
!
interface Ethernet1/6
 no ip address
 shutdown
!
interface Ethernet1/7
 no ip address
 shutdown
!
 interface Cable2/0
 ip address 192.168.1.1 255.255.255.0 secondary

!--- The secondary IP address is used for the CPE’s scope in CNR.

 ip address 10.1.1.10 255.255.255.0

!--- The primary IP address is used for the CM’s scope in CNR.

 no keepalive
 cable downstream annex B

!--- Default for DOCSIS-compliant cable plants. For EuroDOCSIS, use annex A.

 cable downstream modulation 64qam

!--- Default.

 cable downstream interleave-depth 32

!--- Default.

 cable downstream frequency 451250000

!--- Cosmetic except for the uBR7100. This line has no effect
!--- on Upconverter Frequency. Used as a reminder of the frequency
!--- that is used in the Unconverter.

 cable upstream 0 frequency 28000000

!--- Upstream Frequency configuration. This is chosen after a careful
!--- analysis on the noise levels of the return path.

 cable upstream 0 power-level 0
 no cable upstream 0 shutdown

!--- Enables the upstream 0 port.

 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
 cable dhcp-giaddr policy

!--- Modifies the GIADDR field of DHCPDISCOVER and DHCPREQUEST packets.

 cable helper-address 172.17.110.136

!--- Specifies a destination IP address for UDP-broadcast DHCP packets.

!
interface Cable3/0
 no ip address
 no keepalive
 shutdown
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.110.129
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0
 exec-timeout 0 0
  transport input none
line aux 0
line vty 0
 exec-timeout 0 0
 password cisco
 login
line vty 1 4
 password cisco
 login
!
end

Configuración de CM

Típicamente, un módem de cable no requiere ninguna configuración de usuario para que venga en línea (independientemente de los valores predeterminados de fábrica). Esto se aplica solamente si se va el CM a ser utilizado como Bridge. Éste es un ejemplo de una configuración de cablemódem del uBR que se esté obteniendo automáticamente, después de que venga el CM en línea:

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
clock timezone - 0
ip subnet-zero
no ip routing
!
!
interface Ethernet0
 ip address 10.1.1.25 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 ip address negotiated
 no ip directed-broadcast
 no ip route-cache
 cable-modem downstream saved channel 453000000 20 1
 cable-modem mac-timer t2 40000
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip default-gateway 10.1.1.10
ip classless
no ip http server
!
!
line con 0
 transport input none
line vty 0 4
!
end

Verificación y resolución de problemas

Esta sección describe los comandos que se pueden utilizar para verificar la operación correcta de la red de cable.

En el CMTS (uBR7246)

Asegúrese de que el Cable módems esté en línea:

Sydney# show cable modem

Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable2/0/U0 2    online     2290   -0.25  6   1   10.1.1.25       0050.7366.2223

Si el Cable módems se pega en el init (d) estado, después no hay Conectividad entre la interfaz del cable CMTS y el servidor DHCP.

Asegúrese de que usted pueda publicar un ping extendido de la interfaz del cable del CMTS:

Sydney# ping ip

Target IP address: 172.17.110.136
Repeat count [5]: 
Datagram size [100]: 
Timeout in seconds [2]: 
Extended commands [n]: y
Source address or interface: 10.1.1.10
Type of service [0]: 
Set DF bit in IP header? [no]: 
Validate reply data? [no]: 
Data pattern [0xABCD]: 
Loose, Strict, Record, Timestamp, Verbose[none]: 
Sweep range of sizes [n]: 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.110.136, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms

Si el ping no tiene éxito, verifique el IP Routing. También, asegúrese de que el servidor NT que está ejecutando el CNR tenga el gateway predeterminada correcta o la ruta de nuevo al CMTS. Usted puede también publicar un ping del CNR.

Otro comando que se puede utilizar en el CMTS para verificar el módem de cable y la conectividad CPE es show interface cable 2/0 modem 0:

Sydney# show interfaces cable 2/0 modem 0

SID   Priv bits  Type      State     IP address    method    MAC address
2     00         host      unknown   192.168.1.20  dhcp      0010.a4e6.d04d

!--- A laptop that is obtaining an IP address.

2     00         modem     up        10.1.1.25     dhcp      0050.7366.2223

!--- The cable modem.

En el CM (uBR904)

Usted puede también marcar la Conectividad en el lado del módem de cable. Publique el comando show ip interface brief y el control que las interfaces son up/up:

Router# show ip interface brief

Interface                  IP-Address      OK? Method Status         Protocol
Ethernet0                  10.1.1.25       YES unset  up             up
cable-modem0               10.1.1.25       YES unset  up             up

Router# show controllers cable-modem 0

BCM Cable interface 0:
CM unit 0, idb 0x2010AC, ds 0x86213E0, regaddr = 0x800000, reset_mask 0x80
station address 0050.7366.2223  default station address 0050.7366.2223
PLD VERSION: 32
MAC State is maintenance_state, Prev States = 15
MAC mcfilter 01E02F00  data mcfilter 01000000
MAC extended header ON
DS: BCM 3116 Receiver: Chip id = 2
US: BCM 3037 Transmitter: Chip id = 30AC
Tuner: status=0x00
Rx: tuner_freq 453000000, symbol_rate 5055880, local_freq 11520000
    snr_estimate 35210, ber_estimate 0, lock_threshold 26000
    QAM in lock, FEC in lock, qam_mode QAM_64
Tx: TX_freq 27984000, power_level 0x30 (24.0 dBmV), symbol_rate 8
    (1280000 sym/sec)
DHCP: TFTP server = 172.17.110.136, TOD server = 172.17.110.136
      Security server = 0.0.0.0, Timezone Offest = 0
      Config filename = platinum.cm
buffer size 1600

RX data PDU ring with 32 entries at 0x202130
   rx_head = 0x202168 (7), rx_p = 0x8621418 (7)

RX MAC message ring with 8 entries at 0x202270
  rx_head_mac = 0x2022A0 (6), rx_p_Mac = 0x86214BC (6)

TX BD ring with 8 entries at 0x2023A8, TX_count = 0
  TX_head = 0x2023C8 (4), head_txp = 0x8621548 (4)
  TX_tail = 0x2023C8 (4), tail_txp = 0x8621548 (4)

TX PD ring with 8 entries at 0x202428, TX_count = 0
  TX_head_pd = 0x202C28 (4)
  TX_tail_pd = 0x202C28 (4)

Global control and status:
  global_ctrl_status=0x00
interrupts:
  irq_pend=0x0008, irq_mask=0x00F7

Usted puede también probar la conectividad del IP. Haga ping al servidor DHCP del CM:

Router# ping 172.17.110.136

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.110.136, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms

uBR7246

Sydney# show version

Cisco Internetwork Operating System Software
IOS (tm) 7200 Software (UBR7200-IK1S-M),
     Version 12.1(2)T, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Tue 16-May-00 13:36 by ccai
Image text-base: 0x60008900, data-base: 0x613E8000
ROM: System Bootstrap,
     Version 11.1(10) [dschwart 10], RELEASE SOFTWARE (fc1)
BOOTFLASH: 7200 Software (UBR7200-BOOT-M),
     Version 12.0(10)SC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Sydney uptime is 4 days, 40 minutes
System returned to ROM by reload
System image file is "slot0:ubr7200-ik1s-mz_121-2_T.bin"
cisco uBR7223 (NPE150) processor (revision B) with 57344K/8192K bytes of memory.
Processor board ID SAB0249006T
R4700 CPU at 150Mhz, Implementation 33, Rev 1.0, 512KB L2 Cache
3 slot midplane, Version 1.0
Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
8 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
2 Cable Modem network interface(s)
125K bytes of non-volatile configuration memory.
1024K bytes of packet SRAM memory.
20480K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).
4096K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102

uBR904

Router# show version

Cisco Internetwork Operating System Software
IOS (TM) 900 Software (UBR900-K1OY556I-M),
     Version 12.0(7)T,  RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Tue 07-Dec-99 02:01 by phanguye
Image text-base: 0x08004000, database: 0x0852E888


ROM: System Bootstrap,
     Version 11.2(19980518:195057), RELEASED SOFTWARE
ROM: 900 Software (UBR900-RBOOT-M),
     Version 11.3(7)NA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1) 


Router uptime is 1 hour, 6 minutes
System returned to ROM by reload at 11:20:43 - Thu Oct 12 2001
System restarted at 11:21:53 - Thu Oct 12 2001
System image file is "flash:ubr900-k1oy556i-mz.120-7.T.bin"

cisco uBR900 CM (68360) processor (revision D) with 8192K bytes of memory.
Processor board ID FAA0315Q07M
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 Cable Modem network interface(s)
4096K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Boot flash (Read/Write)
        

Configuration register is 0x2102

Para una explicación detallada sobre el uso de los debugs CNR — en caso de que usted necesita resolver problemas los problemas CNR — refiera a los problemas DHCP del troubleshooting en las redes de cable usando el Cisco Network Registrar Debugs. Para la configuración de Client Class, refiera a configurar los clientes class.


Información Relacionada


Document ID: 12547