Marcado y acceso remotos : Dial-on-Demand Routing (DDR)

Configuración de respaldo ISDN con rutas estáticas flotantes

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra para implementar un backup ISDN con las Rutas estáticas flotantes, y proporciona la información básica sobre troubleshooting para los este tipos de configuración.

Para la información sobre la mayoría de las implementaciones frecuentes del backup ISDN, y las comparaciones entre éstos, refiera al documento siguiente: Evaluación de interfaces de respaldo, rutas estáticas flotantes y vigilancia de programas dialer para el respaldo de DDR.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Dos Cisco 2500 Router que funcionan con los Software Release 12.2(3) y 12.2(5) del ½ del ¿Â de Cisco IOSïÂ

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para encontrar la información adicional en los comandos usados en este documento, utilice la herramienta de búsqueda de comandos (clientes registrados solamente).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/12497/diagram.gif

Configuraciones

Este documento usa las configuraciones detalladas a continuación.

krimson (Cisco 2500 Router)
krimson#show running-config
 Building configuration...

 !
 version 12.2
 service timestamps debug datetime msec
 service timestamps log datetime msec
 !
 hostname krimson
 !
 username kevin password 0 <password>
 !
 isdn switch-type basic-net3
 !
 !
 interface Loopback0
 ip address 10.7.7.1 255.255.255.0
 !
 interface Serial0
 ip address 10.1.2.1 255.255.255.0
 !
 interface BRI0
 no ip address
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 dialer pool-member 1
 isdn switch-type basic-net3
 no fair-queue
 no cdp enable
 ppp authentication chap
 !
 interface Dialer0
 ip address 10.9.9.1 255.255.255.0
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer pool 1
 dialer remote-name kevin


 dialer string 8114
 dialer-group 1
 no cdp enable
 ppp authentication chap
 !
 ip classless
 ip route 10.8.8.0 255.255.255.0 10.1.2.2
 ip route 10.8.8.0 255.255.255.0 10.9.9.2 180
 no ip http server
 !
 dialer-list 1 protocol ip permit
 !
 !
 line con 0
 exec-timeout 0 0
 line aux 0
 line vty 0 4
 exec-timeout 0 0
 password <password> login
 !
 end

kevin (Cisco 2500 Router)
kevin#show running-config
 Building configuration...

 Current configuration : 1205 bytes
 !
 version 12.2
 service timestamps debug datetime msec
 service timestamps log datetime msec
 no service password-encryption
 !
 hostname kevin
 !
 username krimson password 0 <password>
 !
 isdn switch-type basic-net3
 !
 !
 !
 interface Loopback0
 ip address 10.8.8.1 255.255.255.0
 !
 interface Serial0
 ip address 10.1.2.2 255.255.255.0
 clockrate 2000000
 !
 interface Serial1
 no ip address
 shutdown
 !
 interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-net3
 no cdp enable
 ppp authentication chap
 !
 interface Dialer0
 ip address 10.9.9.2 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer remote-name krimson
 dialer string 8113
 dialer-group 1
 no cdp enable
 ppp authentication chap
 !
 !
 dialer-list 1 protocol ip permit
 !
 !
 line con 0
 exec-timeout 0 0
 line aux 0
 line vty 0 4
 exec-timeout 0 0
 password <password> login
 !
 end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta del Output Interpreter soportan a los ciertos comandos show (clientes registrados solamente), que permite que usted vea una análisis de la salida del comando show.

  • ruta de IP de la demostración - Entradas de tabla de IP Routing de las visualizaciones.

  • show interfaces - Muestra las estadísticas para todas las interfaces configuradas en el router o en el servidor de acceso.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

La herramienta del Output Interpreter soportan a los ciertos comandos show (clientes registrados solamente), que permite que usted vea una análisis de la salida del comando show.

Nota: Antes de ejecutar un comando debug, consulte Información Importante sobre Comandos Debug.

  • debug isdn q931 - Muestra información acerca de la configuración de llamadas y desconexión de conexiones de red ISDN (Capa 3) entre el router local (lado del usuario) y la red.

  • debug isdn events: muestra los acontecimientos de ISDN que se producen en el lado del usuario (en el router) de la interfaz de ISDN. Los eventos ISDN que pueden visualizarse son eventos Q.931 (configuración de llamada y desactivación de conexiones de red ISDN).

  • debug dialer – Muestra información de depuración acerca de los paquetes o eventos en una interfaz del marcador.

  • debug ppp negotiation – hace que el comando debug ppp muestre los paquetes PPP transmitidos durante el inicio de PPP donde se negocian las opciones PPP

  • debug ppp authentication – Hace que el comando debug ppp muestre los mensajes del protocolo de autenticación, entre ellos el intercambio de paquetes de protocolo de autenticación por desafío mutuo (CHAP) y los intercambios de protocolo de autenticación de contraseña (PAP).

Ejemplo de resultado de depuración

Aquí, podemos probar la funcionalidad de backup usando los comandos shutdown and no shutdown en la interfaz serial en el lado remoto. Esto lleva en consecuencia, a la desaparición de la ruta ip principal a la red de destino en cuestión.

Déjenos primera mirada en el estado inicial de la interfaz primaria y de la tabla de IP Routing:

Parte que llama:

   krimson#show interface serial 0
   Serial0 is up, line protocol is up 
   Hardware is HD64570
   Internet address is 10.1.2.1/24
   MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation HDLC, loopback not set
   Keepalive set (10 sec)
   Last input 00:00:07, output 00:00:07, output hang never
   Last clearing of "show interface" counters never
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/256 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 1158 kilobits/sec
   5 minute input rate 1000 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   92 packets input, 7599 bytes, 0 no buffer
   Received 62 broadcasts, 0 runts, 0 giants, 0 throttles
   0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
   99 packets output, 8991 bytes, 0 underruns
   0 output errors, 0 collisions, 12 interface resets
   0 output buffer failures, 0 output buffers swapped out
   4 carrier transitions
   DCD=up DSR=up DTR=up RTS=up CTS=up
   
   krimson#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
   area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route

   Gateway of last resort is 10.48.74.1 to network 0.0.0.0

   10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
   C 10.1.2.0/24 is directly connected, Serial0
   S 10.8.8.0/24 [1/0] via 10.1.2.2 
  
 !--- The IP route for the destination network points to the primary link.

   C 10.9.9.0/24 is directly connected, Dialer0
   C 10.7.7.0/24 is directly connected, Loopback0
   C 10.48.74.0/23 is directly connected, Ethernet0
   S* 0.0.0.0/0 [254/0] via 10.48.74.1

Parte llamada:

   kevin#show interface serial 0
   Serial0 is up, line protocol is up 
   Hardware is HD64570
   Internet address is 10.1.2.2/24
   MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation HDLC, loopback not set
   Keepalive set (10 sec)
   Last input 00:00:00, output 00:00:08, output hang never
   Last clearing of "show interface" counters never
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/256 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 1158 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   106 packets input, 9432 bytes, 0 no buffer
   Received 71 broadcasts, 0 runts, 0 giants, 0 throttles
   0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
   98 packets output, 8016 bytes, 0 underruns
   0 output errors, 0 collisions, 4 interface resets
   0 output buffer failures, 0 output buffers swapped out
   1 carrier transitions
   DCD=up DSR=up DTR=up RTS=up CTS=up
  
   kevin#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
   area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route

   Gateway of last resort is 10.48.74.1 to network 0.0.0.0

   10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
   C 10.1.2.0/24 is directly connected, Serial0
   C 10.9.9.0/24 is directly connected, Dialer0
   C 10.8.8.0/24 is directly connected, Loopback0
   C 10.48.74.0/23 is directly connected, Ethernet0
   S* 0.0.0.0/0 [254/0] via 10.48.74.1
   kevin# 

Ahora podemos simular la falla de link usando el comando shutdown en la interfaz en serie remota:

   krimson#
   *Mar 4 15:25:18.302: %LINK-3-UPDOWN: Interface Serial0, changed state to
   down
   *Mar 4 15:25:19.302: %LINEPROTO-5-UPDOWN: Line protocol on Interface
   Serial0, changed state to down

Podemos ver aquí que ha ido el link principal abajo.

   krimson#show interface serial 0
   Serial0 is down, line protocol is down 
   Hardware is HD64570
   Internet address is 10.1.2.1/24
   MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation HDLC, loopback not set
   Keepalive set (10 sec)
   Last input 00:00:22, output 00:00:32, output hang never
   Last clearing of "show interface" counters never
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/256 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 1158 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   108 packets input, 8526 bytes, 0 no buffer
   Received 78 broadcasts, 0 runts, 0 giants, 0 throttles
   0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
   114 packets output, 9895 bytes, 0 underruns
   0 output errors, 0 collisions, 12 interface resets
   0 output buffer failures, 0 output buffers swapped out
   5 carrier transitions
   DCD=down DSR=down DTR=up RTS=up CTS=down
   krimson#

Los datos de la tabla de ruteo indican que la ruta estática flotante está instalada en la tabla de ruteo:

   krimson#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
   area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route

   Gateway of last resort is 10.48.74.1 to network 0.0.0.0

   10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
   S 10.8.8.0/24 [180/0] via 10.9.9.2
   C 10.9.9.0/24 is directly connected, Dialer0
   C 10.7.7.0/24 is directly connected, Loopback0
   C 10.48.74.0/23 is directly connected, Ethernet0
   S* 0.0.0.0/0 [254/0] via 10.48.74.1
   krimson#

En el router llamado, podemos simular la falla del link primario simulado mediante el uso del comando shutdown en la interfaz serial local 0.

   kevin#configure terminal
   Enter configuration commands, one per line. End with CNTL/Z.
   kevin(config)#interface serial 0
   kevin(config-if)#shutdown

   *Mar 4 15:32:00.250: %LINK-5-CHANGED: Interface Serial0, changed state to
   administratively down
   *Mar 4 15:32:01.250: %LINEPROTO-5-UPDOWN: Line protocol on Interface
   Serial0, changed state to down
   *Mar 4 15:32:03.742: %SYS-5-CONFIG_I: Configured from console by console

Ahora podemos ver que va el link principal abajo:

   kevin#show interface serial 0
   Serial0 is administratively down, line protocol is down 
   Hardware is HD64570
   Internet address is 10.1.2.2/24
   MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation HDLC, loopback not set
   Keepalive set (10 sec)
   Last input 00:01:28, output 00:01:18, output hang never
   Last clearing of "show interface" counters never
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/256 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 1158 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   114 packets input, 9895 bytes, 0 no buffer
   Received 79 broadcasts, 0 runts, 0 giants, 0 throttles
   0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
   108 packets output, 8526 bytes, 0 underruns
   0 output errors, 0 collisions, 4 interface resets
   0 output buffer failures, 0 output buffers swapped out
   1 carrier transitions
   DCD=down DSR=down DTR=up RTS=up CTS=down

El tráfico de ping que se define como tráfico interesante inicia la llamada saliente vía la interfaz del dialer de backup 0.

   krimson#ping 10.8.8.1

   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 10.8.8.1, timeout is 2 seconds:

   *Mar 4 15:27:39.618: BR0 DDR: rotor dialout [priority]
   *Mar 4 15:27:39.622: BR0 DDR: Dialing cause ip (s=10.9.9.1, d=10.8.8.1)
   *Mar 4 15:27:39.626: BR0 DDR: Attempting to dial 8114
   *Mar 4 15:27:39.642: ISDN BR0: TX -> SETUP pd = 8 callref = 0x09
   *Mar 4 15:27:39.646: Bearer Capability i = 0x8890
   *Mar 4 15:27:39.654: Channel ID i = 0x83
   *Mar 4 15:27:39.658: Called Party Number i = 0x80, '8114',
   Plan:Unknown, Type:Unknown
   *Mar 4 15:27:39.718: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0x89
   *Mar 4 15:27:39.722: Channel ID i = 0x89
   *Mar 4 15:27:39.974: ISDN BR0: RX <- CONNECT pd = 8 callref = 0x89
   *Mar 4 15:27:39.990: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
   *Mar 4 15:27:39.998: %DIALER-6-BIND: Interface BR0:1 bound to profile Di0
   *Mar 4 15:27:40.010: BR0:1 PPP: Treating connection as a callout
   *Mar 4 15:27:40.010: BR0:1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 0 load]
   *Mar 4 15:27:40.014: BR0:1 LCP: O .!!!CONFREQ [Closed] id 19 len 15
   *Mar 4 15:27:40.018: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 4 15:27:40.022: BR0:1 LCP: MagicNumber 0x12D0A490 (0x050612D0A490)
   *Mar 4 15:27:40.030: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref = 0x09
   *Mar 4 15:27:40.054: BR0:1 LCP: I CONFREQ [REQsent] id 9 len 15
   *Mar 4 15:27:40.058: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 4 15:27:40.062: BR0:1 LCP: MagicNumber 0x12D6B638 (0x050612D6B638)
   *Mar 4 15:27:40.066: BR0:1 LCP: O CONFACK [REQsent] id 9 len 15
   *Mar 4 15:27:40.066: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 4 15:27:40.070: BR0:1 LCP: MagicNumber 0x12D6B638 (0x050612D6B638)
   *Mar 4 15:27:40.074: BR0:1 LCP: I CONFACK [ACKsent] id 19 len 15
   *Mar 4 15:27:40.078: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 4 15:27:40.082: BR0:1 LCP: MagicNumber 0x12D0A490 (0x050612D0A490)
   *Mar 4 15:27:40.082: BR0:1 LCP: State is Open
   *Mar 4 15:27:40.086: BR0:1 PPP: Phase is AUTHENTICATING, by both [0 sess, 0 load]
   *Mar 4 !
   Suc15:27:40.090: BR0:1 CHAP: O CHALLENGE id 7 len 28 from "krimson"
   *Mar 4 15:27:40.106: BR0:1 CHAP: I CHALLENGE id 7 len 26 from "kevin"
   *Mar 4 15:27:40.110: BR0:1 CHAP: O RESPONSE id 7 len 28 from "krimson"
   *Mar 4 15:27:40.138: BR0:1 CHAP: I SUCCESS id 7 len 4
   *Mar 4 15:27:40.150: BR0:1 CHAP: I RESPONSE id 7 len 26 from "kevin"
   *Mar 4 15:27:40.158: BR0:1 CHAP: O SUCCESS id 7 len 4
   *Mar 4 15:27:40.162: BR0:1 PPP: Phase is UP [0 sess, 0 load]
   *Mar 4 15:27:40.166: BR0:1 IPCP: O CONFREQ [Not negotiated] id 2 len 10
   *Mar 4 15:27:40.170: BR0:1 IPCP: Address 10.9.9.1 (0x03060A090901)
   *Mar 4 15:27:40.186: BR0:1 IPCP: I CONFREQ [REQsent] id 2 len 10
   *Mar 4 15:27:40.190: BR0:1 IPCP: Address 10.9.9.2 (0x03060A090902)
   *Mar 4 15:27:40.190: BR0:1 IPCP: O CONFACK [REQsent] id 2 len 10
   *Mar 4 15:27:40.194: BR0:1 IPCP: Address 10.9.9.2 (0x03060A090902)
   *Mar 4 15:27:40.202: BR0:1 IPCP: I CONFACK [ACKsent] id 2 len 10
   *Mar 4 15:27:40.206: BR0:1 IPCP: Address 10.9.9.1 (0x03060A090901)
   *Mar 4 15:27:40.206: BR0:1 IPCP: State is Open
   *Mar 4 15:27:40.214: BR0:1 DDR: dialer protocol up
   *Mar 4 15:27:40.218: Di0 IPCP: Install route to 10.9.9.2
   *Mar 4 15:27:41.162: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
   changed state to upcess rate is 80 percent (4/5), round-trip min/avg/max =
   36/47/76 ms
   krimson#

Al mismo tiempo, los debugs que funcionan con en la demostración de parte llamada el producto siguiente para esta misma llamada:

   kevin#   
   *Mar 4 15:34:21.698: ISDN BR0: RX <- SETUP pd = 8 callref = 0x07
   *Mar 4 15:34:21.706: Bearer Capability i = 0x8890
   *Mar 4 15:34:21.714: Channel ID i = 0x89
   *Mar 4 15:34:21.718: Calling Party Number i = 0xA1, '8113',
   Plan:ISDN, Type:National
   *Mar 4 15:34:21.734: Called Party Number i = 0xC1, '8114',
   Plan:ISDN, Type:Subscriber(local)
   *Mar 4 15:34:21.762: ISDN BR0: Event: Received a DATA call from 8113 on B1
   at 64 Kb/s
   *Mar 4 15:34:21.762: ISDN BR0: Event: Accepting the call id 0xC
   *Mar 4 15:34:21.766: BR0:1: interface must be fifo queue, force fifo
   *Mar 4 15:34:21.774: %DIALER-6-BIND: Interface BR0:1 bound to profile Di0
   *Mar 4 15:34:21.786: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
   *Mar 4 15:34:21.798: BR0:1 PPP: Treating connection as a callin
   *Mar 4 15:34:21.802: BR0:1 PPP: Phase is ESTABLISHING, Passive Open [0 sess,
   0 load]
   *Mar 4 15:34:21.806: BR0:1 LCP: State is Listen
   *Mar 4 15:34:21.818: ISDN BR0: TX -> CALL_PROC pd = 8 callref = 0x87
   *Mar 4 15:34:21.826: Channel ID i = 0x89
   *Mar 4 15:34:21.854: ISDN BR0: TX -> CONNECT pd = 8 callref = 0x87
   *Mar 4 15:34:21.918: ISDN BR0: RX <- CONNECT_ACK pd = 8 callref = 0x07
   *Mar 4 15:34:21.926: Channel ID i = 0x89
   *Mar 4 15:34:21.978: BR0:1 LCP: I CONFREQ [Listen] id 19 len 15
   *Mar 4 15:34:21.982: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 4 15:34:21.986: BR0:1 LCP: MagicNumber 0x12D0A490 (0x050612D0A490)
   *Mar 4 15:34:21.990: BR0:1 LCP: O CONFREQ [Listen] id 9 len 15
   *Mar 4 15:34:21.994: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 4 15:34:21.994: BR0:1 LCP: MagicNumber 0x12D6B638 (0x050612D6B638)
   *Mar 4 15:34:21.998: BR0:1 LCP: O CONFACK [Listen] id 19 len 15
   *Mar 4 15:34:22.002: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 4 15:34:22.006: BR0:1 LCP: MagicNumber 0x12D0A490 (0x050612D0A490)
   *Mar 4 15:34:22.030: BR0:1 LCP: I CONFACK [ACKsent] id 9 len 15
   *Mar 4 15:34:22.034: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 4 15:34:22.034: BR0:1 LCP: MagicNumber 0x12D6B638 (0x050612D6B638)
   *Mar 4 15:34:22.038: BR0:1 LCP: State is Open
   *Mar 4 15:34:22.042: BR0:1 PPP: Phase is AUTHENTICATING, by both [0 sess, 0
   load]
   *Mar 4 15:34:22.046: BR0:1 CHAP: O CHALLENGE id 7 len 26 from "kevin"
   *Mar 4 15:34:22.050: BR0:1 CHAP: I CHALLENGE id 7 len 28 from "krimson"
   *Mar 4 15:34:22.054: BR0:1 CHAP: Waiting for peer to authenticate first
   *Mar 4 15:34:22.070: BR0:1 CHAP: I RESPONSE id 7 len 28 from "krimson"
   *Mar 4 15:34:22.078: BR0:1 CHAP: O SUCCESS id 7 len 4
   *Mar 4 15:34:22.082: BR0:1 CHAP: Processing saved Challenge, id 7
   *Mar 4 15:34:22.090: BR0:1 CHAP: O RESPONSE id 7 len 26 from "kevin"
   *Mar 4 15:34:22.114: BR0:1 CHAP: I SUCCESS id 7 len 4
   *Mar 4 15:34:22.118: BR0:1 PPP: Phase is UP [0 sess, 0 load]
   *Mar 4 15:34:22.122: BR0:1 IPCP: O CONFREQ [Not negotiated] id 2 len 10
   *Mar 4 15:34:22.126: BR0:1 IPCP: Address 10.9.9.2 (0x03060A090902)
   *Mar 4 15:34:22.130: BR0:1 IPCP: I CONFREQ [REQsent] id 2 len 10
   *Mar 4 15:34:22.134: BR0:1 IPCP: Address 10.9.9.1 (0x03060A090901)
   *Mar 4 15:34:22.138: BR0:1 IPCP: O CONFACK [REQsent] id 2 len 10
   *Mar 4 15:34:22.142: BR0:1 IPCP: Address 10.9.9.1 (0x03060A090901)
   *Mar 4 15:34:22.226: BR0:1 IPCP: I CONFACK [ACKsent] id 2 len 10
   *Mar 4 15:34:22.230: BR0:1 IPCP: Address 10.9.9.2 (0x03060A090902)
   *Mar 4 15:34:22.230: BR0:1 IPCP: State is Open
   *Mar 4 15:34:22.242: BR0:1 DDR: dialer protocol up
   *Mar 4 15:34:22.250: Di0 IPCP: Install route to 10.9.9.1
   *Mar 4 15:34:23.114: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
   changed state to up
   *Mar 4 15:34:27.794: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to
   8113 krimson

El estado después del respaldo es "activo":

   krimson#show interface dialer 0
   Dialer0 is up, line protocol is up (spoofing)
   Hardware is Unknown
   Internet address is 10.9.9.1/24
   MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   DTR is pulsed for 1 seconds on reset
   Interface is bound to BR0:1
   Last input never, output never, output hang never
   Last clearing of "show interface" counters 00:13:26
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/16 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 42 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   36 packets input, 2160 bytes
   36 packets output, 2160 bytes
   Bound to:
   BRI0:1 is up, line protocol is up 
   Hardware is BRI
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   Keepalive set (10 sec)
   Time to interface disconnect: idle 00:01:33
   Interface is bound to Di0 (Encapsulation PPP)
   LCP Open
   Open: IPCP
   Last input 00:00:26, output 00:00:01, output hang never
   Last clearing of "show interface" counters never
   Queueing strategy: fifo
   Output queue 0/40, 0 drops; input queue 0/75, 0 drops
   30 second input rate 0 bits/sec, 0 packets/sec
   30 second output rate 0 bits/sec, 0 packets/sec
   126 packets input, 3664 bytes, 0 no buffer
   Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
   0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
   131 packets output, 3777 bytes, 0 underruns
   0 output errors, 0 collisions, 15 interface resets
   0 output buffer failures, 0 output buffers swapped out
   28 carrier transitions

   krimson#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
   area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route

   Gateway of last resort is 10.48.74.1 to network 0.0.0.0

   10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
   C 10.9.9.2/32 is directly connected, Dialer0
   S 10.8.8.0/24 [180/0] via 10.9.9.2
   C 10.9.9.0/24 is directly connected, Dialer0
   C 10.7.7.0/24 is directly connected, Loopback0
   C 10.48.74.0/23 is directly connected, Ethernet0
   S* 0.0.0.0/0 [254/0] via 10.48.74.1

En la parte llamada:

El estado después del respaldo es "up" (“activado”).

   kevin#show interface dialer 0
   Dialer0 is up, line protocol is up (spoofing)
   Hardware is Unknown
   Internet address is 10.9.9.2/24
   MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   DTR is pulsed for 1 seconds on reset
   Interface is bound to BR0:1
   Last input never, output never, output hang never
   Last clearing of "show interface" counters 00:16:18
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/16 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 42 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   40 packets input, 2224 bytes
   40 packets output, 2224 bytes
   Bound to:
   BRI0:1 is up, line protocol is up 
   Hardware is BRI
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   Keepalive set (10 sec)
   Time to interface disconnect: idle 00:01:11
   Interface is bound to Di0 (Encapsulation PPP)
   LCP Open
   Open: IPCP
   Last input 00:00:48, output 00:00:00, output hang never
   Last clearing of "show interface" counters never
   Queueing strategy: fifo
   Output queue 0/40, 0 drops; input queue 0/75, 0 drops
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   136 packets input, 3857 bytes, 0 no buffer
   Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
   0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
   131 packets output, 3744 bytes, 0 underruns
   0 output errors, 0 collisions, 12 interface resets
   0 output buffer failures, 0 output buffers swapped out
   35 carrier transitions

   kevin#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
   area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route

   Gateway of last resort is 10.48.74.1 to network 0.0.0.0

   10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks
   C 10.9.9.0/24 is directly connected, Dialer0
   C 10.8.8.0/24 is directly connected, Loopback0
   C 10.9.9.1/32 is directly connected, Dialer0
   C 10.48.74.0/23 is directly connected, Ethernet0
   S* 0.0.0.0/0 [254/0] via 10.48.74.1

Aquí, simulamos la recuperación del link principal usando el comando no shutdown en la interfaz en serie remota:

   krimson# 
   *Mar 4 15:28:58.726: %LINK-3-UPDOWN: Interface Serial0, changed state to up
   *Mar 4 15:28:59.730: %LINEPROTO-5-UPDOWN: Line protocol on Interface
   Serial0, changed state to up

El marcador de respaldo se desconecta después de que se agota el tiempo de inactividad.

   krimson#show isdn active

   --------------------------------------------------------------------------------
   ISDN ACTIVE CALLS

   --------------------------------------------------------------------------------
   Call Calling Called Remote Seconds Seconds Seconds Charges
   Type Number Number Name Used Left Idle
   Units/Currency

   --------------------------------------------------------------------------------
   Out 8114 kevin 120 1 118 0
   --------------------------------------------------------------------------------

   krimson#
   *Mar 4 15:29:41.738: BR0:1 DDR: idle timeout
   *Mar 4 15:29:41.742: BR0 DDR: has total 0 call(s), dial_out 0, dial_in 0
   *Mar 4 15:29:41.746: BR0:1 PPP: Treating connection as a callout
   *Mar 4 15:29:41.750: %DIALER-6-UNBIND: Interface BR0:1 unbound from profile
   Di0
   *Mar 4 15:29:41.754: BR0:1 DDR: disconnecting call
   *Mar 4 15:29:41.758: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from
   8114 kevin, call lasted 121 seconds
   *Mar 4 15:29:41.774: ISDN BR0: TX -> DISCONNECT pd = 8 callref = 0x09
   *Mar 4 15:29:41.782: Cause i = 0x8090 - Normal call clearing
   *Mar 4 15:29:41.790: Di0 IPCP: Remove route to 10.9.9.2
   *Mar 4 15:29:41.862: ISDN BR0: RX <- RELEASE pd = 8 callref = 0x89
   *Mar 4 15:29:41.886: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
   *Mar 4 15:29:41.894: BR0:1 IPCP: State is Closed
   *Mar 4 15:29:41.894: BR0:1 PPP: Phase is TERMINATING [0 sess, 0 load]
   *Mar 4 15:29:41.898: BR0:1 LCP: State is Closed
   *Mar 4 15:29:41.898: BR0:1 PPP: Phase is DOWN [0 sess, 0 load]
   *Mar 4 15:29:41.902: BR0:1 DDR: disconnecting call
   *Mar 4 15:29:41.910: ISDN BR0: TX -> RELEASE_COMP pd = 8 callref = 0x09
   *Mar 4 15:29:42.886: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
   changed state to down

Ahora restablecen al estado inicial.

   krimson#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
   area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route

   Gateway of last resort is 10.48.74.1 to network 0.0.0.0

   10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
   C 10.1.2.0/24 is directly connected, Serial0
   S 10.8.8.0/24 [1/0] via 10.1.2.2
   C 10.9.9.0/24 is directly connected, Dialer0
   C 10.7.7.0/24 is directly connected, Loopback0
   C 10.48.74.0/23 is directly connected, Ethernet0
   S* 0.0.0.0/0 [254/0] via 10.48.74.1

Información Relacionada


Document ID: 12497