IP : Protocolo de túneles punto a punto (PPTP)

Configuración de PPTP a través de PAT hacia un servidor PPTP de Microsoft

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El PPTP (Point-to-Point Tunneling Protocol) de Microsoft (MS) se utiliza para permitir a los usuarios remotos conectar de nuevo con su red corporativa de una manera segura a través de Internet público. Puede asignar una sola dirección IP a una ubicación remota para conservar sus direcciones IP públicas. A continuación, puede permitir que varios usuarios establezcan conexiones PPTP simultáneamente a las mismas ubicaciones o a otras diferentes. El PPTP fue agregado en el Software Release 12.1(4)T de Cisco IOS�.

Para más información, refiera al NAT - soporte para el PPTP en una sección de configuración de la sobrecarga (traducción de dirección de puerto) en el Cisco IOS Software 12.1T Early Deployment Release Series.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco 3600 Router que ejecutan los Cisco IOS Software Releases 12.1.5(9)T y 12.2.3

  • Todas las Plataformas del sistema operativo Windows con los clientes originarios PPTP incorporados

  • Advanced Server de MS Windows 2000 con un servidor PPTP incorporado

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/12483/pptp_pat_01-new.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Luz del router
Current configuration : 1136 bytes 
! 
version 12.2 
service timestamps debug upti 
service timestamps log uptime 
no service password-encryption 
! 
hostname light 
! 
boot system tftp c3660-jk9o3s-mz.122-3.bin 255.255.255.255 
! 
ip subnet-zero 
! 
! 
no ip domain-lookup 
! 
ip audit notify log 
ip audit po max-events 100 
ip ssh time-out 120 
ip ssh authentication-retries 3 
! 
call rsvp-sync 
cns event-service server 
! 
! 
! 
! 
! 
fax interface-type modem 
mta receive maximum-recipients 0 
! 
controller E1 2/0 
! 
! 
! 
interface FastEthernet0/0 
ip address 10.64.10.13 255.255.255.224

!--- Defines the interface as external for NAT.

ip nat outside
duplex auto 
speed auto 
! 
interface FastEthernet0/1 
ip address 192.168.200.1 255.255.255.0 

!--- Defines the interface as internal for NAT.

ip nat inside
duplex auto 
speed auto 
! 
interface Serial1/0 
no ip address 
shutdown 
no fair-queue 
! 
interface Serial1/1 
no ip address 
shutdown 
! 
interface Serial1/2 
no ip address 
shutdown 
! 
interface Serial1/3 
no ip address 
shutdown 
! 

!--- Indicates that any packets received on the inside interface permitted
!--- by access list 101 share one public IP address (the address on Fa0/0).

ip nat inside source list 101 interface FastEthernet0/0 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 10.64.10.1 
no ip http server 
!
access-list 101 permit ip any any
!
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Tabla de traducción de NAT IP
light#show ip nat translations

Pro Inside global      Inside local          Outside local      Outside global
gre 10.64.10.13:50150  192.168.200.253:50150 10.64.10.21:50150  10.64.10.21:50150
gre 10.64.10.13:50151  192.168.200.254:50151 10.64.10.21:50151  10.64.10.21:50151
gre 10.64.10.13:0      192.168.200.254:0     10.64.10.21:0      10.64.10.21:0
gre 10.64.10.13:32768  192.168.200.253:32768 10.64.10.21:32768  10.64.10.21:32768
tcp 10.64.10.13:2643   192.168.200.253:2643  10.64.10.21:1723   10.64.10.21:1723
tcp 10.64.10.13:3546   192.168.200.254:3546  10.64.10.21:1723   10.64.10.21:1723

Base del router
Building configuration...

Current configuration : 2281 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname house
!
enable password cisco
!
ip subnet-zero
!
!
!
fax interface-type modem
mta receive maximum-recipients 0
!
!
interface FastEthernet0/0
 ip address 10.64.10.21 255.255.255.224

!--- Defines the interface as external for NAT.

ip nat outside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.50.1 255.255.255.0

!--- Defines the interface as internal for NAT.

ip nat inside
 duplex auto
 speed auto
!
!
interface FastEthernet4/0
 no ip address
 shutdown
 duplex auto
 speed auto
!

!--- Indicates that any packets received on the inside interface permitted by 
!--- access list 101 share one public IP address (the address on Fa0/0).

ip nat inside source list 101 interface FastEthernet0/0 overload

!--- Static port translation for the Microsoft PPTP server on TCP port 1723
!--- share one public IP address (the address on Fa0/0).

ip nat inside source static tcp 192.168.50.2 1723 interface FastEthernet0/0 1723
ip classless
ip route 0.0.0.0 0.0.0.0 10.64.10.1
ip http server
ip pim bidir-enable
!
access-list 101 permit ip any any
!
!
snmp-server manager
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
!
end

Tabla de traducción de NAT IP
house#show ip nat translations

Pro Inside global      Inside local       Outside local      Outside global
gre 10.64.10.21:50150  192.168.50.2:50150 10.64.10.13:50150  10.64.10.13:50150
gre 10.64.10.21:50151  192.168.50.2:50151 10.64.10.13:50151  10.64.10.13:50151
gre 10.64.10.21:0      192.168.50.2:0     10.64.10.13:0      10.64.10.13:0
gre 10.64.10.21:32768  192.168.50.2:32768 10.64.10.13:32768  10.64.10.13:32768
tcp 10.64.10.21:1723   192.168.50.2:1723  10.64.10.13:2643   10.64.10.13:2643
tcp 10.64.10.21:1723   192.168.50.2:1723  ---                ---
tcp 10.64.10.21:80     192.168.50.2:80    ---                ---
tcp 10.64.10.21:1723   192.168.50.2:1723  10.64.10.13:3546   10.64.10.13:3546

Configure el servidor PPTP MS

Complete estos pasos para configurar el servidor PPTP MS:

  1. Vaya a rutear y al Acceso Remoto y elija la configuración y habilite la encaminamiento y el Acceso Remoto.

    /image/gif/paws/12483/pptp_pat_02.gif

  2. En la encaminamiento y el asistente de configuración de servidor de acceso remoto, elija el servidor del Red privada virtual (VPN).

    /image/gif/paws/12483/pptp_pat_03.gif

  3. Defina los IP Addresses exteriores y de la red interna para la placa de interfaz de la red de servidores (NIC).

    pptp_pat_04.gif

  4. Asigne una agrupación IP a los clientes remotos PPTP.

    /image/gif/paws/12483/pptp_pat_05.gif

  5. Usted puede utilizar el servidor de autenticación de RADIUS MS o usted puede utilizar la autenticación local.

    /image/gif/paws/12483/pptp_pat_06.gif

  6. Cree las bases de datos de usuarios locales para la autenticación local.

    /image/gif/paws/12483/pptp_pat_07.gif

  7. Dos clientes PPTP detrás del router del Port Address Translation (PAT) están conectados con el servidor PPTP MS.

    pptp_pat_08.gif

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  • muestre a IP las traducciones nacionales — Muestra el contenido de la tabla de traducción.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Recursos de resolución de problemas

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 12483