Tecnologías IBM : Data-Link Switching (DLSw) y Data-Link Switching Plus (DLSw+)

Configuraciones básicas de DLSw+

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

La Conmutación de link de datos (DLSw) es un protocolo de switch a switch utilizado para transportar Arquitectura de red de sistemas (SNA) de IBM y tráfico NetBIOS de IBM por una red IP. Este protocolo no otorga un ruteo completo, pero otorga la conmutación de la capa de link de datos SNA y la encapsulación en TCP/IP para el transporte sobre Internet.

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Antecedentes

El DLSw+ es Cisco implementación de DLSw. Además de las funciones estándar de DLSw, DLSw+ también incluye las siguientes:

  • Elección de opción de transporte, que incluye TCP, FST (transporte de secuencia rápida) y encapsulación directa.

  • Mejoras de escalabilidad a través de: grupos de peer, pares a pedido, escudos de protección exploradores, y aprendizaje de ubicación.

  • Conversión a medios entre LAN y SDLC o Ethernet locales y remotas.

¿Cuál es el estándar DLSW?

Para obtener más detalles sobre el estándar DLSw, consulte RFC 1795 (RFC 1434 se volvió obsoleto a partir del RFC 1795). En resumen, RFC 1795 describe el Protocolo de switch a switch (SSP) que se utiliza entre routers para establecer conexiones DLSw, ubicar recursos, enviar datos, manejar el control de flujo y recupera errores. También describe el modo de terminar localmente las conexiones de Controles de links de datos (DLC) y correlacionar las conexiones DLC a un circuito DLSw.

Al finalizar las conexiones DLC localmente, DLSw soluciona los siguientes problemas:

  • Tiempos de espera de DLC

  • Reconocimientos DLC sobre la WAN

  • Control de flujo y congestión.

  • Control de broadcast de los paquetes de la búsqueda

  • Límites del conteo de saltos de la conexión en puente de la ruta de origen

Nota: Las mejoras al RFC 1795 se pueden encontrar en el RFC 2166. Esas mejoras dirigen los problemas de ampliación en DLSw y las clarificaciones al RFC 1795. El RFC 2166, sin embargo, hace no 1795 Obsoletos y se debe utilizar conjuntamente con 1795.

Configuraciones de Ejemplo

Las configuraciones representadas aquí son configuraciones parciales; no retratan solamente la parte de que la configuración requirió para el soporte del DLSw+, y a ninguna del IP o del otro soporte a protocolo. Como DLSw+ depende de TCP/IP (excepto cuando se utiliza FST o directo), se supone que la red IP ya está activa y en funcionamiento.

1. Token Ring al Token Ring sobre WAN

/image/gif/paws/12411/ringwan.gif

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

 
!--- Allows the router to forward single route explorer frames.

Router B

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface TokenRing0
 ip address 150.150.20.2 255.255.255.0
 ring-speed 16
 source-bridge 2 1 2000
 source-bridge spanning

 
!--- Allows the router to forward single route explorer frames.

En este ejemplo, tomamos un anillo virtual, número de anillo 2000, a fin de establecer fácilmente una relación entre los dos grupos. El (RIF) del campo routing information, sin embargo, se termina en el router del DLSw+. Usted puede elegir un diverso número de anillo virtual para cada router. Tenga cuidado al elegir el número de anillo; usted debe seguir las mismas reglas que se aplican al Source-Route Bridging. Actualmente, Cisco soporta solamente un Anillo virtual por el router.

El comando dlsw local-peer se utiliza para definir su propia dirección DLSw+IP del router local. En el ejemplo anterior, se utiliza la dirección IP de la interfaz del loopback para que DLSw+ no tenga que confiar en que la interfaz física real esté en funcionamiento.

El comando dlsw remote-peer define la dirección IP del router remoto. El número 0 que aparece luego a la palabra clave del par remoto es el número de lista en anillo. , Si usted quiere completamente una red mallada, utilice generalmente el número 0. El número de lista en anillo se utiliza para controlar la inundación de tramas del explorador al permitir segmentar la red (el ejemplo nº2 presenta una demostración de lista en anillo).

2. Token Ring al Token Ring con la Timbre-lista

/image/gif/paws/12411/ringlist.gif

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2000
 source-bridge spanning 

 
!--- Allows the router to forward single route explorer frames.

Router B
!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 1 tcp 150.150.1.1
dlsw ring-list 1 rings 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface TokenRing0
 ip address 150.150.20.2 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning 

 
!--- Allows the router to forward single route explorer frames.

!
interface TokenRing1
ip address 150.150.30.1 255.255.255.0
ring-speed 16
source-bridge 2 1 2000
source bridge spanning 


!--- Allows the router to forward single route explorer frames.

En este ejemplo, todas las estaciones de trabajo en el timbre 3 pueden establecer solamente las sesiones con las estaciones en el timbre 1, pero no el timbre 2, y vice versa. Las estaciones en el Anillo 1 aún pueden hablar con las estaciones en el Anillo 2, porque están conectadas localmente al Router B.

Esto significa que no habrá broadcast del timbre 2 que será entregado al router A. El uso de las instrucciones dlsw ring-list, port-list y bgroup-list es muy útil cuando desea controlar el tráfico de transmisión en la WAN.

3. Token Ring a los Ethernetes sobre WAN

/image/gif/paws/12411/ringether.gif

En este ejemplo, los dispositivos están ubicados en medios mixtos; por lo tanto, debemos intercambiar bits de la dirección MAC del host antes de que se codifique en el dispositivo secundario que inicia el paquete de prueba del explorador. Vea también la comprensión y resolver problemas del Source-Route Translational Bridging.

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning 

!--- Allows the router to forward single route explorer frames.


En el siguiente ejemplo, la estación en el segmento Ethernet tiene permitido comunicarse con las estaciones en el segmento Token Ring. El router DLSw+ se ocupará de la conversión del formato Ethernet al formato Token Ring. El comando dlsw bridge-group se utiliza para conectar el segmento Ethernet al proceso DLSw+ de la misma manera en que el enunciado del puente de origen conecta el segmentoToken Ring a la DLSw+ a través del grupo de anillos virtual. No es necesario configurar SRT/LB a menos que posea una interfaz Token Ring en el router B y se requiera la comunicación entre las estaciones en este Token Ring y Ethernet. Vea el ejemplo 6.

Nota:  no es necesario source-bridge ring-group en el router B.

Router B
!
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Ethernet0
 ip address 150.150.30.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec
!

4. Ethernetes a los Ethernetes sobre WAN

/image/gif/paws/12411/etherwan.gif

Router A
!
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface Ethernet0
 ip address 150.150.30.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec
!
Router B
!
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec

Nota:  no es necesario source-bridge ring-group en cualquiera de los dos routers.

5. Token Ring a los Ethernetes en el mismo router

/image/gif/paws/12411/tokenether.gif

Si necesita conectar estaciones entre Ethernet y Token Ring locales para un router, debe usar SR/TLB (conexión en puente con traducción). DLSw local entre los Ethernetes y el Token Ring no se soporta.

Router A

source-bridge ring-group 2000
source-bridge transparent 2000 1000 1 1

interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.

!
bridge 1 protocol ieee

Para el comando source-bridge transparent 2000 1000 1 1 tenemos:

  • 2000 es el número de anillo virtual configurado por source-bridge ring-group 2000.

  • 1000 es el número de seudo anillo dado al dominio Ethernet.

  • 1 es el número del puente de aquél que conduce al dominio de conexión en puente transparente.

  • 1 es el número del grupo puente transparente que desea vincular a su dominio de puente con ruta de origen.

Nota: Las direcciones IP en las interfaces no se necesitan para SRT/LB.

6. SR/TLB y DLSw+

srtlb.gif

Router A
source-bridge ring-group 2000
source-bridge transparent 2000 1000 1 1
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.

!
bridge 1 protocol dec
Router B
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.11.1  255.255.255.0
 ring-speed 16
 source-bridge 2 1 2000
 source-bridge spanning 

!--- Allows the router to forward single route explorer frames.

En el ejemplo anterior, se configura DLSw y SRT/LB. El SRT/LB se requiere solamente cuando las estaciones en el Token Ring necesitan hablar con las estaciones en los Ethernetes en el mismo router, el router A. Si el único requisito es que las estaciones Ethernet en el router A se comuniquen con las estaciones Token Ring remotas en el router B, entonces el grupo de puentes dlsw 1 se encarga de eso.

7. Token Ring al SDLC over WAN

/image/gif/paws/12411/tokensdlc.gif

Router A
!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.


Router B

dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Serial 1
 no ip address
 encapsulation sdlc
 no keepalive
 clockrate 9600
 sdlc role primary

 !--- Assumes SDLC station role secondary for the controller.

 sdlc vmac 4000.9999.0100 

 
!--- Virtual MAC address given to the controller which will 
 !--- have sdlc address (01) appended to it.

 sdlc address 01          

 
!--- SDLC address, obtained from controller configuration.

 sdlc xid 01 05D20001     

 
 !--- 01 is the SDLC address and IDBLK/IDNUM should match that 
 !--- in SMN on the host.

 sdlc partner 4000.1020.1000 01 

 
 !--- 4000.1020.1000 is the MAC address of the host
 !--- and 01 is the SDLC address.
 
 sdlc dlsw 1
!

Nota: La conexión de circuito de DLSw estará entre 4000.9999.0101 y 4000.1020.1000. También, el ejemplo antedicho asume un regulador PU2.0. Para otros tipos de PU, consulte la Guía de soluciones de problemas de DLSw SDLC.

Los ejemplos de configuración antedichos son algunos escenarios de la red común. Puede hacer mucho más con DLSw+, pero estas configuraciones le brindan algunos puntos básicos. Tenga presente que el DLSw+ es RSRB aumentado con la capacidad de interoperabilidad adicional con el otro Routers que está de acuerdo con el RFC 1795 y 2166.


Información Relacionada


Document ID: 12411