IP : Túnel serial (STUN)

Configuración de BSTUN punto a punto con Reconocimiento local sobre retransmisión de tramas

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El soporte de los permisos de la característica del Bisync Serial Tunnel (BSTUN) para los dispositivos que utilizan el Bisync Datalink Protocol. Este protocolo permite a las empresas para transportar el tráfico BISYNC sobre la misma red que soporta su Arquitectura de red de sistemas (SNA) y el tráfico de protocolo múltiple, que elimina la necesidad de los recursos de Bisync separado. Con el Frame Relay, usted puede utilizar la característica del Reconocimiento local para proporcionar la finalización local de la sesión sobre el peerBSTUN.

En este ejemplo, el BSTUN Point-to-Point se configura con Ackowledgement local sobre el Frame Relay. Resaltan al estado pertinente en la salida del comando show bstun en el este documento.

Nota: Aunque los comandos debug bstun packet/event y debug bsc packet/event no deban causar la utilización excesiva CPU, utilizan al comando logging buffered de copiar la salida al archivo del registro.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información en este documento se basa en el Software Release 12.1(5) de Cisco IOS�.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

bstun_p2p_localack_over_fr-01.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Kilcot
Building configuration 
!
version 12.1
service timestamps debug datetime msec
!
hostname kilcot
!
! 
bstun peer-name 100.1.1.1
bstun protocol-group 72 bsc-local-ack
!
! 
interface Loopback0
ip address 100.1.1.1 255.0.0.0
!
interface Serial0/0
ip address 10.1.1.1 255.0.0.0
encapsulation frame-relay
no ip mroute-cache
frame-relay interface-dlci 16
frame-relay lmi-type ansi
!
interface Serial1/0
no ip address
ip directed-broadcast
encapsulation bstun
no ip mroute-cache
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc secondary
bstun route all tcp 200.2.2.2
!
!
router rip
network 10.0.0.0
network 100.0.0.0
!
end

Partido
Building configuration...

version 12.1
! 
service timestamps debug datetime msec
!
hostname party
!
bstun peer-name 200.2.2.2
bstun protocol-group 72 bsc-local-ack
!
!
interface Loopback0
ip address 200.2.2.2 255.255.255.0
! 
interface Serial0
no ip address
encapsulation bstun
load-interval 30
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc primary
bstun route all tcp 100.1.1.1
!
interface Serial1
ip address 10.1.1.2 255.0.0.0
encapsulation frame-relay IETF
no ip mroute-cache
frame-relay interface-dlci 17
frame-relay lmi-type ansi
!
!
router rip
network 10.0.0.0
network 200.2.2.0
!
end

Verificación

En esta sección encontrará información que puede utilizar para comprobar que su configuración funcione correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • show bstun

  • show bsc

kilcot#show bsc
BSC local-ack on Serial1/0:
secondary state is CU_Idle.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Initializing.
   Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
   Rx Counts: 3 frames(total). 0 frames(data). 15 bytes.
 
Total Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
Total Rx Counts: 19 frames(total). 0 frames(data). 59 bytes.

kilcot#show bstun
This peer: 100.1.1.1
 
*Serial1/0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       200.2.2.2                 open         1       3        0

party#show bsc
BSC local-ack on Serial0:
primary state is TCU_Polled.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Inactive.
   Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
   Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
Total Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
Total Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
party#show bstun
This peer: 200.2.2.2
 
*Serial0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       100.1.1.1                 open          3       2        0

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

Salida el debug bstun packet/event y del bsc packet/del evento del debug se ha copiado al archivo del registro. Cuando usted interpreta esta salida de los debugs:

  • Datos en serie entrantes (SDI) — Paquetes recibidos de la interfaz del Synchronous Data Link Control (SDLC).

  • Datos de red entrantes (NDI) — Desencapsulado de los paquetes de WAN.

Nota: Antes de ejecutar un comando de depuración, consulte Información importante sobre comandos de depuración.

kilcot#show log
Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 0 messages logged
    Buffer logging: level debugging, 5088 messages logged
    Trap logging: level informational, 70 message lines logged
          
Log Buffer (100000 bytes):

Dec 28 09:43:21.748: BSC: Serial1/0: POLLEE-FSM event:  E_LineUp old_state: CU_Down.  new_state: CU_Idle.
Dec 28 09:43:21.756: BSC: Serial1/0: SDI-rx: Data (5 bytes):   40407F7F2D
Dec 28 09:43:36.756: BSTUN bsc-local-ack: Serial1/0 SDI:   Data:   401100
Dec 28 09:43:36.756: BSTUN: Change state for peer  (all[72])200.2.2.2/1976 (closed->opening)
Dec 28 09:43:36.756: BSC: Serial1/0: POLLEE-FSM  event: E_RxEnq 
Dec 28 09:43:36.760: BSTUN: Change state for peer   (all[72])200.2.2.2/1976 (opening->open wait)
Dec 28 09:43:36.764: %BSTUN-6-OPENING: CONN:  opening peer (all[72])200.2.2.2/1976, 3
Dec 28 09:43:36.792: bsttcpd_connect:  Refreshing tcp_encaps for group 72
Dec 28 09:43:36.792: %BSTUN-6-OPENED: CONN:  peer (all[72])200.2.2.2/1976 opened, [previous state open wait]
Dec 28 09:43:36.792: BSTUN: Change state for  peer (all[72])200.2.2.2/1976 (open wait->open)
Dec 28 09:43:36.844: BSTUN bsc-local-ack:  Serial1/0 NDI: Data:   401400
Dec 28 09:43:36.848: BSC: Serial1/0: NDI-rx:  Data (3 bytes):  401400
Dec 28 09:43:37.640: %SYS-5-CONFIG_I:  Configured from console by vty0

party#show log
Syslog logging: enabled (0 messages 
   dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 114 messages logged
        Logging to: vty2(114)
    Buffer logging: level debugging, 5199 messages logged
    Trap logging: level informational, 79 message lines logged
          
Log Buffer (100000 bytes):

ec 28 09:48:09.816: %BSTUN-6-PASSIVEOPEN:   passive open 100.1.1.1(11017) -> 1976
Dec 28 09:48:09.836: %BSTUN-6-OPENED: PHDR:  peer (all[72])100.1.1.1/1976 opened, [previous state closed]
Dec 28 09:48:09.836: BSTUN: Change state for  peer (all[72])100.1.1.1/1976 (closed->open)
Dec 28 09:48:09.836: BSTUN bsc-local-ack:  Serial0 NDI: Data:   401100
Dec 28 09:48:09.836: BSC: Serial0: NDI-rx:  Data (3 bytes):  401100
Dec 28 09:48:09.836: BSTUN bsc-local-ack:  Serial0 SDI: Data:   401400
Dec 28 09:48:09.836: BSC: Serial0: SDI-tx:  Data (10 bytes):  37FF32323240407F7F2D

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 12347