Tecnologías IBM : Data-Link Switching (DLSw) y Data-Link Switching Plus (DLSw+)

Ejemplo de la configuración de redundancia del Ethernet DLSw

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Esta configuración de muestra implementa la característica de redundancia Ethernet del software de Cisco IOS� en una red del Data-Link Switching (DLSw). También se incluyen en este documento las técnicas para hacer el debug de esta característica. La característica de redundancia de Ethernet se agregó a la versión 12.0(5)T del software IOS de Cisco.

Esta configuración de muestra muestra cómo implementar la característica de redundancia Ethernet y los comandos usados para monitorear el estatus de las conexiones. Se simulan tres escenarios en los cuales el error ocurre mientras que los comandos debug se están ejecutando para mostrar el comportamiento de cada router.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/12345/8-a.gif

Notas de configuración

  • Configuran al regulador A para establecer a dos sesiones de Control de los links lógicos (LLC) con el host; utiliza un valor del Punto de acceso del servicio local (LSAP) de 0x04 y de 0x08, respectivamente. El regulador B intenta establecer a solamente una sesión LLC, y el host utiliza un valor de LSAP de 0x04.

  • Para esta configuración de muestra, cuando ambos routeres DLSw están para arriba, el regulador A conecta con el host con el Avimimus del router, y el regulador B conecta con el host con el router Turbo. El Equilibrio de carga es realizado cuando ambo Routers es ascendente y trabajo correctamente.

  • Aquí están las direcciones MAC de los reguladores y de las configuraciones:

    • Regulador A

      smac = 0000.2222.0000 (cann), dmac = 0000.6666.0000 (cann)
      lsap = 0x04 and lsap = 0x08, dsap = 0x04 for both connections

      Para consulta, éstos son los valores de intercambio de bits de esta dirección MAC:

      smac = 0000.4444.0000 (non-cann), dmac = 0000.6666.0000 (non-cann)
    • Regulador B

      smac = 0000.1111.0000 (cann), dmac = 0000.7777.0000 (cann)
      lsap = 0x08, dsap = 0x04

      Para consulta, éstos son los valores de intercambio de bits de esta dirección MAC:

      smac = 0000.8888.0000 (non-cann), dmac = 0000.EEEE.0000 (non-can)
  • El host tiene esta dirección MAC:

    smac = 4000.3745.0000 (non-can) 
    lsap = 0x04

    Para consulta, éste es el valor de intercambio de bits de la dirección MAC del host:

    smac = 0200.eca2.0000 (cann)
    
  • El Avimimus se configura para ser el router DLSw principal, y Turbo se configura para ser el router DLSw auxiliar. Avimimus se asigna un valor de la prioridad baja para alcanzar esta configuración. El valor predeterminado es 100. Se enumeran aquí los comandos usados para especificar el valor de prioridad para cada router:

    • Avimimus — master-prioridad transparente 10 del Redundancia-permiso 9999.9999.9999 del dlsw

    • Turbo — Redundancia-permiso transparente 9999.9999.9999 del dlsw

    Ambo Routers debe ser configurado para utilizar el mismo Multicast MAC Address para la comunicación (9999.9999.9999).

  • El Avimimus tiene esta dirección MAC configurada:

    Ethernet 0:
    smac = 0000.3333.0000 (cann), 0000.CCCC.0000 (non-cann)
  • Turbo tiene esta dirección MAC configurada:

    Ethernet 0:
    smac = 0000.5555.0000 (cann), 0000.AAAA.0000 (non-cann)
  • El Avimimus se configura para hacer esta asignación de la dirección MAC:

    local mac: 0000.6666.0000 --> remote mac: 0200.ECA2.0000 (cann)

    Para consulta, éstos son los valores de intercambio de bits de esta dirección MAC:

    local mac: 0000.6666.0000 --> remote mac: 4000.3745.0000 (non-can)
  • Turbo se configura para hacer esta asignación de la dirección MAC:

    local mac: 0000.7777.0000 --> remote mac: 0200.ECA2.0000 (cann)

    Para consulta, éstos son los valores de intercambio de bits de la dirección MAC:

    local mac: 0000.EEEE.0000 --> remote mac: 4000.3745.0000 (non-can)
  • Se enumeran aquí los comandos de especificar la asignación de la dirección MAC en los routeres DLSw:

    • Avimimus — vecino transparente 0000.5555.0000 del MAC remoto 0200.eca2.0000 del local-mac 0000.6666.0000 de la correspondencia del dlsw

    • Turbo — vecino transparente 0000.3333.0000 del MAC remoto 0200.eca2.0000 del local-mac 0000.7777.0000 de la correspondencia del dlsw

    Nota: Todas las direcciones MAC configuradas en estos comandos deben estar en el formato canónico. El valor mac local representa el MAC de destino (DMAC) a las cuales las estaciones terminales de los Ethernetes señalan (0000.6666.0000 y 0000.7777.0000, en este caso). El valor mac remoto es la representación canónica del host remoto que usted intenta alcanzar con DLSw. El valor "vecino" representa la dirección MAC de la interfaz Ethernet del otro router redundante DLSw.

Configuraciones

En este documento, se utilizan estas configuraciones:

Router redundante DLSw principal
avimimus# show run
Building configuration...
!
hostname avimimus
! 
dlsw local-peer peer-id 1.1.1.1
dlsw remote-peer 0 tcp 3.3.3.1
dlsw transparent switch-support
!
!
interface Ethernet0
 mac-address 0000.3333.0000
 ip address 5.5.5.3 255.255.255.0
 no ip redirects
 no ip directed-broadcast
 media-type 10BaseT
 standby timers 3 10
 standby priority 150 preempt
 standby mac-address 0000.3333.3333
 standby ip 5.5.5.4
 dlsw transparent redundancy-enable 9999.9999.9999 master-priority 10

!--- This is the command used to specify the priority value of Avimimus.

 dlsw transparent map local-mac 0000.6666.0000 remote-mac 0200.eca2.0000 neighbor 0000.5555.0000

!--- This is the command used to specify the MAC address mapping at the DLSw router.

!
interface Serial0
 ip address 1.1.1.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
 clockrate 4000000
!
end

Router redundante DLSw esclavo
turbo# show run
Building configuration...
!
hostname turbo
!
dlsw local-peer peer-id 2.2.2.1
dlsw remote-peer 0 tcp 3.3.3.1
dlsw transparent switch-support
!
interface Ethernet0
 mac-address 0000.5555.0000
 ip address 5.5.5.1 255.255.255.0
 no ip redirects
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 standby timers 3 10
 standby priority 100
 standby mac-address 0000.3333.3333
 standby ip 5.5.5.4
dlsw transparent redundancy-enable 9999.9999.9999

!--- This is the command used to specify the priority value of Turbo.

dlsw transparent map local-mac 0000.7777.0000 remote-mac 0200.eca2.0000 neighbor 0000.3333.0000

!--- This is the command used to specify the MAC address mapping at the DLSw router.

!
interface Serial1
 ip address 2.2.2.1 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
end

Router DLSw de Token Ring
limno# show run 
!
hostname limno
!
source-bridge ring-group 100
!
dlsw local-peer peer-id 3.3.3.1
dlsw remote-peer 0 tcp 2.2.2.1
dlsw remote-peer 0 tcp 1.1.1.1
!
interface TokenRing0
 ring-speed 16
 source-bridge 10 1 100
 source-bridge spanning 
!
interface Serial0
 ip address 1.1.1.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!
interface Serial1
 ip address 2.2.2.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 clockrate 4000000
!
end

Verificación

En esta sección encontrará información que puede utilizar para comprobar que su configuración funcione correctamente. Toda la salida del comando show de esta configuración se presenta. Hay comentario con la salida de comando para ayudarle a localizar las secciones importantes.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Esta sección se divide en estas subdivisiones:

Salida del comando show dlsw circuits and show llc

En esta sección, se presenta la salida del comando show dlsw circuits and show llc.

Router redundante DLSw principal
avimimus# show dlsw circuits
Index     local addr(lsap)   remote addr(dsap)  state     uptime
738197594 0000.4444.0000(04) 4000.3745.0000(04) CONNECTED 3d02h
335544411 0000.4444.0000(08) 4000.3745.0000(04) CONNECTED 3d02h
Total number of circuits connected: 2 

Los circuitos DLSw se establecen entre la estación final MAC (0000.4444.0000) y el host MAC. En realidad, la estación final no está indicando 4000.3745.0000, pero el router está realizando la correspondencia de direcciones MAC especificada en el comando dlsw transparent map.

Router redundante DLSw principal
avimimus# show llc brief
LLC2 Connections: total of 3 connections
Et0 NORMAL 0000.aaaa.0000 0000.cccc.0000 94 94
Et0 NORMAL 0000.4444.0000 0000.6666.0000 04 04
Et0 NORMAL 0000.4444.0000 0000.6666.0000 04 08

Establecen a la primera sesión LLC entre los routeres redundantes del Ethernet DLSw usando un valor de SAP de 0x94. Las direcciones MAC para los routeres DLSw aparecen en el formato no canónico. Para más información, refiera a la sección de resultados del comando show dlsw transparent de este documento.

Las otras dos sesiones LLC se refieren cuando los dispositivos extremos comunican con la dirección MAC configurada en el router. Es decir, 0000.6666.0000 es el DMAC Address configurado en las estaciones terminales. Todas las sesiones LLC aparecen originar del interface ethernet 0 (Et0); sin embargo, las direcciones MAC enumeradas luego se visualizan en el formato no canónico. Se enumeran esta manera para consulta a los comandos show dlsw, que visualizan todas las direcciones MAC en el formato no canónico.

Router redundante DLSw principal
avimimus# show llc 
LLC2 Connections: total of 3 connections
Ethernet0 DTE: 0000.aaaa.0000 0000.cccc.0000 94 94 state NORMAL
V(S)=5, V(R)=7, Last N(R)=5, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 9480/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200


Ethernet0 DTE: 0000.4444.0000 0000.6666.0000 04 04 state NORMAL
V(S)=1, V(R)=1, Last N(R)=1, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 8920/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200


Ethernet0 DTE: 0000.4444.0000 0000.6666.0000 04 08 state NORMAL
V(S)=1, V(R)=1, Last N(R)=1, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 9100/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200

Router redundante DLSw esclavo
turbo# show dlsw circuits
Index      local addr(lsap)   remote addr(dsap)  state     uptime
2634022913 0000.8888.0000(08) 4000.3745.0000(04) CONNECTED 4d00h
Total number of circuits connected: 1


turbo# show llc brief
LLC2 Connections: total of 2 connections
Et0 NORMAL 0000.cccc.0000 0000.aaaa.0000 94 94
Et0 NORMAL 0000.8888.0000 0000.eeee.0000 04 08


turbo# show llc
LLC2 Connections: total of 2 connections
Ethernet0 DTE: 0000.cccc.0000 0000.aaaa.0000 94 94 state NORMAL
V(S)=7, V(R)=5, Last N(R)=7, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 7480/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200


Ethernet0 DTE: 0000.8888.0000 0000.eeee.0000 04 08 state NORMAL
V(S)=1, V(R)=1, Last N(R)=1, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 2410/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200

Salida del comando show dlsw transparent

En esta sección, se presenta la salida del comando show dlsw transparent.

Router redundante DLSw principal
avimimus# show dlsw transparent neighbor
Interface Ethernet0
0000.cccc.0000 SELF Master
0000.aaaa.0000 Rcvd Master-Accepted VALID

El comando show dlsw transparent neighbor visualiza a los vecinos DLSw en un dominio interligado de forma transparente. Todas las direcciones MAC enumeradas se muestran en el formato no canónico. Sin embargo, cuando usted configura el router vecino (con el comando dlsw transparent map), utilice el formato canónico. El Avimimus del router tiene la prioridad más baja y así que es el router principal.

Router redundante DLSw principal
avimimus# show dlsw transparent cache

Interface Ethernet0
Circuit Cache

local addr(lsap)   remote addr(dsap)  state    Owner
0000.4444.0000(04) 4000.3745.0000(04) POSITIVE SELF
0000.4444.0000(08) 4000.3745.0000(04) POSITIVE SELF
0000.8888.0000(08) 4000.3745.0000(04) NEGATIVE 0000.aaaa.0000
Total number of circuits in the Cache: 3

El comando show dlsw transparent cache visualiza el caché de circuito principal para el dominio de broadcast. Este router es consciente de la conexión que se establece en el segundo router; esto corresponde con la entrada marcada con un estado NEGATIVO.

Router redundante DLSw principal
avimimus# show dlsw transparent map 

Interface Ethernet0
LOCAL Mac      REMOTE MAC     BACKUP
---------      ----------     ------
0000.6666.0000 4000.3745.0000 0000.aaaa.0000 STATIC
0000.eeee.0000 4000.3745.0000 0000.aaaa.0000 DYNAMIC(Passive)

En la salida anterior, el router es consciente de la traducción especificada en su configuración (véase los PARÁSITOS ATMOSFÉRICOS marcados entrada) y también de la entrada que se configura en el segundo router (DINÁMICO marcado de la entrada). La dirección MAC LOCAL es la dirección MAC que deben usar las estaciones terminales como DMAC.

Luego, el router realiza la traducción a la dirección MAC que aparece bajo la columna REMOTE MAC. El MAC REMOTO debe hacer juego el MAC real del destino remoto al cual DLSw proporciona la Conectividad.

La segunda entrada está en un estado pasivo, así que significa que el segundo router está vivo y proporciona su propia traducción. En el caso de un error, el Avimimus asume el control esa responsabilidad.

Router redundante DLSw esclavo
turbo# show dlsw transparent neighbor 

Interface Ethernet0
0000.aaaa.0000 SELF      Slave
0000.cccc.0000 Connected MASTER.



turbo# show dlsw transparent cache 

Interface Ethernet0
Circuit Cache 

local addr(lsap)   remote addr(dsap)     state    Owner
0000.8888.0000(08) 4000.3745.0000(04)    POSITIVE SELF
Total number of circuits in the Cache: 1


turbo# show dlsw transparent map 

Interface Ethernet0
LOCAL Mac      REMOTE Mac     BACKUP
---------      ----------     ------
0000.eeee.0000 4000.3745.0000 0000.cccc.0000 STATIC
0000.6666.0000 4000.3745.0000 0000.cccc.0000 DYNAMIC(Passive)

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

Esta sección presenta toda la salida del comando debug desde esta configuración. El comentario se incluye con la salida de comando para ayudarle a localizar las secciones importantes.

Nota: Antes de publicar los comandos debug, refiera a la información importante en los comandos Debug.

Esta sección se divide en estas subdivisiones:

Resultado del comando debug dlsw transparent durante un error simulado del router principal

Esta sección presenta el resultado del comando debug dlsw transparent, que se genera durante las fallas simuladas del router principal.

  • debug dlsw transparent master — Mensajes del debug de las visualizaciones relacionados con los eventos de maestro-esclavo.

  • debug dlsw transparent circuits — Los mensajes del debug de las visualizaciones se relacionaron con el caché de circuito principal para el dominio interligado de forma transparente.

  • debug dlsw transparent address-map — Los mensajes del debug de las visualizaciones se relacionaron con las asignaciones de la dirección MAC en el router local y cualquier asignación para las cuales el router local actúe como respaldo para un par vecino.

Router redundante DLSw principal
avimimus# show debug
DLSw:
DLSw Ethernet Redundancy - Master debugging is on
DLSw Ethernet Redundancy - Circuits debugging is on
DLSw Ethernet Redundancy - Address Map debugging is on

Mar 5 18:07:10.039: DLSW-ER: Sending MP Frame
Mar 5 18:07:30.039: DLSW-ER: Sending MP Frame
Mar 5 18:07:40.039: DLSW-ER: Sending MP Frame
Mar 5 18:07:50.039: DLSW-ER: Sending MP Frame
Mar 5 18:08:00.047: DLSW-ER: Sending MP Frame
Mar 5 18:08:10.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:20.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:30.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:40.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:50.051: DLSW-ER: Sending MP Frame

El Router redundante DLSw principal envía una trama del master present (MP) cada 10 segundos.

Aquí, se introduce un incidente cuando se apaga la interfaz de Ethernet:

Router redundante DLSw principal
avimimus# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
avimimus(config)# interface ethernet0
avimimus(config-if)# shut


Mar 5 18:09:00.951: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Active -> Init
Mar 5 18:09:02.951: %LINK-5-CHANGED: Interface Ethernet0, changed state to administratively down
Mar 5 18:09:02.951: DLSW-ER:dm_action_b: LLC2 session dead freeing neighbor 0000.aaaa.0000
Mar 5 18:09:02.951: DLSW-ER:Sourcing a TestFrame 0000.6666.0000 --> 0000.aaaa.0000 on Ethernet0
Mar 5 18:09:02.951: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.aaaa.0000 on Ethernet0
Mar 5 18:09:02.971: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:09:02.979: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:09:03.951: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed 
 state to down

Aquí están los debugs tomados del router esclavo durante el error:

Router redundante DLSw esclavo
turbo#
Mar 5 18:09:10.251: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Standby -> Active
Mar 5 18:09:10.583: DLSW-ER:dm_action_r: LLC2 session dead to neighbor 0000.cccc.0000 
Mar 5 18:09:10.587: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:09:10.591: DLSW-ER:Sourcing a TestFrame 0000.6666.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:09:10.595: DLSW-ER: Sending MP Frame
Mar 5 18:09:10.595: DLSW-ER:dm_action_u: Freeing current master 0000.cccc.0000
Mar 5 18:09:10.599: DLSW-ER:dm_action_u: Changing state to Master
Mar 5 18:09:20.595: DLSW-ER: Sending MP Frame
Mar 5 18:09:30.595: DLSW-ER: Sending MP Frame

En la sintaxis anterior, Turbo se convierte en el router principal y también asume el control la traducción que fue configurada en el router Avimimus.

Aquí están los debugs en Turbo cuando las estaciones terminales que están conectadas con el reintento del Avimimus la conexión al host:

Router redundante DLSw esclavo
turbo#
Mar 5 18:09:40.595: DLSW-ER: Sending MP Frame
Mar 5 18:09:40.927: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:40.939: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:40.995: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:40.995: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:09:40.999: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:4

En la sintaxis anterior, usted ve que Turbo completa las traducciones necesarias (que fue poseído previamente por el Avimimus) para configurar a la primera sesión LLC del regulador A. Esta sesión utiliza LSAP 0x04 y RSAP 0x04.

Router redundante DLSw esclavo
Mar 5 18:09:41.963: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:41.975: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:41.979: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:09:41.983: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:8

En la sintaxis anterior, usted ve que Turbo completa las traducciones necesarias (que fue poseído previamente por el Avimimus) para configurar a la segunda sesión LLC del regulador A. Esta sesión utiliza el LSAP 0x08 y RSAP 0x04.

Router redundante DLSw esclavo
Mar 5 18:09:41.991: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:41.995: DLSW-ER:CSM->MS: C_INQ:PENDING: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:09:41.999: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:4

El primer circuito de DLSw ha sido establecido, indicado por la frase de UGotIt.

Router redundante DLSw esclavo
Mar 5 18:09:42.003: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000
Mar 5 18:09:42.971: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:42.975: DLSW-ER:CSM->MS: C_INQ:PENDING: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:09:42.983: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:8

Se completa el segundo circuito de DLSw.

Router redundante DLSw esclavo
Mar 5 18:09:42.987: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000
Mar 5 18:09:50.595: DLSW-ER: Sending MP Frame

Aquí están todos los comandos dlsw que indican que Turbo ha asumido el control el Avimimus y que los circuitos todos están conectados a través de Turbo:

Router redundante DLSw esclavo
turbo# show dlsw transparent cache
Interface Ethernet0
Circuit Cache
local addr(lsap)   remote addr(dsap)  state    Owner
0000.4444.0000(04) 4000.3745.0000(04) POSITIVE SELF
0000.4444.0000(08) 4000.3745.0000(04) POSITIVE SELF
0000.8888.0000(08) 4000.3745.0000(04) POSITIVE SELF
Total number of circuits in the Cache: 3

turbo# show dlsw transparent map 

Interface Ethernet0
LOCAL Mac      REMOTE Mac     BACKUP
---------      ----------     ------
0000.eeee.0000 4000.3745.0000 0000.cccc.0000 STATIC
0000.6666.0000 4000.3745.0000 0000.cccc.0000 DYNAMIC(Active)

En la sintaxis anterior, usted puede ver que el estatus de la segunda traducción ahora es DYNAMIC(Active), que indica que el Avimimus debe estar abajo.

Router redundante DLSw esclavo
turbo# show dlsw circuits
Index       local addr(lsap)    remote addr(dsap)   state     uptime
4009754676  0000.4444.0000(04) 4000.3745.0000(04) CONNECTED  00:01:05
1610612789  0000.4444.0000(08) 4000.3745.0000(04) CONNECTED  00:01:04
2634022913  0000.8888.0000(08) 4000.3745.0000(04) CONNECTED  4d01h
Total number of circuits connected: 3

Resultado del comando debug dlsw transparent durante la recuperación del router principal

Esta sección presenta el resultado del comando debug dlsw transparent que se genera durante la recuperación del router principal.

Router redundante DLSw principal
avimimus# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
avimimus(config)# interface ethernet0
avimimus(config-if)# no shut

Mar 5 18:12:00.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:03.127: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
Mar 5 18:12:03.595: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Listen -> Active
Mar 5 18:12:04.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed 
 state to up
Mar 5 18:12:10.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:10.599: DLSW-ER: New neighbor: master 0000.cccc.0000, neighbor 0000.aaaa.0000
Mar 5 18:12:10.599: DLSW-ER:dm_action_a: Rcvd MP with worse priority from 0000.aaaa.0000
Mar 5 18:12:10.607: DLSW-ER:dm_action_l: LLC2 up for neighbor 0000.aaaa.0000
Mar 5 18:12:10.607: DLSW-ER: Sending MC to 0000.aaaa.0000
Mar 5 18:12:10.615: DLSW-ER:dm_action_d: Received MA from neighbor 0000.aaaa.0000 

En la sintaxis anterior, el Avimimus ha recibido un mensaje del master accept (MA) de Turbo, que confirma que el Avimimus ahora es el nuevo master.

Aquí, el dos Routers intercambia BACKMEUP_REQ para las asignaciones para las cuales lo configuran. Cada petición se debe seguir por un ACK.

Router redundante DLSw esclavo
Mar 5 18:12:10.615: DLSW-ER: Sending BACKMEUP_REQ 0000.6666.0000 --> 4000.3745.0000 to 
 neighbor 0000.aaaa.0000 (617321C8)
Mar 5 18:12:10.615: DLSW-ER: Sending DN to 0000.aaaa.0000
Mar 5 18:12:10.623: DLSW-ER:Rcvd BACKMEUP_REQ from 0000.aaaa.0000 for map entry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.623: DLSW-ER: Sending BACKMEUP_ACK 0000.eeee.0000 --> 4000.3745.0000 to 
 neighbor 0000.aaaa.0000 (617321C8)
Mar 5 18:12:10.651: DLSW-ER:dm_action_f: Rcvd CO from 0000.aaaa.0000
Mar 5 18:12:10.667: DLSW-ER:Rcvd BACKMEUP_REQ from 0000.aaaa.0000 for mapentry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.667: DLSW-ER: Sending BACKMEUP_ACK 0000.eeee.0000 --> 4000.3745.0000 to 
 neighbor 0000.aaaa.0000 (617321C8)
Mar 5 18:12:19.731: DLSW-ER:dm_action_h: Rcvd CG <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:19.735: DLSW-ER:dm_action_h: Rcvd CG <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:20.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:20.647: DLSW-ER:Rcvd BACKMEUP_ACK from 0000.aaaa.0000 for mapentry 0000.6666.0000 
 --> 4000.3745.0000
Mar 5 18:12:20.647: DLSW-ER:Sourcing a TestFrame 0000.6666.0000 --> 0000.aaaa.0000 on Ethernet0
Mar 5 18:12:30.087: DLSW-ER: Sending MP Frame

Aquí están los debugs tomados de Turbo cuando sube el Avimimus del router principal:

Router redundante DLSw esclavo
turbo#
Mar 5 18:12:00.595: DLSW-ER: Sending MP Frame
Mar 5 18:12:03.603: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Active -> Speak
Mar 5 18:12:10.087: DLSW-ER: New neighbor: master 0000.aaaa.0000, neighbor 0000.cccc.0000
Mar 5 18:12:10.091: DLSW-ER:dm_action_o: Rcvd MP with better priority: 0000.cccc.0000
Mar 5 18:12:10.595: DLSW-ER: Sending MP Frame
Mar 5 18:12:10.611: DLSW-ER:dm_action_l: LLC2 up for neighbor 0000.cccc.0000
Mar 5 18:12:10.611: DLSW-ER: Sending MA to 0000.cccc.0000

Turbo reconoce el mensaje del Avimimus, y entonces Turbo se convierte en el esclavo.

Router redundante DLSw esclavo
Mar 5 18:12:10.615: DLSW-ER: Sending BACKMEUP_REQ 0000.eeee.0000 --> 4000.3745.0000 
 to neighbor 0000.cccc.0000 (45B47C)
Mar 5 18:12:10.623: DLSW-ER:dm_action_c: Rcvd MC with better priority from 0000.cccc.0000
Mar 5 18:12:10.627: DLSW-ER:dm_action_c: Changing state: Master to Slave

Turbo se convierte en el router esclavo.

Router redundante DLSw esclavo
Mar 5 18:12:10.627: DLSW-ER:Rcvd BACKMEUP_REQ from 0000.cccc.0000 for mapentry 0000.6666.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.635: DLSW-ER:calling admin_stop for ckt(0000.4444.0000(4) 4000.3745.0000(4)) with 
 lmac 0000.6666.0000
Mar 5 18:12:10.643: DLSW-ER:calling admin_stop for ckt(0000.4444.0000(8) 4000.3745.0000(4)) with 
 lmac 0000.6666.0000

En la sintaxis anterior, Turbo termina los circuitos de DLSw que se deben poseer por el Avimimus. (Los circuitos deben ser derribados cuando viene el master salvaguardia.) Esta terminación sucede después de que Turbo reciba BACKMEUP_REQ del Avimimus.

Router redundante DLSw esclavo
Mar 5 18:12:10.643: DLSW-ER: dm_action_n: Rcvd DN frame from 0000.cccc.0000
Mar 5 18:12:10.647: DLSW-ER:Sending CO frame # 0 to 0000.cccc.0000
Mar 5 18:12:10.651: DLSW-ER:Rcvd BACKMEUP_ACK from 0000.cccc.0000 for mapentry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.655: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:12:10.659: DLSW-ER:dm_action_s: LLC2 session up to neighbor 0000.cccc.0000
Mar 5 18:12:10.659: DLSW-ER: Sending BACKMEUP_REQ 0000.eeee.0000 --> 4000.3745.0000 
 to neighbor 0000.cccc.0000 (45B47C)
Mar 5 18:12:10.671: DLSW-ER:Rcvd BACKMEUP_ACK from 0000.cccc.0000 for mapentry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.675: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:12:13.603: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Speak -> Standby
Mar 5 18:12:19.723: DLSW-ER:CG -> 0000.cccc.0000: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:19.727: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:19.731: DLSW-ER:CG -> 0000.cccc.0000: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:19.735: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:20.643: DLSW-ER: Sending BACKMEUP_ACK 0000.6666.0000 --> 4000.3745.0000 
 to neighbor 0000.cccc.0000 (45B47C)

turbo# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
2634022913  0000.8888.0000(08)   4000.3745.0000(04) CONNECTED  4d01h
Total number of circuits connected: 1

Se presentan en el sintaxis aquí los debugs que ocurren cuando las estaciones terminales intentan restablecer la conexión. El Avimimus es de reserva servir como el router principal.

Router redundante DLSw principal
avimimus#
Mar 5 18:12:40.071: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:40.071: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:40.079: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:40.079: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:40.079: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:40.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:41.071: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:41.075: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:41.075: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:41.075: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:41.079: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:41.079: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000
Mar 5 18:12:42.075: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:42.075: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000


avimimus# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
3070230625  0000.4444.0000(04)  4000.3745.0000(04) CONNECTED  00:00:08
4194304098  0000.4444.0000(08)  4000.3745.0000(04) CONNECTED  00:00:08
Total number of circuits connected: 2

Salida del comando debug dlsw transparent durante el establecimiento de circuito del router esclavo DLSw

Esta sección presenta el comando debug dlsw transparent hecho salir se genera que cuando el router esclavo intenta sacar a colación un circuito de DLSw.

Es útil examinar la comunicación entre el esclavo y el master antes de que el esclavo reciba el permiso para validar el circuito.

Se simula el escenario cuando el circuito existente de DLSw se borra en el router esclavo.

Router redundante DLSw esclavo
turbo# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
2634022913  0000.8888.0000(08)  4000.3745.0000(04) CONNECTED   4d02h
Total number of circuits connected: 1


turbo# clear dlsw circuits 2634022913
turbo#
Mar 5 20:02:37.426: DLSW-ER:CG -> 0000.cccc.0000: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:02:37.430: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.8888.0000:8 

Turbo dice el router principal borrar su entrada de caché para el circuito apenas-borrado.

Router redundante DLSw esclavo
Mar 5 20:03:07.398: DLSW-ER:Replacing dmac 0000.eeee.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 20:03:07.462: DLSW-ER:Replacing dmac 0000.eeee.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 20:03:07.466: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:07.470: DLSW-ER:IW -> 0000.cccc.0000: 4000.3745.0000:4 0000.8888.0000:8

Turbo recibe un pedido entrante del dispositivo extremo de conectar al final el host. En 20:03:07.470, Turbo notifica el router principal de esta petición.

Router redundante DLSw esclavo
Mar 5 20:03:07.474: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.458: DLSW-ER:Replacing dmac 0000.eeee.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 20:03:08.462: DLSW-ER:CSM->MS: C_INQ:PENDING: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.474: DLSW-ER:dm_action_k: Rcvd UG for 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.478: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.eeee.0000

Turbo consigue un UG de su master, y se saca a colación el circuito.

Router redundante DLSw esclavo
turbo# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
385876023   0000.8888.0000(08)  4000.3745.0000(04) CONNECTED  00:00:33
Total number of circuits connected: 1

Aquí están los datos tomados en el router principal cuando el esclavo intenta sacar a colación el circuito.

Router redundante DLSw principal
avimimus# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
3070230625  0000.4444.0000(04)  4000.3745.0000(04) CONNECTED  01:49:13
4194304098  0000.4444.0000(08)  4000.3745.0000(04) CONNECTED  01:49:13
Total number of circuits connected: 2


avimimus# show dlsw transparent cache
Interface Ethernet0
Circuit Cache

local addr(lsap)        remote addr(dsap)     state     Owner
0000.4444.0000(04)     4000.3745.0000(04)   POSITIVE    SELF
0000.4444.0000(08)     4000.3745.0000(04)   POSITIVE    SELF
0000.8888.0000(08)     4000.3745.0000(04)   NEGATIVE    0000.aaaa.0000
Total number of circuits in the Cache: 3

Mar 5 20:02:37.433: DLSW-ER:dm_action_h: Rcvd CG <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:02:41.409: DLSW-ER: Sending MP Frame
Mar 5 20:02:51.409: DLSW-ER: Sending MP Frame
Mar 5 20:03:01.417: DLSW-ER: Sending MP Frame
Mar 5 20:03:07.473: DLSW-ER:dm_action_j: Rcvd IW <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.473: DLSW-ER:UG -> 0000.aaaa.0000: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:11.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:21.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:31.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:41.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:51.421: DLSW-ER: Sending MP Frame
avimimus#un all

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 12345