IP : Túnel serial (STUN)

Ejemplo de la configuración de encapsulación directa de STUN

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra para la encapsulación directa del Serial Tunnel (STUN). Muestran en el verificar y resuelven problemas los estados pertinentes en la salida y los cambios de estado del comando show stun en el resultado del comando de debug las secciones de este documento.

Aunque los comandos debug stun packet y debug stun event no deban causar la utilización excesiva de la CPU, utilizan al comando logging buffered de copiar la salida al archivo del registro.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información en este documento se basa en el Software Release 12.0(8) del ½ del ¿Â de Cisco IOSï con las características de IBM para la configuración STUN.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/12277/19_a.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Cloclo
cloclo# show run

Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cloclo
!
boot system flash rsp-jsv-mz.120-8
logging buffered 64000 debugging
no logging console
enable password cisco
!
microcode CIP flash slot0:cip27-3
microcode reload
ip subnet-zero
no ip domain-lookup
ip cef
!
!
stun peer-name 10.10.10.10
stun protocol-group 2 sdlc
!
!
!
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.0
 no ip directed-broadcast
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 encapsulation stun
 no ip mroute-cache
 clockrate 9600
 stun group 2
 stun route address 1 interface Serial0/1
!
interface Serial0/1
 ip address 10.2.1.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
!

!--- Output suppressed.

!
interface Ethernet1/0
 ip address 10.1.1.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!

!--- Output suppressed.

!
router eigrp 100
 network 10.0.0.0
!
ip classless
!
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end
cloclo#

Fairbanks
fairbanks# show run

Building configuration...
Current configuration:
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname fairbanks
!
boot system flash
 logging buffered 64000 debugging
no logging console
enable password cisco
!
ip subnet-zero
!
!
stun peer-name 10.20.20.20
stun protocol-group 2 sdlc
!
!
!
!
interface Loopback0
 ip address 10.20.20.20 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 10.1.1.2 255.255.255.0
 no ip directed-broadcast
 shutdown
 media-type 10BaseT
!
interface Ethernet1
 ip address 172.17.240.12 255.255.255.0
 no ip directed-broadcast
 shutdown
 media-type 10BaseT
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation stun
 no ip mroute-cache
 clockrate 9600
 stun group 2
 stun route address 1 interface Serial2
!

!--- Output suppressed.

!
interface Serial2
 ip address 10.2.1.2 255.255.255.0
 no ip directed-broadcast
 clockrate 19200
!

!--- Output suppressed.

!
router eigrp 100
 network 10.0.0.0
!
ip classless
!
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
end
fairbanks#

Verificación

Esta sección proporciona la información que usted puede utilizar para confirmar que su configuración está trabajando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Muestran el comando show stun hecho salir para ambo Routers en esta sección. Muestra que el estado del ATURDIR de cada router está abierto. También, los contadores para los paquetes recibidos (rx_pkts) y para los paquetes transmitidos (tx_pkts) incrementan cada vez que usted publica el comando show stun.

cloclo# show stun

This peer: 10.10.10.10
  *Serial0/0  (group 2 [sdlc])
                             state       rx_pkts   tx_pkts     drops    poll
1     IF  Serial0/1        open             4510      4513         0
fairbanks# show stun

This peer: 10.20.20.20
  *Serial0  (group 2 [sdlc])
                             state       rx_pkts   tx_pkts     drops    poll
1     IF  Serial2          open             2260      2257         0

fairbanks# show stun

This peer: 10.20.20.20
  *Serial0  (group 2 [sdlc])
                             state       rx_pkts   tx_pkts     drops    poll
1     IF  Serial2          open             2270      2267         0

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de la configuración.

Comandos para resolución de problemas

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de ejecutar un comando de depuración, consulte Información importante sobre comandos de depuración.

  • debug stun packet — Visualiza la información sobre los paquetes que viajan a través de los links del ATURDIR.

  • debug stun event — Conexiones STUN y actividad de las visualizaciones.

Capturas del debug durante la Activación STUN

cloclo# show log

Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 0 messages logged
    Buffer logging: level debugging, 232 messages logged
    Trap logging: level informational, 43 message lines logged

Log Buffer (64000 bytes):

!--- These timestamped lines each appear on one line in normal output:

*Nov  3 11:35:06.191: %LINK-3-UPDOWN:
  Interface Serial0/1, changed state to up
*Nov  3 11:35:07.191: %LINEPROTO-5-UPDOWN:
  Line protocol on Interface Serial0/1, changed state to up
*Nov  3 11:35:31.819: %LINK-3-UPDOWN:
  Interface Serial0/0, changed state to up
*Nov  3 11:35:32.819: %LINEPROTO-5-UPDOWN:
  Line protocol on Interface Serial0/0, changed state to up
*Nov  3 11:35:36.631: STUN sdlc:
  00:04:12 Serial0/0       SDI: (001/008) U: SNRM    PF:1  
*Nov  3 11:35:37.831: STUN sdlc:
  00:00:01 Serial0/0       SDI: (001/008) U: SNRM    PF:1  
*Nov  3 11:35:37.859: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) U: UA      PF:1  
*Nov  3 11:35:37.879: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 11:35:37.907: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 11:35:38.031: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 11:35:38.059: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 11:35:38.091: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) I:         PF:0  NR:000  NS:000
*Nov  3 11:35:38.231: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 11:35:38.295: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) I:         PF:1  NR:001  NS:000
*Nov  3 11:35:38.431: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 11:35:38.459: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 11:35:38.555: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) I:         PF:0  NR:001  NS:001
*Nov  3 11:35:38.631: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 11:35:38.691: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) I:         PF:1  NR:002  NS:001
*Nov  3 11:35:38.831: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:38.859: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.031: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.059: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.231: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.259: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.431: STUN sdlc:
  00:00:00 Serial0/0       SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 11:35:39.563: STUN sdlc:
  00:00:00 Serial0/0       NDI: (001/008) S: RR      PF:1  NR:002  

cloclo#
fairbanks# show log

Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 0 messages logged
    Buffer logging: level debugging, 203 messages logged
    Trap logging: level informational, 40 message lines logged

Log Buffer (64000 bytes):

!--- These timestamped lines each appear on one line in normal output:

*Nov  3 09:38:12.759: %SYS-5-CONFIG_I:
  Configured from console by console
*Nov  3 09:38:14.231: %LINK-3-UPDOWN:
  Interface Serial2, changed state to up
*Nov  3 09:38:15.231: %LINEPROTO-5-UPDOWN:
  Line protocol on Interface Serial2, changed state to up
*Nov  3 09:38:44.687: STUN sdlc:
  00:04:41 Serial0         NDI: (001/008) U: SNRM    PF:1  
*Nov  3 09:38:45.887: STUN sdlc:
  00:00:01 Serial0         NDI: (001/008) U: SNRM    PF:1  @
*Nov  3 09:38:45.899: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) U: UA      PF:1  
*Nov  3 09:38:45.935: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 09:38:45.947: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 09:38:46.087: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 09:38:46.099: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 09:38:46.155: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) I:         PF:0  NR:000  NS:000
*Nov  3 09:38:46.287: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:000  
*Nov  3 09:38:46.323: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) I:         PF:1  NR:001  NS:000
*Nov  3 09:38:46.487: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 09:38:46.499: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 09:38:46.615: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) I:         PF:0  NR:001  NS:001
*Nov  3 09:38:46.687: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:001  
*Nov  3 09:38:46.719: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) I:         PF:1  NR:002  NS:001
*Nov  3 09:38:46.887: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 09:38:46.899: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 09:38:47.087: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 09:38:47.099: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 09:38:47.287: STUN sdlc:
  00:00:00 Serial0         NDI: (001/008) S: RR      PF:1  NR:002  
*Nov  3 09:38:47.299: STUN sdlc:
  00:00:00 Serial0         SDI: (001/008) S: RR      PF:1  NR:002  
 
fairbanks#

Información Relacionada


Document ID: 12277