Módulos e interfaces de Cisco : Procesadores de interfaz de canal Cisco

Ejecución de OROUTED para el Intercambio de Actualizaciones de RIP Routing

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento da un ejemplo de la configuración requerida en el router y en la unidad central para intercambiar las actualizaciones de RIP Routing con el uso del procedimiento OROUTED. El OROUTED es un procedimiento que se ejecuta en la unidad central y que realiza esencialmente la misma función que cuando usted ejecuta la daemon RUTEADA en un host UNIX. Funcionamientos OROUTED del espacio de la dirección de OpenEdition/del almacenamiento virtual múltiple (OMVS) o como tarea comenzada.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Esta configuración fue desarrollada y probada con estas versiones de software y hardware:

  • Software Release 12.1(2) del½ del¿Â del Cisco IOSï con el microcódigo xcpa27-7 del adaptador de puerto del canal del sistema central (XCPA).

    Ésta era la última versión del código liberada en ese entonces, pero estas características se deben soportar en todas las versiones importantes actualmente mantenidas del código.

  • El router es un Cisco 7206 con un PCPA (adaptador de puerto del canal paralelo).

El OROUTED requiere estos dos archivos de configuración en la unidad central en el espacio de dirección OMVS, con las variables de entorno que señalan a su ubicación:

  • exportación ROUTED_PROFILE=/etc/orouted.profile

  • exportación RESOLVER_CONF=/etc/resolv.conf

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Antecedentes

Para comenzar el OROUTED, publique estos comandos dentro del OMVS:

cd /usr/lpp/tcpip/sbin

orouted

En la consola MVS, usted puede publicar este comando para encontrar el número de proceso del proceso OROUTED:

d omvs,u=p390

Nota:  p390 es la identificación del inicio bajo la cual el OROUTED fue comenzado.

Usted puede también comenzar el proceso OROUTED con el lenguaje de control de tareas (JCL), como una tarea comenzada. Si usted la comienza del OMVS, cambie el puerto 520 en el grupo de datos del perfil TCP/IP al OMVS.

Éstos son ejemplos de los grupos de datos:

/etc/orouted.profile
RIP_SUPPLY_CONTROL: RIP1
RIP_RECEIVE_CONTROL: ANY
RIP2_AUTHENTICATION_KEY:
/etc/resolv.conf
TCPIPJobName TCPIP
DomainOrigin cisco.com
domain cisco.com
Datasetprefix TCPIP
HostName P390
Messagecase mixed

TCP/IP profile dataset configuration changes
--------------------------------------------

; ----------------------------------------------------------------------- ;

;
orouted Routing Information
;
; if you are using orouted, comment out the GATEWAY statement and
; update the BSDROUTINGPARMS statement to reflect your installation
; configuration and remove the semicolon
;
;    Link     Maxmtu   Metric   Subnet Mask      Dest Addr
BSDROUTINGPARMS false
LDIPTG         1500       0     255.255.255.240  10.64.3.33
VIPALINK       1500       0     255.255.255.240  0
ENDBSDROUTINGPARMS
; -----------------------------------------------------------------------
RIP

Configuración

Router del Procesador de interfaz de canal (CIP)
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname diplodocus
!
boot system flash slot1:c7200-a3js-mz.121-2.bin
!
!
!
!
!
microcode pcpa slot1:xcpa27-9
microcode reload
!
interface Channel2/0
ip address 10.64.3.33 255.255.255.240
no keepalive
csna 0100 41
csna 0100 42
cmpc 0100 24 DIPTG READ
cmpc 0100 25 DIPTG WRITE
lan TokenRing 0
source-bridge 4 1 1
adapter 0 4000.0000.0001
adapter 1 4000.0000.0002
adapter 2 4000.0000.0003
adapter 3 4000.0000.0004
adapter 4 4000.0000.0005
lan TokenRing 1
source-bridge 5 1 1
adapter 7 4000.0000.0001
tn3270-server
pu PU1	    01712444 10.64.3.35      token-adapter 1  04 rmac
4000.0000.0001   lu-seed DIPL###
pu PU2	    01712555 10.64.3.36      token-adapter 1  08 rmac
4000.0000.0001   lu-seed DIPL2##
tg DIPTG    ip 10.64.3.34 10.64.3.33 broadcast
!
!
router eigrp 1
redistribute rip
passive-interface Channel2/0
network 10.0.0.0
passive-interface Ethernet6/1
passive-interface Ethernet6/3
network 10.0.0.0
!
no auto-summary
!
router rip
redistribute eigrp 1
passive-interface Serial1/3
  
 passive-interface TokenRing5/0


Información Relacionada


Document ID: 12258