Módulos e interfaces de Cisco : Procesadores de interfaz de canal Cisco

Configuración de OMPROUTE para ejecutarse en el sistema central

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento delinea el host de ejemplo y las configuraciones del router para funcionar con el procedimiento OMPROUTE en la unidad central para intercambiar las actualizaciones de ruteo por el resto de la red TCP/IP. El OMPROUTE es de uso frecuente, como en este ejemplo, conjuntamente con una dirección IP virtual (VIPA), que permite la dirección IP de la unidad central configurada en los clientes para ser independiente de cualquier una interfaz de canal. Esto proporciona la Redundancia para el canal. Originalmente, la implementación de la unidad central TCP/IP de IBM soportó solamente el Routing Information Protocol (RIP) como Routing Protocol, con el uso del procedimiento OROUTED. El OMPROUTE más nuevo soporta el RIP V1 o V2 y Open Shortest Path First (OSPF). IBM recomienda que el OMPROUTE esté utilizado bastante que el OROUTED, y IBM quitará eventual el soporte para el OROUTED.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La versión de software del ½ del ¿Â de Cisco IOSï que fue utilizada para esta configuración era 12.1(3a)T2 con el microcódigo xCPA 27-9, que era el más último en ese entonces esto fue probada. Si usted está utilizando la GARRA, sin embargo, ésta debe trabajar con cualquier versión del Cisco IOS Software. El uso del CMPC+ requiere un mínimo de Cisco IOS Software Release 12.1T.

El router era un Cisco 7206 con un adaptador de puerto xCPA. Alternativamente, un Cisco 7500 Router con una placa CIP podría ser utilizado con los cambios menores en la configuración, según lo observado más adelante en este documento.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Configuraciones

Configuración del sistema central - archivos OMPROUTE

La configuración del OMPROUTE en la unidad central es muy similar a la configuración del OROUTED. El OMPROUTE también utiliza un mínimo de dos archivos de configuración. Usted debe señalar a la ubicación de estos archivos de configuración, en el espacio de dirección OMVS, con estas dos variables de entorno:

  • exportación resolver_conf=/etc/resolv.conf

  • exportación omproute_file=/etc/omproute.conf

Éste es un ejemplo del contenido del resolver_conf:

TCPJobName TCPIP
DomainOrigin cisco.com
domain cisco.com
Datasetprefix TCPIP
HostName P390
Messagecase mixed

El omproute_file dependerá encendido si se está utilizando el RIP o el OSPF. Esto es un ejemplo de configuración para el RIP:

;
Originate_RIP_Default Condition=Always Cost=1
;
RIP_Interface IP_Address=10.64.3.34
Name=LDIPTG
Subnet_Mask=255.255.255.240
Receive_Dynamic_Nets=YES
Receive_Dynamic_Subnets=YES
MTU=1470
Destination_Addr=10.64.3.33
;
RIP_Interface IP_Address=10.64.3.17
Name=VIPALINK
Subnet_Mask=255.255.255.240
MTU=1470
;

Para el OSPF, hay más opciones de configuración disponibles, que incluyen la capacidad de hacer que la unidad central actúa como zona fragmentada. Esto puede reducir perceptiblemente las actualizaciones de ruteo de la carga que se ponen en el canal cuando muchas divisiones lógicas (LPAR) están conectando sobre el mismo canal. Aquí tiene un ejemplo:

Area Area_Number=0.0.0.0 Authentication_Type=None Stub_Area=NO
;
Comparison=Type2
;
AS_Boundary_Routing Import_Subnet_Routes=YES
Import_Direct_Routes=YES
;
OSPF_Interface IP_Address=10.64.3.34
Name=LDIPTG
Subnet_Mask=255.255.255.240
Attaches_To_Area=0.0.0.0
MTU=1470
Destination_Addr=10.64.3.33
Hello_Interval=30
Dead_Router_Interval=120
;
OSPF_Interface IP_Address=10.64.3.17
Name=VIPALINK
Subnet_Mask=255.255.255.240

Configuración del sistema central - Pila de TCP/IP

El grupo de datos del perfil TCP/IP no requiere ninguna configuración especial para el OMPROUTE, con excepción del hecho de que usted deba comentar hacia fuera toda la configuración y la sección BSDROUTINGPARMS (que de los parásitos atmosféricos y de la ruta predeterminado es utilizada solamente por el OROUTED). Este extracto muestra solamente qué debe ser comentada hacia fuera y los parámetros a los cuales los archivos de configuración OMPROUTE se refieren:

TCPIP Profile dataset
---------------------
 -----------------------------------------------------------------------
; Hardware definitions:
 -----------------------------------------------------------------------
; NOTE: To use these device and link statements, update the statements
; to reflect your installation configuration and remove the semicolon
;
DEVICE DIPTG MPCPTP
LINK LDIPTG MPCPTP DIPTG
DEVICE VIPADEV VIRTUAL 0
LINK VIPALINK VIRTUAL 0 VIPADEV
;
;
; -----------------------------------------------------------------------
;
; HOME Internet (IP) addresses of each link in the host.
;
; NOTE: To use this home statement, update the ipaddress and linknames 
; to reflect your installation configuration and remove the semicolon
;
HOME
10.64.3.17    VIPALINK
10.64.3.34    LDIPTG
; -----------------------------------------------------------------------
;
; IP routing information for the host.	All static IP routes should
; be added here.
;
; NOTE: To use this GATEWAY statement, update the addresses and links
; to reflect your installation configuration and remove the semicolon
;
; GATEWAY
;
; Direct Routes - Routes that are directly connected to my interfaces.
;
; Network  First Hop  Link Name Packet Size  Subnet Mask  Subnet Value
; 10           =       CIS1      1500       0.255.255.0    0.101.1
; 10           =       LDIPTG    1500       0.255.255.240  0.64.3.32
; 9            =       LIS1      1500       0.255.255.0    0.117.56.0
; 130.50       =       TR1       2000       0.0.255.0      0.0.10.0
; 193.5.2      =       ETH1      1500       0
; 9            =       FDDI1     4000       0.255.255.0    0.67.43.0
; 193.7.2.2    =       SNA1      2000       HOST
;
; Indirect Routes - Routes that are reachable through routers on my
;		    network.
;
; Network     First Hop   Link Name Packet Size  Subnet Mask  Subnet Value
; DEFAULTNET  10.64.3.33  LDIPTG    DEFAULTSIZE  0
; 193.12.2    130.50.10.1 TR1       2000         0
; 10.5.6.4    193.5.2.10  ETH1      1500         HOST
;
; Default Route - All packets to an unknown destination are routed
;		  through this route.
;
; Network     First Hop   Link Name Packet Size  Subnet Mask  Subnet Value
; DEFAULTNET  9.67.43.1   FDDI1     DEFAULTSIZE  0
;
; -----------------------------------------------------------------------
;
; orouted Routing Information
;
; if you are using orouted, comment out the GATEWAY statement and
; update the BSDROUTINGPARMS statement to reflect your installation
; configuration and remove the semicolon
;
;    Link     Maxmtu   Metric   Subnet Mask     Dest Addr
; BSDROUTINGPARMS false
; LDIPTG       1500       0     255.255.255.240 10.64.3.33
; VIPALINK     1500       0     255.255.255.240 0
;    TR1       2000       0     255.255.255.0   0
;    ETH1      1500       0     255.255.255.0   0
;    FDDI1  DEFAULTSIZE   0     255.255.255.0   0
; ENDBSDROUTINGPARMS

!--- Note that all of the last two sections have been commented out.

Configuración del sistema central - TCP/IP de las definiciones de VTAM y el comenzar

Las actualizaciones de ruteo se pueden intercambiar sobre las conexiones de la GARRA o CMPC+. Si usted está utilizando la GARRA, no se requiere ninguna configuración adicional en la unidad central. Este ejemplo utiliza CMPC, que requiere una entrada del Transport Resource List VTAM (TRL). Éste es el miembro VTAM:

DIPTGTRL VBUILD TYPE=TRL
*
*
DIPTG	 TRLE  LNCTL=MPC,MAXBFRU=16,READ=(E24),WRITE=(E25)
*

Se comienza El TRL se debe activar antes de la tarea comenzada TCPIP. Por ejemplo:

V NET,ACT,ID=DIPTRL1,UPDATE=ALL
IST097I VARY ACCEPTED
ISTTRL ACTIVE

Entonces, active la tarea comenzada TCP/IP con el comando console S TCPIP MVS. Una vez que la tarea comenzada TCP/IP se está ejecutando, el procedimiento OMPROUTE se puede comenzar, cualquiera con el uso del lenguaje de control de tareas (JCL) como tarea comenzada o dentro del espacio de dirección OMVS. Para comenzar dentro del OMVS, publique estos comandos:

cd /usr/lpp/tcpip/sbin

omproute &

Para marcar que el OMPROUTE se está ejecutando, publique este comando console, donde está la identificación del usuario p390 bajo la cual comenzaron a la demon OMPROUTE:

d omvs,u=p390

Configuración del router

La GARRA y CMPC se deben configurar específicamente para enviar los broadcasts sobre el canal, con la palabra clave del broadcast. Por ejemplo, para la GARRA:

claw 0100 20 10.101.1.10 P390D C7000D TCPIP TCPIP broadcast

En este ejemplo, el CMPC+ es funcionando, así que éstas son las partes pertinentes de la configuración del router:

!
interface Channel2/0
 ip address 10.64.3.33 255.255.255.240
 ip ospf network point-to-multipoint
 no keepalive
 cmpc 0100 24 DIPTG READ
 cmpc 0100 25 DIPTG WRITE
 tg DIPTG    ip 10.64.3.34 10.64.3.33 broadcast
 router ospf 1
  network 10.0.0.0 0.255.255.255 area 0
!

Si esto hubiera sido un Cisco 7500 Router con una placa CIP en vez de 7200 con un adaptador de puerto xCPA, la declaración tg habría sido configurada bajo interfaz virtual de /2. Observe el comando ip ospf network point-to-multipoint, que se requiere para que funcione el OSPF correctamente. La interfaz de canal se considera una interfaz multipunto como el Frame Relay. Si usted no desea ejecutar el OSPF en su red, usted puede ejecutarla solamente en la interfaz de canal sí mismo y utilizar la redistribución entre otros Routing Protocol. Por ejemplo:

!
router eigrp 1
 redistribute ospf 1
 passive-interface Channel2/0
 network 10.0.0.0
 no eigrp log-neighbor-changes
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 1
 network 10.64.3.33 0.0.0.0 area 0
!

Visualizaciones en el router

diplodocus# show extended channel 2/0 status

Path: 0100  -- ESTABLISHED
       Command    Selective   System     Device    CU
Dev    Connects    Retries    Cancels    Reset    Reset    Errors    Busy
24        30         21          1         0        0        0        0
25        29         0           1         0        0        0        0
Blocks         Bytes         Dropped Blk         Memd
Dev-Lnk    Read    Write    Read    Write    Read    Write    wait    Con
24-00       29       6      3484     789      0        0       0       Y
25-00        9      29       801    3920      0        0       0       Y
Path 0100
Total:      38      35      4285    4709      0        0       0
Last statistics 0 seconds old, next in 10 seconds

diplodocus# show extended channel 2/0 cmpc

Path    Dv    TGName    Dir    Bfrs     Status
CMPC   0100     24     DIPTG  READ  16  Active+
CMPC   0100     25     DIPTG  WRITE 16  Active+

diplodocus# show ip ospf i

Channel2/0 is up, line protocol is up
Internet Address 10.64.3.33/28, Area 0
Process ID 1, Router ID 200.100.100.9, Network Type POINT_TO_MULTIPOINT,
Cost: 4
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:10
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.64.3.17
Suppress hello for 0 neighbor(s)

diplodocus# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address       Interface
10.64.3.17       1    FULL/  -        00:01:35
Neighbor is up for 00:04:01           10.64.3.34  Channel2/0

diplodocus# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 10.64.3.1 to network 0.0.0.0
1.0.0.0/27 is subnetted, 1 subnets
C	1.1.1.0 is directly connected, Loopback1
200.100.100.0/29 is subnetted, 1 subnets
C	200.100.100.8 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D	10.0.0.0/8 is a summary, 00:06:40, Null0
C	10.64.3.0/28 is directly connected, Ethernet6/0
O E2	10.64.3.17/32 [110/1] via 10.64.3.34, 00:03:57, Channel2/0
O	10.64.3.16/28 [110/5] via 10.64.3.34, 00:03:57, Channel2/0
C	10.64.3.32/28 is directly connected, Channel2/0
S	10.64.3.34/32 [1/0] via 10.64.3.34, Channel2/0
S	10.64.3.37/32 [1/0] via 10.64.3.37, Channel2/0
C	10.64.3.48/28 is directly connected, Serial1/3.1
C	10.64.3.128/28 is directly connected, Serial1/3.2
S*   0.0.0.0/0 [1/0] via 10.64.3.1

Se muestra en el sistema central

VTAM aparece en la consola del sistema

D NET,TRL

IST097I DISPLAY ACCEPTED
ST350I DISPLAY TYPE = TRL 042
IST1314I TRLE = DIPTG	  STATUS = ACTIV       CONTROL = MPC
IST1454I 1 TRLE(S) DISPLAYED
IST314I END

D NET,TRL,TRLE=DIPTG

IST097I DISPLAY ACCEPTED
IST075I NAME = DIPTG, TYPE = TRLE 045
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV
IST087I TYPE = LEASED		  , CONTROL = MPC , HPDT = YES
IST1715I MPCLEVEL = HPDT       MPCUSAGE = SHARE
IST1577I HEADER SIZE = 4092 DATA SIZE = 60 STORAGE = ***NA***
IST1221I WRITE DEV = 0E25 STATUS = ACTIVE     STATE = ONLINE
IST1577I HEADER SIZE = 4092 DATA SIZE = 60 STORAGE = DATASPACE
IST1221I READ  DEV = 0E24 STATUS = ACTIVE     STATE = ONLINE
IST314I END

Visualizaciones de información de ruteo bajo TSO del comando netstat

la ruta del netstat visualiza la tabla de ruteo. Por ejemplo:

===> netstat route

EZZ2350I MVS TCP/IP NETSTAT CS V2R7       TCPIP NAME: TCPIP       15:56:33
EZZ2755I Destination       Gateway       Flags  Refcnt  Interface
EZZ2756I -----------       -------       -----  ------  ---------
EZZ2757I 10.0.0.0          10.64.3.33    UG     000000  LDIPTG
EZZ2757I 10.64.3.32        0.0.0.0       U      000000  LDIPTG
EZZ2757I 10.64.3.33        0.0.0.0       UH     000000  LDIPTG

muestras del dispositivo del netstat el estatus y así sucesivamente de todos los dispositivos conectados o links. Por ejemplo:

===> netstat device

EZZ2350I MVS TCP/IP NETSTAT CS V2R7	  TCPIP NAME: TCPIP	   15:58:04
EZZ2760I DevName: LOOPBACK	    DevType: LOOPBACK  DevNum: 0000
EZZ2761I   LnkName: LOOPBACK	      LnkType: LOOPBACK    Status: Ready
EZZ2762I     NetNum: 0	 QueSize: 0   ByteIn: 0000004278   ByteOut: 0000004278
EZZ2768I   BSD Routing Parameters:
EZZ2769I     MTU Size: 00000		 Metric: 00
EZZ2770I     DestAddr: 0.0.0.0		 SubnetMask: 0.0.0.0
EZZ2810I   Multicast Specific:
EZZ2811I     Multicast Capability: No
EZZ2760I DevName: DIPTG 	    DevType: MPC       DevNum: 0000
EZZ2761I   LnkName: LDIPTG	      LnkType: MPC	   Status: Ready
EZZ2762I     NetNum: 0	 QueSize: 0   ByteIn: 0000001848   ByteOut: 0000001936
EZZ2768I   BSD Routing Parameters:
EZZ2769I     MTU Size: 01470		 Metric: 01
EZZ2770I     DestAddr: 0.0.0.0		 SubnetMask: 255.255.255.240
EZZ2810I   Multicast Specific:
EZZ2811I     Multicast Capability: Yes
EZZ2812I     Group            RefCnt
EZZ2813I     -----            ------
EZZ2814I     224.0.0.5        0000000001
EZZ2814I     224.0.0.1        0000000001
EZZ2760I DevName: VIPADEV	    DevType: VIPA      DevNum: 0000
EZZ2761I   LnkName: VIPALINK	      LnkType: VIPA	   Status: Ready
EZZ2762I     NetNum: 0	 QueSize: 0   ByteIn: 0000000000   ByteOut: 0000000000
EZZ2768I   BSD Routing Parameters:
EZZ2769I     MTU Size: 01470		 Metric: 01
EZZ2770I     DestAddr: 0.0.0.0		 SubnetMask: 255.255.255.240
EZZ2810I   Multicast Specific:
EZZ2811I     Multicast Capability: No

Hay muchas más opciones disponibles con el netstat. ¿Usted puede publicar el netstat? comando de visualizarlos todos.


Información Relacionada


Document ID: 12257