Tecnologías IBM : SNA Switch (SNASw)

Configuración de servicios de conmutación SNA en DLSw

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo configurar un router y una computadora del sistema central para utilizar los servicios de transferencia de la Arquitectura de red de sistemas (SNASw) sobre el Data-Link Switching (DLSw), para conectar la conexión en sentido ascendente con la unidad central y rio abajo con un nodo del physical unit (PU) 2.0 de la herencia. ¿En este documento??? el ejemplo s, la conexión ascendente a la unidad central está a través de un Procesador de interfaz de canal (CIP), y el nodo PU2.0 conecta con la unidad central sobre el tubo del Dependent Logical Unit Requester (DLUR) establecido por el SNASw.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • ¿SNASw 4700 con el Cisco IOS?? Software Release 12.1(7)

  • CIP 7507 con el Cisco IOS Software Release 12.1(7)

  • Downstream Physical Unit (DSPU) 4700 con el Cisco IOS Software Release 12.0(10)

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/12253/dlsw_snasw.gif

El DSPU se utiliza solamente para traer para arriba un PU en el Token Ring. Observe que el MAC remoto (el rmac) con el cual conecta es la dirección MAC que se especifica en el puerto del control de link de datos virtual (VDLC) que se define al SNASw en el Brachio.

Configuraciones

En este documento, se utilizan estas configuraciones:

Una declaración del link se requiere solamente para la conexión ascendente, y solamente una definición del puerto VDLC es necesitada por la conexión en sentido ascendente y las conexiones descendentes.

¿Brachio??? Configuración del router del SNASwitch
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname brachio
!
no logging buffered
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
cns event-service server
!
source-bridge ring-group 2
dlsw local-peer peer-id 10.64.3.195
dlsw remote-peer 0 tcp 10.64.3.194
dlsw remote-peer 0 tcp 192.168.25.18
!
!
interface TokenRing0
ip address 10.64.3.195 255.255.255.240
ip ospf authentication-key mypasswo
ring-speed 16
!
interface TokenRing1
ip address 192.168.25.19 255.255.255.240
ring-speed 16
source-bridge 200 1 2
!
snasw cpname P390.BRACHIO
snasw dlus P390.P390SSCP
snasw port PVDLC vdlc 2 mac 4000.0000.1234
snasw link LVDLC port PVDLC rmac 4000.0000.0001
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip classless
no ip http server
!
!
!
line con 0
exec-timeout 0 0
transport input none                                                  
line aux 0
line vty 0 4
login
!
end

¿FEP??? Configuración del router CIP
!
version 12.1
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname FEP
!
boot system flash slot0:rsp-a3jsv-mz.121-7.bin
logging buffered 64000 debugging
!
!
!
microcode CIP flash slot0:cip27-17
microcode reload

!
source-bridge ring-group 60
dlsw local-peer peer-id 10.64.3.194
dlsw remote-peer 0 tcp 10.64.3.195
!
!
interface TokenRing0/0
ip address 10.64.3.194 255.255.255.240
ip nat inside
ip ospf authentication-key pass
no ip mroute-cache
ethernet-transit-oui 90-compatible
ring-speed 16
multiring all
source-bridge 100 1 60
source-bridge spanning
llc2 local-window 127
!
!
interface Channel5/0
no ip address
no keepalive
csna 0100 40
!
interface Channel5/1
no ip address
no keepalive
shutdown
!
interface Channel5/2
no keepalive
lan TokenRing 0
source-bridge 600 1 60
adapter 0 4000.0000.0001
!
!
router ospf 1
log-adjacency-changes
redistribute static
network 0.0.0.0 255.255.255.255 area 0                                
default-information originate
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
login
!

¿Para??? Router DSPU configuración
!
version 12.0
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname para
!
enable secret 5 $1$py25$yYt4gnt.YlmsBH00wQW3G1
enable password parra
!
ip subnet-zero
!
source-bridge ring-group 300
dlsw local-peer peer-id 192.168.25.18
dlsw remote-peer 0 tcp 10.64.3.195
!
!
dspu vdlc 300 4000.0000.5678
dspu vdlc enable-host lsap 12
!
dspu host DPU4 xid-snd 01700004 rmac 4000.0000.1234 rsap 4 lsap 12    
!
dspu vdlc start DPU4
!
!
interface TokenRing0
ip address 192.168.25.18 255.255.255.240
no ip directed-broadcast
ring-speed 16
source-bridge 200 1 300
source-bridge spanning
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password parra
login
!
end

¿Unidad central??? Configuración VTAM
Nodo principal XCA
XCAE40R VBUILD TYPE=XCA
*/*
XPE40R    PORT CUADDR=E40,ADAPNO=0,SAPADDR=4,MEDIUM=RING,   -
DELAY=0,TIMER=30
*/*
*/* --------------------------------------- XCAE40R PERIPHERAL NODES
*/* ----------------------------------------------------------------
*/*
XGE40R   GROUP DIAL=YES,CALL=IN,ANSWER=ON,ISTATUS=ACTIVE
XGRL00    LINE
XGRP00      PU
*/*
XGRL01    LINE
XGRP01      PU
*/*
XGRL02    LINE
XGRP02      PU
*/*
XGRL03    LINE
XGRP03      PU
*/*
XGRL04    LINE
XGRP04      PU
*/*
XGRL05    LINE
XGRP05      PU
*/*
XGRL06    LINE
XGRP06      PU
Switched Major Node para el punto de control del SNASwitch
VBUILD TYPE=SWNET
*
*
BRACHPU  PU    ADDR=01,      NOT USED                   X
DISCNT=NO,                 WHEN TO DISCONNECT           X
ANS=CONTINUE,                                           X
ISTATUS=ACTIVE,                                         X
NETID=P390,                                             X
CPCP=YES,                                               X
CONNTYPE=APPN,                                          X
CPNAME=BRACHIO,                                         X
HPR=YES,                                                X
PUTYPE=2
*
Switched Major Node para los dispositivos PU2.0 conectados vía el tubo DLUR
VBUILD TYPE=SWNET,         INCREASE # IF MORE PU        X
MAXGRP=19,                 MAX NO OF PATH GROUPS        X
MAXNO=19                   MAX NO OF 'TEL' NOS
*
*
DPU4     PU    ADDR=01,      NOT USED                   X
DISCNT=NO,                 WHEN TO DISCONNECT           X
IDBLK=017,                 **  MUST MATCH 'PU' CUST     X
IDNUM=00004,  MUST MATCH 'PU' CUST (LAST 5 OF TR ADDR!) X
IRETRY=YES,                REPOLL ON IDLE DETECT T/O  ? X
LOGAPPL=A06TSO,            INITIAL LOGON                X
MAXDATA=265,               PIU SIZE (FIXED FOR DCA CS)  X
MAXOUT=7,                  NO OF PIUS BEFORE RESPONSE ? X
MAXPATH=1,                 MAX NO OF 'DIALOUT' PATHS    X
PASSLIM=7,                 MAX NO OF CONTIG PIUS SENT ? X
USSTAB=USSS,                                            X
MODETAB=ISTINCLM,                                       X
DLOGMOD=M2782,                                          X
SSCPFM=USSSCS,                                          X
PUTYPE=2
*
*
DLU42    LU    LOCADDR=2
DLU43    LU    LOCADDR=3
DLU44    LU    LOCADDR=4
DLU45    LU    LOCADDR=5
DLU46    LU    LOCADDR=6
DLU47    LU    LOCADDR=7
*

Verificación

Esta sección proporciona la información que usted puede utilizar para confirmar que su configuración está trabajando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Estos ejemplos de la salida del comando show visualizan la información de estatus para el Routers en la configuración de muestra:

para# show dspu

dspu host DPU4 Vdlc  PU STATUS Active
FRAMES RECEIVED 7 FRAMES SENT 7
LUs USED BY DSPU 0 LUs ACTIVE 0
LUs USED BY API 0 LUs ACTIVE 0
LUs ACTIVATED BY HOST BUT NOT USED 6

brachio# show snasw link

Number of links 2
SNA Links                                                            HPR
Link Name     State    Port Name   Adjacent CP Name  Node Type     Sess  Sup
---------    --------  ---------   ----------------  ------------  ----  ---
1> @I000003   Active    PVDLC      P390.DPU4         LEN Node         7  No
2> LVDLC      Active    PVDLC      P390.P390SSCP     Network Node     2  Yes

brachio# show snasw dlus

Number of Dependent LU Servers 1
SNA Dependent LU Servers
DLUS Name          Default?  Backup?  Pipe State         PUs
-----------------  --------  -------  ----------------  -------
1> P390.P390SSCP      Yes       No       Active            1

brachio# show snasw pu

Number of DLUR PUs 1
SNA DLUR PUs
PU Name    PU ID     State       DLUS Name
--------  --------  --------  -----------------
1> DPU4    01700004  Active    P390.P390SSCP

Estos ejemplos de la salida del comando display muestran el estatus del Virtual Telecommunications Access Method (VTAM):

D NET,ID=SNASW1,E

IST097I DISPLAY ACCEPTED
IST075I NAME = SNASW1, TYPE = SW SNA MAJ NODE 231
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV
IST1656I VTAMTOPO = REPORT, NODE REPORTED - YES
IST084I NETWORK RESOURCES:
IST089I BRACHPU  TYPE = PU_T2.1          , ACTIV--L--
IST1500I STATE TRACE = OFF
IST314I END

D NET,ID=XCAE40R,E

IST097I DISPLAY ACCEPTED
IST075I NAME = XCAE40R, TYPE = XCA MAJOR NODE 234
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV
IST1021I MEDIUM=RING,ADAPNO= 0,CUA=0E40,SNA SAP= 4
IST654I I/O TRACE = OFF, BUFFER TRACE = OFF
IST1656I VTAMTOPO = REPORT, NODE REPORTED - YES
IST170I LINES:
IST232I XGRL00   ACTIV
IST232I XGRL01   ACTIV
IST232I XGRL02   ACTIV
IST232I XGRL03   ACTIV
IST232I XGRL04   ACTIV
IST232I XGRL05   ACTIV
IST232I XGRL06   ACTIV
IST314I END

D NET,ID=CISCOPU4,E

IST097I DISPLAY ACCEPTED
IST075I NAME = CISCOPU4, TYPE = SW SNA MAJ NODE 237
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV
IST1656I VTAMTOPO = REPORT, NODE REPORTED - YES
IST084I NETWORK RESOURCES:
IST089I DPU4     TYPE = PU_T2.1          , ACTIV
IST089I DLU42    TYPE = LOGICAL UNIT     , ACTIV
IST089I DLU43    TYPE = LOGICAL UNIT     , ACTIV
IST089I DLU44    TYPE = LOGICAL UNIT     , ACTIV
IST089I DLU45    TYPE = LOGICAL UNIT     , ACTIV
IST089I DLU46    TYPE = LOGICAL UNIT     , ACTIV
IST089I DLU47    TYPE = LOGICAL UNIT     , ACTIV
IST314I END

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 12253