Tecnologías IBM : Data-Link Switching (DLSw) y Data-Link Switching Plus (DLSw+)

Data Link Switching Plus

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El Data-Link Switching (DLSw) es un estándar implementado por el IBM que soporta el transporte del Logical Link Control (LLC) sobre los WAN. DLSw es una forma más elaborada de Remote Source-Route Bridging (RSRB) y es más específico en cuanto a lo que puede o no puede interligar. DLSw requiere que el router transporte una sesión válida LLC2 o a una sesión de NetBIOS.

Los routeres Cisco implementan el RFC 1795 (estándar DSLw) y 2166 (la versión de DLSw 2). También, DLSw implementa más características para el control de broadcast y transporta menos información a través del WAN que otros métodos.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Comandos generales

Esta sección cubre los comandos dlsw importantes, los comandos para configurar DLSw, y los comandos para resolver problemas DLSw.

timbre-grupo del fuente-Bridge

El primer paso en configurar DLSw es agregar el comando source-bridge ring-group. Esto conecta las interfaces Token Ring que realizan el (SRB) del Source-Route Bridging.

Tarea Comando
Defina un grupo de anillo. source-bridge ring-group ring-group [dirección mac virtual]

Nota: Al realizar DLSw en un router que tenga solamente interfaces de Ethernet, no hay necesidad de configurar a un timbre-grupo.

Defina la identificación del peer local

La opción siguiente es definir la identificación del peer local. Esto es una dirección IP en el mismo cuadro. Esto comienza básicamente DLSw en el router.

Tarea Comando
Defina el par local DLSw+. local-par del dlsw [peer-id ip-address] [group group] [border] [cost cost] [lf size] [keepalive seconds] [passive] [promiscuous] [biu-segment]

La mayoría de la opción básica en configurar DLSw es establecer el local peer-id ip-address. Éstas son descripciones de los parámetros de comando:

  • grupo y frontera — Estos comandos se publican juntos de crear a los peeres de borde en la red.

  • coste — Se publica este comando cuando hay trayectos múltiples a la misma ubicación. Este comando dice a router cómo alcanzar estos sitios remotos usando el trayecto de costo más bajo primero.

  • lf — Este comando determina el tamaño de trama más grande que este par puede manejar. Los tamaños de trama pueden ser:

    • del tamaño de trama del 516-516 bytes como máximo

    • 1470-1470 bytes como máximo del tamaño de trama

    • El tamaño máximo de la trama es 1500-1500 byte

    • tamaño máximo de trama de 2052-2052 bytes

    • 4472-4472 bytes como máximo del tamaño de trama

    • 8144-8144 bytes como máximo del tamaño de trama

    • tamaño máximo de trama de 11407-11407 bytes

    • Tamaño máximo de trama en bytes de 11454-11454

    • 17800-17800 bytes como máximo del tamaño de trama

  • keepalive — Este comando define los paquetes de keepalive medios del intervalo. El intervalo puede extenderse a partir de la 0 a 1200 segundos. Se fija generalmente a 0 al configurar DLSw para el Dial-on-Demand Routing (DDR).

  • pasivo — Este comando configura al router para no iniciar un lanzamiento del par del router.

  • promiscuo — Este comando significa que el router valida las conexiones de cualquier peer remoto que pide un lanzamiento del par. Este comando es útil en los sitios grandes que tienen muchos pares, porque usted no tiene que definir a todos los peeres remotos en el router del núcleo.

  • biu-segmento — Este comando es una opción para DLSw que permita que DLSw controle el tamaño del segmento más arriba en las capas del System Network Architecture (SNA). Este comando habilita las estaciones terminales cree que pueden enviar cantidades más grandes de datos.

Defina al peer remoto

Después de definir al peer local, usted define al peer remoto. Usted puede definir tres tipos de pares: El TCP, el Fast-Sequenced Transport (FST), y dirige el control de link de alto nivel (HDLC) y el Frame Relay. Éstas son explicaciones de los comandos publicados para definir al peer remoto:

Tarea Comando
Encapsulación directa sobre retransmisión de tramas [bytes-netbios-out bytes-list-name] del dlci-número del número de serie de la interfaz de Frame Relay del número de lista del telecontrol-par del dlsw [backup-peer ip-address] [cost cost] [dest-mac mac-address] [dmac-output-list access-list-number] [host-netbios-out host-list-name] [keepalive seconds] [lf size] [linger minutes] [lsap-output-list list] [pass-thru]
Encapsulación directa sobre HDLC [bytes-netbios-out bytes-list-name] del número de serie de la interfaz del número de lista del telecontrol-par del dlsw [backup-peer ip-address] [cost cost] [dest-mac mac-address] [dmac-output-list access-list-number] [host-netbios-out host-list-name] [keepalive seconds] [lf size] [linger minutes] [lsap-output-list list] [pass-thru]
FST [bytes-netbios-out bytes-list-name] del IP address del fst del número de lista del telecontrol-par del dlsw [backup-peer ip-address] [cost cost] [dest-mac mac-address] [dmac-output-list access-list-number] [host-netbios-out host-list-name] [keepalive seconds] [lf size] [linger minutes] [lsap-output-list list] [pass-thru]
TCP [bytes-netbios-out bytes-list-name] del dlsw remote-peer list-number tcp ip-address [backup-peer ip-address] [cost cost] [dest-mac mac-address] [dmac-output-list access-list-number] [dynamic] [host-netbios-out host-list-name] [inactivity minutes] [keepalive seconds] [lf size] [linger minutes] [lsap-output-list list] [no-llc minutes] [priority] [tcp-queue-max size] [descanso seconds][v2-single-tcp]

Éstas son las descripciones del comando options:

  • backup peer — Este comando option define al par que sostiene a este par en caso que el primer par falle.

  • coste — Este comando option define el coste de este par. Se utiliza este comando cuando hay trayectos múltiples a un destino y cuando usted necesita un escenario preferir-capaz.

  • dest-mac, dinámico, ninguno-LLC e inactividad — este discuten el comando options en la sección del peer de backup/costo de este documento.

  • Dmac-output-list — Publican este comando option de definir una lista de acceso que diga a router qué direcciones MAC del destino remoto usted permite, o niega, tráfico del explorador.

  • Host-netbios-out — Publican este comando option de aplicar los nombres del filtro del host del NetBios.

  • keepalive — Publican este comando option de determinar el intervalo en los segundos entre el Keepalives. Se utiliza sobre todo para las configuraciones DDR.

  • lf — Este comando option especifica el tamaño más grande permitido para el par.

  • retrásese — Este comando option especifica la cantidad de tiempo que el router deja el backup peer abierto que hace activo (debido a la falla primaria) después de que el link principal llegue a ser activo otra vez.

  • prioridad — Este comando option crea a los peeres múltiples para el priorización del tráfico de DLSw.

  • tcp-queue-max — Este comando option cambia el valor predeterminado de 200 para las colas de administración del tráfico TCP.

  • descanso — Este comando option es el número de segundos que el TCP espere un acuse de recibo antes de derribar la conexión.

  • V2-single-tcpM — Diseñan a este comando option para el uso en los entornos del Network Address Translation (NAT). Cada par piensa tiene la dirección IP más alta para evitar que cada par derribe una de las conexiones TCP.

Temporizadores usados en DLSw

Éstas son explicaciones de los temporizadores usados en DLSw:

Parámetro Descripción
icannotreach-block-time La vida en caché del recurso inalcanzable, durante la cual busca para ese recurso se bloquea. El intervalo válido es 1 a 86400 segundos. El valor por defecto es 0 (inhabilitado)
netbios-cache-timeout Vida en caché de la ubicación del nombre de NetBIOS para ambos caché del alcance local y remoto. El intervalo válido es 1 a 86400 segundos. El valor por defecto es 16 minutos.
netbios-explorer-timeout Longitud del tiempo que el software del ½ del ¿Â IOSï espera una respuesta del explorador antes de marcar un recurso inalcanzable (LAN y WAN). El intervalo válido es 1 a 86400 segundos. El valor por defecto es 6 segundos.
Netbios-retry-interval Intervalo entre reintentos del explorador NetBIOS (LAN solamente). El intervalo válido es 1 a 86400 segundos. El valor por defecto es 1 segundo.
netbios-verify-interval Intervalo entre la creación de una entrada de caché y cuando la entrada se marca como añejo. Si una petición de búsqueda viene adentro para una entrada de caché que ha expirado, dirigido verifica la interrogación se envía para asegurarse de que todavía existe. El intervalo válido es 1 a 86400 segundos. El valor por defecto es 4 minutos.
sna-cache-timeout Longitud del tiempo que existe una entrada de caché de la ubicación del Punto de acceso SNA MAC/Service (SAP) antes de que se deseche (local y remoto). El intervalo válido es 1 a 86400 segundos. El valor por defecto es 16 minutos.
sna-explorer-timeout Longitud del tiempo que el software IOS espera una respuesta del explorador antes de marcar un recurso inalcanzable (LAN y WAN). El intervalo válido es 1 a 86400 segundos. El valor por defecto es 3 minutos.
sna-retry-interval Intervalo entre las recomprobaciones del explorador SNA (LAN). El intervalo válido es 1 a 86400 segundos. El valor predeterminado es de 30 segundos.
Sna-verify-interval Intervalo entre la creación de una entrada de caché y cuando la entrada se marca como añejo. Si una petición de búsqueda viene adentro para una entrada de caché que ha expirado, dirigido verifica la interrogación se envía para asegurar que todavía existe. El intervalo válido es 1 a 86400 segundos. El valor por defecto es 4 minutos.
tiempo-espera-explorador Mida el tiempo, en los segundos, que el router espera a todos los exploradores para volver antes de determinar que miren para utilizar.

Estos parámetros son muy útiles. Por ejemplo, usted puede cambiar el intervalo en los segundos que el router envía a un explorador. Esto ayuda a reducir la cantidad de exploradores en la red aumentando el tiempo entre ellos. También, usted puede cambiar los valores en los cuales el router mide el tiempo hacia fuera de las entradas del caché.

Comandos dlsw adicionales

Éstos son comandos dlsw importantes adicionales:

  • dlsw allroute-SNA/NetBIOS — Se publica este comando de cambiar el comportamiento de DLSw para utilizar todos los Route Explorer en vez de los exploradores de un solo Route.

  • bridge-group del dlsw — Se publica este comando de atar transparente los dominios Bridged con DLSw. Se utiliza extensivamente al configurar el NetBios con los Ethernetes.

  • explorerq-profundidad del dlsw — Este comandos estableces el valor de la cola del Explorador DLSw. Este comando se publica después del comando explorer-queue regular del fuente-Bridge, pero refiere a todas las tramas CANUREACH (CUR) que necesitan ser procesadas. Este comando es importante porque cubre los paquetes de los Ethernetes, aunque no se cubre en el comando source-bridge explorerq-depth. Refiera a entender y a resolver problemas el Source-Route Bridging para más información sobre este comando.

Comandos show

Los comandos show y las salidas descritos en esta sección son útiles al resolver problemas DLSw.

show dlsw peer

Este comando proporciona la información sobre los pares. Visualizan a cada peer remoto configurado aquí, incluyendo la cantidad de transmitido y los paquetes recibidos.

Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime
 TCP 5.5.5.1         CONNECT          2         2  conf      0    0   0 00:00:06

Éstos son los estados posibles:

  • CONECTE — Este estado significa que el par de DLSw es en servicio.

  • DESCONECTE este estado significa que el par abajo o no está conectado.

  • CAP_EXG — Este estado significa que DLSw está en el intercambio de las capacidades con el peer remoto.

  • WAIT_RD — Este estado es el último paso en comenzar encima del par. Este par está esperando al peer remoto para abrir el puerto leído. Refiera a la sección de debugging de este documento para más información sobre cuando el par empieza para arriba y publicando el comando debug dlsw peer.

  • WAN_BUSY — Este estado significa que la cola saliente TCP es llena, y el paquete no puede ser transmitido.

El comando show dlsw peer también muestra el número de descensos, la cantidad de circuitos a través del par específico, la cola TCP, y el uptime. Los aumentos del contador de caídas por estas razones:

  • La interfaz WAN no esta activa para un par directo.

  • DLSw intenta enviar un paquete antes de que el par esté conectado completamente (para evento TCP o evento de capacidades que espera). Cola TCP de salida por completo.

  • Discordancia en el conteo de secuencia de números FST.

  • No puede conseguir el buffer para reducir el paquete FST del Switch.

  • Error del controlador CiscoBus en la mayor capacidad; no puede mover el paquete desde reciben el buffer para transmitir el buffer, o vice versa.

  • El IP Address de destino del paquete FST no hace juego al peer local ID.

  • Interfaz WAN no funciona para un par FST.

  • Ningún comando de memoria caché de ruta SRB configurado.

  • El buffer del timbre del Madge es lleno en los sistemas de menor capacidad: LAN de alimentación PÁLIDO demasiado rápido.

capacidades del show dlsw

DLSw: Capabilities for peer 5.5.5.1(2065)
  vendor id (OUI)         : '00C' (cisco)
  version number          : 1
  release number          : 0
  init pacing window      : 20
  unsupported saps        : none
  num of tcp sessions     : 1
  loop prevent support    : no
  icanreach mac-exclusive : no
  icanreach netbios-excl. : no
  reachable mac addresses : none
  reachable netbios names : none
  cisco version number    : 1
  peer group number       : 0
  border peer capable     : no
  peer cost               : 3
  biu-segment configured  : no
  local-ack configured    : yes
  priority configured     : no
  version string          :
Cisco Internetwork Operating System Software
IOS (tm) 4500 Software (C4500-J-M), Version 10.3(13), RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1996 by cisco Systems, Inc.

alcance de show dlsw

DLSw MAC address reachability cache list
Mac Addr        status     Loc.    peer/port            rif
0800.5a0a.c51d  FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
0800.5a49.1e38  FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
0800.5a95.3a13  FOUND      REMOTE  5.5.5.1(2065)
 
DLSw NetBIOS Name reachability cache list
NetBIOS Name    status     Loc.    peer/port            rif
PIN-PIN         FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
QUENEPA         FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
WIN95           FOUND      REMOTE  5.5.5.1(2065)

El campo de estatus es la mayoría de la parte importante del comando show dlsw reach. Éstos son los estados posibles:

  • ENCONTRADO — El router ha localizado el dispositivo.

  • BÚSQUEDA — El router está buscando para el recurso.

  • NOT_FOUND — El almacenamiento en memoria inmediata negativo está prendido, y la estación no ha respondido a las interrogaciones.

  • SIN CONFIRMAR — Se configura la estación, pero DLSw no la ha verificado.

  • VERIFIQUE — Se está verificando verificar la información de la memoria caché porque el caché va añejo, o la configuración de usuario.

show dlsw circuit

Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
        PCEP: 60A545B4   UCEP: 60B0B640
        Port:To3/0          peer 5.5.5.1(2065)
        Flow-Control-Tx CW:20, Permitted:32; Rx CW:20, Granted:32
        RIF = 06B0.0021.00F0

Al publicar el comando show dlsw circuit, preste la atención al control de flujo. El control de flujo existe en una base del por-circuito. Ésta es una comunicación que ocurre mientras que los dos pares de DLSw asignan a circuito una ventana de la transferencia posible. Este valor aumenta y disminuye dependiendo de la cantidad de tráfico con la cual el circuito está intentando moverse. El valor puede cambiar dependiendo de la congestión de la nube.

El comando show dlsw circuit es más extenso a partir de IOS 11.1. El comando ahora permite que usted mire el circuito de DLSw en un valor del punto de acceso de servicio (SAP) o el valor MAC, que simplifican la localización de los circuitos al resolver problemas. Éste es un ejemplo de salida:

ibu-7206#sh dlsw cir
Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
ibu-7206#sh dls cir det ?
  <0-4294967295>  Circuit ID for a specific remote circuit
  mac-address     Display all remote circuits using a specific MAC
  sap-value       Display all remote circuits using a specific SAP
  <cr>
 
ibu-7206#show dlsw circuit detail mac 4000.0000.0001
Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
        PCEP: 60A545B4   UCEP: 60B0B640
        Port:To3/0          peer 5.5.5.1(2065)
        Flow-Control-Tx CW:20, Permitted:29; Rx CW:20, Granted:29
        RIF = 06B0.0021.00F0
241-00  4000.0000.0001(04)  4001.68ff.0000(04) CONNECTED
        Port:To0          peer 5.5.7.1(2065)
        Flow-Control-Tx CW:20, Permitted:27; Rx CW:20, Granted:27
        RIF = 0630.00F1.0010
s5e#sh cls
DLU user: DLSWDLU
      SSap:0x63       type:  llc0   class:0
        DTE:0800.5a95.3a13 0800.5a0a.c51d F0 F0
        T1 timer:0      T2 timer:0      Inact timer:0
        max out:0       max in:0        retry count:0
        XID retry:0     XID timer:0     I-Frame:0
 
        DTE:4000.0000.0001 4001.68ff.0000 04 04
        T1 timer:0      T2 timer:0      Inact timer:0
        max out:0       max in:0        retry count:0
        XID retry:0     XID timer:0     I-Frame:0
TokenRing0 DTE: 4000.0000.0001 4001.68ff.0000 04 04 state NORMAL
   V(S)=23, V(R)=23, Last N(R)=22, Local window=7, Remote Window=127
   akmax=3, n2=8, Next timer in 1240
   xid-retry timer      0/0       ack timer    1240/1000
   p timer              0/1000    idle timer  10224/10000
   rej timer            0/3200    busy timer      0/9600
   akdelay timer        0/100     txQ count       0/200

Resolución de problemas

Por abandono, DLSw termina a las sesiones LLC en el Routers (Local-ack). Además, porque termina el (RIF) del campo routing information, hay otros problemas de diseño a considerar. La mayoría de los problemas comunes de DLSw se describen en esta sección.

Loops

Uno de la mayoría de los asuntos importantes a recordar sobre DLSw es terminación RIF. Esto es un problema porque los loopes importantes en la red pueden ser creados fácilmente. Este diagrama demuestra un loop:

/image/gif/paws/12249/dlsw_1.gif

En este caso, puesto que DLSw termina el RIF, el paquete circunda indefinidamente. Esto es porque cada vez que una trama CUR se envía del par para mirar, el par de recepción crea a un nuevo explorador (NINGÚN RIF) y lo envía. Los pasos del explorador se describen:

  1. Los 3174 en el timbre 11 envía a un explorador para alcanzar el host.

  2. Tanto SF1 como el puente copian la trama.

  3. El SF1 crea una trama CUR a LA1 (su par) para decir a LA1 que los 3174 quiere alcanzar el HOST.

  4. SF2 recibe el paquete y hace lo mismo.

  5. Ahora, LA1 y LA2 crean el explorador y lo envían al anillo.

  6. El LA1 y el LA2 reciben a un explorador que creó.

  7. Ahora hay un dilema, porque cada lado cree que los 3174 localmente está asociado.

  8. Cada router tiene los 3174, local y telecontrol.

  9. Ahora envían una trama Icanreach al SF1 y al SF2, respectivamente, que crea una respuesta del host hacia los 3174.

  10. El SF1 y el SF2 ponen la respuesta del explorador en el Token Ring y cada uno aprende que la dirección MAC del host es accesible localmente y remotamente.

  11. De la accesibilidad DLSw Firewall con eficacia contra el explorador que coloca indefinidamente. Sin embargo, con las tramas de la información sin numerar (UI), esto puede colocar, después conduce el CPU y alinea la utilización hasta el 100%.

Si ocurre esto, verifique que el Anillo virtual en el Routers sea exactamente lo mismo en cada lado de la nube, como se muestra en este diagrama:

/image/gif/paws/12249/dlsw_2.gif

El Routers en cada lado de esta nube tiene el exacto el mismo número de anillo virtual. Esto se asegura de que uno del Routers envíe a un explorador que ha pasado ya a través del timbre, entonces el router lo caiga. Cuando el LA1 genera a un explorador para una trama CUR recibida por el SF1, el LA2 lo cae porque el explorador pasó ya a través del timbre 1. En este escenario, es importante que el router hace un diverso Bridge configurar si el paquete se va al mismo timbre, que es el caso del lado LA de la red.

En una Versión de Ethernet del mismo escenario, usted debe inhabilitar a un par. Un ejemplo se visualiza en este diagrama:

dlsw_3.gif

Porque un paquete en los Ethernetes no tiene un RIF, el router no puede determinar si el broadcast, creado por el otro router en el LAN, es del otro router o de una estación de origen. Con el SNA, el paquete localmente se origina o telecontrol. Porque los exploradores de un entorno Token Ring en efecto tienen ambos MAC Address de origen y destino, son un no broadcast en los Ethernetes, sino un directed frame a una estación de otra.

Qué ocurre en el diagrama precedente se explica en estos pasos:

  1. Se envía un explorador desde el 3174 al host.

  2. El SF2 valida a este explorador el SF1 y.

  3. SF1 y SF2 generan cada uno un CUR hacia el otro lado, LA1 y LA2.

  4. Éstos generan a un explorador que el host responde a; porque es explorador de un solo Route, se responde con a un explorador de la todo-ruta.

  5. El LA1 y el LA2 crean una trama CUR al SF1 y al SF2, que crean el paquete para los 3174.

  6. El SF1 oye la dirección MAC del HOST que viene de los Ethernetes y ahora cree que el HOST está situado en el LAN local. Pero en el caché del SF1, el ID del host está respondiendo de un peer remoto.

  7. Esto fuerza al router a tener el HOST local y remoto, así que significa que DLSw está quebrado.

Pares de respaldo/costo

Los backup peer agregan la tolerancia de fallas a DLSw en caso que pierdan a un par. Esto se configura generalmente en los entornos de la base de modo que cuando un router del núcleo falla, otro router pueda validar al router que falla. Las configuraciones y el diagrama en esta sección ilustran una configuración del backup peer.

D3B
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3b
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.14.1
   cost 2 promiscuous
!
interface Loopback0
 ip address 1.1.14.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.2 255.255.255.0
 bandwidth 125000
 clockrate 125000
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

D3C
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.12.1
   cost 4 promiscuous
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 bandwidth 500000
 clockrate 500000
!
interface TokenRing0
 ip address 1.1.5.2 255.255.255.0
 ring-speed 16
 source-bridge 3 2 2
 source-bridge spanning
!

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1
dlsw remote-peer 0 tcp 1.1.14.1
dlsw remote-peer 0 tcp 1.1.12.1
dlsw timer explorer-wait-time 2
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.1 255.255.255.0
 bandwidth 500000
!
interface Serial1
 ip address 1.1.4.2 255.255.255.0
 bandwidth 125000
!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

/image/gif/paws/12249/dlsw_8.gif

La primera cosa a recordar sobre los pares del coste de DLSw es que ambos pares son activos. El router mantiene a solamente un backup peer. Puede tener dos en ese entonces si retrásese se configura. Esto es qué ocurrió en el diagrama precedente:

  1. D3a recibe a un explorador y comienza el proceso enviando una trama CUR a cada peer remoto.

  2. El D3B y el D3C reciben las tramas CUR. Cada uno genera a un explorador al host, que contesta de nuevo al D3B y al D3C.

  3. El D3B y el D3C responden de nuevo al D3A con Icanreach.

  4. El D3A envía la estación de la respuesta del explorador al final.

  5. La estación remota enciende el circuito del dlsw, con el Identificación de intercambio (XID) para SNA y el Set Asynchronous Balanced Mode Extended (SABME) para el NetBios.

  6. El D3A selecciona el costo bajo dentro del accesibilidad.

Hay un temporizador en el D3A que se puede definir para decir al router cuánto tiempo esperar a todos los exploradores para volver al D3A. Esto evita los problemas con los costes que pueden ocurrir cuando el router utiliza al primer explorador que vuelve a él. Publique el comando del <seconds> del temporizador tiempo-espera-explorador del dlsw de fijar este temporizador.

Además, al realizar a los peeres de borde, DLSw envía solamente una trama CUR al par más barato. Se comporta diferentemente que lo hace al realizar el coste sin los peeres de borde.

Los backup peer actúan un poco diferentemente. Usted especifica al backup peer en el par que va a ser de reserva para el par especificado. Esto significa que el par que tiene el enunciado de backup es el backup peer sí mismo.

Especifique la opción del retraso de modo que cuando el peer primario hace operativo otra vez, los circuitos no puedan derribar inmediatamente. Esto es útil si el peer primario varía hacia arriba y hacia abajo, porque usted no quiere utilizar al par defectuoso.

Esto demuestra la configuración de los backup peer:

D3B
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3b
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.14.1
   promiscuous
!
interface Loopback0
 ip address 1.1.14.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.2 255.255.255.0
 bandwidth 125000
 clockrate 125000
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

D3C
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.12.1
   promiscuous
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 bandwidth 500000
 clockrate 500000
!
interface TokenRing0
 ip address 1.1.5.2 255.255.255.0
 ring-speed 16
 source-bridge 3 2 2
 source-bridge spanning
!

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1
dlsw remote-peer 0 tcp 1.1.14.1
dlsw remote-peer 0 tcp 1.1.12.1 backup-peer 1.1.14.1 linger 5
dlsw timer explorer-wait-time 2
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.1 255.255.255.0
 bandwidth 500000
!
interface Serial1
 ip address 1.1.4.2 255.255.255.0
 bandwidth 125000
!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

Publicando desconecta al par el comando show dlsw peer:

d3a#sh dls peer
Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime
 TCP 1.1.14.1        CONNECT        464      1286  conf      0    0   0 03:17:02
 TCP 1.1.12.1        DISCONN          0         0  conf      0    0   -        -

Pares de bordes

Los peeres de borde son una característica importante de DLSw porque solucionan el problema del control de broadcast en una red. Este ejemplo ilustra cómo configuran a los peeres de borde y qué ocurre cuando sube una sesión:

/image/gif/paws/12249/dlsw_6.gif

D3E
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3e
!
!
dlsw local-peer peer-id 1.1.11.1 group 1
   border promiscuous
dlsw remote-peer 0 tcp 1.1.12.1
!
interface Loopback0
 ip address 1.1.11.1 255.255.255.0
!
interface Serial0
 ip address 1.1.3.1 255.255.255.0
!
interface Serial1
 ip address 1.1.2.2 255.255.255.0
 clockrate 500000
!
interface TokenRing0
 ip address 10.17.1.189 255.255.255.0
 ring-speed 16
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

D3C
Current configuration:
!
version 11.1

service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
dlsw local-peer peer-id 1.1.12.1 group 2
   border promiscuous
dlsw remote-peer 0 tcp 1.1.11.1
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 no fair-queue
 clockrate 500000
!
interface Serial1
 ip address 1.1.3.2 255.255.255.0
 clockrate 500000
!
interface TokenRing0
 no ip address
 shutdown
 ring-speed 16
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

D3F
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3f
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.10.1 group 1
   promiscuous
dlsw remote-peer 0 tcp 1.1.11.1
dlsw peer-on-demand-defaults inactivity 1
!
interface Loopback0
 ip address 1.1.10.1 255.255.255.0
!
interface Serial0
 ip address 1.1.2.1 255.255.255.0
 no fair-queue
!!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2
 source-bridge spanning
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1 group 2
   promiscuous
dlsw remote-peer 0 tcp 1.1.12.1
dlsw peer-on-demand-defaults inactivity 1
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.2 255.255.255.0
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

La primera parte de que configura a los peeres de borde es crear a los peeres promiscuos. Los peeres promiscuos validan las conexiones de cualquier router DLSw que intenta abrir a un par con este router. Por ejemplo, en el diagrama precedente, usted quisiera que el D3A abriera a un par con el D3F. Si no hay ninguna peeres de borde, usted necesita configurar a los peeres estáticos en la red. Esto trabaja muy bien, pero cuando usted tiene centenares de sitios y usted utiliza a los peeres estáticos cuando un router necesita encontrar una estación remotamente, el router tiene que enviar una trama CUR a cada par. Esto puede causar muchos gastos indirectos.

Por otra parte, cuando usted utiliza a los peeres de borde, ese router remoto necesita enviar solamente una petición al peer de borde. Esta petición entonces se propaga a través de los grupos, y el router remoto abre a un par con el otro router remoto para encender un circuito y para establecer una conexión. Este proceso se explica en este diagrama:

/image/gif/paws/12249/dlsw_7.gif

  1. Cuando el D3A recibe al explorador, envía un broadcast al D3C. El D3C es el peer de borde a quien se asocia el D3A.

  2. Cuando el D3C recibe la trama CUR, envía la trama CUR a todos los pares en el grupo. El D3C también envía una trama de prueba a cualquier interfaz local que se configure para hacer así pues, y envía una trama CUR a los peeres de borde en el otro grupo.

  3. El D3E recibe el CUR del D3C en otro grupo. Entonces el D3E hace lo mismo enviando el CUR a todos los pares en el grupo y cualquier interfaz local.

  4. El D3F recibe la trama CUR y envía un sondeo de prueba a la interfaz local. Si el D3F tiene un par que señala a otro router, no puede producir eco esa trama CUR a otro router.

  5. Cuando el D3F recibe una contestación para la estación terminal, devuelve la trama Icanreach al D3E.

  6. El D3E lo envía al D3C, que adelante él al D3A. El D3A envía una respuesta de la prueba al dispositivo.

  7. Cuando la estación terminal comienza un circuito del dlsw, con el XID para el SNA y el SABME para el NetBios, D3A inicia una conexión de peer con el D3F y comienza para arriba la sesión.

Éste es el debug del D3C y del D3A durante este proceso:

d3a#
DLSW Received-ctlQ : CLSI Msg : TEST_STN.Ind   dlen: 40
CSM: Received CLSI Msg : TEST_STN.Ind   dlen: 40 from TokenRing0
CSM:   smac c001.68ff.0000, dmac 4000.0000.0001, ssap 4 , dsap 0
DLSw: sending bcast to BP peer 1.1.12.1(2065)

Se considera la trama de prueba que entra en al router. Entonces, el router genera una trama CUR al D3C. La actividad D3C visualiza esta salida:

DLSw: Pak from peer 1.1.13.1(2065) with op DLX_MEMBER_TO_BP
DLSw: recv_member_to_border() from peer 1.1.13.1(2065)
DLSw: passing pak to core originally from 1.1.13.1 in group 2
%DLSWC-3-RECVSSP: SSP OP = 3( CUR  ) -explorer from peer 1.1.13.1(2065)
DLSw: Pak from peer 1.1.11.1(2065) with op DLX_RELAY_RSP
DLSW: relaying pak to member 1.1.13.1 in group 2

Cuando el D3C recibe el paquete del D3A, él adelante el paquete a la base. Más adelante, usted ve la respuesta del peer remoto que se está retransmitiendo de nuevo al D3A. Entonces el D3A comienza para arriba la conexión (par a pedido) con el peer remoto D3F en este debug:

DLSw: Pak from peer 1.1.12.1(2065) with op DLX_RELAY_RSP
DLSW: creating a peer-on-demand for 1.1.10.1
DLSw: passing pak to core originally from 1.1.10.1 in group 1
%DLSWC-3-RECVSSP: SSP OP = 4( ICR  ) -explorer from peer 1.1.10.1(2065)
DISP Sent : CLSI Msg : TEST_STN.Rsp   dlen: 44
DLSW Received-ctlQ : CLSI Msg : ID_STN.Ind   dlen: 54
CSM: Received CLSI Msg : ID_STN.Ind   dlen: 54 from TokenRing0
CSM:   smac c001.68ff.0000, dmac 4000.0000.0001, ssap 4 , dsap 4
DLSw: new_ckt_from_clsi(): TokenRing0 4001.68ff.0000:4->4000.0000.0001:4
DLSw: action_a() attempting to connect peer 1.1.10.1(2065)
DLSw: action_a(): Write pipe opened for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state DISCONN, new state WAIT_RD
DLSw: passive open 1.1.10.1(11003) -> 2065
DLSw: action_c(): for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state WAIT_RD, new state CAP_EXG
DLSw: CapExId Msg sent to peer 1.1.10.1(2065)
DLSw: Recv CapExId Msg from peer 1.1.10.1(2065)
DLSw: Pos CapExResp sent to peer 1.1.10.1(2065)
DLSw: action_e(): for peer 1.1.10.1(2065)
DLSw: Recv CapExPosRsp Msg from peer 1.1.10.1(2065)
DLSw: action_e(): for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state CAP_EXG, new state CONNECT
DLSw: peer_act_on_capabilities() for peer 1.1.10.1(2065)
DLSw: action_f(): for peer 1.1.10.1(2065)
DLSw: closing read pipe tcp connection for peer 1.1.10.1(2065)
DLSw: new_ckt_from_clsi(): TokenRing0 4001.68ff.0000:4->4000.0000.0001:4
DLSw: START-FSM (1474380): event:DLC-Id state:DISCONNECTED
DLSw: core: dlsw_action_a()
DISP Sent : CLSI Msg : REQ_OPNSTN.Req   dlen: 106
DLSw: END-FSM (1474380): state:DISCONNECTED->LOCAL_RESOLVE

Después de que el router reciba el paquete retransmitido del peer de borde, abre a un par a pedido con el peer remoto D3F (1.1.10.1), y pone en marcha el circuito.

el hacer el debug de

El primer paso en cualquier red DLSw está criando a los pares. Sin los pares, no hay intercambio de los datos. La mayor parte de los detalles de qué ocurren entre los pares de DLSw se explican en el RFC 1795.

Nota: Si usted habla con equipo no Cisco vía DLSw, utilice DLSw. Sin embargo, entre los routeres Cisco, DLSw+ del uso.

Esta salida es de publicar a los pares del dlsw del debug y de criar a los pares para arriba entre dos routeres Cisco:

DLSw: passive open 5.5.5.1(11010) -> 2065
DLSw: action_b(): opening write pipe for peer 5.5.5.1(2065)
DLSw: peer 5.5.5.1(2065), old state DISCONN, new state CAP_EXG
DLSw: CapExId Msg sent to peer 5.5.5.1(2065)
DLSw: Recv CapExId Msg from peer 5.5.5.1(2065)
DLSw: Pos CapExResp sent to peer 5.5.5.1(2065)
DLSw: action_e(): for peer 5.5.5.1(2065)
DLSw: Recv CapExPosRsp Msg from peer 5.5.5.1(2065)
DLSw: action_e(): for peer 5.5.5.1(2065)
shSw: peer 5.5.5.1(2065), old state CAP_EXG, new state CONNECT
DLSw: peer_act_on_capabilities() for peer 5.5.5.1(2065)
DLSw: action_f(): for peer 5.5.5.1(2065)
DLSw: closing read pipe tcp connection for peer 5.5.5.1(2065)

Esta salida muestra al router que comienza encima del par y que abre a una sesión TCP con el otro router. Entonces comienza a las capacidades de intercambio. Después del intercambio positivo de capacidades, el par está conectado. En contraste con el RSRB, DLSw no mueve al par a un estado cerrado cuando no hay actividad, tal como tráfico. Siguen siempre conectados. Si los pares son disconnected, par del dlsw del debug del problema para determinar porqué no son capaces de la apertura.

Al resolver problemas una sesión que es traída para arriba, la base del dlsw del debug del problema para observar la falla de la sesión y para verificarla si está subiendo el circuito.

Éste es el flujo para un controlador de comunicaciones. 3174 al host vía el DLSw+:

/image/gif/paws/12249/dlsw_4.gif

La salida del dlsw del debug visualiza el flujo de la sesión que es traída para arriba correctamente:

ibu-7206#debug dlsw
DLSw reachability debugging is on at event level for all protocol traffic
DLSw peer debugging is on
DLSw local circuit debugging is on
DLSw core message debugging is on
DLSw core state debugging is on
DLSw core flow control debugging is on
DLSw core xid debugging is on
ibu-7206#
DLSW Received-ctlQ : CLSI Msg : UDATA_STN.Ind   dlen: 208
CSM: Received CLSI Msg : UDATA_STN.Ind   dlen: 208 from TokenRing3/0
CSM:   smac 8800.5a49.1e38, dmac c000.0000.0080, ssap F0, dsap F0
CSM: Received frame type NETBIOS DATAGRAM from 0800.5a49.1e38, To3/0
DLSw: peer_put_bcast() to non-grouped peer 5.5.5.1(2065)
DLSw: Keepalive Request sent to peer 5.5.5.1(2065))
DLSw: Keepalive Response from peer 5.5.5.1(2065)
DLSW Received-ctlQ : CLSI Msg : TEST_STN.Ind   dlen: 41
CSM: Received CLSI Msg : TEST_STN.Ind   dlen: 41 from TokenRing3/0
CSM:   smac c001.68ff.0001, dmac 4000.0000.0001, ssap 4 , dsap 0

Note la trama de prueba el venir del LAN (localmente) de la estación c001.68ff.0001 a la dirección MAC de 4000.0000.0001. Cada uno. El Ind indica que un paquete está viniendo adentro del LAN. Cuando el router envía un paquete al LAN, usted ve un .RSP.

DLSw: peer_put_bcast() to non-grouped peer 5.5.5.1(2065)
%DLSWC-3-RECVSSP: SSP OP = 4( ICR  ) -explorer from peer 5.5.5.1(2065)
DISP Sent : CLSI Msg : TEST_STN.Rsp   dlen: 44

Ahora usted puede ver el broadcast enviado al peer remoto y a la respuesta de la Velocidad de celda inicial (ICR) detrás. Esto significa que el router remoto identificó a la estación como alcanzable. El TEST_STN.Rsp es el router que envía una respuesta de la prueba a la estación.

DLSW Received-ctlQ : CLSI Msg : ID_STN.Ind   dlen: 54
CSM: Received CLSI Msg : ID_STN.Ind   dlen: 54 from TokenRing3/0
CSM:   smac c001.68ff.0001, dmac 4000.0000.0001, ssap 4 , dsap 4

Después de que la estación reciba la respuesta de la prueba, envía el primer XID. Usted puede notar esto con el IS_STN.Ind. Ahora el router tiene que sostenerse sobre esta trama temporalmente hasta que borre un par de detalles entre los dos routeres DLSw.

DLSw: new_ckt_from_clsi(): TokenRing3/0 4001.68ff.0001:4->4000.0000.0001:4
DLSw: START-FSM (1622182940): event:DLC-Id state:DISCONNECTED
DLSw: core: dlsw_action_a()
DISP Sent : CLSI Msg : REQ_OPNSTN.Req   dlen: 108
DLSw: END-FSM (1622182940): state:DISCONNECTED->LOCAL_RESOLVE
 
DLSW Received-ctlQ : CLSI Msg : REQ_OPNSTN.Cfm CLS_OK dlen: 108
DLSw: START-FSM (1622182940): event:DLC-ReqOpnStn.Cnf state:LOCAL_RESOLVE
DLSw: core: dlsw_action_b()
CORE: Setting lf size to 30
%DLSWC-3-SENDSSP: SSP OP = 3(CUR)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:LOCAL_RESOLVE->CKT_START
 
%DLSWC-3-RECVSSP: SSP OP = 4(ICR)  from peer 5.5.5.1(2065)
DLSw: 1622182940 recv FCI 0 - s:0 so:0 r:0 ro:0
DLSw: recv RWO
DLSw: START-FSM (1622182940): event:WAN-ICR state:CKT_START
DLSw: core: dlsw_action_e()
DLSw: sent RWO
DLSw: 1622182940 sent FCI 80 on  ACK   - s:20 so:1 r:20 ro:1
%DLSWC-3-SENDSSP: SSP OP = 5(ACK)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_START->CKT_ESTABLISHED

Aquí usted puede notar el flujo interno de DLSw entre los dos pares. Estos paquetes son normales para cada iniciación de sesión. La primera fase es moverse desde un estado desconectado a un estado del CKT_ESTABLISHED. Ambo Routers transmite una trama CUR para el circuito sí mismo. Se llama esto puede la configuración del circuito del alcance u (CURCS). Cuando el par que inicia la trama CURCS recibe una trama ICRCS, envía un acuse de recibo y se mueve a un estado establecido del circuito. Ahora, ambos routeres DLSw están listos para el proceso XID.

DLSw: START-FSM (1622182940): event:DLC-Id state:CKT_ESTABLISHED
DLSw: core: dlsw_action_f()
DLSw: 1622182940 sent FCA on  XID
%DLSWC-3-SENDSSP: SSP OP = 7(XID)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED

El router recibió un XID después de enviar la respuesta de la prueba a la estación. Guarda este XID por un momento, después lo transmite al par a través del circuito. Esto significa que usted les está enviando los paquetes a/desde el par con el circuit id marcado con etiqueta. Esta manera, DLSw entiende la actividad entre las dos estaciones. Recuerde que DLSw termina el Logical Link Control, el tipo-2 (LLC2), sesión en cada lado de la nube.

%DLSWC-3-RECVSSP: SSP OP = 7(XID)  from peer 5.5.5.1(2065)
DLSw: 1622182940 recv FCA on  XID   - s:20 so:0 r:20 ro:0
DLSw: START-FSM (1622182940): event:WAN-XID state:CKT_ESTABLISHED
DLSw: core: dlsw_action_g()
DISP Sent : CLSI Msg : ID.Rsp   dlen: 12
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED
 
DLSW Received-ctlQ : CLSI Msg : ID.Ind   dlen: 39
DLSw: START-FSM (1622182940): event:DLC-Id state:CKT_ESTABLISHED
DLSw: core: dlsw_action_f()
%DLSWC-3-SENDSSP: SSP OP = 7(XID)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED

Usted primero nota una respuesta al primer XID que fue enviado antes. En ID.Rsp, usted ve que el XID fue enviado a la estación, a la cual la estación respondió con un ID.Ind. Éste es otro XID que fue enviado a través al par de DLSw.

%DLSWC-3-RECVSSP: SSP OP = 8(CONQ)  from peer 5.5.5.1(2065)
DLSw: START-FSM (1622182940): event:WAN-CONQ state:CKT_ESTABLISHED

Esta parte nos muestra que la estación en el otro lado respondió con un SABME (CONQ) al XID. La negociación XID ha terminado y el router está listo para comenzar la sesión.

DLSw: core: dlsw_action_i()
DISP Sent : CLSI Msg : CONNECT.Req   dlen: 16

Luego, el router envía SABME a la estación en CONNECT.Req.

DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CONTACT_PENDING
 
DLSW Received-ctlQ : CLSI Msg : CONNECT.Cfm CLS_OK dlen: 8
DLSw: START-FSM (1622182940): event:DLC-Connect.Cnf state:CONTACT_PENDING
DLSw: core: dlsw_action_j()
%DLSWC-3-SENDSSP: SSP OP = 9( CONR )  to peer 5.5.5.1(2065) success
DISP Sent : CLSI Msg : FLOW.Req   dlen: 0
DLSw: END-FSM (1622182940): state:CONTACT_PENDING->CONNECTED

Entonces usted recibe el reconocimiento sin numeración (UA) de la estación, que se muestra en el mensaje del CONNECT.Cfm. Esto se envía al peer remoto vía un CONR. Entonces el proceso de la velocidad relativa (RR) se comienza con FLOW.Req.

%DLSWC-3-RECVSSP: SSP OP = 10(INFO)  from peer 5.5.5.1(2065)
DLSw: 1622182940 decr r - s:20 so:0 r:19 ro:0
DLSw: START-FSM (1622182940): event:WAN-INFO state:CONNECTED
DLSw: core: dlsw_action_m()
DISP Sent : CLSI Msg : DATA.Req   dlen: 34
DLSw: END-FSM (1622182940): state:CONNECTED->CONNECTED
 
DLSw: 1622182940 decr s - s:19 so:0 r:19 ro:0
DLSW Received-disp : CLSI Msg : DATA.Ind   dlen: 35
DLSw: sent RWO
DLSw: 1622182940 sent FCI 80 on  INFO  - s:19 so:0 r:39 ro:1
%DLSWC-3-SENDSSP: SSP OP = 10(INFO)  to peer 5.5.5.1(2065) success
%DLSWC-3-RECVSSP: SSP OP = 10(INFO)  from peer 5.5.5.1(2065)
DLSw: 1622182940 decr r - s:19 so:0 r:38 ro:1
DLSw: 1622182940 recv FCA on  INFO  - s:19 so:0 r:38 ro:0
DLSw: 1622182940 recv FCI 0 - s:19 so:0 r:38 ro:0
DLSw: recv RWO
DLSw: START-FSM (1622182940): event:WAN-INFO state:CONNECTED
DLSw: core: dlsw_action_m()
DISP Sent : CLSI Msg : DATA.Req   dlen: 28
DLSw: END-FSM (1622182940): state:CONNECTED->CONNECTED

El DATA.Req indica que el router transmitió una Yo-trama. Data.Ind indica que el router recibió una Yo-trama. Usted puede utilizar esta información para determinar el flujo de paquetes a través de los routeres DLSw.

DLSW Received-ctlQ : CLSI Msg : DISCONNECT.Ind   dlen: 8
DLSw: START-FSM (1622182940): event:DLC-Disc.Ind state:CONNECTED

Esta parte contiene un DISCONNECT.Ind. . El Ind indica un paquete que viene adentro del LAN. En este caso, la estación envía una DESCONEXIÓN, que hace al router comenzar a derribar el circuito.

DLSw: core: dlsw_action_n()
%DLSWC-3-SENDSSP: SSP OP = 14( HLTQ )  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CONNECTED->DISC_PENDING
 
%DLSWC-3-RECVSSP: SSP OP = 15( HLTR )  from peer 5.5.5.1(2065)
DLSw: START-FSM (1622182940): event:WAN-HLTR state:DISC_PENDING

Después de que el router reciba la DESCONEXIÓN, envía un ALTO al peer remoto y espera la respuesta. Todo se deja que es enviar un UA a la estación y al cierre abajo el circuito, que se muestra en el debug siguiente con el DISCONNECT.Rsp:

DLSw: core: dlsw_action_q()
DISP Sent : CLSI Msg : DISCONNECT.Rsp   dlen: 4
DISP Sent : CLSI Msg : CLOSE_STN.Req   dlen: 4
DLSw: END-FSM (1622182940): state:DISC_PENDING->CLOSE_PEND
 
DLSW Received-ctlQ : CLSI Msg : CLOSE_STN.Cfm CLS_OK dlen: 8
DLSw: START-FSM (1622182940): event:DLC-CloseStn.Cnf state:CLOSE_PEND
DLSw: core: dlsw_action_y()
DLSw: 1622182940 to dead queue
DLSw: END-FSM (1622182940): state:CLOSE_PEND->DISCONNECTED

La cosa más reciente DLSw se realiza es poner el circuito en la cola muerta. De allí, los punteros se limpian y alistan para un nuevo circuito.

Sesiones de NetBIOS

DLSw administra sesiones NetBIOS en forma diferente, pero las depuraciones son muy similares.

/image/gif/paws/12249/dlsw_5.gif

Nota: Recuerde que los XID no fluyen para las estaciones NetBIOS y que las tramas y el nombre de NETBIOS del System Switch Processor de la interrogación del nombre de NETBIOS del intercambio de los routeres DLSw (SSP) reconocieron. Ésta es la diferencia principal.


Información Relacionada


Document ID: 12249