Entrega de contenido y video : Cisco Universal Broadband Routers (uBR) de la serie 900

DHCP-proxy del módem de cable nacional en los cables módem de Cisco

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Este documento explica cómo utilizar el comando cable-modem dhcp-proxy nat. La función principal de este comando es configurar a una agrupación de direcciones del Network Address Translation (NAT) con una dirección IP suministrada por el servidor DHCP del proveedor de Intrernet.

Para más información, refiera al DHCP-proxy del módem de cable en los comandos cmts IOS del cable.

precaución Precaución: Sea consciente del Id. de bug Cisco CSCdt32356 (clientes registrados solamente), que se repara en los trenes de versión de software 12.2 de Cisco IOS� y posterior. El NAT dinámico usando el comando cable interface nacional del pool-nombre del DHCP-proxy del módem de cable no funciona correctamente. La dirección IP o las máscaras de subred y los default gatewayes no se asignan correctamente, si en absoluto. Después de que se ingrese el comando, el direccionamiento que se asigna al agrupamiento NAT no responde al Address Resolution Protocol (ARP). El ip nat pool se crea que es del alcance del módem de cable, bastante que el alcance del Customer Premises Equipment (CPE), así que él pone una dirección IP unroutable en el agrupamiento NAT. Note que este problema ocurre en las versiones de Cisco IOS Software para vario Cable módems, especialmente 12.1(5)T. Se recomienda que usted utiliza el tren de versión del Cisco IOS Software 12.2 en el uBR924 y utiliza las versiones 12.2T, 12.3, y posterior entrena para el uBR905, el uBR925, y los módems CVA. Para la información adicional, refiera al Id. de bug Cisco CSCdt32356 (clientes registrados solamente).

Nota: También sea consciente de estas consideraciones:

  1. Porque las Plataformas del uBR904 no soportan el Cisco IOS Software Release 12.1(1)T, no es posible configurar el comando cable-modem dhcp-proxy en esta plataforma.

  2. Para habilitar la característica del DHCP-proxy en el uBR924, se recomienda generalmente que usted utiliza el Cisco IOS Software Release 12.2(6j).

  3. Para el CVA122, el comando se documenta como DHCP-proxy del cable nacional. Este comando es lo mismo que el comando cable-modem dhcp-proxy nat en los uBR900 Series Cable Modem.

    De un CVA122, esta salida puede ser considerada:

    Router(config)# interface cable 0
    
    Router(config-if)# cable?
    
    cable-modem

prerrequisitos

Requisitos

Quienes lean este documento deben tener conocimiento de los siguientes temas:

  • Comprensión básica de la traducción de dirección de red y porqué se utiliza

  • Protocolo del Data-over-Cable Service Interface Specifications (DOCSIS) 1.0

  • La interfaz de línea del comando del Cisco IOS Software

Componentes Utilizados

Esta tabla muestra las versiones de Cisco IOS Software que soportan este comando para cada plataforma del cable módem de Cisco:

Libere que introducido el comando cable-modem dhcp-proxy Plataforma
12.1(1)T uBR924
12.1(3)XL ubr905
12.2(2)XA ubr925
12.1(5)XU1 CVA122

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

NAT dinámico contra el NAT estático

Con el NAT dinámico, las traducciones no existen en la tabla de traducción de NAT hasta que el router reciba el tráfico que requiere la traducción. Las traducciones dinámicas tienen un período de descanso, después de lo cual se purgan de la tabla de traducción. Con el NAT estático, sin embargo, las traducciones existen en la tabla de traducción de NAT tan pronto como usted configure un comando static nat, y sigue habiendo en la tabla de traducción hasta que usted borre el comando static nat o los comandos.

La manera más fácil de determinar que usted hace el NAT dinámico configurar en su módem de cable está buscando para este comando en la configuración del módem de cable:

ip nat inside source list 100 interface cable-modem0 overload

Señalando la fuente NAT a una lista de acceso, usted está construyendo dinámicamente la tabla de traducción de NAT. El comando cable-modem dhcp-proxy nat utiliza esta función NAT dinámica.

Configuración usando el comando cable-modem dhcp-proxy nat

Al usar el comando cable-modem dhcp-proxy nat, el direccionamiento usado para el agrupamiento NAT se afecta un aparato automáticamente del servidor DHCP del operador de cable.

Al usar esta opción, incluya estos comandos nat configuration:

  • interfaz interior nacional del IP — Utilice para configurar la interfaz de Ethernet como la interfaz del “interior”.

  • interfaz exterior nacional del IP — Utilice para configurar la interfaz del cable como la interfaz del “exterior”.

  • sobrecarga — Especifique esta opción con el comando ip nat global configuration porque el agrupamiento NAT creado por el comando cable-modem dhcp-proxy nat contiene solamente una dirección IP.

Después de configurar al router con el comando cable-modem dhcp-proxy nat, reinicie al router. Durante el proceso de abastecimiento del DOCSIS, el router envía un pedido de DHCP cliente de obtener una dirección IP para la interfaz del cable. El router entonces envía un pedido DHCP de representación al servidor DHCP usando la dirección MAC de la interfaz de Ethernet. El servidor DHCP contesta con una segunda dirección IP que el router asigna a un Loopback Interface dinámicamente configurado que está señalando a un agrupamiento NAT dinámicamente configurado de solamente un direccionamiento.

Vea el resultado de la configuración en este documento para la información que se agrega automáticamente a la configuración después de que se procese el DHCP.

Para configurar el NAT de modo que cree el pool dinámicamente, publique estos comandos en su router. Recuerde que, para configurar el NAT, su router debe estar en el modo de ruteo.

Router# config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)# interface ethernet 0

Router(config-if)# ip address 192.168.1.1 255.255.255.0

!--- Assign an IP address to interface Ethernet 0.

Router(config-if)# no bridge-group 59

!--- Remove bridging so that you can configure for routing.

Router(config-if)# no bridge-group 59 spanning

!--- Remove bridging spanning.

Router(config-if)# ip nat inside

!--- Enable NAT inside for the Ethernet interface.

Router(config-if)# exit

Router(config)#

Router(config)# interface cable 0

Router(config-if)# no bridge-group 59

!--- Remove bridging so that you can configure for routing.

Router(config-if)# no bridge-group 59 spanning

!--- Remove bridging spanning.

Router(config-if)# no cable compliant bridge

!--- Remove bridging so that you can configure for routing.

Router(config-if)# ip nat outside

!--- Enable NAT outside for the cable interface.

Router(config-if)# cable-modem dhcp-proxy nat TEST_POOL

!--- Define dhcp-proxy nat for the TEST_POOL pool.

Router(config-if)# exit

Router(config)#

Router(config)# ip routing

!--- Enable routing.

Router(config)# ip nat inside source list 1 pool TEST_POOL overload

!--- Configure dynamic NAT.

Router(config)# access-list 1 permit 192.168.1.0 0.0.0.255

!--- Define interesting traffic for NAT.

La configuración parece esto:

router# show run

Building configuration...
Current configuration : 953 bytes
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
!
ip audit notify log
ip audit PO max-events 100
no ip dhcp-client network-discovery
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no ip mroute-cache
!
interface cable-modem0
 ip nat outside
 no ip mroute-cache
 no cable-modem compliant bridge
 cable-modem dhcp-proxy nat TEST_POOL
!
ip nat inside source list 1 pool TEST_POOL overload
ip classless
no ip http server
no ip http cable-monitor
!
access-list 1 permit 192.168.1.0 0.0.0.255
snmp-server packetsize 4096
snmp-server manager
!
voice-port 0
 input gain -2
 output attenuation 0
!
voice-port 1
 input gain -2
 output attenuation 0
!
!
line con 0
 transport input none
line vty 0 4
 login
!
end

router#

Los comandos intrépidos son los que usted ingresó; los otros son los valores por defecto. Note que no han creado al agrupamiento NAT todavía en este momento. El módem de cable necesita ser recargado, o la interfaz del cable necesita ser reajustada publicando el comando shut seguido por el comando no shut.

router# reload

Proceed with reload? [confirm]
133.CABLEMODEM.CISCO: 00:06:16: %SYS-5-RELOAD: Reload requested
System Bootstrap, Version 12.0(6r)T3, RELEASE SOFTWARE (fc1)
Copyright (c) 1999 by Cisco Systems, Inc.
UBR924 platform with 16384 Kbytes of main memory
program load complete, entry point: 0x80010000, size: 0x398070
Self decompressing the image : #################################
################################################################
################################################################
################################################################
################################################################
################################################################
########################################################## [OK]

!--- Output suppressed.

Press RETURN to get started!

Nota: En el resultado de la configuración, la información que se agrega automáticamente a la configuración después de que se procese el DHCP se observa con los comentarios.

En este documento, un uBR7114 y el uBR924 se utilizan como ejemplos. Las versiones de Cisco IOS Software instaladas en ellos son 12.1(5)EC1 y 12.1(3a)T4, respectivamente. La figura siguiente muestra la Conectividad y los IP Addresses usados.

Figura 1: Diagrama usado en la configuración usando el comando cable dhcp-proxy nat

/image/gif/paws/12176/cable_dhcp_proxy1.gif

uBR924 — Configuración del conjunto de direcciones NAT con una dirección IP suministrada por el servidor DHCP del proveedor de servicio
router# show run

Building configuration...
Current configuration : 1273 bytes
!
! Last configuration change at 13:12:52 - Tue Feb 29 2000
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
logging rate-limit console 10 except errors
!
clock timezone - -8
ip subnet-zero
no ip finger
!
ip audit notify log
ip audit PO max-events 100
no ip dhcp-client network-discovery
!
!
interface Loopback0
 ip address 111.111.111.8 255.255.255.255

!--- Lookback interface added automatically by DHCP configuration.

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no ip mroute-cache
!
interface cable-modem0
 ip nat outside
 no ip mroute-cache
 no cable-modem compliant bridge
 cable-modem dhcp-proxy nat TEST_POOL
 cable-modem boot admin 2
 cable-modem boot oper 5
 cable-modem downstream saved channel 525000000 37 1
!
ip nat pool TEST_POOL 111.111.111.8 111.111.111.8 netmask 255.255.255.0

!--- NAT pool added automatically by DHCP configuration.

ip nat inside source list 1 pool TEST_POOL overload
ip classless
no ip http server
no ip http cable-monitor
!
access-list 1 permit 192.168.1.0 0.0.0.255
snmp-server packetsize 4096
snmp-server manager
!
voice-port 0
 input gain -2
 output attenuation 0
!
voice-port 1
 input gain -2
 output attenuation 0
!
!
line con 0
 transport input none
line vty 0 4
 login
!
end

Verificación de la configuración

Esta sección describe cómo utilizar la salida del comando show para verificar la configuración del módem de cable.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Publique el comando show arp de visualizar las entradas en la tabla ARP.

router# show arp

Protocol  Address         Age (min) Hardware Addr   Type   Interface
Internet  111.111.111.111      56   0002.b9ff.8c1c  ARPA   cable-modem0
Internet  10.4.1.1             59   0002.b9ff.8c1c  ARPA   cable-modem0

!--- IP address of the interface cable 1/0
!--- of the cable modem termination system (CMTS).

Internet  192.168.1.1           -   0030.1976.771a  ARPA   Ethernet0
Internet  192.168.1.5          34   00a0.243c.eff5  ARPA   Ethernet0

!--- IP address of the PC behind the cable modem.

Internet  10.4.1.114            -   0030.1976.771b  ARPA   cable-modem0

El PC detrás del módem de cable tiene la dirección IP 192.168.1.5 configurada estáticamente. Es muy fácil, sin embargo, hacer el módem de cable un servidor DHCP que asigne dinámicamente una dirección IP a sus hosts LAN; utilice esta configuración:

ip dhcp excluded-address 192.168.1.1 
ip dhcp pool pool name


   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1

Para probar que el NAT trabaja, publique un comando ping del PC conectado detrás del módem de cable para intentar alcanzar la interfaz del cable.

Si usted mira la tabla de traducción de NAT, usted puede ver las traducciones exitosas.

router# show ip nat translations

Pro  Inside global      Inside local       Outside local    Outside global
icmp 111.111.111.8:512  192.168.1.5:512    10.4.1.114:512   10.4.1.114:512

Para más información, refiera al DHCP-proxy del módem de cable en los comandos cmts IOS del cable.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 12176