Switching de LAN : EtherChannel

Ejemplo de Configuración de EtherChannel entre Catalyst 3550/3560/3750 Series Switches y Catalyst Switches que ejecutan Cisco IOS System Software

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (7 Octubre 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra para que cómo configure un EtherChannel entre un Catalyst 3550 y un Catalyst 6500/6000 que funcionan con el software del sistema del½ del¿Â del Cisco IOSïÂ. El EtherChannel se puede denominar Fast EtherChannel o Gigabit EtherChannel, según la velocidad de las interfaces o de los puertos utilizados para crear el EtherChannel.

Nota: Los comandos de EtherChannel aplicados al Catalyst 3550 switch en este documento también se pueden aplicar a los Catalyst 3750 series switches.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • El switch Catalyst 3550 que ejecuta la versión 12.1(14)EA del software del IOS de Cisco.

  • Switch Catalyst 6500/6000 con la versión del software del IOS de Cisco 12.1 (13) E1.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Teoría Precedente

En este documento, dos interfaces de Ethernet Gigabite en un Catalyst 3550 switch, -- la interfaz de GigabitEthernet en el 3500 es una interfaz Ethernet negociada 10/100/1000 -- se agruparon en un Fast EtherChannel con dos interfaces Fast Ethernet de un Catalyst 6500/6000 switch que ejecuta Cisco IOS System Software para crear un EtherChannel de Capa 2 (L2).

Nota: En este documento, Fast EtherChannel, Gigabit EtherChannel, canal de puerto, y grupo de canales se refieren al EtherChannel.

La configuración del switch Catalyst en este documento se aplica a cualquier Catalyst 6500/6000 o a los switches de las series Catalyst 4500/4000 que ejecutan el Software del sistema del IOS de Cisco.

Este documento muestra archivos de configuración únicamente de los switches y los resultados de los comandos show de muestra relacionados. Para obtener detalles sobre cómo configurar un EtherChannel, consulte estos documentos:

Notas importantes

El EtherChannel se puede configurar de forma manual con los comandos adecuados. También puede configurar EtherChannel de forma automática con el Port Aggregation Protocol (PAgP) para que el switch pueda negociar el canal con el otro lado. Para obtener detalles sobre el PAgP, consulte estos documentos:

Las configuraciones en este documento están implementadas con el modo deseable. Si planea configurar el EtherChannel manualmente, siga los pasos provistos para crear un canal de puerto. Esto evita problemas con Spanning Tree Protocol (STP) (protocolo de árbol transversal) durante el proceso de configuración. El STP puede cerrar algunos puertos, con un estado de puerto de error inhabilitado [errdisable], si se configura un lado como canal antes de que el otro lado se pueda configurar como canal.

Siga estos pasos para crear un canal de puerto:

  1. Deje las interfaces que se utilizarán en la canalización del puerto como administrativamente apagadas.

  2. Cree el canal de puerto (grupo de canal) en el switch Catalyst 6500/6000.

    Asegúrese de que configuró el modo del canal como activo, por ejemplo, modo del canal de grupo 1 activo.

  3. Cree los canales de puerto en el switch Catalyst 3550, 3560 o 3750.

    Asegúrese de activar el modo de canal.

  4. Vuelva a habilitar las interfaces que fueron inhabilitadas anteriormente en el Catalyst 6500/6000 switch con el comando no shut.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en este diagrama:

/image/gif/paws/12033/89-a.gif

Nota: La interfaz de Ethernet Gigabite en Catalyst 3550 es una interfaz de Ethernet negociada de 10/100/1000 Mbps. El puerto Gigabit en el Catalyst 3550 también se puede conectar con un puerto FastEthernet (100 Mbps) en un Catalyst 6500/6000.

Nota: Los switches Catalyst de pila cruzada serie 3750 admiten un EtherChannel, que le permite a las interfaces de diferentes switches de pila ser miembros del mismo grupo EtherChannel. Para más EtherChannel del ½ del ¿Â del onï de la información en el entorno del interruptor de apilado del ½ del ¿Â del aïÂ, refiera al EtherChannel y conmute la sección de los stack de la documentación de los EtherChanneles que configura para los Catalyst 3750 Series Switch.

Configuraciones

En este documento, se utilizan estas configuraciones:

Catalyst 3550
Building configuration...
Current configuration : 1610 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3550
!
enable password ww
!
ip subnet-zero
no ip finger
!
!
!
!
!--- A logical port-channel interface is automatically created 
!--- when ports are grouped into a channel group.

interface Port-channel 1


!--- In this example, the L2 EtherChannel is configured.
!--- A Layer 3 (L3) EtherChannel can also be configured on the Catalyst 3550 switches.
!--- For more information, refer to the document Configuring EtherChannel.

switchport mode access no ip address snmp trap link-status!

!--- Note: The Gigabit Ethernet interface on the Catalyst 3550 is a 
!--- 10/100/1000 Mbps negotiated Ethernet interface. The Gigabit port on the Catalyst 3550 is 
!--- connected to a FastEthernet (100 Mbps) port on the Catalyst 6500/6000.

!--- The port is a member of channel group 1.

interface GigabitEthernet0/1
 switchport mode access
 no ip address
 snmp trap link-status
 channel-group 1 mode desirable
!


!--- The port is a member of channel group 1.

interface GigabitEthernet0/2
 switchport mode access
 no ip address
 snmp trap link-status
 channel-group 1 mode desirable
!
interface GigabitEthernet0/3
 switchport mode access
 no ip address
 snmp trap link-status
!


!--- Output suppressed.

interface GigabitEthernet0/12
 switchport mode access
 no ip address
 snmp trap link-status


!--- Interface VLAN1 is required for management purposes.

interface Vlan1
 ip address 10.1.1.1 255.255.255.0
!
ip classless
ip http server
!
!
line con 0
 transport input none
line vty 5 15
!
end

Catalyst 6500/6000
Building configuration...
  
 Current configuration : 5869 bytes
 !
 version 12.1
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname cat6500
 !
 boot buffersize 126968
 boot bootldr bootflash:c6msfc-boot-mz.121-4.E1
 enable password ww
 !
 redundancy
  main-cpu
   auto-sync standard
 ip subnet-zero
 !
 !
 no ip finger
 !
 !
 !
 !


!--- A logical port-channel interface is automatically created 
!--- when ports are grouped into a channel group.

 interface Port-channel 1
  no ip address
  switchport
  switchport mode access
 !
 interface GigabitEthernet1/1
  no ip address
  shutdown
 !
 interface GigabitEthernet1/2
  no ip address
  shutdown
 !

!--- Note: The Gigabit Ethernet interface on the Catalyst 3550 is a
!--- 10/100/1000 Mbps negotiated Ethernet interface. The Gigabit port on the Catalyst 3550 is 
!--- connected to a FastEthernet (100 Mbps) port on the Catalyst 6500/6000.

 interface FastEthernet3/1
  no ip address


!--- In this example, the L2 EtherChannel is configured.
!--- An L3 EtherChannel can also be configured on the Catalyst 6500/6000 running
!--- Cisco IOS System Software. For more details, refer to the document
!--- Configuring EtherChannel.

!--- On a Catalyst 6500/6000, you must issue the switchport
!--- command once, without any keywords, in order to configure the interface as an L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default;
!--- no additional command is required.

 switchport

!--- This command puts the interface in VLAN1, by default.

 switchport mode access

!--- The port is a member of channel group 1.

 channel-group 1 mode desirable
 !
 interface FastEthernet3/2
  no ip address

!--- On a Catalyst 6500/6000, you must issue the switchport 
!--- command once, without any keywords, in order to configure the interface as an L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default;  
!--- no additional command is required.

  switchport

!--- This command puts the interface in VLAN1, by default.

  switchport mode access

!--- The port is a member of channel group 1.

  channel-group 1 mode desirable
 !
 interface FastEthernet3/3
  no ip address
 switchport
  switchport mode access
 !


!--- Output suppressed.

 !
 interface FastEthernet3/48
  no ip address
 switchport
  switchport mode access
 !


!--- Interface VLAN1 is required for management purposes.

 interface Vlan1
  ip address 10.1.1.2 255.255.255.0
 !
 ip classless
 no ip http server
 !
 !
 !
 line con 0
  transport input none
 line vty 0 4
 !
 end

Nota: Este ejemplo de configuración muestra una configuración EtherChannel con enlaces de acceso. La misma configuración se utiliza para los links troncales EtherChannel. Ejecute el comando switchport mode trunk, o permita que los switches negocien el modo con el modo dinámico deseable. Para obtener más información sobre cómo configurar el trunking, consulte la sección Configuración de Trunks VLAN del documento Configuración de VLANs.

Configuración de la interfaz sub del canal del puerto

Otro ejemplo de la configuración del canal del puerto con la interfaz sub en el Cisco IOS Software Release 12.2(25) corriente del Catalyst 3560 Switch.

Catalyst 3560
Building configuration...
  
Current configuration : 2480 bytes
!
version 12.2
!
interface Port-channel5
no switchport
no ip address
!
interface Port-channel5.690
!
interface Port-channel10
no switchport
no ip address
!
interface Port-channel10.1
!
interface Port-channel10.690
!
interface Port-channel11
no switchport
no ip address

Verificación

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Para verificar el canal de puerto en los switches Catalyst 6500/6000 y Catalyst 3500 que ejecutan Cisco IOS System Software, ejecute estos comandos:

Para verificar el estado STP en los switches Catalyst 6500/6000 y Catalyst 3500 que ejecutan el Cisco IOS System Software, ejecute este comando:

Catalyst 3550

Cat3550#show interface port-channel 1
Port-channel1 is up, line protocol is up
Hardware is EtherChannel, address is 0002.4b28.db02 (bia 0002.4b28.db02)
MTU 1500 bytes, BW 200000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
 Full-duplex, 100Mb/s
input flow-control is off, output flow-control is off
 Members in this channel: Gi0/1 Gi0/2
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:03:27, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
26 packets input, 5344 bytes, 0 no buffer
Received 17 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
59 packets output, 5050 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Cat3550#show spanning-tree vlan 1 detail
 
 VLAN1 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 0002.4b28.db01
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 1 last change occurred 00:00:38 ago
          from Port-channel1
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 0
 
 Port 65 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 128.65.
   Designated root has priority 32768, address 0002.4b28.db01
   Designated bridge has priority 32768, address 0002.4b28.db01
   Designated port id is 128.65, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 34, received 0 

Cat3550# show etherchannel 1 summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        R - Layer3      S - Layer2
        U - port-channel in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Gi0/1(P)   Gi0/2(P)

Cat3550# ping 10.1.1.2
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Catalyst 6500/6000

Cat6500# show interface port-channel 1
Port-channel1 is up, line protocol is up
  Hardware is EtherChannel, address is 0002.7ef1.36e1 (bia 0002.7ef1.36e1)
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Full-duplex, 100Mb/s
  Members in this channel: Fa3/1 Fa3/2
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/2000, 0 drops
  5 minute input rate 1000 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     407 packets input, 34994 bytes, 0 no buffer
     Received 311 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     93 packets output, 16598 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Cat6500# show spanning-tree vlan 1 detail
 
 VLAN1 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 00d0.024f.6001
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32768, address 0002.4b28.db01
  Root port is 833 (Port-channel1), cost of root path is 12
  Topology change flag not set, detected flag not set
  Number of topology changes 0 last change occurred 00:02:13 ago
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300
 
 Port 833 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 131.65.
   Designated root has priority 32768, address 0002.4b28.db01
   Designated bridge has priority 32768, address 0002.4b28.db01
   Designated port id is 128.65, designated path cost 0
   Timers: message age 1, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 0, received 66

Cat6500# show etherchannel 1 summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        R - Layer3      S - Layer2
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa3/1(P)   Fa3/2(P)

Cat6500# ping 10.1.1.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Troubleshooting

Err-Disable State

Un problema frecuente durante la configuración de EtherChannel es que las interfaces ingresan en el modo err-disable. Esto puede observarse cuando el EtherChannel se conmuta al modo ENCENDIDO en un switch, y el otro switch no se configura inmediatamente. Si permanece en este estado durante un minuto más o menos, el STP en el switch donde se habilita EtherChannel considera que hay un loop. Lo anterior provoca el ingreso de los puertos de canalización en el estado err-disable. Consulte este ejemplo para obtener más información sobre cómo determinar si sus interfaces del EtherChannel están en estado err-disable:

%SPANTREE-2-CHNL_MISCFG: Detected loop due to etherchannel misconfiguration of Gi0/9
%PM-4-ERR_DISABLE: channel-misconfig error detected on Po10, putting Gi0/9 in err-disable state
%PM-4-ERR_DISABLE: channel-misconfig error detected on Po10, putting Gi0/10 in err-disable state
Switch1#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        u - unsuitable for bundling
        U - in use      f - failed to allocate aggregator
        d - default port

Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
10     Po10(SD)         -        Gi0/9(D)    Gi0/10(D)

Switch1#show interfaces GigabitEthernet 0/9 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/9                        err-disabled 1            auto   auto 10/100/1000BaseTX

Switch1#show interfaces GigabitEthernet 0/10 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/10                       err-disabled 1            auto   auto 10/100/1000BaseTX

El mensaje de error indica que el EtherChannel encontró un loop de spanning tree. Para resolver el problema, fije al modo del canal a deseable a ambos lados de la conexión, y después vuelva a permitir las interfaces:

Switch1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch1(config)#interface gi0/9
Switch1(config-if)#channel-group 10 mode desirable

Lo anterior hace que cada lado cree un canal solamente si ambos deciden canalizar. Si no lo hacen, continúan funcionando como puertos normales.

Una vez configurado el modo de canal deseable en ambos lados de la conexión, ejecute los comandos shutdown y no shutdown en la interfaz asociada para volver a habilitar los puertos manualmente:

Switch1(config-if)#shutdown
Switch1(config-if)#no shutdown

"El Comando "speed nonegotiate" No Aparece en la Configuración Actual.

El comando speed nonegotiate configurado en un canal de puerto no siempre aparece en la configuración actual. Esto sucede porque nonegotiate en la interfaz del canal de puerto depende de la interfaz de los puertos agrupados. Se inserta cuando el canal de puerto está activo y está basado en la configuración de los puertos de canal individuales.


Información Relacionada


Document ID: 12033