Switching de LAN : Inter-Switch Link (ISL)

Configuración de una conexión troncal ISL entre switches Catalyst serie 2948G-L3 y Catalyst serie 2900/3500XL ó 2970.

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (7 Octubre 2015) | Comentarios


Contenido


Introducción

Este documento discute cómo configurar un troncal de Protocolo del Inter-Switch Link (ISL) entre un Cisco Catalyst 2948G-L3 y Catalyst 2900/3500XL o los 2970 Series Switch. Cuando usted conecta un Catalyst 2948G-L3 con un Switch, las tareas de configuración son lo mismo que ésas para conectar a un router con un Switch. El ejemplo de configuración en este documento utiliza el Catalyst 2948G-L3 como router y utiliza el Catalyst 3500XL como el Switch de la capa 2 (L2). Usted puede substituir el Catalyst 2900XL o la 2970 para el 3500XL, con el propósito de este documento.

Para utilizar el concepto de VLA N en el Catalyst 2948G-L3, usted debe utilizar a los Grupos de Bridge. Cada grupo de puente se considera una VLAN separada. Estos grupos de puentes corresponden al número VLAN del switch conectado.

prerrequisitos

Requisitos

Antes de que usted intente esta configuración, asegúrese de que usted conecte un cable de par cruzado entre el 2900/3500XL o la 2970 y el 2948G-L3. Típicamente, usted utiliza un cable de conexión directa entre un router y un Switch; pero con el Catalyst 2948G-L3, usted utiliza un cable de par cruzado para conectar con otro Switch. Éste es el mismo cable de par cruzado que usted utilizaría para una conexión entre switches.

Quienes lean este documento deben tener conocimiento de los siguientes temas:

Componentes Utilizados

La información que contiene este documento se basa en estas versiones de software:

  • Software Release 12.0(25)W5(27) de Cisco IOS� para el Switch/el router (CAT2948G-IN-M) de la capa 3 (L3)

  • Cisco IOS Software Release 12.0(5)WC9 (C3500XL-C3H2S-M) (fc1)

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Configurar

Esta sección proporciona la información para configurar las características descritas en este documento.

Nota: Para encontrar la información adicional sobre los comandos en este documento, utilice la herramienta de búsqueda de comandos (clientes registrados solamente).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/12019/25.gif

Si usted quisiera que los tres PC pudieran hacerse ping y tener un default gateway, después usted debe utilizar el bridging con el Integrated Routing and Bridging (IRB).

El Catalyst 2948G-L3 es el dispositivo L3 en este escenario. Porque es un dispositivo L3, no puede tener dos interfaces L3 en la misma subred. Por eso usted necesita utilizar a los Grupos de Bridge en las interfaces y atarlas así como un (BVI) del Interfaz Virtual de Bridge, BVI 2.

La dirección IP del BVI 2 es el default gateway para todos los PC y dispositivos en VLAN2 o el Grupo de Bridge 2.

Configuraciones

En este documento, se utilizan estas configuraciones:

2948G-L3
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2948G-L3
!
!
ip subnet-zero
bridge irb
!
!
!
interface FastEthernet1

!--- This interface is the ISL trunk to the switch.

 no ip address
 no ip directed-broadcast
!
interface FastEthernet1.1
 encapsulation isl 1        
 no ip redirects
 no ip directed-broadcast
 bridge-group 1

!--- Use bridge-group 1 for the trunk subinterface.
!--- You can not use an IP address here because of the subnet
!--- overlap that would occur due to BVI 1, which is in the
!--- same subnet.

!
interface FastEthernet1.2
 encapsulation isl 2
 no ip redirects
 no ip directed-broadcast
 bridge-group 2             
!
interface FastEthernet2
 no ip address
 no ip directed-broadcast
 bridge-group 2

!--- This port belongs to VLAN 2.

!
interface FastEthernet3
 no ip address
 no ip directed-broadcast
 bridge-group 2

!--- This port belongs to VLAN 2.

!
interface FastEthernet4
 no ip address
 no ip directed-broadcast
 bridge-group 1

!--- This port belongs to VLAN 1.

!
interface BVI1
 ip address 10.1.1.1 255.255.0.0

!--- This is the IP address of BVI 1.

 no ip directed-broadcast
 no ip route-cache cef
!
interface BVI2

!--- This is the IP address of BVI 2.

 ip address 10.2.2.2 255.255.0.0
 no ip directed-broadcast
 no ip route-cache cef
!
ip classless
!
bridge 1 protocol ieee

!--- Choose IEEE as the Spanning Tree Protocol.

 bridge 1 route ip

!--- Allow routing to occur for IP.

bridge 2 protocol ieee
 bridge 2 route ip
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

2900/3500XL o 2970

!--- First, add VLAN 2 to the VLAN database for a 2900/3500XL
!--- switch:

3500XL# vlan database

3500XL(vlan)# vlan 2

VLAN 2 added:
    Name: VLAN0002

3500XL(vlan)# exit

APPLY completed.
Exiting....
3500XL#

!--- The Catalyst 2970 gives you the option to configure VLANs
!--- from the VLAN database or from global configuration mode:

2970# configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

2970(config)# vlan 2

2970(config-vlan)# end

2970#

!--- The switchport configurations on the Catalyst 2900/3500XL
!--- and on the 2970 are identical, for the purposes of this
!--- document. Remember that the Catalyst 2970 has 10/100/1000
!--- ports (1000Base-T), so the interfaces in this output
!--- would instead be labeled Gigabit Ethernet 0/1, 0/2,
!--- and so forth.

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3500XL
!
interface FastEthernet0/1
 switchport mode trunk

!--- This port is an ISL trunk.

!
interface FastEthernet0/2
 switchport access vlan 2

!--- This port is in VLAN 2.

!
interface FastEthernet0/3

!--- This port is in the default VLAN 1.

!
interface FastEthernet0/4
!
!
interface VLAN1
 ip address 10.1.1.100 255.255.0.0

!--- This is the IP address of the management interface.

 no ip directed-broadcast
 no ip route-cache
!
snmp-server engineID local 000000090200000AF484CC80
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
 transport input none
 stopbits 1
line vty 0 4
 login
line vty 5 15
 login
!
end

Verificación

Esta sección proporciona la información para confirmar que su configuración está trabajando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • show interface fa0/1 switchport — Verifique el estatus del trunk en el 2900/3500XL o la 2970 y vea qué VLA N son activos.

    3500XL# show interface fa0/1 switchport
    
    Name: Fa0/1
    Switchport: Enabled
    Administrative mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: ALL
    Trunking VLANs Active: 1,2
    Pruning VLANs Enabled: 2-1001
    
    Priority for untagged frames: 0
    Override vlan tag priority: FALSE
    Voice VLAN: none
    Appliance trust: none
    Self Loopback: No
    3500XL#
  • demostración vlan — Verifique que los puertos en el 2900/3500XL o la 2970 estén asignados a los VLA N correctos.

    3500XL# show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14,
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18,
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22,
                                                    Fa0/23, Fa0/24, Gi0/1, Gi0/2
    2    VLAN0002                         active    Fa0/2
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        0      0
    1003 tr    101003     1500  -      -      -        -    -        0      0
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0
    3500XL#
  • show interface bvi 1 — Verifique que interfaces BVI 2948G-L3 y el Line Protocol sean ambas para arriba en el 2948G-L3.

    2948G-L3# show interface bvi 1
    
    BVI1 is up, line protocol is up
      Hardware is BVI, address is 0001.c75c.680a (bia 0000.0000.0000)
      Internet address is 10.1.1.1/16
      MTU 1500 bytes, BW 10000 Kbit, DLY 5000 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set
      ARP type: ARPA, ARP Timeout 04:00:00
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue 0/0 (size/max)
    2948G-L3#
  • muestre el Bridge 1 — Verifique ese Bridge 1 está remitiendo. También puede verificar que el Protocolo de árbol de expansión esté habilitado y el reenvío con un comando show spanning-tree.

    2948G-L3# show bridge 1
    
    Total of 300 station blocks, 299 free
    Codes: P - permanent, S - self
    
    Bridge Group 1:
    
        Address       Action   Interface
    00ee.1e9f.50c0   forward   Fa1.1
    
    2948G-L3#

Troubleshooting

Esta sección proporciona las extremidades y la salida de muestra para ayudar a resolver problemas su configuración.

  • Verifique que pueda realizar ping con el otro dispositivo.

  • Verifique que las PC puedan realizar ping a las demás PC en otras VLAN.

  • Asegúrese de que el default gateway esté correcto. En este escenario, la gateway predeterminada es la respectiva BVI en la 2948G-L3.

2948G-L3# ping 10.1.1.100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/12 ms

2948G-L3# show arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.2.2.2                -   0030.40d6.4008  ARPA   BVI2
Internet  10.1.1.1                -   0030.40d6.400a  ARPA   BVI1
Internet  10.1.1.100              1   00ee.1e9f.50c0  ARPA   BVI1
2948G-L3#

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 12019