Switches : Switches Cisco Catalyst de la serie 6500

Configuración y solución de problemas de IP MLS en switches Catalyst 6500/6000 con MSFC

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (19 Septiembre 2015) | Comentarios


Contenido


Introducción

Este documento es una guía para la verificación y lectura de comandos de Multilayer Switching (MLS) en el Catalyst 6500/6000. El documento contiene un estudio muy breve sobre qué es MLS, y también ofrece ejemplos de cómo utilizar MLS. Basándose en estos ejemplos, este documento muestra cómo verificar el funcionamiento de MLS y proporciona breves consejos de troubleshooting para configurar MLS.

Este documento se aplica solamente al Catalyst 6500/6000 Series Switch equipado del hardware siguiente:

  • Supervisor Engine 1A que funciona con el software del Catalyst OS (CatOS)

  • Policy Feature Card (PFC)

  • (MSFC) de la Multilayer Switch Feature Card

Nota: Este documento es inválido al usar cualquier otra configuración del hardware tal como Supervisor Engine 2 o módulo multilayer switch (MS). Es también inválido al funcionar con el software de Cisco IOS� en el Supervisor Engine 1A y el MSFC.

Para información similar sobre el Unicast Routing del troubleshooting en un Catalyst 6500/6000 Series Switch con el Supervisor Engine 2 y el software CatOS corriente, refiera al Unicast IP Routing del Troubleshooting que implica el CEF en los Catalyst 6500/6000 Series Switch con un Supervisor Engine 2 y un software del sistema corriente de CatOS.

Para una descripción más completa de la terminología y el funcionamiento MLS, consulte la sección Información Relacionada.

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

prerrequisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Catalyst 6500/6000 con un MSFC

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Información general de MLS en MSFC

El MSFC es el motor de ruteo de segunda generación para el switch Catalyst de la serie 6500/6000 que puede rutear 15 millones de paquetes por segundo. El MSFC trabaja solamente con los motores del supervisor que tienen el PFC. El MSFC realiza un MLS interno con el PFC, que actúa similar al Netflow Feature Card (NFFC) en el Catalyst 5000. Este MLS interno no es visible y es puramente limitado al Switch: usted no tiene nada que configurar para hacer que trabaja y soporta los accesos directos por hardware para el IP, el IPX, y el Multicast IP. La configuración de la MSFC es similar a la configuración de un RSM o una RSFC mediante interfaces de VLAN. Puede acceder mediante el uso de la sesión 15 (para MSFC en el Supervisor Engine en la ranura 1) o la sesión 16 (para MSFC en el Supervisor Engine en la ranura 2).

El principio es similar al protocolo multilayer switching (MLSP) en el Catalyst 5000. El primer paquete es ruteado por el MSFC, y el PFC crea un acceso directo que sea utilizado por todos los paquetes subsiguientes del mismo flujo. A diferencia del MLSP en el Catalyst 5000, que requiere la comunicación IP entre el MLS-SE y el MLS-RP, el MLS en el Catalyst 6500/6000 trabaja por la comunicación entre el MSFC y el PFC sobre un canal serial (SCP).

El PFC no puede ser el MLS-SE para un entorno MLS del Catalyst 5000; sin embargo, el MSFC puede ser MLS-RP para el otro Catalyst 5000s en la red. En ese caso, usted debe configurar el MSFC usando el mismo comando mls rp ip que usted para cualquier router del Cisco IOS usado como el MLS RP.

/image/gif/paws/10566/mls.gif

Ejemplo 1: Ruteo de MSFC entre dos VLAN

El MLS en el Catalyst 6500/6000 para IP de unidifusión es plug and play. No es necesario configurarlo. Abajo está una configuración de muestra donde doméstico es un Catalyst 6500/6000, que tiene un doméstico-MSFC llamado MSFC. El ruteo entre VLAN 11 y 12 se configura en la MSFC sin un sólo comando relacionado con MLS. Tenga en cuenta que el Supervisor Engine no tendrá ninguna configuración específica de MLS.

tamer-msfc#wr t 
Building configuration... 

Current configuration: 
! 
version 12.1 
no service pad 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname tamer-msfc 
! 
boot system flash bootflash:c6msfc-ds-mz.121-1.E2.bin 
! 
ip subnet-zero 
ip cef 
! 
interface Vlan11 
 ip address 11.1.1.2 255.255.255.0 
! 
interface Vlan12 
 ip address 12.1.1.2 255.255.255.0 
! 
router eigrp 1 
 network 11.0.0.0 
 network 12.0.0.0 
 no auto-summary 
! 
ip classless 
no ip http server 
! 
! 
line con 0 
 transport input none 
line vty 0 4 
 login 
! 
end

Lectura de entradas show mls y verificación básica

Abajo está la salida que usted debe conseguir al publicar el comando show mls en el Supervisor Engine.

tamer (enable) show mls 
Total packets switched = 8      

!--- Number of packet shortcuted by MLS.

Total Active MLS entries = 0      

!--- Number of flows currently existing.

MSFC 11.1.1.2 (Module 15) entries = 0 
IP Multilayer switching aging time = 256 seconds 
IP Multilayer switching fast aging time = 0 seconds, packet threshold = 0 
IP Current flow mask is Destination flow 
Active IP MLS entries = 0 
Netflow Data Export version: 7 
Netflow Data Export disabled 
Netflow Data Export port/host is not configured. 
Total packets exported = 0 

IP MSFC ID      Module XTAG MAC               Vlans 
--------------- ------ ---- ----------------- ---------------- 
11.1.1.2        15     1    00-d0-d3-9c-9e-3c 12,11      

!--- MSFC recognized by the switch.

La salida del comando show mls debe siempre tener un MSFC ID IP. Si usted no ve el MSFC ID IP cuando usted publica el comando show mls, verifique el siguiente:

  • El MSFC es en servicio (no pegado en el modo ROMMON, por ejemplo).

  • El MLS todavía se habilita en el MSFC.

Puede verificarlo mediante la ejecución de los siguientes comandos en la MSFC:

tamer-msfc#show mls status 
MLS global configuration status: 
global mls ip:                     enabled     

!--- Should be enabled for unicast IP.

global mls ipx:                    enabled 
global mls ip multicast:           disabled 
current ip flowmask for unicast:   destination only 
current ipx flowmask for unicast:  destination only 

Mediante la ejecución del comando show mls status, puede determinar si el MLS está habilitado para IP, IPX y multidifusión IP. Estas características se deben habilitar siempre por abandono; sin embargo, pueden inhabilitarse si se ejecuta el siguiente comando en el modo configuración:

no mls ip

El comando no mls ip sólo se debe usar para propósitos de depuración. El comando está también disponible como comando oculto en el modo de configuración global. Usted puede también inhabilitar el MLS sobre una base de la interfaz del por el VLAN publicando el comando no mls ip en el modo de configuración de la interfaz

Nota: No publique el comando show mls rp en el MSFC. Esta salida de comando indica que el MLS está inhabilitado. Sin embargo, la salida del comando show mls publicó en el antedicho del Supervisor Engine indicado que el MLS trabajaba correctamente. Esta discrepancia ocurre porque el comando show mls rp debe ser utilizado al hacer el MLS-RP conjuntamente con un Catalyst 5000 Switch.

tamer-msfc#show mls rp 
ip multilayer switching is globally disabled 
ipx multilayer switching is globally disabled 
ipx mls inbound acl override is globally disabled 
mls id is 00d0.d39c.9e04 
mls ip address 0.0.0.0 
mls ip flow mask is unknown 
mls ipx flow mask is unknown 
number of domains configured for mls 0

Un paquete candidato es un paquete que puede potencialmente iniciar la configuración de un acceso directo MLS. Su dirección MAC del destino es igual a la dirección MAC de un router que ejecuta el MLS. En este caso, la dirección MAC del MSFC es 00-d0-d3-9c-9e-3c (se obtiene ejecutando el comando show mls). Para verificar que el Switch sepa que esta dirección MAC sea un Router MAC Address, publique el comando show cam mac_address, como se muestra abajo.

tamer (enable) show cam 00-d0-d3-9c-9e-3c 
* = Static Entry. + = Permanent Entry. # = System Entry. R = Router Entry. 
X = Port Security Entry 
VLAN  Dest MAC/Route Des    [CoS]  Destination Ports or VCs / [Protocol Type] 
----  ------------------    -----  ------------------------------------------- 
11    00-d0-d3-9c-9e-3c R#          15/1 
12    00-d0-d3-9c-9e-3c R#          15/1 
Total Matching CAM Entries Displayed = 2

Esta salida confirma que el Switch sabe que esta dirección MAC es una entrada del router conectada al puerto 15/1 (puerto MSFC en el slot 1).

Si usted todavía no ve el MSFC cuando usted publica el comando show mls en el Supervisor Engine del Switch, publique el siguiente comando:

tamer (enable) show mls rlog l2 
SWLOG at 815d0c50: magic 1008, size 51200, cur 815d4170, end 815dd460 
Current time is: 08/08/00,17:13:25 

118 08/08/00,17:13:16:(RouterConfig)Router_cfg: router_add_MAC_to_earl 00-d0-d3-
9c-9e-3c  added for mod 15/1 Vlan 12 Earl AL =0 
117 08/08/00,17:13:16:(RouterConfig)Router_Cfg: Process add mls entry for mod 15
/1 vlan 12, i/f 1, proto 0, LC 3 
116 08/08/00,17:13:16:(RouterConfig)Router_cfg: router_add_MAC_to_earl 00-d0-d3-
9c-9e-3c  added for mod 15/1 Vlan 11 Earl AL =0 
115 08/08/00,17:13:16:(RouterConfig)Router_Cfg: Process add mls entry for mod 15
/1 vlan 11, i/f 1, proto 0, LC 3

Este comando le muestra que los mensajes que el Switch está recibiendo del MSFC, y que las entradas del router están agregadas.

Lectura de tablas de resultados del comando show mls

Ejecute el comando show mls entry para visualizar la tabla MLS entera con todos los accesos directos. La siguiente salida muestra todos los flujos recibidos.

tamer (enable) show mls entry 
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
10.68.5.1       -               -     -      -      00-d0-00-3f-a3-ff 8    ARPA 
12.1.1.1        -               -     -      -      00-00-0c-8c-70-88 12   ARPA 
11.1.1.1        -               -     -      -      00-00-0c-09-50-66 11   ARPA 
ESrc DPort  SPort  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 1/3    7/3    4          400         00:00:02 00:00:02 
ARPA 7/4    7/3    4          400         00:00:08 00:00:08 
ARPA 7/3    7/4    9          900         00:00:08 00:00:08 


Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  Stat-Pkts  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 

Total entries displayed: 2 
tamer (enable)

Nota: Un flujo se crea por el destino. Un ping de 12.1.1.1 a 11.1.1.1 creará dos flujos (uno para cada dirección), según lo indicado por las dos líneas más recientes en la salida mostrada arriba.

Los siguientes son algunas descripciones de la información que se encuentra en la tabla:

  • Destination IP (IP de destino), source IP (IP de origen), Prot, DstPrt y SrcPrt son los campos que se utilizan para crear accesos directos. En este caso, se utiliza el flujo del destino solamente. Solamente el IP Address de destino de un flujo se oculta. Esto puede ser cambiada modificando el flowmask, que se describe más adelante en este documento.

  • El destino MAC es una dirección MAC que se usará para volver a escribir el destino MAC de un paquete. La dirección MAC de origen se reescribe con la dirección MAC de la MSFC.

  • El VLA N indica el VLAN de destino necesario para alcanzar esa dirección IP. El VLAN de destino es importante, por ejemplo, si el paquete necesita ser enviado en un trunk.

  • DPort y Sport son el destino y el puerto de origen del flujo.

  • Stat-Pkts y Stat-Bytes proporcionan estadísticas sobre la cantidad de paquetes que ha utilizado este acceso directo desde la creación del flujo.

  • El tiempo de actividad es el tiempo transcurrido desde que se creó el flujo.

  • La edad es el tiempo transcurrido puesto que el flujo era último usado.

Cambie el flujo a la destino-fuente. La salida del comando show mls entry visualiza la dirección IP de origen y el IP Address de destino está ocultando. Un diverso flujo para cada dirección IP de origen que comunica al mismo IP Address de destino ahora se crea, como se muestra abajo.

tamer (enable) set mls flow destination-source 
Configured IP flowmask is set to destination-source flow. 
Warning: Configuring more specific flow mask may increase the number of MLS 
 entries dramatically. 
tamer (enable) 2000 Aug 09 17:05:12 %MLS-5-FLOWMASKCHANGE:IP flowmask changed 
 from DEST to DEST-SRC 

tamer (enable) show mls entry 
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
11.1.1.1        12.1.1.1        -     -      -      00-00-0c-09-50-66 11   ARPA 
11.1.1.1        10.68.5.1       -     -      -      00-00-0c-09-50-66 11   ARPA 
10.68.5.1       11.1.1.1        -     -      -      00-d0-00-3f-a3-ff 8    ARPA 
12.1.1.1        11.1.1.1        -     -      -      00-00-0c-8c-70-88 12   ARPA 
MSFC 0.0.0.0 (Module 16): 

ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 7/3    7/4    4          400         00:00:02 00:00:02 
ARPA 7/3    1/3    4          400         00:00:32 00:00:32 
ARPA 1/3    7/3    4          400         00:00:32 00:00:32 
ARPA 7/4    7/3    4          400         00:00:02 00:00:02 


Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Pkts  Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 
MSFC 0.0.0.0 (Module 16): 


Total entries displayed: 4
tamer (enable)

La tercera opción es fijar MLS a flujo completo. Realice algunos ping y sesiones telnets para ver cómo los diversos flujos se crean para cada puerto TCP. A continuación se muestra cómo debe verse la tabla MLS luego de realizar algunas sesiones ping y Telnet. Al utilizar este flujo, la cantidad de flujos creados aumenta muy rápidamente. La información de puerto TCP se oculta, y aparece en la tabla MLS.

tamer (enable) set mls flow full 
Configured IP flowmask is set to full flow. 
Warning: Configuring more specific flow mask may increase the number of MLS 
 entries dramatically. 
Tamer (enable) 2000 Aug 09 17:30:01 %MLS-5-FLOWMASKCHANGE:IP flowmask changed
 from DEST to FULL 

tamer (enable) 
tamer (enable) show mls entry 
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
12.1.1.1        11.1.1.1        ICMP  -      -      00-00-0c-8c-70-88 12   ARPA 
11.1.1.1        12.1.1.1        TCP   11001  Telnet 00-00-0c-09-50-66 11   ARPA 
12.1.1.1        11.1.1.1        TCP*  Telnet 11001  00-00-0c-8c-70-88 12   ARPA 
11.1.1.1        10.68.5.1       TCP   11002  Telnet 00-00-0c-09-50-66 11   ARPA 
10.68.5.1       11.1.1.1        ICMP  -      -      00-d0-00-3f-a3-ff 8    ARPA 
10.68.5.1       11.1.1.1        TCP*  Telnet 11002  00-d0-00-3f-a3-ff 8    ARPA 
11.1.1.1        10.68.5.1       ICMP  -      -      00-00-0c-09-50-66 11   ARPA 
11.1.1.1        12.1.1.1        ICMP  -      -      00-00-0c-09-50-66 11   ARPA 

ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 7/4    7/3    4          400         00:00:30 00:00:30 
ARPA 7/3    7/4    16         688         00:00:26 00:00:24 
ARPA 7/4    7/3    18         757         00:00:26 00:00:24 
ARPA 7/3    1/3    61         4968        00:00:16 00:00:06 
ARPA 1/3    7/3    4          400         00:00:33 00:00:33 
ARPA 1/3    7/3    69         2845        00:00:17 00:00:06 
ARPA 7/3    1/3    4          400         00:00:33 00:00:33 
ARPA 7/3    7/4    4          400         00:00:32 00:00:31 

  
Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  Stat-Pkts  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 

Total entries displayed: 8

Notas

  • En una red en funcionamiento, el número de flujos creados puede estar hasta varios millares. Publique el IP de la entrada de los mls de la demostración [destino|comando de la fuente] de visualizar el flujo específico en vez de visualizar la tabla del flujo completo, como se muestra abajo.

    tamer (enable) show mls entry ip destination 12.1.1.1 
    
    Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
    --------------- --------------- ----- ------ ------ ----------------- ---- ---- 
    
    MSFC 11.1.1.2 (Module 15): 
    12.1.1.1        -               -     -      -      00-00-0c-8c-70-88 12   ARPA 
    
    
    ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
    ---- ------ ------ ---------- ----------- -------- -------- 
    ARPA 7/4    7/3    4          400         00:00:30 00:00:30 
    
  • Usted puede verificar las estadísticas para el flujo publicando el comando show mls statistics, como se muestra abajo.

    tamer (enable) show mls statistics entry ip 15 
                                      Last    Used 
    Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
    --------------- --------------- ---- ------ ------ ---------- --------------- 
    MSFC 11.1.1.2 (Module 15): 
    12.1.1.1        11.1.1.1        ICMP -      -      9          900 
    11.1.1.1        10.68.5.1       TCP  11005  Telnet 20         913 
    11.1.1.1        10.68.5.1       TCP  11004  Telnet 0          0 
    10.68.5.1       11.1.1.1        ICMP -      -      4          400 
    10.68.5.1       12.1.1.1        ICMP -      -      9          900 
    12.1.1.1        10.68.5.1       ICMP -      -      4          400 
    11.1.1.1        10.68.5.1       ICMP -      -      4          400 
    11.1.1.1        12.1.1.1        ICMP -      -      9          900

Solución de problemas en una conexión específica

Si tiene problemas de conectividad en una dirección IP específica o entre dos hosts específicos, intente con la siguiente solución de problemas:

  • Publique el IP de la entrada de los mls de la demostración [destino|comando de la fuente] de ver si se ha creado el flujo.

  • Publique la entrada de estadísticas de los mls de la demostración [fuente|comando del destino] varias veces en fila de ver si los contadores del stat-pakts para ese acceso directo están aumentando.

  • Verifique el flujo relevante.

Por ejemplo, para una sesión FTP de un archivo grande entre el servidor TFTP 12.1.1.1 y el cliente TFTP 11.1.1.1, usted necesita verificar los dos flujos siguientes:

  • Uno con destino 12.1.1.1 que debería acertarse sólo por el reconocimiento de TFTP (paquete pequeño) (origen del flujo 12.1.1.1 si se utiliza el flujo de origen y destino).

  • Uno con destino 11.1.1.1 que debe ser encontrado por muchos paquetes grandes (la transferencia de archivos real) (origen del flujo 11.1.1.1 si se utiliza el flujo destino-origen).

    Éste es un ejemplo del TFTP entre 12.1.1.1. y 11.1.1.1 de un archivo alrededor del 7.6 MB. A continuación se observa la tabla de estadísticas MLS antes del comienzo del TFTP:

    tamer (enable) show mls statistics entry 
                                      Last    Used 
    Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
    --------------- --------------- ---- ------ ------ ---------- --------------- 
    MSFC 11.1.1.2 (Module 15): 
    12.1.1.1        11.1.1.1        ICMP -      -      4          400 
    11.1.1.1        12.1.1.1        ICMP -      -      4          400 
    12.1.1.1        11.1.1.1        TCP  11000  Telnet 20         894
    

El TFTP acaba de comenzar. Los dos flujos adicionales creados para el tráfico TFTP (puerto UDP 69) se muestran a continuación.

tamer (enable) show mls statistics entry 
                                  Last    Used 
Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
--------------- --------------- ---- ------ ------ ---------- --------------- 
MSFC 11.1.1.2 (Module 15): 
12.1.1.1        11.1.1.1        ICMP -      -      4          400 
12.1.1.1        11.1.1.1        UDP  69     50532  343        10997 
11.1.1.1        12.1.1.1        ICMP -      -      4          400 
11.1.1.1        12.1.1.1        UDP  50532  69     343        186592 
12.1.1.1        11.1.1.1        TCP  11000  Telnet 20         894

La transferencia TFTP apenas terminada. Se transfieren aproximadamente 8.1 MB desde el servidor al cliente en 14,903 paquetes, lo cual implica un promedio de 544 bytes de tamaño para cada paquete. En la otra dirección, la misma cantidad de paquetes se recibe con los tamaños promedios de 476,949 divididos por 14,904, que hace 33 bytes.

Tamer (enable) show mls statistics entry 
                                  Last    Used 
Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
--------------- --------------- ---- ------ ------ ---------- --------------- 
MSFC 11.1.1.2 (Module 15): 
12.1.1.1        11.1.1.1        ICMP -      -      4          400 
12.1.1.1        11.1.1.1        UDP  69     50532  14904      476949 
11.1.1.1        12.1.1.1        ICMP -      -      4          400 
11.1.1.1        12.1.1.1        UDP  50532  69     14903      8107224 
12.1.1.1        11.1.1.1        TCP  11000  Telnet 20         894

Estas tablas deben darle una idea de lo que debe parecer su patrón de tráfico.

Ejemplo 2: Dos MSFC en el mismo chasis configurado para HSRP

Abajo está la configuración corriente de los dos MSFC configurados para el HSRP y la salida del comando show standby. El MSFC en el slot 15 es activo para el VLAN 12, y el MSFC en el slot 16 es activo para el VLAN 11.

Ranura 15 Ranura 16
tamer-msfc#wr t 
Building configuration... 

Current configuration: 
! 
version 12.1 
no service pad 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname tamer-msfc 
! 
boot system flash bootflash:
  c6msfc-ds-mz.121-1.E2.bin 
! 
ip subnet-zero 
ip cef 
! 
! 
! 
! 
interface Vlan1 
 ip address 10.200.11.120 255.255.252.0 
! 
interface Vlan8 
 ip address 10.68.5.2 255.255.252.0 
! 
interface Vlan11 
 ip address 11.1.1.2 255.255.255.0 
 no ip redirects 
 standby 11 preempt 
 standby 11 ip 11.1.1.3 
! 
interface Vlan12 
 ip address 12.1.1.2 255.255.255.0 
 no ip redirects 
 standby 12 priority 105 preempt 
 standby 12 ip 12.1.1.3 
! 
router eigrp 1 
 network 10.0.0.0 
 network 11.0.0.0 
 network 12.0.0.0 
 no auto-summary 
! 
ip classless 
! 
line con 0 
 transport input none 
line vty 0 4 
 login 
! 
end
tamer-msfc-2#wr t 
Building configuration... 

Current configuration: 
! 
version 12.1 
no service pad 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname tamer-msfc-2 
! 
boot system flash
  bootflash:c6msfc-jsv-mz.121-2.E.bin 
! 
ip subnet-zero 
!
! 
! 
! 
interface Vlan1 
 ip address 10.200.11.121 255.255.252.0 
! 
interface Vlan8 
 ip address 10.68.5.4 255.255.252.0 
! 
interface Vlan11 
 ip address 11.1.1.4 255.255.255.0 
 no ip redirects 
 standby 11 priority 105 preempt 
 standby 11 ip 11.1.1.3 
! 
interface Vlan12 
 ip address 12.1.1.4 255.255.255.0 
 no ip redirects 
 standby 12 preempt 
 standby 12 ip 12.1.1.3 
! 
router eigrp 1 
 network 10.0.0.0 
 network 11.0.0.0 
 network 12.0.0.0 
 no auto-summary 
! 
ip classless!  
! 
line con 0 
 transport input none 
line vty 0 4 
 login 
! 
end


tamer-msfc>show standby 
Vlan11 - Group 11 
  Local state is Standby, priority 100,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:00.814 
  Hot standby IP address is 11.1.1.3 configured 
  Active router is 11.1.1.4 expires in 00:00:09 
  Standby router is local 
  Standby virtual MAC address is 0000.0c07.ac0b 
  4 state changes, last state change 00:06:36 
Vlan12 - Group 12 
  Local state is Active, priority 105,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:02.380 
  Hot standby IP address is 12.1.1.3 configured 
  Active router is local 
  Standby router is 12.1.1.4 expires in 00:00:09 
  Standby virtual MAC address is 0000.0c07.ac0c 
  2 state changes, last state change 00:12:22
tamer-msfc-2#show standby 
Vlan11 - Group 11 
  Local state is Active, priority 105,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:02.846 
  Hot standby IP address is 11.1.1.3 configured 
  Active router is local 
  Standby router is 11.1.1.2 expires in 00:00:08 
  Standby virtual MAC address is 0000.0c07.ac0b 
  2 state changes, last state change 00:07:02 
Vlan12 - Group 12 
  Local state is Standby, priority 100,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:02.518 
  Hot standby IP address is 12.1.1.3 configured 
  Active router is 12.1.1.2 expires in 00:00:07,
   priority 105 
  Standby router is local 
  Standby virtual MAC address is 0000.0c07.ac0c 
  4 state changes, last state change 00:04:08

La información del ejemplo anterior todavía es válida. Para verificar qué ha cambiado después de configurar el HSRP, vea la salida de los comandos mls abajo.

Activación de comandos show mls

tamer (enable) show mls 
Total packets switched = 29894 
Total Active MLS entries = 0 
  MSFC 11.1.1.2 (Module 15) entries = 0 
  MSFC 10.200.11.121 (Module 16) entries = 0 
IP Multilayer switching aging time = 256 seconds 
IP Multilayer switching fast aging time = 0 seconds, packet threshold = 0 
IP Current flow mask is Full flow 
Active IP MLS entries = 0 
Netflow Data Export version: 7 
Netflow Data Export disabled 
Netflow Data Export port/host is not configured. 
Total packets exported = 0 
IP MSFC ID      Module XTAG MAC               Vlans 
--------------- ------ ---- ----------------- ---------------- 
11.1.1.2        15     1    00-d0-d3-9c-9e-3c 12,11,8,1 
                            00-00-0c-07-ac-0c 12 

10.200.11.121   16     2    00-d0-bc-f0-07-b0 1,8,11,12 
                            00-00-0c-07-ac-0b 11 
  

IPX Multilayer switching aging time = 256 seconds 
IPX flow mask is Destination flow 
IPX max hop is 15 
Active IPX MLS entries = 0 

IPX MSFC ID     Module XTAG MAC               Vlans 
--------------- ------ ---- ----------------- ---------------- 
11.1.1.2        15     1    -                 - 

10.200.11.121   16     2    -                 -
  • Ahora hay dos routeres MLS vistos por el PFC.

  • Para cada router mostrado, la dirección MAC que utiliza el grupo HSRP es 00-00-0c-07-ac-xx. Estas direcciones MAC son las direcciones MAC virtuales usadas por el HSRP. Sólo puede observar la dirección MAC del grupo 11 conectado al router que está activado para dicho grupo (ranura 15 para VLAN 12 y ranura 16 para VLAN 11). Eso significa que además de los paquetes con la dirección MAC del destino que es la dirección MAC MSFC, los paquetes candidato también están considerados, que son paquetes con el MAC de destino que es la dirección HSRP.

  • Como se afirma en el primer ejemplo, usted también necesita ver este a la dirección HSRP en la tabla CAM de la capa 2 que señala al MSFC.

tamer (enable) show cam 00-00-0c-07-ac-0c 
* = Static Entry. + = Permanent Entry. # = System Entry. R = Router Entry. 
X = Port Security Entry 

VLAN  Dest MAC/Route Des    [COs]  Destination Ports or VCS / [Protocol Type] 
----  ------------------    -----  ------------------------------------------- 
12    00-00-0c-07-ac-0c R#          15/1 
Total Matching CAM Entries Displayed = 1 
tamer (enable) 

tamer (enable) show cam 00-00-0c-07-ac-0b 
* = Static Entry. + = Permanent Entry. # = System Entry. R = Router Entry. 
X = Port Security Entry 

VLAN  Dest MAC/Route Des    [COs]  Destination Ports or VCS / [Protocol Type] 
----  ------------------    -----  ------------------------------------------- 
11    00-00-0c-07-ac-0b R#          16/1 
Total Matching CAM Entries Displayed = 1 
tamer (enable)

Ejecución de comandos de entrada show mls

tamer (enable) show mls entry
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
11.1.1.1        12.1.1.1        ICMP  -      -      00-00-0c-09-50-66 11   ARPA 
MSFC 10.200.11.121 (Module 16): 
12.1.1.1        11.1.1.1        ICMP  -      -      00-10-7b-3b-af-3b 12   ARPA 

ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 7/3    7/4    4          400         00:00:03 00:00:03 
ARPA 7/4    7/3    4          400         00:00:04 00:00:03 


Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  Stat-Pkts  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 
MSFC 10.200.11.121 (Module 16):

  • Ahora hay dos tablas de accesos directos: uno para los flujos creados por la MSFC y otro para los flujos creados por la segunda MSFC.

  • Haciendo ping entre 11.1.1.1 y 12.1.1.1, que son dos PC configuraron con la dirección HSRP como su default gateway, los paquetes de 12.1.1.1 a 11.1.1.1 que venía en el VLAN 12 en el Switch shortcuted por el MSFC en el slot 15 (pues es el router HSRP activo para el VLAN 12), y acceso directo para destino 11.1.1.1 es creado por el MSFC en el slot 15. Los accesos directos para los paquetes de 11.1.1.1 a 12.1.1.1 han sido creados en el otro extremo por el MSFC en el slot 16.

Consejos de Troubleshooting

Creación de los flujos

Si no se ha creado un flujo, utilice los siguientes consejos para la resolución de problemas:

  • ¿Observa el Supervisor Engine la MSFC con todas las direcciones MAC esperadas al ejecutar el comando show mls?

    • Si sí, vaya al siguiente paso.

    • Si ningún, aseegurese que el MSFC no está pegado en el modo ROMMON. Verificar que MLS esté habilitado en MSFC activando el comando show mls status.

  • ¿La dirección MAC del MSFC está presente cuando se ejecuta el comando show cam? ¿Aparece como una entrada de router cam (R#)?

  • Verifique que no haya configurado una función en la MSFC que desactiva MLS.

    • Verifique las funciones que podrían impactar el MLS con la revisión de las notas de versión para la versión del software que está ejecutando.

    • Los ejemplos de restricciones se muestran en la tabla abajo.

      Restricciones de IP de los comandos del router

      Comando Comportamiento
      borre la ruta de IP Borra todas las entradas de caché MLS para todos los switches que realizan conmutación de Capa 3 para esta MSFC.
      ip routing La opción no borra todas las entradas de caché MLS y desactiva IP MLS en esta MSFC.
      Seguridad del IP (todas las formas de este comando) Inhabilita el IP MLS en la interfaz.
      compresión-conexiones tcp del IP Inhabilita el IP MLS en la interfaz.
      Compresión del encabezado ip tcp Inhabilita el IP MLS en la interfaz.

  • Verifique que usted haya habilitado una lista de acceso que pide el software que dirige en vez del proceso por los accesos directos por hardware. Refiera a dirección del hardware y software de IOS ACL para más información.

Si después de seguir todos los consejos mencionados anteriormente todavía experimenta problemas, verifique si la MSFC todavía esta siendo alcanzada por muchos paquetes.

  • Algo puede hacer las entradas ser purgado continuamente. Entre las causas posibles de la purga de la tabla de flujo se puede incluir lo siguiente:

    • Inestabilidad de ruta o cualquier inestabilidad de la capa 3.

    • La memoria caché de ARP cambia en la MSFC.

    • La máscara de flujo cambió en Supervisor Engine.

    • La VLAN de destino está eliminada.

    • La interfaz VLAN se cierra en la MSFC.

  • Otras razones para el reenvío del software (paquete que consultan la MSFC) en lugar de accesos directos por hardware pueden incluir lo siguiente:

    • Paquete con la configuración de opción de IP.

    • Paquete con TTL inferior o igual 1.

    • Paquete que necesita ser hecho fragmentos.

  • Usted puede tener hasta 128 K del flujo, sin embargo, se utiliza un algoritmo de troceo. Si usted excede 32k los flujos, usted puede comenzar a tener colisión del hash que cause los paquetes que son ruteados por el software.

    • Una manera de evitar tener demasiados flujos es configurar un envejecimiento rápido para el flujo MLS.

  • Recuerde que sólo puede tener MLS para IP, IPX e IP de multidifusión. Si tiene otros tipos de tráfico (por ejemplo, AppleTalk), serán software enrutado y pueden causar picos de la CPU en la MSFC o paquete excesivo que se dispara en el MSFC.

  • Como se detalló, los IP MLS e IPX MLS están activados de forma predeterminada, esto no sucede con los IP MLS multidifusión. Si está utilizando la multidifusión de IP, asegúrese de habilitar MLS para la multidifusión tal como se especifica en la guía de configuración.

Nota: Una notificación del cambia la topología del árbol de expansión (TCN) o los puertos inestables en un Catalyst 6500/6000 Series Switch no hará la tabla del flujo MLS ser borrada, al igual que el caso para el MLS en los Catalyst 5000 Switch.

Las estadísticas IP excluyen el tráfico MLS

En las Cisco Catalyst 6500 Series, se despliega la transferencia de la capa múltiple (MLS) de una manera tal que una vez que se establece un flujo, el tráfico se conmute directamente en el PFC (conmutado por hardware) y no sea procesado por el MSFC, por lo tanto la falta de estadísticas continuas. Los solamente nuevos o process-switched flujos (conmutados por software) son registrados por las estadísticas IP cuando están habilitados, e incluso después solamente hasta la entrada ingresados en la base de datos. Así, el mensaje de advertencia anterior se visualiza normalmente cuando usted habilita las estadísticas IP en tal plataforma.

6500(config)#int fa8/40
6500(config-if)#ip accounting
Accounting will exclude mls traffic when mls is enabled.

La Contabilización de Netflow es el método preferido. Refiera a configurar el Netflow para más información que mira al Netflow.

Incapaz de configurar el flowmask interfaz-FULL

C6500#mls flow ip interface-full
%  Unable to configure flow mask for ip protocol: interface-full. Reset
to the default flow mask type: none

Publique el comando detail del flowmask del fie del fm de la demostración y verifiquelo si el NAT se habilita y utiliza la máscara del flujo completo de Intf.

C6500#show fm fie flowmask detail

!--- Part of the output not shown

Primary Flowmasks registered by Features
----------------------------+------------------------+------------------
---
          Feature                   Flowmask             Flowmask Status
----------------------------+------------------------+------------------
---
 IP_ACCESS_INGRESS               Intf Full Flow		Disabled/Unused
 IP_ACCESS_EGRESS                Intf Full Flow		Disabled/Unused
 NAT_INGRESS                     Intf Full Flow            Enabled
 NAT_EGRESS                      Intf Full Flow            Enabled

!--- Remaining part of the output not shown

Si el NAT utiliza la máscara del flujo completo de Intf y cuando usted intenta configurar el interfaz-FULL para el Netflow, hay un problema, pues hay un conflicto del flowmask. Si usted quiere utilizar el stat del Netflow, usted puede intentar utilizar la interfaz-destino-fuente (los mls fluyen comando de la interfaz-destino-fuente del IP), que no está en conflicto con el uso de la máscara del Netflow.

El NDE asume que todos los flujos están creados con la misma máscara del flujo. Debido a esta restricción, el NDE no se puede habilitar con ciertas características que requieran las máscaras en conflicto del flujo. Un caso específico es NAT acelerado por hardware. El NDE y el NAT acelerado por hardware son mutuamente - exclusiva.

El NDE falla si ocurren ninguno de estos eventos:

  • Se habilita el NAT acelerado por hardware.

  • Dos o más características con las máscaras en conflicto del flujo se han configurado en el Switch.

Inversamente, una vez que el NDE se configura con éxito, el NAT no se puede configurar para trabajar en el hardware y dos diversas características con los requisitos en conflicto de la máscara del flujo no se pueden configurar en el Switch.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 10566