Modo de transferencia asíncrona (ATM) : Switching y túneles VP (ruta virtual)

LANE, CES y VBR PVC en túneles VP modelados

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento muestra una configuración de muestra del LAN Emulation (LANE), del Circuit Emulation Service (CES), y de las conexiones virtuales permanentes del Velocidad de bits variable (VBR) (PVC) en los túneles formados del trayecto virtual (VP). En la configuración mostrada en este documento, el LANE, el CES, y el bit variable tarifa-NON (VBR-NRT) PVC en tiempo real se transportan a través de WAN. El uso de estos ejemplos formó los túneles VP para asegurar la conformidad con los contratos de tráfico. Cuando el usar formó los túneles VP con los parámetros del tráfico idénticos al proveedor de servicio, la red ATM del proveedor de servicio no debe caer ninguna células.

El túnel VP debe estar Velocidad de bits constante (CBR) de la categoría de servicio para ser formado: es el único túnel modelado que Cisco soporta actualmente. Usted debe tener tres túneles VP porque el LANE utiliza las conexiones virtuales conmutadas de la Velocidad de bit sin especificar (UBR) (SVC), las aplicaciones CBR PVC CES, usted tiene un VBR PVC, y usted está utilizando los túneles formados VP. Usted tiene uno para cada categoría de servicio: Canales virtuales CBR (VCs) y UBR VCs. Usted habría podido utilizar un túnel usando los túneles del VP jerárquico.

prerrequisitos

Requisitos

Quienes lean este documento deben tener conocimiento de los siguientes temas:

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Software Release 11.3(0.8)TWA4 ASP del � del Cisco IOS o más adelante para el LightStream1010 (LS1010)

  • Cualquier versión de Cisco 8540-MSR

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Suposición

El ejemplo mostrado en este documento asume estos hechos:

  • Los túneles modelados deben estar de la categoría de servicio CBR, así que este ejemplo tiene un túnel VP CBR que pueda contener solamente CBR VCs. Se utiliza para CES CBR PVC (etiquetado VPI1 en el diagrama de la red). Observe que el número del identificador de trayecto virtual (VPI) está localmente - significativo al puerto del switch, así que a usted puede tener el mismo número del VPI en el mismo Switch, pero dos diversos puertos del switch.

  • Porque los túneles formados VP no pueden transportar simultáneamente VCs de las categorías de servido servicio múltiple, el primer túnel VP usado para CBR VCs no se puede utilizar para LANE UBR VCs o el VBR-NRT PVC. Usted debe crear otro túnel VP para el LANE (que utiliza la categoría de servicio VCs UBR). Por lo tanto, el segundo túnel VP (etiquetado VPI2 en el diagrama de la red) es un túnel VP CBR-formado a través de las cuales solamente se permite el UBR VCs.

  • Un túnel VP modelado del tercero transporta el VBR-NRT PVC (etiquetado VPI3 en el diagrama de la red).

  • Usted necesita comprar tres CBR VP del proveedor de servicio.

  • Se asume que los tres CBR VP tienen una velocidad de célula de cresta (PCR) de 10 Mbps y una tolerancia de variación de retraso de celda (CDVT) de 500 células. Observe que la suma de los PCR de todos los túneles VP definida en la misma interfaz física debe ser más pequeña del 95 por ciento de la línea tarifa de la interfaz física (si se asume que solamente los túneles VP están configurados en la interfaz física).

  • Para el VBR PVC, la velocidad continua de celda (SCR) del PVC debe ser más pequeña del 95 por ciento del PCR del túnel VP CBR-formado. Es decir el PVC SCR debe ser más pequeño que el 9.5 Mbps para el VBR-NRT. Si hay múltiple el VBR PVC que pasa con el CBR hace un túnel, la suma de los SCR de todo el VBR PVC debe ser más pequeño del 95 por ciento del PCR del túnel VP modelado. Sigue habiendo el 5 por ciento es reservado para los protocolos obligatorios de señalización y otros.

  • El dispositivo 5500-asp-f está para el VP Switching. El proveedor de servicio realiza típicamente esta función.

  • Definen a los servicios LANe en 8540-MSR; El (LECs) de los LAN Emulation Clients se define en 8540-MSR y 5500-asp-e.

    Nota: En este ejemplo, ponen a los servicios LANe en el switch ATM para la simplicidad. Ésa no es, sin embargo, la ubicación óptima para los servicios LANe. El mejor lugar para un LAN Emulation Server (LES) o el broadcast y servidor desconocidos (BUS) está en el módulo LANE de un Catalyst 5500. El lugar ideal para un LEC está en un Cisco 7500 Series Router.

  • Los dos intercambios de central privada (PBX) en el uso del diagrama un circuito CES CBR. Para los detalles en cómo configurar la emulación de circuito, refiera a configurar los Circuit Emulation Service.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Haga clic en el Switches en este diagrama para ver las configuraciones de muestra:

/image/gif/paws/10493/PVPshap.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

configuración de muestra 5500-asp-e

5500-asp-e
5500-asp-e# show running-config

Building configuration...
Current configuration:
!
version 11.3
no service pad
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname 5500-asp-e
!
boot system flash slot0:LS1010-wp-mz.120-3c.W5.9.bin
!
ip host-routing
!
atm connection-traffic-table-row index 63997 vbr-nrt pcr 20480 scr10 9000  mbs 100
atm connection-traffic-table-row index 64000 cbr pcr 10240  cdvt 500
atm lecs-address-default 47.0091.8100.0000.0090.2144.8401.0090.2144.8405.00 1
atm address 47.0091.8100.0000.0050.537e.1401.0050.537e.1401.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
!
!
interface CBR10/0/0
 no ip address
 ces circuit 0 circuit-name test
 ces pvc 0 interface ATM11/0/1.6 vpi 6 vci 100
!
interface ATM11/0/1
 no atm signaling enable
 no ip address
 atm pvp 5 shaped rx-cttr 64000 tx-cttr 64000
 atm pvp 6 shaped rx-cttr 64000 tx-cttr 64000
 atm pvp 7 shaped rx-cttr 64000 tx-cttr 64000
!
interface ATM11/0/1.5 point-to-point
 atm cac service-category cbr deny
 atm cac service-category ubr permit
!
interface ATM11/0/1.6 point-to-point
!
interface ATM11/0/1.7 point-to-point
 atm cac service-category cbr deny
 atm cac service-category vbr-nrt permit
 atm pvc 7 100 rx-cttr 63997 tx-cttr 63997  interface  ATM10/1/0 0 100
!
interface ATM11/0/2
 no ip address
!
interface ATM11/0/3
 no ip address
!
interface ATM11/1/0
 no ip address
!
interface ATM11/1/1
 no ip address
!
interface ATM11/1/2
 no ip address
!
interface ATM11/1/3
 no ip address
!
interface ATM13/0/0
 no ip address
 atm maxvp-number 0
!
interface ATM13/0/0.1 multipoint
 ip address 100.100.100.2 255.255.255.0
 lane client ethernet test
!
interface Ethernet13/0/0
 no ip address
!
no ip classless
logging buffered 16000 debugging
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Visualización de características

Usted puede utilizar los comandos show en esta sección de verificar las características de configuración en el dispositivo. La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Usted puede utilizar los comandos show adicionales de verificar la configuración; no todos se incluyen en este documento.

Para asegurarse de que todo el LANE VCs vaya a través del túnel VP correcto (es decir evitar la señalización de la iniciación a través de la interfaz principal), señalando se inhabilita en la interfaz atm11/0/1 usando el comando no atm signaling enable. La misma operación se ha realizado en el 8540-MSR.

Para ver qué VCs está pasando a través del túnel VP con un VPI de 7, publique el comando show atm vc interface interface-number:

5500-asp-e# show atm vc interface atm11/0/1.7

Interface    VPI   VCI   Type    X-Interface  X-VPI X-VCI  Encap Status

ATM11/0/1.7  7     3      PVC     ATM13/0/0    0     181   SNAP   UP
ATM11/0/1.7  7     4      PVC     ATM13/0/0    0     182   SNAP   UP
ATM11/0/1.7  7     5      PVC     ATM13/0/0    0     180   QSAAL  UP
ATM11/0/1.7  7     16     PVC     ATM13/0/0    0     179   ILMI   UP
ATM11/0/1.7  7     18     PVC     ATM13/0/0    0     183   PNNI   UP
ATM11/0/1.7  7     100    PVC     ATM10/1/0    0     100          UP

5500-asp-e# show atm interface resource atm11/0/1.7

Resource Management configuration:
    Service Categories supported: vbr-nrt
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none vbr,
        Peak-cell-rate TX: none vbr,
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none vbr,
        CDVT TX: none vbr,
        MBS: none vbr RX, none vbr TX
Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 613 vbr RX, 613 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 9114 vbr RX, 9114 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

5500-asp-e# show atm interface resource atm11/0/1

Resource Management configuration:
    Service Classes:
        Service Category map: c1 cbr, c2 vbr-rt, c3 vbr-nrt, c4 abr, c5 ubr
        Scheduling: RS c1 WRR c2, WRR c3, WRR c4, WRR c5
        WRR Weight: 8 c2, 1 c3, 1 c4, 1 c5
    Pacing: disabled   0 Kbps rate configured, 0 Kbps rate installed
    Service Categories supported: cbr,vbr-rt,vbr-nrt,abr,ubr
    Link Distance: 0 kilometers
    Controlled Link sharing:
        Max aggregate guaranteed services: none RX,  none TX
        Max bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
        Min bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none cbr, none vbr, none abr, none ubr
        Peak-cell-rate TX: none cbr, none vbr, none abr, none ubr
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX: none abr, none ubr
        Minimum-cell-rate TX: none abr, none ubr
        CDVT RX: none cbr, none vbr, none abr, none ubr
        CDVT TX: none cbr, none vbr, none abr, none ubr
        MBS: none vbr RX, none vbr TX

Resource Management state:
    Available bit rates (in Kbps):
        117023 cbr RX, 117023 cbr TX, 117023 vbr RX, 117023 vbr TX,
        117023 abr RX, 117023 abr TX, 117023 ubr RX, 117023 ubr TX
    Allocated bit rates:
        30720 cbr RX, 30720 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Best effort connections: 0 pvcs,  4 svcs

configuración de muestra 5500-asp-f

El Switch se configura para el VP Switching.

5500-asp-f
5500-asp-f# show running-config

Building configuration...
Current configuration:
!
version 11.3
no service padservice timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 5500-asp-f
!
!
!
atm connection-traffic-table-row index 63997 vbr-nrt pcr 20480 scr10 9000  mbs 100
atm connection-traffic-table-row index 64000 cbr pcr 10240  cdvt 500
atm address 47.0091.8100.0000.0050.5308.2401.0050.5308.2401.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
!
!
interface ATM11/0/0
 no ip address
!
interface ATM11/0/1
 no ip address
 atm pvp 5  interface  ATM11/0/0 10
 atm pvp 6 rx-cttr 64000 tx-cttr 64000 interface ATM11/0/0 6 rx-cttr 64000 tx-cttr 64000
 atm pvp 7 rx-cttr 63997 tx-cttr 63997 interface ATM11/0/0 7 rx-cttr 63997 tx-cttr 63997
!
interface ATM13/0/0
 no ip address
 atm maxvp-number 0
!
interface Ethernet13/0/0
 no ip address
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Visualización de las características

Para verificar que el VP sea operativo, publique el comando show atm vp:

5500-asp-f# show atm vp

Interface    VPI    Type  X-Interface     X-VPI     Status
ATM11/0/0    6       PVP     ATM11/0/1    6         UP
ATM11/0/0    7       PVP     ATM11/0/1    7         UP
ATM11/0/0    10      PVP     ATM11/0/1    5         UP
ATM11/0/1    5       PVP     ATM11/0/0    10        UP
ATM11/0/1    6       PVP     ATM11/0/0    6         UP
ATM11/0/1    7       PVP     ATM11/0/0    7         UP

Configuración de muestra 8540-MSR

8540-MSR
8540-MSR# show running-config

Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 8540-MSR
!
logging buffered 4096 debugging
!
redundancy
 main-cpu
  sync config startup
  sync config running
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
ip subnet-zero
!
atm connection-traffic-table-row index 63997 vbr-nrt pcr 20480 scr10 9000  mbs 100
atm connection-traffic-table-row index 63998 cbr pcr 10000
atm connection-traffic-table-row index 63999 cbr pcr 10240  cdvt 500
atm lecs-address-default 47.0091.8100.0000.0090.2144.8401.0090.2144.8405.00 1
atm address 47.0091.8100.0000.0090.2144.8401.0090.2144.8401.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
!
lane database PVP
  name test server-atm-address 47.009181000000009021448401.009021448403.01
!
!
interface CBR1/0/0
 no ip address
 no ip directed-broadcast
 shutdown
 ces circuit 0 circuit-name test
 ces pvc 0 interface ATM2/1/0.6 vpi 6 vci 100
!
interface ATM2/1/0
 no atm signaling enable
 no ip address
 no ip directed-broadcast
 atm pvp 6 shaped rx-cttr 63999 tx-cttr 63999
 atm pvp 7 shaped rx-cttr 63999 tx-cttr 63999
 atm pvp 10 shaped rx-cttr 63999 tx-cttr 63999
!
interface ATM2/1/0.6 point-to-point
 no ip directed-broadcast
!
interface ATM2/1/0.7 point-to-point
 no ip directed-broadcast
 atm cac service-category cbr deny
 atm cac service-category vbr-nrt permit
 atm pvc 7 100 rx-cttr 63997 tx-cttr 63997  interface  ATM1/1/0 0 100
!
interface ATM2/1/0.10 point-to-point
 no ip directed-broadcast
 atm cac service-category cbr deny
 atm cac service-category ubr permit
!
interface ATM2/1/1
 no ip address
 no ip directed-broadcast
!
interface ATM2/1/2
 no ip address
 no ip directed-broadcast
!
interface ATM2/1/3
 no ip address
 no ip directed-broadcast
!
interface ATM0
 no ip address
 no ip directed-broadcast
 atm maxvp-number 0
 lane config auto-config-atm-address
 lane config database PVP
!
interface ATM0.1 multipoint
 ip address 100.100.100.1 255.255.255.0
 no ip directed-broadcast
 lane server-bus ethernet test
 lane client ethernet test
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
!
ip classless
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end

Visualización de características

Usted puede utilizar los comandos show en esta sección de verificar las características de configuración en el dispositivo.

8540-MSR# show atm interface resource atm2/1/0.7

Resource Management configuration:
    Service Categories supported: vbr-nrt
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none vbr,
        Peak-cell-rate TX: none vbr,
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none vbr,
        CDVT TX: none vbr,
        MBS: none vbr RX, none vbr TX
Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 613 vbr RX, 613 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 9114 vbr RX, 9114 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

8540-MSR# show atm interface resource atm2/1/0

Resource Management configuration:
    Service Classes:
        Service Category map: c2 cbr, c2 vbr-rt, c3 vbr-nrt, c4 abr, c5 ubr
        Scheduling: RS c1 WRR c2, WRR c3, WRR c4, WRR c5
        WRR Weight: 8 c2, 1 c3, 1 c4, 1 c5
    Pacing: disabled   0 Kbps rate configured, 0 Kbps rate installed
    Service Categories supported: cbr,vbr-rt,vbr-nrt,abr,ubr
    Link Distance: 0 kilometers
    Controlled Link sharing:
        Max aggregate guaranteed services: none RX,  none TX
        Max bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
        Min bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none cbr, none vbr, none abr, none ubr
        Peak-cell-rate TX: none cbr, none vbr, none abr, none ubr
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX: none abr, none ubr
        Minimum-cell-rate TX: none abr, none ubr
        CDVT RX: none cbr, none vbr, none abr, none ubr
        CDVT TX: none cbr, none vbr, none abr, none ubr
        MBS: none vbr RX, none vbr TX

Resource Management state:
    Available bit rates (in Kbps):
        117023 cbr RX, 117023 cbr TX, 117023 vbr RX, 117023 vbr TX,
        117023 abr RX, 117023 abr TX, 117023 ubr RX, 117023 ubr TX
    Allocated bit rates:
        30720 cbr RX, 30720 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Best effort connections: 0 pvcs,  0 svcs

8540-MSR# show atm interface resource atm2/1/0.6

Resource Management configuration:
    Service Categories supported: cbr
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none cbr,
        Peak-cell-rate TX: none cbr,
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none cbr,
        CDVT TX: none cbr,

Resource Management state:
    Available bit rates (in Kbps):
        9727 cbr RX, 9727 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        1741 cbr RX, 1741 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

8540-MSR# show atm interface resource atm2/1/0.7

Resource Management configuration:
    Service Categories supported: vbr-nrt
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none vbr,
        Peak-cell-rate TX: none vbr,
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none vbr,
        CDVT TX: none vbr,
        MBS: none vbr RX, none vbr TX

Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 613 vbr RX, 613 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 9114 vbr RX, 9114 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

8540-MSR# show atm interface resource atm2/1/0.10

Resource Management configuration:
    Service Categories supported: ubr
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none ubr
        Peak-cell-rate TX: none ubr
        Minimum-cell-rate RX: none ubr
        Minimum-cell-rate TX: none ubr
        CDVT RX: none ubr
        CDVT TX: none ubr

Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada

Haga clic para ver la configuración del switch 5500-asp-e. Haga clic para ver la configuración del switch 5500-asp-f. Haga clic para ver la configuración del 8540-MSR Switch.


Document ID: 10493