Switching por etiquetas multiprotocolo (MPLS) : Switching por etiquetas multiprotocolo por ATM (MPLS over ATM)

MPLS sobre túneles VP

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Un proveedor de servicio normalmente le da uno o más túneles del trayecto virtual (VP) para conectar sus dispositivos juntos en vez de un vículo físico de punto a punto. Este documento explica los pasos necesarios configurar el Multiprotocol Label Switching (MPLS) cuando usted utiliza los túneles VP.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/10476/mpls_vptunnel-1.gif

En esta configuración, el proveedor de servicio ha suministrado dos túneles VP:

  • Uno entre el Ischia y el Capri con VPI= 3 (identificador de trayecto virtual)

  • Uno entre el Alcazaba y el Capri con VPI= 4

El Ischia y el Alcazaba son dos Cisco 7200 Router que funcionan con el Software Release 12.1(3a)E del½ del¿Â del Cisco IOSïÂ. El Capri es un router de switch multiservicio del Catalyst 8540 (MSR) esa versión de los funcionamientos 12.0(10)W5(18c). El Capri es un vecino del (TDP) del Tag Distribution Protocol del Alcazaba y del Ischia.

Nota: Usted debe funcionar con la versión 12.0(3)T o más arriba para configurar esta característica.

Las configuraciones usadas aquí están para un Catalyst 8500 MSR, o LightStream1010, y un router.

Configuraciones

En este documento, se utilizan estas configuraciones:

Ischia
ip cef 
! 
interface Loopback0 
 ip address 1.1.1.1 255.255.255.0 
! 
interface ATM2/0.3 tag-switching 
 ip address 3.0.0.1 255.255.255.0 
 tag-switching atm vp-tunnel 3 
 tag-switching ip 
! 
router ospf 6 
 log-adjacency-changes 
 network 1.1.1.1 0.0.0.0 area 0 
 network 3.0.0.0 0.0.0.255 area 0 

Alcazaba
 ip cef 
! 
interface Loopback0 
 ip address 2.2.2.2 255.255.255.0 
! 
interface ATM4/0.4 tag-switching 
 ip address 4.0.0.1 255.255.255.0 
 tag-switching atm vp-tunnel 4 
 tag-switching ip 
! 
router ospf 6 
 log-adjacency-changes 
 network 2.2.2.2 0.0.0.0 area 0 
 network 4.0.0.0 0.0.0.255 area 0 

Capri
 interface ATM3/1/1 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 atm pvp 3 
 atm pvp 4 
! 
interface ATM3/1/1.3 point-to-point 
 ip address 3.0.0.2 255.255.255.0 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 tag-switching ip 
! 
interface ATM3/1/1.4 point-to-point 
 ip address 4.0.0.2 255.255.255.0 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 tag-switching ip 

Nota: Esta configuración es similar a las configuraciones de router estándar que usted puede encontrar aquí. La única diferencia es que usted tiene que especificar al router que usted utiliza un túnel VP. Usted puede hacer esto con el comando tag-switching atm vp-tunnel vpi, donde está el valor el vpi del VPI que se asocia al túnel ese los extremos en este router.

Nota: Para el LightStream1010 y el Catalyst 8500 MSR, usted necesita configurar uno o más trayectos virtuales permanentes (PVP) para cada túnel VP con el comando atm pvp vpi. Vea aquí para una configuración de muestra. Una subinterfaz se asocia a cada uno de estos túneles. Por ejemplo, la interfaz ATM 3/1/1.3 se asocia al PVP=3. Usted debe configurar esta subinterfaz con el Tag Switching, como usted hace en la interfaz principal.

Verificación

Utilice estos comandos show del Tag Switching de probar que su red actúa correctamente:

  • show tag-switching tdp neighbor

  • muestre los atascamientos del Tag Switching ATM-TDP — Esto muestra la información dinámica de la etiqueta atmósfera.

  • muestre la tabla de reenvío del Tag Switching — Esto muestra el (TFIB) del Tag Forwarding Information Base.

  • show tag-switching interfaces atm [int number] detail — Esto muestra la información de Tag Switching detallada para cada interfaz.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Esta salida es un resultado de estos comandos entered en los dispositivos mostrados en el diagrama de la red.

Ischia#show tag-switching tdp neighbor
Peer TDP Ident: 10.200.10.57:1; Local TDP Ident 1.1.1.1:1
        TCP connection: 3.0.0.2.11001 - 3.0.0.1.711
        State: Oper; PIEs sent/rcvd: 92/93; ; Downstream on demand
        Up time: 01:16:52
        TDP discovery sources:
          ATM2/0.3
 
Ischia#show tag-switching atm-tdp bindings 
 Destination: 4.0.0.0/24
    Headend Router ATM2/0.3 (1 hop) 3/33  Active, VCD=127
 Destination: 1.1.1.0/24
    Tailend Router ATM2/0.3 3/33 Active, VCD=127
 Destination: 2.2.2.2/32
    Headend Router ATM2/0.3 (2 hops) 3/34  Active, VCD=128
 
Ischia#show tag-switching forwarding-table 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
26     3/33        4.0.0.0/24        0          AT2/0.3    point2point  
27     3/34        2.2.2.2/32        0          AT2/0.3    point2point   
 
Ischia#show tag-switching interfaces detail 
Interface ATM2/0.3:
        IP tagging enabled
        TSP Tunnel tagging not enabled
        Tagging operational
        Tagswitching turbo vector
        MTU = 4470
        ATM tagging:
                Tag VPI = 3 (VP Tunnel)
                Tag VCI range = 33 - 65535
                Control VC = 3/32
 
Capri#show tag-switching atm-tdp bindings 
 Destination: 4.0.0.0/24
    Tailend Switch ATM3/1/1.3 3/33 Active -> Terminating Active
 Destination: 1.1.1.1/32
    Transit ATM3/1/1.4 4/33 Active -> ATM3/1/1.3 3/33 Active
 Destination: 3.0.0.0/24
    Tailend Switch ATM3/1/1.4 4/34 Active -> Terminating Active
 Destination: 2.2.2.2/32
    Transit ATM3/1/1.3 3/34 Active -> ATM3/1/1.4 4/33 Active
 
Capri#show tag-switching tdp neighbor 
Peer TDP Ident: 1.1.1.1:1; Local TDP Ident 10.200.10.57:1
        TCP connection: 3.0.0.1.711 - 3.0.0.2.11001
        State: Oper; PIEs sent/rcvd: 95/94; ; Downstream on demand
        Up time: 01:18:49
        TDP discovery sources:
          ATM3/1/1.3
Peer TDP Ident: 2.2.2.2:1; Local TDP Ident 10.200.10.57:2
        TCP connection: 4.0.0.1.711 - 4.0.0.2.11002
        State: Oper; PIEs sent/rcvd: 93/95; ; Downstream on demand
        Up time: 01:18:22
        TDP discovery sources:
          ATM3/1/1.4
 
Capri#show tag-switching interfaces detail 
Interface ATM3/1/1.3:
        IP tagging enabled
        TSP Tunnel tagging not enabled
        Tagging operational
        MTU = 4470
        ATM tagging: Tag VPI = 3, Control VC = 3/32
Interface ATM3/1/1.4:
        IP tagging enabled
        TSP Tunnel tagging not enabled
        Tagging operational
        MTU = 4470
        ATM tagging: Tag VPI = 4, Control VC = 4/32

Esta salida es similar a la salida estándar del Tag Switching, pero una diferencia importante es que señala al interfaz del túnel VP.


Información Relacionada


Document ID: 10476