Switching por etiquetas multiprotocolo (MPLS) : Switching por etiquetas multiprotocolo por ATM (MPLS over ATM)

MPLS sobre la atmósfera: Fusión de VC

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra del Multiprotocol Label Switching (MPLS) sobre la atmósfera usando la fusión del virtual circuit (VC).

prerrequisitos

Requisitos

Antes de que usted intente esta configuración, asegúrese de que usted tenga una comprensión básica de la atmósfera, del MPLS, y del Open Shortest Path First (OSPF).

Componentes Utilizados

Utilice uno de este Routers para implementar esta configuración:

  • Router switch de borde de etiqueta (LSR) — Cualquier router de ATM que funcione con el Software Release 12.0 o Posterior del ½ del ¿Â de Cisco IOSïÂ, con el MPLS ofrece. Esta configuración utiliza a los Cisco 3600 Series Router que funcionan con el Cisco IOS Software Release 12.1(3)T y a un Cisco 7200 Router que funcione con el Cisco IOS Software Release 12.0(8)S.

  • Atmósfera LSR — Cualquier switch ATM tal como el LightStream1010 o Catalyst 85xx MSR. Cisco recomienda que usted utiliza el WA4.8d de la versión de software o más adelante. El LightStream1010 requiere una espera de PerFlow de la placa de función (FC-PFQ).

Usted puede encontrar una descripción más exacta de las plataformas admitidas en el diseño del MPLS para la atmósfera.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Refiera a estos links para más información sobre la configuración de MPLS y los convenios:

  • El recurso de la fusión del VC se estandardiza en la Multiprotocol Label Switching Architecture de la Fuerza de tareas de ingeniería en Internet (IETF) (IETF) y el MPLS usando los documentos del Protocolo de distribución de etiquetas (LDP) y del VC Switching atmósfera. Usted puede acceder ambos documentos de la carta IETF MPLSleavingcisco.com .

  • Usted puede encontrar las instrucciones de configuración en el MPLS sobre la documentación atmósfera.

  • La dimensionalización del número de VCs utilizó en una red MPLS se cubre en la sección de dimensionalización del espacio del VC de la escritura de la etiqueta MPLS de diseñar el MPLS para la atmósfera.

Antecedentes

El recurso de la fusión del VC permite que un Switch agregue los flujos entrantes múltiples con la misma dirección destino en un solo flujo saliente. Dondequiera que ocurra la fusión del VC, varias etiquetas entrantes se asocian a una sola etiqueta saliente. Las células de diversos identificadores de canal virtual (VCIs) que vayan al mismo destino se transmiten al mismo VC saliente con el uso de las conexiones de la de múltiples puntos-a-punta. Esta distribución de las escrituras de la etiqueta reduce el número total de VCs requirió para el switching por etiquetas. Sin la fusión del VC, cada trayectoria (con el mismo router de ingreso y la misma clase equivalente de reenvío (FEC)) consume un VC de la escritura de la etiqueta en cada interfaz a lo largo de la trayectoria. La fusión del VC reduce la escasez de espacio de etiquetado compartiendo las escrituras de la etiqueta para diversos flujos con el mismo destino, es decir, el mismo FEC.

Esta figura muestra un ejemplo de la fusión del VC. En esta figura, el Routers A y B envían el tráfico para prefijar 171.69.0.0/16 en el C del router. El switch ATM en el centro se configura con un solo VCI 50 saliente limitado para prefijar 171.69.0.0/16. Los flujos de datos del Routers A y B se juntan en el switch ATM y comparten el mismo VC saliente. Las células que vienen del VCI 40 y del VCI 70 están mitigadas en las colas de entrada del switch ATM hasta que se reciban las tramas completas AAL5. La trama completa entonces se remite al C del router en el VCI 50.

/image/gif/paws/10475/mpls_vcmerge1.gif

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza esta configuración de red:

/image/gif/paws/10475/mpls_vcmerge2.gif

Configuraciones

En este ejemplo, se utilizan los identificadores del trayecto virtual ATM (VPIs) 2,3, o 4. Pero, no es obligatorio especificar qué trayectos virtuales (VP) se utilizan para el MPLS.

Configure el Cisco Express Forwarding (CEF) IP en el Routers. Si usted utiliza a un Cisco 7500 Router, usted debe asegurarse de que habiliten al comando ip cef distributed.

Este documento usa estas configuraciones.

Router 1
!
interface Loopback0
 ip address 223.0.0.12 255.255.255.255
!
interface Loopback1
 ip address 100.100.1.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 100.100.0.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 network 100.100.0.0 0.0.0.255 area 10
 network 100.100.1.0 0.0.0.255 area 10
 network 223.0.0.12 0.0.0.0 area 10
!

Router 2
!
ip cef
!
interface Loopback0
 ip address 223.0.0.11 255.255.255.255
!
interface Ethernet0/1
 ip address 100.100.0.1 255.255.255.0
!
interface ATM1/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
!
interface ATM1/0.1 label-switching
 ip address 10.0.0.2 255.255.255.252
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 100.100.0.0 0.0.0.255 area 10
 network 223.0.0.11 0.0.0.0 area 0
!

Router 3
!
ip cef
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Loopback1
 ip address 200.200.0.1 255.255.255.255
!
interface ATM4/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal
 !
 pvc ilmi 0/16 ilmi
 !
!
interface ATM4/0.1 label-switching
 ip address 10.0.0.6 255.255.255.252
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 redistribute static
 network 10.0.0.0 0.0.0.255 area 0
 network 200.200.0.0 0.0.0.255 area 20
 network 223.0.0.21 0.0.0.0 area 0
!
ip route 158.0.0.0 255.0.0.0 Null0
!

Router 4
!
ip cef
!
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
 no ip directed-broadcast
! 
interface Loopback1
 ip address 150.150.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM4/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no atm ilmi-keepalive
!
interface ATM4/0.1 label-switching
 ip address 10.0.0.13 255.255.255.252
 no ip directed-broadcast
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 150.150.0.0 0.0.255.255 area 30
 network 223.0.0.3 0.0.0.0 area 0
!
ip route 150.150.150.0 255.255.255.0 Null0
!

ATM Switch 1
!
interface Loopback0
 ip address 223.0.0.1 255.255.255.255
 no ip directed-broadcast
!
interface ATM4/1/2
 ip address 10.0.0.1 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
interface ATM4/1/3
 ip address 10.0.0.21 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.1 0.0.0.0 area 0
!

ATM Switch 2
!
interface Loopback0
 ip address 223.0.0.2 255.255.255.255
 no ip directed-broadcast
!
interface ATM0/1/0
 ip address 10.0.0.14 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!         
interface ATM0/1/2
 ip address 10.0.0.5 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
interface ATM0/1/3
 ip address 10.0.0.22 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.2 0.0.0.0 area 0
!

Verificación

Esta sección proporciona la información que usted puede utilizar para confirmar que su configuración trabaja correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • muestre la capacidad del Tag Switching ATM-TDP

  • muestre los atascamientos del Tag Switching ATM-TDP

  • show atm vc

Publique el comando show tag atm-tdp para obtener la información sobre la fusión de VC. Esta salida, generada por el comando show tag-switching atm-tdp capability, muestra que la fusión de VC está habilitada en estas interfaces:

ATMswitch2#show tag-switching atm-tdp capability 
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/0       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 1023]   UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 1023]   UNIDIR           -    -    
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/2       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 1018]   UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 1018]   UNIDIR           -    -    
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/3       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 16383]  UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 16383]  UNIDIR           -    -

Usted también puede marcar la fusión del VC para un FEC determinado – por ejemplo, 100.100.1.1/32 – como se ve en esta salida:

ATMswitch2#show tag atm-tdp bindings
Destination: 100.100.1.1/32
    Transit ATM0/1/2 2/47 Active -> ATM0/1/3 2/52 Active
    Transit ATM0/1/0 2/47 Active -> ATM0/1/3 2/52 Active

ATMswitch2#show atm vc
Interface  VPI  VCI   Type   X-Interface     X-VPI X-VCI Encap  Status
ATM0/1/0    2    47   TVC(I) ATM0/1/3          2   52           UP
ATM0/1/2    2    47   TVC(I) ATM0/1/3          2   52           UP
ATM0/1/3    2    52   TVC(O) ATM0/1/2          2   47           UP
                             ATM0/1/0          2   47           UP

Si la fusión del VC no trabaja (o si se inhabilita con el comando no tag-switching atm vc-merge), usted recibe esta salida de comando:

ATMswitch2#show tag atm-tdp bindings
Destination: 100.100.1.1/32
    Transit ATM0/1/2 2/38 Active -> ATM0/1/3 2/35 Active
    Transit ATM0/1/0 2/43 Active -> ATM0/1/3 2/43 Active

ATMswitch2#show atm vc
Interface  VPI  VCI   Type   X-Interface     X-VPI X-VCI Encap  Status
ATM0/1/0   2    43    TVC(I) ATM0/1/3          2   43           UP
ATM0/1/2   2    38    TVC(I) ATM0/1/3          2   35           UP
ATM0/1/3   2    35    TVC(O) ATM0/1/2          2   38           UP
ATM0/1/3   2    43    TVC(O) ATM0/1/0          2   43           UP

Usted puede ver de esta salida que inhabilitar la función de la fusión del VC lleva al sistema usando muchos más VCs.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 10475