Switching por etiquetas multiprotocolo (MPLS) : Switching por etiquetas multiprotocolo por ATM (MPLS over ATM)

MPLS VPN sobre ATM: con el OSPF en el lado del cliente (sin el área 0)

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra de un Multiprotocol Label Switching (MPLS) VPN sobre la atmósfera cuando el Open Shortest Path First (OSPF) está presente en el lado del cliente, sin el área 0.

La característica del Red privada virtual (VPN), cuando está utilizada con el MPLS, permite que varios sitios transparente interconecten a través de la red de un proveedor de servicio. Una red proveedora de servicios puede ofrecer soporte a varias VPN IP diferentes Cada una de éstas le aparece a sus usuarios como una red privada, separada de todas las otras redes. Dentro de una VPN, cada sitio puede enviar paquetes IP a cualquier otro sitio dentro de la misma VPN

prerrequisitos

Requisitos

Cada VPN está asociada con uno o más casos de reenvío o ruteo VPN (VRF). Un VRF consiste en una tabla de IP Routing, un Cisco Express Forwarding (CEF) derivado, la tabla y un conjunto de las interfaces que utilizan esta tabla de reenvío.

El router mantiene un ruteo separado y una tabla CEF para cada VRF. Con esto, la información no se puede enviar fuera del VPN pero la misma subred se puede utilizar en varios VPN sin los problemas de IP Address duplicado.

El router que utiliza el Border Gateway Protocol (BGP) distribuye la información de VPN Routing con las comunidades ampliadas BGP.

Para más información con respecto a la difusión de actualizaciones con un VPN, refiera a estos URL:

Versiones de hardware y de software

Estas cartas representan los diversos tipos de Routers y de Switches usados:

  • P: Router del núcleo del proveedor

  • PE: Router de borde del proveedor

  • CE: Router borde del cliente

  • C: Router del cliente

Desarrollamos y probamos la configuración con estas versiones de software y hardware:

  • Routers PE:

    • Software: Software Release 12.1(3)T del½ del¿Â del Cisco IOSïÂ. Las características del MPLS VPN aparecen en la versión 12.0(5)T. El OSPF como Routing Protocol PE-CE aparece en la versión 12.0(7)T.

    • Hardware Los Cisco 3660 o 7206 Router. Para los detalles del otro hardware que usted puede utilizar, refiera al MPLS de diseño para la guía atmósfera.

  • Routers CE: Utilice a cualquier router que pueda intercambiar la información de ruteo por su router PE.

  • Routers P y switches: La función de la integración del MPLS VPN reside solamente al borde de la red MPLS, así que utilice cualquier switch con MPLS habilitado. En la configuración de muestra, la nube MPLS se compone de 8540 MSR y un LightStream1010. Si usted utiliza el LightStream1010, recomendamos que usted utiliza el WA4.8d de la versión de software o más arriba. Usted puede también utilizar el otro Switches ATM, tal como el Cisco BPX 8650 o el MGX8850 en la red del núcleo atmósfera.

Convenciones

Este diagrama muestra una configuración típica que utilice a estos convenios:

/image/gif/paws/10472/mpls_ospf4.gif

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Información previa de OSPF información

Tradicionalmente, red OSPF elaborada consiste en una área de estructura básica (área 0) y varias áreas conectadas con esta estructura básica a través de un router del borde del área (ABR).

Con una estructura básica MPLS para el VPN con el OSPF en el sitio del cliente, usted puede introducir un tercer nivel en la jerarquía del modelo de OSPF. Este tercer nivel se llama la estructura básica súper del MPLS VPN.

En los casos simples, la estructura básica súper del MPLS VPN se combina con la estructura básica de la área tradicional 0. Esto significa que no hay area 0 backbone en la red del cliente puesto que la estructura básica súper del MPLS VPN desempeña el mismo papel que el area 0 backbone. Esto se muestra en este diagrama:

/image/gif/paws/10472/mpls_ospf1.gif

Este diagrama ilustra esta información:

  • El Routers del límite del proveedor (PE) es ABR y Routers del Autonomous System Boundary Router (ASBR).

  • El Routers del límite del cliente (CE) es routeres para OSPF simples.

  • La información de VPN se transporta a través de las comunidades ampliadas BGP de los PE a otros PE y se reinyecta en las áreas OSPF como Red de resumen (anuncios del estado del vínculo del tipo 3) (LSA).

La estructura básica súper del MPLS VPN también permite a los clientes para utilizar las estructuras básicas de la área múltiple 0 en sus sitios. Cada sitio puede tener un área separada 0 mientras esté conectado con la estructura básica súper del MPLS VPN. El resultado es lo mismo que con una estructura básica de la área particionada 0. Esto se muestra en este diagrama:

/image/gif/paws/10472/mpls_ospf2.gif

En este caso, estas cosas ocurren:

  • El Routers PE es ABR y routeres ASBR.

  • El Routers CE es routeres ABR.

  • Los LSA que contienen la información de VPN se transportan con las comunidades ampliadas BGP de los PE a otros PE. En resumen red (transportan al tipo 3) LSA, información entre los PE y los CE.

Esta configuración de muestra se basa en la primera configuración mostrada. Usted puede encontrar una configuración de muestra que utilice la segunda configuración en el MPLS VPN sobre la atmósfera: con el OSPF en el lado del cliente (con el área 0).

La información de OSPF se transporta con los atributos de comunidad extendida de BGP (que incluyen uno que identifique la red OSPF). Cada VPN debe tener su propio proceso OSPF. Para especificar esto, usted puede utilizar este comando:

router ospf <process ID> vrf <VPN routing/forwarding instance name>

Procedimiento de Configuración

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/10472/mpls_ospf3.gif

La documentación del IOS de Cisco (redes privadas virtuales MPLS) también describe este procedimiento de configuración.

Parte I del Procedimiento de configuración

Asegúrese de que la ip cef esté habilitada. Si usted utiliza a un Cisco 7500 Router, usted debe asegurarse de que el cef del IP distribuido esté habilitado. En los PE, una vez que se configura el MPLS, realice estas tareas:

  1. Cree un VRF para cada VPN conectado con el comando ip vrf <VPN routing/forwarding instance name>. Cuando usted hace esto:

    • Especifique el discriminador de rutas adecuado usado para esa VPN. Esto se utiliza para extender la dirección IP de modo que usted pueda identificar el VPN al cual pertenece.

      rd <VPN route distinguisher>
      
    • Configure las propiedades de importación y exportación para las comunidades ampliadas BGP. Éstos se utilizan para filtrar el proceso de la importación y de la exportación.

      route-target [export|import|both] <target VPN extended community> 
      
      
  2. Configure a los detalles de reenvío para las interfaces de los respectives con este comando:

    ip vrf forwarding <table name>
    

    Recuerde configurar la dirección IP después de que usted haga esto.

  3. Dependiente sobre el Routing Protocol PE-CE que usted uso, usted debe ahora hacer uno o más de éstos:

    • Configure las Static rutas:

      ip route vrf vrf-name prefix mask [next-hop-address]
                                        [interface {interface-number}] 
      
      
    • Configure el RIP con este comando:

      address-family ipv4 vrf <VPN routing/forwarding instance name>
      

      Una vez que haya realizado esta parte, escriba los comandos de configuración de RIP normal.

      Nota: esto sólo se aplica a la interfaz de reenvío para laVRF actual

      Nota: tiene que volver a distribuir el BGP correcto en RIP. Cuando usted hace esto, también recuerde especificar el métrico que está utilizado.

    • Declare la información del vecino BGP.

    • Configure el OSPF con el nuevo comando ios:

      router ospf <process ID> vrf <VPN routing/forwarding instance name>
      

      Nota: esto sólo se aplica a la interfaz de reenvío para laVRF actual

      Nota: tiene que volver a distribuir el BGP correcto en OSPF. Cuando usted hace esto, también recuerde especificar el métrico que está utilizado.

      Nota: Una vez que usted atribuye el proceso OSPF a un VRF, este número de proceso se utiliza siempre para este VRF determinado. Esto sucede incluso si no lo especifica en la línea de comando.

Parte II del Procedimiento de configuración

Configure BGO entre los routers PE. Hay varias maneras de configurar el BGP, tal como el uso del reflector de ruta o de los métodos de confederación. El método usado aquí – configuración de vecino directo – es el más simple y lo más menos posible scalable.

  1. Declare los diferentes vecinos.

  2. Ingrese el vrf de la direccionamiento-familia ipv4 <VPN routing/forwarding instance name> para cada VPN presente en este router PE. Realice uno o más de estos pasos, cuanto sea necesario:

    • Vuelva a distribuir la información de ruteo estático.

    • Vuelva a distribuir los datos de RIP Routing.

    • ‘Vuelva a distribuir la información de ruteo de OSPF.’

    • Active a los vecinos BGP con el Routers CE.

  3. Ingrese al modo address-family vpnv4, y realice estas tareas:

    • Activar los vecinos.

    • Especifique que debe usarse la comunidad extendida. Esto es obligatorio.

Configuraciones

Nota: Solamente incluyen a las partes pertinentes de la salida aquí.

Alcazaba
ip cef
!
ip vrf vpn1
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!         
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vpn1
 ip address 222.0.0.10 255.255.255.255
!
interface Ethernet1/1
 ip vrf forwarding vpn1
 ip address 150.150.0.1 255.255.255.0
 no ip mroute-cache
!
interface ATM4/0
 no ip address
 no ip mroute-cache
 atm sonet stm-1
 no atm ilmi-keepalive
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.13 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 150.150.0.0 0.0.0.255 area 0
 network 223.0.0.3 0.0.0.0 area 0
!
router ospf 2 vrf vpn1
 log-adjacency-changes
 redistribute bgp 1 metric-type 1 subnets
 network 150.150.0.0 0.0.0.255 area 1
 network 222.0.0.0 0.0.0.255 area 1
!
router bgp 1
 neighbor 223.0.0.21 remote-as 1
 neighbor 223.0.0.21 update-source Loopback0
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended
 exit-address-family
!

Kozel
!
ip cef
!
ip vrf vpn1
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vpn1
 ip address 222.0.0.30 255.255.255.255
!         
interface Ethernet1/1
 ip vrf forwarding vpn1
 ip address 69.69.0.1 255.255.255.252
 no ip mroute-cache
 tag-switching ip
!
interface ATM4/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal
 !
 pvc ilmi 0/16 ilmi
 !
!
interface ATM4/0.1 tag-switching
 ip address 11.0.0.6 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 11.0.0.0 0.0.0.255 area 0
 network 223.0.0.21 0.0.0.0 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
router ospf 2 vrf vpn1
 log-adjacency-changes
 redistribute bgp 1 metric-type 1 subnets
 network 69.69.0.0 0.0.0.255 area 3
 network 222.0.0.0 0.0.0.255 area 3
!
router bgp 1
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 neighbor 223.0.0.11 remote-as 1
 neighbor 223.0.0.11 update-source Loopback0
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 neighbor 223.0.0.11 activate
 neighbor 223.0.0.11 send-community extended
 exit-address-family
!

Rápido
!
interface Loopback0
 ip address 222.0.0.1 255.255.255.255
!
interface Loopback2
 ip address 7.7.7.7 255.255.255.0
!         
interface FastEthernet0/1
 ip address 150.150.0.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 network 7.7.7.7 0.0.0.0 area 1
 network 150.150.0.0 0.0.0.255 area 1
 network 222.0.0.1 0.0.0.0 area 1
!

Pivrnec
!
interface Loopback0
 ip address 222.0.0.3 255.255.255.255
!
interface Loopback1
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/1
 ip address 69.69.0.2 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 6.6.6.6 0.0.0.0 area 3
 network 69.69.0.0 0.0.0.255 area 3
 network 222.0.0.3 0.0.0.0 area 3
!

Verificación

Comandos show

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  • muestre el vrf de la ruta de IP <VPN routing or forwarding instance name>

  • muestre el vrf BGP vpnv4 del IP <VPN routing or forwarding instance name> <A.B.C.D>

  • muestre el number> del <process ID OSPF del IP

  • muestre la interfaz del number> del <process ID OSPF del IP

  • muestre la base de datos del number> del <process ID OSPF del IP

  • show tag-switching forwarding-table vrf <VPN routing or forwarding instance name>

Este comando muestra el VRF para un VPN determinado en el router PE:

Alcazaba#show ip route vrf vpn1
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
     69.0.0.0/30 is subnetted, 1 subnets
B       69.69.0.0 [200/0] via 223.0.0.21, 00:19:39
     222.0.0.0/32 is subnetted, 4 subnets
B       222.0.0.30 [200/0] via 223.0.0.21, 00:19:39
C       222.0.0.10 is directly connected, Loopback1
B       222.0.0.3 [200/11] via 223.0.0.21, 00:20:39
O       222.0.0.1 [110/11] via 150.150.0.2, 00:20:59, Ethernet1/1
     6.0.0.0/32 is subnetted, 1 subnets
B       6.6.6.6 [200/11] via 223.0.0.21, 00:20:39
     7.0.0.0/32 is subnetted, 1 subnets
O       7.7.7.7 [110/11] via 150.150.0.2, 00:21:00, Ethernet1/1
     150.150.0.0/24 is subnetted, 1 subnets
C       150.150.0.0 is directly connected, Ethernet1/1

Usted puede también visualizar la información sobre BGP para un VRF determinado con el comando show ip bgp vpnv4 vrf. Los resultados PE-PE del BGP interno (IBGP) están indicados con una i.

Alcazaba#show ip bgp vpnv4 vrf vpn1
BGP table version is 21, local router ID is 223.0.0.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
 
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:101 (default for vrf vpn1)
*>i6.6.6.6/32       223.0.0.21              11    100      0 ?
*> 7.7.7.7/32       150.150.0.2             11         32768 ?
*>i69.69.0.0/30     223.0.0.21               0    100      0 ?
*> 150.150.0.0/24   0.0.0.0                  0         32768 ?
*> 222.0.0.1/32     150.150.0.2             11         32768 ?
*>i222.0.0.3/32     223.0.0.21              11    100      0 ?
*> 222.0.0.10/32    0.0.0.0                  0         32768 ?
*>i222.0.0.30/32    223.0.0.21               0    100      0 ?

Usted puede marcar los detalles de una entrada. Para mostrar esto, el Route Distinguisher es el "1:101."

Alcazaba#show ip bgp vpnv4 vrf vpn1 6.6.6.6
BGP routing table entry for 1:101:6.6.6.6/32, version 28
Paths: (1 available, best #1, table vpn1)
  Not advertised to any peer
  Local
    223.0.0.21 (metric 4) from 223.0.0.21 (223.0.0.21)
      Origin incomplete, metric 11, localpref 100, valid, internal, best
      Extended Community: RT:1:101 OSPF RT:3:2:0

Alcazaba#show ip bgp vpnv4 vrf vpn1 7.7.7.7
BGP routing table entry for 1:101:7.7.7.7/32, version 20
Paths: (1 available, best #1, table vpn1)
  Advertised to non peer-group peers:
  223.0.0.21 
  Local
    150.150.0.2 from 0.0.0.0 (223.0.0.3)
      Origin incomplete, metric 11, localpref 100, weight 32768, valid, sourced, best
      Extended Community: RT:1:101 OSPF RT:1:2:0

El comando show ip route en un router CE es los medios principales para verificar las tablas de ruteo:

rapid#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
     69.0.0.0/30 is subnetted, 1 subnets
O IA    69.69.0.0 [110/11] via 150.150.0.1, 00:20:25, FastEthernet0/1
     222.0.0.0/32 is subnetted, 4 subnets
O IA    222.0.0.30 [110/11] via 150.150.0.1, 00:20:25, FastEthernet0/1
O       222.0.0.10 [110/11] via 150.150.0.1, 00:21:46, FastEthernet0/1
O IA    222.0.0.3 [110/21] via 150.150.0.1, 00:21:25, FastEthernet0/1
C       222.0.0.1 is directly connected, Loopback0
     6.0.0.0/32 is subnetted, 1 subnets
O IA    6.6.6.6 [110/21] via 150.150.0.1, 00:21:25, FastEthernet0/1
     7.0.0.0/24 is subnetted, 1 subnets
C       7.7.7.0 is directly connected, Loopback2
     10.0.0.0/22 is subnetted, 1 subnets
C       10.200.8.0 is directly connected, FastEthernet0/0
     150.150.0.0/24 is subnetted, 1 subnets
C       150.150.0.0 is directly connected, FastEthernet0/1
S    158.0.0.0/8 is directly connected, Null0

Comandos específicos de OSPF

Usted puede utilizar todos los comandos show ip ospf. Cuando usted hace esto, recuerde indicar el identificador de proceso. Hemos marcado a la mayoría de las partes importantes de la salida abajo en el texto puesto en letra itálica.

El OSPF LSA del tipo 9, 10 y 11 (también conocido como Opaque LSA) se utiliza para dirigir el tráfico.

Comandos para un router PE

Alcazaba#show ip ospf 2
 Routing Process "ospf 2" with ID 222.0.0.10
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Connected to MPLS VPN super backbone
 It is an area border and autonomous system boundary router
 Redistributing External Routes from,
    bgp 1, includes subnets in redistribution
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x0     
 Number of opaque AS LSA 0. Checksum Sum 0x0     
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 External flood list length 0
    Area 1
        Number of interfaces in this area is 2
        Area has no authentication
        SPF algorithm executed 4 times
        Area ranges are
        Number of LSA 7. Checksum Sum 0x420BE 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

Alcazaba#show ip ospf 2 interface
Loopback1 is up, line protocol is up 
  Internet Address 222.0.0.10/32, Area 1 
  Process ID 2, Router ID 222.0.0.10, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Ethernet1/1 is up, line protocol is up 
  Internet Address 150.150.0.1/24, Area 1 
  Process ID 2, Router ID 222.0.0.10, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1 
  Designated Router (ID) 222.0.0.10, Interface address 150.150.0.1
  Backup Designated router (ID) 222.0.0.1, Interface address 150.150.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:07
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 3
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 222.0.0.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)

Alcazaba#show ip ospf 2 database
 
            OSPF Router with ID (222.0.0.10) (Process ID 2)
 
                Router Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       1364        0x80000013 0x7369   3
222.0.0.10      222.0.0.10      1363        0x80000002 0xFEFE   2
 
                Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
150.150.0.1     222.0.0.10      1363        0x80000001 0xEC6D  
 
                Summary Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.10      1328        0x80000001 0x4967  
69.69.0.0       222.0.0.10      1268        0x80000001 0x2427  
222.0.0.3       222.0.0.10      1328        0x80000001 0xEEF7  
222.0.0.30      222.0.0.10      1268        0x80000001 0x7B5A  

Comandos para un router CE

rapid#show ip ospf interface
FastEthernet0/1 is up, line protocol is up 
  Internet Address 150.150.0.2/24, Area 1 
  Process ID 1, Router ID 222.0.0.1, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State BDR, Priority 1 
  Designated Router (ID) 222.0.0.10, Interface address 150.150.0.1
  Backup Designated router (ID) 222.0.0.1, Interface address 150.150.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:04
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 222.0.0.10  (Designated Router)
  Suppress hello for 0 neighbor(s)
Loopback0 is up, line protocol is up 
  Internet Address 222.0.0.1/32, Area 1 
  Process ID 1, Router ID 222.0.0.1, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Loopback2 is up, line protocol is up 
  Internet Address 7.7.7.7/24, Area 1 
  Process ID 1, Router ID 222.0.0.1, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host

rapid#show ip ospf database
 
       OSPF Router with ID (222.0.0.1) (Process ID 1)
 
                Router Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       1350        0x80000013 0x7369   3
222.0.0.10      222.0.0.10      1350        0x80000002 0xFEFE   2
 
                Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
150.150.0.1     222.0.0.10      1351        0x80000001 0xEC6D  
 
                Summary Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.10      1316        0x80000001 0x4967  
69.69.0.0       222.0.0.10      1256        0x80000001 0x2427  
222.0.0.3       222.0.0.10      1316        0x80000001 0xEEF7  
222.0.0.30      222.0.0.10      1256        0x80000001 0x7B5A  

Alcazaba#show tag-switching forwarding-table vrf vpn1
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
24     Aggregate   222.0.0.10/32[V]  0                                  
25     Aggregate   150.150.0.0/24[V] 0                                  
27     Untagged    7.7.7.7/32[V]     1710       Et1/1      150.150.0.2  
28     Untagged    222.0.0.1/32[V]   0          Et1/1      150.150.0.2

Etiquetas MPLS

Usted puede marcar la pila de etiquetas usada para una ruta determinado:

Alcazaba#show tag-switching forwarding-table vrf vpn1 6.6.6.6 detail
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
None   2/41        6.6.6.6/32        0          AT4/0.1    point2point  
        MAC/Encaps=4/12, MTU=4466, Tag Stack{2/41(vcd=10) 16}
        000A8847 0000A00000010000

‘Resultados de la depuración’

Aquí está un extracto de la información de debugging del intercambio de ruta. Esto muestra cómo se importa una ruta determinado.

Alcazaba#debug ip bgp vpnv4 import
Tag VPN import processing debugging is on
*Aug  5 05:10:09.283: vpn: Start import processing for: 1:101:222.0.0.3
*Aug  5 05:10:09.283: vpn: Import check for vpn1; flags mtch, impt
*Aug  5 05:10:09.283: vpn: Import for vpn1 permitted; import flags mtch, impt
*Aug  5 05:10:09.283: vpn: Same RD import for vpn1
*Aug  5 05:10:09.283: vpn: 1:101:222.0.0.3 (ver 29), imported as:
*Aug  5 05:10:09.283: vpn: 1:101:222.0.0.3 (ver 29)
*Aug  5 05:10:09.287: VPN: Scanning for import check is done.

Salida de prueba

Usted puede ahora utilizar el ping para probar que todo está muy bien:

Pivrnec#ping 7.7.7.7      
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

El comando traceroute visualiza esta salida:

Pivrnec#traceroute 7.7.7.7
 
Type escape sequence to abort.
Tracing the route to 7.7.7.7
 
  1 69.69.0.1 0 msec 0 msec 0 msec
  2 150.150.0.1 0 msec 0 msec 20 msec
  3 150.150.0.2 0 msec 0 msec * 

Los host MLPS no están aquí porque no consideran el encabezado IP. Los host MPLS marcan solamente la escritura de la etiqueta entrante o interconectan y entonces adelante él.

La operación en el campo del Time to Live IP (TTL) se realiza solamente en el borde LSR. El conteo saltos mostrado es menos que el conteo saltos real.


Información Relacionada


Document ID: 10472