Switching por etiquetas multiprotocolo (MPLS) : Switching por etiquetas multiprotocolo por ATM (MPLS over ATM)

MPLS CoS sobre la atmósfera: VC con múltiple TBR (con CAR)

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El mecanismo de la clase del servicio del Multiprotocol Label Switching (MPLS CoS) es una característica que lleva a cabo los Servicios diferenciados sobre la atmósfera. Permite que la red ATM trate diversos paquetes basados en el campo (experimental) EXP (también llamado CoS) del encabezado MPLS, que tiene las mismas propiedades y que se puede asociar a la Prioridad IP.

0                   1                   2                   3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|               Label                   | EXP |S|      TTL      |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Este documento explica cómo hacer uso de este mecanismo dentro de una red del núcleo MPLS que reciba los paquetes del IP (sin los bits de precedencia fijados) de las diferentes fuentes.

prerrequisitos

Multi-Virtual Circuit Tagged Bit Rate (Multi-VC TBR)

El Multi-VC TBR utiliza las diversas trayectorias y clases del nuevo-servicio para soportar el tratamiento distinto sobre la atmósfera. Este método consiste en hasta cuatro circuitos virtuales de etiqueta paralelos (LVC) (o el “Tag VC” en la vieja terminología) y las correspondencias a MPLS CoS. Esta tabla muestra el mapeo predeterminado:

Tipo del circuito virtual de etiqueta Clase de servicio Tipo de servicio IP
Disponible 0 0,4
Estándar 1 1,5
Superior 2 2,6
Control 3 3,7

Cada Label Switch Router (LSR) tiene vario VCs (a partir el uno a cuatro) que corresponda para el mismo destino o “multi-VC”. Estos LVC paralelos son configurados por el router de borde por aguas arriba con el Label Distribution Protocol.

Para soportar los LVC en el nivel del Switch, se han introducido cuatro nuevas categorías de CoS. Se llaman las clases marcadas con etiqueta de la velocidad de bits (TBR) y son servicios de mejor esfuerzo (como con la Velocidad de bit sin especificar (UBR) tradicional). Pueden ser configuradas de la misma manera. Es decir, sus ponderaciones del pariente o los límites de sus umbrales pueden ser cambiados.

Clase de servicio del foro ATM CoS Ponderación relativa de la clase Circuito virtual de etiqueta
CBR (Ritmo de bits constante) 2 No aplicable
VBR-RT 2 8
VBR-NRT 3 1
ABR 4 1
UBR 5 1
TBR_1 (WRR_1) 1 1 Disponible
TBR_2 (WRR_2) 6 2 Estándar
TBR_3 (WWR_3) 7 3 Superior
TBR_4 (WWR_4) 8 4 Control

Nota: Las nuevas categorías de CoS están en intrépido.

Mecanismo

El borde LSR fija el campo MPLS CoS con el Committed Access Rate (CAR) en la interfaz de entrada correcta. El CAR se puede configurar para actuar de acuerdo con un contrato o cualquier otra regla específica. El LSR en el borde de la red ATM hace cola las células que contienen el paquete en la cola correcta (disponible, estándar, superior, o control), dependientes en el mapa de CoS. Las células entonces transitan a través de la red ATM MPLS con el mismo LVC. El resultado es que, en cualquier atmósfera LSR, las células reciben un tratamiento por CoS:

  • Por el Espera equitativa ponderada (WFQ) de CoS es proporcional a las ponderaciones relativas de la clase.

  • Por el Weighted Early Packet Discard de CoS (WEPD) es un método para desechar los paquetes cuando las colas de administración del tráfico se llenan (similar al Weighted Random Early Detection (WRED)).

Como consecuencia, para el LS1010 y el 8540MSR, esto por el comportamiento del CoS se emula encima por la espera del VC.

Espacio VC

Fusiones estándar del VC de los soportes MPLS CoS. Para utilizar menos VCs, usted puede reducir el LVC usado (a partir el cuatro a dos, por ejemplo). Refiera a MPLS CoS sobre la atmósfera: Mapa de CoS para una configuración de muestra.

El tema del número de VCs se trata en el diseño del MPLS para la atmósfera: Dimensionalización del espacio del VC de la escritura de la etiqueta MPLS.

Versiones de hardware y de software

Esta configuración fue desarrollada y probada con estas versiones de software y hardware:

Borde LSR

  • Software - Software Release 12.1(3)T del½ del¿Â del Cisco IOSïÂ; función de Multi-VC aparecido en el Cisco IOS Software Release 12.0(5)T.

  • Hardware - Cisco 7200 Router con el PA-A1.

Nota: Esta característica trabaja solamente con Cisco 7200s y 7500s con el PA-A1.

Atmósfera LSR de la base

  • Software - Cualquier versión de software que soporte el MPLS; se recomiendan las últimas versiones.

  • Hardware - El LS1010 y el 8540MSR.

Nota: Una placa de función per-flow que hace cola (FC-PFQ) es obligatoria para el LS1010.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/10469/mpls_cos_atm1.gif

Procedimiento de Configuración

Este documento utiliza este Procedimiento de configuración:

  1. Para configurar cuatro LVC predeterminados (con el mapeo predeterminado), agregue esta instrucción al configuración de la subinterfaz ATM del borde LSR:

    tag-switching atm multi-vc
    
  2. Los LVC paralelos configuran automáticamente en el Switches ATM. Para clasificar los paquetes, uso CAR (refiera a la documentación de CAR) de fijar el campo experimental del encabezado MPLS al valor deseado. Este ejemplo fija CoS de todos los paquetes de entrada en los Ethernetes 1/1 interfaz a 1 (y fija la correspondencia al “estándar”):

    interface Ethernet1/1
     rate-limit input 8000 1500 200 conform-action set-mpls-exp-transmit 1 exceed-action set-mpls-exp-transmit 1
    
  3. Usted puede también realizar el control de tráfico y fijar CoS a 2 (correspondencia al “premio”) para el tráfico que conforma y a 0 (correspondencia a “disponible”) para el tráfico que se excede:

    interface Ethernet1/1
     rate-limit input 64000 8000 16000 conform-action set-mpls-exp-transmit 2 exceed-action set-mpls-exp-transmit 0
    

    Nota: Usted puede también utilizar el comando tag-switching atm vpi 2-4, pero no es obligatorio especificar qué identificadores de trayecto virtual (VPIs) se utilizan para el MPLS.

    Nota: Recuerde configurar el cef del IP (cef del IP distribuido en un Cisco 7500) en la Configuración general del Routers.

Configuraciones de Ejemplo

En este documento, se utilizan estas configuraciones:

Rápido
 !
 interface Loopback0
  ip address 223.0.0.12 255.255.255.255
 !
 interface Loopback2
  ip address 7.7.7.7 255.255.255.0
 !
 !
 interface FastEthernet0/1
  ip address 150.150.0.2 255.255.255.0
  duplex auto
  speed auto
 !
 !
 router ospf 1
  network 7.7.7.7 0.0.0.0 area 0
  network 150.150.0.0 0.0.0.255 area 0
  network 223.0.0.0 0.0.0.255 area 0
 !      

Alcazaba
 !
 ip cef
 !
 !
 interface Loopback0
  ip address 223.0.0.3 255.255.255.255
 !
 interface Loopback1
  ip address 1.1.1.1 255.255.255.255
 !
 interface Ethernet1/1
  ip address 150.150.0.1 255.255.255.0
  rate-limit input 64000 32000 64000 conform-action set-mpls-exp-transmit 2 
  exceed-action set-mpls-exp-transmit 1
  no ip mroute-cache
 !
 !
 interface ATM4/0
  no ip address
  no ip mroute-cache
  no atm ilmi-keepalive
 !
 interface ATM4/0.1 tag-switching
  ip address 10.0.0.13 255.255.255.252
  tag-switching atm multi-vc
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 router ospf 1
  network 1.1.1.1 0.0.0.0 area 0
  network 10.0.0.0 0.0.0.255 area 0
  network 150.150.0.0 0.0.0.255 area 0
  network 223.0.0.3 0.0.0.0 area 0
 !

Capri
 !
 interface Loopback1
  ip address 223.0.0.6 255.255.255.255
  no ip directed-broadcast
 !
 !
 interface ATM3/0/2
  ip address 10.0.0.14 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 interface ATM3/1/2
  ip address 10.0.0.10 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 router ospf 2
  network 10.0.0.0 0.0.0.255 area 0
  network 223.0.0.6 0.0.0.0 area 0
 !

Goldorak
 !
 interface Loopback0
  ip address 223.0.0.2 255.255.255.255
  no ip directed-broadcast
 !
 interface ATM0/1/0
  ip address 10.0.0.9 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 !
 interface ATM0/1/3
  ip address 11.0.0.1 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 5-7
  tag-switching ip
 !
 !
 router ospf 1
  network 10.0.0.0 0.0.0.255 area 0
  network 11.0.0.0 0.0.0.255 area 0
  network 223.0.0.2 0.0.0.0 area 0
 !

Ischia
 !         
 ip cef
 !
 interface Loopback0
  ip address 223.0.0.11 255.255.255.255
 !
 interface Loopback1
  ip address 2.2.2.2 255.255.255.255
 !
 !
 interface ATM3/0.158 tag-switching
  ip address 11.0.0.2 255.255.255.252
  tag-switching atm multi-vc
  tag-switching atm vpi 5-7
  tag-switching ip
 !
 router ospf 1
  log-adjacency-changes
  network 2.2.2.2 0.0.0.0 area 0
  network 11.0.0.0 0.0.0.255 area 0
  network 223.0.0.11 0.0.0.0 area 0
 !

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Comandos show

En un router LSR:

  • show tag-switching forwarding-table

  • muestre el detalle de la tabla de reenvío del Tag Switching

En un switch ATM:

  • muestre los atascamientos del Tag Switching ATM-TDP

  • <interface> del show atm vc interface <vci/vpi>

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Ejemplo de resultado del comando show

Para marcar el multi-VC en un borde LSR, el comando show tag-switching forwarding-table tradicional puede ser utilizado. Para marcar específicamente el descriptor de circuito virtual (VCD) o el identificador de ruta virtual/identificador de canal virtual (VPI/VCI), el comando debe ser específico a un destino y debe terminar con el detalle de la palabra.

Alcazaba#show tag-switching forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
16     Untagged    7.7.7.0/24        0          Et1/1      150.150.0.2  
17     Untagged    10.0.0.0/16       0          Et1/1      150.150.0.2  
18     Untagged    158.0.0.0/8       0          Et1/1      150.150.0.2  
19     Untagged    223.0.0.12/32     0          Et1/1      150.150.0.2  
20     Untagged    7.7.7.7/32        570        Et1/1      150.150.0.2  
21     Multi-VC    10.0.0.8/30       0          AT4/0.1    point2point  
25     Multi-VC    2.2.2.2/32        0          AT4/0.1    point2point  
32     Multi-VC    223.0.0.2/32      0          AT4/0.1    point2point  
34     Multi-VC    223.0.0.6/32      0          AT4/0.1    point2point  
36     Multi-VC    11.0.0.0/30       0          AT4/0.1    point2point  
37     Multi-VC    223.0.0.11/32     0          AT4/0.1    point2point 

Alcazaba#show tag-switching forwarding-table 2.2.2.2 32 detail
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
25     Multi-VC    2.2.2.2/32        0          AT4/0.1    point2point  
        available 2/61(882), standard 2/62(883), premium 2/63(884), control 2/64(885), 
        MAC/Encaps=4/8, MTU=4470, Tag Stack{Multi-VC}
        04F48847 004F4000
    Per-packet load-sharing 

En cualquier atmósfera LSR, usted puede también asociar el diverso VCs a partir de una interfaz a otra (con el comando show tag-switching atm-tdp bindings) con sus clases de servicio respectivas (el comando del show atm vc interface <ATM interface> <vpi> <vci>).

Capri#show tag-switching atm-tdp bindings
 Destination: 2.2.2.2/32
    Transit ATM3/0/2 2/61 Active -> ATM3/1/2 2/69 Active, CoS=available
    Transit ATM3/0/2 2/62 Active -> ATM3/1/2 2/70 Active, CoS=standard
    Transit ATM3/0/2 2/63 Active -> ATM3/1/2 2/71 Active, CoS=premium
    Transit ATM3/0/2 2/64 Active -> ATM3/1/2 2/72 Active, CoS=control
 Destination: 10.0.0.8/30
    Tailend Switch ATM3/0/2 2/97 Active -> Terminating Active, CoS=available
    Tailend Switch ATM3/0/2 2/98 Active -> Terminating Active, CoS=standard
    Tailend Switch ATM3/0/2 2/99 Active -> Terminating Active, CoS=premium
    Tailend Switch ATM3/0/2 2/100 Active -> Terminating Active, CoS=control
[...]
Capri#show atm vc interface atm3/0/2 2 63
 
Interface: ATM3/0/2, Type: oc3suni 
VPI = 2  VCI = 63
Status: UP
Time-since-last-status-change: 02:07:24
Connection-type: TVC(O) 
Cast-type: multipoint-to-point-output
Packet-discard-option: enabled
Usage-Parameter-Control (UPC): pass
Wrr weight: 2
Number of OAM-configured connections: 0
OAM-configuration: disabled
OAM-states:  Not-applicable
Cross-connect-interface: ATM3/1/2, Type: oc3suni 
Cross-connect-VPI = 2 
Cross-connect-VCI = 147
Cross-connect-UPC: pass
Cross-connect OAM-configuration: disabled
Cross-connect OAM-state:  Not-applicable
Threshold Group: 9, Cells queued: 0
Rx cells: 0, Tx cells: 0
Tx Clp0:0,  Tx Clp1: 0
Rx Clp0:0,  Rx Clp1: 0
Rx Upc Violations:0, Rx cell drops:0
Rx pkts:0, Rx pkt drops:0
Rx connection-traffic-table-index: 63998
Rx service-category: WRR_3 (WRR Bit Rate)
Rx pcr-clp01: none
Rx scr-clp01: none
Rx mcr-clp01: none
Rx      cdvt: 0 (from default for interface)
Rx       mbs: none
Tx connection-traffic-table-index: 63998
Tx service-category: WRR_3 (WRR Bit Rate)
Tx pcr-clp01: none
Tx scr-clp01: none
Tx mcr-clp01: none
Tx      cdvt: none
Tx       mbs: none

En las configuraciones de muestra, todos los paquetes que conforman son enviados por el LVC superior. Todos los paquetes que exceden la regla de CAR son enviados por el LVC estándar. En estas primeras salidas, un ping estándar se hace y se relanza 158 veces:

rapid#ping        
Protocol [ip]: 
Target IP address: 2.2.2.2
Repeat count [5]: 158
Datagram size [100]: 
Timeout in seconds [2]: 
Extended commands [n]: 
Sweep range of sizes [n]: 
Type escape sequence to abort.
Sending 158, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (158/158), round-trip min/avg/max = 1/1/5 ms

Usted puede marcar si todos los paquetes pasan con el LVC superior con el comando show atm vc en el borde LSR como en la salida de muestra. En esta muestra, la salida superior VCD es 884.

Alcazaba#show atm vc 884
ATM4/0.1: VCD: 884, VPI: 2, VCI: 63
UBR, PeakRate: 155000
AAL5-MUX, etype:0x8847, Flags: 0x40C84, VCmode: 0x0
OAM frequency: 0 second(s)
InARP DISABLED
InPkts: 0, OutPkts: 158, InBytes: 0, OutBytes: 17064
InPRoc: 0, OutPRoc: 0
InFast: 0, OutFast: 158, InAS: 0, OutAS: 0
Giants: 0
OAM cells received: 0
OAM cells sent: 0
Status: UP
Tag VC: local tag: 0

Usted puede también comprobar cualquier switch ATM con el comando del <interface> de la interfaz del tráfico del VC de la demostración ATM <vpi/vci>. En esta muestra, cada paquete ping se transporta en tres células: 158*3 = 474 células.

Capri#show atm vc traffic interface atm 3/0/2 2 63
Interface    VPI     VCI      Type      rx-cell-cnts     tx-cell-cnts
ATM3/0/2     2       63        TVC(O)             0                0
ATM3/0/2     2       63        TVC(I)           474                0

Información Relacionada


Document ID: 10469