Modo de transferencia asíncrona (ATM) : Emulación LAN (LANE)

Configuración de Ejemplo de LAN Emulation

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento ilustra cómo configurar los servicios y a los clientes del LAN Emulation (LANE) en los routeres Cisco, switches Catalyst y switches ATM.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/10457/lane_config1.gif

En esa configuración:

  • El router1 y el router2 son Cisco 4500 Router que funcionan con el Software Release 12.1(4) del ½ del ¿Â de Cisco IOSïÂ. Ambos actúan como (LECs) de los LAN Emulation Clients.

  • El LightStream1010 es Cisco IOS Software Release 12.0(10)W5(18b) corriente. Actúa como LAN Emulation Configuration Server (LECS).

  • El switch de Ethernet es un Catalyst 5000 con una Tarjeta LANE en slot4. Esta Tarjeta LANE actúa como LEC y como broadcast y servidor desconocidos LANE (LES/BUS).

  • Han configurado a los servicios LANe según las recomendaciones de diseño de LANe.

  • Se han configurado dos LAN emulados (ELAN): prueba-ELAN y test-elan2.

  • El router1 tiene un LEC en cada ELAN. El switch de Ethernet tiene un LEC en test-elan2. El router2 y el LightStream1010 tienen un LEC en el prueba-ELAN.

  • En el switch de Ethernet, el LAN virtual, VLAN2, está limitado a test-elan2.

  • El router1 está responsable de hacer la encaminamiento entre los dos ELAN.

Ésta es la configuración lógica:

lane_config2.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Nota: Solamente las porciones de los comandos configuration que son relevantes al LANE son incluidas.

LightStream 1010

!--- Output suppressed.

atm lecs-address-default 47.0091.8100.0000.0060.705a.8f01.0060.705a.8f05.00

!

lane database test

  name test-elan server-atm-address 47.0091810000000060705A8F01.00E0B00B7031.01
  name test-elan2 server-atm-address 47.0091810000000060705A8F01.00E0B00B7031.02
!
interface atm2/0/0
 no ip address
 no ip directed-broadcast
 lane config auto-config-atm-address
 lane config database test
!
interface atm2/0/0.2 multipoint
 ip address 20.0.0.2 255.255.255.0
 no ip directed-broadcast
 lane client ethernet test-elan

!--- Output suppressed.

La prueba de la base de datos LANe define el direccionamiento del punto de acceso al servicio de red (NSAP) del LES/BUS para cada ELAN. Estos direccionamientos en la configuración del LightStream1010 señalan a la Tarjeta LANE del switch de Ethernet:

lane-blade# show lane default

interface atm0:
LANE Client:        47.0091810000000060705A8F01.00E0B00B7030.**
LANE Server:        47.0091810000000060705A8F01.00E0B00B7031.**
LANE Bus:           47.0091810000000060705A8F01.00E0B00B7032.**
LANE Config Server: 47.0091810000000060705A8F01.00E0B00B7033.00

Nota:  ** representa la cantidad de bytes de la subinterfaz en el formato hexadecimal.

Nota: La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Una vez que usted ha definido la base de datos LANe, apliqúela en la interfaz principal del LECS usando el comando lane config database database-name. Ésta es una explicación de los tres comandos que se configuran en el LECS:

  • NSAP-direccionamiento del lecs-direccionamiento-valor por defecto ATM — Define que dirigen el Switch hacen publicidad como siendo el LECS NSAP a sus dispositivos conectados con el Interim Local Management Interface (ILMI). En este caso, el direccionamiento configurado es el NSAP Address asignado a la interfaz ATM0 del LightStream1010. Publique el comando show lane default de obtener este direccionamiento:

    LightStream 1010# show lane default
    
    interface ATM2/0/0:
    LANE Client:        47.0091810000000060705A8F01.0060705A8F02.**
    LANE Server:        47.0091810000000060705A8F01.0060705A8F03.**
    LANE Bus:           47.0091810000000060705A8F01.0060705A8F04.**
    LANE Config Server: 47.0091810000000060705A8F01.0060705A8F05.00
    

    Nota:  ** representa la cantidad de bytes de la subinterfaz en el formato hexadecimal.

  • lane config auto-config-atm-address — Indica si el LECS responde a las configuraciones de la llamada hechas a su NSAP Address real.

  • lane config database nombre de la base de datos — Define que la base de datos LANe el LECS utiliza.

Una vez que usted ha aplicado la configuración arriba a la interfaz principal, el LECS es ascendente y activo.

Verificación del estado de LECS

Publique el comando show lane config de marcar el estado del LEC:

LightStream 1010# show lane config

LE Config Server ATM2/0/0 config table: test
Admin: up State: operational
LECS Mastership State: active master
list of global LECS addresses (49 seconds to update):
47.0091810000000060705A8F01.0060705A8F05.00
ATM Address of this LECS: 47.0091810000000060705A8F01.0060705A8F05.00 (auto)
 vcd  rxCnt  txCnt  callingParty
  46      1      1  47.0091810000000060705A8F01.00E0B00B7031.01 LES test-elan 0 active
  62      1      1  47.0091810000000060705A8F01.00E0B00B7031.02 LES test-elan2 0 active
ATM Address of this LECS: 47.007900000000000000000000.00A03E000001.00 (well known)
cumulative total number of unrecognized packets received so far: 0
cumulative total number of config requests received so far: 608
cumulative total number of config failures so far: 601
    cause of last failure: no configuration
    culprit for the last failure: 47.009181000000FFFF705A8F01.0050E2030602.01
Router1

!--- Output suppressed.

interface ATM0

 no ip address
 pvc 0/5 qsaal
 !
 PVC 0/16 ilmi
 !
 no ATM ilmi-keepalive
!
interface ATM0.2 multipoint
 ip address 20.0.0.1 255.255.255.0
 lane client ethernet test-elan
!
interface ATM0.3 multipoint
 ip address 21.0.0.1 255.255.255.0
 lane client ethernet test-elan2
!
router rip
 network 20.0.0.0
 network 21.0.0.0

!--- Output suppressed.

Marcar el estado de LEC

Publique estos comandos de marcar el estado de LEC:

  • muestre el [interface atm number[.subinterface-number] del cliente LANE]

    router1# show lane client interface atm 0.2
    
    LE Client ATM0.2  ELAN name: test-elan  Admin: up  State: operational
    Client ID: 2                 LEC up for 18 hours 9 minutes 42 seconds
    ELAN ID: 0
    Join Attempt: 1
    Known LE Servers: 1
    HW Address: 0060.837b.b3a2   Type: ethernet             Max Frame Size: 1516
    ATM Address: 47.0091810000000060705A8F01.0060837BB3A2.02
     VCD  rxFrames  txFrames  Type       ATM Address
       0         0         0  configure  47.0091810000000060705A8F01.0060705A8F05.00
       5         1        47  direct     47.0091810000000060705A8F01.00E0B00B7031.01
       6       145         0  distribute 47.0091810000000060705A8F01.00E0B00B7031.01
       7         0      4567  send       47.0091810000000060705A8F01.00E0B00B7032.01
       8     10221         0  forward    47.0091810000000060705A8F01.00E0B00B7032.01
  • atm ilmi-status de la demostración — Verifica si el cliente haya registrado correctamente su NSAP Address con el ILMI.

    router1# show atm ilmi-status
    
    Interface : ATM0 Interface Type : Private UNI (User-side)
    ILMI VCC : (0, 16) ILMI Keepalive : Disabled
    ILMI State:       UpAndNormal
    Peer IP Addr:     10.200.10.47    Peer IF Name:     ATM0/0/0
    Peer MaxVPIbits:  8               Peer MaxVCIbits:  14
    Active Prefix(s) :
    47.0091.8100.0000.0060.705a.8f01
    End-System Registered Address(s) :
    47.0091.8100.0000.0060.705a.8f01.0060.837b.b3a2.02(Confirmed)
    47.0091.8100.0000.0060.705a.8f01.0060.837b.b3a2.03(Confirmed)

    Refiera a estos documentos para más información sobre el comando show atm ilmi-status:

Router2

!--- Output suppressed.

interface ATM1

 no ip address
 PVC 0/16 ilmi
 !
 PVC 0/5 qsaal
 !
 no ATM ilmi-keepalive
!
interface ATM1.2 multipoint
 ip address 20.0.0.3 255.255.255.0
 lane client ethernet test-elan
!
router rip
 network 20.0.0.0

!--- Output suppressed.

Tarjeta LANE del switch de Ethernet

!--- Output suppressed.

interface ATM0

 ATM preferred phy A
 atm PVC 1 0 5 qsaal
 ATM PVC 2 0 16 ilmi
 no ATM ilmi-keepalive
!
interface ATM0.1 multipoint
 lane server-bus ethernet test-elan

!--- Configuration of the Bus.

!
interface ATM0.2 multipoint
 lane server-bus ethernet test-elan2
!
interface ATM0.3 multipoint
 lane client ethernet 2 test-elan2

!--- Output suppressed.

El comando lane server-bus ethernet elan-name configura este dispositivo como el LES/BUS para el nombre de ELAN nombrado ELAN.

Nota: Puede solamente haber un servidor-bus por la subinterfaz de multipunto.

Comandos adicionales

Éstos son algunos comandos útiles de utilizar al configurar el LANE. No es necesario utilizar estos comandos para implementar el LANE.

En el LECS

interface ATM2/0/0
  no ip address
  no ip directed-broadcast
  lane config fixed-config-atm-address
  lane config auto-config-atm-address
  lane config config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane config database test
  • lane config fixed-config-atm-address — Indica que el LECS responde a las configuraciones de la llamada hechas a las direcciones NSAP conocidas. Las direcciones NSAP conocidas son 47.007900000000000000000000.00A03E000001.00.

  • Config-atm-address NSAP del lane config — Indica que las respuestas LECS también a las configuraciones de la llamada hechas al NSAP Address configurado 47.0091.8100.0000.0060.705a.8f01.0000.0000.0001.01.

En LES (Servidor de emulación LAN)

interface ATM0.1 multipoint
  lane config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane server-atm-address 47.0091810000000060705A8F01.000000000002.01
  lane bus-atm-address 47.0091810000000060705A8F01.000000000003.01
  lane server-bus ethernet test-elan
  • lane config-atm-address NSAP — Fuerza el LES/BUS para conectar con el LECS con el direccionamiento del NSAP, en vez de usar el direccionamiento LECS aprendido del ILMI.

  • lane server-atm-address NSAP y bus-ATM-direccionamiento NSAP del carril — Permita que usted configure estáticamente el NSAP Address del LES y del BUS respectivamente.

Refiera a poner en hard-code los ATM Address para el LES/LEC/BUS/LECS para más información.

En la LEC

interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0
  lane fixed-config-atm-address
  lane client ethernet test-elan

interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0

  lane config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane client ethernet test-elan
  interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0

  lane server-atm-address 47.0091810000000060705A8F01.000000000002.01
  lane client ethernet test-elan
  • reparar-config-ATM-direccionamiento del carril — Fuerza el LEC para conectar con el LECS usando las direcciones NSAP conocidas, en vez de usar el NSAP Address LECS aprendido del ILMI.

  • lane config-atm-address NSAP — Fuerza el LEC para conectar con el LECS con el direccionamiento del NSAP, en vez de usar el direccionamiento LECS aprendido del ILMI.

  • lane server-atm-address NSAP — Fuerza el LEC para conectar directamente con el LES con el direccionamiento del NSAP sin la conexión con el LECS primero.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 10457