Modo de transferencia asíncrona (ATM) : ATM a interacción de Frame Relay

Frame Relay a servicio de interconexión ATM (FRF.8 – Modo Traducción)

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

La función de interconexión Frame Relay (FR) al servicio ATM permite la comunicación entre un usuario final de FR y un usuario final de ATM. Se basa en el acuerdo de instrumentaciónleavingcisco.com del Frame Relay Forum (FRF.8), que especifica que una estación terminal FR puede comunicar con estación terminal ATM a condición de que hay un router que realiza las especificaciones dadas en el FRF.8 en el software entre las estaciones del dos extremos.

Este documento presenta una configuración de ejemplo del FR a una interconexión de servicio ATM con FRF.8 (modo traducción) en el LightStream 1010. Esta configuración también funciona en Catalyst 8510 MSR u 8540 MSR

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información en este documento se basa en la versión del � del Cisco IOS 12.0(3c)W5(9).

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/10409/frf8.gif

Los parámetros de modelado de tráfico con FR utilizados en este ejemplo de configuración en el Router 1 son:

  • Velocidad de la información comprometida (CIR) = 64 kbps

  • Ráfaga comprometida (Bc) = 8000

  • Ráfaga en exceso (Be) = 8000

Nota: Para una explicación detallada en cómo resolver problemas las conexiones del Control de tráfico de Frame Relay, refiera a los comandos show para el Control de tráfico de Frame Relay.

Configuraciones

En este documento, se utilizan estas configuraciones:

Nota: Estas configuraciones contienen la información relevante solamente para el Frame Relay al ATM Service Interworking.

Router 1
controller E1 5/0 
 channel-group 30 timeslots 1-31 
! 
interface Serial5/0:30 
 ip address 12.12.12.2 255.255.255.0 
 no ip directed-broadcast 
 encapsulation frame-relay IETF

!--- The FR encapsulation used is IETF. It should match the switch.
 
 no fair-queue 
 frame-relay traffic-shaping

!--- Enabling FR traffic shaping on this interface.
          
 frame-relay class test-iwf 
 frame-relay map ip 12.12.12.1 123 broadcast 
! 
map-class frame-relay test-iwf 
 no frame-relay adaptive-shaping

!--- Traffic shaping parameters configured.

 frame-relay cir 64000 
 frame-relay bc 8000 
 frame-relay be 8000

ATM Switch
frame-relay connection-traffic-table-row index 123 64000 
8000 128000 8000 vbr-nrt 123 
! 
controller E1 4/0/0 
 clock source free-running 
 channel-group 30  timeslots 1-31 
! 
interface Serial4/0/0:30 
 no ip address 
 no ip directed-broadcast 
 encapsulation frame-relay IETF

!--- The FR encapsulation used is IETF.

 no arp frame-relay 
 frame-relay intf-type dce

!--- Interface type is dce, because it is providing clocking.

 frame-relay pvc 123 rx-cttr 123 tx-cttr 123 service translation 
 interface  ATM0/0/0 0 123 

!--- This command makes the translation from          
!--- Frame Relay to ATM PVC 123.

Router 2
interface ATM2/0.123 point-to-point 
 ip address 12.12.12.1 255.255.255.0 
 no ip directed-broadcast 
 pvc 0/123

!--- Configured ATM PVC 0/123 with traffic shaping and          
!--- oam-pvc management enabled.
 
 vbr-nrt 163 81 49 
 broadcast 
 oam-pvc manage 
 encapsulation aal5snap

Los parámetros de modelado del tráfico en el router2 se pueden obtener de la tabla del tráfico de la conexión de Frame Relay en el switch ATM (véase la sección).

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • show frame-relay lmi

  • show frame-relay map

  • show frame-relay pvc

  • atm0/0/0 del show atm vc interface

  • Connection-traffic-table-row del show frame-relay

  • show atm connection-traffic-table

  • show frame-relay interface resource serial 4/0/0:30 all-information

La salida mostrada abajo es un resultado de ingresar los comandos antedichos en los dispositivos mostrados en el diagrama de la red. El resultado muestra que la red está funcionando correctamente.

Router 1

Nota: Cuando se conecta un router de Cisco a una tercera conexión, es preferible utilizar la Interfaz de administración local (LMI) del Grupo de trabajo en ingeniería de Internet (IETF). Observe que la LMI sea Cisco y que el Frame Relay sea DTE cuando reciba la temporización desde el switch.

Router1# show frame-relay lmi 
 
LMI Statistics for interface Serial5/0:30 (Frame Relay DTE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 1222             Num Status msgs Rcvd 1222
  Num Update Status Rcvd 0              Num Status Timeouts 2

Para verificar que DLCI está activo y correlacionado con la dirección IP correspondiente, utilice el comando show frame-relay map.

Router1# show frame-relay map 

Serial5/0:30 (up): ip 12.12.12.1 dlci 123(0x7B,0x1CB0), static,
              broadcast,
              IETF, status defined, active

Para marcar el estatus del pvc del Frame Relay, utilice el comando show frame-relay pvc. En la salida abajo podemos ver que es activa.

Router1# show frame-relay pvc 
 
PVC Statistics for interface Serial5/0:30 (Frame Relay DTE)
 
              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0
 
DLCI = 123, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0:30
 
  input pkts 786           output pkts 549          in bytes 742312    
  out bytes 684503         dropped pkts 6           in FECN pkts 0         
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
  in DE pkts 0             out DE pkts 0         
  out bcast pkts 1          out bcast bytes 608       
  pvc create time 03:25:16, last time pvc status changed 03:09:30

ATM Switch

Nota: El término ATM-PX/Y/Z se refiere a una pseudo interfaz.

ATMswitch# show atm vc interface atm 0/0/0
Interface         VPI  VCI   Type   X-Interface      X-VPI X-VCI Encap  Status 
ATM0/0/0          0    5     PVC    ATM2/0/0          0    43    QSAAL  UP
ATM0/0/0          0    16    PVC    ATM2/0/0          0    35    ILMI   UP
ATM0/0/0          0    101   PVC    ATM0/1/0          0    101          UP
ATM0/0/0          0    102   PVC    ATM0/1/0          0    102          UP
ATM0/0/0          0    123   PVC    ATM-P4/0/0        30   155          UP

Para visualizar el Frame Relay a las conexiones ATM en el Switch, utilice el comando show frame-relay connection-traffic-table-row, como se muestra abajo:

ATMswitch# show frame-relay connection-traffic-table-row 
Row            cir      bc     be      pir      fr-atm Service-category    ATM Row
                                            
100           64000   32768   32768   64000            vbr-nrt              100       
123           64000   8000    8000    128000           vbr-nrt              123       


ATMswitch# show atm connection-traffic-table 
Row      Service-category    pcr        scr/mcr       mbs         cdvt
1            ubr          7113539        none                     none
2            cbr              424                                 none
3            vbr-rt           424         424          50         none
4            vbr-nrt          424         424          50         none
5            abr              424           0                     none
6            ubr              424        none                     none
10           cbr            50000                                 none
11           cbr             1000                                 none
12           cbr            11700                                 none
100          vbr-nrt           81          81-0        50         none
123          vbr-nrt          163          81-0        49         none 
<-- (*)

2147483645*  ubr                0        none                     none
2147483646*  ubr                1        none                     none
2147483647*  ubr          7113539        none                     none

(*) Al crear frame-relay connection-traffic-table-row, asociamos un índice de filas de tabla ATM en la cual los parámetros de modelado de tráfico ATM se calculan automáticamente mediante la especificación de la Interfaz dentro de la portadora de banda ancha (B-ICI), V2.0 (ver fórmulas).

ATMswitch# show frame-relay interface resource serial 4/0/0:30 all-information 
Encapsulation: FRAME-RELAY
Resource Management configuration:
    Input queues (PAM to switch fabric):
       Discard threshold: 87% vbr-nrt, 87% abr, 87% ubr
       Marking threshold: 75% vbr-nrt, 75% abr, 75% ubr
    Output queues (PAM to line):
       Discard threshold: 87% vbr-nrt, 87% abr, 87% ubr
       Marking threshold: 75% vbr-nrt, 75% abr, 75% ubr
    Overflow servicing for VBR: enabled
  Available bit rates (in bps):
     1920000 vbr-nrt RX, 1920000 vbr-nrt TX
     1920000 abr RX,     1920000 abr TX
     1920000 ubr RX,     1920000 ubr TX
    Overbooking: disabled
Resource Management state:  Allocated bit rates (in bps):
     64000 vbr-nrt RX, 64000 vbr-nrt TX
     0 abr RX,     0 abr TX
     0 ubr RX,     0 ubr TX
  Actual allocated bit rates (in bps):
     64000 vbr-nrt RX, 64000 vbr-nrt TX
     0 abr RX,     0 abr TX
     0 ubr RX,     0 ubr TX

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 10409