Modo de transferencia asíncrona (ATM) : Clase de servicio IP a ATM

Class-Based Weighted Fair Queuing por VC (por VC CBWFQ) en los routers Cisco 7200, 3600, y 2600

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

La Cola justa ponderada (WFQ) se implementó para los links de baja velocidad (como los seriales) a fin de proporcionar un tratamiento justo para cada tipo de tráfico. Para hacer su trabajo, el WFQ clasifica el tráfico en diversos flujos basados en el información de las capas 3 y 4 asociado (IP Addresses, puertos TCP, y así sucesivamente). No es necesario definir las listas de acceso para que esto funcione. Con el WFQ, el tráfico del ancho de banda baja tiene prioridad eficaz sobre el tráfico del ancho de banda alto. El tráfico de ancho de banda alto comparte el medio de transmisión de manera proporcional a los pesos asignados.

El WFQ tiene las limitaciones siguientes:

  • Si el flujo de tráfico aumenta en forma significativa, no es posible modificar WFQ debido a que no ofrece posibilidades de ampliación.

  • El WFQ no está disponible en las interfaces de alta velocidad, tales como atmósfera.

Se ha desarrollado una nueva función, CBWFQ (colocación en cola equilibrada ponderada basada en la clase), para resolver las limitaciones de WFQ. A diferencia del WFQ, el CBWFQ permite que usted defina las clases de tráfico. Una vez que se han definido las clases, los parámetros pueden entonces ser aplicados. Estos parámetros incluyen el ancho de banda y el cola-límite.

Al usar el CBWFQ, la ponderación especificada para una clase se convierte en la ponderación de cada paquete que haga juego los criterios de clase. Para obtener más información consulte la sección de Marcado entrante El WFQ entonces se aplica a estas clases en vez de la aplicación a los flujos ellos mismos. Las clases pueden incluir varios flujos.

Abajo está un resumen Per-VC de la disponibilidad CBWFQ en los 7200, los 3600, y los 2600 Router:

  • 7200: Versiones 12.0(5)T de Cisco IOS�, 12.0(5)XE, 12.1(1), 12.1(1)T, 12.1(1)E y posterior usando un PA-A3.

  • 7200 con el NSE: Versión deL Cisco IOS 12.1(7)E y posterior.

  • 7200 con el NSE-1 mantiene el acelerador: Versión deL Cisco IOS 12.2(4)B1.

  • 2600/3600 con el soporte LLQ/CBWFQ de los módulos NM-1A-T3/E3 en la versión deL Cisco IOS 12.1(5)T y posterior.

  • 2600/3600 con los módulos de red DS3/E3: Versión deL Cisco IOS 12.1(2)T.

Nota: La funcionalidad de Switching del Cisco Express Forwarding (CEF) debe ser utilizada porque el CBWFQ monitorea solamente los paquetes CEF-Switched.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de hardware:

  • Series Router del 7200, 3600 y 2600 de Cisco

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/10395/7200-1.gif

  • 1/130 es el valor del VPI/VCI asignado en los ambos extremos del PVC entre los 7200 y del router A.

  • El generador de tráfico está conectado para interconectar las normas Ethernet rápidas 3/0.

  • Los 7200 es la versión deL Cisco IOS corriente 12.0(5)T.

  • Utilizan al router A como dispositivo del fregadero para las pruebas.

  • La configuración se realiza en 7200, pero es similar en un 2600/3600.

Configuración de muestra:

Abajo está la configuración 7200 necesaria implementar el CBWFQ:

7200
    class-map ixia
      match input-interface FastEthernet3/0
    class-map loopbacks
      match access-group 102
    !
    policy-map mypol
      class ixia
       bandwidth 40000
       queue-limit 40
      class loopbacks
       bandwidth 10000
      class class-default
       fair-queue
    !
    interface ATM2/0.130 point-to-point
     ip address 14.0.0.2 255.0.0.0
     no ip directed-broadcast
     pvc 1/130
      service-policy output mypol
      vbr-nrt 100000 75000
      broadcast
      encapsulation aal5mux ip
    !
    access-list 102 permit ip host 10.0.0.1 host 11.0.0.1

Abajo están algunos comentarios sobre la configuración:

  • Las correspondencias de la clase clasifican y asignan las ponderaciones para traficar. Los parámetros de clasificación y los mapas de clase se definen en el mismo lugar. En este caso, una clase se aplica a todo el tráfico entrante en las normas Ethernet rápidas 3/0 (el tráfico del generador de tráfico). La otra clase se relaciona con el tráfico entre los loopback (definidos en los 7200 y el router A).

  • Después de definir los parámetros de clasificación, usted puede utilizar una correspondencia de políticas para aplicar los parámetros del tráfico a estos flujos clasificados. En este caso, el flujo del generador de tráfico “se afecta un aparato” un ancho de banda del 40 Mbps y una profundidad de espera en cola de 40 paquetes. El tráfico entre los loopback se afecta un aparato un ancho de banda del 10 Mbps.

  • La profundidad de espera en cola es el número de paquetes que se puedan salvar para una clase determinada antes de que ocurran los descensos. El valor predeterminado es 64 (que es también el Maximum Queue Depth).

  • Después de que los parámetros del tráfico se hayan definido para cada clase, el CBWFQ se aplica sobre una VC-base usando el siguiente comando: servicio-directiva [entrada|Policy-map-name de la salida].

  • Tráfico que no corresponde con una de las correspondencias de la clase definida será asignado una correspondencia de la clase predeterminada (valor por defecto de la clase) que se define en la correspondencia de políticas. Todo el tráfico no clasificado será aplicado los parámetros definidos bajo esta clase predeterminada. En este caso, se configura el Weighted Fair Queuing normal.

  • Para esta configuración de muestra, el CBWFQ se aplica en un VC, pero puede ser utilizado en un agrupamiento de PVC también. Además, el CBWFQ se puede asociar al Weighted Random Early Discard (WRED) como mecanismo de descarte (cuando se alcanza el cola-límite).

Importante:

Antes de realizar las tareas de configuración en esta sección, usted debe primero crear las clases que serán utilizadas para distinguir el tráfico en el VC, después define una correspondencia de políticas para incluirlas. Usted puede configurar las políticas de clase para tantas clases como se definen en el router -- hasta el máximo de 64. Sin embargo, la cantidad total de ancho de banda de VC asignado (para todas las clases incluidas en una correspondencia de políticas) no debe exceder el 75 por ciento del ancho de banda disponible para la VC.

Porque el CBWFQ proporciona una garantía mínima del ancho de banda, usted puede aplicar solamente el CBWFQ a VCs con las clases del servicio con excepción del UBR y de UBR+.

Usted no puede aplicar el WFQ por VC y el CBWFQ a UBR y a UBR+ VCs porque ambas clases de servicio son las clases Best-Effort que no garantizan el ancho de banda mínima. Cuando el CBWFQ se habilita para un VC, todas las clases configuradas como parte de la política de servicio están instaladas en el sistema Fair Queuing.

Si usted aplica una política de servicio a un VC atmósfera y la directiva incluye una característica que no sea el Parallel Express Forwarding (PXF) - habilitado, los paquetes serán llevados en batea al trayecto de Switching inferior siguiente. Ejecute el comando show pxf acc summ y busque un valor que incrementa para las bateas debido a la “función de resultados.”

router#show pxf acc sum      
            Pkts             Dropped   RP Processed             Ignored 
           Total                 242      328395045                   0 
10 second averages: PXF complex busy:       28%  PXF read pipeline full:   0% 
PXF Statistic: 
     Packets RP -> PXF: 
         switch ip:                       0 
         switch raw:              556612940 
         qos fastsend:                    0 
         qos enqueue:                     0 
     Total:                       556612940 
Packets PXF -> RP: 
         qos pkts:                        0 
         fast pkts:               228217649 
         drops: total                   242 
           "    no route               :         242 
         punts: total             328395045 
           "    not IP                 :         597 
           "    IP options             :         676 
           "    CEF no adjacency       :      186770 
           "    CEF receive            :      265306 
           "    output feature         :   327916956 

Configuración CBWFQ avanzada en routers 7200

En los Cisco 7200 Router que funcionan con la versión deL Cisco IOS 12.1(5)E, 12.1(5)T y posterior, podemos agrupar las clases de la correspondencia para formar correspondencias más complicadas de la clase. Además, podemos asociar las operaciones lógicas para clasificar los parámetros de la correspondencia (determinar si el tráfico corresponde con una clase).

Miremos las correspondencias siguientes de la clase para aclarar este concepto:

Configuración avanzada de CBWFQ
class-map match-all ixia
  description traffic from Ixia 
  match input-interface FastEthernet1/0 
class-map match-all ftp1 
  description ftp traffic initiated by the traffic generator 
  match class-map ixia 
  match class-map ftp2 
class-map match-all ftp2 
  match access-group 103 
class-map match-any test 
  match access-group 102    
  match input-interface Ethernet0/0 
! 
access-list 103 permit tcp any any eq ftp    
! 
access-list 102 permit ip host 10.1.1.1 any

La diferencia entre match-all y match-any es la siguiente:

  • corresponda con todos: un flujo se asocia a una correspondencia de la clase si se verifican todas las condiciones asociadas.

  • el match-any significa: un flujo se asocia a un clase-mapa si NINGUNAS de las condiciones asociadas se verifican (no no necesariamente todas las condiciones).

Podemos ver aquí que una correspondencia de la clase puede incluir las pruebas contra otras correspondencias de la clase configurada. En este caso, un flujo se asocia a ftp1 si hace juego todas las condiciones definidas bajo el ixia y la correspondencia ftp2 de la correspondencia de la clase de la clase.

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • show policy-map interface atm x/y.z — Este comando permite que usted considere las estadísticas por la cola, tal como los descensos. Es útil para monitorear los resultados de una servicio-directiva creada con el comando line interface(cli) de la calidad de servicio modular de Cisco (QoS) (MQC). Para información más detallada sobre cómo interpretar la salida de este comando, refiera comprensión de los contadores de paquetes en la salida del show policy-map interface.

            7200#show policy-map interface atm 2/0.130 
             ATM2/0.130: VC 1/130 - output : mypol 
              Weighted Fair Queueing 
                Class ixia 
                  Output Queue: Conversation 264 
                    Bandwidth 40000 (kbps) Packets Matched 0 Max Threshold 40(packets) 
                    (discards/tail drops) 0/0 
                Class loopbacks 
                  Output Queue: Conversation 265 
                    Bandwidth 10000 (kbps) Packets Matched 0 Max Threshold 64(packets) 
                    (discards/tail drops) 0/0 
                Class class-default 
                  Output Queue: Conversation 266 
                    Bandwidth 0 (kbps) Packets Matched 0 Max Threshold 64 (packets) 
                    (discards/tail drops) 0/0

    Nota: Vea las explicaciones siguientes con respecto a los dos tipos de descensos:

    • Descartes: descensos totales de esta cola.

    • Eliminaciones de cola: los descensos de esta cola solamente cuando otra cola tiene un paquete entrante con un “más bajo” número de secuencia WFQ y el sistema WFQ alcanzan el número de límite máximo de cola del paquete.

  • VC del show policy-map interface atm x/y.z [vcd | vpi/vci] — este comando da más granularity para VCs específico.

            7200#show policy-map interface atm 2/0.130 vc 1/130 
             ATM2/0.130: VC 1/130 - output : mypol 
              Weighted Fair Queueing 
                Class ixia 
                  Output Queue: Conversation 264 
                    Bandwidth 40000 (kbps) Packets Matched 0 Max Threshold 40(packets) 
                    (discards/tail drops) 0/0 
                Class loopbacks 
                  Output Queue: Conversation 265 
                    Bandwidth 10000 (kbps) Packets Matched 0 Max Threshold 64(packets) 
                    (discards/tail drops) 0/0 
                Class class-default 
                  Output Queue: Conversation 266 
                    Bandwidth 0 (kbps) Packets Matched 0 Max Threshold 64 (packets) 
                    (discards/tail drops) 0/0
    

Usted puede también utilizar otros comandos como el clase-mapa de la demostración o mostrar la clase del directiva-mapa para conseguir más información detallada en las clases de la correspondencia.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 10395