Marcado y acceso remotos : Conexiones asíncronas

DNIS y sondeo del módem con una línea PRI

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Las configuraciones de muestra en este documento ilustran cómo configurar el soporte del Servicio de identificación del número digital (DNIS) para una Interfaz de velocidad principal (PRI) y cómo configurar el agrupamiento de módems. Se proveen tres configuraciones:

  1. Modem pooling con los módems múltiples definidos en el pool-rango.

  2. Modem pooling con un módem en el pool-rango.

  3. Sondeo del módem sin un rango de grupo

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Software Release 11.3(1.1)T o Posterior del ½ del ¿Â de Cisco IOSïÂ.

  • PRI provista por la compañía de telecomunicaciones para el soporte de DNIS.

  • Router Cisco serie AS5x00.

Nota: El agrupamiento de módems no es posible en el router Cisco Serie 3600.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Teoría Precedente

Si usa el Servicio de usuario de acceso telefónico de autenticación remota (RADIUS) como protocolo de autenticación, necesita conocer la función de contabilidad 30 (Estación-ID) de RADIUS (IETF).

La identificación de estación permite que el servidor de acceso a la red (NAS) envíe el número desde donde llamó el usuario como parte del paquete de petición de acceso (con DNIS o tecnología similar). La Id. de estación sólo se admite en llamadas ISDN y de módem en Cisco AS5x00 cuando se lo utiliza con PRI.

Configurar

Este documento usa las configuraciones detalladas a continuación.

  • Agrupación de módems en un rango de conjuntos

  • Un módem en una agrupación

  • Agrupación de módems sin un rango de grupo

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la herramienta Command Lookup.

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/10383/pri_dnis_mpool.gif

Configuración 1: Agrupación de módems en un rango de conjuntos

Notas de configuración

Un cliente marca 5557528 y se conecta a un módem en el rango de grupos de 3 a 5. Las líneas 3 a la 5 están configuradas según el comando autocommand telnet para dirigir al usuario a una dirección IP específica, una vez que se hayan ingresado el ID de usuario de conexión y la contraseña cuando el router los solicita (>).

precaución Precaución: Cuando usted configura función del número al que se llamó y no pone en el número de conexión máxima, el router Cisco omite el número de módems en el pool. En este ejemplo de configuración, los módems 3 a 5 están configurados de forma tal que el software del IOS de Cisco agrega max-conn 3 al final del comando called-number.

Si cambia la cantidad de módems en los recursos compartidos, debe cambiar manualmente el número de conexión máxima.

Este ejemplo de configuración usa autenticación local.

Agrupación de módems en un rango de conjuntos
Current configuration: 
! 
version 11.3 
service timestamps debug datetime msec 
service password-encryption 

service udp-small-servers 
service tcp-small-servers 
! 
hostname isdn2-2 
! 

aaa new-model 
! 
username cisco password 7 xxxxxxxxx 
! 
modem-pool tito 
 pool-range 3-5 
 called-number 5557528 max-conn 3 
ip domain-name cisco.com 
isdn switch-type primary-5ess 
clock timezone PST -8 
clock summer-time PDT recurring 
! 
! 
controller T1 0 
 framing esf 
 clock source line primary 
 linecode b8zs 
 pri-group timeslots 1-24 
 description 5557528 pri 
! 
controller T1 1 
 framing esf 
 clock source line secondary 
 linecode b8zs 
! 
interface Loopback0 
 ip address 10.1.1.1 255.0.0.0 
! 
interface Ethernet0 
 ip address 172.16.25.52 255.255.255.240 
! 
interface Serial0 
 no ip address 
 shutdown 
! 
interface Serial1 
 no ip address 
 shutdown 
! 
interface Serial0:23 
 no ip address 
 no ip mroute-cache 
 isdn incoming-voice modem 
 no cdp enable 
! 
interface Group-Async1 
 no ip address 
 group-range 1 24 
! 
router eigrp 202 
 network 172.16.0.0 
 distance 90 172.16.25.49 0.0.0.0 
 distance 255 0.0.0.0 255.255.255.255 
 no auto-summary 
! 
ip default-gateway 172.16.25.49 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.16.25.49 
! 
line con 0 
 exec-timeout 0 0 
line 1 2 
 modem InOut 
line 3 5 
 modem InOut 
 autocommand telnet 10.1.1.1 
line 6 24 
 modem InOut 
line aux 0 
line vty 0 4 
 password 7 xxxxx 
! 
end 
 
isdn2-2# 

Consejos sobre Depuración y Verificación

Para asegurarse de que su configuración funcione correctamente, utilice los comandos show y debug. La salida de este comando debe ser similar a la salida que se muestra a continuación.

isdn2-2#show version 
Cisco Internetwork Operating System Software 
IOS (tm) 5200 Software (C5200-D-L), Version 11.3(1.1)T, 
MAINTENANCE INTERIM SOFTWARE 
Copyright (c) 1986-1998 by cisco Systems, Inc. 
Compiled Sun 11-Jan-98 07:12 by ccai 
Image text-base: 0x03034CD4, data-base: 0x00005000 
 
ROM: System Bootstrap, Version 11.1(473), SOFTWARE 
 
isdn2-2 uptime is 18 hours, 41 minutes 
System restarted by reload 
System image file is "bootflash:c5200-d-l.113-1.1.T", booted via flash 
 
cisco AS5200 (68030) processor (revision 0x00) with 16384K/8192K 
bytes of memory. 
Processor board ID 03676053 
Bridging software. 
X.25 software, Version 3.0.0. 
Primary Rate ISDN software, Version 1.0. 
Mother board without terminator card. 
1 Ethernet/IEEE 802.3 interface(s) 
26 Serial network interface(s) 
24 terminal line(s) 
2 Channelized T1/PRI port(s) 
128K bytes of non-volatile configuration memory. 
8192K bytes of processor board System flash (Read/Write) 
8192K bytes of processor board Boot flash (Read ONLY) 
 
Configuration register is 0x2101 
 
isdn2-2#
  • muestre el módem-pool cuando no se conecta ningún usuario

    Los módems 3, 4 y 5 se han configurado para el grupo de módems denominado "tito" y ninguno de ellos ha marcado aún. La agrupación predeterminada es para los usuarios que marcan un número que no está configurado para una agrupación de módems definida.

    isdn2-2#show modem-pool 
    modem-pool: System-def-Mpool
    
    !--- default pool 
    
    modems in pool: 21 active conn: 0 
     3 no free modems in pool 
     
    modem-pool: tito
    
    !--- modem-pool named 'tito'  
    
    modems in pool: 3 active conn: 0 
     0 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 3, active conn: 0 
      0 max-conn exceeded, 0 no free modems in pool 
    
    
  • El comando show modem-pool cuando hay un usuario conectado

    Marcan adentro y están conectado a un usuario con el módem 5. El comando show modem-pool no visualiza que el módem en el pool fue utilizado.

    show modem-pool 
         ------------- 
    modem-pool: tito 
    modems in pool: 3 active conn: 1 
     0 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 3, active conn: 1 
      0 max-conn exceeded, 0 no free modems in pool 
    
    

    El comando show line muestra que el módem 5 está utilizado.

    isdn2-2#show line 
     Tty Typ   Tx/Rx   A Modem Roty AccO AccI Uses  Noise  Overruns 
    * 0 CTY        -  -   -  -  -   0    0    0/0 
      1 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
      2 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
      3 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
      4 TTY 115200/115200 - inout   -  -  -   1    0    0/0 
    * 5 TTY 115200/115200 - inout   -  -  -   1    0    0/0 
      6 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
      7 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
      8 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
      9 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
     10 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
     11 TTY 115200/115200 - inout   -  -  -   0    0    0/0 
     12 TTY 115200/115200 - inout   -  -  -   0    0    0/0
    
    [remaining output omitted]
    
  • Usando el comando debug isdn q931

    Note el número marcado por el usuario remoto. Este número debe coincidir con el número configurado bajo la agrupación de módems tito. El número de teléfono del usuario no es importante en este escenario.

    *Mar 1 18:54:31.951:     Called Party Number i = 0xC1, '4085557528' 
    

    Nota: Algunas de las siguientes líneas de resultado de depuración se han seccionado en líneas múltiples por motivos de impresión.

    isdn2-2# 
    *Mar 1 18:54:31.935: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x2B 
    *Mar 1 18:54:31.939:     Bearer Capability i = 0x9090A2 
    *Mar 1 18:54:31.939:     Channel ID i = 0xA98393 
    *Mar 1 18:54:31.943:     Progress Ind i = 0x8381 - Call not end-to-end ISDN,
       may have in-band info 
    *Mar 1 18:54:31.947:     Calling Party Number i = '!', 0x83, '4085559486' 
    *Mar 1 18:54:31.951:     Called Party Number i = 0xC1, '4085557528' 
    *Mar 1 18:54:31.963: ISDN Se0:23: Incoming call id = 0xA 
    *Mar 1 18:54:31.987: ISDN Se0:23: TX -> CALL_PROC pd = 8 callref = 0x802B 
    *Mar 1 18:54:31.991:     Channel ID i = 0xA98393 
    *Mar 1 18:54:32.023: ISDN Se0:23: TX -> ALERTING pd = 8 callref = 0x802B 
    *Mar 1 18:54:33.067: ISDN Se0:23: TX -> CONNECT pd = 8 callref = 0x802B 
    *Mar 1 18:54:33.143: ISDN Se0:23: RX <- CONNECT_ACK pd = 8 callref = 0x2B 
    isdn2-2# 
    
    
  • Resultado de debug isdn Q931 y debug modem csm

    El usuario está conectado para alinear 5 o el módem del módem 5 (slot/port)=0/4. El procesamiento de llamadas es de ordenamiento cíclico. El primer módem usado es 3, el siguiente es 4, y el último es 5. No importa si está disponible el primer módem.

    isdn2-2# show line 5 
         
     TTY Typ   TX/Rx   A Modem Roty AccO AccI Uses  Noise  Overruns 
    * 5 TTY 115200/115200 - inout   -  -  -   1    0    0/0 
     
    Line 5, Location: "", Type: "" 
    Length: 24 lines, Width: 80 columns 
    Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits 
    Status: Ready, Active, No Exit Banner 
    Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out 
     Modem Callout, Modem RI is CD 
    Modem state: Ready 
     modem(slot/port)=0/4, state=CONNECTED 
     dsx1(slot/unit/channel)=2/0/18, status=VDEV_STATUS_ACTIVE_CALL. 
    Modem hardware state: CTS DSR DTR RTS 
    Special Chars: Escape Hold Stop Start Disconnect Activation 
            ^^x  none  -   -    none 
    Timeouts:   Idle EXEC  Idle Session  Modem Answer Session  Dispatch 
            00:10:00    never            none   not set 
                  Idle Session Disconnect Warning 
                   never 
    Modem type is unknown. 
    Session limit is not set. 
    Time since activation: 00:01:35 
    Editing is enabled. 
    History is enabled, history size is 10. 
    DNS resolution in show commands is enabled 
    Full user help is disabled 
    Allowed transports are pad telnet rlogin mop. Preferred is telnet. 
    Automatically execute command "telnet 10.1.1.1" 
    No output characters are padded 
    No special data dispatching characters 
    isdn2-2# 
    
    
  • ‘Resultado de debug’

    isdn2-2# 
    %SYS-5-CONFIG_I: Configured from console by console 
    *Mar 1 19:00:07.227: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x2D 
    *Mar 1 19:00:07.227:     Bearer Capability i = 0x9090A2 
    *Mar 1 19:00:07.231:     Channel ID i = 0xA98393 
    *Mar 1 19:00:07.235:     Progress Ind i = 0x8381 - Call not end-to-end ISDN,
       may have in-band info 
    *Mar 1 19:00:07.239:     Calling Party Number i = '!', 0x83, '4085559444' 
    *Mar 1 19:00:07.243:     Called Party Number i = 0xC1, '4085557528' 
    *Mar 1 19:00:07.255: ISDN Se0:23: Incoming call id = 0xC 
    *Mar 1 19:00:07.259: EVENT_FROM_ISDN::dchan_idb=0x25B660, call_id=0xC, ces=0x1 
      bchan=0x12, event=0x1, cause=0x0 
    *Mar 1 19:00:07.263: VDEV_ALLOCATE: slot 0 and port 4 is allocated. 
    *Mar 1 19:00:07.263: EVENT_FROM_ISDN:(000C): DEV_INCALL at slot 0 and port 4 
    *Mar 1 19:00:07.267: CSM_PROC_IDLE: CSM_EVENT_ISDN_CALL at slot 0, port 4 
    *Mar 1 19:00:07.267: Fast Ringing On at modem slot 0, port 4 
    *Mar 1 19:00:07.291: ISDN Se0:23: TX -> CALL_PROC pd = 8 callref = 0x802D 
    *Mar 1 19:00:07.291:     Channel ID i = 0xA98393 
    *Mar 1 19:00:07.343: ISDN Se0:23: TX -> ALERTING pd = 8 callref = 0x802D 
    *Mar 1 19:00:08.367: Fast Ringing Off at modem slot 0, port 4 
    *Mar 1 19:00:08.367: CSM_PROC_IC1_RING: CSM_EVENT_MODEM_OFFHOOK at slot 0, port 4 
    *Mar 1 19:00:08.379: ISDN Se0:23: TX -> CONNECT pd = 8 callref = 0x802D 
    *Mar 1 19:00:08.451: ISDN Se0:23: RX <- CONNECT_ACK pd = 8 callref = 0x2D 
    *Mar 1 19:00:08.463: EVENT_FROM_ISDN::dchan_idb=0x25B660, call_id=0xC, ces=0x1 
       bchan=0x12, event=0x4, cause=0x0 
    *Mar 1 19:00:08.467: EVENT_FROM_ISDN:(000C): DEV_CONNECTED at slot 0 and port 4 
    *Mar 1 19:00:08.471: CSM_PROC_IC4_WAIT_FOR_CARRIER: CSM_EVENT_ISDN_CONNECTED at
       slot 0, port 4 
    *Mar 1 19:00:20.939: TTY5: DSR came up 
    *Mar 1 19:00:20.947: tty5: Modem: IDLE->READY 
    *Mar 1 19:00:20.951: TTY5: EXEC creation  
    
  • muestre el módem-pool sin los módems libres

    El siguiente resultado muestra que todos los módems están ocupados y una llamada rechazada por la configuración de llamadas de ISDN.

    modem-pool: System-def-Mpool 
    modems in pool: 21 active conn: 0 
     3 no free modems in pool 
     
    modem-pool: tito 
    modems in pool: 3 active conn: 0 
         3 no free modems in pool
    
    !--- This number is the number of times it has failed to allocate a modem 
    !--- from the pool. It is not the number of modems in the pool.) 
    
    called_party_number: 5557528 
         max conn allowed: 3, active conn: 0
    
    !--- 3 is the number of modems configured in the pool tito. 
    !--- None are active.
    
    0 max-conn exceeded, 3 no free modems in pool 
    
    !--- failed 3 times to allocate a modem from the pool
    
    
    isdn2-2#debug isdn events 
    ISDN events debugging is on 
    isdn2-2# 
    *Mar 1 19:11:26.471: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x2F 
    *Mar 1 19:11:26.475:     Bearer Capability i = 0x9090A2 
    *Mar 1 19:11:26.479:     Channel ID i = 0xA98393 
    *Mar 1 19:11:26.479:     Progress Ind i = 0x8381 
    - Call not end-to-end ISDN, may have in-band info 
    *Mar 1 19:11:26.483:     Calling Party Number i = '!', 0x83, '4085559445' 
    *Mar 1 19:11:26.487:     Called Party Number i = 0xC1, '4085557528' 
    *Mar 1 19:11:26.499: ISDN Se0:23: Incoming call id = 0xE 
    *Mar 1 19:11:26.503: CCPRI, state = 0, serv = 0, int_id = 0, 
    lo_chan = 19, type = 3, Dsl_Id = 0, callid = E 
    *Mar 1 19:11:26.507: CCPRI in a Glare situation state 0 serv 0 
    *Mar 1 19:11:26.511: ISDN Se0:23: received CALL_INCOMING 
    *Mar 1 19:11:26.511:  extracted channel ie[0-8]= 18 3 A9 83 93 38 34 33 32 
    *Mar 1 19:11:26.515: 
    *Mar 1 19:11:26.519: ISDN Se0:23: Event: 
    Received a Voice call from 4085559445 on B19 at 64 Kb/s 
    *Mar 1 19:11:26.519: ISDN Se0:23: 
    CALL_INCOMING: MODEM ERROR 2C: bchan 18, call id E 
    *Mar 1 19:11:26.535: in CCPRI_ReleaseCall bchan is 13 dsl is 0 
    *Mar 1 19:11:26.539: leaving CCPRI_ReleaseCall, Allocated CCBs = 0 
    *Mar 1 19:11:26.543: ISDN Se0:23: entering process_rxstate, CALL_CLEARED 
    *Mar 1 19:11:26.615: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x802F 
    *Mar 1 19:11:26.615:     Cause i = 0x80AC - Requested channel not available 
    isdn2-2# 
    

Configuración 2: Un módem en una agrupación

Un módem en una agrupación
enable password 7 XXXXXXXXXX 
! 
username cisco password 7 xxxxxxxxxxxx 
! 
modem-pool tito 
 pool-range 3

! -- only modem #3 is configured

 called-number 5557528 max-conn 1       
ip domain-name cisco.com 
isdn switch-type primary-5ess 
clock timezone PST -8 
clock summertime PDT recurring 
! 
!

Consejos sobre Depuración y Verificación

Para asegurarse de que su configuración funcione correctamente, utilice el comando show. El resultado de este comando debe ser similar al resultado que se muestra a continuación:

  • muestre el módem-pool con un módem

    El producto siguiente muestra a un agrupamiento de módems configurado con un módem. Dos usuarios marcan al mismo tiempo y un usuario está conectado.

    isdn2-2# show modem-pool 
     modem-pool: System-def-Mpool 
      modems in pool: 23 active conn: 0 
      3 no free modems in pool 
         
     modem-pool: tito 
      modems in pool: 1 active conn: 1 
      4 no free modems in pool 
      called_party_number: 5557528 
      max conn allowed: 1, active conn: 1 
      0 max-conn exceeded, 1 no free modems in pool 
    
    isdn2-2# show modem-pool 
    modem-pool: System-def-Mpool 
    modems in pool: 23 active conn: 0 
     3 no free modems in pool 
     
    modem-pool: tito 
    modems in pool: 1 active conn: 1 
     4 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 1, active conn: 1 
      0 max-conn exceeded, 1 no free modems in pool 
     
    isdn2-2#  
    

    En el producto siguiente, el primer usuario sigue conectado y diales los segundos de un usuario adentro una vez y la llamada falla.

    isdn2-2# 
    isdn2-2# 
    *Mar 1 19:38:57.103: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x33 
    *Mar 1 19:38:57.107:     Bearer Capability i = 0x9090A2 
    *Mar 1 19:38:57.111:     Channel ID i = 0xA98394 
    *Mar 1 19:38:57.111:     Progress Ind i = 0x8381 
    - Call not end-to-end ISDN, may have in-band info 
    *Mar 1 19:38:57.115:     Calling Party Number i = '!', 0x83, '4085559474' 
    *Mar 1 19:38:57.119:     Called Party Number i = 0xC1, '4085557528' 
    *Mar 1 19:38:57.135: ISDN Se0:23: Incoming call id = 0x12 
    *Mar 1 19:38:57.139: ISDN Se0:23: CALL_INCOMING: MODEM ERROR 2C: bchan 19, 
    call id 12 
    *Mar 1 19:38:57.235: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x8033 
    *Mar 1 19:38:57.239:     Cause i = 0x80AC - Requested channel not available 
    isdn2-2# 
    isdn2-2#show modem-pool 
    modem-pool: System-def-Mpool 
    modems in pool: 23 active conn: 0 
     3 no free modems in pool 
     
    modem-pool: tito 
    modems in pool: 1 active conn: 1 
     4 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 1, active conn: 1 
      1 max-conn exceeded, 1 no free modems in pool 
    isdn2-2# 
    
    

    Un segundo usuario intenta marcar adentro otra vez y falla. Note la declaración excedida MAX-CONN 2.

    isdn2-2# 
    *Mar 1 19:40:34.143: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x34 
    *Mar 1 19:40:34.147:     Bearer Capability i = 0x9090A2 
    *Mar 1 19:40:34.147:     Channel ID i = 0xA98394 
    *Mar 1 19:40:34.151:     Progress Ind i = 0x8381 - Call not end-to-end ISDN,
       may have in-band info 
    *Mar 1 19:40:34.155:     Calling Party Number i = '!', 0x83, '4085559486' 
    *Mar 1 19:40:34.159:     Called Party Number i = 0xC1, '4085557528' 
    *Mar 1 19:40:34.171: ISDN Se0:23: Incoming call id = 0x13 
    *Mar 1 19:40:34.179: ISDN Se0:23: CALL_INCOMING: MODEM ERROR 2C: bchan 19,
       call id 13 
    *Mar 1 19:40:34.267: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x8034 
    *Mar 1 19:40:34.271:     Cause i = 0x80AC - Requested channel not available 
    isdn2-2# 
    isdn2-2#show modem-pool 
    modem-pool: System-def-Mpool 
    modems in pool: 23 active conn: 0 
     3 no free modems in pool 
     
    modem-pool: tito 
    modems in pool: 1 active conn: 1 
     4 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 1, active conn: 1 
      2 max-conn exceeded, 1 no free modems in pool  
    isdn2-2# 
  • show modem-pool Cuando el primer usuario excede el tiempo de espera por inactividad.

    isdn2-2#show modem-pool 
    modem-pool: System-def-Mpool 
    modems in pool: 23 active conn: 0 
     3 no free modems in pool 
     
    modem-pool: tito 
    modems in pool: 1 active conn: 0 
     4 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 1, active conn: 0 
      2 max-conn exceeded, 1 no free modems in pool 
    
    modem-pool: System-def-Mpool 
    
     !--- This is the default modem pool 
    
    modems in pool: 23 active conn: 0 
    
     !--- There are 24 modems installed on this access server, 
     !--- 23 are available to the default pool, the other 
     !--- modem is available only to modem-pool tito 
    
     3 no free modems in pool 
    
     !--- Three failures to allocate a modem from a pool for a user dialing in
    
    
    modem-pool: tito 
    
    !--- Pool named tito 
    
    modems in pool: 1 active conn: 0 
    
    !--- One modem configured in this pool, 0 active connections to
    !--- modems in this pool 
    
     4 no free modems in pool 
    
     !--- Four failed attempts to allocate a modem to a user that dialed in. 
    
    called_party_number: 5557528 
    
    !--- This is the number of the Cisco access-server that the remote user dialed.
    
     max conn allowed: 1, active conn: 0 
    
     !--- Max connection allowed per pool, 0 active 
    
     2 max-conn exceeded, 1 no free modems in pool 
    
     !--- Failed twice to allocate a modem to the user because the 
     !--- number of connections was exceeded for that pool) 
    
     
    isdn2-2# 
    

Configuración 3: Agrupación de módems sin un rango de grupo

A excepción del comando pool-range 3-5 y del argumento max-conn, esta configuración es la misma que los Módems múltiples en la configuración Pool-Range (Rango de agrupamiento).

Agrupación de módems sin un rango de grupo
! 
modem-pool tito 
 called-number 5557528 max-conn 0 
ip domain-name cisco.com 
isdn switch-type primary-5ess 
!

Consejos sobre Depuración y Verificación

Para asegurarse de que su configuración funcione correctamente, utilice el comando show. El resultado de este comando debe ser similar al resultado que se muestra a continuación:

  • muestre el módem-pool antes del primer dial

    isdn2-2#show modem-pool 
    modem-pool: System-def-Mpool 
    modems in pool: 24 active conn: 1 
     3 no free modems in pool 
      
    modem-pool: tito 
    modems in pool: 0 active conn: 0 
     4 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 0, active conn: 0 
      0 max-conn exceeded, 0 no free modems in pool 
    
    
  • show modem-pool y debug Luego de que el usuario marca y no puede conectarse

    isdn2-2#debug isdn q931 
    ISDN Q931 packets debugging is on 
    isdn2-2#debug modem 
    Modem control/process activation debugging is on 
    isdn2-2# 
    *Mar 1 19:56:50.827: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x38 
    *Mar 1 19:56:50.827:     Bearer Capability i = 0x9090A2 
    *Mar 1 19:56:50.831:     Channel ID i = 0xA98393 
    *Mar 1 19:56:50.835:     Progress Ind i = 0x8381 - Call not end-to-end
       ISDN, may have in-band info 
    *Mar 1 19:56:50.839:     Calling Party Number i = '!', 0x83, '4085559474' 
    *Mar 1 19:56:50.843:     Called Party Number i = 0xC1, '4085557528' 
    *Mar 1 19:56:50.851: ISDN Se0:23: Incoming call id = 0x17 
    *Mar 1 19:56:50.859: ISDN Se0:23: CALL_INCOMING: MODEM ERROR 2C: bchan 18,
       call id 17 
    *Mar 1 19:56:50.947: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x8038 
    *Mar 1 19:56:50.951:     Cause i = 0x80AC - Requested channel not available 
    isdn2-2# 
    
    isdn2-2#show modem-pool 
    modem-pool: System-def-Mpool 
    modems in pool: 24 active conn: 0 
     3 no free modems in pool 
      
    modem-pool: tito 
    modems in pool: 0 active conn: 0 
     4 no free modems in pool 
     called_party_number: 5557528 
      max conn allowed: 0, active conn: 0 
      1 max-conn exceeded, 0 no free modems in pool 
    

Verificación

Refiera por favor a los ejemplos de configuración arriba para la información de verificación específica.

Troubleshooting

Refiera por favor a los ejemplos de configuración arriba para la información de verificación específica.


Información Relacionada


Document ID: 10383