WAN : Protocolo punto a punto (PPP)

links múltiples PPP en routers adosados con varias interfaces en serie

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

En algunos entornos, puede ser necesario liar los links seriales para actuar como solo ancho de banda total. Este documento describe cómo configurar un servidor de acceso del Cisco 2503 para liar dos interfaces seriales con dos métodos distintos:

Estas configuraciones pueden utilizarse para los routers conectados por líneas dedicadas o para routers que tienen la unidad de servicio de canal, la unidad de servicio de datos (CSU/DSU) o el adaptador de terminal (TA) ISDN configurado para marcado. (No han configurado a los routeres Cisco para marcar los números de teléfono.) Usted puede agregar las características adicionales a esta configuración para adaptarse a sus necesidades.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco 2503 Router

  • Software Release 12.2(7b) del ½ del ¿Â de Cisco IOSïÂ

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Productos Relacionados

Esta configuración se puede utilizar con cualquier dos Routers con dos interfaces seriales PÁLIDAS cada uno. Usted puede utilizar el WIC-1T, el WIC-2T, o las interfaces seriales PÁLIDAS fijas.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/10382/pppmultilink.gif

Configuraciones

Esta configuración fue probada con el Cisco IOS Software Release 12.2(7b) en los Cisco 2500 Series Router. Los conceptos de la misma configuración se aplicarían a una topología similar del router o a otras versiones de Cisco IOS Software.

Ejemplo 1: Marcador de la interfaz

Ejemplo 2: Plantilla virtual

Ejemplo 1: Marcador de la interfaz

Router1 - Cisco 2503
Current configuration:
version 12.2
 
hostname Router1
!
username Router2 password 0 abc

!--- This local username and password pair is used for PPP Challenge
!--- Handshake Authentication Protocol (CHAP) authentication.

ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
 ip address 192.168.10.2 255.255.255.0

!--- The loopback address is used by interface dialer 1.

!
!
interface Serial0
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1

 !--- Interface Serial0 is a member of rotary-group 1.
 !--- The rotary group configuration is in interface dialer 1. 

 no fair-queue
 pulse-time 1
!
interface Serial1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 pulse-time 1
!
interface Dialer1

!--- This is the configuration for rotary-group 1.
!--- The dialer interface number must exactly match the rotary group number.

 ip unnumbered Loopback0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 300
 dialer map ip 192.168.20.1 name Router2 broadcast
 dialer load-threshold 2 either
 dialer-group 1

 !--- Apply interesting traffic definition from dialer-list 1.

 no fair-queue
 ppp authentication chap
 ppp direction callout  

 !--- This is a hidden command; see the Notes section for more information.

 ppp multilink

 !--- Allow multilink for the dialer profile.
 !--- Without this command, multilink is NOT negotiated.

!
ip classless
ip route 192.168.20.1 255.255.255.255 Dialer1
dialer-list 1 protocol ip permit

!--- The dialer-list defines the interesting traffic.

!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Router2 - Cisco 2503
Current configuration:
version 12.2
hostname Router2
!
!
username Router1 password 0 abc
ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
!
!
interface Serial0
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 clockrate 56000
 pulse-time 1
!
interface Serial1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 clockrate 56000
 pulse-time 1
!
!
interface Dialer1
 ip unnumbered Loopback0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 999
 dialer map ip 192.168.10.2 name Router1 broadcast
 dialer load-threshold 2 either
 dialer-group 1
 no fair-queue
 no cdp enable
 ppp authentication chap
 ppp multilink
!
ip classless
ip route 192.168.10.2 255.255.255.255 Dialer1
!
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
line vty 0 4
!
end

Notas del ejemplo 1

El comando ppp direction callout es un comando oculto usado cuando un router se encuentra confundido acerca de quién llamó a quién (cuando está conectado en forma adosada o conectado mediante líneas arrendadas y el CSU/DSU o el ISDN TA están configurados para el marcado). El comando ppp direction callin puede también ser utilizado. Utilice uno de estos comandos.

  • Para un router local, utilice el ppp direction callout.

  • Para un router remoto, utilice el callin de la dirección ppp.

Si usted no utiliza este comando, el router conecta para un momento y entonces las desconexiones.

La configuración antedicha describe dos Routers, router1 y router2, que tienen dos interfaces seriales que se liarán para actuar como solo ancho de banda total. En ambo Routers, el Interface Loopback se configura y se integra con el marcador de la interfaz usando el loopback0 innumerable del IP. Ambas interfaces seriales se configuran para ninguna dirección IP. El serial0 y el Serial1 de las interfaces físicas se configuran con el grupo rotativo de dialers y se asocian a un solo marcador de la interfaz lógica.

El dialer-list 1 define el tráfico interesante, que a su vez acciona el comando dialer-group 1 en el interface dialer 1 de sacar a colación el link. La sentencia del mapa de marcado definida en ambo Routers asocia el interface dialer 1 al IP Address del router del par, y el nombre de host definido sirve en la autenticación CHAP. La Static ruta definida rutea el tráfico al destino.

El comando ppp authentication chap habilita la negociación PPP. El comando dialer load-threshold fija una carga esa los activadores para traer la segunda línea serial. Han configurado a los comandos ppp multilink y dialer rotary-group para poder liar ambas interfaces seriales juntas como una interfaz de acceso virtual para el ancho de banda total. El comando ppp direction callout determina que el lado tiene que hacer un reclamo durante la negociación PPP y la autenticación CHAP.

Verifique el ejemplo 1

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Router1# show ppp multilink 
Virtual-Access1, bundle name is Router2 
  Bundle up for 00:01:05 
  Dialer interface is Dialer1 
  0 lost fragments, 0 reordered, 0 unassigned 
  0 discarded, 0 lost received, 1/255 load 
  0x0 received sequence, 0x0 sent sequence 
  Member links: 2 (max not set, min not set) 
    Serial0, since 00:01:05, no frags rcvd 
    Serial1, since 00:01:05, no frags rcvd   

 Router2# show ppp multilink  

 Virtual-Access1, bundle name is Router1
  Bundle up for 00:03:25
  Dialer interface is Dialer1
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x0 received sequence, 0x0 sent sequence
  Member links: 2 (max not set, min not set)
    Serial1, since 00:03:25, no frags rcvd
    Serial0, since 00:03:25, no frags rcvd

Ejemplo 1 del Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de ejecutar un comando de depuración, consulte Información importante sobre comandos de depuración.

comandos debug

En el router1, el comando debug ppp authentication muestra el éxito de la GRIETA.

May  8 17:52:19: Se1 PPP: Using configured call direction
May  8 17:52:19: Se1 PPP: Treating connection as a callout
May  8 17:52:19: Se0 CHAP: O CHALLENGE id 135 len 28 from "Router1"
May  8 17:52:19: Se1 CHAP: O CHALLENGE id 135 len 28 from "Router1"
May  8 17:52:19: Se0 CHAP: I CHALLENGE id 134 len 28 from "Router2"
May  8 17:52:19: Se0 CHAP: O RESPONSE id 134 len 28 from "Router1"
May  8 17:52:19: Se1 CHAP: I CHALLENGE id 134 len 28 from "Router2"
May  8 17:52:19: Se1 CHAP: O RESPONSE id 134 len 28 from "Router1"
May  8 17:52:19: Se0 CHAP: I SUCCESS id 134 len 4
May  8 17:52:19: Se0 CHAP: I RESPONSE id 135 len 28 from "Router2"
May  8 17:52:19: Se0 CHAP: O SUCCESS id 135 len 4
May  8 17:52:19: Se1 CHAP: I SUCCESS id 134 len 4
May  8 17:52:19: Se1 CHAP: I RESPONSE id 135 len 28 from "Router2"
May  8 17:52:19: Se1 CHAP: O SUCCESS id 135 len 4
5d05h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
May  8 17:52:19: Vi1 PPP: Using configured call direction
May  8 17:52:19: Vi1 PPP: Treating connection as a callout
5d05h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
5d05h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to up

En el router2, el comando debug ppp authentication muestra “para al par que espera….”

5d02h: %LINK-3-UPDOWN: Interface Serial0, changed state to up
5d02h: Se0 PPP: Treating connection as a callin
5d02h: Se0 CHAP: O CHALLENGE id 132 len 28 from "Router2"
5d02h: Se0 CHAP: I CHALLENGE id 133 len 28 from "Router1"
5d02h: Se0 CHAP: Waiting for peer to authenticate first
5d02h: Se0 CHAP: I RESPONSE id 132 len 28 from "Router1"
5d02h: Se0 CHAP: O SUCCESS id 132 len 4
5d02h: Se0 CHAP: Processing saved Challenge, id 133
5d02h: Se0 CHAP: O RESPONSE id 133 len 28 from "Router2"
5d02h: Se0 CHAP: I SUCCESS id 133 len 4
5d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up

Ejemplo 2: Plantilla virtual

Router1 - Cisco 2503
Current configuration
!
version 12.2
!
hostname Router1
!
!
username Router2 password 0 abc
 
ip subnet-zero
no ip domain-lookup
!
 
multilink virtual-template 1

!--- Applies the virtual interface template to the multilink bundle.

 
interface Loopback0
 ip address 192.168.10.2 255.255.255.0

 !--- The loopback address is used by virtual-template 1.

 
 
interface Virtual-Template1

!--- Interface virtual-template is a logical interface that creates
!--- virtual access interfaces dynamically and applies them to 
!--- physical serial interfaces.

 ip unnumbered Loopback0

!--- Always unnumber the virtual-template to an UP interface.
!--- Do not assign a static IP.

 ppp authentication chap
 ppp multilink 

 !--- Enables multilink PPP on the virtual-template interface.

 
interface Serial0
 no ip address
 encapsulation ppp
 pulse-time 1
 ppp multilink
!
interface Serial1
 no ip address
 encapsulation ppp
 pulse-time 1
 ppp multilink
!
!
ip classless
!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Router2 - Cisco 2503
Current configuration :
!
version 12.2
!
hostname Router2
!
!
username Router1 password 0 abc
 
ip subnet-zero
no ip domain-lookup
!
multilink virtual-template 1
!
!
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
!
!
interface Virtual-Template1
 ip unnumbered Loopback0
 ppp authentication chap
 ppp multilink
!
interface Serial0
 no ip address
 encapsulation ppp
 no fair-queue
 clockrate 56000
 pulse-time 1
 ppp multilink
!
interface Serial1
 no ip address
 encapsulation ppp
 no fair-queue
 clockrate 56000
 pulse-time 1
 ppp multilink
!
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
!
end

La configuración antedicha describe la plantilla virtual configurada en el router1 y el router2. En este ejemplo, ambos routers están configurados con plantillas virtuales. Los routers están adosados y la sesión de links múltiples no se interrumpe por inactividad. Se necesitan rutas no estáticas. una ruta host se instala luego de las negociaciones PPP.

Utilice la versión de software del IOS de Cisco 11.3 o posterior para utilizar la plantilla virtual para el link múltiple PPP.

El comando virtual template crea dinámicamente una interfaz de acceso virtual y los aplica a las interfaces del serial física con el comando multilink virtual-template. Los parámetros (tales como grieta de la autenticación PPP) configurados en la plantilla virtual de la interfaz son aplicados para ambas interfaces seriales. El comando ppp multilink en la virtual-plantilla de la interfaz lía las interfaces del serial física para formar un acceso virtual para agregar el ancho de banda.

Verifique el ejemplo 2

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Router2# show ppp multilink
 
Virtual-Access1, bundle name is Router1

!--- Virtual Access interface used for the bundle

  Bundle up for 00:20:38
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x0 received sequence, 0x0 sent sequence
  Member links: 2 (max not set, min not set)
    Serial1, since 00:20:39, no frags rcvd
    Serial0, since 00:20:39, no frags rcvd

!--- Note that there are two links (Se 0 and Se1) in the bundle

Estos comandos pueden también ayudar:

  • show ip route connected — Para ver si la ruta de IP para el acceso virtual está instalada.

  • show interface virtual-access x — Para marcar el estatus de una interfaz de acceso virtual determinada. En el ejemplo anterior, el número de la interfaz de acceso virtual es 1.

Ejemplo 2 del Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de ejecutar un comando de depuración, consulte Información importante sobre comandos de depuración.

Configure los grupos fecha/hora en la configuración global como sigue:

service timestamps debug datetime msec
service timestamps log datetime msec

Utilice estos comandos de resolver problemas:

  • haga el debug de la negociación ppp — Para ver si un cliente pasa la negociación PPP. También puede verificar qué opciones (devolución de llamada, links múltiples PPP [MLP] y otros) y qué protocolos (IP, IPX, etc.) se negocian.

  • autenticación PPP del debug — Para ver si un cliente pasa la autenticación.

  • debug vtemplate — Para ver se utilizan qué configuraciones de plantilla virtual.

  • debug vprofile — Para ver qué opciones de configuración se aplican a la interfaz de acceso virtual.


Información Relacionada


Document ID: 10382