Marcado y acceso remotos : Conexiones asíncronas

Conexión de Routers Adosados Mutuamente Mediante Puertos Auxiliares

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Esta configuración de ejemplo muestra cómo conectar directamente dos routers, sin un módem ni otros dispositivos de Equipo de comunicación de datos (DCE). Para más información sobre cómo configurar los módems en el auxiliar (AUX) o los puertos de la consola, vea la guía para la conexión del módem-router o el soporte de tecnología de acceso de marcado.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Antecedentes

En esta configuración, dos routeres Cisco están conectados continuamente a través de los puertos auxiliares asíncronos con la ayuda de un cable módem nulo (cable transpuesto de consola). Los puertos auxiliares del dos Routers están conectados directamente con la ayuda de un cable transpuesto de consola con el Point-to-Point Protocol (PPP) que se ejecuta en el link. Los puertos AUX son dispositivos de equipos terminales de datos (DTE). Usted requerirá un cable módem nulo (cable transpuesto de consola) conectar el DTE con los dispositivos DTE.

El cable transpuesto (módem nulo) satinado plano (número de pedido CAB-500RJ= ) usualmente es proporcionado con todos los routers Cisco para permitir una conectividad de la consola RJ-45. Si el puerto auxiliar es un DB-25, utilice una “terminal marcada adaptador” del RJ-45-to-DB-25 con el cable módem nulo (cable transpuesto de consola).

Nota: Asegúrese de que la longitud del cable sea menos de los pies debido 50 (conocido antes como RS-232) a las limitaciones EIA/TIA-232.

Para más información sobre el cableado, refiera al guía del cableado para la consola RJ-45 y los puertos auxiliares y rj-45 cables.

Routers con puertos auxiliares DB-25

Para el Routers con un puerto auxiliar DB-25 (por ejemplo, Cisco4500, 7200 y 7500), usted necesita un cable módem nulo del DB-25-to-DB-25. Este cable se puede comprar en la mayoría de las tiendas de descuento de electrónica.

Nota: Debido a los pares de señales incorrectos, usted NO PUEDE utilizar un cable satinado plano rolled del RJ-45-to-RJ-45 con los adaptadores del RJ-45-to-DB-25 (numero de parte CAB-25AS-MMOD) en los ambos extremos.

Verifique si su cable módem nulo del DB-25-to-DB-25 tenga las conexiones de pin indicadas en el cuadro 1.

Cuadro 1 – Conexiones de pin del cable módem nulo del DB-25-to-DB-25

DB-25 DB-25
Rxd 2 3 TXD
TxD 3 2 Rxd
CTS 4 5 RTS (Sistema activador de RADIUS)
RTS (Sistema activador de RADIUS) 5 4 CTS
DTR (ritmo de transferencia de datos) 6 20 CD
DSR (Ajuste de datos listo) 8
CD 20 6 DTR (ritmo de transferencia de datos)
8 DSR (Ajuste de datos listo)
GND 7 7 GND

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/10365/auxback.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

  • Router 1

  • Router 2

Nota: Esta conexión se ha configurado con direcciones IP en los puertos auxiliares para una conexión permanente (“constante”).

Router 1
version 11.1
 service udp-small-servers
 service tcp-small-servers
 !
 hostname Router1
 !
 interface Ethernet0
  no ip address
  shutdown
 !
 interface Serial0
  no ip address
  shutdown
 !
 interface Serial1
  no ip address
  shutdown
 !         
 interface Async1

 !--- The async interface that corresponds to the AUX port.
 !--- Use the show line command to determine which async interface corresponds
 !--- to the AUX port.

  ip address 192.168.10.1 255.255.255.0

 !--- The IP address on the AUX ports of both routers are in the same subnet.

  encapsulation ppp

 !--- Set PPP as the encapsulation.

  async default routing 

 !--- This allows routing protocols on the link. 

  async mode dedicated
 !
 no ip classless
 ip route 0.0.0.0 0.0.0.0 Async1

 !--- The default route points to the Async1 (AUX port) interface.

 logging buffered
 !
 line con 0
  exec-timeout 0 0
 line aux 0

 !--- Line configuration for the AUX port.

  modem InOut
  transport input all

  !--- This allows all protocols to use the line.

  rxspeed 38400

  !--- Set the Rx speed (identical to the TX speed of the other router).

  txspeed 38400

  !--- Set the Tx speed (identical to the RX speed of the other router).

  flowcontrol hardware
 line vty 0 4
  login
 !
 end

Router 2
version 11.1

 service udp-small-servers
 service tcp-small-servers
 !
 hostname Router2
 !
 interface Ethernet0
  ip address 10.1.1.1 255.255.255.0
 !
 interface Serial0
  no ip address
  shutdown
 !
 interface Serial1
  no ip address
  shutdown
 !         
 interface Async1

 !--- The async interface that corresponds to the AUX port.
 !--- Use the show line command to determine which async interface corresponds
 !--- to the AUX Port.

  ip address 192.168.10.2 255.255.255.0

  !--- The IP address on the AUX ports of both routers are in the same subnet.

  encapsulation ppp

  !--- Set PPP as encapsulation.

  async default routing 
  
!--- This allows routing protocols on the link.
 
  async mode dedicated
 !
 no ip classless
 ip route 0.0.0.0 0.0.0.0 Ethernet0
 
!--- This default route points to interface Ethernet0.

 logging buffered
 !
 line con 0
  exec-timeout 0 0
 line aux 0

 !--- Line configuration for the AUX port.

  modem InOut
  transport input all

 !--- This allows all protocols to use the line.

  rxspeed 38400

 !--- set the Rx speed (identical to the TX speed of the other router).

  txspeed 38400

 !--- set the Tx speed (identical to the RX speed of the other router).

  flowcontrol hardware
 line vty 0 4
  login
 !
 end

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Procedimiento de Troubleshooting

Antes de ejecutar un comando debug, consulte Información Importante sobre Comandos Debug.

Complete estos pasos:

  1. Utilice el comando show line de determinar la interfaz asincrónica de los puertos auxiliares.

    Aunque la mayoría de los routers tienen el puerto AUX como interfaz asíncrona 1, los servidores de acceso tienen la interfaz de puerto AUX después de las líneas TTY. Por ejemplo, si su router tiene 16 líneas de módem asíncrono, el puerto auxiliar es la línea 17. En tal caso, el puerto auxiliar se debe configurar en el interface async 17. Configure el puerto AUX en función de las salidas de línea show. Aquí está un ejemplo a verificar que la configuración de puerto auxiliar está en el Async1 de la interfaz en su Routers:

    Router1#show line
     Tty Typ     Tx/Rx    A Modem Roty AccO AccI Uses  Noise  Overruns
    *  0 CTY              -    -     -    -    -    0      0       0/0
    A  1 AUX  38400/38400 - inout    -    -    -    0      0       0/0
       2 VTY              -    -     -    -    -    0      0       0/0
       3 VTY              -    -     -    -    -    0      0       0/0
       4 VTY              -    -     -    -    -    0      0       0/0
       5 VTY              -    -     -    -    -    0      0       0/0
       6 VTY              -    -     -    -    -    0      0       0/0
  2. Publique el comando show line aux 0.

  3. Verifique que todas las señales estén activas (por ejemplo, Habilitar para enviar (CTS), Petición para enviar (RTS), Terminal de datos listo (DTR) y Detección de la portadora (CD)).

    Si no aparece nada al lado de ellas, están funcionando. Si aparece "No" al lado de ellos (por ejemplo, No-CTS), esto significa que se encuentran inactivos. Si están abajo, verifique la configuración en cada lado. Verifique que usted tenga la interfaz asincrónica y la línea del puerto auxiliar configurado (como se muestra arriba).

    Nota: Si la salida del comando show line indica que el DSR no está para arriba (noDSR), usted debe verificar que el cada extremo en el cable módem nulo del DB-25-to-DB-25 tenga contactos 6 y 8 atado con alambre físicamente para fijar 20 en el otro extremo. Refiera al cuadro 1 para las configuraciones del cable correctas.

    Router1#show line aux 0
     Tty Typ    Tx/Rx     A Modem Roty AccO AccI Uses  Noise  Overruns
    A  1 AUX 38400/38400  - inout    -    -    -    0      0       0/0
    
    Line 1, Location: "", Type: ""
    Length: 24 lines, Width: 80 columns
    Baud rate (TX/RX) is 38400/38400, no parity, 2 stopbits, 8 databits
    Status: Ready, Active, Async Interface Active
    Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
      Modem Callout, Modem RI is CD, Line is permanent async interface
    Modem state: Ready
    Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                    ^^x    none   -     -       none         
    Timeouts:  Idle EXEC  Idle Session  Modem Answer  Session  Dispatch
               00:10:00      never                       none   not set
    Modem type is unknown.
    Session limit is not set.
    Time since activation: 00:00:30
    Editing is enabled.
    History is enabled, history size is 10.
    Full user help is disabled
    Allowed transports are pad v120 telnet.  Preferred is telnet.
    No output characters are padded
    No special data dispatching characters
    Line is running PPP for address 192.168.10.2.
    0 output packets queued, 1 input packets.
     Async Escape map is 00000000000000000101000000000000
    Modem hardware state: CTS* DSR*  DTR RTS 
    
  4. Si la configuración aparece correctamente, reemplace el cable transpuesto entre el router.

  5. Use los comandos shutdown y no shutdown en la interfaz asíncrona para reiniciar la conexión.

Comandos para resolución de problemas

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Utilice estos comandos debug de verificar que sube el link correctamente.

Nota: Antes de ejecutar un comando de depuración, consulte Información importante sobre comandos de depuración.

  • haga el debug de la negociación ppp — información de las visualizaciones sobre el tráfico y los intercambios PPP pues la negociación del (LCP), de la autenticación, y del protocolo network control del Link Control Protocol (NCP) está en curso. Una negociación PPP exitosa abrirá primero el estado LCP, luego realizará la autenticación y por último negociará el NCP. Si se envían los CONFREQ, solamente no se recibe, marcan ningunos CONFACK si el cableado está correcto, y si la línea correcta está configurada (publique el comando interface async x para esto).

  • la autenticación PPP del debug — los mensajes de protocolo de la autenticación PPP de las visualizaciones (si se configura la autenticación), e incluye los intercambios de paquetes del Challenge Handshake Authentication Protocol (CHAP) y los intercambios del protocolo password authentication (PAP). En esta autenticación de configuración no se configura. Por lo tanto, este comando debug no es necesario.

  • debug ppp error — errores del protocolo y estadística de errore de las visualizaciones asociados a la negociación y a la operación de la conexión PPP.


Información Relacionada


Document ID: 10365