Marcado y acceso remotos : Conexiones asíncronas

Configuración de marcado de salida con un módulo de módem analógico NM-8AM o NM-16AM

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento muestra cómo configurar el dialout usando un módem con el módulo de red con módem analógico NM-AM. En este escenario, un router con el módulo del módem NM-8AM marca la interfaz de la velocidad primaria (PRI) del router del sitio central.

Este documento asume que usted tiene una buena comprensión de los diversos problemas asociados a las configuraciones del módem. Si usted necesita más información sobre estos problemas, refiera por favor a la guía para la conexión del módem-router.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Esta configuración fue desarrollada y probada utilizando las versiones de software y hardware indicadas a continuación:

  • Un Cisco 3640 Router con el indicador luminoso LED amarillo de la placa muestra gravedad menor NM-8AM que funciona con el Software Release 12.1(5)T del ½ del ¿Â de Cisco IOSïÂ.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para encontrar la información adicional en los comandos usados en este documento, utilice la herramienta de búsqueda de comandos (clientes registrados solamente).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/10316/dialout-nmam.gif

Configuraciones

Este documento usa las configuraciones detalladas a continuación.

Router1 (Cisco 3640)
Current configuration : 1676 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
enable password ww
!
username router2 password 0 ww

!--- username for remote router (Router 2) and shared secret
!--- shared secret(used for CHAP authentication) must be the same on both sides

ip subnet-zero
!
chat-script async "" "AT" OK "ATDT\T" TIMEOUT 30 CONNECT \c

!--- chat script "async" used for the dialout connection

!
!
interface Ethernet2/0
 ip address 10.200.20.51 255.255.255.0
 half-duplex
!
interface Async104	

!--- async interface corresponding to the modem 
!--- This was determined using the show line command.

 ip address 10.10.0.2 255.255.255.252

!--- IP address of this async interface

 encapsulation ppp
 dialer in-band
 dialer wait-for-carrier-time 180
 dialer map ip 10.10.0.1 name router2 modem-script async 8214

!--- dialer map statements for the remote router 
!--- The name must match the one used by the remote router to identify itself.
!--- use modem chat script "async" for this connection

 dialer-group 1
!--- apply interesting traffic definition from dialer-list 1
 async mode dedicated

!--- Place the line into dedicated asynchronous network mode.
!--- This interface is now automatically configured for PPP connections.

 ppp authentication chap
!--- use chap authentication
!
ip classless
ip route 10.10.0.0 255.255.0.0 10.10.0.1

!--- Traffic for the 10.10.0.0/16 network uses a next hop of 10.10.0.1

ip route 10.10.0.1 255.255.255.255 Async104	

!--- the next hop for 10.10.0.1/32 (which is also the next hop for the 
!--- previous route) is interface Async104.

!
dialer-list 1 protocol ip permit

!--- All IP traffic is defined interesting.
!--- This is applied to Async104 using dialer-group 1.

!
!
line con 0
 exec-timeout 0 0
 password ww transport input none
line 33 38
line 97 103
 modem InOut transport input all
line 104		

!--- line interface configuration for Async 104

 modem InOut	

!--- allow incoming and outgoing modem calls on this line
	
 transport input all
 transport output lat pad v120 lapb-ta telnet rlogin udptn
 flowcontrol hardware
line aux 0
line vty 0 4
 password ww
 login
!
end

En este 3600 chasis, el indicador luminoso LED amarillo de la placa muestra gravedad menor NM-8AM está instalado en el slot 3. que se refiere a cómo las líneas asincrónicas se numeran en los Cisco 3600 Series Router documento, nosotros comprueba que el slot 3 tiene línea 97 con el 128 reservado. Para determinar que la interfaz asincrónica específica usted debe configurar, utiliza el comando show line de descubrir las líneas disponibles. En esta configuración, observe que solamente las líneas 97-104 (8 líneas) están disponibles dentro de ese rango. Por lo tanto, para configurar el primer módem en el indicador luminoso LED amarillo de la placa muestra gravedad menor configure la línea 97 (e interconecte async97) mientras que el módem más reciente es line/async104.

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Solución de problemas de conexión analógica

Complete estos pasos para resolver problemas la conexión de marcado de salida:

  1. Marque la configuración del módem.

    Verifique la configuración del módem. Usted debe marcar la configuración de línea correspondiente al módem así como el async de la interfaz.

  2. Invierta el telnet al módem e inicie un dialout.

    Invierta el telnet hacia fuera el puerto al módem, y utilice EN el comando set de marcar y de conectar con el dispositivo remoto. Esto puede usarse para verificar que el hardware del módem y el circuito telefónico están funcionando. En este ejemplo, puesto que el puerto del módem está en la línea 104, invierta el telnet al puerto 2104 en el router. Para más información sobre los telnets reversos, refiera a establecer a una sesión telnet reversa a un módem.

    router1#telnet 10.200.20.51 2104 
    Trying 10.200.20.51, 2104  ... Open
    User Access Verification
    Username: admin
    Password: 
    
    !--- Authentication performed by local router for the reverse telnet
    
    at
    OK
    atdt 81690
    
    !--- The modem dials (81690) and connects.
    !--- This takes approximately 30-45 seconds.
    
    CONNECT 31200/ARQ/V34/LAPM/V42BIS
    
    !--- Connect speed and protocols that were negotiated
    
    User Access Verification
    Username: admin
    Password:
    
    !--- Authentication performed by remote router for the incoming call
     
    router2>
    
    !--- Remote router's prompt
    
    

    Usted puede también aplicar otro EN los comandos para verificar las configuraciones del módem. Refiérase EN el comando set y el resumen de registro para los módulos de red con módem analógico para más información sobre EN el comando disponible para los módulos del módem analógico.

  3. Active el chat script manualmente e inicie un dial.

    Utilice el comando start-chat para activar el chat script e iniciar un dial. El comando start-chat le requiere especificar el nombre del chat script que se activará, del número de teléfono que se marcarán, y de la interfaz del módem para marcar hacia fuera encendido.

  4. Verifique que haya una ruta a la interfaz asincrónica.

    Utilice el comando show ip route para marcar si hay una ruta a la interfaz asincrónica. Si no hay ruta, cree una Static ruta. Se muestra un ejemplo a continuación:

    ip route 10.10.0.1 255.255.255.255 Async104 
  5. Genere un ping destinado para la red del salto siguiente especificada en el paso 4.

    Un ping para el router remoto, que se especifica usando la red del salto siguiente del paso 4, hace al router marcar el dispositivo remoto.

    router1#ping 10.10.0.1
    

Refiera a las llamadas de salida del troubleshooting para más información sobre cómo resolver problemas su conexión.

Errores comunes

  • Verifique que el nombre del chat script sea idéntico al especificado en la sentencia del mapa de marcado. También verifique que el número de teléfono que se marcará esté especificado correctamente.

  • Marque para ver que el tráfico interesante está definido correctamente. El tráfico interesante se especifica con el comando dialer-list.

  • Asegúrese de que la definición de tráfico interesante esté aplicada a la interfaz asincrónica. Esto se hace usando el comando dialer-group, donde el número de grupo debe hacer juego la definición de tráfico interesante especificada con el comando dialer-list.

  • Verifique que el nombre de usuario y contraseña para la autenticación PAP/CHAP esté correcto.

  • Marque para aseegurarse que la sentencia del mapa de marcado tiene el nombre, la dirección IP, y el número de teléfono correctos a marcar.

comandos debug

Antes de ejecutar un comando de depuración, consulte Información importante sobre comandos de depuración.

  • debug dialer – Para mostrar la información de depuración sobre los paquetes recibidos en una interfaz del marcador. Cuando el On-Demand Routing del dial (DDR) se habilita en la interfaz, la información referente a la causa de cualquier llamada (llamada la causa de marcación) también se visualiza. Si desea obtener más información, consulte los datos sobre depuración de dialer en la documentación de comandos de depuración.

  • módem del debug - Para visualizar la actividad de línea del módem, el control del módem, y los mensajes de activación de proceso en el router.

  • charla del debug - Para monitorear la ejecución del chat script cuando se inicia la marca async/POTS. Refiera a la tecnología de marcación manual: Técnicas de resolución de problemas para obtener más información.

  • negociación ppp del debug - Al mostrar información en el tráfico y los intercambios PPP mientras que negocia a los componentes PPP incluyendo el (LCP), la autenticación, y el protocolo network control del Link Control Protocol (NCP). Una negociación PPP satisfactoria primero abrirá el estado LCP, después autentica, y finalmente negocia el NCP.

  • autenticación PPP del debug - Para visualizar los mensajes de protocolo de la autenticación PPP, incluyendo los intercambios de paquetes del protocolo challenge authentication (GRIETA) y los intercambios del protocolo password authentication (PAP).

Ejemplo de resultado del comando debug

router1#show debug
General OS:
  Modem control/process activation debugging is on
Dial on demand:
  Dial on demand events debugging is on
Generic IP:
  ICMP packet debugging is on
PPP:
  PPP protocol negotiation debugging is on
Chat Scripts:
  Chat scripts activity debugging is on
router1#
router1#ping 10.10.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.0.1, timeout is 2 seconds:
*Mar  1 00:22:58.663: As104 DDR: Dialing cause ip (s=10.10.0.2, d=10.10.0.1)

!--- Dialing reason is the ping for 10.10.10.1
!--- The dialout is using Async104.

*Mar  1 00:22:58.663: As104 DDR: Attempting to dial 8214

!--- Phone number to be dialed

*Mar  1 00:22:58.663: CHAT104: Attempting async line dialer script
*Mar  1 00:22:58.663: CHAT104: Dialing using Modem script: async & System script: none

!--- Use chat script named "async"

*Mar  1 00:22:58.663: CHAT104: process started
*Mar  1 00:22:58.667: CHAT104: Asserting DTR
*Mar  1 00:22:58.667: CHAT104: Chat script async started

!--- Chat-script "async" is started.

*Mar  1 00:22:58.667: CHAT104: Sending string: AT
*Mar  1 00:22:58.667: CHAT104: Expecting string: OK
*Mar  1 00:22:58.739: CHAT104: Completed match for expect: OK
*Mar  1 00:22:58.739: CHAT104: Sending string: ATDT\T<8214>
*Mar  1 00:22:58.739: CHAT104: Expecting string: CONNECT
*Mar  1 00:22:58.751: Modem 3/7 Mcom: in modem state 'Dialing/Answering'
*Mar  1 00:23:10.775: Modem 3/7 Mcom: in modem state 'Waiting for Carrier'
*Mar  1 00:23:21.903: Modem 3/7 Mcom: in modem state 'Connected'
*Mar  1 00:23:22.323: Modem 3/7 Mcom: CONNECT at 26400/24000(Tx/Rx), V34, LAPM, V42bis,
 Originate

!--- Connect speeds, protocols and so forth, and so on negotiated for the connection
!--- Note that the modem used is 3/7 which is equivalent to line 104.
!--- Refer to How Async Lines are Numbered in Cisco 3600 Series Routers.

*Mar  1 00:23:22.375: CHAT104: Completed match for expect: CONNECT
*Mar  1 00:23:22.375: CHAT104: Sending string: \c
*Mar  1 00:23:22.375: CHAT104: Chat script async finished, status = Success

!--- Chat script is successful. Notice the Expect/Send attributes and the time elapsed.

*Mar  1 00:23:22.375: Modem 3/7 Mcom: switching to PPP mode
*Mar  1 00:23:22.379: TTY104: no timer type 1 to destroy
*Mar  1 00:23:22.379: TTY104: no timer type 0 to destroy
*Mar  1 00:23:22.379: As104 IPCP: Install route to 10.10.0.1
*Mar  1 00:23:24.379: %LINK-3-UPDOWN: Interface Async104, changed state to up
*Mar  1 00:23:24.379: As104 DDR: Dialer statechange to up
*Mar  1 00:23:24.379: As104 DDR: Dialer call has been placed
*Mar  1 00:23:24.379: As104 PPP: Treating connection as a callout

!--- PPP negotiation begins.

*Mar  1 00:23:24.379: As104 PPP: Phase is ESTABLISHING, Active Open [0 sess, 0 load]
*Mar  1 00:23:24.379: Modem 3/7 Mcom: PPP escape map: Tx map = FFFFFFFF, Rx map = 0
*Mar  1 00:23:24.379: As104 LCP: O CONFREQ [Closed] id 17 len 25
*Mar  1 00:23:24.379: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.379: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.379: As104 LCP:    MagicNumber 0x1090720F (0x05061090720F)
*Mar  1 00:23:24.379: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.379: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.543: As104 LCP: I CONFREQ [REQsent] id 1 len 25
*Mar  1 00:23:24.543: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.543: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.543: As104 LCP:    MagicNumber 0x41B616FF (0x050641B616FF)
*Mar  1 00:23:24.543: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.543: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.543: As104 LCP: O CONFACK [REQsent] id 1 len 25
*Mar  1 00:23:24.543: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.543: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.543: As104 LCP:    MagicNumber 0x41B616FF (0x050641B616FF)
*Mar  1 00:23:24.543: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.543: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.555: As104 LCP: I CONFACK [ACKsent] id 17 len 25
*Mar  1 00:23:24.555: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.555: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.559: As104 LCP:    MagicNumber 0x1090720F (0x05061090720F)
*Mar  1 00:23:24.559: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.559: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.559: As104 LCP: State is Open

!--- LCP negotiation is complete.

*Mar  1 00:23:24.559: Modem 3/7 Mcom: PPP escape map: Tx map = A0000, Rx map = 0
*Mar  1 00:23:24.559: As104 PPP: Phase is AUTHENTICATING, by both [0 sess, 0 load]

!--- Two-way PPP authentication begins.

*Mar  1 00:23:24.559: As104 CHAP: O CHALLENGE id 4 len 28 from "router1"
*Mar  1 00:23:24.691: As104 CHAP: I CHALLENGE id 1 len 28 from "router2"
*Mar  1 00:23:24.691: As104 CHAP: O RESPONSE id 1 len 28 from "router1"
*Mar  1 00:23:24.707: As104 CHAP: I RESPONSE id 4 len 28 from "router2"
*Mar  1 00:23:24.707: As104 CHAP: O SUCCESS id 4 len 4
*Mar  1 00:23:24.815: As104 CHAP: I SUCCESS id 1 len 4

!--- Incoming and outgoing CHAP authentication is successful.

*Mar  1 00:23:24.815: As104 PPP: Phase is UP [0 sess, 0 load]
*Mar  1 00:23:24.819: As104 IPCP: O CONFREQ [Closed] id 6 len 10
*Mar  1 00:23:24.819: As104 IPCP:    Address 10.10.0.2 (0x03060A0A0002)
*Mar  1 00:23:24.835: As104 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar  1 00:23:24.835: As104 IPCP:    Address 10.10.0.1 (0x03060A0A0001)
*Mar  1 00:23:24.839: As104 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar  1 00:23:24.839: As104 IPCP:    Address 10.10.0.1 (0x03060A0A0001)
*Mar  1 00:23:24.931: As104 IPCP: I CONFACK [ACKsent] id 6 len 10
*Mar  1 00:23:24.931: As104 IPCP:    Address 10.10.0.2 (0x03060A0A0002)
*Mar  1 00:23:24.931: As104 IPCP: State is Open

!--- IP Control Protocol (IPCP) negotiation is complete.

*Mar  1 00:23:24.931: As104 DDR: dialer protocol up
*Mar  1 00:23:25.379: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async104,
 changed state to up

!--- Interface is up.


Información Relacionada


Document ID: 10316