WAN : Frame Relay

Configuración de respaldo ISDN para links WAN mediante el uso de rutas flotantes

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Esta configuración de ejemplo muestra cómo realizar una copia de respaldo de un link frame relay con la Red digital de servicios integrados (ISDN) mediante rutas estáticas flotantes y el ruteo de marcado a pedido (DDR)

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Esta configuración fue desarrollada y probada utilizando las versiones de software y hardware indicadas a continuación.

  • Cisco 2503 Routers

  • El Software Release 12.2(7b) del ½ del ¿Â de Cisco IOSï se ejecutaba en ambo Routers

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Teoría Precedente

Una meta de la implementación de los links de WAN es la de suministrar una forma de respaldar el link, en caso de que éste falle. El ISDN proporciona con frecuencia este respaldo. Cisco ofrece estrategias de respaldo que pueden alcanzar la misma funcionalidad pero en diferentes formas. Si se pasa información de ruteo a través del link de retransmisión de tramas, una ruta flotante puede incrementar el link de respaldo si el link de retransmisión de tramas deja de pasar información.

Nota: Este ejemplo muestra un respaldo para el Frame Relay usando las Rutas estáticas flotantes. Sin embargo, usted puede también utilizar este respaldo del método cualquier link PÁLIDO.

Las otras soluciones pueden emplear una Interfaz de respaldo (véase configurar una Interfaz de respaldo para una subinterfaz) o el Monitoreo de marcado. Si utiliza el método del comando backup interface, las subinterfaces punto a punto son más ventajosas dado que las interfaces principales o las multipunto pueden permanecer en estado activo/activo aún cuando las conexiones virtuales permanentes (PVC) no funcionan con retransmisión de tramas.

Para más información sobre configurar el backup DDR, refiera a Usted puede también referir a las evaluaciones de la interfaz de respaldo, a las Rutas estáticas flotantes, y al Monitoreo de marcado del documento para el backup DDR para más información sobre los diversos métodos de backup DDR.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para encontrar la información adicional en los comandos usados en este documento, utilice la herramienta de búsqueda de comandos para el IOS.

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/10214/fr_isdn_backup.gif

Configuraciones

Este documento usa las configuraciones detalladas a continuación.

Esta configuración fue probada utilizando la versión 12.2(7b) del software IOS de Cisco en routers de la serie 2500. Los mismos conceptos de configuración pueden aplicarse a una tipología de router similar o a otras versiones de Cisco IOS.

Router1 (Cisco 2503 Router)
Current configuration:

version 12.2
!
hostname Router1
!

!--- This username password pair is used for 
!--- PPP CHAP authentication

username Router2 password 0 letmein
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
interface Serial0

!--- Primary Link.
!--- The bandwidth is adjusted to allow for rapid backup of the link.


!--- This adjusts the EIGRP Hello interval and 
!--- Hold time for rapid convergence.
!--- The bandwidth command does not actually change the bandwidth of the link,
!--- it only adjusts the routing protocol bandwidth parameter.

 bandwidth 2048
 ip address 172.16.2.1 255.255.255.128
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 clockrate 64000
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface BRI0

! -- Backup link.

 ip address 172.16.3.1 255.255.255.0

! -- The backup link is in a different subnet.
! -- The BRI interface on the peer should also be in this subnet.

 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer map ip 172.16.3.2 name Router2 broadcast 5552000

! -- Dialer map for the peer. Note the IP address and name.
! -- The name must match the authenticated username of the peer.

 dialer load-threshold 5 either
 dialer-group 1

! -- Apply interesting traffic definition.
! -- Interesting traffic definition is defined in dialer-list 1.

 isdn switch-type basic-5ess
 ppp authentication chap
 ppp multilink
!
router eigrp 100

!--- This example uses eigrp. 
!--- You can use any routing protocol instead.

 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 172.16.4.0 255.255.255.0 172.16.3.2 200

!--- The floating static route is defined.
!--- Note the administrative distance of the route is 200.
!--- Hence it is only used when all other routes for 172.16.4.0/24 
!--- are lost. Note that the next hop for the floating static route 
!--- matches the dialer map ip. If the nexthop is not the same as 
!--- in the dialer map then the router will no dial.

!
access-list 100 deny   eigrp any any
access-list 100 permit ip any any

!--- EIGRP routing packets are denied in the dialer-list.


!--- This prevents eigrp packets from keeping the link up.
!--- Adjust the interesting traffic depending on your traffic definitions.

!
dialer-list 1 protocol ip list 100

!---  Interesting traffic defintion. Use access-list 100.
!---  The interesting traffic is applied to BRI interface 
!--- using dialer-group 1. 

!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Se configuró una estática flotante para el Router1. Las Rutas estáticas flotantes tienen una distancia administrativa asignada de 200. Una ruta de la misma subred será conocida en el link de retransmisión de tramas a través del protocolo mejorado de ruteo de puerta de link interior (EIGRP), lo que enfatiza la naturaleza adicional o redundante de la ruta flotante. La ruta aprendida EIGRP será instalada en la tabla de ruteo debido a su distancia administrativa menor 90, comparada a la de la Static ruta 200. En caso de error del link de Frame Relay, la ruta EIGRP desaparecerá de la tabla de ruteo, las Rutas estáticas flotantes está instalada. Todo tráfico interesante a ser enviado a través de la conexión ISDN abre la línea. Cuando la Conectividad se restablece sobre el Frame Relay, la ruta se aprende otra vez con el EIGRP. Esta ruta reemplaza la ruta estática y el tráfico directo una vez más por el circuito de retransmisión de tramas.

El tráfico del Routing Protocol se marca como sin interés en la lista del dialer de modo que no haga la línea ISDN conectar o seguir conectada. Sin embargo, el link está una vez para arriba, los paquetes EIGRP pueden cruzar el link y el dos Routers puede intercambiar la información de ruteo. La palabra clave del broadcast se ha incluido en la sentencia del mapa de marcado para permitir la aprobación del tráfico del Routing Protocol sobre el link ISDN. Si usted no quisiera que el EIGRP intercambiara la información de ruteo incluso si el link ISDN está para arriba, no incluya la palabra clave del broadcast en la sentencia del mapa de marcado.

El comando dialer load-threshold establece una carga que activará una llamada concurrente que se colocará en el segundo canal B. El Point-to-Point Protocol (PPP) de Multilink ha sido configurado (PPP multilink) para que ambos canales puedan agruparse como una sola interfaz de acceso vitual para el ancho de banda total.

En la configuración actual, sólo el router1 está configurado para realizar una llamada. Router2 recibe llamadas del Router1. Si usted quisiera que los ambos lados sacaran a colación el link, agregue los comandos dialer map y dialer load-threshold a la configuración del router2.

Router 2 (Router Cisco 2503)
Current configuration:

version 12.2
!
!
hostname Router2
!
username Router1 password 0 letmein
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
!
interface Ethernet0
 ip address 172.16.4.1 255.255.255.0
!
interface Serial0
 bandwidth 2048
 ip address 172.16.2.2 255.255.255.128
 encapsulation frame-relay
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
 clockrate 64000
!
interface BRI0
 ip address 172.16.3.2 255.255.255.0

! -- IP address of backup interface.
! -- This router accepts the call. Note the IP address matches both the 
! -- dialer map floating static router nexthop on the peer.

 encapsulation ppp
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
 ppp multilink

!--- The missing dialer map command disables 
!--- this router from making the call.

!
router eigrp 100
 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 172.16.1.0 255.255.255.0 172.16.3.1 200
!
access-list 100 deny   eigrp any any
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100
!
!
line con 0
line aux 0
line vty 0 4
!
end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

Cambios en la tabla de ruteo

Nota: La herramienta del Output Interpreter soportan a los ciertos comandos show, que permite que usted vea una análisis de la salida del comando show;

Observe las tablas de ruteo del Router1 que se muestran a continuación. Nótese que la ruta estática flotante reemplazó a la ruta conocida EIGRP luego de que el router 2 se volvió inalcanzable sobre el link de retransmisión de tramas.

Se muestra abajo la tabla de ruteo de router1, cuando el link de Frame Relay está para arriba.

Router1#show ip route      
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
            D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
            N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
            E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
            i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS 
            inter area      
            * - candidate default, U - per-user static route, o - ODR 
            P - periodic downloaded static route 

     Gateway of last resort is not set 

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks 
      [D 172.16.4.0/2490/1787392] via 172.16.2.2, 00:06:56, Serial0
     
!---  EIGRP learned route over Frame Relay link 

     C 172.16.1.0/24 is directly connected, Ethernet0 
     C 172.16.2.0/25 is directly connected, Serial0 
     C 172.16.3.0/24 is directly connected, BRI0 
     Router1# 

Cuando se pierde la conectividad sobre el link de retransmisión de tramas, el Router 1 instala la ruta estática flotante en su tabla de ruteo como se muestra a continuación.

Router1#show ip route 
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 

     Gateway of last resort is not set 

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks 
     S 172.16.4.0/24 [200/0] via 172.16.3.2 
     
!--- Floating static route. Administrative distance is 200 

     C 172.16.1.0/24 is directly connected, Ethernet0 
     C 172.16.2.0/25 is directly connected, Serial0 
     C 172.16.3.0/24 is directly connected, BRI0 
     Router1# 

Cualquier tráfico interesante a la red 172.16.4.0/24 ahora saca a colación la conexión ISDN. Por ejemplo, del router1, un ping a 172.16.4.1 saca a colación el link ISDN como se muestra abajo.

Nota: Si usted hace el Routing Protocol interesante, después el tráfico periódico saca a colación el link automáticamente. La desventaja de esto es que seguirá habiendo el link para arriba indefinidamente, posiblemente dando por resultado los cargos por larga distancia altos.

Router1#ping 172.16.4.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds: 
.!!!! 
Success rate is 80 percent (4/5), round-trip min/avg/max = 36/36/36 ms 
Router1# 
3d22h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
3d22h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
3d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
changed state to up 
3d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, 
changed state to up 
3d22h: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5552000 Router2 
Router1# 

Puesto que la línea ISDN está para arriba, el EIGRP ahora comienza a exchaging la información de ruteo sobre la conexión ISDN. Esto hace el router1 instalar la ruta EIGRP en su tabla de ruteo, señalando al Next-Hop 172.16.3.2.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 

Gateway of last resort is not set 

172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks 
D      172.16.4.0/24 [90/40537600] via 172.16.3.2, 00:00:17, BRI0

!--- EIGRP route learnt over the ISDN link 

C      172.16.3.2/32 is directly connected, BRI0 
C      172.16.1.0/24 is directly connected, Ethernet0 
C      172.16.2.0/25 is directly connected, Serial0 
C      172.16.3.0/24 is directly connected, BRI0 
Router1# 

El tráfico interesante es el tráfico que iniciará la llamada ISDN y es definido por el comando dialer-list. En la configuración antedicha, la marcador-lista señala a la lista de acceso número 100 que permite todos los paquetes del IP excepto los paquetes EIGRP. Este los medios, todos los paquetes del IP, a menos que los paquetes EIGRP, pueden sacar a colación la conexión ISDN. Una vez que se hace la conexión, cualquier tráfico, incluyendo el tráfico del EIGRP, se permite ir a través del link. Pero si ningún tráfico interesante cruza el link ISDN para la duración del temporizador de inactividad del dialer, el link será derribado y no se intercambiará ningunas rutas EIGRP. En este momento, las Rutas estáticas flotantes serán instaladas otra vez en la tabla de ruteo Router1.

Troubleshooting

Para la información sobre resolver problemas las Rutas estáticas flotantes refiera al documento Configuración y Troubleshooting de DDR Backup. Este documento dirige los síntomas comunes por ejemplo:

  • El link de backup no se marca cuando va el link principal abajo.

  • Los diales del link de backup pero no conectan con el otro lado.

  • El link de respaldo no se desactiva cuando se recupera el link principal.

  • El link de backup no es estable (por ejemplo, agita) cuando la interfaz primaria está abajo.

Para el troubleshooting específico del Frame Relay refiera a configurar el backup de Frame Relay

Los siguientes comandos pueden ayudar a resolver problemas el link de backup.:

Antes de intentar la ejecución de cualquiera de los comandos de depuración mencionados, consulte la Información importante sobre comandos de depuración.

‘Resultado de debug’

El tráfico del protocolo de ruteo (EIGRP) es marcado como no interesante por el comando dialer list por lo que no hará que aparezca el link o no lo mantendrá. Sin embargo, cuando el link es activo, las actualizaciones de ruteo serán intercambiadas. El comando debug dialer packet puede verificar si el tráfico correcto puede activar un link. A continuación se muestra la salida.

Router1#debug dialer packets 
Dial on demand packets debugging is on 
Router1# 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 -- failed, 
not connected 

!---  EIGRP packet does not bring up the link 

3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 -- failed, 
not connected 

!---  EIGRP packet does not bring up the link 

3d22h: BR0 DDR: cdp, 273 bytes, outgoing uninteresting (no list matched) 

El tráfico interesante (generaciones de eco del Internet Control Message Protocol (ICMP) en este caso) reajustará el temporizador de inactividad y guardará el link para arriba como abajo. El tráfico no interesante será transmitido pero no mantendrá el link en funcionamiento si caduca el temporizador de inactividad.

Router1#ping 172.16.4.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/51/80 ms 
Router1# 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping) 

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 

Marcado sin embargo como sin interés, los paquetes EIGRP cruzan el link ISDN, porque la conexión es hecha ya por el tráfico interesante ICMP.


Información Relacionada


Document ID: 10214