Calidad de servicio (QoS) : Supervisión de QoS

Opción de calidad de servicio en las interfaces de túnel GRE

13 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Este el documento revisa que el Calidad de Servicio (QoS) ofrece se puede configurar en las interfaces del túnel usando el Generic Routing Encapsulation (GRE). Los túneles configurados con la seguridad IP (IPSec) están fuera del ámbito de este documento.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Información general de GRE

Antes de saber de la QoS sobre los túneles GRE, primero necesita comprender el formato de un paquete tunelizado.

Una interfaz del túnel es una virtual o una interfaz lógica en un router que funciona con el software de Cisco IOS�. Crea un link virtual punto a punto entre dos routers Cisco en puntos remotos, en una operación entre redes IP.

GRE es un protocolo de encapsulación compatible con IOS y definido en RFC 1702.leavingcisco.com Los protocolos de túneles encapsulan los paquetes dentro de un Transport Protocol.

Una interfaz del túnel soporta una encabezado para cada uno de éstos:

  • Un protocolo pasajero o un protocolo encapsulado, como por ejemplo IP, Apple Talk, DECnet o IPX.

  • Un protocolo de la portadora (GRE en este caso).

  • Un protocolo de transporte (IP sólo en este caso).

El formato de un paquete del túnel se ilustra aquí:

http://www.cisco.com/c/dam/en/us/support/docs/quality-of-service-qos/qos-policing/10106-qostunnel-01.gif

Refiera a configurar las interfaces lógicas para más información sobre configurar los túneles GRE.

Qos de Cisco para túneles GRE

Una interfaz de túnel admite muchas de las mismas funciones de Calidad de servicio (QoS) que una interfaz física. Estas secciones describen las características soportadas de QoS.

Modelado

El Cisco IOS Software Release12.0(7)T introdujo el soporte para aplicar el Control de tráfico genérico (GTS) directamente en la interfaz del túnel. El siguiente ejemplo de configuración le da forma a la interfaz de túnel a una velocidad general de salida de 500 kbps. Refiera a configurar el Control de tráfico genérico para más información.

interface Tunnel0 
  ip address 130.1.2.1 255.255.255.0 
  traffic-shape rate 500000 125000 125000 1000 
  tunnel source 10.1.1.1 
  tunnel destination 10.2.2.2

Apoyo añadido del Cisco IOS Software Release 12.1(2)T para la modelación basada en la clase usando la interfaz de la línea de comandos de la Calidad del servicio (QoS) modular (MQC). El siguiente ejemplo de configuración muestra cómo aplicar la misma política de modelado a la interfaz de túnel con los comandos MQC. Refiera a configurar la modelación basada en la clase para más información.

policy-map tunnel 
  class class-default 
    shape average 500000 125000 125000 
interface Tunnel0 
  ip address 130.1.2.1 255.255.255.0 
  service-policy output tunnel 
  tunnel source 130.1.35.1 
  tunnel destination 130.1.35.2

Control de tráfico

Cuando se congestiona una interfaz y los paquetes comienzan a acumularse, puede aplicar un método de colocación en cola a los paquetes que esperan ser transmitidos. Las interfaces lógicas del IOS de Cisco no soportan de forma inherente un estado de congestión y no soportan la aplicación directa de una política de servicios que se aplica a un método de colocación en cola. En lugar, usted necesita aplicar una política de jerarquía como sigue:

  1. Cree una política "hija" o de menor nivel que configure un mecanismo de colocación en cola, como colocación en cola de latencia baja y colocación en cola equilibrada ponderada calculada en función de la clase (CBWFQ) con el comando bandwidth. Refiera a la administración de la congestión para más información.

    policy-map child 
     class voice 
      priority 512
  2. Cree una política "controlante" o de nivel superior que aplique un modelado basado en clase. Aplique la política hija como comando bajo política controlante puesto que el control de admisión para la clase hija se hace sobre la base de la velocidad de modelado para la clase controlante.

    policy-map tunnel 
     class class-default 
      shape average 2000000 
      service-policy child 
  3. Aplique la política controlante a la interfaz del túnel.

    interface tunnel0 
       service-policy tunnel

El router imprime este mensaje del registro cuando una interfaz del túnel se configura con una política de servicio que aplique los Datos en espera sin formar.

router(config)# interface tunnel1
router(config-if)# service-policy output child
 Class Based Weighted Fair Queueing not supported on this interface

De las interfaces del túnel el class-based policing del soporte también, sino ellos no soporta el Committed Access Rate (CAR).

Nota: Las políticas de servicio no son admitidas en las interfaces de túnel en la 7500.

Prevención de Congestión

El Cisco IOS Software Release 11.3T introdujo la marca del túnel GRE y los valores DSCP o de la Prioridad IP, que configura al router para copiar los valores del bit de precedencia IP del Byte ToS al túnel o al encabezado IP GRE que encapsula el paquete interno. Anteriormente, esos bits estaban configurados en cero. Los routers intermedios entre los puntos finales del túnel pueden usar valores de precedencia IP para clasificar los paquetes para las funciones de calidad de servicio (QoS), tales como política de ruteo, WFQ y detección temprana aleatoria ponderada (WRED).

El comando qos pre-classify

Cuando los paquetes son encapsulados por encabezados de túnel o encripción, las funciones QoS no pueden examinar los encabezados originales de los paquetes y clasificar correctamente los paquetes. Los paquetes que se transmiten a través del mismo túnel tienen los mismos encabezados de túnel. Por lo tanto, los paquetes son tratados de manera similar cuando la interfaz física está congestionada. Con la introducción de la función de calidad de servicio para las redes privadas de servicio virtual (VPN), ahora se pueden clasificar los paquetes antes de que ocurra la tunelización o encriptación.

En este ejemplo, el tunnel0 es el nombre de túnel. El comando qos pre-classify habilita la QoS para la función VPNs en tunnel0.

Router(config)# interface tunnel0
Router(config-if)# qos pre-classify

Nota:  El comando qos pre-classify puede ser utilizado para clasificar el tráfico basado en los valores con excepción de la Prioridad IP o del DSCP. Por ejemplo, usted puede ser que quiera clasificar los paquetes basados en el flujo IP o acodar la información 3, tal como IP Address de origen y de destino para el cual este comando puede ser utilizado. Requieren al comando qos pre-classify solamente si usted clasifica el tráfico en el IP, el protocolo, o el puerto. Si la clasificación se basa en el código DSCP, después los qos PRE-clasifican no se requieren.

Definición de características del tráfico para las políticas de QoS

Al configurar una política de servicio, usted primero puede ser que necesite caracterizar el tráfico que está atravesando el túnel. El IOS de Cisco, admite Netflow y contabilidad IP de Cisco Express Forwarding (CEF) en interfaces lógicas como túneles. Refiera a la guía de las soluciones de los servicios de NetFlow para más información.

¿Dónde puedo solicitar la Política de Servicio?

Puede aplicar una política de servicio a la interfaz de túnel o a la interfaz física subyacente. La decisión de dónde aplicar la política depende de los objetivos de QoS. También depende de qué encabezado necesita utilizar para clasificación.

  • Aplique la política a la interfaz de túnel sin qos-preclassify cuando quiera clasificar paquetes según el encabezado anterior al túnel.

  • Aplique la directiva a la interfaz física fuera qos-preclassify cuando usted quiere clasificar los paquetes basados en la encabezado del poste-túnel. Asimismo, aplique la política a la interfaz física cuando desee modelar o vigilar todo el tráfico perteneciente a un túnel, y la interfaz física admita varios túneles.

  • Aplique la directiva a una interfaz física y el permiso qos-preclassify en una interfaz del túnel cuando usted quiere clasificar los paquetes basados en el encabezado previó al túnel.

Interfaces de túnel multipunto

El CBWFQ dentro de la modelación basada en la clase no se soporta en una interfaz multipunto. El ID de falla de funcionamiento de Cisco CSCds87191 configura al router para que imprima un mensaje de error al rechazar la política.

Problemas conocidos

En las condiciones poco probables, la aplicación de una servicio-directiva configurada con el comando shape lleva CPU elevada a la utilización y a los errores de alineación. Carga de la CPU es causado registrando los errores de alineación, que a su vez son causados por el CEF que fija incorrectamente la interfaz de salida y la información de reescritura de adyacencia. Este problema afecta solamente a las plataformas sin RSP (poco sofisticadas) y a las plataformas que utilizan conmutación CEF basada en partículas. La resolución del problema se lleva a cabo con los ID de errores de funcionamiento de Cisco CSCdu45504 y CSCuk30302. Usted también puede considerar estas soluciones alternativas:

  • Reemplace la encapsulación GRE con el modo de túnel ipip.

  • Reemplace el comando shape por el comando police.

  • Configure el modelado en la interfaz física que soporta el túnel.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 10106