Calidad de servicio (QoS) : Supervisión de QoS

Aplicación de las características QoS en las subinterfaces Ethernet

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo aplicar el Mecanismo de cola de espera equitativo y ponderado basado en clases (CBWFQ) y otras características basadas en software del Calidad de Servicio (QoS) del � del Cisco IOS en una subinterfaz Ethernet. Una subinterfaz Ethernet es una interfaz lógica en IOS de Cisco. Puede utilizar el Comando modular de QoS (MQC) de Interfaz de línea (CLI) para crear y aplicar una política de servicio en una subinterfaz Ethernet.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco IOS Software 12.2(2)T

  • Cisco 2620 Router con un módulo de red de los fast ethernet

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Aplicación de una política de servicio

En general, para elegir dónde aplicar una política, se deben considerar las características QoS que activa esta política. Una subinterfaz Ethernet admite lo siguiente:

  • Regulación de tráfico según la clase – Si aplica una política con el comando de vigilancia en la interfaz y la subinterfaz, sólo el supervisor de la subinterfaz se encontrará activo para el tráfico que coincida con la clase. Refiera a la Vigilancia de tráfico para más información.

  • Marcado basado en clases — refiera a la Descripción general de la clasificación para más información.

  • Modelación basada en la clase — refiera a configurar la modelación basada en la clase para más información.

  • Espera basada en la clase — La espera es a caso especial para las subinterfaces de Ethernet. Vea el resto de esta sección para más información.

Un router comienza a hacer cola los paquetes cuando el número de paquetes que necesita ser transmitido hacia fuera una interfaz excede la velocidad de salida de esa interfaz. Los paquetes en exceso se colocan en cola. Un método de almacenamiento en cola puede aplicarse a los paquetes que están esperando ser transmitidos.

Las interfaces lógicas del IOS de Cisco no admiten de forma inherente un estado de congestión y no admiten la aplicación directa de una política de servicios que se aplica a un método de colocación en cola. En cambio, primero se debe aplicar el modelado a la subinterfaz utilizando el modelado de tráfico genérico (GTS) o el modelado basado en la clase. Refiera al establecimiento de políticas y modelado para más información.

El router imprime este mensaje del registro cuando una subinterfaz Ethernet se configura con una política de servicio que aplique la espera sin formar:

router(config)# interface ethernet0/0.1
router(config-subif)# service-policy output test
 CBWFQ : Not supported on subinterfaces

Observe que la misma regla aplica a Gigabit Ethernet una subinterfaz.

c7400(config)# interface gig0/0.1
c7400(config-subif)# service-policy ou
c7400(config-subif)# service-policy output outFE
  CBWFQ : Not supported on subinterfaces

Es decir usted debe configurar una política de jerarquía con el comando shape en el nivel del padre. Utilice el comando bandwidth para CBWFQ, o el comando priority para la Colocación en cola de latencia baja (LLQ) en niveles más bajos. La modelación basada en la clase limita la velocidad de salida y (podemos asumir) lleva a un estado de congestión en la subinterfaz lógica. La subinterfaz que el “backpressure,” y el Cisco IOS comienza a hacer cola los paquetes en exceso que son sostenidos por el shaper.

Aplicación de una política jerárquica

Siga estos pasos a continuación para utilizar una política jerárquica.

  1. Cree una política pequeña o de bajo nivel que configure un mecanismo de formación de colas. En el ejemplo abajo, configuramos el LLQ usando el comando priority y el CBWFQ usando el comando bandwidth. Refiera a la descripción general de la administración de congestión para más información.

    policy-map child 
     class voice 
      priority 512
  2. Cree una política controlante o de nivel superior que corresponda a un modelado basado en la clase. Aplique la política hija como un comando debajo de la política controlante, ya que el control de admisión para la clase hija se realiza en función de la velocidad de modelado para la clase controlante.

    policy-map parent
     class class-default 
      shape average 2000000 
      service-policy child 
  3. Aplique la política controlante a la subinterfaz.

    interface ethernet0/0.1
     service-policy parent 

Configuración de la formación basada en clase

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Configuración

Router 2620A
hostname 2620A 
! 
ip cef 
! 
class-map match-any dscp46 
 match ip dscp 46 
class-map match-all telnet_ping_snmp 
 match access-group 150 
class-map match-all http 
 match access-group 154 
class-map match-all pop3_smtp 
 match access-group 153 
! 
! 
policy-map voice_traffic 
 class dscp46 
  shape average 30000 10000 
 class telnet_ping_snmp 
  shape average 20000 15440 
 class pop3_smtp 
  shape average 20000 15440 
 class http 
  shape average 20000 15440 
! 
interface FastEthernet0/0 
 ip address 10.10.247.2 255.255.255.0 
 duplex auto 
 speed auto 
! 
interface FastEthernet0/0.1 
 encapsulation dot1Q 1 native 
 ip address 10.1.1.1 255.255.255.0 
 service-policy output voice_traffic

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

Los ciertos comandos show son soportados por la herramienta del Output Interpreter, que permite que usted vea una análisis de la salida del comando show.

  • show policy-map {policy name} - Visualiza la configuración de todas las clases para una correlación de políticas de servicio especificada.

    2620A# show policy-map voice_traffic 
    Policy Map voice_traffic 
    Class dscp46 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 30000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 10000 
    Class telnet_ping_snmp 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    Class pop3_smtp 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    Class http 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    
    2620A# show policy-map voice_traffic class dscp46 
    Class dscp46 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 30000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 10000
  • show policy-map interface fast - Visualiza los contadores de coincidencias para todas las clases de una correlación de políticas de servicio especificada.

    2620A# show policy-map interface fa0/0.1 
    FastEthernet0/0.1 
    Service-policy output: voice_traffic 
    Class-map: dscp46 (match-any) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: ip dscp 46 
    0 packets, 0 bytes 
    5 minute rate 0 bps 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    30000     2500   10000     10000     333       1250      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: telnet_ping_snmp (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 150 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: pop3_smtp (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 153 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: http (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 154 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: class-default (match-any) 
    926 packets, 88695 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: any

Nota: La modelación basada en la clase trabaja en el nivel de interfaz y subinterfaz. El IOS 12.2(2.5) de Cisco presenta la capacidad de configurar el modelado en la interfaz principal y las direcciones IP en las subinterfaces.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 10104