Switching de LAN : VLAN

Creación de VLAN de Ethernet en Switches Catalyst

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (23 Junio 2008) | Inglés (20 Octubre 2015) | Comentarios


Contenido


Introducción

Este documento proporciona la información básica en cómo crear los VLA N en los switches de Catalyst que funcionan con el Catalyst OS (CatOS) y el software del sistema de Cisco IOS�. En los comandos de ejemplo de cada sección se utiliza un switch Catalyst de cada sección de configuración.

prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento de la información en esta sección.

Las VLAN son un mecanismo para permitir que los administradores de red creen dominios de broadcast lógicos que pueden abarcar un solo switch o varios switches múltiples, sin importar la proximidad física. Esta función es útil para reducir los tamaños de los dominios de broadcast o para permitir que los grupos o los usuarios se agrupen lógicamente sin necesidad de estar situados físicamente en el mismo lugar.

Para crear las VLAN, tiene que decidir cómo va a configurar estos elementos:

  • Qué nombre de dominio de VLAN Trunk Protocol (VTP) y qué modo VTP utilizar en este switch

  • Qué puertos del switch pertenecen a cada VLAN

  • Si será necesario que haya comunicación entre las VLAN o si estarán aisladas

    Si necesita la comunicación entre VLAN, debe utilizar un dispositivo de ruteo de la Capa 3, tal como un router Cisco externo o un módulo de router interno. Aquí están los ejemplos:

    • Tarjeta WS-X4232-Layer 3 para Catalyst 4500/4000 Switches con Supervisor Engine I y Supervisor Engine II

    • Route Switch Module (RSM) o Route Switch Feature Card (RSFC) para Catalyst 5500/5000 Switches

    • Multilayer Switch Module (MSM) o Multilayer Switch Feature Card (MSFC) para Catalyst 6500/6000 Switches

    Algunos de los switches tienen soporte incorporado en el software y hardware para el ruteo entre VLAN. Con el ruteo entre VLAN, no se requiere ningún dispositivo externo, módulo ni placa hija. A continuación, algunos ejemplos de estos switches:

    • Catalyst 3550/3750/6500 con Supervisor Engine 720

    • Catalyst 4500/4000 con Supervisor Engine II+, Supervisor Engine III y Supervisor Engine IV

Refiérase a estos documentos para obtener más información sobre la configuración del ruteo entre VLAN en un SFC, RSM, RSFCC o un router externo:

Nota: En este documento se asume que tiene conectividad básica con el switch, ya sea a través de la consola o mediante acceso telnet. Refiérase a estos documentos para obtener más información sobre cómo conseguir la conectividad básica con los switches:

Componentes Utilizados

La información que contiene este documento se basa en estas versiones de software y hardware.

  • Catalyst 6009 Switch que funciona con el software CatOS 5.5(x)

  • Catalyst 3524XL Switch que funciona con Cisco IOS Software Release 12.0(5.x)XU

  • Catalyst 4507 Switch con Supervisor Engine IV (WS-X4515) que funciona con Cisco IOS Software Release 12.1(13)EW1

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Productos Relacionados

La información de este documento también puede utilizarse con estos switches:

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Diferencia entre el software de sistema CatOS y Cisco IOS

CatOS en Supervisor Engine y Cisco IOS Softwatre en el MSFC (híbrido): Es posible utilizar una imagen de CatOS como software de sistema para ejecutar Supervisor Engine en switches Catalyst 6500/6000. Si está instalado el MSFC opcional, se utiliza una imagen de software IOS de Cisco separada para ejecutar el MSFC.

Cisco IOS Software en Supervisor Engine y en MSFC (Nativo): es posible utilizar una única imagen del software del IOS de Cisco como software de sistema para ejecutar tanto el motor supervisor como el MSFC en switches Catalyst 6500/6000.

Nota: Refiérase a Comparación de los Sistemas Operativos Cisco Catalyst y Cisco IOS para Cisco Catalyst 6500 Series Switch para obtener más información.

Configuración de la VLAN en Switches Catalyst que Ejecutan CatOS

Creación de VLAN y Puertos

Complete los pasos de esta sección para crear una VLAN.

Antes de que pueda crear una VLAN, el switch debe estar en modo servidor VTP o en modo transparente VTP. Si el switch es un servidor VTP, debe definir un nombre de dominio VTP antes de agregar VLAN.

  1. Defina un nombre de dominio VTP.

    Debe definir el nombre de dominio VTP independientemente de:

    • El número de switches de la red, ya se trate de uno o de varios

    • Si utiliza el VTP para propagar VLAN a otros switches de la red

    La configuración VTP predeterminada en el switch es la siguiente:

    CatosSwitch> (enable)show vtp domain
    
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
                                     1            2           server      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    5          1023             0               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    0.0.0.0         disabled disabled 2-1000

    Ejecute el comando set vtp para establecer el nombre de dominio y el modo.

    CatosSwitch> (enable)set vtp domain ?
    
      <name>                     Domain name
    
    CatosSwitch> (enable)set vtp domain cisco ?
    
      mode                       Set VTP mode
      passwd                     Set VTP password
      pruning                    Set VTP pruning
      v2                         Set VTP version 2
    
    CatosSwitch> (enable)set vtp domain cisco mode ?
    
      client                     VTP client mode
      server                     VTP server mode
      transparent                VTP transparent mode
    
    CatosSwitch> (enable)set vtp domain cisco mode server
    
    VTP domain cisco modified

    Nota: Refiérase a Cómo Comprender VLAN Trunk Protocol (VTP) para obtener más información sobre VTP.

  2. Ejecute el comando show vtp domain para verificar la configuración VTP.

    CatosSwitch> (enable)show vtp domain
    
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
    cisco                            1            2           server      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    5          1023             1               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    0.0.0.0         disabled disabled 2-1000

    Nota: Si tiene el resultado del comando show vtp domain de su dispositivo de Cisco, puede utilizar Output Interpreter (solo clientes registrados) para mostrar los potenciales problemas y soluciones.

  3. Después de configurar y verificar el dominio VTP, puede empezar a crear las VLAN en el switch.

    De forma predeterminada, hay solo una VLAN para todos los puertos. Esta VLAN se llama default. No puede cambiar el nombre de VLAN 1 ni eliminarla.

    Ejecute el comando show vlan para visualizar los parámetros para todas las VLAN configuradas en el dominio administrativo.

    CatosSwitch> (enable)show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    5       1/1-2
                                                            3/1-48
                                                            4/1-16
    1002 fddi-default                     active    6
    1003 token-ring-default               active    9
    1004 fddinet-default                  active    7
    1005 trnet-default                    active    8
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    1    enet  100001     1500  -      -      -      -    -        0      0
    1002 fddi  101002     1500  -      -      -      -    -        0      0
    1003 trcrf 101003     1500  -      -      -      -    -        0      0
    1004 fdnet 101004     1500  -      -      -      -    -        0      0
    1005 trbrf 101005     1500  -      -      -      ibm  -        0      0
    
    VLAN DynCreated  RSPAN
    ---- ---------- --------
    1    static     disabled
    1002 static     disabled
    1003 static     disabled
    1004 static     disabled
    1005 static     disabled
    
    VLAN AREHops STEHops Backup CRF 1q VLAN
    ---- ------- ------- ---------- -------
    1003 7       7       off
    1. Ejecute el comando set vlan para crear VLAN.

      CatosSwitch> (enable)set vlan
      
      Usage: set vlan <vlan> <mod/port>
             (An example of mod/port is 1/1,2/1-12,3/1-2,4/1-12)
             set vlan <vlan_num> [name <name>] [type <type>] [state <state>]
                                 [pvlan-type <pvlan_type>]
                                 [said <said>] [mtu <mtu>]
                                 [ring <hex_ring_number>]
                                 [decring <decimal_ring_number>]
                                 [bridge <bridge_number>] [parent <vlan_num>]
                                 [mode <bridge_mode>] [stp <stp_type>]
                                 [translation <vlan_num>] [backupcrf <off|on>]
                                 [aremaxhop <hopcount>] [stemaxhop <hopcount>]
                                 [rspan]
             (name = 1..32 characters, state = (active, suspend)
              type = (ethernet, fddi, fddinet, trcrf, trbrf)
              said = 1..4294967294, mtu = 576..18190
              pvlan-type = (primary,isolated,community,none)
              hex_ring_number = 0x1..0xfff, decimal_ring_number = 1..4095
              bridge_number = 0x1..0xf, parent = 2..1005, mode = (srt, srb)
              stp = (ieee, IBM, auto), translation = 1..1005
              hopcount = 1..13)
      Set vlan commands:
      ----------------------------------------------------------------------------
      set vlan                     Set vlan information
      set vlan mapping             Map an 802.1q vlan to an Ethernet vlan
      
      CatosSwitch> (enable)set vlan 2 name cisco_vlan_2
      
      Vlan 2 configuration successful
    2. Ejecute el comando show vlan para verificar la configuración de VLAN.

      CatosSwitch> (enable)show vlan
      
      VLAN Name                             Status    IfIndex Mod/Ports, Vlans
      ---- -------------------------------- --------- ------- --------------------
      1    default                          active    5       1/1-2
                                                              3/1-48
                                                              4/1-16
      2    cisco_vlan_2                     active    75      
      1002 fddi-default                     active    6       
      1003 token-ring-default               active    9       
      1004 fddinet-default                  active    7       
      1005 trnet-default                    active    8       
      
      
      VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
      ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
      1    enet  100001     1500  -      -      -      -    -        0      0
      2    enet  100002     1500  -      -      -      -    -        0      0
      1002 fddi  101002     1500  -      -      -      -    -        0      0
      1003 trcrf 101003     1500  -      -      -      -    -        0      0
      1004 fdnet 101004     1500  -      -      -      -    -        0      0
      1005 trbrf 101005     1500  -      -      -      IBM  -        0      0
      
      !--- Output suppressed.
      
      
    3. Si desea añadir puertos a la VLAN, ejecute el comando set vlan vlan_number mod/ports.

      CatosSwitch> (enable)set vlan 2 3/1-12
      
      VLAN 2 modified.
      VLAN 1 modified.
      VLAN  Mod/Ports
      ---- -----------------------
      2     3/1-12
            15/1

      Nota: También puede crear la VLAN y añadir los puertos a esa VLAN con toda la información en un comando único.

      Por ejemplo, si desea crear la tercera VLAN y después asignar los puertos 3/13 a 3/15 a esa VLAN, ejecute este comando:

      CatosSwitch> (enable)set vlan 3 3/13-15
      
      Vlan 3 configuration successful
      VLAN 3 modified.
      VLAN 1 modified.
      VLAN  Mod/Ports
      ---- -----------------------
      3     3/13-15
            15/1
  4. Ejecute el comando show vlan para verificar la configuración de VLAN.

    CatosSwitch> (enable)show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    5       1/1-2
                                                            3/16-48
                                                            4/1-16
    2    cisco_vlan_2                     active    75      3/1-12
    3    VLAN0003                         active    76      3/13-15
    1002 fddi-default                     active    6
    1003 token-ring-default               active    9
    1004 fddinet-default                  active    7
    1005 trnet-default                    active    8
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    1    enet  100001     1500  -      -      -      -    -        0      0
    2    enet  100002     1500  -      -      -      -    -        0      0
    3    enet  100003     1500  -      -      -      -    -        0      0
    1002 fddi  101002     1500  -      -      -      -    -        0      0
    1003 trcrf 101003     1500  -      -      -      -    -        0      0
    1004 fdnet 101004     1500  -      -      -      -    -        0      0
    1005 trbrf 101005     1500  -      -      -      IBM  -        0      0
    
    !--- Output suppressed.
    
    

Remoción de Puertos o VLAN

Para remover puertos de una VLAN, ejecute el comando set vlan vlan_number mod/ports y coloque los puertos en una VLAN diferente. Esta remoción es esencialmente lo que sucede cuando se asigna un puerto a cualquier VLAN, porque todos los puertos pertenecen inicialmente a la VLAN1.

Ejecute el comando clear vlan para eliminar una VLAN. Los puertos se desactivan porque siguen formando parte de esa VLAN, y la VLAN ya no existe. El switch visualiza una advertencia y le da la oportunidad de cancelar la solicitud actual.

CatosSwitch> (enable)clear vlan 3

This command will deactivate all ports on vlan 3
in the entire management domain.
Do you want to continue(y/n) [n]? y

Vlan 3 deleted

CatosSwitch> (enable)show vlan

VLAN Name                             Status    IfIndex Mod/Ports, Vlans
---- -------------------------------- --------- ------- ------------------------
1    default                          active    5       1/1-2
                                                        3/16-48
                                                        4/1-16
2    cisco_vlan_2                     active    75      3/1-12
1002 fddi-default                     active    6
1003 token-ring-default               active    9
1004 fddinet-default                  active    7
1005 trnet-default                    active    8

VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
1    enet  100001     1500  -      -      -      -    -        0      0
2    enet  100002     1500  -      -      -      -    -        0      0
1002 fddi  101002     1500  -      -      -      -    -        0      0
1003 trcrf 101003     1500  -      -      -      -    -        0      0
1004 fdnet 101004     1500  -      -      -      -    -        0      0
1005 trbrf 101005     1500  -      -      -      IBM  -        0      0

!--- Output suppressed.

Nota: Los puertos 3/13 a 3/15 no se visualizan en la salida del comando show vlan porque la remoción de VLAN 3 desactiva estos puertos. Los puertos no se muestran hasta que se agregan de nuevo a otra VLAN.

Consejos de Troubleshooting

Esta sección proporciona consejos de troubleshooting para problemas comunes que puede encontrar al crear VLAN en switches de Catalyst que ejecutan CatOS:

  • Si crea una VLAN cuando no haya un nombre de dominio VTP definido, recibirá este mensaje de error:

    Cannot add/modify VLANs on a VTP server without a domain name.

    Para corregir este problema, cree un nombre de dominio VTP en el switch. La sección Creación de VLAN y Puertos proporciona el procedimiento.

  • Si crea una VLAN en un switch que esté en el modo cliente de VTP, recibirá este mensaje de error:

    Cannot add/modify VLANs on a VTP client.

    Nota: Un switch solo puede crear VLAN si está en el modo de servidor de VTP o en el modo transparente de VTP. Refiérase a Cómo Comprender VLAN Trunk Protocol (VTP) para obtener más información sobre VTP.

  • Los puertos están en el estado inactivo en el resultado del comando show port mod/port. Este estado significa que la VLAN a la cual los puertos pertenecían originalmente fue eliminada, generalmente debido a VTP. Puede recrear esa VLAN o corregir la configuración VTP para que se restablezca la VLAN en el dominio VTP. Esto es un ejemplo de salida del comando show port mod/port:

    CatosSwitch> (enable)show port 3/1
    
    Port  Name               Status     Vlan       Duplex Speed Type
    ----- ------------------ ---------- ---------- ------ ----- ------------
     3/1                     inactive   2            auto  auto 10/100BaseTX
    
    Port  AuxiliaryVlan AuxVlan-Status     InlinePowered     PowerAllocated
                                       Admin Oper   Detected mWatt mA @42V
    ----- ------------- -------------- ----- ------ -------- ----- --------
     3/1  none          none           -     -      -        -     -
    
    !--- Output suppressed.
    
    

    Si tiene la salida de un comando show-tech support de su dispositivo Cisco, puede utilizar Output Interpreter (solo usuarios registrados) para mostrar los potenciales problemas y soluciones.

    CatosSwitch> (enable)show vlan 2
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN DynCreated  RSPAN
    ---- ---------- --------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN AREHops STEHops Backup CRF 1q VLAN
    ---- ------- ------- ---------- -------
  • Las interfaces VLAN creadas en los módulos de ruteo (RSM, RSFC, MSM, o MSFC) aparecen solamente cuando la VLAN correspondiente está disponible en el switch. Para que la interfaz VLAN esté completamente activa, lo que significa que esté administrativamente activa y con el protocolo de línea activo, asegúrese de tener al menos un puerto que sea miembro de esa VLAN, con un dispositivo activo conectado al puerto. Vea la sección Requisitos de este documento para ver las pautas de configuración.

Configuración de la VLAN en Catalyst 2900XL, 3500XL, 2950, 2970 y 2940 Series Switches

Creación de VLAN y Puertos

Nota: La salida que usted ve puede ser diferente de parte de la salida de comandos que se muestra en esta sección. La diferencia depende del modelo de su switch.

Siga estos pasos para crear una VLAN.

  1. Decida si utilizará VTP en la red.

    Con VTP, puede realizar cambios en la configuración de manera central en un solo switch y comunicar automáticamente tales cambios a todos los demás switches de la red. El modo VTP predeterminado en los switches Catalyst 2900XL, 3500XL, 2950, 2970 y 2940 es el modo de servidor. Refiérase a Cómo Comprender VLAN Trunk Protocol (VTP) para obtener más información sobre VTP.

    Nota: Ejecute el comando show vtp status para verificar el estado de VTP en los XL Series Switches.

    3524XL#show vtp status
    
    VTP Version                     : 2
    Configuration Revision          : 0
    Maximum VLANs supported locally : 254
    Number of existing VLANs        : 5
    VTP Operating Mode              : Server
    
    !--- This is the default mode.
    
    VTP Domain Name                 : 
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0xBF 0x86 0x94 0x45 0xFC 0xDF 0xB5 0x70 
    Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
  2. Después de configurar y verificar el dominio VTP, puede empezar a crear las VLAN en el switch.

    De forma predeterminada, hay solo una VLAN para todos los puertos. Esta VLAN se llama default. No puede cambiar el nombre de VLAN 1 ni eliminarla.

    Ejecute el comando show vlan para verificar la información de VLAN.

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12,
                                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16,
                                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20,
                                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24,
                                                    Gi0/1, Gi0/2
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1        IBM  -        0      0

    Ejecute el siguiente conjunto de comandos en modo privilegiado para crear otra VLAN:

    3524XL#vlan database
    
    !--- You must enter into VLAN database in order to configure any VLAN.
    
    3524XL(vlan)#vtp server
    
    Device mode already VTP SERVER.
    
    !--- You can skip this command if the switch is already in server mode and you
    !--- want the switch to be in server mode.
    
    

    Nota: Un switch solo puede crear VLAN si está en el modo de servidor de VTP o en el modo transparente de VTP. Refiérase a Cómo Comprender VLAN Trunk Protocol (VTP) para obtener más información sobre VTP.

    524XL(vlan)#vlan ?
    
      <1-1005>  ISL VLAN index
    
    3524XL(vlan)#vlan 2 ?
    
      are        Maximum number of All Route Explorer hops for this VLAN
      backupcrf  Backup CRF mode of the VLAN
      bridge     Bridging characteristics of the VLAN
      media      Media type of the VLAN
      mtu        VLAN Maximum Transmission Unit
      name       Ascii name of the VLAN
      parent     ID number of the Parent VLAN of FDDI or Token Ring type VLANs
      ring       Ring number of FDDI or Token Ring type VLANs
      said       IEEE 802.10 SAID
      state      Operational state of the VLAN
      ste        Maximum number of Spanning Tree Explorer hops for this VLAN
      stp        Spanning tree characteristics of the VLAN
      tb-vlan1   ID number of the first translational VLAN for this VLAN (or zero
                 if none)
      tb-vlan2   ID number of the second translational VLAN for this VLAN (or zero
                 if none)
    
    3524XL(vlan)#vlan 2 name ?
    
      WORD  The ASCII name for the VLAN
    
    3524XL(vlan)#vlan 2 name cisco_vlan_2
    
    VLAN 2 added:
        Name: cisco_vlan_2
    
    3524XL(vlan)#exit
    
    !--- You must exit from the VLAN database in order for the changes 
    !--- to be committed.
    
    APPLY completed.
    Exiting....
    3524XL#

    Nota: El modo VTP puede cambiar del modo de cliente al modo transparente si el switch intenta aprender o pasar un número de VLAN mayor del que soporte. Verifique siempre que los switches que funcionen en modo cliente soporten el mismo número de VLAN que envíen los switches en modo de servidor.

  3. Ejecute el comando show vlan para asegurarse de que se cree la VLAN.

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12,
                                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16,
                                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20,
                                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24,
                                                    Gi0/1, Gi0/2
    2    cisco_vlan_2                     active    
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1
  4. Puede añadir puertos (interfaces) a la VLAN recién creada.

    Para llegar a cada una de las interfaces que quiere agregar a la nueva VLAN debe ingresar en el modo de configuración de interfaz.

    Nota: Puede asignar los puertos de un Layer 2 Catalyst Switch a varios VLAN, pero el switch solo soporta una interfaz VLAN de administración activa a la vez y otras interfaces virtuales conmutadas (SVI) no hacen up/up debido a las funciones de la Capa 2. Por lo tanto, el switch soporta solamente un direccionamiento de la Capa 3 de la administración activa. En un Layer 2 Catalyst Switch, puede ejecutar el comando management opcional bajo la nueva SVI para apagar automáticamente la VLAN1 y transferir la dirección IP a la nueva VLAN.

    Switch#configure terminal
    
    Switch(config)#interface vlan 2
    
    Switch(config-subif)#management
    
    Switch(config-subif)#^Z
    
    Switch#show ip interface brief
    Interface                  IP-Address      OK? Method Status   Protocol
    VLAN1                      10.0.0.2        YES manual up       down    
    VLAN2                      20.0.0.2        YES manual up       up      
    FastEthernet0/1            unassigned      YES unset  up       up      
    FastEthernet0/2            unassigned      YES unset  up       up
    
    !--- Output suppressed.
    
    

    Ejecute este conjunto de comandos en modo privilegiado para añadir una interfaz particular a la VLAN:

    3524XL#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    3524XL(config)#interface fastethernet 0/2
    
    3524XL(config-if)#switchport access ?
    
      vlan  Set VLAN when interface is in access mode
    
    3524XL(config-if)#switchport access vlan ?
    
      <1-1001>  VLAN ID of the VLAN when this port is in access mode
      dynamic   When in access mode, this interfaces VLAN is controlled by VMPS
    
    3524XL(config-if)#switchport access vlan 2
    
    !--- These commands assign interface Fast Ethernet 0/2 to VLAN 2.
    
    3524XL(config-if)#exit
    
    3524XL(config)#interface fastethernet 0/3
    
    3524XL(config-if)#switchport access vlan 2
    
    !--- These commands assign interface Fast Ethernet 0/3 to VLAN 2.
    
    3524XL(config-if)#end
    
    3524XL#
    00:55:26: %SYS-5-CONFIG_I: Configured from console by console
    
    3524XL#write memory
    
    !--- This saves the configuration.
    
    Building configuration...
  5. Ejecute el comando show vlan para verificar la configuración de VLAN.

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/4, Fa0/5, Fa0/6,
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14,
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18,
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22,
                                                    Fa0/23, Fa0/24, Gi0/1, Gi0/2
    2    cisco_vlan_2                     active    Fa0/2, Fa0/3
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1        IBM  -        0      0

Remoción de Puertos o VLAN

Para remover los puertos de la VLAN, ejecute el comando no switchport access vlan vlan_number en el modo de configuración de la interfaz. Una vez eliminado el puerto de una VLAN que no sea VLAN1 (la VLAN predeterminada), ese puerto se añadirá de nuevo automáticamente a la VLAN predeterminada.

Por ejemplo, si desea remover la interfaz Fast Ethernet 0/2 de cisco_vlan_2 (VLAN 2), ejecute este conjunto de comandos en el modo privilegiado:

3524XL#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

3524XL(config)#interface fastethernet 0/2

3524XL(config-if)#no switchport access vlan 2

!--- These two commands remove interface Fast Ethernet 0/2 from VLAN 2.

3524XL(config-if)#end

3524XL#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5,

!--- Note: Fast Ethernet 0/2 is added back to the default VLAN.

                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9,
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13,
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17,
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21,
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/1,
                                                Gi0/2
2    cisco_vlan_2                     active    Fa0/3
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
2    enet  100002     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
1005 trnet 101005     1500  -      -      1        IBM  -        0      0

Para eliminar la VLAN, ejecute el comando no vlan vlan_number en el modo de base de datos de VLAN. Las interfaces de esa VLAN siguen siendo una parte de esa VLAN y se desactivan porque ya no pertenecen a ninguna VLAN.

Por ejemplo, si quiere eliminar cisco_vlan_2 del switch, ejecute este conjunto de comandos en el modo privilegiado:

3524XL#vlan database

!--- This command enters you into the VLAN database mode.

3524XL(vlan)#no vlan 2

!--- This command removes the VLAN from the database.

Deleting VLAN 2...

3524XL(vlan)#exit

APPLY completed.
Exiting....

3524XL#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5,
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9,
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13,
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17,
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21,
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/1,
                                                Gi0/2
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

!--- Output suppressed.

Observe que el puerto .Fast Ethernet 0/3 no se muestra en la salida del comando show vlan. La remoción de VLAN 2 desactiva este puerto. A menos que añada de nuevo el puerto a otra VLAN, el puerto no se mostrará ni será utilizable.

3524XL#show interfaces fastethernet 0/3

FastEthernet0/3 is down, line protocol is down

!--- Output suppressed.

Para hacer que la interfaz esté disponible, debe asegurarse de que pertenezca a alguna VLAN. En el caso de esta sección del documento, deberá añadir la interfaz Ethernet 0/3 a la VLAN predeterminada (VLAN 1) para hacer esta interfaz utilizable.

Si tiene la salida de un comando show-tech support de su dispositivo Cisco, puede utilizar Output Interpreter (solo usuarios registrados) para mostrar los potenciales problemas y soluciones.

Nota: En el caso de los Catalyst 3550 Switches, todavía puede utilizar la interfaz sin la adición de la interfaz a una VLAN. Sin embargo, deberá convertir esa interfaz en una interfaz de la Capa 3. Refiérase a la sección Configuración de las Interfaces de la Capa 3 en Configuración de las Características de la Interfaz para obtener más información sobre las interfaces de la Capa 3 en Catalyst 3550 Switches.

Configuración de un Puerto de VLAN Múltiple en el Catalyst 2900XL/3500XL

La función del puerto de VLAN múltiple en los Catalyst 2900XLl/3500XL Switches permite configurar un puerto único en dos o más VLAN. Esta característica permite que los usuarios de diversas VLAN accedan a un servidor o un router sin la implementación de la capacidad del de ruteo entre VLAN. Un puerto de VLAN múltiples realiza funciones de conmutación normales en todas sus VLAN asignadas. El tráfico de VLAN en el puerto de VLAN múltiple no se encapsula mientras se encuentra en trunking.

Nota: Las limitaciones de la implementación de las funciones del puerto de VLAN múltiple son las siguientes:

  • No puede configurar un puerto de VLAN múltiple cuando hay un tronco configurado en el switch. Puede conectar el puerto de VLAN múltiple solamente a un router o a un servidor. El switch cambia automáticamente al modo transparente de VTP cuando se habilita la función del puerto de VLAN múltiple, lo que inhabilita a VTP. No es necesaria ninguna configuración de VTP.

  • La función del puerto de VLAN múltiple se soporta solamente en los Catalyst 2900XL/3500XL Series Switches. Esta función no se soporta en los Catalyst 4500/4000, 5500/5000, o los switches de las series 6500/6000 Series ni en ningún otro switch Catalyst.

  1. Determine qué puerto se debe configurar como puerto de VLAN múltiple.

    Aquí, se crean tres VLAN en un Catalyst 3512XL Switch, y un puerto del switch está conectado con un router externo. Este ejemplo configura el puerto que está conectado con el router como puerto de VLAN múltiple.

    6-3512xl#show vlan
    
    VLAN Name                             Status      Ports
    ---- -------------------------------- ---------   -----------------------------
    1    default                          active      Fa0/1, Fa0/3, Fa0/6, Fa0/7,
                                                      Fa0/8, Fa0/9, Fa0/10, Fa0/11,
                                                      Fa0/12, Gi0/1, Gi0/2
    2    VLAN0002                         active      Fa0/2, Fa0/4
    3    VLAN0003                         active      Fa0/5
    4    VLAN0004                         active
    5    VLAN0005                         active
    6    VLAN0006                         active

    En el ejemplo, el puerto Fast Ethernet 0/1 está conectado a un router externo. Para obtener más información sobre cómo crear VLAN y asignar puertos a VLAN, vea la sección Configuración de la VLAN en Catalyst 2900XL, 3500XL, 2950, 2970 y 2940 Series Switches de este documento.

  2. Configure el puerto Fast Ethernet 0/1 en el modo de VLAN múltiple y añada las VLAN asignadas al puerto de VLAN múltiple.

    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface fastethernet 0/1
    
    6-3512xl(config-if)#switchport mode multi
    
    !--- This command changes the port Fast Ethernet 0/1 mode to multi.
    
    6-3512xl(config-if)#switchport multi vlan ?
    
      LINE    VLAN IDs of VLANs to be used in multi-VLAN mode
      add     add VLANs to the current list
      remove  remove VLANs from the current list
    
    6-3512xl(config-if)#switchport multi vlan 1,2,3
    
    !--- This command assigns VLANs 1, 2, and 3 to multi-VLAN port Fast Ethernet 0/1.
    
    6-3512xl(config-if)#^Z
     
    6-3512xl#
  3. Ejecute el comando show interface interface_id switchport y el comando show vlan para verificar la configuración.

    6-3512xl#show interface fastethernet 0/1 switchport
    
    Name: Fa0/1
    Operational Mode: multi
    
    !--- The port is in multi-VLAN mode.
    
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: NONE
    Pruning VLANs Enabled: NONE
    
    Priority for untagged frames: 0
    
    Override vlan tag priority: FALSE
    
    Voice VLAN: none
    
    Appliance trust: none
    
    6-3512xl#show vlan brief
    
    VLAN Name                             Status       Ports
    ---- -------------------------------- ---------    ----------------------------
    1    default                          active       Fa0/1, Fa0/3, Fa0/6, Fa0/7,
                                                       Fa0/8, Fa0/9, Fa0/10, Fa0/1
                                                       Fa0/12, Gi0/1, Gi0/2
    2    VLAN0002                         active       Fa0/1, Fa0/2, Fa0/4
    
    !--- Note: Previously, port Fast Ethernet 0/1 was only in VLAN 1.
    !--- Now the port is assigned to multiple VLANs 1, 2, and 3.
    
    3    VLAN0003                         active       Fa0/1, Fa0/5
    4    VLAN0004                         active
    5    VLAN0005                         active
  4. Ejecute el comando ping del switch al router para verificar la operación de VLAN múltiple.

    El comando ping recibe una respuesta del router cada vez que se asigna la dirección IP de administración a cualquiera de las VLAN 1, 2 o 3.

    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 1
    
    6-3512xl(config-if)#ip address 192.168.1.1 255.255.255.0
    
    !--- The management IP address is assigned to VLAN 1.
    
    6-3512xl(config-if)#^Z
    
    6-3512xl#
    23:56:54: %SYS-5-CONFIG_I: Configured from console by console
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- You can ping the router from VLAN 1.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 1
    
    6-3512xl(config-if)#no ip address
    
    !--- The management IP address is removed from VLAN 1.
    
    6-3512xl(config-if)#shutdown
    
    6-3512xl(config-if)#exit
    
    6-3512xl(config)#interface vlan 2
    
    6-3512xl(config-subif)#ip address 192.168.1.1 255.255.255.0
    
    6-3512xl(config-subif)#no shutdown
    
    !--- The management IP address is assigned to VLAN 2.
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#exit
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- You can ping the router from VLAN 2.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/202/1004 ms
    
    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 2
    
    6-3512xl(config-subif)#no ip address
    
    !--- The management IP address is removed from VLAN 2.
    
    6-3512xl(config-subif)#shutdown
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#interface vlan 3
    
    6-3512xl(config-subif)#ip address 192.168.1.1 255.255.255.0
    
    6-3512xl(config-subif)#no shut
    
    !--- The management IP address is assigned to VLAN 3.
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#exit
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- You can ping the router from VLAN 3.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/205/1004 ms

Configuración de la VLAN en los Switches Catalyst de la Serie 3550, 3750, 4500/4000 y 6500/6000 que Ejecutan Cisco IOS Software

Creación de VLAN y Puertos

En esta sección se utiliza el Catalyst 4500 Switch para los comandos del ejemplo de configuración, pero las tareas de configuración también se aplican a otros switches que ejecuten la Capa 3 (o Cisco IOS Software). Estos otros switches incluyen los Catalyst 3550, 3570 y 6500 Series Switches que funcionan con Cisco IOS Software. Antes de que pueda crear una VLAN, el switch debe estar en modo servidor VTP o en modo transparente VTP. Si el switch es un servidor VTP, debe definir un nombre de dominio VTP antes de añadir VLAN. Debe definir un nombre de dominio VTP independientemente de:

  • El número de switches de la red, ya se trate de uno o de varios

  • Si utiliza el VTP para propagar VLAN a otros switches de la red

Refiérase a Cómo Comprender y Configurar VTP para obtener más información sobre cómo configurar VTP en los módulos de Supervisor Engine basados en Cisco IOS Software del Catalyst 4500/4000. Refiérase a la Guía de Configuración del Software para la plataforma del switch bajo consideración para obtener información de la configuración VTP para otras plataformas de switches Catalyst. Refiérase a las Páginas de Soporte de Productos LAN para localizar la Guía de Configuración del Software.

Puede crear VLAN tanto en modo de base de datos VLAN como en modo de configuración global. Debe crear VLAN con numeración superior a 1005 en el modo de configuración global. El modo VTP debe fijarse en transparente para crear estas VLAN. Las VLAN con numeración superior a 1005 no son hechas públicas por VTP. Además, las VLAN con numeración superior a 1005 se almacenan en el archivo de configuración del switch y no en el archivo .dat de VLAN. La ubicación predeterminada del archivo .dat de VLAN en los Catalyst 4000 Switches con Supervisor Engine IV es el directorio cat4000_flash.

Switch#dir cat4000_flash:

Directory of cat4000_flash:/

1 -rw- 676 <no date> vlan.dat

524260 bytes total (523584 bytes free)

Nota: Un Catalyst 6500 Switch que funciona con Cisco IOS Software permite crear VLAN en el modo de servidor sin un nombre de dominio VTP.

El comando show vtp status muestra la información VTP del switch.

Switch#show vtp status

VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs : 8
VTP Operating Mode : Server
VTP Domain Name : cisco
VTP Pruning Mode : Enabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xA4 0x18 0x78 0x52 0x5A 0x1B 0x2E 0x14
Configuration last modified by 0.0.0.0 at 5-28-01 05:17:02
Local updater ID is 10.10.10.1 on interface Vl1 (lowest numbered VLAN interface)
  1. Ejecute el comando show vlan para verificar la información de VLAN.

    Switch#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Gi1/1, Gi1/2, Gi3/1, Gi3/2
                                                    Gi3/3, Gi3/4, Gi3/5, Gi3/6
                                                    Gi3/7, Gi3/8, Gi3/9, Gi3/10
                                                    Gi3/11, Gi3/12, Gi3/13, Gi3/14
                                                    Gi3/15, Gi3/16, Gi3/17, Gi3/18
    
    !--- Output suppressed.
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1002 fddi-default                     act/unsup
    1003 token-ring-default               act/unsup
    1004 fddinet-default                  act/unsup
    1005 trnet-default                    act/unsup
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        0      0
    1003 tr    101003     1500  -      -      -        -    -        0      0
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0
    
    Primary Secondary Type              Ports 
    ------- --------- ----------------- ------------------------------------------
  2. Ingrese en el modo correcto, ya sea en modo de base de datos o en modo de configuración global.

    Ejecute el comando vlan database en el modo privilegiado para ingresar en el modo de base de datos de VLAN.

    Switch#vlan database
    
    Switch(vlan)#
  3. Ejecute el comando vlan vlan_number para configurar una VLAN.

    Switch(vlan)#vlan 2
    
    VLAN 2 added:
    Name: VLAN0002
    
    Switch(vlan)#apply
    
    APPLY completed.

    Nota: Para que la configuración tenga efecto, puede ejecutar el comando apply o salir del modo de base de datos de VLAN. La palabra clave end y los métodos de salida Ctrl-Z no funcionan en el modo de base de datos de VLAN. Ejecute el comando exit para salir del modo de base de datos de VLAN.

    Ejecute estos comandos en orden para realizar la configuración de VLAN en el modo de configuración global:

    Switch(config)#vlan 3
    
    Switch(config-vlan)#exit
    
    Switch(config)#
  4. Ejecute el comando show run para ver las VLAN con numeración superior a 1005 en la configuración en ejecución.

    Switch#show running-config
    
    Building configuration...
    
    Current configuration : 2975 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service compress-config
    !
    hostname Switch
    !
    !
    ip subnet-zero
    !
    spanning-tree extend system-id
    !
    redundancy
    mode rpr
    main-cpu
    auto-sync standard
    !
    !
    vlan 2000
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    
    !--- Output suppressed.
    
    

En Cisco IOS Software, las interfaces están en shutdown state de forma predeterminada, a diferencia de los switches basados en CatOS. En CatOS, el puerto se activa si detecta la presencia de un link físico.

De forma predeterminada, las interfaces de Cisco IOS Software son interfaces de Capa 2 en los Catalyst 3550, 3750 y 4500 Series Switches. Las interfaces son interfaces de Capa 3 en los Catalyst 6500/6000 Series Switches. Puede configurar la interfaz como una interfaz de Capa 2 con el comando switchport en el modo de configuración de la interfaz. Debe publicar este comando antes de asignar una interfaz a una VLAN, si la interfaz está en el modo de Capa 3. El comando para asignar una interfaz a una VLAN es switchport access vlan vlan_number .

Nota: Si se configura la interfaz como una interfaz de Capa 3, lo que significa que se configura el comando no switchport, no podrá asignar la interfaz a una VLAN.

Para asociar los puertos a VLAN en Cisco IOS Software, se requiere esta configuración mínima:

Switch(config)#interface gigabitethernet 3/1

Switch(config-if)#switchport

!--- This command is required if the interface is in Layer 3 mode.

Switch(config-if)#switchport access vlan 2

Switch(config-if)#no shutdown

Ejecute el comando show interface gigabitethernet module/interface switchport para verificar el estado de la interfaz de Capa 2.

Switch#show interface gigabitethernet 3/1 switchport

Name: Gi3/1
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 2 (VLAN0002)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Voice VLAN: none (Inactive)
Appliance trust: none

Si el puerto se configura como trunk, que es un puerto que puede llevar más de una VLAN, el comando switchport trunk native vlan puede ser útil. El comando es útil si la VLAN nativa de la interfaz se ha modificado si es necesario modificar sus valores respecto a los predeterminados. La VLAN nativa es la VLAN que se utiliza si la interfaz se va a convertir en una interfaz de capa 2. Si usted no define explícitamente una VLAN nativa, VLAN1 se convierte en la VLAN nativa de forma predeterminada. Tenga en cuenta que no se añade una cabecera IEEE 802.1Q al enviar datos en la VLAN nativa. Asegúrese de que los puertos trunk en ambos dispositivos conectados tengan la misma VLAN nativa. Una discordancia en las VLAN nativas puede causar problemas de ruteo entre VLAN, entre otros problemas.

Este mensaje aparece cuando la VLAN nativa no coincide en los dos switches Cisco:

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEhernet1/1 (2),
 with D-R3550-9B GigabitEthernet0/1 (1)

En este mensaje de ejemplo, la VLAN nativa es VLAN2 en uno de los switches, pero el switch vecino tiene la VLAN nativa 1.

Ejecute el comando show interfaces module/interface trunk para ver la información de VLAN nativa, encapsulación y VLAN de trunking.

Switch#show interfaces gigabitethernet 3/1 trunk

Port Mode Encapsulation Status Native vlan
Gi3/1 on 802.1q trunking 1
 Port Vlans allowed on trunk
Gi3/1 1-4094
 Port Vlans allowed and active in management domain
Gi3/1 1-4,2000,3000
 Port Vlans in spanning tree forwarding state and not pruned
Gi3/1 none

Si utiliza la configuración predeterminada, la VLAN nativa se establece en VLAN 1. Para cambiar la VLAN nativa en la interfaz que de trunking, ejecute el comando switchport trunk native vlan vlan_number.

Switch(config)#interface gigabitethernet 3/1

Switch(config-if)#switchport trunk native vlan 2

Ejecute este comando para verificar:

Switch#show interfaces gigabitethernet 3/1 trunk

Port Mode Encapsulation Status Native vlan
Gi3/1 on 802.1q trunking 2
 Port Vlans allowed on trunk
Gi3/1 1-4094
 Port Vlans allowed and active in management domain
Gi3/1 1-4,2000,3000
 Port Vlans in spanning tree forwarding state and not pruned
Gi3/1 none

Asignación de Puertos Múltiples a una Sola VLAN

Puede asignar múltiples interfaces de un switch a una única VLAN. Ejecute estos comandos:

  1. Switch(config)#interface range fastethernet [mod/slot - mod/slot]
    
  2. Switch(config-if-range)#switchport access vlan vlan_number
    
    
  3. Switch(config-if-range)#switchport mode access
    
  4. Switch(config-if-range)#no shut
    

Nota: El comando interface range no se soporta en todas las versiones de software. El comando interface range se soporta en Cisco IOS Software Release 12.1(13)EW y posterior.

Remoción de VLAN

Para remover una VLAN de la base de datos de VLAN, ejecute el comando no vlan vlan_number en el modo de base de datos de VLAN o en el modo de configuración global. En este ejemplo se utiliza el modo de base de datos de VLAN para remover la VLAN 2.

Switch#vlan database

Switch(vlan)#no vlan 2

Deleting VLAN 2...

Switch(vlan)#apply

APPLY completed.

El modo de configuración global no registra ningún mensaje en la consola que indique la eliminación de la VLAN. Sin embargo, puede ejecutar el comando show vlan para verificar la eliminación de la VLAN.

Cambio del Nombre de VLAN

Para cambiar el nombre de una VLAN desde la base de datos de VLAN, ejecute el comando name vlan_name en el modo de base de datos de VLAN o en el modo de configuración global.

Este ejemplo utiliza el modo de base de datos de VLAN para cambiar el nombre de VLAN 3:

Switch#vlan database

Switch(vlan)#vlan 3

Switch(vlan)#name CISCO

Switch(vlan)#apply

APPLY completed.

En este ejemplo se utiliza el modo de configuración global para cambiar el nombre de VLAN 3:

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

Switch(vlan)#vlan 3

Switch(vlan)#name CISCO

Para la verificación, ejecute el comando show vlan brief o show vlan-switch brief.

switch#show vlan brief

VLAN  Name                             Status    Ports
---- -------------------------------- --------- -----------
 3    CISCO                            active    Fa0/3

Nota: Cuando cambie el nombre de la VLAN, no es necesario que remueva la VLAN asignada al puerto usando el comando switchport access vlan vlan_number.

Cómo Aislar la Comunicación entre Dos VLAN

Esta sección no trata las VLAN privadas. Las VLAN privadas proporcionan aislamiento de la Capa 2 entre los puertos dentro de la misma VLAN privada (VLAN aislada) o entre las VLAN privadas (VLAN de comunidad).

Hay dos escenarios para intentar aislar dos VLAN.

Aislamiento entre Dos VLAN de Capa 2

Una VLAN de Capa 2 es la VLAN creada en el switch y no configurada con el comando interface vlan <vlan_number>. Los hosts de las diferentes VLAN de Capa 2 no se pueden comunicar entre sí.

Complete estos pasos para crear una VLAN de capa 2 y aislarla de VLAN más antiguas:

  1. Cree la nueva VLAN en la base de datos. Cuando salga del modo de base de datos de vlan, se aplicarán los cambios de configuración.

    Switch#vlan database
    
    !--- You must enter into VLAN database mode in order to 
    !--- configure any VLAN.
    
    Switch(vlan)#vlan 5
    VLAN 5 added:
        Name: VLAN0005
    Switch(vlan)#vlan 6
    VLAN 6 added:
        Name: VLAN0006
    Switch(vlan)#exit
    APPLY completed.
    Exiting....
  2. Asegúrese de que la VLAN se cree en la base de datos de vlan. La nueva VLAN debe aparecer en la salida del comando show vlan.

  3. No establezca una dirección IP en las VLAN recién creadas.

  4. Configure las interfaces físicas que conectan los clientes con la VLAN correspondiente.

    Switch(config)#interface fastEthernet 2/1
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 5
    Switch(config-if)#no shut
    
    witch(config)#interface fastEthernet 2/2
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 6
    Switch(config-if)#no shut
    
  5. Asigne a cada host una dirección IP estática, una máscara de subred, y no establezca un gateway predeterminado. Esto hace que los hosts de los puertos fa 2/1 y 2/2 no se comuniquen entre sí. Los dispositivos que pertenecen a una VLAN no se comunican más que con dispositivos dentro de la misma VLAN.

Aislamiento entre 3 VLAN de Capa 3

Cuando se crea una VLAN y se asigna una dirección IP con el comando interface vlan <vlan_number>, la VLAN se convierte en una VLAN de Capa 3. En los switches de la Capa 3, los hosts entre las dos VLAN pueden comunicarse entre sí (si los hosts están configurados con el gateway predeterminado como dirección IP de la interfaz VLAN). Puede utilizar ACL para denegar la comunicación entre VLAN.

Esta sección muestra un ejemplo de cómo aislar la comunicación entre una VLAN de Capa 3 recién creada y una VLAN más antigua.

En este ejemplo, el switch 3750 tiene dos VLAN antiguas (VLAN 1 y VLAN 2). La VLAN recién creada es VLAN 5. VLAN 1, VLAN 2 y VLAN 5 son VLAN de la Capa 3. Los ACL se implementan para denegar el tráfico de modo que VLAN 1 y VLAN 2 no puedan comunicarse con VLAN 5 y que VLAN 5 no se comunique con VLAN 1 ni VLAN2.

  • VLAN 1 - 10.10.10.0 /24

  • VLAN 2 - 172.16.1.0 /24

  • VLAN 5 - 192.168.1.0 /24

  1. Cree la nueva VLAN en la base de datos. En este caso la nueva VLAN es VLAN 5. Cuando salga del modo de base de datos de vlan, se aplicarán los cambios de configuración.

    Switch#vlan database
    
    !--- You must enter into VLAN database mode
    !--- in order to configure any VLAN.
    
    Switch(vlan)#vlan 5
    VLAN 5 added:
        Name: VLAN0005
    Switch(vlan)#exit
    APPLY completed.
    Exiting....
  2. Asegúrese de que la VLAN se cree en la base de datos de vlan. Verifique la salida del comando show vlan.

  3. Establezca una dirección IP para la VLAN recién creada.

    Switch(config)#interface vlan 5
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config)#no shut
    
  4. Configure las interfaces físicas que conectan los clientes con la VLAN correspondiente.

    Switch(config)#interface fastEthernet 2/1 
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 5
    Switch(config-if)#no shut
    

    Debe configurar tres listas de acceso, una para cada VLAN.

    • Esta lista de acceso deniega al tráfico procedente de VLAN 1 el acceso a VLAN 5.

      
      !--- Some of the commands in this output are wrapped
      !--- to a second line due to spatial reasons.
      
      Switch#configure terminal
      Switch(config)#access-list 101 deny 
      ip 10.10.10.0 0.0.0.255 192.168.1.0 0.0.0.255
      Switch(config)#access-list 101 permit ip 10.10.10.0 0.0.0.255 any
      
    • Esta lista de acceso deniega el tráfico procedente de VLAN 2 el acceso a VLAN 5.

      Switch#configure terminal
      Switch(config)#access-list 102 deny ip 172.16.1.0 0.0.0.255 192.168.1.0 0.0.0.255
      Switch(config)#access-list 102 permit ip 172.16.1.0 0.0.0.255 any
      
    • Esta lista de acceso deniega el tráfico procedente de VLAN 5 el acceso a VLAN 1 y VLAN 2.

      Switch#configure terminal
      Switch(config)#access-list 105 deny ip 192.168.1.0 0.0.0.255 10.10.10.0 0.0.0.255
      Switch(config)#access-list 105 deny ip 192.168.1.0 0.0.0.255 172.16.1.0 0.0.0.255
      Switch(config)#access-list 105 permit ip 192.168.1.0 0.0.0.255 any
      

    Y, una vez configuradas, aplique las listas de acceso a la interface VLAN 1, la interfaz VLAN 2 y la interfaz VLAN 5.

    Switch#configure terminal
    Switch(config)#interface vlan 1
    Switch(config-if)#ip access-group 101 in
    Switch(config-if)#exit
    
    Switch#configure terminal
    Switch(config)#interface vlan 2
    Switch(config-if)#ip access-group 102 in
    Switch(config-if)#exit
    
    Switch#configure terminal
    Switch(config)#interface vlan 5
    Switch(config-if)#ip access-group 105 in
    Switch(config-if)#end
    

Cómo Configurar las VLAN de Rango Extendido en un Catalyst 6500 Series Switch

Para configurar VLAN extendidas en los Catalyst 6500 Series Switch que ejecutan el Cisco IOS, debe ejecutar el comando spanning-tree extend system-id. Entonces, se debe crear la VLAN extendida en el modo de configuración, y no desde el modo de base de datos vlan.

Complete estos pasos para crear VLAN extendidas en los Catalyst 6500 Series Switches que ejecuten Cisco IOS:

  1. Consola en el switch:

    Switch>enable
    Switch#
  2. Ingrese en el modo de configuración:

    Switch#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#
  3. Ejecute el comando spanning-tree extend system-id en el modo de configuración:

    Switch(config)#spanning-tree extended system-id
    
  4. Ejecute el comando vtp mode transparent en el modo de configuración:

    Switch(config)#vtp mode transparent
    
  5. Cree la VLAN en el modo de configuración:

    Switch(config)#vlan 1311
    Notice
    Switch(config-vlan)#exit
    
  6. Salga del modo de configuración:

    Switch(config)#exit
    
  7. Ejecute el comando show vlan para verificar la información de VLAN.

    Switch#show vlan
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    
    101  VLAN0101                         active    Gi4/8, Gi4/10
    1002 fddi-default                     act/unsup 
    1003 token-ring-default               act/unsup 
    1004 fddinet-default                  act/unsup 
    1005 trnet-default                    act/unsup 
    1311 VLAN1311                         active    
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0   
    101  enet  100101     1500  -      -      -        -    -        0      0   
    1002 fddi  101002     1500  -      -      -        -    -        0      0   
    1003 tr    101003     1500  -      -      -        -    -        0      0   
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0   
    1311 enet  101311     1500  -      -      -        -    -        0      0   

Consejos de Troubleshooting

Esta sección proporciona consejos de troubleshooting para problemas comunes que puede encontrar durante la creación de VLAN en switches de Catalyst que funcionen con Cisco IOS.

En los switches que funcionan con Cisco IOS Software, puede utilizar el propio switch para el ruteo entre VLAN Routing, en vez de un router externo. Cuando se crea un SVI, no se crea automáticamente una VLAN en la base de datos de la Capa 2. Para que se active una SVI, se debe crear una VLAN en el modo de base de datos de vlan o (en versiones posteriores de Cisco IOS Software) en el modo de configuración global. Para que la SVI esté completamente activa, lo que significa que esté administrativamente activa y con el protocolo de línea activo, asegúrese de tener al menos un puerto que sea miembro de esa VLAN, con un dispositivo activo conectado al puerto.

Esto mismo se aplica al copiar configuraciones de un switch diferente o al restaurar configuraciones con VLAN creadas en el modo de base de datos de VLAN. Usted debe también substituir el archivo de base de datos de VLAN (vlan.dat), o usted debe reconstruir los VLA N, pues el procedimiento en la sección de CreateVLANs y de los puertos de este documento muestra. Si copia la configuración de otro switch, las bases de datos de VLAN no se copiará.

Si la VLAN de Capa 2 no se crea en el switch, las interfaces SVI se muestran como UP/DOWN en la salida del comando show ip interface brief cuando se aplica la configuración al switch. Asegúrese de que todas las VLAN anteriores que se crearon en el modo de base de datos de VLAN o en el modo de configuración global continúen existiendo después de copiar la configuración en el switch.

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Error de Valor TLB Incoherente en Switches IOS

El error de valor de bridging de traducción incoherente (BTI) se produce cuando se crea una VLAN en un switch Cisco IOS que haya recibido recientemente una actualización VTP de un switch CatOS o que se haya convertido desde CatOS. Esto es porque CatOS Cisco IOS tienen algunos valores predeterminados diferentes para el bridge VLAN de traducción. Las VLAN de traducción traducen Fiber Distributed Data Interface (FDDI) o Token Ring a Ethernet. Las VLAN de bridge de traducción (tb) para VLAN 1, 1002 y 1003 son diferentes en CatOS y son 0 de forma predeterminada . Las VLAN de bridge de traducción predeterminadas de fábrica en los switches de Cisco IOS son:

Vlan ID      tb1        tb2
--------     -----     -----
1            1002      1003
1002         1         1003
1003         1         1002

Un switch Cisco IOS que haya recibido recientemente una actualización VTP de un switch CatOS o que se haya convertido desde CatOS sobrescribe los valores tb predeterminados. Cuando intente crear cualquier VLAN después de esto, generará este mensaje de error:

VLAN 1002 TLB 1 VLAN 1 has inconsistent TLB values (0 / 0)

Como solución temporal para este problema, cambie los valores predeterminados tb del switch Cisco IOS para que VLAN 1, 1002 y 1003 coincidan con los valores de CatOS.

switch#vlan data
switch(vlan)#no vlan 1002 tb-vlan1 tb-vlan2
switch(vlan)#no vlan 1003 tb-vlan1 tb-vlan2
switch(vlan)#apply
APPLY completed.
switch(vlan)#exit
APPLY completed.Exiting....

Recuperación del Archivo vlan.dat en Switches IOS

Para los switches Cisco Catalyst que funcionan con Cisco IOS Software, la información de VLAN se encuentra en un archivo distinto denominado vlan.dat. Si el archivo vlan.dat se elimina accidentalmente y el switch se recarga, se pierden todas las VLAN que estuvieran disponibles en el switch. Hasta que se recargue el switch, la información de VLAN está presente en el switch.

Completar estos pasos para recuperar el archivo vlan.dat:

  1. Ejecute el comando show vlan para confirmar la disponibilidad de la información de VLAN.

    Switch#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                    Fa0/10, Fa0/11, Fa0/12, Gi0/1
                                                    Gi0/2
    10   VLAN0010                         active
    11   VLAN0011                         active
    20   VLAN0020                         active
    21   VLAN0021                         active
    30   VLAN0030                         active
    31   VLAN0031                         active
    40   VLAN0040                         active
    41   VLAN0041                         active
    50   Vlan50                           active
    100  100thVLAN                        active
  2. Si el switch está en el servidor VTP o en el modo transparente, haga cualquier modificación en la base de datos de VLAN.

    Las modificaciones en la base de datos de VLAN pueden ser cualquiera de estas:

    • Crear cualquier VLAN.

    • Remover cualquier VLAN.

    • Modificar las propiedades de cualquier VLAN existente.

    Si el switch está en el modo Cliente de VTP, haga modificaciones en la base de datos de VLAN en cualquier servidor VTP del mismo dominio.

    Switch#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#vlan 50
    
    Switch(config-vlan)#name 50thVLAN
    
    Switch(config-vlan)#end
    Switch#

    Una vez hecho cualquier cambio en la base de datos de VLAN, el switch creará automáticamente el archivo vlan.dat.

  3. Ejecute el comando show flash: para verificar la creación del archivo vlan.dat.

    Switch#show flash:
    
    Directory of flash:/
    
        2  -rwx           5   Mar 01 1993 00:04:47  private-config.text
        3  -rwx     2980487   Mar 02 1993 06:08:14  c2950-i6q4l2-mz.121-19.EA1a.bin
        4  -rwx        1156   Mar 01 1993 01:51:27  vlan.dat
       16  -rwx        1014   Mar 01 1993 00:04:47  config.text
        6  drwx        4096   Mar 02 1993 03:49:26  html
        7  -rwx     3121383   Mar 02 1993 03:47:52  c2950-i6q4l2-mz.121-22.EA9.bin
    
    7741440 bytes total (65536 bytes free)

No se Pudo Crear VLAN en Rango Extendido

Error 1

% Failed to create VLANs [dec]
VLAN(s) not available in Port Manager.

Los puertos LAN de Capa 3, interfaces y subinterfaces WAN, y algunas funciones del software, tales como RSPAN, usan VLAN internas en el rango extendido. No puede utilizar una VLAN de rango extendido que esté asignada para uso interno.

Para mostrar las VLAN usadas internamente, ejecute el comando show vlan internal usage. Puede configurar la asignación de VLAN interna ascendente (a partir de 1006 y hacia arriba) o la asignación de VLAN interna descendente (a partir del 4094 y hacia abajo).

Switch(config)#vlan internal allocation policy {ascending | descending}


!--- Enter the ascending keyword to allocate internal VLANs from 1006 and up. 
!--- Enter the descending keyword to allocate internal VLAN from 4094 and down.

Switch(config)#end 
Switch#reload

precaución Precaución: No es necesario ejecutar el comando reload inmediatamente. Ejecute el comando reload durante una ventana de mantenimiento planeado. La política de asignación de VLAN interna solo se aplica después de una recarga.

Si la recarga del dispositivo no es una opción, como solución temporal puede utilizar la traducción de VLAN. En los puertos trunk, puede traducir un número de VLAN a otro número de VLAN, lo que transfiere todo el tráfico recibido en una VLAN a la otra VLAN. Refiérase a la sección de la Configuración de la Traducción de VLAN de Configuración de VLAN para obtener más información.

Nota: Los switches que funcionan con el software de la familia de productos Catalyst no soportan la configuración de las VLAN 1006-1024. Si configura las VLAN 1006-1024, asegúrese de que las VLAN no se extiendan a ningún switch que funcione con el software de la familia de productos Catalyst.

Error 2

%Failed to commit extended VLAN(s) changes

Puede que reciba este mensaje cuando esté intentando crear VLAN Extendidas en el modo Servidor o Cliente de VTP.

Asegúrese de que el dispositivo (Switch o Router) esté en el modo Transparente cuando cree VLAN de rango extendido. Refiérase a la sección Pautas del Protocolo de Trunking de VLAN de ID de LAN Extendida para obtener más información.

No se Pudo Configurar la VLAN desde la Configuración de Inicio

SW-VLAN-4-BAD-STARTUP-VLAN-CONFIG-FILE: Failed to configure VLAN from 
startup-config. Fallback to use VLAN configuration file from non-volatile memory

Este mensaje indica que el software VLAN no pudo utilizar la configuración de VLAN del archivo de configuración de inicio. La configuración de VLAN se almacena en el archivo vlan.dat. El archivo vlan.dat reside en memoria no volátil. Cuando se sustituye el módulo Supervisor, vlan.dat está vacío (0). En la función de arranque, el switch compara el nombre de dominio y el modo VTP del archivo de configuración inicial y del archivo vlan.dat. Si los valores no coinciden, el switch utiliza la configuración del archivo vlan.dat.

Para realizar una copia de seguridad completa de su configuración, el archivo vlan.dat se debe incluir en la copia de seguridad con la configuración. El administrador de la red debe subir tanto el archivo vlan.dat como el archivo de configuración para restablecer la configuración completa.

Copia de Seguridad y Restauración de vlan.dat en Cisco IOS Switches

Para hacer una copia de seguridad de vlan.dat, complete este paso:

Copie el archivo vlan.dat de la NVRAM del dispositivo a un servidor TFTP o a una tarjeta PCMCIA externa.

copy const_nvram:vlan.dat tftp:

Nota: La ubicación de memoria donde se almacena el archivo vlan.dat varía de dispositivo a dispositivo. En Cisco Catalyst 6500/6000 Series Switches, es const_nvram:. De manera similar para Catalyst 4500/4000 Switches, es cat4000_flash:. Refiera a la documentación de producto respectivo antes de publicar el copycommand.

Para restaurar el archivo vlan.dat, complete estos pasos:

  1. Copie el archivo vlan.dat en la NVRAM del dispositivo desde un servidor TFTP o una tarjeta PCMCIA externa.

    copy tftp: const_nvram:
  2. Recargue el switch, puesto que vlan.dat es de solo lectura durante el proceso de arranque.

La Creación de VLAN Falla con el Mensaje de Error VLAN 1003 parent VLAN missing

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 102
Switch(config-vlan)#name marketing
Switch(config-vlan)#exit
VLAN 1003 parent VLAN missing
APPLY VLAN changes failed.
Switch(config)#end
Switch#

Un configuración incorrecta en un switch puede provocar que fallen las actualizaciones de la configuración de VTP. En la mayoría de los casos, el problema es que la nueva VLAN creada en el switch del servidor VTP no se propaga a los switches clientes de VTP, lo que crea problemas de conectividad del host.

Una causa común para este problema es una discordancia en la versión de VTP entre los switches de un dominio VTP. La versión de VTP 1 y la versión de VTP 2 no son interoperables en los dispositivos de red del mismo dominio VTP. Un dispositivo de red con capacidad VTP versión 2 puede funcionar con un dispositivo de red que funcione con la versión 1 de VTP, a condición de que la versión 2 de VTP se inhabilite en el dispositivo de red con capacidad VTP versión 2. La versión 2 de VTP está inhabilitada de forma predeterminada. Cada dispositivo de red del dominio VTP debe utilizar la misma versión de VTP. Verifique la versión de VTP que se ejecuta en un switch. Si está habilitada la versión 2 de VTP, inhabilítela para resolver este problema.

Verifique si el switch está configurado correctamente para otros parámetros de VTP:

  • Verifique que los switches estén conectados a través de los enlaces trunk, porque las actualizaciones VTP se intercambian solamente a través de enlaces trunk.

  • Verifique que el nombre de dominio VTP sea exactamente el mismo en los switches apropiados. El nombre distingue entre mayúsculas y minúsculas. Las actualizaciones de VTP se intercambian solamente entre switches del mismo dominio VTP.

  • Verifique que la contraseña de VTP sea exactamente la misma en todos los switches del dominio. La contraseña distingue entre mayúsculas y minúsculas. Si se configura una contraseña, debe configurarse en todos los switches del dominio y la contraseña debe ser la misma.

En caso de un problema de convergencia de VTP, donde un cliente VTP no actualice la información de VLAN, la solución temporal es forzar una convergencia de VTP mediante la creación y, a continuación, la remoción de una VLAN simulada en el servidor VTP. Esto incrementa el número de revisión y fuerza a todos los clientes VTP a actualizar sus bases de datos de VLAN.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 10023