Marcado y acceso remotos : Conexiones asíncronas

PPP de link múltiple asíncrono de router a router

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Esta configuración describe un Cisco 3640 remoto con una tarjeta de módem analógico de 8 puertos interna (NM-8AM) marcando hacia un Cisco AS5300 con una Interfaz de velocidad primaria (PRI). La configuración describe una conexión de links múltiples compuesta de dos líneas telefónicas analógicas en el sitio remoto. Si están disponibles, se pueden configurar más líneas de teléfono para MP.

prerrequisitos

Requisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Un Cisco 3640 que funciona con el Cisco IOS Software Release 12.1(3)

  • Un Cisco AS5300 que funciona con el Cisco IOS Software Release 12.07(T)

Nota: El MP primero fue introducido en el Cisco IOS Software Release 11.0(3).

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Teoría Precedente

El (MP) PPP de links múltiples permite a los dispositivos enviar datos por múltiples links de datos punto a punto al mismo destino con la implementación de un link virtual. La conexión de MP posee un ancho de banda máximo equivalente a la suma de los anchos de banda de los links componentes. MP puede ser configurado para links de multiplexión, por ejemplo, ISDN y Frame Relay o para varias líneas asíncronas. Refiera al RFC 1990leavingcisco.com para más información sobre el MP.

Nota: El RFC 1990 refiere al Multilink PPP como MP. Otros nombres con los que se conoce a MP incluyen MPPP, MPL y Multilink.

El MP asincrónico se puede utilizar para conectar a los clientes remotos a una mayor velocidad que disponible a través de una sola conexión analógica. En el MP asincrónico, el cliente remoto utiliza los módems múltiples, y por lo tanto las líneas de teléfono múltiple, para marcar adentro al router central y para acceder la red. Dado que múltiples líneas telefónicas suelen ser más baratas que un servicio de Interfaz de velocidad básica (BRI), Async MP brinda un modo efectivo de acelerar la velocidad de conexión para usuarios remotos a la vez que mantiene el control sobre los costos. MP asincrónico también es un modo efectivo de obtener velocidades de acceso más altas para las áreas remotas que no pueden ser atendidas por ISDN.

El MP asíncrono agrupa conexiones de módems separados hacia un servidor de acceso. El software PPP de cada par fracciona los paquetes y luego transmite las piezas al otro lado a través de conexiones analógicas múltiples. El extremo receptor recopila estas partes de las conexiones separadas y, sobre la base de información MP incorporada en ellas, reensambla las partes en paquetes de datos válidos y así proporciona un link virtual de extremo a extremo con mayor ancho de banda. El MP asincrónico se puede configurar entre dos routers o entre un router y una PC cliente.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la herramienta Command Lookup.

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/9585/router2router.gif

Configuraciones

Este documento usa las configuraciones detalladas a continuación.

Cisco 3640
clearlake-lan-01#show runnning-config
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
!
hostname clearlake-lan-01
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default if-needed local
!
username bobslake-nas-01 password <deleted>

!--- Remote router and password for CHAP authentication.
!--- Dialer interface must also be configured to use 
!--- this username and password.

username admin privilege 15 password <deleted>
!         
no ip domain-lookup
!
chat-script async-mppp ABORT ERROR ABORT BUSY 
"" "ATZ" OK "ATDT \T" TIMEOUT 30 CONNECT \c

!--- Chat script used for dialing out.

!
interface Loopback0
 ip address 172.21.126.254 255.255.255.0
!
interface Ethernet0/0
 ip address 172.21.125.1 255.255.255.0
!
interface Group-Async1

!--- Interface to configure modems used for dialout.

 no ip address
 encapsulation ppp

!--- Use PPP encapsulation for members of this 
!--- group-async interface.

 dialer in-band

!--- Permit DDR on this interface.

 dialer pool-member 10

!--- All members of this group-async interface belong 
!--- to dialer pool 10.

 ppp multilink

!--- Enable PPP multilink on physical interface.

 group-range 33 34

!--- Assign async 33 and 34 to this group-async interface.
!--- This can be adjusted depending on the number of POTS lines available.

! 
 interface Dialer1

!--- Dialer interface to dialout to bobslake-nas-01.

 ip address negotiated

!--- Obtain an IP address from central site.

 encapsulation ppp
 dialer remote-name bobslake-nas-01

!--- Identify central site router for CHAP authentication.
!--- Shared secret password is defined above.

 dialer pool 10

!--- Defines the pool of physical resources that the Dialer 
!--- interface may use.

 dialer idle-timeout 600

!--- Specifies number of seconds without interesting traffic that 
!--- the connection is kept up.

 dialer string 5551212

!--- Number to be dialed; this number belongs to the PRI 
!--- of the central router.

 dialer load-threshold 15 either

!--- Load level for either inbound or outbound traffic 
!--- at which additional lines will be added to the MP bundle.
!--- Load level values range from 1 (unloaded) to 255 (fully loaded).

 dialer-group 8

!--- Uses dialer-list 8 to determine interesting traffic.

 ppp authentication chap callin

!--- Use CHAP authentication for incoming calls only
!--- This router will not challenge remote routers for outgoing calls.

 ppp multilink

!--- Activates the interface for MP operation.

 ppp timeout multilink link remove 300

!--- Keeps the multilink connections up for 300 seconds 
!--- after the load drops below the threshold.
!--- This command should be used to control flapping.

!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1

!--- Use Interface Dialer1 for all networks.

no ip http server
!
access-list 188 remark define interesting traffic
access-list 188 deny   udp any any eq ntp
access-list 188 permit ip any any
dialer-list 8 protocol ip list 188

!--- Assign access-list 188 to dialer-list 8.  

!
line con 0
 transport input none
line 33 34

!--- Async lines to be used for dialout. 
!--- This number should match the group-range in the 
!--- Group-Async interface.

 script dialer async-mppp

!--- Use chat script called async-mppp for dialout.

 modem InOut
 modem autoconfigure discovery
 transport preferred none
 transport input all
line 35 40
 transport preferred none
 transport input all
line aux 0
line vty 0 4
!
ntp clock-period 17179871
ntp server 172.22.255.1 prefer
end

AS5300 de Cisco
bobslake-nas-01#show running-config 

Building configuration...

Current configuration:
  
version 12.0
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service tcp-small-servers
!
hostname bobslake-nas-01
!
logging buffered 10000 debugging
aaa new-model
aaa authentication login default local
aaa authentication ppp default if-needed local

!--- Authenticate for PPP if not authenticated during login.
!--- Allows users with Terminal Window after Dial to initiate PPP.

!
username clearlake-lan-01 password <deleted>

!--- Remote router and password for Challenge Handshake 
!--- Authentication Protocol (CHAP) authentication.
!--- The password must be identical on both sides.

spe 1/0 1/7
firmware location system:/ucode/mica_port_firmware
!
resource-pool disable
!
ip subnet-zero
!
multilink virtual-template 1

!--- Use virtual-template 1 for multilink connections.

isdn switch-type primary-5ess
isdn voice-call-failure 0
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
 interface Loopback0
  ip address 172.21.10.10 255.255.255.255
  no ip directed-broadcast
!
interface Loopback1
 ip address 172.21.104.254 255.255.255.0

!--- Summarizes addresses in address pool. 
!--- Loopback 1 is in the same subnet as the address pool.

 no ip directed-broadcast
!
 interface Virtual-Template1
 description Template for Multilink Users
 ip unnumbered Loopback0 
 no ip directed-broadcast
 peer default ip address pool addr-pool

!--- Use IP pool called addr-pool for incoming calls.

 ppp authentication chap

!--- Authenticate using CHAP.

 ppp multilink

!--- Allow multilink sessions.

!

!--- Configure D channel on PRI.

interface Serial0:23
 description Headquarters 555-1212 active PRI line
 no ip address
 no ip directed-broadcast
 isdn switch-type primary-5ess
 isdn incoming-voice mode
 fair-queue 64 256 0
 no cdp enable
!
interface FastEthernet0
 ip address 172.21.101.23 255.255.255.0
 no ip directed-broadcast
 duplex auto
 speed auto
!
interface Group-Async1
 ip unnumbered Loopback0
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 600 either

!--- Specifies number of seconds without interesting 
!--- traffic that the connection is kept up.
!--- Configure the same idle-timeout on both routers.

 dialer map ip 172.21.125.1 name clearlake-nas-01
 dialer-group 5

!--- Uses dialer-list 5 to determine interesting traffic.

 async mode interactive
 peer default ip address pool addr-pool

!--- Use IP pool called addr-pool for incoming calls.

 ppp authentication chap callin

!--- Issue CHAP challenges for dialin users only.  

ppp multilink
 group-range 1 48

!--- Assign modems 1-48 to the Group-Async 1 configuration template.

! 
 router eigrp 1
 passive-interface Group-Async1

!--- To prevent routing traffic on async lines. 

 network 172.21.0.0
!
ip local pool addr-pool 172.21.104.1 172.21.104.48

!--- Define IP address pool range for dialin clients.
 
ip classless
no ip http server
!
access-list 105 permit ip any any

!--- Define interesting traffic.

dialer-list 5 protocol ip list 105

!--- Assign access list 105 to dialer list 5.

!
line con 0
 transport input none
line 1 48
 autoselect during-login

!--- Permits user login prompts after dialin.

 autoselect ppp

!--- Automatically launches PPP on the line.

 modem InOut

!--- Modems can be used to dialin and dialout.

 transport preferred none
 transport output telnet
line aux 0
line vty 0 4
!
ntp clock-period 17180374
ntp update-calendar
ntp server 172.22.255.1 prefer
end

Ajuste y comandos opcionales

Los siguientes comandos pueden utilizarse para ajustar el comportamiento de la conexión MP. El ajuste cuidadoso de tales parámetros puede ayudar a controlar los costos al evitar el uso excesivo e innecesario de los datos de los links.

  • dialer load-threshold load [saliente | entrante | ya sea]

    MP se puede configurar para que canales adicionales puedan aparecer de inmediato después de que se establezca el canal primario. Para poner este escenario, fije el valor del umbral de carga en el comando dialer load-thershold load a 1. en este caso, los canales adicionales se sacan a colación y continúan permaneciendo para arriba (es decir, no hacen flap). Si load-threshold se configura en cualquier otro valor, los canales múltiples podrían moverse, según la carga en el link. Si usted quiere tener canales adicionales agregados cuanto sea necesario, dependiendo del tráfico, fije el umbral de carga al valor apropiado entre 1 y 255. Por ejemplo, para que los canales adicionales suban en el 50 por ciento, el umbral se debe fijar a 128 (0.50*255). Al determinar el umbral, se debe considerar el tiempo de configuración para llamadas asincrónicas ya que los tiempos de configuración más prolongados quizás precisen umbrales menores.

    La carga puede calcularse según el tráfico saliente, entrante o el tráfico entrante o saliente mayor en la interfaz. Si basa la carga en el entrante o en cualquier otro, asegúrese de que el sitio central tenga configurada una interfaz pasiva de Group-async1 para que las actualizaciones del ruteo del núcleo no se envíen a través de la línea asíncrona. Al evitar que el tráfico de ruteo pase por el link, se proporciona más ancho de banda a otros datos en la línea.

  • ppp timeout multilink link remove seconds

    Es posible que este comando sea utilizado para evitar el “flapping” en las conexiones de links múltiples cuando varía la carga. Por ejemplo, cuando el umbral de carga está configurado en 15 (es decir, 15/255=6%) y el tráfico excede ese umbral, las líneas adicionales aparecen arriba. Cuando el tráfico desciende el umbral, se suprimen las líneas adicionales. En los casos donde la velocidad de los datos varía mucho, es beneficioso para los diferentes canales permanecer en funcionamiento por un periodo de tiempo aun cuando el umbral de la carga sea menor al valor especificado. Asigna este tiempo de espera multilink para que sea menor al especificado por el tiempo de espera inactivo del dialer que controla el tiempo de espera para todos los links.

  • ppp timeout multilink link add seconds

    Este comando se puede utilizar para evitar que se añadan múltiples links al conjunto MP hasta que se reciba un tráfico elevado durante un intervalo especificado. Esto puede evitar que las ráfagas de tráfico activen innecesariamente líneas adicionales.

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

Los ciertos comandos show son soportados por la herramienta del Output Interpreter, que permite que usted vea una análisis de la salida del comando show.

  • show ppp multilink, para mostrar información sobre paquetes multienlace no activados. Este comando debería utilizarse para verificar la conexión de links múltiples.

  • show caller – Para mostrar información sobre usuarios individuales y recursos consumidos en NAS. Este comando muestra las estadísticas de llamadas activas para grandes agrupaciones de conexiones y los tiempos absolutos e inactivos por usuario. Si su versión del software del IOS de Cisco no es compatible con este comando, utilice el comando show user.

  • show caller user – Para mostrar los parámetros del usuario específico, tales como el tipo de línea TTY empleada, la interfaz asíncrona (estante/ranura/puerto), el número de canal DS0, el número de módem, la dirección de IP asignada, los parámetros de PPP y los parámetros de agrupamiento de PPP, entre otros. Si su versión del software del IOS de Cisco no es compatible con este comando, utilice el comando show user.

Ejemplo de resultado del comando show

Las salidas del comando showes siguientes se toman del Cisco 3640 que está marcando en el AS5300. Muestra que la conexión de links múltiples está para arriba

clearlake-lan-01#show ppp multilink
Virtual-Access1, bundle name is bobslake-nas-01

!--- Virtualized MP bundle. Bundle name is derived from the 
!--- username used during authentication.

  Dialer interface is Dialer1

!--- This Virtual Access Interface used Interface Dialer1.

  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x4 received sequence, 0x0 sent sequence
  Member links: 2 (max not set, min not set)
    Async34
    Async33

!--- Members of the MP bundle.


clearlake-lan-01#show dialer


As33 - dialer type = IN-BAND ASYNC NO-PARITY
Dialer pool 10, priority 0

!--- Member of dialer pool 10.

Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is multilink member
Dial reason: Multilink bundle overloaded

!--- Interface was not the first link in the MP bundle. 

Interface bound to profile Di1
Current call connected 00:00:54

!--- Current call duration

Connected to <deleted>5551212 (bobslake-nas-01) 

!--- Phone number that was dialed.


As34 - dialer type = IN-BAND ASYNC NO-PARITY
Dialer pool 10, priority 0

!--- Member of dialer pool 10.

Idle timer (600 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is multilink member
Dial reason: ip (s=172.21.125.1, d=172.21.104.254)

!--- Interface was the first link in the bundle, triggered by 
!--- interesting traffic.

Interface bound to profile Di1
Current call connected 00:00:54

!--- Current Call duration.

Connected to 5551212 <deleted> (bobslake-nas-01)

!--- Phone number that was dialed.


Gr1 - dialer type = IN-BAND ASYNC NO-PARITY
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle


Dial String      Successes   Failures    Last DNIS   Last status

Di1 - dialer type = DIALER PROFILE
Load threshold for dialing additional calls is 15

!--- Load threshold.

Idle timer (600 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Number of active calls = 2

Dial String      Successes   Failures    Last DNIS   Last status
            15          0    00:00:56       successful   Default
clearlake-lan-01#show caller
                                                Active    Idle
  Line         User               Service       Time      Time
  con 0        tarpon             TTY           00:09:11  00:00:00  
  tty 33       -                  Async         -         00:00:01  
  TTY 34       -                  Async         -         00:00:06  
  As33         bobslake-nas-01    PPP           00:00:24  00:00:00  

!--- Second connection.

  As34         bobslake-nas-01    PPP           00:01:05  00:00:00  

!--- First connection. 

  Vi1          bobslake-nas-01    PPP   Bundle  00:01:05  00:01:04  

!--- MP bundle
!--- bobslake-nas-01 has two async lines, two TTY, and one virtual 
!--- interface bundle.


clearlake-lan-01#show caller user bobslake-nas-01

  User: bobslake-nas-01, line As33, service PPP

!--- PPP setting for bobslake-nas-01.

        Active time 00:00:34, Idle time 00:00:00
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, CHAP (-> AAA)

!--- Multilink is up.

  Dialer: Connected 00:01:09 to <deleted>, outbound

!--- Dialer interface was used to dialout.

          Type is IN-BAND ASYNC, group Dialer1
          Cause: Multilink bundle overloaded

!--- This interface was not the first member of the MP bundle.

  IP: Local 172.21.104.48/32
  Bundle: Member of bobslake-nas-01, last input 00:00:00
  Counts: 59 packets input, 3529 bytes, 0 no buffer
          0 input errors, 22 CRC, 0 frame, 0 overrun
          31 packets output, 1515 bytes, 0 underruns
          0 output errors, 0 collisions, 4 interface resets

!--- Packets are passing through the connection.


  User: bobslake-nas-01, line As34, service PPP

!--- PPP setting for user bobslake-nas-01.

        Active time 00:01:15, Idle time 00:00:00
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, CHAP (-> AAA)

!--- MP state is open.

  Dialer: Connected 00:01:10 to <deleted>, outbound
          Type is IN-BAND ASYNC, group Dialer1
          Cause: ip (s=172.21.125.1, d=172.21.104.254)

!--- Dialing cause was interesting traffic; this was the 
!--- first link in the bundle.

  IP: Local 172.21.104.48/32
  Bundle: Member of bobslake-nas-01, last input 00:00:00
  Counts: 172 packets input, 20699 bytes, 0 no buffer
          0 input errors, 81 CRC, 0 frame, 0 overrun
          80 packets output, 14347 bytes, 0 underruns
          0 output errors, 0 collisions, 6 interface resets

!--- Packets are passing through the connection.


  User: bobslake-nas-01, line Vi1, service PPP Bundle

!--- Bundle information for user bobslake-nas-01.

        Active time 00:01:16, Idle time 00:01:15
  Timeouts:            Absolute  Idle
      Limits:          -         00:10:00  
      Disconnect in:   -         00:08:44  

!--- Idle-timeout is 600 seconds(10 minutes).

  PPP: LCP Open, multilink Open, IPCP
  Dialer: Connected 00:01:10 to <deleted>, outbound
          Idle timer 600 secs, idle 75 secs
          Type is IN-BAND SYNC, group Dialer1
  IP: Local 172.21.104.48/32, remote 172.21.104.254

!--- IP address assigned to the bundle and loopback address 
!--- of the remote router.

  Bundle: First link of bobslake-nas-01, 2 links, last input 00:01:16
  Counts: 23 packets input, 4758 bytes, 0 no buffer
          0 input errors, 0 CRC, 0 frame, 0 overrun
          7 packets output, 3734 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

Algunas salidas del comando showes del AS5300 se muestran abajo. Para más salidas refiera al marcado PPP multilink asíncrono del documento de la documentación de clientes de Microsoft Windows. La demostración y la salida de los debugs del AS5300 (sitio central) serán similares para el MP asincrónico del PC-router y el MP asincrónico del Router-router.

bobslake-nas-01#show ppp multilink

Virtual-Access1, bundle name is clearlake-lan-01
  0 lost fragments, 0 reordered, 0 unassigned, sequence 0x1/0x10 rcvd/sent
  0 discarded, 0 lost received, 1/255 load
  Member links: 2 (max not set, min not set)
    Async47
    Async45

bobslake-nas-01#show caller
                                                Active    Idle
  Line         User               Service       Time      Time
  TTY 45       clearlake-lan-01   Async         00:01:12  00:01:03  
  TTY 47       clearlake-lan-01   Async         00:01:51  00:00:06  
  vty 0        admin              VTY           00:11:02  00:00:00  
  As45         clearlake-lan-01   PPP           00:01:02  00:00:00  
  As47         clearlake-lan-01   PPP           00:01:49  00:00:00  
  Vi1          clearlake-lan-01   PPP   Bundle  00:01:43  00:01:10  

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Procedimiento de Troubleshooting

Al localizar averías una conexión MP, proceda de manera semejante los ingresos de la llamada:

Un ejemplo de salida del debug, marcado con las explicaciones en qué buscar, se proporciona abajo.

Al probar su configuración MP, asegúrese de que usted está generando bastante tráfico a través del link para accionar el umbral de carga. Usted puede ajustar el valor del umbral de carga durante su prueba cuanto sea necesario.

  1. Utilice los comandos debug dialer and debug chat de verificar que el marcador está marcando correctamente.

  2. Verifique que la negociación PPP y la autenticación sea acertadas. Preste la atención a la negociación LCP donde los parámetros MP alinean el Maximum Receive Reconstructed Unit (MRRU) y se negocia el discriminador de punto final (EndpointDisc).

  3. Verifique que el link esté virtualizado correctamente. Una interfaz de acceso virtual será creada por el Cisco IOS Software para representar el conjunto MP.

  4. Verifique que la negociación del Protocolo de control de Protocolo de Internet (IPCP) fuera acertada. Observe si los IP Addresses correctos fueron asignados y si las rutas apropiado fueron instaladas.

Comandos para resolución de problemas

Los ciertos comandos show son soportados por la herramienta del Output Interpreter, que permite que usted vea una análisis de la salida del comando show.

Nota: Antes de ejecutar un comando debug, consulte Información Importante sobre Comandos Debug.

  • debug vtemplate - Para visualizar una información de clonación para una interfaz de acceso virtual a partir del tiempo que se reproduce de una plantilla virtual al tiempo se toma abajo.

  • debug ppp multilink events – Para mostrar información acerca de eventos que afectan el agrupamiento de enlaces múltiples.

  • debug ppp negotiation – Para ver la información sobre los intercambios y el tráfico PPP mientras negocia el LCP (Protocolo de control de link), la autenticación y el NCP (Protocolo de control de red). Una negociación PPP exitosa abrirá primero el estado LCP, luego realizará la autenticación y por último negociará el NCP. Los parámetros de links múltiples como el Maximum Receive Reconstructed Unit (MRRU) se establecen durante la negociación LCP (protocolo de control de links)

  • debug ppp authentication – Permite mostrar los mensajes del protocolo de autenticación PPP, entre ellos el intercambio de paquetes del Protocolo de confirmación de aceptación de la autenticación (CHAP) y los intercambios de protocolo de autenticación de contraseña (PAP).

  • debug ppp error - Para visualizar los errores del protocolo y la estadística de errore se asoció a la negociación y a la operación de la conexión PPP.

  • debug modem - Para mostrar la actividad de línea del módem en un Servidor de acceso.

Ejemplo de resultado del comando debug

Los productos siguientes fueron obtenidos del Cisco 3640. Muestran el Cisco 3640 que marca el PRI del AS5300 y que establece una conexión MP. Por un ejemplo de la salida de los debugs del AS5300 refiera al marcado PPP multilink asíncrono del documento de los clientes de Microsoft Windows.

clearlake-lan-01#debug dialer
Dial on demand events debugging is on
clearlake-lan-01#debug ppp negotiation
PPP protocol negotiation debugging is on
clearlake-lan-01#debug ppp authentication 
PPP authentication debugging is on
clearlake-lan-01#debug vtemplate 
Virtual Template debugging is on
clearlake-lan-01#debug ppp multilink events
clearlake-lan-01#show debug
Dial on demand:
  Dial on demand events debugging is on
PPP:
  PPP authentication debugging is on
  PPP protocol negotiation debugging is on
  Multilink events debugging is on
VTEMPLATE:
  Virtual Template debugging is on
clearlake-lan-01#ping ip   
Target IP address: 172.21.104.254
Repeat count [5]: 20
Datagram size [100]: 1200
Timeout in seconds [2]: 
Extended commands [n]: 
Sweep range of sizes [n]: 
Type escape sequence to abort.
Sending 20, 1200-byte ICMP Echos to 172.21.104.254, timeout is 2 seconds:

Jul 25 13:20:29.047 UTC: As34 DDR: rotor dialout [priority]
Jul 25 13:20:29.047 UTC: As34 DDR: Dialing cause ip (s=172.21.125.1, 
d=172.21.104.254)

!--- Dialing Reason

Jul 25 13:20:29.047 UTC: As34 DDR: Attempting to dial <deleted>5551212

!--- Number being dialed

Jul 25 13:20:29.047 UTC: CHAT34: Attempting async line dialer script
Jul 25 13:20:29.047 UTC: CHAT34: Dialing using Modem script: 
async-mppp & System script: none

!--- Using chat script async-mppp for dialout

Jul 25 13:20:29.051 UTC: CHAT34: process started
Jul 25 13:20:29.051 UTC: CHAT34: Asserting DTR
Jul 25 13:20:29.051 UTC: CHAT34: Chat script async-mppp started

!--- Call is being established; 
!--- note the time elapsed for call setup

Jul 25 13:20:54.831 UTC: CHAT34: Chat script async-mppp finished, 
status = Success.
Jul 25 13:20:56.831 UTC: 
%LINK-3-UPDOWN: Interface Async34, changed state to up
Jul 25 13:20:56.831 UTC: 
Async34 DDR: Dialer statechange to up
Jul 25 13:20:56.831 UTC: 
%DIALER-6-BIND: Interface As34 bound to profile Di1
Jul 25 13:20:56.831 UTC: 
Async34 DDR: Dialer call has been placed

!--- PPP negotiation begins

Jul 25 13:20:56.831 UTC: As34 PPP: Treating connection as a callout
Jul 25 13:20:56.831 UTC: As34 PPP: Phase is ESTABLISHING, Active Open
Jul 25 13:20:56.831 UTC: As34 PPP: No remote authentication for call-out

!--- CHAP challenge is configured for callin only
!--- LCP negotiation begins; Multilink parameters are also negotiated

Jul 25 13:20:56.835 UTC: As34 LCP: O CONFREQ [Closed] id 43 len 43
Jul 25 13:20:56.835 UTC: As34 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:20:56.835 UTC: As34 LCP:    MagicNumber 0x4395638E (0x05064395638E)
Jul 25 13:20:56.835 UTC: As34 LCP:    PFC (0x0702)
Jul 25 13:20:56.835 UTC: As34 LCP:    ACFC (0x0802)
Jul 25 13:20:56.835 UTC: As34 LCP:    MRRU 1524 (0x110405F4)

!--- Negotiate Maximum Receive Reconstructed Unit (MRRU)
!--- MRRU is the maximum packet size this end will reconstruct

Jul 25 13:20:56.835 UTC: As34 LCP:    EndpointDisc 1 Local
Jul 25 13:20:56.835 UTC: As34 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:20:56.835 UTC: As34 LCP:     (0x2D3031).
Jul 25 13:20:58.831 UTC: As34 LCP: TIMEout: State REQsent
Jul 25 13:20:58.831 UTC: As34 LCP: O CONFREQ [REQsent] id 44 Len 43
Jul 25 13:20:58.831 UTC: As34 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:20:58.831 UTC: As34 LCP:    MagicNumber 0x4395638E (0x05064395638E)
Jul 25 13:20:58.831 UTC: As34 LCP:    PFC (0x0702)
Jul 25 13:20:58.831 UTC: As34 LCP:    ACFC (0x0802)
Jul 25 13:20:58.831 UTC: As34 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:20:58.831 UTC: As34 LCP:    EndpointDisc 1 Local
Jul 25 13:20:58.831 UTC: As34 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:20:58.831 UTC: As34 LCP:     (0x2D3031).
Jul 25 13:21:00.831 UTC: As34 LCP: TIMEout: State REQsent
Jul 25 13:21:00.831 UTC: As34 LCP: O CONFREQ [REQsent] id 45 Len 43
Jul 25 13:21:00.831 UTC: As34 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:00.831 UTC: As34 LCP:    MagicNumber 0x4395638E (0x05064395638E)
Jul 25 13:21:00.831 UTC: As34 LCP:    PFC (0x0702)
Jul 25 13:21:00.831 UTC: As34 LCP:    ACFC (0x0802)
Jul 25 13:21:00.831 UTC: As34 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:00.831 UTC: As34 LCP:    EndpointDisc 1 Local
Jul 25 13:21:00.831 UTC: As34 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:21:00.831 UTC: As34 LCP:     (0x2D3031)
Jul 25 13:21:01.135 UTC: As34 LCP: I CONFACK [REQsent] id 45 Len 43
Jul 25 13:21:01.135 UTC: As34 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:01.135 UTC: As34 LCP:    MagicNumber 0x4395638E (0x05064395638E)
Jul 25 13:21:01.135 UTC: As34 LCP:    PFC (0x0702)
Jul 25 13:21:01.135 UTC: As34 LCP:    ACFC (0x0802)
Jul 25 13:21:01.135 UTC: As34 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:01.135 UTC: As34 LCP:    EndpointDisc 1 Local
Jul 25 13:21:01.135 UTC: As34 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:21:01.135 UTC: As34 LCP:     (0x2D3031)
Jul 25 13:21:01.139 UTC: As34 LCP: I CONFREQ [ACKrcvd] id 6 Len 47
Jul 25 13:21:01.139 UTC: As34 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:01.143 UTC: As34 LCP:    AuthProto CHAP (0x0305C22305)
Jul 25 13:21:01.143 UTC: As34 LCP:    MagicNumber 0xE16DFC8D (0x0506E16DFC8D)
Jul 25 13:21:01.143 UTC: As34 LCP:    PFC (0x0702)
Jul 25 13:21:01.143 UTC: As34 LCP:    ACFC (0x0802)
Jul 25 13:21:01.143 UTC: As34 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:01.143 UTC: As34 LCP:    EndpointDisc 1 Local
Jul 25 13:21:01.143 UTC: As34 LCP:     (0x131201626F62736C616B652D6E61732D)
Jul 25 13:21:01.143 UTC: As34 LCP:     (0x3031)
Jul 25 13:21:01.143 UTC: As34 LCP: O CONFACK [ACKrcvd] id 6 Len 47
Jul 25 13:21:01.143 UTC: As34 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:01.143 UTC: As34 LCP:    AuthProto CHAP (0x0305C22305)
Jul 25 13:21:01.143 UTC: As34 LCP:    MagicNumber 0xE16DFC8D (0x0506E16DFC8D)
Jul 25 13:21:01.143 UTC: As34 LCP:    PFC (0x0702)
Jul 25 13:21:01.143 UTC: As34 LCP:    ACFC (0x0802)
Jul 25 13:21:01.143 UTC: As34 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:01.143 UTC: As34 LCP:    EndpointDisc 1 Local
Jul 25 13:21:01.143 UTC: As34 LCP:     (0x131201626F62736C616B652D6E61732D)
Jul 25 13:21:01.143 UTC: As34 LCP:     (0x3031)

!--- Both sides have CONFACKed the parameters 
!--- MRRU of 1524 bytes and the Endpoint Discriminator have been negotiated

Jul 25 13:21:01.143 UTC: As34 LCP: State is Open

!--- LCP negotiation complete

Jul 25 13:21:01.147 UTC: As34 PPP: Phase is AUTHENTICATING, by the peer

!--- Received a challenge from the remote router

Jul 25 13:21:01.351 UTC: As34 CHAP: I CHALLENGE id 3 Len 36 
from "bobslake-nas-01"
Jul 25 13:21:01.351 UTC: As34 CHAP: O RESPONSE id 3 Len 
Jul 25 13:21:01.539 UTC: As34 CHAP: I SUCCESS id 3 Len 4

!--- CHAP authentication successful

Jul 25 13:21:01.539 UTC: As34 PPP: Phase is VIRTUALIZED

!--- Virtualize Async 34 
!--- Virtual Access interface will represent the MP bundle

Jul 25 13:21:01.543 UTC: Vi1 VTEMPLATE: Reuse Vi1, recycle queue size 0
Jul 25 13:21:01.543 UTC: Vi1 VTEMPLATE: Hardware address 0030.9401.f101
Jul 25 13:21:01.543 UTC: Vi1 PPP: Phase is DOWN, Setup
Jul 25 13:21:01.543 UTC: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
Jul 25 13:21:01.543 UTC: Vi1 VTEMPLATE: Has a new cloneblk dialer, 
now it has dialer
Jul 25 13:21:01.547 UTC: %LINK-3-UPDOWN: Interface Virtual-Access1, 
changed state to up
Jul 25 13:21:01.547 UTC: Virtual-Access1 DDR: Dialer statechange to up

!--- Virtual Access Interface is up
!--- Negotiate LCP and PPP parameters for Virtual-Access Interface

Jul 25 13:21:01.547 UTC: Virtual-Access1 DDR: Dialer call has been placed
Jul 25 13:21:01.547 UTC: Vi1 PPP: Treating connection as a callout
Jul 25 13:21:01.547 UTC: Vi1 PPP: Phase is ESTABLISHING, Active Open
Jul 25 13:21:01.547 UTC: Vi1 PPP: No remote authentication for call-out
Jul 25 13:21:01.547 UTC: Vi1 LCP: O CONFREQ [Closed] id 1 Len 33
Jul 25 13:21:01.547 UTC: Vi1 LCP:    MagicNumber 0x439575FC (0x0506439575FC)
Jul 25 13:21:01.547 UTC: Vi1 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:01.551 UTC: Vi1 LCP:    EndpointDisc 1 Local
Jul 25 13:21:01.551 UTC: Vi1 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:21:01.551 UTC: Vi1 LCP:     (0x2D3031)
Jul 25 13:21:01.551 UTC: Vi1 PPP: Phase is UP
Jul 25 13:21:01.551 UTC: Vi1 IPCP: O CONFREQ [Closed] id 1 Len 10
Jul 25 13:21:01.551 UTC: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
Jul 25 13:21:01.551 UTC: 
As34 MLP: bobslake-nas-01, multilink up, first link

!--- First multilink connection is virtualized

Jul 25 13:21:01.651 UTC: Vi1 IPCP: I CONFREQ [REQsent] id 1 Len 10
Jul 25 13:21:01.651 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jul 25 13:21:01.651 UTC: Vi1 IPCP: O CONFACK [REQsent] id 1 Len 10
Jul 25 13:21:01.651 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jul 25 13:21:01.731 UTC: Vi1 IPCP: I CONFNAK [ACKsent] id 1 Len 10
Jul 25 13:21:01.731 UTC: Vi1 IPCP:    Address 172.21.104.48 (0x0306AC156830)
Jul 25 13:21:01.731 UTC: Vi1 IPCP: O CONFREQ [ACKsent] id 2 Len 10
Jul 25 13:21:01.731 UTC: Vi1 IPCP:    Address 172.21.104.48 (0x0306AC156830)
Jul 25 13:21:01.915 UTC: Vi1 IPCP: I CONFACK [ACKsent] id 2 Len 10
Jul 25 13:21:01.915 UTC: Vi1 IPCP:    Address 172.21.104.48 (0x0306AC156830)
Jul 25 13:21:01.915 UTC: Vi1 IPCP: State is Open
Jul 25 13:21:01.915 UTC: Di1 IPCP: Install negotiated IP interface 
address 172.21.104.48

!--- IP address is assigned to virtual-access interface

Jul 25 13:21:01.919 UTC: Vi1 DDR: dialer protocol up
Jul 25 13:21:01.919 UTC: Di1 IPCP: Install route to 172.21.104.254

!--- Route to loopback address of remote router

Jul 25 13:21:02.539 UTC: 
%LINEPROTO-5-UPDOWN: Line protocol on Interface Async34, 
changed state to up
Jul 25 13:21:02.551 UTC: 
%LINEPROTO-5-UPDOWN: Line protocol on Interface 
Virtual-Access1, changed state to up

!--- Full connectivity with first async connection
!--- Begin dialout using second async interface

Jul 25 13:21:08.191 UTC: As33 DDR: rotor dialout [priority]
Jul 25 13:21:08.191 UTC: 
As33 DDR: Attempting to dial <deleted>5551212

!--- Number to be dialed; this number is the PRI on the remote router

Jul 25 13:21:08.191 UTC: CHAT33: Attempting async line dialer script
Jul 25 13:21:08.191 UTC: CHAT33: Dialing using Modem script: 
async-mppp & System script: none

!--- Use chat script async-mppp for dialout

Jul 25 13:21:08.191 UTC: CHAT33: process started
Jul 25 13:21:08.191 UTC: CHAT33: Asserting DTR
Jul 25 13:21:08.191 UTC: CHAT33: Chat script async-mppp started
Jul 25 13:21:33.859 UTC: CHAT33: Chat script async-mppp finished, 
status = Success

!--- Chat script successful

Jul 25 13:21:35.859 UTC: %LINK-3-UPDOWN: Interface Async33, 
changed state to up
Jul 25 13:21:35.859 UTC: Async33 DDR: Dialer statechange to up
Jul 25 13:21:35.859 UTC: %DIALER-6-BIND: Interface As33 bound to 
profile Di1
Jul 25 13:21:35.859 UTC: Async33 DDR: Dialer call has been placed

!--- PPP negotiation begins

Jul 25 13:21:35.859 UTC: As33 PPP: Treating connection as a callout
Jul 25 13:21:35.859 UTC: As33 PPP: Phase is ESTABLISHING, Active Open
Jul 25 13:21:35.859 UTC: As33 PPP: No remote authentication for call-out

!--- CHAP challenge is configured for callin only
!--- LCP negotiation begins; Multilink parameters are also negotiated

Jul 25 13:21:35.863 UTC: As33 LCP: O CONFREQ [Closed] id 21 Len 43
Jul 25 13:21:35.863 UTC: As33 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:35.863 UTC: As33 LCP:    MagicNumber 0x4395FC05(0x05064395FC05)
Jul 25 13:21:35.863 UTC: As33 LCP:    PFC (0x0702)
Jul 25 13:21:35.863 UTC: As33 LCP:    ACFC (0x0802)
Jul 25 13:21:35.863 UTC: As33 LCP:    MRRU 1524 (0x110405F4)

!--- negotiate Maximum Receive Reconstructed Unit (MRRU)

Jul 25 13:21:35.863 UTC: As33 LCP:    EndpointDisc 1 Local
Jul 25 13:21:35.863 UTC: As33 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:21:35.863 UTC: As33 LCP:     (0x2D3031)
Jul 25 13:21:37.859 UTC: As33 LCP: TIMEout: State REQsent
Jul 25 13:21:37.859 UTC: As33 LCP: O CONFREQ [REQsent] id 22 Len 43
Jul 25 13:21:37.859 UTC: As33 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:37.859 UTC: As33 LCP:    MagicNumber 0x4395FC05 (0x05064395FC05)
Jul 25 13:21:37.859 UTC: As33 LCP:    PFC (0x0702)
Jul 25 13:21:37.859 UTC: As33 LCP:    ACFC (0x0802)
Jul 25 13:21:37.859 UTC: As33 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:37.859 UTC: As33 LCP:    EndpointDisc 1 Local
Jul 25 13:21:37.859 UTC: As33 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:21:37.859 UTC: As33 LCP:     (0x2D3031)
Jul 25 13:21:39.859 UTC: As33 LCP: TIMEout: State REQsent
Jul 25 13:21:39.859 UTC: As33 LCP: O CONFREQ [REQsent] id 23 Len 43
Jul 25 13:21:39.859 UTC: As33 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:39.859 UTC: As33 LCP:    MagicNumber 0x4395FC05 (0x05064395FC05)
Jul 25 13:21:39.859 UTC: As33 LCP:    PFC (0x0702)
Jul 25 13:21:39.859 UTC: As33 LCP:    ACFC (0x0802)
Jul 25 13:21:39.859 UTC: As33 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:39.859 UTC: As33 LCP:    EndpointDisc 1 Local
Jul 25 13:21:39.859 UTC: As33 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:21:39.859 UTC: As33 LCP:     (0x2D3031)
Jul 25 13:21:40.199 UTC: As33 LCP: I CONFREQ [REQsent] id 6 Len 47
Jul 25 13:21:40.199 UTC: As33 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:40.203 UTC: As33 LCP:    AuthProto CHAP (0x0305C22305)
Jul 25 13:21:40.203 UTC: As33 LCP:    MagicNumber 0xE16E950F (0x0506E16E950F)
Jul 25 13:21:40.203 UTC: As33 LCP:    PFC (0x0702)
Jul 25 13:21:40.203 UTC: As33 LCP:    ACFC (0x0802)
Jul 25 13:21:40.203 UTC: As33 LCP:    MRRU 1524 (0x110405F4)
Jul 25 13:21:40.203 UTC: As33 LCP:    EndpointDisc 1 Local
Jul 25 13:21:40.203 UTC: As33 LCP:     (0x131201626F62736C616B652D6E61732D)
Jul 25 13:21:40.203 UTC: As33 LCP:     (0x3031)
Jul 25 13:21:40.203 UTC: As33 LCP: O CONFACK [REQsent] id 6 Len 47

!--- PPP parameters are agreed on (CONFACKed) by both sides

Jul 25 13:21:40.203 UTC: As33 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:40.203 UTC: As33 LCP:    AuthProto CHAP (0x0305C22305)
Jul 25 13:21:40.203 UTC: As33 LCP:    MagicNumber 0xE16E950F (0x0506E16E950F)
Jul 25 13:21:40.203 UTC: As33 LCP:    PFC (0x0702)
Jul 25 13:21:40.203 UTC: As33 LCP:    ACFC (0x0802)
Jul 25 13:21:40.203 UTC: As33 LCP:    MRRU 1524 (0x110405F4)

!--- MRRU of 1524 bytes is accepted

Jul 25 13:21:40.203 UTC: As33 LCP:    EndpointDisc 1 Local
Jul 25 13:21:40.203 UTC: As33 LCP:     (0x131201626F62736C616B652D6E61732D)
Jul 25 13:21:40.203 UTC: As33 LCP:     (0x3031)
Jul 25 13:21:40.207 UTC: As33 LCP: I CONFACK [ACKsent] id 23 Len 43
!--- PPP parameters are agreed on (CONFACKed) by both sides
Jul 25 13:21:40.207 UTC: As33 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jul 25 13:21:40.207 UTC: As33 LCP:    MagicNumber 0x4395FC05 (0x05064395FC05)
Jul 25 13:21:40.207 UTC: As33 LCP:    PFC (0x0702)
Jul 25 13:21:40.207 UTC: As33 LCP:    ACFC (0x0802)
Jul 25 13:21:40.207 UTC: As33 LCP:    MRRU 1524 (0x110405F4)

!--- MRRU of 1524 bytes is accepted

Jul 25 13:21:40.207 UTC: As33 LCP:    EndpointDisc 1 Local
Jul 25 13:21:40.207 UTC: As33 LCP:     (0x131301636C6561726C616B652D6C616E)
Jul 25 13:21:40.207 UTC: As33 LCP:     (0x2D3031)

!--- LCP negotiation is complete

Jul 25 13:21:40.207 UTC: As33 LCP: State is Open
Jul 25 13:21:40.207 UTC: As33 PPP: Phase is AUTHENTICATING, by the peer

!--- CHAP authentication begins

Jul 25 13:21:40.419 UTC: As33 CHAP: I CHALLENGE id 3 Len 36 
from "bobslake-nas-01"

!--- Received challenge from bobslake-nas-01

Jul 25 13:21:40.423 UTC: As33 CHAP: O RESPONSE id 3 Len 37 
from "clearlake-lan-01"
Jul 25 13:21:42.528 UTC: As33 CHAP: I SUCCESS id 3 Len 4

!--- CHAP authentication is successful

Jul 25 13:21:42.528 UTC: As33 PPP: Phase is VIRTUALIZED

!--- Async 33 is added to Virtualized MP bundle

Jul 25 13:21:42.528 UTC: As33 MLP: bobslake-nas-01, multilink up

!--- Multilink connection is up

Jul 25 13:21:43.528 UTC: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Async33, 
changed state to up
clearlake-lan-01#
Jul 25 13:23:52.028 UTC: Vi1 MLP: Disabling particle-fastswitching 
in 'bobslake-nas-01'
Jul 25 13:23:52.028 UTC: Vi1 MLP: Enabling particle-fastswitching 
on 'bobslake-nas-01'

!--- Cisco IOS adjusting fast switching strategy to keep in step 
!--- with delivery of packet fragments

Jul 25 13:23:53.872 UTC: Vi1 MLP: Disabling particle-fastswitching 
in 'bobslake-nas-01'
Jul 25 13:23:53.884 UTC: Vi1 MLP: Enabling particle-fastswitching 
on 'bobslake-nas-01'

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 9585