Marcado y acceso remotos : "Red digital de servicios integrados (ISDN), Señalización por canal asociado (CAS)"

Configuración de NFAS con cuatro T1

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El Non-facility Associated Signaling ISDN (NFAS) permite que un solo canal D controle las interfaces múltiples de la velocidad primaria (PRI). Usted puede configurar un respaldo canal D cuando canal D primario NFAS falla. Cuando usted configura los reguladores canalizados T1 para ISDN PRI, usted necesita solamente configurar el NFAS primario canal D; su configuración se distribuye a todos los miembros del grupo asociado NFAS.

Usando un solo canal D a los PRI múltiples de control, un canal adicional en cada interfaz está libre de llevar el tráfico de datos. Cualquier falla de hardware del canal primario de la D-señalización da lugar a un Switchover inmediato al respaldo canal D sin la desconexión actualmente de los usuarios conectados.

Nota: Si usted configura un respaldo canal D, sólo 23 canales B se pueden utilizar en el respaldo controlador T1 porque canal D prendido el respaldo está inasequible. Por lo tanto, solamente eso T1s que es ni primario ni de reserva puede tener 24 canales B disponibles. En esta configuración, controlador T1 4/0 es el primario y tiene 23 canales B disponibles, y controlador T1 4/1 es el respaldo y tiene 23 canales B disponibles. T1 los reguladores 5/0 y 5/1 por cada uno tienen 24 canales B disponibles.

prerrequisitos

Requisitos

Los requisitos previos para el NFAS son como sigue:

  • El NFAS se soporta solamente con controlador T1 canalizado y, como consecuencia, los reguladores T1 se deben también configurar para ISDN PRI antes de implementar el NFAS. Para más información sobre configurar el ISDN, refiera a la página del soporte ISDN.

  • El router configurado para el NFAS debe conectar con un 4ess, dms250, dms100, o un tipo de switch de ISDN nacional.

    Nota: El NFAS no se soporta en el Switches del tipo del 5ess primario. Consulte su proveedor de servicio o compañía telefónica para determinar si el NFAS se puede configurar para su línea T1.

  • El NFAS se debe configurar en su switch ISDN del Telco's.

  • Usted debe utilizar el Software Release 11.3T o Posterior de Cisco IOS�.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • La configuración siguiente fue probada con un Cisco IOS Software Release 12.0(5) corriente del Cisco 7507 Router.

  • Esta configuración ilustra cómo configurar a cuatro Miembros de NFAS dentro del mismo grupo. La interfaz primaria NFAS es T1 4/0, y el respaldo es T1 4/1. T1 los reguladores 5/0 y 5/1 tienen 24 canales B disponibles para ellos

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Antecedentes

Terminología NFAS

Los términos de uso general NFAS son como sigue:

  • NFAS - Un servicio ISDN que permite un solo canal D a los PRI múltiples de control. Usando un solo canal D a los PRI múltiples de control permite que un canal B en cada interfaz lleve el otro tráfico.

  • 24 interfaces del canal B - Un grupo de canal PRI configurado para no tener ningún NFAS canal D; todos los 24 canales son canales B. Este T1 determinado utiliza canal D configurado en el controlador primario para señalar.

  • El agrupar de canal del Group-a PRI NFAS (el grupo de interfaces) bajo el control de un solo canal D. El grupo de canal puede incluir todos los canales ISDN en los reguladores múltiples T1.

    Nota: El NFAS se puede configurar con los miembros en diversos slots en el router (por ejemplo, no restringen a los Miembros de NFAS a estar en el mismo slot o módulo). También, dentro de un chasis único, soportan a cinco grupos NFAS. En caso de que el T1s de los varios proveedores se utilice, el proveedor los agrupan a menudo.

  • Miembro de NFAS - Un PRI en un grupo NFAS. Por ejemplo, un grupo NFAS pudo incluir las interfaces seriales 1/0:23, 1/1:23, y 2/0:23 si T1 los reguladores 1/0, 1/1, y 2/0 se configuran en un grupo NFAS. Para visualizar a los miembros de todo el NFAS agrupe, utilice el comando show isdn nfas group privileged exec.

Comando necesario

Nota: Los comandos de configuración de PRI normales ISDN no aparecen en este documento. Vea la sección de información relacionada para más información sobre configurar ISDN PRI.

group_number del nfas_group del int_number del nfas_interface de la función del nfas_d del pri-group timeslots 1-24

Esto comando controller configuration asigna controlador T1 al grupo NFAS y señala su función dentro del grupo. Especifique los valores siguientes como apropiados:

  • función - La función que se realizará por el intervalo de tiempo 24, primario, de reserva, o el ninguno. Cada grupo NFAS debe tener uno primario. El router no requiere un respaldo, no obstante la mayoría de las implementaciones de NFAS tienen un respaldo canal D. Entre en contacto su compañía telefónica para determinar si usted debe configurar un respaldo canal D para su grupo NFAS. El resto de los reguladores se puede configurar con ninguno, que señala el 24to intervalo de tiempo como canal B.

    Nota: Configure los canales primarios y de reserva D exactamente según lo especificado por su compañía telefónica. Un error común con una configuración de NFAS desginating incorrectamente qué T1 es el primario y cuál es el respaldo.

  • int_number - Un valor asignado por el proveedor de servicio y usado para identificar únicamente el PRI. El rango posible de los valores a partir de la 0 al T1 más alto disponible en el router, menos uno. Por ejemplo, si el router tiene 10 T1s el número de la interfaz NFAS puede extenderse entre 0 y 9. Las 0 interfaces se deben asignar al primario canal D y a la 1 interfaz al respaldo canal D.

    Nota: En ciertos escenarios donde la configuración NFAS no utiliza un respaldo canal D, no utilice el nfas_interface 1 de la palabra clave como es reservado para el respaldo canal D. Configure solamente los nfas_interfaces 0,2,3, 4 y así sucesivamente.

    Nota: Al configurar a los grupos múltiples NFAS, las 0 interfaces se deben asignar a cada uno primario canal D y a la 1 interfaz a cada respaldo canal D, con tal que estén en un diverso nfas_group.

  • group_number - Identificador del grupo único en el router. Los grupos múltiples NFAS pueden existir en el router. Cada grupo debe ser configurado con un controlador primario y secundario.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/9584/quadt1_nfas.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Cisco 7507
! 
! 
Last configuration change at 13:07:00 cst Mon Jan 31 2000 
!
version 12.0 
no service pad 
service timestamps debug uptime 
service timestamps log datetime localtime show-timezone 
no service password-encryption 
! 
hostname Router 
! 
enable secret 
! 
ip subnet-zero 
no ip domain-lookup 
ip host west 172.22.173.21
isdn switch-type primary-dms100 

!--- Switchtype must be configured. 
!--- Contact your Telco for more information.
!--- Primary T1 controller.

controller T1 4/0 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d primary nfas_int 0 nfas_group 1 

!--- Primary D channel, nfas interface 0 and member of group 1.

controller T1 4/1 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d backup nfas_int 1 nfas_group 1 


!--- Backup D channel, nfas interface 1 and member of group 1. 


controller T1 5/0 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d none nfas_int 2 nfas_group 1 

!--- 24th timeslot used as B channel, nfas interface 2 and member of group 1.


controller T1 5/1 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d none nfas_int 3 nfas_group 1 

!--- 24th timeslot used as B channel, nfas interface 3 and member of group 1.

process-max-time 200 
! 
interface FastEthernet1/0/0   
 ip address 10.1.1.1 255.255.255.0 
 no ip directed-broadcast 
 no ip route-cache distributed 
 no ip mroute-cache 
 full-duplex 
! 
interface FastEthernet1/1/0 
 no ip address 
 no ip directed-broadcast 
 no ip route-cache distributed 
 no ip mroute-cache 
 shutdown 

!--- D channel for primary controller.
!--- Note: Other D channels in the group are not seen.
!--- All configuration changes made to the primary D channel propagate 
to all the NFAS group members.


interface Serial4/0:23 
 description primary d channel 
 no ip address 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool-member 1 
 isdn switch-type primary-dms100 
 isdn tei-negotiation first-call 
 ppp authentication chap 
 ppp multilink 
! 
interface Dialer0 
 ip address 192.168.10.1 255.255.255.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer remote-name C3620-EA-BCO 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap 
 ppp multilink 
!
router eigrp 200 
 redistribute static 
 network 10.0.0.0 
 network 192.168.10.0 

! 
no ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.1.2 
! 
dialer-list 1 protocol ip permit 
! 
line con 0 
 transport input none 
line aux 0 
 password
   login
  modem InOut
  stopbits 1
 line vty 0 4
  exec-timeout 60 0
  password 
 login 
! 
end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • isdn status de la demostración - Aseegurese que el router está comunicando correctamente con el switch ISDN. Verifique en el resultado que el estado de la capa 1 sea ACTIVE (Activo) y que aparezca MULTIPLE_FRAME_ESTABLISHED en la capa 2.

  • comando show isdn nfas group privileged exec de visualizar a los miembros de un grupo NFAS especificado o de todos los grupos NFAS.

  • muestre el servicio isdn - Comando privileged exec de mostrar el estado y el estatus del servicio de cada canal ISDN. Los canales D se indican según lo reservado. Este comando se puede utilizar para verificar si los canales individuales busied hacia fuera o son defectuosos.

  • show controller t1 - Muestra el estado del controlador específico para el hardware del controlador. También visualiza la información para resolver problemas los problemas de la Capa física y de la capa del link de datos. En el funcionamiento normal, la salida debe indicar que el regulador es ascendente y que no hay alarmas.

Nota: Aseegurese que la conexión T1 señalada como primario por la compañía telefónica y en su configuración del router está conectada con el puerto correcto. Un error común está teniendo la línea incorrecta T1 (cables) conectada con el puerto T1 primario en su router.

Ejemplo de resultado del comando show

Los siguientes son algunas salidas del comando showes del router configurado con el NFAS.

A continuación se muestra un ejemplo de la salida del comando show isdn status:

Router#show isdn status 
Global ISDN Switchtype = primary-dms100 
ISDN Serial4/0:23 interface
         dsl 0, interface ISDN Switchtype = primary-dms100 : 
Primary D channel of nfas group 1
     Layer 1 Status:
         ACTIVE

!--- Primary D channel is active

    Layer 2 Status: 
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED 

!--- Layer 2 is established correctly

    Layer 3 Status: 
        23 Active Layer 3 Call(s) 
    Activated dsl 0 CCBs = 23 
        CCB:callid=0xA0B, sapi=0x0, ces=0x0, B-chan=1 
        CCB:callid=0xA0C, sapi=0x0, ces=0x0, B-chan=3 
        CCB:callid=0xA0D, sapi=0x0, ces=0x0, B-chan=4 
        CCB:callid=0xA0E, sapi=0x0, ces=0x0, B-chan=2 
        CCB:callid=0xA0F, sapi=0x0, ces=0x0, B-chan=5 
        CCB:callid=0xA10, sapi=0x0, ces=0x0, B-chan=6 
        CCB:callid=0xA11, sapi=0x0, ces=0x0, B-chan=7 
        CCB:callid=0xA12, sapi=0x0, ces=0x0, B-chan=8 
        CCB:callid=0xA13, sapi=0x0, ces=0x0, B-chan=9 
        CCB:callid=0xA14, sapi=0x0, ces=0x0, B-chan=10 
        CCB:callid=0xA15, sapi=0x0, ces=0x0, B-chan=11 
        CCB:callid=0xA16, sapi=0x0, ces=0x0, B-chan=12 
        CCB:callid=0xA17, sapi=0x0, ces=0x0, B-chan=13 
        CCB:callid=0xA18, sapi=0x0, ces=0x0, B-chan=14 
        CCB:callid=0xA1B, sapi=0x0, ces=0x0, B-chan=15 
        CCB:callid=0xA1C, sapi=0x0, ces=0x0, B-chan=16 
        CCB:callid=0xA1D, sapi=0x0, ces=0x0, B-chan=17 
        CCB:callid=0xA1E, sapi=0x0, ces=0x0, B-chan=18 
        CCB:callid=0xA1F, sapi=0x0, ces=0x0, B-chan=19 
        CCB:callid=0xA20, sapi=0x0, ces=0x0, B-chan=20 
        CCB:callid=0xA21, sapi=0x0, ces=0x0, B-chan=21 
        CCB:callid=0xA22, sapi=0x0, ces=0x0, B-chan=22 
        CCB:callid=0xA23, sapi=0x0, ces=0x0, B-chan=23 
    The Free Channel Mask:  0x80000000 
ISDN Serial4/1:23 interface
         dsl 1, interface ISDN Switchtype = primary-dms100 :
 Backup D channel of nfas group 1
     Layer 1 Status:
         DEACTIVATED
     Layer 2 Status:
         TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED 
    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 1 CCBs = 0 
    The Free Channel Mask:  0x7E7FFB 
ISDN Serial5/0:23 interface
         dsl 2, interface ISDN Switchtype = primary-dms100 :
 Group member of nfas group 1
     Layer 1 & 2 Status Not Applicable
 
!--- NFAS member: D channel is used as B channel.

    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 2 CCBs = 0 
    The Free Channel Mask:  0x0 
ISDN Serial5/1:23 interface
         dsl 3, interface ISDN Switchtype = primary-dms100 :
 Group member of nfas group 1 
    Layer 1 & 2 Status Not Applicable

!--- NFAS member-channel is used as B channel.

    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 3 CCBs = 0 
    The Free Channel Mask:  0x80000000 
    Total Allocated ISDN CCBs = 23

Nota: La demostración isdn status output visualiza solamente la información referente canal D para el primario y los controladores de backup. También, solamente el primario canal D (Serial4/0:23) muestra el ACTIVE y el MULTIPLE FRAME ESTABLISHED. El estatus del respaldo canal D (Serial4/1:23) aparece según lo DESACTIVADO y TEI_ASSIGNED.

La demostración isdn status output para el Layer 1 y acoda 2 para el T1 5/0 y 5/1 se señala NO CORRESPONDE porque el 24to canal (Serial5/0:23 y el serial 5/1:23) se está utilizando como canal B.

Aquí está el comando show isdn nfas group hecho salir:

Router#show isdn nfas group 1 
ISDN NFAS GROUP 1 ENTRIES:The primary D is Serial4/0:23.    
The backup D is Serial4/1:23.    
The NFAS member is Serial5/0:23.    
The NFAS member is Serial5/1:23. 
There are 4 total nfas members.    
There are 68 total available B channels. 
The primary D-channel is DSL 0 in state IN SERVICE. 
The backup D-channel is DSL 1 in state OUT OF SERVICE. 
The current active layer 2 DSL is 0.

Nota: La salida del grupo del ISDN NFAS de la demostración muestra a los miembros del grupo. La salida muestra que el regulador 4/0 es el primario y 4/1 es el respaldo. Los reguladores 5/0 y 5/1 son miembros del grupo y tienen 24 canales B disponibles para ellos.

La salida también muestra el número total de Miembros de NFAS y el número de canales disponibles. Muestra que el primario canal D está en el servicio mientras que el respaldo es Out Of Service.

Aquí está un ejemplo de un comando show isdn service hecho salir:

Router# show isdn service 
PRI Channel Statistics:
 ISDN Se4/0:23, Channel [1-24]
      Configured Isdn Interface (dsl) 0
      Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
      0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3
      Service State (0=Inservice 1=Maint 2=Outofservice)
      0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
 ISDN Se4/1:23, Channel [1-24]
     Configured Isdn Interface (dsl) 1
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
     2 2 0 2 2 2 2 2 2 2 2 2 2 2 2 0 0 2 2 2 2 2 0 3  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 2 0 0 0 0 0 0 0 0 0 0 0 0 2 2 0 0 0 0 0 0 0  
ISDN Se5/0:23, Channel [1-24] 
     Configured Isdn Interface (dsl) 2 
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)    
     2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  
ISDN Se5/1:23, Channel [1-24] 
     Configured Isdn Interface (dsl) 3 
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)    
     2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  
Router#

La salida del servicio isdn de la demostración muestra que los canales D para el primario y secundario están en el estado 3, que corresponde a reservado. Los canales D para los otros miembros están adentro Estado 2, que indica que él es ocupado y funcionando como canales B. Un estado del canal de 0 indica que el canal está disponible para el uso.

Nota: En muchos dispositivos (lo más comúnmente posible Access Server) el estado de servicio para canal D es 2, indicando que el canal es Out Of Service. Esto es un problema estético y no debe afectar a su conexión. Para determinar si canal D es realmente uso el funcionamiento el comando show isdn status según lo descrito previamente

Para los reguladores que no se señalan como primario o de reserva (5/0 y 5/1), asegúrese de que el 24to canal esté en el estado ocioso u ocupado. No debe estar en el estado reservado.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de publicar los comandos debug, refiera a la información importante en los comandos Debug:

  • debug ISDN q931 - Muestre la configuración de la llamada y derribe de la conexión de red ISDN (capa 3).

  • haga el debug de isdn q921 - Muestre los mensajes de la capa del link de datos (capa 2) en canal D en medio el router y el switch ISDN. Use este depurador cuando el comando ‘show isdn status’ no muestre que la Capa 1 y la Capa 2 están funcionando.

Si se cierra el regulador

¿Qué sucede cuando el regulador que pertenece a un grupo NFAS se cierra? Todas las llamadas activas en ésa regulador cerrado serán borradas, y uno del siguiente se aplicará:

  • Si el regulador cerrado es el primario y no se configura ningún respaldo, se borran todas las llamadas activas en general agrupan.

  • Si el regulador cerrado es el primario, el active (IN SERVICE) canal D está en el primario, y un respaldo se configura, el Switches del active canal D al controlador de backup.

  • Si el regulador cerrado es el primario y el active (IN SERVICE) canal D está en el respaldo, el active canal D permanece en el controlador de backup.

  • Si el regulador cerrado es el respaldo y el active canal D está en el respaldo, el active canal D cambia al controlador primario.

Nota: El cambio del active canal D entre el controlador primario y de backup sucede solamente cuando cualquiera de los links falla y no cuando sube el link.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 9584