Marcado y acceso remotos : Conexiones asíncronas

Marcado PPP Multilink asincrónico desde clientes de Microsoft Windows

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

En esta configuración del PPP Multilink asincrónico, los usuarios de marcación remota con Microsoft Windows 95/98 PC utilizan los módems múltiples para aumentar la velocidad de acceso disponible. El PPP Multilink asincrónico se puede también configurar con otros clientes, tales como Linux y Apple Macintosh, con el software de cliente PPP apropiado. La configuración del router para PPP de link múltiple es independiente de la plataforma de la PC del cliente.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Cisco AS5300 que funciona con el Software Release 12.07(T) del½ del¿Â del Cisco IOSïÂ.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Teoría Precedente

El Multilink PPP (MPPP) permite que los dispositivos envíen los datos al mismo destino sobre el punto múltiple para señalar los links de datos implementando un link virtual. La conexión MPPP tiene un ancho de banda máximo igual a la suma de los anchos de banda de los links componentes. El MPPP se puede configurar para los links multiplexados, tales como ISDN y Frame Relay, o para las líneas asíncronas múltiples.

El PPP Multilink asincrónico se puede utilizar para conectar a los clientes remotos a una mayor velocidad que eso disponible a través de una sola conexión analógica. En el MPPP asincrónico, el cliente remoto utiliza los módems múltiples, y por lo tanto las líneas de teléfono múltiple, al dialin al router central y accede la red. Porque las líneas de teléfono múltiple son a menudo más baratas que el servicio del Basic Rate Interface (BRI) ISDN, el MPPP asincrónico proporciona una manera eficaz de aumentar la velocidad de la conexión para los usuarios remotos mientras que el controlar cuesta. El MPPP asincrónico es también una manera eficaz de obtener velocidades de acceso más altas para las áreas remotas que no se pueden mantener por el ISDN.

El MPPP asincrónico lía juntas las conexiones de módem distintas a un servidor de acceso. El software PPP en cada par hace fragmentos de los paquetes y transmite los pedazos al otro lado a través de las conexiones analógicas múltiples. El extremo receptor recolecta los paquetes de las otras conexiones y, sobre la base de la información PPP integrada dentro de ellas, vuelve a montar los pedazos en los paquetes de datos válidos, así proporcionando a un link virtual extremo a extremo con el ancho de banda mayor. El MPPP asincrónico se puede configurar entre dos Routers o entre un router y una a PC del cliente.

Aunque es posible utilizar más de dos módems para una conexión de links múltiples del PC del cliente, los gastos indirectos que los resultados de la fragmentación y del nuevo ensamble de los paquetes en el PC pueden negar cualquier ancho de banda adicional ganado.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en este diagrama:

/image/gif/paws/9553/async_multilink.gif

Configuración de NAS

En esta configuración, un servidor AS5300 con una conexión de la interfaz de la velocidad primaria T1 (PRI) se utiliza como el servidor de acceso a la red del marcado de entrada del usuario analógico (NAS). Debido a que ninguno de los otros controladores T1 en este NAS está configurado, este servidor de acceso se usa exclusivamente para marcado asíncrono. Esta configuración AS5300 utiliza plantillas virtuales para clonar interfaces de acceso virtual para llamadas entrantes. El agrupamiento PPP de links múltiples duplica sus parámetros de interfaz de las definiciones de plantilla virtual.

Se incluyen algunos comandos de autenticación, autorización y contabilización (AAA) como ejemplo de la mejor metodología. Los nombres de usuario y las contraseñas para usuarios de marcación de entrada están configuradas en el router. Las direcciones de IP asignadas a los usuarios de marcación de entrada son provistas por el agrupamiento de direcciones.

AS5300 de Cisco
bobslake-nas-01#show running-config
Building configuration...

Current configuration:
!
! Last configuration change at 16:01:01 UTC Wed Jun 28 2000
! NVRAM config last updated at 15:30:28 UTC Wed Jun 28 2000 
!
version 12.0
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service tcp-small-servers
!
hostname bobslake-nas-01
!
logging buffered 10000 debugging
aaa new-model
aaa authentication login default local
aaa authentication ppp default if-needed local

!--- authenticate for PPP if not authenticated during login
!--- allows users with Terminal Window after Dial to initiate PPP!

username admin password <deleted> 
username charlie password <deleted> 
spe 1/0 1/7
 firmware location system:/ucode/mica_port_firmware
!
resource-pool disable
!
ip subnet-zero
no ip source-route
ip domain-name the.net
!
multilink virtual-template 1

!--- use virtual-template 1 for multilink connections

async-bootp dns-server 172.22.53.210
isdn switch-type primary-5ess
isdn voice-call-failure 0
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 3
 framing esf
 clock source line secondary 3
 linecode b8zs
 pri-group timeslots 1-24
!
interface Loopback0
 ip address 172.21.10.10 255.255.255.255
 no ip directed-broadcast
!
interface Loopback1
 ip address 172.21.104.254 255.255.255.0

!--- summarizes addresses in address pool 
!--- Loopback 1 is in the same subnet as the address pool 

no ip directed-broadcast
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Virtual-Template1
 description Template for Multilink Users
 ip unnumbered Loopback0  
 no ip directed-broadcast
 peer default ip address pool addr-pool

!--- use IP pool called addr-pool 
!--- for incoming calls
 
ppp authentication chap

!--- authenticate using Challenge Handshake Authentication Protocol (CHAP)

 ppp multilink
!

!--- configure D channel on PRI interface Serial0:23

 description Headquarters 324-1939 active PRI line
 no ip address
 no ip directed-broadcast
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial1:23
 no ip address
 no ip directed-broadcast
 no logging event link-status
 no snmp trap link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial2:23
 no ip address
 no ip directed-broadcast
 no logging event link-status
 no snmp trap link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial3:23
 no ip address
 no ip directed-broadcast
 no logging event link-status
 no snmp trap link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface FastEthernet0
 ip address 172.21.101.23 255.255.255.0
 no ip directed-broadcast
 duplex auto
 speed auto
!
interface Group-Async1

!--- template to control all async interface configuration 

ip unnumbered Loopback0
 no ip directed-broadcast
 encapsulation ppp

!--- use PPP encapsulation dialer in-band

 dialer-group 5
 async mode interactive
 peer default ip address pool addr-pool

!--- use IP pool called addr-pool 
!--- for incoming calls 

 no fair-queue
 no cdp enable
 ppp authentication chap callin

!--- CHAP authenticate for dialin users only 

 ppp multilink
 group-range 1 48

!--- assign modems 1-48 to the Group-Async 1 configuration template

 router eigrp 1
 network 172.21.0.0
!
ip local pool addr-pool 172.21.104.1 172.21.104.48

!--- define IP address pool range for dialin clients 

ip classless
no ip http server
!

access-list 105 permit ip any any
dialer-list 5 protocol ip list 105
!
line con 0
 exec-timeout 0 0
 transport input none
line 1 48
 autoselect during-login

!--- permits user login prompts after dialin 

 autoselect ppp

!--- automatically launch PPP on the line




 modem InOut

!--- modems can be used to dialin and dialout
!--- InOut may be replaced by Dialin 
!--- if NAS handles only incoming calls

 transport preferred none
 transport output telnet
line aux 0
line vty 0 4
 transport preferred none
 transport input telnet
 transport output telnet
!
ntp clock-period 17180374
ntp update-calendar
ntp server 172.22.255.1 prefer
end

bobslake-nas-01#

Configuración de clientes Windows 9x

El siguiente procedimiento es una descripción rápida en configurar a sus clientes de Windows 9x para el MPPP. Refiera al sitio Web de Microsoftleavingcisco.com si usted tiene dificultad.

Para configurar a los clientes de Microsoft Windows 9x para el MPPP, aseegurese le hacer la versión 1.3 o posterior del Dial Up Networking instalar.

Vaya al sitio Web de Microsoftleavingcisco.com para más información y descargar la última versión del Dial Up Networking (DUN).

  1. Conecte y configure cada módem por separado.

    Desde el Panel de control de Windows, utilice la función “Agregar nuevo hardware” para agregar los módems al cliente. Si tiene problemas para agregar módems, contáctese con su proveedor de PC o con Microsoft para acceder a las instrucciones para solucionar el problema. Verifique que cada módem esté conectado correctamente y que sea reconocido por el sistema operativo. Usted puede querer utilizar un terminal emulator para verificar que su módem funciona correctamente.

  2. Produzca una conexión nueva de marcado manual.

    En Windows haga doble clic el icono del “mi PC” y navegue a la “interconexión de redes de marcación manual.” Después, clic doble “Make New Connection.” Siga las instrucciones para crear una conexión de acceso telefónico utilizando el módem principal. Las funciones multilink se configuran más adelante. Llame al proveedor del servicio para probar la conexión.

  3. Agregue funciones de multilink a su conexión de marcado manual.

    Haga doble clic el icono del “mi PC” y navegue a la “interconexión de redes de marcación manual.” Haga clic con el botón derecho en el icono de conexión recientemente configurado. Del menú que aparece, seleccione las “propiedades.”

    Haga clic la lengueta del “Multilink”, dispositivos adicionales los “del uso selecto,” y haga clic “agregan” el botón. Seleccione un módem adicional en el menú desplegable e ingrese el número de teléfono de siete dígitos del Servidor de acceso o acepte el número que se muestra. No incluya el código de área al configurar el dispositivo adicional, aún cuando se trata de una llamada de larga distancia. La conexión utiliza automáticamente el código de área configurado para el primer módem. Haga clic dos veces en "OK” para completar la configuración.

    A continuación se incluyen algunas capturas de pantalla de una configuración multilink de Windows:

    /image/gif/paws/9553/win95_mppp_1.gif

    win95_mppp_2.gif

  4. Inicie la conexión del módem al servidor de acceso.

    Haga doble clic en el icono de conexión recientemente creado. Ingrese el nombre de usuario y la contraseña configurados en el router y luego haga clic en el botón "Connect" (Conectar). La interconexión de redes de marcación manual marcará el número configurado para el módem primario especificado para la conexión. Cuando se establece la primera conexión, la interconexión de redes de marcación manual marca utilizando los módems adicionales que se especifican en la lista de dispositivos adicionales.

    Al establecerse todas las conexiones, podrá ver información acerca del estado del link haciendo doble clic en el icono "Communicating Computers" (Computadoras conectadas) de la barra de tareas o desconectar la conexión. Haga clic en “Detalles” para verificar que la conexión está utilizando dispositivos múltiples. Cuando selecciona un dispositivo del cuadro de lista, aparece un botón Suspend o Resume. Si aparece un botón Suspender, el dispositivo está en uso ahora y está "agrupado" dentro de la conexión multilink. Al hacer clic en el botón "Suspend" (suspender), se desconecta y se elimina la línea de las conexiones agrupadas. Si aparece el botón “Resume” (Reanudar), haga clic en éste para marcar esa conexión y agregar esa línea al agrupamiento. De manera dinámica, puede suspender y reanudar los links múltiples sin eliminar la conexión.

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta del Output Interpreter soportan a los ciertos comandos show, que permite que usted vea una análisis de la salida del comando show.

  • show ppp multilink, para mostrar información sobre paquetes multienlace no activados. Este comando debería utilizarse para verificar la conexión de links múltiples.

  • show caller – Para mostrar información sobre usuarios individuales y recursos consumidos en NAS. Este comando muestra las estadísticas de llamadas activas para grandes agrupaciones de conexiones y los tiempos absolutos e inactivos por usuario.

  • show caller user – Para mostrar los parámetros del usuario específico, tales como el tipo de línea TTY empleada, la interfaz asíncrona (estante/ranura/puerto), el número de canal DS0, el número de módem, la dirección de IP asignada, los parámetros de PPP y los parámetros de agrupamiento de PPP, entre otros.

Para ayudar a verificar y a resolver problemas la conexión MPPP, refiera a estas sugerencias:

  • Asegúrese de que los prefijos, tales como usar 9 antes de marcar una línea exterior, estén configurados correctamente en PC del cliente. Si esto no está configurado correctamente, usted oirá una señal de ocupado tan pronto como el número comience a marcar.

  • Cree a los clientes separados del DUN para cada módem y verifiquelos que usted tiene total conectividad a su proveedor de servicio. Utilice cada módem por separado antes de proceder con resolver problemas su conexión de links múltiples.

  • Utilice un terminal emulator para conectar con el módem. Marque el número del NAS usando el comando atdt. Por ejemplo, en el hyperterminal ingrese el atdt 55511111. Verifique que el módem marque correctamente y conecte con el NAS. Si el módem no conecta, resuelva problemas su módem. Vea usar básico EN la documentaciónleavingcisco.com de los comandos modem en el sitio Web de Microsoft para más información sobre los modemes del cliente del troubleshooting.

  • Si su conexión primaria conecta correctamente, pero la segunda conexión de marcación manual da una señal de ocupado, verifique que el número de teléfono para el módem adicional esté configurado correctamente en el DUN. Recuerde, los códigos de área no debe ser agregado a la configuración para los dispositivos adicionales. Refiera a los pasos para la configuración en la sección de los clientes de Windows que configura 9x arriba.

Resultado de ejemplo de show y debug

Aquí están alguna demostración y salidas de los debugs del AS5300. Para mayor brevedad, se han eliminado porciones de las depuraciones. Preste atención a las secciones en negrita y a los comentarios proporcionados en los resultados.

Note que el llamador está conectado en Async5 y Async6 hasta después de la autenticación. Un IP Address temporal se proporciona al llamador de la agrupación de direcciones. La llamada después se virtualiza o se ata a un agrupamiento virtual existente. La razón es que el servidor de acceso necesita saber quién es la parte de realiza la llamada para determinar si pertenecen a un agrupamiento virtual establecido. Una vez que la parte que realiza la llamada está unida al agrupamiento, la dirección IP temporal es eliminada y la parte que realiza la llamada utiliza la dirección IP del agrupamiento virtual.

bobslake-nas-01#
bobslake-nas-01#show ppp multilink 

Virtual-Access1, bundle name is charlie
  0 lost fragments, 0 reordered, 0 unassigned, sequence 0x29/0x17 rcvd/sent
  0 discarded, 0 lost received, 1/255 load
  Member links: 2 (max not set, min not set)
    Async5
    Async6


!--- Note that the bundle is using Async line 5 and 6 for multilink. 

bobslake-nas-01#show caller 
                                                Active    Idle
  Line         User               Service       Time      Time
  con 0        admin              Host connect  1w4d      16:50:19  
  tty 5        charlie             Async         00:04:34  00:01:54  
  tty 6        charlie             Async         00:02:00  00:00:57  
  vty 1        admin              VTY           00:13:43  00:00:00  
  As5          charlie             PPP           00:04:25  00:00:00  
  As6          charlie             PPP           00:01:53  00:00:00  
  Vi1          charlie             PPP   Bundle  00:04:25  00:00:57  


!--- User charlie has two async lines, two tty, 
!--- and one virtual interface bundle.

bobslake-nas-01#show caller user charlie

  User: charlie, line tty 5, service Async

!--- shows hardware level settings for user charlie (first connection)

        Active time 00:04:43, Idle time 00:00:06
  Timeouts:            Absolute  Idle      Idle
                                 Session   Exec
      Limits:          -         -         00:10:00  
      Disconnect in:   -         -         -         
  TTY: Line 5, running PPP on As5

!--- user charlie is using tty 5

  DS0: (slot/unit/channel)=0/0/0  Line: Baud rate (TX/RX) is 115200/115200, 
no parity, 1 stopbits, 8 databits
  Status: Ready, Active, No Exit Banner, Async Interface Active
          HW PPP Support Active
  Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
                Modem Callout, Modem RI is CD, 
                Line usable as async interface, Integrated Modem
  Modem State: Ready

  User: charlie, line tty 6, service Async


!--- shows hardware level settings for user charlie (second connection)

        Active time 00:02:09, Idle time 00:01:06
  Timeouts:            Absolute  Idle      Idle
                                 Session   Exec
      Limits:          -         -         00:10:00  
      Disconnect in:   -         -         -         
  TTY: Line 6, running PPP on As6

!--- user charlie is using tty 6

  DS0: (slot/unit/channel)=0/0/1
  Line: Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
  Status: Ready, Active, No Exit Banner, Async Interface Active
          HW PPP Support Active
  Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
                Modem Callout, Modem RI is CD, 
                Line usable as async interface, Integrated Modem
  Modem State: Ready

  User: charlie, line As5, service PPP

!--- PPP setting for user charlie (first connection).

        Active time 00:04:34, Idle time 00:00:00
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, CHAP (<- AAA)

!--- MPPP state is open.

  Dialer: Connected, inbound
          Type is IN-BAND ASYNC, group Async5
  IP: Local 172.21.10.10
  Bundle: Member of charlie, last input 00:00:00
  Counts: 54 packets input, 4110 bytes, 0 no buffer
          1 input errors, 1 CRC, 0 frame, 0 overrun
          73 packets output, 4150 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

!--- Packets are passing through the connection.

  User: charlie, line As6, service PPP

!--- PPP setting for user charlie (second connection).

        Active time 00:02:02, Idle time 00:00:00
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, CHAP (<- AAA)

!--- MPPP state is Open.

  Dialer: Connected, inbound
          Type is IN-BAND ASYNC, group Async6
  IP: Local 172.21.10.10
  Bundle: Member of charlie, last input 00:00:00
  Counts: 6 packets input, 462 bytes, 0 no buffer
          1 input errors, 1 CRC, 0 frame, 0 overrun
          20 packets output, 1129 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

!--- Packets are passing through the connection.

    
User: charlie, line Vi1, service PPP Bundle


!--- Bundle information for user charlie

        Active time 00:04:34, Idle time 00:00:06
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, IPCP
  IP: Local 172.21.104.254, remote 172.21.104.2

!--- Remote IP address is obtained from IP pool.

  Counts: 50 packets input, 4034 bytes, 0 no buffer
          0 input errors, 0 CRC, 0 frame, 0 overrun
          80 packets output, 8750 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

 

bobslake-nas-01#debug vtemplate
Virtual Template debugging is on
bobslake-nas-01#debug ppp multilink events 
Multilink events debugging is on
bobslake-nas-01#debug ppp negotiation 
PPP protocol negotiation debugging is on
bobslake-nas-01#debug ppp authentication 
PPP authentication debugging is on
bobslake-nas-01#debug ppp error 
PPP protocol errors debugging is on
bobslake-nas-01#debug modem
Modem control/process activation debugging is on
bobslake-nas-01#show debug
General OS:
  Modem control/process activation debugging is on
PPP:
  PPP authentication debugging is on
  PPP protocol errors debugging is on
  PPP protocol negotiation debugging is on
  Multilink events debugging is on
VTEMPLATE:
  Virtual Template debugging is on

bobslake-nas-01#
Jun 28 15:41:46.281 UTC: TTY5: DSR came up
Jun 28 15:41:46.281 UTC: tty5: Modem: IDLE->(unknown)

!--- Modem responds to first dialin connection.

Jun 28 15:41:46.281 UTC: TTY5: EXEC creation
...
Jun 28 15:41:48.537 UTC: TTY5 Autoselect cmd:  ppp negotiate
Jun 28 15:41:48.537 UTC: TTY5: EXEC creation
...
Jun 28 15:41:48.545 UTC: As5 IPCP: Install route to 172.21.104.4

!--- IP address for first link obtained from address pool.
!--- Route will be removed when link is virtualized later. 

Jun 28 15:41:50.541 UTC: As5 PPP: Treating connection as a callin
Jun 28 15:41:50.541 UTC: As5 PPP: Phase is ESTABLISHING, Passive Open
Jun 28 15:41:50.541 UTC: As5 LCP: State is Listen

!--- LCP negotiation begins.

Jun 28 15:41:51.549 UTC: As5 LCP: I CONFREQ [Listen] id 3 len 46
...
Jun 28 15:41:51.549 UTC: Unthrottle 5
Jun 28 15:41:51.549 UTC: As5 LCP: O CONFREQ [Listen] id 1 len 47
...
Jun 28 15:41:51.549 UTC: As5 LCP: O CONFREJ [Listen] id 3 len 7
...
Jun 28 15:41:53.549 UTC: As5 LCP: O CONFREQ [REQsent] id 2 len 47
Jun 28 15:41:53.549 UTC: As5 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jun 28 15:41:53.549 UTC: As5 LCP:    AuthProto CHAP (0x0305C22305)
Jun 28 15:41:53.549 UTC: As5 LCP:    MagicNumber 0x56E3C73E (0x050656E3C73E)
Jun 28 15:41:53.549 UTC: As5 LCP:    PFC (0x0702)
Jun 28 15:41:53.549 UTC: As5 LCP:    ACFC (0x0802)
Jun 28 15:41:53.549 UTC: As5 LCP:    MRRU 1524 (0x110405F4)

!--- Max-Receive-Reconstructed-Unit:Maximum packet size 
!--- that the peer will reconstruct.
!--- Both sides must agree on the packet size (MRRU).

Jun 28 15:41:53.549 UTC: As5 LCP:    EndpointDisc 1 Local
Jun 28 15:41:53.549 UTC: As5 LCP:     (0x131201626F62736C616B652D6E61732D)
Jun 28 15:41:53.549 UTC: As5 LCP:     (0x3031)
Jun 28 15:41:53.789 UTC: As5 LCP: I CONFACK [REQsent] id 2 len 47
Jun 28 15:41:53.789 UTC: As5 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jun 28 15:41:53.789 UTC: As5 LCP:    AuthProto CHAP (0x0305C22305)
Jun 28 15:41:53.789 UTC: As5 LCP:    MagicNumber 0x56E3C73E (0x050656E3C73E)
Jun 28 15:41:53.789 UTC: As5 LCP:    PFC (0x0702)
Jun 28 15:41:53.789 UTC: As5 LCP:    ACFC (0x0802)
Jun 28 15:41:53.789 UTC: As5 LCP:    MRRU 1524 (0x110405F4)

!--- Max-Receive-Reconstructed-Unit:Maximum packet size that 
!--- the peer will reconstruct.

Jun 28 15:41:53.789 UTC: As5 LCP:    EndpointDisc 1 Local
Jun 28 15:41:53.789 UTC: As5 LCP:     (0x131201626F62736C616B652D6E61732D)
Jun 28 15:41:53.789 UTC: As5 LCP:     (0x3031)Jun 28 15:41:54.541 UTC: 
As5 LCP: I CONFREQ [ACKrcvd] id 4 len 46
...
Jun 28 15:41:54.541 UTC: As5 LCP: O CONFREJ [ACKrcvd] id 4 len 7
...
Jun 28 15:41:54.717 UTC: As5 LCP: I CONFREQ [ACKrcvd] id 5 len 43
...
Jun 28 15:41:54.717 UTC: As5 LCP: O CONFACK [ACKrcvd] id 5 len 43
...
Jun 28 15:41:54.721 UTC: As5 LCP: State is Open

!--- LCP negotiation is complete.

Jun 28 15:41:54.721 UTC: As5 PPP: Phase is AUTHENTICATING, by this end

!--- CHAP authentication begins.

Jun 28 15:41:54.721 UTC: As5 CHAP: O CHALLENGE id 1 len 36 from "bobslake-nas-01"
Jun 28 15:41:54.909 UTC: As5 CHAP: I RESPONSE id 1 len 27 from "charlie"
Jun 28 15:41:54.909 UTC: As5 CHAP: O SUCCESS id 1 len 4

!--- CHAP authentication is successful.

Jun 28 15:41:54.909 UTC: As5 MLP: Multilink up event pending
Jun 28 15:41:54.913 UTC: As5 PPP: Phase is VIRTUALIZED

!--- Call is virtualized after authentication.

Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Reuse Vi1, recycle queue size 0
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Hardware address 0010.7b4d.7046
Jun 28 15:41:54.913 UTC: Vi1 PPP: Phase is DOWN, Setup
Jun 28 15:41:54.913 UTC: Vi1 MLP: VP: Clone from Vtemplate 1 block=1
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Has a new cloneblk vtemplate
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: ************* CLONE VACCESS1 ***********
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Clone from Virtual-Template1

!--- Cloning from Virtual-Template.

interface Virtual-Access1
default ip address
no ip address
encap ppp
description Template for Multilink Users
ip unnumbered Loopback0
no ip directed-broadcast
no logging event link-status
no snmp trap link-status
peer default ip address pool addr-pool
ppp authentication chap
ppp multilink
ip unnum loop 1
end
Jun 28 15:41:55.005 UTC: Vi1 PPP: Treating connection as a dedicated line
Jun 28 15:41:55.005 UTC: Vi1 PPP: Phase is ESTABLISHING, Active Open
Jun 28 15:41:55.005 UTC: Vi1 LCP: O CONFREQ [Closed] id 1 len 37
...
Jun 28 15:41:55.009 UTC: Vi1 PPP: Phase is UP
Jun 28 15:41:55.009 UTC: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
Jun 28 15:41:55.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:55.009 UTC: As5 MLP: charlie, multilink up, first link

!--- First link in multilink bundle for user charlie is up.

Jun 28 15:41:55.009 UTC: As5 IPCP: Remove route to 172.21.104.4

!--- Temporary route to first link removed since link is virtualized.

Jun 28 15:41:55.069 UTC: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 40
...
Jun 28 15:41:55.069 UTC: Vi1 IPCP: Pool returned 172.21.104.2

!--- IP address for virtual bundle obtained from address pool.

Jun 28 15:41:55.069 UTC: Vi1 IPCP: O CONFREJ [REQsent] id 1 len 22
...
Jun 28 15:41:55.085 UTC: Vi1 CCP: I CONFREQ [Not negotiated] id 1 len 15
Jun 28 15:41:55.085 UTC: Vi1 CCP:    MS-PPC supported bits 0x00000001 (0x120600)
...
Jun 28 15:41:55.181 UTC: Vi1 IPCP: I CONFACK [REQsent] id 1 len 10
Jun 28 15:41:55.181 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:57.009 UTC: Vi1 IPCP: TIMEout: State ACKrcvd
Jun 28 15:41:57.009 UTC: Vi1 IPCP: O CONFREQ [ACKrcvd] id 2 len 10
Jun 28 15:41:57.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:59.009 UTC: Vi1 IPCP: TIMEout: State REQsent
Jun 28 15:41:59.009 UTC: Vi1 IPCP: O CONFREQ [REQsent] id 3 len 10
Jun 28 15:41:59.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:59.617 UTC: Vi1 IPCP: I CONFREQ [REQsent] id 2 len 34
...
Jun 28 15:41:59.617 UTC: Vi1 IPCP: O CONFREJ [REQsent] id 2 len 16
...
Jun 28 15:41:59.633 UTC: Vi1 PPP: Replace IPCP code 2 id 3 with id 3
Jun 28 15:41:59.633 UTC: Vi1 IPCP: I CONFACK [REQsent] id 3 len 10
Jun 28 15:41:59.633 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:59.777 UTC: Vi1 IPCP: I CONFREQ [ACKrcvd] id 3 len 22
...
Jun 28 15:41:59.777 UTC: Vi1 IPCP: O CONFNAK [ACKrcvd] id 3 len 22
...
Jun 28 15:41:59.937 UTC: Vi1 IPCP: I CONFREQ [ACKrcvd] id 4 len 22
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    Address 172.21.104.2 
(0x0306AC156802)

!--- IP address of virtual bundle was previously obtained from 
!--- address pool.

Jun 28 15:41:59.937 UTC: Vi1 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    SecondaryDNS 171.68.10.70 (0x8306AB440A46)
Jun 28 15:41:59.937 UTC: Vi1 IPCP: O CONFACK [ACKrcvd] id 4 len 22
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    Address 172.21.104.2 (0x0306AC156802)
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    SecondaryDNS 171.68.10.70 (0x8306AB440A46)
Jun 28 15:41:59.937 UTC: Vi1 IPCP: State is Open
Jun 28 15:41:59.941 UTC: Vi1 IPCP: Install route to 172.21.104.2

!--- Add route for virtual bundle to routing table.

Jun 28 15:42:44.383 UTC: TTY51: timer type 1 expired
Jun 28 15:42:44.383 UTC: TTY51:  Exec timer (continued)

!--- Modem comes up for multilink connection.

Jun 28 15:44:20.385 UTC: TTY6: DSR came up

!--- Async 6 is used for second connection.

Jun 28 15:44:20.385 UTC: tty6: Modem: IDLE->(unknown)
Jun 28 15:44:20.385 UTC: TTY6: EXEC creation
...
Jun 28 15:44:20.529 UTC: TTY6 Autoselect cmd:  ppp negotiate
Jun 28 15:44:20.529 UTC: TTY6: EXEC creation
...Jun 28 15:44:20.661 UTC: As6 IPCP: Install route to 172.21.104.5

!--- IP address for second link is obtained from the pool.
!--- Route will be removed when link is added to the MPPP bundle.

Jun 28 15:44:22.661 UTC: As6 PPP: Treating connection as a callin
Jun 28 15:44:22.661 UTC: As6 PPP: Phase is ESTABLISHING, Passive Open

!--- LCP negotiation begins.

Jun 28 15:44:22.661 UTC: As6 LCP: State is Listen
Jun 28 15:44:23.521 UTC: As6 LCP: I CONFREQ [Listen] id 2 len 46
...
Jun 28 15:44:23.525 UTC: Unthrottle 6
Jun 28 15:44:23.525 UTC: As6 LCP: O CONFREQ [Listen] id 1 len 47
...
Jun 28 15:44:23.525 UTC: As6 LCP: O CONFREJ [Listen] id 2 len 7
Jun 28 15:44:23.525 UTC: As6 LCP:    Callback 6  (0x0D0306)
Jun 28 15:44:25.525 UTC: As6 LCP: TIMEout: State REQsent
Jun 28 15:44:25.525 UTC: As6 LCP: O CONFREQ [REQsent] id 2 len 47
...
Jun 28 15:44:25.765 UTC: As6 LCP: I CONFACK [REQsent] id 2 len 47
...
Jun 28 15:44:26.533 UTC: As6 LCP: I CONFREQ [ACKrcvd] id 3 len 46
...
Jun 28 15:44:26.533 UTC: As6 LCP: O CONFREJ [ACKrcvd] id 3 len 7
Jun 28 15:44:26.533 UTC: As6 LCP:    Callback 6  (0x0D0306)
Jun 28 15:44:26.741 UTC: As6 LCP: I CONFREQ [ACKrcvd] id 4 len 43
...
Jun 28 15:44:26.741 UTC: As6 LCP: O CONFACK [ACKrcvd] id 4 len 43
...
Jun 28 15:44:26.741 UTC: As6 LCP: State is Open

!--- LCP negotiation is complete.
!--- CHAP authentication begins.

Jun 28 15:44:26.745 UTC: As6 PPP: Phase is AUTHENTICATING, by this end
Jun 28 15:44:26.745 UTC: As6 CHAP: O CHALLENGE id 1 len 36 from "bobslake-nas-01"
Jun 28 15:44:26.981 UTC: As6 CHAP: I RESPONSE id 1 len 27 from "charlie"
Jun 28 15:44:26.981 UTC: As6 CHAP: O SUCCESS id 1 len 4

!--- CHAP authentication is successful. 

Jun 28 15:44:26.981 UTC: As6 MLP: Multilink up event pending
Jun 28 15:44:26.981 UTC: As6 PPP: Phase is VIRTUALIZED

!--- Link is virtualized.

Jun 28 15:44:26.985 UTC: As6 MLP: charlie, multilink up

!--- Multilink connection is up.

Jun 28 15:44:26.985 UTC: As6 IPCP: Remove route to 172.21.104.5

!--- Use IP address previously assigned to the bundle 
!--- (in this case, 172.21.104.2).

bobslake-nas-01#

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

La herramienta del Output Interpreter soportan a los ciertos comandos show, que permite que usted vea una análisis de la salida del comando show.

Nota: Antes de ejecutar un comando debug, consulte Información Importante sobre Comandos de Debug.

  • debug vtemplate - Información de clonación de las visualizaciones para una interfaz de acceso virtual a partir del tiempo que se reproduce de una plantilla virtual al tiempo baja.

  • debug ppp multilink events - Visualiza la información sobre los eventos que afectan a los agrupamientos de links múltiples.

  • debug pp negotiation – Muestra información sobre el tráfico PPP e intercambios mientras negocia el Protocolo de control de link (LCP), la autenticación ysel Protocolo de control de red (NCP). Una negociación PPP exitosa abrirá primero el estado LCP, luego realizará la autenticación y por último negociará el NCP.

  • autenticación PPP del debug - Mensajes de protocolo de la autenticación PPP de las visualizaciones, incluyendo los intercambios de paquetes del Challenge Handshake Authentication Protocol (CHAP) y los intercambios del protocolo password authentication (PAP).

  • debug ppp error - Los errores del protocolo y la estadística de errore de las visualizaciones se asociaron a la negociación y a la operación de la conexión PPP.

  • debug modem – Muestra la actividad de la línea del módem en un servidor de acceso.


Información Relacionada


Document ID: 9553