Marcado y acceso remotos : Virtual Private Dialup Network (VPDN)

Configuración de saltos múltiples L2Tp para ejecutar varios saltos desde NAS al LNS

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Contenido


Introducción

El Multihop Virtual Private Dialup Network (VPDN) permite que usted configure varios saltos en la manera del L2TP Access Concentrator (LAC) al L2TP Network Server (LNS). Se soporta un máximo de cuatro saltos. El túnel se termina en cada salto (LNS) y reinitiated al destino del salto siguiente. Este proceso permite la conmutación de túnel. Las redes multisalto pueden emplearse entre ISP a fin de brindar un servicio al por mayor de Red privada virtual (VPN) de acceso.

La expedición de la capa 2 (L2F) y acoda 2 Tunnel Protocol (L2TP) se soporta en este escenario. Sin embargo, puesto que el L2TP se está convirtiendo en el estándar de la industria, focos de este documento en el L2TP.

prerrequisitos

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Requisitos

No hay requisitos previos específicos para este documento.

Para una explicación del proceso VPDN, refiera comprensión del VPDN.

Componentes Utilizados

La información que contiene este documento se basa en las versiones de software y hardware indicadas a continuación.

  • Versiones de software de Cisco IOS� 12.3(6)

  • L2TP Access Concentrator (LAC) (Concentrador de acceso L2TP) un Access Server del Cisco AS5400

  • Servidores de red L2TP (LNS): Routers Cisco 7200

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/9497/l2tp_multihop2a.gif

En esta configuración:

  • El cliente utiliza el ISDN para marcar en el LAC (podría, por ejemplo, utilizar el DSL en lugar de otro).

  • El LAC utiliza una interfaz de la velocidad primaria del e1 (PRI) para validar las llamadas.

  • No hay túnel ya abierto entre los dispositivos L2TP.

  • La configuración del túnel y de la sesión se basa en el Domain Name. No hay servidor de AAA para la autenticación o la autorización.

  • Utiliza dos LNS.

El proceso es el siguiente:

  1. El cliente marca en el LAC. El cliente y el LAC negocian las opciones LCP. Se lleva a cabo la fase de autenticación, y LAC obtiene el nombre de usuario (user@cisco.com) y contraseña. De acuerdo con el Domain Name (cisco.com en nuestro ejemplo), abre un túnel seguido por una sesión al LNS1.

  2. Una vez que la sesión L2TP se abre entre el LAC y el LNS1, el LNS1 recibe las opciones LCP que fueron negociadas entre el LAC y el cliente junto con el nombre de usuario y la contraseña (usuario@cisco.com, contraseña).

  3. El LNS1 tiene un grupo de VPDN con el mismo dominio (cisco.com) en su configuración. Abre un túnel y una sesión en el LNS2. Si no tiene tal configuración, termina la sesión PPP autenticando el cliente, negociando la dirección IP e instalando la ruta.

  4. Una vez que se abre la sesión L2TP entre el LNS1 y el LNS2, el LNS2 obtiene las opciones LCP que se negociaron entre el LAC y el cliente, junto con el usuario y la contraseña (usuario@cisco.com, contraseña). Autentica al usuario, negocia IPCP e instala la ruta.

Configuraciones

Este documento usa las configuraciones detalladas a continuación. El número mínimo de comandos se utiliza aquí. Por ejemplo, el LAC no terminará ninguna sesión, por lo que no hay necesidad de configurar una dirección IP en la interfaz Dialer1 o Group-asyn1. El LNS1 no terminará ninguna sesión PPP, por lo que no existe ninguna dirección IP bajo virtual-template1.

LAC
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname LAC
!
boot-start-marker
no boot startup-test
boot-end-marker
!
enable password 7 02050D480809
!
!
!
resource-pool disable
spe default-firmware spe-firmware-2
no aaa new-model
ip subnet-zero
no ip domain lookup
!         
ip cef

! -- Enables VPDN.

vpdn enable

! -- VPDN tunnel authorization is based first on the domain name 
! -- (the default is DNIS).

! vpdn search-order domain  
!

! -- The LAC opens an L2TP tunnel and session to 10.48.74.113 (LNS1) 
! -- using the password LACLNS1 for users whose domain-name is cisco.com.

vpdn-group 1
 request-dialin
  protocol l2tp
  domain cisco.com
 initiate-to ip 10.48.74.113 
 l2tp tunnel password LACLNS1
!
isdn switch-type primary-net5
!
!
no voice hpi capture buffer
no voice hpi capture destination 
!
!
controller E1 7/0
 pri-group timeslots 1-31
!
interface FastEthernet0/0
 ip address 10.48.74.128 255.255.255.0
 duplex auto
 speed auto
!
interface Serial7/0:15
 no ip address
 encapsulation ppp
 dialer rotary-group 1
 isdn switch-type primary-net5
!
interface Group-Async1
 no ip address
 encapsulation ppp
 async mode interactive
 ppp authentication chap callin
 group-range 1/00 3/107
!
interface Dialer1
 no ip address
 encapsulation ppp
 ppp authentication chap callin
!
ip classless
no ip http server
!
!
voice-port 7/0:D
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
line 1/00 1/107
 modem InOut
 transport input all
line 3/00 3/107
 modem InOut
 transport input all
!
scheduler allocate 10000 400
!         
end

LNS1
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname LNS1
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
clock timezone CET 1
no aaa new-model
ip subnet-zero
ip cef    
!
!
no ip domain lookup
!

! -- Enables VPDN. 

vpdn enable

! -- Enables VPDN multihop.

vpdn multihop
!

!-- LNS1 accepts L2TP tunnel/session from the router named LAC.
!-- The password LACLNS1 is used between LAC and LNS1 for authentication.
!-- The virtual-template 1 is used for the PPP phase.

vpdn-group FromLAC
 accept-dialin
  protocol l2tp
  virtual-template 1
 terminate-from hostname LAC
 l2tp tunnel password 0 LACLNS1
!

! -- The LNS1 opens a L2TP tunnel and session to 10.11.0.2 (LNS2) 
! -- using the password LNS1LNS2 for users whose domain-name is cisco.com.


vpdn-group TowardsLNS2
 request-dialin
  protocol l2tp
  domain cisco.com
 initiate-to ip 10.11.0.2 
 l2tp tunnel password 0 LNS1LNS2
!
!
interface Ethernet0/0
 ip address 10.48.74.113 255.255.255.0
 no ip proxy-arp
 half-duplex
!
interface Ethernet0/1
 ip address 10.11.0.1 255.255.255.0
 half-duplex
!
interface Virtual-Template1
 no ip address
 ppp authentication chap callin
!
no ip http server
ip classless
!
!
dial-peer cor custom
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password ww
 login
!
ntp clock-period 17208915
ntp server 10.48.75.134
!
!
end

LNS2
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname LNS2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
username user@cisco.com password 0 cisco
no aaa new-model
ip subnet-zero
!
!
ip cef    
!

!-- Enables VPDN.

vpdn enable
!

!-- LNS2 accepts L2TP tunnel/session from the router named LNS1.
!-- The password LNS1LNS2 is used between LNS1 and LNS2 for authentication.
!-- The virtual-template 1 is used for the PPP phase.

vpdn-group FromLNS1
! Default L2TP VPDN group
 accept-dialin
  protocol l2tp
  virtual-template 1
 l2tp tunnel password 0 LNS1LNS2
!
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet3/0
 ip address 10.11.0.2 255.255.255.0
 duplex half
!
interface Virtual-Template1
 ip unnumbered Loopback0
 peer default ip address pool VpdnUsers
 ppp authentication chap callin
!
ip local pool VpdnUsers 192.168.1.2 192.168.1.254
ip classless
no ip http server
!
!
line con 0
 exec-timeout 0 0
 transport preferred all
 transport output all
 stopbits 1
line aux 0
 transport preferred all
 transport output all
 stopbits 1
line vty 0 4
 login
 transport preferred all
 transport input all
 transport output all
!
!
!
end

Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • vpdn de la demostración - Información de las visualizaciones sobre el L2TP activo o túnel y identificadores de mensajes del protocolo L2F en un VPDN.

  • show caller user user detail – Muestra información de la parte llamadora.

El resultado de la utilización de estos comando en el LAC, LNS1 y LNS2 se muestra a continuación:

LAC#show vpdn        

L2TP Tunnel and Session Information Total tunnels 1 sessions 1

LocID RemID Remote Name   State  Remote Address  Port  Sessions VPDN Group
18693 28416 LNS1          est    10.48.74.113    1701  1        1              

LocID RemID TunID Intf          Username             State  Last Chg Uniq ID
19    21    18693 Se7/0:3       user@cisco.com       est    00:02:04 28     

%No active L2F tunnels

%No active PPTP tunnels
LAC#

Vemos que el LNS1 tiene dos túneles con una sesión en cada uno.

LNS1#show vpdn 

L2TP Tunnel and Session Information Total tunnels 2 sessions 2

LocID RemID Remote Name   State  Remote Address  Port  Sessions VPDN Group
28416 18693 LAC           est    10.48.74.128    1701  1        FromLAC        

LocID RemID TunID Intf          Username             State  Last Chg Uniq ID
21    19    28416 SSS Circuit   user@cisco.com       est    00:02:25 13     

LocID RemID Remote Name   State  Remote Address  Port  Sessions VPDN Group
30255 35837 LNS2          est    10.11.0.2       1701  1        TowardsLNS2    

LocID RemID TunID Intf          Username             State  Last Chg Uniq ID
22    9     30255 SSS Circuit   user@cisco.com       est    00:02:25 13     

%No active L2F tunnels

%No active PPTP tunnels
LNS1#
LNS2#show vpdn

L2TP Tunnel and Session Information Total tunnels 1 sessions 1

LocID RemID Remote Name   State  Remote Address  Port  Sessions VPDN Group
35837 30255 LNS1          est    10.11.0.1       1701  1        FromLNS1       

LocID RemID TunID Intf          Username             State  Last Chg Uniq ID
9     22    35837 Vi2.1         user@cisco.com       est    00:03:22 8      

%No active L2F tunnels

%No active PPTP tunnels
LNS2#

LNS2#show caller user user@cisco.com detail

  User: user@cisco.com, line Vi2.1, service PPPoVPDN
        Connected for 00:03:33, Idle for 00:00:58
  Timeouts:    Limit     Remaining Timer Type
               -         -         -         
  PPP: LCP Open, CHAP (<-), IPCP
  LCP: -> peer, AuthProto, MagicNumber
       <- peer, MagicNumber, EndpointDisc
  NCP: Open IPCP
  IPCP: <- peer, Address
        -> peer, Address
  IP: Local 192.168.1.1, remote 192.168.1.2
  Counts: 56 packets input, 2562 bytes
          57 packets output, 2570 bytes

LNS2#

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de ejecutar un comando debug, consulte Información Importante sobre Comandos Debug.

Comandos de Troubleshooting en el LAC

  • debug isdn q931 - Muestra información acerca de la configuración de llamadas y desconexión de conexiones de red ISDN (Capa 3) entre el router local (lado del usuario) y la red.

  • debug vpdn event – Muestra errores L2TP y eventos que son una parte del establecimiento normal túneles o apagado para VPDN.

  • debug vpdn error - Localiza averías el Tunnel Protocol de la capa 2 versión 3 (L2TPv3) y la infraestructura circundante el hacer un túnel de la capa 2.

  • debug vpdn l2x-events: muestra los eventos que ocurren como resultado de condiciones específicas de protocolos.

  • vpdn l2x-errors: Muestra los errores que ocurren en condiciones específicas de protocolos.

  • negociación ppp del debug - Visualizaciones si un cliente está pasando la negociación PPP. Puede ver qué opciones (por ejemplo, devolución de llamada o MLP) y qué opciones (tales como IP e IPX) están siendo negociadas.

Comandos para la resolución de problemas en el LNS1

  • debug vpdn event

  • debug vpdn error

  • evento del l2x del vpdn del debug

  • vpdn l2x-erro

  • debug ppp negotiation

  • información de clonación de los errores apareces del debug vtemplate para una interfaz de acceso virtual a partir del tiempo que se reproduce de una plantilla virtual al tiempo la interfaz de acceso virtual viene abajo de cuando la llamada termina.

  • evento del debug vtemplate - Información de clonación de las visualizaciones para una interfaz de acceso virtual a partir del tiempo que se reproduce de una plantilla virtual al tiempo la interfaz de acceso virtual viene abajo de cuando la llamada termina.

Comandos para la resolución de problemas en el LNS2

Igual que para LNS1 pero con un comando adicional:

  • debug ip peer: Muestra la actividad de la dirección y contiene resultados adicionales cuando se definen grupos de agrupación.

Salida del depurador - LAC

La salida de los depuradores en LAC es el siguiente:

LAC#
*Apr 23 08:55:23.579: ISDN Se7/0:15 Q931: RX <- SETUP pd = 8  callref = 0x256F 
        Sending Complete 
        Bearer Capability i = 0x8890 
                Standard = CCITT 
                Transer Capability = Unrestricted Digital 
                Transfer Mode = Circuit 
                Transfer Rate = 64 kbit/s 
        Channel ID i = 0xA18384 
                Preferred, Channel 4 
        Calling Party Number i = 0xA1, '8101' 
                Plan:ISDN, Type:National 
        Called Party Number i = 0x81, '7070' 
                Plan:ISDN, Type:Unknown 
        Locking Shift to Codeset 6 
        Codeset 6 IE 0x28  i = 'TAC BRI 8101'
*Apr 23 08:55:23.583: ISDN Se7/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0xA56F 
        Channel ID i = 0xA98384 
                Exclusive, Channel 4
*Apr 23 08:55:23.583: ISDN Se7/0:15 Q931: TX -> CONNECT pd = 8  callref = 0xA56F 
        Channel ID i = 0xA98384 
                Exclusive, Channel 4
*Apr 23 08:55:23.583: Se7/0:3 PPP: Using dialer call direction
*Apr 23 08:55:23.583: Se7/0:3 PPP: Treating connection as a callin
*Apr 23 08:55:23.583: Se7/0:3 PPP: Phase is ESTABLISHING, Passive Open
*Apr 23 08:55:23.583: Se7/0:3 LCP: State is Listen
*Apr 23 08:55:23.607: ISDN Se7/0:15 Q931: RX <- CONNECT_ACK pd = 8  
callref = 0x256F
*Apr 23 08:55:23.695: Se7/0:3 LCP: I CONFREQ [Listen] id 180 len 31
*Apr 23 08:55:23.695: Se7/0:3 LCP:    MagicNumber 0x9028FFED (0x05069028FFED)
*Apr 23 08:55:23.695: Se7/0:3 LCP:    MRRU 1524 (0x110405F4)
*Apr 23 08:55:23.695: Se7/0:3 LCP:    EndpointDisc 1 user@cisco.com
*Apr 23 08:55:23.695: Se7/0:3 LCP:     (0x1311017573657240636973636F2E636F)
*Apr 23 08:55:23.695: Se7/0:3 LCP:     (0x6D)
*Apr 23 08:55:23.695: Se7/0:3 LCP: O CONFREQ [Listen] id 1 len 15
*Apr 23 08:55:23.695: Se7/0:3 LCP:    AuthProto CHAP (0x0305C22305)
*Apr 23 08:55:23.695: Se7/0:3 LCP:    MagicNumber 0x050E44FB (0x0506050E44FB)
*Apr 23 08:55:23.695: Se7/0:3 LCP: O CONFREJ [Listen] id 180 len 8
*Apr 23 08:55:23.695: Se7/0:3 LCP:    MRRU 1524 (0x110405F4)
*Apr 23 08:55:23.727: Se7/0:3 LCP: I CONFACK [REQsent] id 1 len 15
*Apr 23 08:55:23.727: Se7/0:3 LCP:    AuthProto CHAP (0x0305C22305)
*Apr 23 08:55:23.727: Se7/0:3 LCP:    MagicNumber 0x050E44FB (0x0506050E44FB)
*Apr 23 08:55:23.751: Se7/0:3 LCP: I CONFREQ [ACKrcvd] id 181 len 27
*Apr 23 08:55:23.751: Se7/0:3 LCP:    MagicNumber 0x9028FFED (0x05069028FFED)
*Apr 23 08:55:23.751: Se7/0:3 LCP:    EndpointDisc 1 user@cisco.com
*Apr 23 08:55:23.751: Se7/0:3 LCP:     (0x1311017573657240636973636F2E636F)
*Apr 23 08:55:23.751: Se7/0:3 LCP:     (0x6D)
*Apr 23 08:55:23.751: Se7/0:3 LCP: O CONFACK [ACKrcvd] id 181 len 27
*Apr 23 08:55:23.751: Se7/0:3 LCP:    MagicNumber 0x9028FFED (0x05069028FFED)
*Apr 23 08:55:23.751: Se7/0:3 LCP:    EndpointDisc 1 user@cisco.com
*Apr 23 08:55:23.751: Se7/0:3 LCP:     (0x1311017573657240636973636F2E636F)
*Apr 23 08:55:23.751: Se7/0:3 LCP:     (0x6D)
*Apr 23 08:55:23.751: Se7/0:3 LCP: State is Open
*Apr 23 08:55:23.751: Se7/0:3 PPP: Phase is AUTHENTICATING, by this end
*Apr 23 08:55:23.751: Se7/0:3 CHAP: O CHALLENGE id 1 len 24 from "LAC"
*Apr 23 08:55:23.803: Se7/0:3 CHAP: I RESPONSE id 1 len 35 from "user@cisco.com"
*Apr 23 08:55:23.803: Se7/0:3 PPP: Phase is FORWARDING, Attempting Forward
*Apr 23 08:55:23.807:  Tnl/Sn 18693/19 L2TP: Session FS enabled
*Apr 23 08:55:23.807:  Tnl/Sn 18693/19 L2TP: Session state change 
from idle to wait-for-tunnel
*Apr 23 08:55:23.807: Se7/0:3 Tnl/Sn 18693/19 L2TP: Create session
*Apr 23 08:55:23.807:  Tnl 18693 L2TP: SM State idle
*Apr 23 08:55:23.807:  Tnl 18693 L2TP: O SCCRQ 
*Apr 23 08:55:23.807:  Tnl 18693 L2TP: Control channel retransmit delay 
set to 1 seconds
*Apr 23 08:55:23.807:  Tnl 18693 L2TP: Tunnel state change from idle to 
wait-ctl-reply
*Apr 23 08:55:23.807:  Tnl 18693 L2TP: SM State wait-ctl-reply
*Apr 23 08:55:23.815:  Tnl 18693 L2TP: I SCCRP from LNS1
*Apr 23 08:55:23.815:  Tnl 18693 L2TP: Got a challenge from remote peer, LNS1
*Apr 23 08:55:23.815:  Tnl 18693 L2TP: Got a response from remote peer, LNS1
*Apr 23 08:55:23.815:  Tnl 18693 L2TP: Tunnel Authentication success
*Apr 23 08:55:23.815:  Tnl 18693 L2TP: Tunnel state change from 
wait-ctl-reply to established
*Apr 23 08:55:23.815:  Tnl 18693 L2TP: O SCCCN  to LNS1 tnlid 28416
*Apr 23 08:55:23.815:  Tnl 18693 L2TP: Control channel retransmit 
delay set to 1 seconds
*Apr 23 08:55:23.815:  Tnl 18693 L2TP: SM State established
*Apr 23 08:55:23.815: Se7/0:3 Tnl/Sn 18693/19 L2TP: O ICRQ to LNS1 28416/0
*Apr 23 08:55:23.815: Se7/0:3 Tnl/Sn 18693/19 L2TP: Session state change 
from wait-for-tunnel to wai
t-reply
*Apr 23 08:55:23.831: Se7/0:3 Tnl/Sn 18693/19 L2TP: O ICCN to LNS1 28416/21
*Apr 23 08:55:23.831:  Tnl 18693 L2TP: Control channel retransmit delay 
set to 1 seconds
*Apr 23 08:55:23.831: Se7/0:3 Tnl/Sn 18693/19 L2TP: Session state change 
from wait-reply to establis
hed
*Apr 23 08:55:23.831: Se7/0:3 Tnl/Sn 18693/19 L2TP: VPDN session up
*Apr 23 08:55:23.831: Se7/0:3 PPP: Phase is FORWARDED, Session Forwarded
*Apr 23 08:55:23.831: Se7/0:3 PPP: Process pending packets
LAC#

Resultado de depuración - LNS1

El resultado de la depuración en LNS1 es el siguiente:

LNS1#
.Apr 23 08:57:08.900: L2TP: I SCCRQ from LAC tnl 18693
.Apr 23 08:57:08.900:  Tnl 28416 L2TP: Got a challenge in SCCRQ, LAC
.Apr 23 08:57:08.900:  Tnl 28416 L2TP: New tunnel created for remote LAC, 
address 10.48.74.128
.Apr 23 08:57:08.904:  Tnl 28416 L2TP: O SCCRP  to LAC tnlid 18693
.Apr 23 08:57:08.904:  Tnl 28416 L2TP: Control channel retransmit delay 
set to 1 seconds
.Apr 23 08:57:08.904:  Tnl 28416 L2TP: Tunnel state change from idle to 
wait-ctl-reply
.Apr 23 08:57:08.908:  Tnl 28416 L2TP: I SCCCN from LAC tnl 18693
.Apr 23 08:57:08.908:  Tnl 28416 L2TP: Got a Challenge Response in 
SCCCN from LAC
.Apr 23 08:57:08.912:  Tnl 28416 L2TP: Tunnel Authentication success
.Apr 23 08:57:08.912:  Tnl 28416 L2TP: Tunnel state change from 
wait-ctl-reply to established
.Apr 23 08:57:08.912:  Tnl 28416 L2TP: SM State established
.Apr 23 08:57:08.912:  Tnl 28416 L2TP: I ICRQ from LAC tnl 18693
.Apr 23 08:57:08.916:  Tnl/Sn 28416/21 L2TP: Session FS enabled
.Apr 23 08:57:08.916:  Tnl/Sn 28416/21 L2TP: Session state change 
from idle to wait-connect
.Apr 23 08:57:08.916:  Tnl/Sn 28416/21 L2TP: New session created
.Apr 23 08:57:08.916:  Tnl/Sn 28416/21 L2TP: O ICRP to LAC 18693/19
.Apr 23 08:57:08.920:  Tnl 28416 L2TP: Control channel retransmit 
delay set to 1 seconds
.Apr 23 08:57:08.924:  Tnl/Sn 28416/21 L2TP: 
I ICCN from LAC tnl 18693, cl 19
.Apr 23 08:57:08.924: user@cisco.com Tnl/Sn 28416/21 L2TP: 
Session state change from wait-connect to wait-for-service-selection
.Apr 23 08:57:08.932: ppp13 PPP: Phase is ESTABLISHING
.Apr 23 08:57:08.932: ppp13 LCP: I FORCED rcvd CONFACK len 11
.Apr 23 08:57:08.932: ppp13 LCP:    AuthProto CHAP (0x0305C22305)
.Apr 23 08:57:08.936: ppp13 LCP:    MagicNumber 0x050E44FB (0x0506050E44FB)
.Apr 23 08:57:08.936: ppp13 LCP: I FORCED sent CONFACK len 23
.Apr 23 08:57:08.936: ppp13 LCP:    MagicNumber 0x9028FFED (0x05069028FFED)
.Apr 23 08:57:08.936: ppp13 LCP:    EndpointDisc 1 user@cisco.com
.Apr 23 08:57:08.936: ppp13 LCP:     (0x1311017573657240636973636F2E636F)
.Apr 23 08:57:08.936: ppp13 LCP:     (0x6D)
.Apr 23 08:57:08.940: ppp13 PPP: Phase is FORWARDING, Attempting Forward
.Apr 23 08:57:08.948:  Tnl/Sn 30255/22 L2TP: Session FS enabled
.Apr 23 08:57:08.952:  Tnl/Sn 30255/22 L2TP: Session state change 
from idle to wait-for-tunnel
.Apr 23 08:57:08.952: uid:13 Tnl/Sn 30255/22 L2TP: Create session
.Apr 23 08:57:08.952:  Tnl 30255 L2TP: SM State idle
.Apr 23 08:57:08.952:  Tnl 30255 L2TP: O SCCRQ 
.Apr 23 08:57:08.956:  Tnl 30255 L2TP: Control channel retransmit 
delay set to 1 seconds
.Apr 23 08:57:08.956:  Tnl 30255 L2TP: Tunnel state change from 
idle to wait-ctl-reply
.Apr 23 08:57:08.956:  Tnl 30255 L2TP: SM State wait-ctl-reply
.Apr 23 08:57:08.960:  Tnl 30255 L2TP: I SCCRP from LNS2
.Apr 23 08:57:08.960:  Tnl 30255 L2TP: Got a challenge from remote peer, LNS2
.Apr 23 08:57:08.964:  Tnl 30255 L2TP: Got a response from remote peer, LNS2
.Apr 23 08:57:08.964:  Tnl 30255 L2TP: Tunnel Authentication success
.Apr 23 08:57:08.964:  Tnl 30255 L2TP: Tunnel state change from 
wait-ctl-reply to established
.Apr 23 08:57:08.964:  Tnl 30255 L2TP: O SCCCN  to LNS2 tnlid 35837
.Apr 23 08:57:08.968:  Tnl 30255 L2TP: Control channel retransmit 
delay set to 1 seconds
.Apr 23 08:57:08.968:  Tnl 30255 L2TP: SM State established
.Apr 23 08:57:08.968: uid:13 Tnl/Sn 30255/22 L2TP: O ICRQ to LNS2 35837/0
.Apr 23 08:57:08.968: uid:13 Tnl/Sn 30255/22 L2TP: Session state 
change from wait-for-tunnel to wait-reply
.Apr 23 08:57:08.972: uid:13 Tnl/Sn 30255/22 L2TP: O ICCN to LNS2 35837/9
.Apr 23 08:57:08.976:  Tnl 30255 L2TP: Control channel retransmit 
delay set to 1 seconds
.Apr 23 08:57:08.976: uid:13 Tnl/Sn 30255/22 L2TP: Session state 
change from wait-reply to established
.Apr 23 08:57:08.976: uid:13 Tnl/Sn 30255/22 L2TP: VPDN session up
.Apr 23 08:57:08.980: ppp13 PPP: Phase is FORWARDED, Session Forwarded
.Apr 23 08:57:08.984: user@cisco.com Tnl/Sn 28416/21 L2TP: 
Session state change from wait-for-service-selection to established
.Apr 23 08:57:08.984: user@cisco.com Tnl/Sn 28416/21 L2TP: VPDN session up
.Apr 23 08:57:08.984: ppp13 PPP: Process pending ncp packets
LNS1#

Salida de los depuradores – LNS2

La salida de los debugs en el LNS2 es como sigue:

LNS2#
*Apr 23 08:57:59.615: L2TP: I SCCRQ from LNS1 tnl 30255
*Apr 23 08:57:59.615:  Tnl 35837 L2TP: Got a challenge in SCCRQ, LNS1
*Apr 23 08:57:59.615:  Tnl 35837 L2TP: New tunnel created for remote LNS1, 
address 10.11
.0.1
*Apr 23 08:57:59.615:  Tnl 35837 L2TP: O SCCRP  to LNS1 tnlid 30255
*Apr 23 08:57:59.615:  Tnl 35837 L2TP: Control channel retransmit delay 
set to 1 seconds
*Apr 23 08:57:59.615:  Tnl 35837 L2TP: Tunnel state change from idle to 
wait-ctl-reply
*Apr 23 08:57:59.623:  Tnl 35837 L2TP: I SCCCN from LNS1 tnl 30255
*Apr 23 08:57:59.623:  Tnl 35837 L2TP: Got a Challenge Response in 
SCCCN from LNS1
*Apr 23 08:57:59.623:  Tnl 35837 L2TP: Tunnel Authentication success
*Apr 23 08:57:59.623:  Tnl 35837 L2TP: Tunnel state change from 
wait-ctl-reply to establ
ished
*Apr 23 08:57:59.623:  Tnl 35837 L2TP: SM State established
*Apr 23 08:57:59.627:  Tnl 35837 L2TP: I ICRQ from LNS1 tnl 30255
*Apr 23 08:57:59.627:  Tnl/Sn 35837/9 L2TP: Session FS enabled
*Apr 23 08:57:59.627:  Tnl/Sn 35837/9 L2TP: Session state change 
from idle to wait-conne
ct
*Apr 23 08:57:59.627:  Tnl/Sn 35837/9 L2TP: New session created
*Apr 23 08:57:59.627:  Tnl/Sn 35837/9 L2TP: O ICRP to LNS1 30255/22
*Apr 23 08:57:59.627:  Tnl 35837 L2TP: Control channel retransmit 
delay set to 1 seconds
*Apr 23 08:57:59.635:  Tnl/Sn 35837/9 L2TP: I ICCN from LNS1 tnl 30255, cl 22
*Apr 23 08:57:59.635: user@cisco.com Tnl/Sn 35837/9 L2TP: Session state
change from wait - connect to wait-for-service-selection
*Apr 23 08:57:59.635: ppp8 PPP: Phase is ESTABLISHING
*Apr 23 08:57:59.635: ppp8 LCP: I FORCED rcvd CONFACK len 11
*Apr 23 08:57:59.635: ppp8 LCP:    AuthProto CHAP (0x0305C22305)
*Apr 23 08:57:59.635: ppp8 LCP:    MagicNumber 0x050E44FB (0x0506050E44FB)
*Apr 23 08:57:59.635: ppp8 LCP: I FORCED sent CONFACK len 23
*Apr 23 08:57:59.635: ppp8 LCP:    MagicNumber 0x9028FFED (0x05069028FFED)
*Apr 23 08:57:59.635: ppp8 LCP:    EndpointDisc 1 user@cisco.com
*Apr 23 08:57:59.635: ppp8 LCP:     (0x1311017573657240636973636F2E636F)
*Apr 23 08:57:59.635: ppp8 LCP:     (0x6D)
*Apr 23 08:57:59.635: ppp8 PPP: Phase is FORWARDING, Attempting Forward
*Apr 23 08:57:59.639: ppp8 PPP: Phase is AUTHENTICATING, Unauthenticated User
*Apr 23 08:57:59.639: ppp8 PPP: Phase is FORWARDING, Attempting Forward
*Apr 23 08:57:59.639: VT[Vi2]:Sending vaccess request, id 0x73000015
*Apr 23 08:57:59.639: VT:Processing vaccess requests, 1 outstanding
*Apr 23 08:57:59.639: VT:Create and clone subif, base Vi2 Vt1
*Apr 23 08:57:59.639: VT[Vi2.1]:Reuse subinterface, recycle queue size 1
*Apr 23 08:57:59.639: VT[Vi2.1]:Recycled subinterface becomes Vi2.1
*Apr 23 08:57:59.639: VT[Vi2.1]:Cloning a recycled vaccess
*Apr 23 08:57:59.639: VT[Vi2.1]:Processing vaccess response, 
id 0x73000015, result success (1)
*Apr 23 08:57:59.643: Vi2.1 Tnl/Sn 35837/9 L2TP: 
Virtual interface created for user@cisco.com, bandwidth 64 Kbps
*Apr 23 08:57:59.643: Vi2.1 Tnl/Sn 35837/9 L2TP: VPDN session up
*Apr 23 08:57:59.643: Vi2.1 Tnl/Sn 35837/9 L2TP: 
Session state change from wait-for-service-selection to established
*Apr 23 08:57:59.643: Vi2.1 PPP: Phase is AUTHENTICATING, Authenticated User
*Apr 23 08:57:59.643: Vi2.1 CHAP: O SUCCESS id 1 len 4
*Apr 23 08:57:59.643: Vi2.1 PPP: Phase is UP
*Apr 23 08:57:59.643: Vi2.1 PPP: Process pending ncp packets
*Apr 23 08:57:59.643: Vi2.1 IPCP: O CONFREQ [Closed] id 1 len 10
*Apr 23 08:57:59.643: Vi2.1 IPCP:    Address 192.168.1.1 (0x0306C0A80101)
*Apr 23 08:57:59.667: Vi2.1 IPCP: I CONFREQ [REQsent] id 125 len 10
*Apr 23 08:57:59.667: Vi2.1 IPCP:    Address 0.0.0.0 (0x030600000000)
*Apr 23 08:57:59.667: Vi2.1 AAA/AUTHOR/IPCP: Start.  Her address 0.0.0.0, 
we want 0.0.0.0
*Apr 23 08:57:59.667: Vi2.1 AAA/AUTHOR/IPCP: Done.  Her address 0.0.0.0, 
we want 0.0.0.0
*Apr 23 08:57:59.667: Vi2.1: Pools to search : VpdnUsers
*Apr 23 08:57:59.667: Vi2.1: Pool VpdnUsers returned address = 192.168.1.2
*Apr 23 08:57:59.667: Vi2.1 IPCP: Pool returned 192.168.1.2
*Apr 23 08:57:59.667: Vi2.1 IPCP: O CONFNAK [REQsent] id 125 len 10
*Apr 23 08:57:59.667: Vi2.1 IPCP:    Address 192.168.1.2 (0x0306C0A80102)
*Apr 23 08:57:59.683: Vi2.1 IPCP: I CONFACK [REQsent] id 1 len 10
*Apr 23 08:57:59.683: Vi2.1 IPCP:    Address 192.168.1.1 (0x0306C0A80101)
*Apr 23 08:57:59.699: Vi2.1 IPCP: I CONFREQ [ACKrcvd] id 126 len 10
*Apr 23 08:57:59.699: Vi2.1 IPCP:    Address 192.168.1.2 (0x0306C0A80102)
*Apr 23 08:57:59.699: Vi2.1 IPCP: O CONFACK [ACKrcvd] id 126 len 10
*Apr 23 08:57:59.699: Vi2.1 IPCP:    Address 192.168.1.2 (0x0306C0A80102)
*Apr 23 08:57:59.699: Vi2.1 IPCP: State is Open
*Apr 23 08:57:59.703: Vi2.1 IPCP: Install route to 192.168.1.2
*Apr 23 08:57:59.703: Vi2.1 IPCP: Add link info for cef entry 192.168.1.2
LNS2#

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 9497