Switching de LAN : Inter-Switch Link (ISL)

Configurar la conexión troncal de ISL entre los switches de Catalyst que funcionan con CatOS y el software del sistema del Cisco IOS

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (7 Octubre 2015) | Comentarios


Contenido


Introducción

Este documento proporciona las configuraciones de muestra para el enlace del Inter-Switch Link (ISL) entre un Cisco Catalyst 5000 Switch que funcione con el Catalyst OS (CatOS) y un Catalyst 6500 Switch que funcione con el software del sistema de Cisco IOS�. Puede utilizar cualquiera de estos switches en este escenario para obtener los mismos resultados:

  • Cualquier Catalyst 4500/4000, 5500/5000, o 6500/6000 Series conmuta que los funcionamientos CatOS

  • Cualquier Catalyst 4500/4000 o Catalyst 6500/6000 Series conmuta que software del sistema del Cisco IOS de los funcionamientos

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Catalyst 5000 Switch que funciona con el software de CatOS 6.1(1)

  • Catalyst 6509 Switch que funciona con el Cisco IOS Software Release 12.1(4)E1

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Para más información sobre el ambiente de laboratorio, vea la sección del diagrama de la red de este documento. Asegúrese de que usted entienda el impacto potencial de cualquier configuración o comando en su red antes de que usted la utilice. Las configuraciones en todos los dispositivos fueron borradas con los comandos clear config all y write erase para asegurar una configuración predeterminada.

Teoría Precedente

El enlace es una manera de llevar el tráfico de varios VLA N sobre un link punto a punto entre dos dispositivos. Dos maneras de las cuales usted puede implementar los troncales Ethernet son:

  • ISL (un protocolo de propietario de Cisco)

  • IEEE 802.1Q (una norma IEEE)

Este documento sólo incluye los archivos de configuración de los switches y los resultados de los comandos show de muestra relacionados. Para los detalles en cómo configurar un troncal ISL entre los switches de Catalyst, refiera a estos documentos:

Notas importantes

  • El Switches de las 4500/4000 Series del Catalyst (que incluyen el Catalyst 2948G y el Catalyst 2980G) ese enlace del 802.1Q del soporte de CatOS del funcionamiento solamente. Este Switches no soporta la conexión troncal de ISL.

  • Los Catalyst 4000 Switch con un Supervisor Engine II+ o Cisco IOS Software más adelante por abandono funcionado con. Este Switches apoya el ISL y a los modos de concentración links del 802.1Q en todas las interfaces excepto en el bloqueo de los puertos Gigabit en los módulos WS-X4418-GB y S-X4412-2GB-T. En estos casos, el Switches soporta solamente el enlace del 802.1Q. Los puertos 3 a 18 están bloqueando los puertos Gigabit en el módulo WS-X4418-GB. Los puertos 1 a 12 están bloqueando los puertos Gigabit en el módulo WS-X4412-2GB-T. El término “puerto de bloqueo” significa que la conexión del puerto al backplane es oversubscribed.

  • Cualquier acceso de Ethernet en un Catalyst 6500/6000 Series Switch soporta el 802.1Q y la encapsulación ISL.

  • De acuerdo con el módulo, el Catalyst 5000 los puertos con capacidad de tronco admiten la encapsulación ISL solamente o soporta el ISL y el 802.1Q. La mejor manera de determinar los tipos de encapsulación admitidos es utilizar el comando show port capabilities. La salida de comando estado explícitamente la capacidad de conexión de troncal, pues este ejemplo muestra:

    cat5000> show port capabilities 3
    Model                    WS-X5225R
    Port                     3/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1Q, ISL
    
    !--- This particular port supports both 802.1Q and ISL.
    
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  3/1-2,3/1-4
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off,on)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(none),tx-(none)
    CoS rewrite              yes
    ToS rewrite              IP-Precedence
    Rewrite                  no
    UDLD                     yes
    AuxiliaryVlan            1..1000,1025..4094,untagged,dot1p,none
    SPAN                     source,destination
  • Esté seguro que los modos de concentración links hacen juego a través del link de troncal. Si usted configura un lado del link como troncal ISL, usted debe configurar el otro lado del link como ISL. Semejantemente, si usted configura un lado del link como 802.1Q, usted debe configurar el otro lado del link como 802.1Q.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/8759/66a.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Nota: Este documento visualiza los comentarios y las explicaciones en los en color azules y en cursiva dentro de las configuraciones.

Catalyst 5000 Switch
#version 6.1(1)
!
set option fddi-user-pri enabled
set password $2$h/BN$i3S54iNvIXknFelh6gOve0
set enablepass $2$DpAu$/mw1ZxL5I8ymR.yn85ovB/
!
#errordetection
set errordetection portcounter enable
!
#system
set system name  cat5000
!
#frame distribution method
set port channel all distribution mac both
!
#vtp

!--- In the example, the VLAN Trunk Protocol (VTP) mode is set to be transparent.
!--- Use your network as a basis to set the VTP mode.

set vtp mode transparent

!--- For details on VTP, refer to Configuring VTP.


set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm
set vlan 2
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state acti
ve mode srb aremaxhop 7 stemaxhop 7 backupcrf off
!
#ip

!--- This is the IP address that is used for management.

set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255
 
!
#set boot command
set boot config-register 0x10f
set boot system flash bootflash:cat5000-sup3.6-1-1.bin
!
#mls
set mls nde disable
!
# default port status is enable
!
!
#module 1 : 0-port Supervisor III
!
#module 2 empty
!
#module 3 : 9-port Gigabit Ethernet
!
#module 4 : 24-port 10/100BaseTX Ethernet
!
#module 5 : 24-port 10/100BaseTX Ethernet

!--- Ports 5/13–24 have been assigned to VLAN 2.

set vlan 2 5/13-24


!--- The ISL trunking mode is set to "on".
!--- Use your network and requirements as a basis to set the trunking mode.

set trunk 5/1 on isl 1-1005

!--- For details on different trunking modes, refer to 
!--- Configuring VLAN Trunks on Fast Ethernet and Gigabit Ethernet Ports.


!--- PortFast has been enabled on the ports that are connected to the workstations.

set spantree portfast 5/2-24 enable

!--- For details on why to enable PortFast, refer to
!--- Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays.

end

Catalyst 6500 Switch
Current configuration : 4207 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6000
!
boot buffersize 126968
boot bootldr bootflash:c6msfc-boot-mz.121-4.E1.bin
no logging console

!--- The example uses the privileged mode password.

enable password mysecret
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
no ip domain-lookup
!
ip cef
cns event-service server
!
!
!
interface gigabitethernet1/1
 no ip address
 shutdown
!
interface gigabitethernet1/2
 no ip address
 shutdown
!
interface fastethernet9/1
 no ip address


!--- Issue the switchport command once, without any keywords, 
!--- in order to configure the interface as a Layer 2 (L2) port for the Catalyst 6500.
!--- For details, refer to Configuring Layer 2 Ethernet Interfaces (Catalyst 6500).
!--- On a Catalyst 4000 switch that runs Cisco IOS Software, all ports are 
!--- L2 ports by default. If there is no change to the default configuration, 
!--- you do not need to issue the switchport command.
!--- For details, refer to Configuring Layer 2 Ethernet Interfaces (Catalyst 4000).

 switchport

!--- Configure trunk encapsulation as ISL.

 switchport trunk encapsulation isl


!--- Enable trunking on the interface.

 switchport mode trunk
!

!--- Interfaces Fast Ethernet 9/2 through 9/24 are configured to be in access mode.
!--- For details, refer to the "Layer 2 Interface Modes" section of
!--- Configuring Layer 2 Ethernet Interfaces.

interface fastethernet9/2
 no ip address
 switchport
 switchport mode access
!
interface fastethernet9/3
 no ip address
 switchport
 switchport mode access
!

!--- Output suppressed.

!
interface fastethernet9/11
 no ip address
 switchport
 switchport mode access
!
interface fastethernet9/12
 no ip address
 switchport
 switchport mode access
!

!--- Interfaces Fast Ethernet 9/13 through 9/24 are placed in VLAN 2.

interface fastethernet9/13
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!
interface fastethernet9/14
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!

!--- Output suppressed.

!
interface fastethernet9/23
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!
interface fastethernet9/24
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!
interface fastethernet9/25
 no ip address
 shutdown
!

!--- Output suppressed.

!
interface fastethernet9/48
 no ip address
 shutdown
!
interface vlan1

!--- This is the IP address that is used for management.

 ip address 10.10.10.3 255.255.255.0
!
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line vty 0 4

!--- This example uses the Telnet password.

 password mysecret
login
!
end

Nota: Si usted asigna una interfaz a un VLA N que no exista, la interfaz apaga hasta que usted cree el VLA N en las bases de datos de VLAN. Si desea obtener más detalles, consulte la sección Creación o modificación de VLAN Ethernet en Configuración de VLAN.

Verificación

Comandos show

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Catalyst 5000 o Catalyst 6000 Switches ese funcionamiento CatOS

  • muestre el /port del módulo de las capacidades de puerto — Utilice este comando de marcar si el puerto es capaz del enlace.

    cat5000> (enable) show port capabilities 5/1
    Model                    WS-X5234
    Port                     5/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1Q,ISL
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  5/1-2,5/1-4
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off,on)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(none),TX(1q4t)
    COs rewrite              yes
    ToS rewrite              IP-Precedence
    Rewrite                  yes
    UDLD                     yes
    AuxiliaryVlan            1..1000,1025..4094,untagged,dot1p,none
    SPAN                     source,destination
  • muestre el /port del módulo del puerto — Este comando muestra el estatus de un puerto determinado y si es enlace.

    cat5000> (enable) show port 5/1
    Port  Name               Status     Vlan       Level  Duplex Speed Type
    ----- ------------------ ---------- ---------- ------ ------ ----- ------------
     5/1                     connected  trunk      normal a-full a-100 10/100BaseTX
    
    Port  AuxiliaryVlan AuxVlan-Status
    ----- ------------- --------------
     5/1  none          none          
    
    
    Port  Security Violation Shutdown-Time Age-Time Max-Addr Trap     IfIndex
    ----- -------- --------- ------------- -------- -------- -------- -------
     5/1  disabled  shutdown             0        0        1 disabled      66
    
    Port  Num-Addr Secure-Src-Addr   Age-Left Last-Src-Addr     Shutdown/Time-Left
    ----- -------- ----------------- -------- ----------------- ------------------
     5/1         0                 -        -                 -        -         -
    
    !--- Output suppressed.
    
    
  • muestre el /port del módulo troncal — Utilice este comando de verificar el estado de troncal y la configuración.

    cat5000> (enable) show trunk
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     5/1      on           isl            trunking      1
     
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     5/1      1-1005
     
    Port      Vlans allowed and active in management domain
    --------  ---------------------------------------------------------------------
     5/1      1-2
     
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     5/1      1-2
    
  • muestre el dominio del vtp — Utilice este comando de marcar la información VTP.

    cat5000> (enable) show vtp domain
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
                                     1            2           Transparent -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    6          1023             0               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    10.10.10.2      disabled disabled 2-1000

Switches del Catalyst 6500/6000 o Switches del Catalyst 4500/4000 que funciona con el Cisco IOS Software

  • muestre el trunk del /port del módulo del interface_type de las interfaces — Este comando le dice si el puerto es enlace.

    cat6000#show interfaces fastethernet 9/1 trunk
     
    Port      Mode         Encapsulation  Status        Native vlan
    Fa9/1     on           isl            trunking      1
     
    Port      Vlans allowed on trunk
    Fa9/1     1-1005
     
    Port      Vlans allowed and active in management domain
    Fa9/1     1-2,1002-1005
     
    Port      Vlans in spanning tree forwarding state and not pruned
    Fa9/1     1-2,1002-1005
  • demostración vlan — Este comando proporciona la información sobre los VLA N y los puertos que pertenecen a un VLAN determinado.

    cat6000#show vlan
     
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa9/2, Fa9/3, Fa9/4, Fa9/5
                                                    Fa9/6, Fa9/7, Fa9/8, Fa9/9
                                                    Fa9/10, Fa9/11, Fa9/12
    2    VLAN0002                         active    Fa9/13, Fa9/14, Fa9/15, Fa9/16
                                                    Fa9/17, Fa9/18, Fa9/19, Fa9/20
                                                    Fa9/21, Fa9/22, Fa9/23, Fa9/24
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    !--- Output suppressed.
    
    

Nota: Solamente esos puertos se configuran que mientras que se visualizan los puertos del nontrunk L2. Para los detalles, refiera a las interfaces de Ethernet que configuran para la sección del Layer 2 Switching de configurar las interfaces de Ethernet de la capa 2.

Troubleshooting

Use esta sección para resolver problemas de configuración.

El Switch no valida un cambio del VLAN nativo en un puerto troncal porque el puerto es un puerto Non-802.1Q

Este problema ocurre porque el puerto troncal no soporta la encapsulación del 802.1Q. Un VLAN nativo requiere el soporte del 802.1Q en un puerto. Si el puerto no tiene el soporte del 802.1Q, el Switch no permite un cambio del VLAN nativo.

el soporte del 802.1Q para el enlace es un factor dependiente del hardware. Publique el comando show port capabilities para marcar para saber si hay soporte del 802.1Q. La opción de encapsulación en la salida de los estados de comando show port capabilities el soporte del 802.1Q para el enlace.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 8759