IP : Protocolo mejorado de routing de gateway interior (EIGRP)

Redistribución de protocolos de ruteo

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Traducción Manual (19 Mayo 2008) | Inglés (22 Agosto 2015) | Comentarios


Contenido

RIP

Introducción

El uso de un Routing Protocol de hacer publicidad de las rutas que son aprendidas por algún otro medio, por ejemplo por otro Routing Protocol, las Static rutas, o directamente los Routeconectad, se llama redistribución. Mientras que ejecutar un Routing Protocol único en su operación entre redes IP entera es deseable, el ruteo de protocolo múltiple es común por varias razones, tales como fusiones de compañía, departamento múltiples manejados por los administradores de red múltiple, y entornos multi-vendor. La ejecución de diversos protocolos de ruteo a menudo forma parte del diseño de red. En cualquiera de los casos, tener un entorno de varios protocolos hace que la redistribución sea una necesidad.

Una redistribución puede causarse por diferencias en las características del protocolo de ruteo, tales como métricas, distancia administrativa y capacidades con y sin clase. Se deben tener en consideración estas diferencias para que la redistribución sea exitosa.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Software Release 12.2(10b) del ½ del ¿Â de Cisco IOSïÂ

  • Cisco 2500 Series Routers

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Métrica

Cuando redistribuye un protocolo en otro, recuerde que las métricas de cada protocolo tienen un rol importante en la redistribución. Cada protocolo utiliza las métricas diferentes. Por ejemplo, el Routing Information Protocol (RIP) métrico se basa en el conteo saltos, pero el Interior Gateway Routing Protocol (IGRP) y el Enhanced Interior Gateway Routing Protocol (EIGRP) utilizan una medición compuesta basada en el ancho de banda, el retardo, la confiabilidad, la carga, y la Unidad máxima de transmisión (MTU) (MTU), donde ancho de banda y el retardo es los únicos parámetros usados por abandono. Cuando las rutas son redistribuidas, debe definir una métrica comprensible para el protocolo receptor. Cuando se redistribuyen rutas, existen dos métodos para definir las métricas.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-a.gif

Solamente puede definir la medición para esa redistribución específica:

router rip
redistribute static metric 1
redistribute ospf 1 metric 1

O usted puede utilizar lo mismo métricos que un valor por defecto para toda la redistribución (usando el comando default-metric guarda el trabajo porque elimina la necesidad de definir el métrico por separado para cada redistribución.):

router rip
redistribute static
redistribute ospf 1
default-metric 1

Distancia administrativa

¿Si un router está funcionando con más de un Routing Protocol y aprende una ruta al mismo destino usando ambos Routing Protocol, después que la ruta se deba seleccionar como la mejor ruta? Cada protocolo utiliza su propio tipo de métrica para determinar la mejor ruta. Comparar las rutas con los tipos de métrica diferente no puede ser hecha. Las distancias administrativas se ocupan de este problema. Las distancias administrativas se asignan a las fuentes de router para que se elija el router de la fuente preferida como mejor ruta. Consulte Selección de ruta en routers Cisco para más información sobre distancias administrativas y selección de ruta.

Las distancias administrativas colaboran con la selección de ruta entre los distintos protocolos de ruteo, pero pueden causar problemas para la redistribución. Estos problemas pueden estar bajo la forma de loopes de la encaminamiento, problemas de convergencia, o encaminamiento ineficaz. Vea abajo para una topología y una descripción de un Posible problema.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-b.gif

En la topología anterior, si el R1 está ejecutando RIP y el R2 y el R5 están ejecutando tanto RIP como IGRP y redistribuyen el RIP dentro del IGRP, entonces hay un problema potencial. Por ejemplo, el R2 y el R5 aprenden de la red 192.168.1.0 desde el R1 utilizando RIP. Este conocimiento se redistribuye en el IGRP. R2 aprende acerca de la red 192.168.1.0 a través de R3, y R5 aprende acerca de esta red a través de R4 que usa IGRP. El IGRP tiene una distancia administrativa menor que el RIP (100 contra 120); por lo tanto, la ruta IGRP es qué se utiliza en la tabla de ruteo. Ahora hay un loop de ruteo potencial. Incluso si el horizonte de la fractura, o cualquier otra función significó ayudar a evitar el rutear de los loopes entra en el juego, allí sigue siendo un problema de convergencia.

Si R2 y R5 también redistribuyen IGRP en RIP (también conocida como redistribución mutua) y la red, 192.168.1.0, no está directamente conectada a R1 (R1 está recibiendo datos de otro router conectado en dirección ascendente), existe un potencial problema de que R1 perciba la red de R2 o R5 con una métrica mejor que la de la fuente original.

Nota: Los mecánicos de la redistribución de ruta son propietarios en los routeres Cisco. Las reglas para la redistribución en un router Cisco dictan que la ruta redistribuido esté presente en la tabla de ruteo. No es suficiente que la ruta esté presente en la topología de ruteo o la base de datos. Las rutas con una distancia administrativa menor (AD) están instaladas siempre en la tabla de ruteo. Por ejemplo, si una Static ruta se redistribuye en el IGRP en el R5, y entonces el IGRP redistribuido posteriormente en el RIP en el mismo router (R5), la Static ruta no se redistribuye en el RIP porque nunca consiguió ingresado en la tabla de ruteo de IGRP. Esto es debido al hecho de que las Static rutas tienen un AD de 1 y las rutas IGRP tiene un AD de 100 y la Static ruta está instalada en la tabla de ruteo. Para redistribuir la Static ruta en el IGRP en el R5, usted necesita utilizar el comando redistribute static bajo comando router rip.

El comportamiento predeterminado para el RIP, el IGRP y el EIGRP es hacer publicidad directamente de los Routeconectad cuando una declaración de la red bajo Routing Protocol incluye la subred de la interfaz conectada. Hay dos métodos para conseguir un Routeconectad:

  • Una interfaz se configura con una dirección IP y la máscara, esta subred correspondiente se considera un Routeconectad.

  • Una Static ruta se configura con solamente una interfaz saliente, y no un Next-Hop IP, esto también se considera un Routeconectad.

Router#conf t
   Router(config)#ip route 10.0.77.0 255.255.255.0 ethernet 0/0
   Router(config)#end

   Router#show ip route static
   10.0.0.0/24 is subnetted, 1 subnets
   S 10.0.77.0 is directly connected, Ethernet0/0

Un comando network configurado bajo el EIGRP, el RIP o el IGRP que incluye (o las “cubiertas”) a cualquiera de estos tipos de Routeconectad incluye esa subred para promoción.

Por ejemplo, si una interfaz tiene el direccionamiento 10.0.23.1 y máscara 255.255.255.0, la subred 10.0.23.0/24 es un Routeconectad y será hecha publicidad por estos Routing Protocol cuando se configura una declaración de la red como sigue:

router rip | igrp # | eigrp #
   network 10.0.0.0

Esta Static ruta, 10.0.77.0/24, también es hecha publicidad por estos Routing Protocol, porque es un Routeconectad y “es cubierto” por la declaración de la red.

Para consejos acerca de cómo evitar este problema, consulte la sección de este documento Evitar problemas por redistribución.

Sintaxis y ejemplos de la configuración de redistribución

IGRP y EIGRP

Esta salida muestra a un router IGRP/EIGRP que redistribuye los parásitos atmosféricos, el Open Shortest Path First (OSPF), el RIP, y las rutas del Intermediate System-to-Intermediate System (IS-IS).

router igrp/eigrp 1 
network 131.108.0.0 
redistribute static
redistribute ospf 1 
redistribute rip 
redistribute isis 
default-metric 10000 100 255 1 1500

El IGRP y el EIGRP necesitan cinco métricas al redistribuir otros protocolos: ancho de banda, retardo, confiabilidad, carga, y MTU, respectivamente. A continuación, encontrará un ejemplo de mediciones IGRP:

Métrico Valor
ancho de banda En las unidades de kilobites por segundo; 10000 para Ethernet
demora En las unidades de decenas de microsegundos; para los Ethernetes él is100 x 10 microsegundos = 1 ms
confiabilidad 255 para 100 por ciento de confiabilidad
carga Carga efectiva en el link, expresada como un número de 0 a 255 (255 es una carga del 100 por ciento)
MTU (unidad de transmisión básica) Mínimo MTU de la trayectoria; generalmente iguales que para la interfaz de Ethernet, que es 1500 bytes

Varios procesos IGRP y EIGRP pueden ejecutarse en el mismo router, con una redistribución entre ellos. Por ejemplo, IGRP1 e IGRP2 pueden funcionar en el mismo router. Sin embargo, funcionar con dos procesos del mismo protocolo en el mismo router es raramente necesario, y puede consumir la memoria y el CPU del router.

La redistribución del IGRP/EIGRP en otro proceso IGRP/EIGRP no requiere ninguna conversión métrica, tan no hay necesidad de definir la métrica o de utilizar el comando default-metric durante la redistribución.

Una Static ruta redistribuida toma la precedencia sobre la ruta de resumen porque la Static ruta tiene una distancia administrativa de 1 mientras que la ruta de resumen del eigrp tiene una distancia administrativa de 5. Esto sucede cuando una Static ruta se redistribuye con el uso de redistribuye los parásitos atmosféricos bajo proceso del eigrp y el proceso del eigrp tiene una ruta predeterminado.

OSPF

Esta salida muestra a un router para OSPF que redistribuye los parásitos atmosféricos, las rutas del RIP, IGRP, del EIGRP, y IS-IS.

router ospf 1 
network 131.108.0.0 0.0.255.255 area 0 
redistribute static metric 200 subnets
redistribute rip metric 200 subnets 
redistribute igrp 1 metric 100 subnets 
redistribute eigrp 1 metric 100 subnets 
redistribute isis metric 10 subnets

El OSPF métrico es un valor de costo basado en el ancho de banda 108 del link en los dígitos por segundo. Por ejemplo, el costo de OSPF de los Ethernetes es 10: 108/107 = 10

Nota: Si no hay métrica especificada, OSPF fija un valor predeterminado de 20 al redistribuir las rutas de todos los protocolos, a excepción de las rutas del Protocolo de puerta de enlace de frontera (BGP) que tiene una métrica de 1.

Cuando hay una red principal que es subnetted, usted necesita utilizar la palabra clave subred para redistribuir los protocolos en el OSPF. Sin esta palabra clave, OSPF solo redistribuye redes principales que no están conectadas en subredes.

Es posible funcionar con más de un proceso OSPF en el mismo router. sin embargo, la ejecución de más de un proceso del mismo protocolo es poco común y consume recursos de memoria del router y de la CPU.

Al redistribuir un proceso OSPF en otro, no necesita definir la métrica ni usar el comando default-metric.

RIP

Nota: Los principios en este documento se aplican a las versiones I y II del RIP.

Esta salida muestra a un router del RIP que redistribuye los parásitos atmosféricos, las rutas IGRP, del EIGRP, OSPF, y IS-IS.

router rip 
network 131.108.0.0 
redistribute static
redistribute igrp 1 
redistribute eigrp 1 
redistribute ospf 1 
redistribute isis 
default-metric 1

El RIP métrico se compone del conteo saltos, y la máxima métrica válida es 15. Cualquier cosa sobre 15 se considera infinito; puede utilizar 16 para describir una métrica infinita en RIP. Al redistribuir un protocolo en el RIP, Cisco recomienda que usted utiliza un valor bajo de la medición, tal como 1. Una medición de alto valor, tal como 10, los límites RASGA incluso más futuro. Si usted define un métrico de 10 para las rutas redistribuido, estas rutas se pueden hacer publicidad solamente al Routers hasta 5 saltos lejos, momento en el cual que el métrico (conteo saltos) excede de 15. Al definir una métrica de 1, se activa un router para que recorra una cantidad máxima de saltos en un dominio RIP. Pero, hacer esto aumenta la posibilidad de los loopes de la encaminamiento si hay puntas múltiples de la redistribución y un router aprende sobre la red con un mejor métrico de la punta de la redistribución que de la fuente original, como se explica en la sección de la distancia administrativa de este documento. Por lo tanto, usted tiene que aseegurarse que el métrico no es ninguno demasiado alto, evitando que sea hecha publicidad a todo el Routers, o demasiado bajo, el llevar a rutear coloca cuando hay puntas múltiples de la redistribución.

Redistribución de las Static rutas excepto el gateway de último recurso en el RIP usando el Route Map

Esta configuración es un ejemplo de redistribuir las Static rutas excepto el gateway del centro turístico más reciente del gateway en el RIP a través del routemap.

Configuración inicial por este ejemplo:

router rip

version 2

network 10.0.0.0

default-information originate

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.32.32.3

ip route 10.32.42.211 255.255.255.255 192.192.192.102

ip route 10.98.0.0 255.255.255.0 10.32.32.1

ip route 10.99.0.0 255.255.255.0 10.32.32.1

ip route 10.99.99.0 255.255.255.252 10.32.32.5

ip route 67.129.103.128 255.255.255.240 10.32.31.1

ip route 156.55.231.0 255.255.255.0 10.32.32.5

ip route 172.16.28.0 255.255.252.0 10.32.32.5

ip route 192.168.248.0 255.255.255.0 10.32.32.5

ip route 199.43.0.0 255.255.255.0 10.32.32.5

ip route 204.103.0.0 255.255.255.0 10.32.32.5

Complete estos pasos para configurar esto:

  1. Cree una lista de acceso para hacer juego todas las redes que necesite ser redistribuida

    Router#show access-lists 10
    
    Standard IP access list 10
    
        10 permit 10.32.42.211
    
        20 permit 10.98.0.0, wildcard bits 0.0.0.255
    
        30 permit 10.99.0.0, wildcard bits 0.0.0.255
    
        40 permit 67.129.103.128, wildcard bits 0.0.0.15
    
        50 permit 156.55.231.0, wildcard bits 0.0.0.255
    
        60 permit 172.16.28.0, wildcard bits 0.0.3.255
    
        70 permit 192.168.248.0, wildcard bits 0.0.0.255
    
        80 permit 199.43.0.0, wildcard bits 0.0.0.255
    
        90 permit 204.103.0.0, wildcard bits 0.0.0.255
  2. Llame esta lista de acceso en un route-map.

    Route-map TEST
    
     Match ip address 10
  3. Redistribuya en el RIP usando el route-map en y quite la información predeterminada originan el comando del proceso del RIP.

    Router RIP
    
    version 2
    
    network 10.0.0.0
    
    redistribute static route-map TEST
    
    no auto-summary

IS-IS

Esta salida muestra a un router IS-IS que redistribuye los parásitos atmosféricos, el RIP, el IGRP, el EIGRP, y las OSPF rutas.

router isis 
network 49.1234.1111.1111.1111.00
redistribute static
redistribute rip metric 20 
redistribute igrp 1 metric 20 
redistribute eigrp 1 metric 20 
redistribute ospf 1 metric 20

El IS-IS métrico debe estar entre 1 y 63. No hay opción del Default-metric en el IS-IS — usted debe definir un métrico para cada protocolo, tal y como se muestra en del ejemplo anterior. Si no es métrico se especifica para las rutas que son redistribuidas en el IS-IS, un valor métrico de 0 se utiliza por abandono.

Rutas conectadas

La redistribución directamente de las redes conectadas en los Routing Protocol no es una práctica común y no se muestra en los ejemplos anteriores uces de los por este motivo. Sin embargo, es importante observar que puede ser hecha, ambos directa e indirectamente. Para redistribuir directamente los Routeconectad, utilice el comando configuration del router conectado de la redistribución. Usted debe también definir un métrico en este caso. Usted puede también redistribuir indirectamente los Routeconectad en los Routing Protocol tal y como se muestra en de este ejemplo.

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-cnctd.gif

En este ejemplo, el Router B tiene dos interfaces Fast Ethernet. El FastEthernet0/0 está en la red 10.1.1.0/24 y el FastEthernet0/1 está en la red 20.1.1.0/24. El router B es EIGRP corriente con el router A, y el OSPF con el router C. Router B está redistribuyendo mutuamente entre el EIGRP y los procesos OSPF. Ésta es la información de configuración pertinente para el Router B:

router B
interface FastEthernet0/0
 ip address 10.1.1.4 255.255.255.0

interface FastEthernet0/1
 ip address 20.1.1.4 255.255.255.0

router eigrp 7
 redistribute ospf 7 metric 10000 100 255 1 1500
 network 10.1.1.0 0.0.0.255
 auto-summary
 no eigrp log-neighbor-changes
!
router ospf 7
 log-adjacency-changes
 redistribute eigrp 7 subnets
 network 20.1.1.0 0.0.0.255 area 0

Si observa la tabla de ruteo para el Router B, verá lo siguiente:

routerB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0

De la configuración y de la tabla de ruteo anteriores, hay tres elementos que debemos tener en cuenta:

  • Las redes en cuestión figuran en la tabla de ruteo del router B como redes con conexión directa.

  • La red 10.1.1.0/24 es parte del proceso EIGRP y la red 20.1.1.0/24 es parte del proceso OSPF.

  • El router B está redistribuyendo mutuamente entre el EIGRP y el OSPF.

A continuación, se encuentran las tablas de ruteo para los Routers A y C.

routerA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0
     20.0.0.0/24 is subnetted, 1 subnets
D EX    20.1.1.0 [170/284160] via 10.1.1.4, 00:07:26, FastEthernet0


routerC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet1
O E2    10.1.1.0 [110/20] via 20.1.1.4, 00:07:32, FastEthernet1

El router A ha aprendido sobre la red 20.1.1.0/24 vía el EIGRP, que se muestra como ruta externo, porque fue redistribuida del OSPF en el EIGRP. El C del router ha aprendido sobre la red 10.1.1.0/24 vía el OSPF como ruta externo, porque fue redistribuida del EIGRP en el OSPF. Aunque el router B no esté redistribuyendo las redes conectadas, hace publicidad de la red 10.1.1.0/24, que es parte de que el proceso EIGRP redistribuyó en el OSPF. Del mismo modo, el Router B anuncia la red 20.1.1.0/24, la cual es parte del proceso OSPF redistribuido en EIGRP.

Refiera a redistribuir las redes conectadas en el OSPF para más información sobre los Routeconectad que son redistribuidos en el OSPF.

Nota: Por abandono, solamente la información EBGP-docta es candidato que se redistribuirá en el IGP cuando publican el comando bgp del redistibute. Las rutas del IBGP no se redistribuyen en el IGP hasta que configuren al comando bgp redistribute-internal bajo comando router bgp. Pero las precauciones deben ser orden admitida para evitar los loopes dentro del sistema autónomo cuando las rutas del IBGP redistirbuted en el IGP.

Cómo evitar problemas debido a la redistribución

En la sección sobre distancia administrativa vio cómo la redistribución puede llegar a causar problemas potenciales tales como ruteo por debajo del nivel óptimo, loops de ruteo y convergencia lenta. Evitar estos tipos de problema es realmente muy simple — nunca anuncie la información recibida originalmente del proceso de ruteo X nuevamente dentro del proceso de ruteo X.

Ejemplo 1

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-b.gif

En la topología anterior, el r2 y el R5 están haciendo la redistribución recíproca. El RIP se está redistribuyendo en el IGRP y el IGRP está redistribuyendo en el RIP, pues esta configuración muestra.

R2:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2

R5:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2

Con la configuración previa usted tiene el potencial para cualquier el problemas descritos previamente. Para evitarlos, usted puede filtrar las actualizaciones de ruteo como sigue:

R2:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2
 
access-list 1 deny 192.168.1.0
access-list 1 permit any

R5:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1 
 
router rip
network 178.1.0.0

redistribute igrp 7 metric 2 
 
access-list 1 deny 192.168.1.0
access-list 1 permit any

Las listas de la distribución agregadas a las configuraciones, como se muestra arriba, filtran cualquier actualización de IGRP que entre en la interfaz del serial 1 del Routers. Si las rutas en las actualizaciones son permitidas por la lista de acceso 1, el router las valida en la actualización; de lo contrario no lo hace. En este ejemplo, están diciendo el Routers que él no debe aprender la red 192.168.1.0 a través de las actualizaciones de IGRP que él recibe en su interfaz del serial 1. es por ello que el único conocimiento que estos routers tienen con respecto a la red 192.168.1.0 es a través del RIP del R1.

También tenga presente que en este caso no es necesario utilizar la misma estrategia de filtrado para el proceso del RIP porque el RIP tiene una distancia administrativa más alta que el IGRP. Si las rutas que originan en el dominio de IGRP fueran alimentadas de nuevo al r2 y al R5 con el RIP, las rutas IGRP todavía tomarían la precedencia.

‘Ejemplo 2’

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-c.gif

Usando la topología como arriba, otro método, que es a veces más preferible, para evitar los problemas de redistribución puede ser demostrado. Este método usa mapas de rutas para establecer etiquetas para varias rutas. Los procesos de ruteo pueden entonces redistribuir basado en las etiquetas. Observe que la redistribución basada en las etiquetas no trabaja con la versión de RIP 1 o IGRP.

Uno de los problemas que usted puede funcionar con en la topología anterior es como sigue:

R1 anuncia la red 192.168.1.0 a R2. Luego R2 redistribuye a EIGRP. R5 conoce la red a través de EIGRP y la redistribuye a RIPv2. Dependiendo del métrico que el R5 fija para la ruta del RIPv2, el R6 pudo preferir la ruta menos conveniente con el R5 en vez del r1 directo para alcanzar la red. La siguiente configuración le ayuda a evitar esto por medio de la configuración de etiquetas y luego la redistribución basada en las etiquetas.

R2:

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1

!--- Redistributes RIP routes that are
 

!--- permitted by the route-map rip_to_eigrp




router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2

!--- Redistributes EIGRP routes and set the tags
 

!--- according to the eigrp_to_rip route-map



route-map rip_to_eigrp deny 10
match tag 88

!--- Route-map statement to deny any routes that have a tag of "88"


!--- from being redistributed into EIGRP
  

!--- Notice the routes tagged with "88" should be the EIGRP
 

!--- routes that are redistributed into RIPv2


route-map rip_to_eigrp permit 20
set tag 77

!--- Route-map statement to set the tag 


!--- on RIPv2 routes redistributed into EIGRP to "77"


route-map eigrp_to_rip deny 10
match tag 77

!--- Route-map statement to deny any routes that have a
 

!--- tag of "77" from being redistributed into RIPv2


!--- Notice the routes tagged with "77" should be the RIPv2
 

!--- routes that are redistributed into EIGRP



route-map eigrp_to_rip permit 20
set tag 88

!--- Route-map statement to set the tag on EIGRP
 

!--- routes redistributed into RIPv2 to "88"

R5:

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1

!--- Redistributes RIPv2 routes that are permitted 


!--- by the route-map rip_to_eigrp




router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2

!--- Redistributes EIGRP routes and sets the tags 


!--- according to the eigrp_to_rip route-map




route-map rip_to_eigrp deny 10
match tag 88

!--- Route-map statement to deny any routes that have a tag
 

!--- of "88" from being redistributed into EIGRP


!--- Notice the routes tagged with "88" should be the EIGRP routes
 

!--- that are redistributed into RIPv2


route-map rip_to_eigrp permit 20
set tag 77

!--- Route-map statement to set the tag on rip routes 


!--- redistributed into EIGRP to "77"


route-map eigrp_to_rip deny 10
match tag 77

!--- Route-map statement to deny any routes that have a tag 


!--- of "77" from being redistributed into RIPv2


!--- Notice the routes tagged with "77" should be the RIPv2 routes
 

!--- that are redistributed into EIGRP


route-map eigrp_to_rip permit 20
set tag 88

!--- Route-map statement to set the tag on EIGRP routes 


!--- redistributed into RIPv2 to "88"

Con la configuración antedicha realizada, usted puede mirar algunas rutas específicas en la tabla de ruteo para ver que se han fijado las etiquetas. Debajo de la salida de las demostraciones del comando show ip route para las rutas del específico en el R3 y el r1:

R3#show ip route 178.1.10.8
Routing entry for 178.1.10.8/30
  Known via "eigrp 7", distance 170, metric 2560512256
  Tag 77, type external
  Redistributing via eigrp 7
  Last update from 181.16.2.10 on Serial0, 00:07:22 ago
  Routing Descriptor Blocks:
  * 181.16.2.10, from 181.16.2.10, 00:07:22 ago, via Serial0
      Route metric is 2560512256, traffic share count is 1
      Total delay is 20010 microseconds, minimum bandwidth is 1 Kbit
      Reliability 1/255, minimum MTU 1 bytes
      Loading 1/255, Hops 1


R1#show ip route 181.16.2.4
Routing entry for 181.16.0.0/16
  Known via "rip", distance 120, metric 2
  Tag 88
  Redistributing via rip
  Last update from 178.1.10.5 on Serial0, 00:00:15 ago
  Routing Descriptor Blocks:
  * 178.1.10.5, from 178.1.10.5, 00:00:15 ago, via Serial0
      Route metric is 2, traffic share count is 1

El EIGRP utiliza cinco diversas variables para calcular el métrico. Sin embargo, las rutas redistribuido no tienen estos parámetros, que hace las rutas no ser fijada uniformemente. La mejor práctica es fijar un Default-metric al redistribuir las rutas. Fijando el métrico predeterminado, el funcionamiento del EIGRP puede ser mejorado. Para el EIGRP, los valores predeterminados se ingresan con este comando:

Router(config-router)#default-metric 10000 100 255 100 1500

Ejemplo 3

La redistribución también puede llevarse a cabo entre diferentes procesos del mismo protocolo de ruteo. La configuración siguiente es un ejemplo de una política de redistribución usada para redistribuir el proceso EIGRP dos que se ejecuta en el mismo router o en los routeres múltiples:

router eigrp 3
 redistribute eigrp 5 route-map to_eigrp_3
 default-metric 10000 100 255 1 1500

!--- Redistributes EIGRP 5 into EIGRP 3, setting the tags 


!--- according to the route map "to_eigrp_3"



router eigrp 5
 redistribute eigrp 3 route-map to_eigrp_5
 default-metric 10000 100 255 1 1500

!--- Redistributes EIGRP 3 into EIGRP 5


!--- Routes with tag 33 will not be redistributed
 

!--- due to route map "to_eigrp_5"
!--- Though the default-metric command is not required
!--- when redistributing between different EIGRP processes,
!--- you can use it optionally as shown above to advertise 
!--- the routes with specific values for calculating the metric.


route-map to_eigrp_3 deny 10
match tag 55

!--- Route-map statement used to deny any routes that have a tag
 

!--- of "55" from being redistributed into EIGRP 3


!--- Notice the routes tagged with "55" should be the EIGRP 3 routes
 

!--- that are redistributed into EIGRP 5


route-map to_eigrp_3 permit 20
 set tag 33

!--- Route-map statement used to set the tag on routes
 

!--- redistributed from EIGRP 5 to EIGRP 3 to "33"


route-map to_eigrp_5 deny 10
 match tag 33

!--- Route-map statement used to deny any routes that have a tag 


!--- of "33" from being redistributed into EIGRP 5


!--- Notice the routes tagged with "33" should be the EIGRP 5 routes
 

!--- that are redistributed into EIGRP 3


route-map to_eigrp_5 permit 20
set tag 55

!--- Route-map statement used to set the tag on routes
 

!--- redistributed from EIGRP 3 to EIGRP 5 to "55"

Éstos son apenas algunos ejemplos de la estrategia de filtrado usados para el intento de este documento. Sin embargo, pudo haber otras estrategias válidas que usted puede utilizar. Refiera a la sección en la información de ruteo de filtración en configurar las características IP Routing Protocol-Independent para más información.

Ejemplo 4

Por ejemplo, usted tiene dos Routers, uno es un protocolo BGP corriente del router de mayor capacidad, y el otro es protocolo de menor capacidad del RIP del funcionamiento del router. Cuando usted redistribuye las rutas BGP en el RIP, es posible que usted ve algunos paquetes llegar a ser perdidos.

La redistribución del BGP en el protocolo del RIP no se recomienda generalmente y los protocolos como el iBGP, el OSPF, y el EIGRP son scalable y tienen opciones amplias disponibles.

En caso de que usted encuentre este escenario, que es la redistribución entre el BGP A RASGAR, y pierda algún la más packest, él posible que usted tiene que configurar este comando en el proceso del RIP:

RIP de Router(Config)#router

Router (Config-router) # entrada-cola 1024

Nota: Considere el uso del comando input-queue si usted tiene un router de mayor capacidad que envíe en la velocidad a un router de poca velocidad que no pudo poder recibir en la velocidad. La configuración de este comando help previene la pérdida de información de la tabla de ruteo.

Ejemplo 5

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-d.gif

Este ejemplo ilustra la redistribución de la Static ruta en el RIP Routing Protocol. Según la topología, tenemos tres Routers (r1, r2, y R3). El r1 y el r2 tienen RIP configurado en el Ethernet0/0 de la interfaz fast. El r1 tiene una Static ruta para alcanzar el Lo 0 interfaces (IP Address 3.3.3.3/32) del router R3. Esta Static ruta se redistribuye en el RIP Routing Protocol. Configuran al router R3 con un FastEthernet0/0 de 0.0.0.0 0.0.0.0 de la ruta de IP de la ruta predeterminado R3#.

R1(config)# ip route 3.3.3.3 255.255.255.255 10.13.13.3
R1(config)# router rip
R1(config-router) redistribute static metric 10

En el r2 del router, la ruta 3.3.3.3 se puede considerar vía el comando show ip route:

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.12.12.0/24 is directly connected, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
R      3.3.3.3 [120/10] via 192.12.12.1, 00:00:07, FastEthernet0/0

Cómo redistribuir la sola Static ruta

Para redistribuir la sola Static ruta, utilice el route-map para seleccionar la Static ruta que necesita ser redistribuida.

Router(config)#access-list 1 permit <network no> <mask>

Router(config)#route-map <route-map name> permit 10
Router(config-route-map)#match ip address access list number

Router(config)#router eigrp <As number>

Router(config-router)#redistribute static route-map <map-name> metric <value>


Información Relacionada


Document ID: 8606