Routers : Routers Cisco de la serie 800

La configuración de un router 827 de Cisco como cliente PPPoE con NAT

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

En el Software Release 12.1(3)XG del ½ del ¿Â de Cisco IOSïÂ, una función de cliente del PPP over Ethernet (PPPoE) fue introducida para el Cisco 827 Router. La función permite que la funcionalidad PPPoE se traslade al router. Los PC múltiples se pueden instalar detrás del Cisco 827. Antes de que su tráfico se envíe a la sesión PPPoE, puede ser cifrado, filtrado, y así sucesivamente. También, el Network Address Translation (NAT) puede ejecutarse.

Este documento muestra un cliente PPPoE configurado en la interfaz ATM (la interfaz DSL) del router Cisco 827. Esta configuración también puede usarse en un router Cisco 1700 con una tarjeta de interfaz WAN (WIC) de línea de suscriptor digital asimétrica (ADSL).

La configuración del procesador de la ruta del nodo (NRP) de Cisco 6400 también puede aplicarse a otro router que se utiliza como un agregador y con una interfaz ATM.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección, le presentan con la información usada para configurar las características descritas en este documento.

Nota: Para encontrar la información adicional en los comandos usados en este documento, use la Command Lookup Tool (clientes registrados solamente).

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/8514/827pppoe_client.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

El PPPoE se configura en el Cisco 827 Router con los comandos del Virtual Private Dial Network (VPDN). Aseegurese le configurar estos comandos primero.

Nota: Para la información sobre cómo cambiar el tamaño de la Unidad máxima de transmisión (MTU) (MTU), refiera a la talla del MTU del troubleshooting en la conectividad de marcación PPPoE.

Cisco 827 Router
! 
vpdn enable 
no vpdn logging

!--- This is the default.

! 
vpdn-group pppoe 
 request-dialin     
 
!--- This is the PPPoE client that requests to establish a session  
 !--- with the aggregation unit (6400 NRP). 
 
  protocol pppoe 
! 


!--- This is the Internal Ethernet network.
 
! 
interface Ethernet0 
 ip address 10.92.1.182 255.255.255.0 
 ip nat inside 
  


!--- The DSL interface.
 
! 
interface ATM0 
 no ip address 
 no atm ilmi-keepalive
 bundle-enable
 dsl operating-mode auto
 hold-queue 224 in
 
!--- All defaults.

  


!--- PPPoE runs on top of AAL5SNAP. However, the 
!--- encap aal5snap command is not used.
  
! 
interface ATM0.1 point-to-point 
 pvc 1/1 
  pppoe-client dial-pool-number 1 
  
!--- pvc 1/1 is an example value that must be changed 
  !--- in order to match the value used by the ISP. 

 ! 



!--- The PPPoE client code ties into a dialer interface upon  
!--- which a virtual-access interface is cloned.  

! 
interface Dialer1 
 ip address negotiated 
 ip mtu 1492
 
!--- Ethernet MTU is 1500 by default -- 1492 + PPPoE headers = 1500

 ip nat outside 
 encapsulation ppp 
 dialer pool 1
 
!--- Ties to ATM interface.
  
 ppp authentication chap callin 
 ppp chap hostname <username> 
 ppp chap password <password> 
! 

!--- Note: The ISP  instructs you  about the 
!--- type of authentication to use. 
!--- In order to change from PPP CHAP to PPP PAP, replace
!--- ppp authentication chap callin 
!--- ppp chap hostname <username> 
!--- ppp chap password <password>   
!--- with ppp authentication pap callin
!--- ppp pap sent-username <username> password <password>




!--- For NAT, overload on the Dialer1 interface 
!--- and add a default route out since dialer IP address can change. 
  
ip nat inside source list 1 interface Dialer1 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 dialer1 
no ip http server 
! 
access-list 1 permit 10.92.1.0 0.0.0.255

!--- For NAT.

! 

Cisco 6400 NRP
*** local ppp user 

!--- Or,  use AAA.


username <username> password <password>



!--- Begin with the VPDN commands. 
!--- Notice that the PPPoE is bound here to 
!--- a virtual-template instead of on the ATM interface. 
!--- You cannot (at this time) use more than one 
!--- virtual-template (or VPDN group) for PPPoE that begins  
!--- with the VPDN commands. 

vpdn enable 
no vpdn logging 
! 
vpdn-group pppoe 
 accept-dialin
 
!--- PPPoE server mode.
 
  protocol pppoe 
  virtual-template 1 
! 
! 
interface ATM0/0/0 
 no ip address 
 no atm ilmi-keepalive 
 hold-queue 500 in 



!--- The binding to the virtual-template 
!--- interface is configured in the VPDN group.
  
! 
interface ATM0/0/0.182 point-to-point 
 pvc 1/82 
  encapsulation aal5snap
  
!--- Needs the command on the server side. 

  protocol pppoe 
 ! 
! 



!--- Virtual-template is used instead of dialer interface.
 
! 
interface Virtual-Template1 
 ip unnumbered Loopback10 
 ip mtu 1492 
 peer default ip address pool ippool 
 ppp authentication chap 
! 
! 
interface Loopback10 
 ip address 8.8.8.1 255.255.255.0 
! 
ip local pool ippool 9.9.9.1 9.9.9.5 

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de ejecutar un comando de depuración, consulte Información importante sobre comandos de depuración.

Haga el debug de al Cliente de PPPoE

Para hacer el debug de al Cliente de PPPoE en el Cisco 827 Router o el Cisco 6400 NRP, usted debe considerar la pila del protocolo. Usted puede comenzar a resolver problemas en la parte inferior.

1. Capa física DSL

Aseegurese la línea es ascendente y entrenado.

show interface atm0 

ATM0 is up, line protocol is up 
  Hardware is PQUICC_SAR (with Alcatel ADSL Module) 
 
show dsl interface atm0 

!--- Look for "Showtime" in the first few lines.


                ATU-R (DS)                      ATU-C (US) 
Modem Status:    Showtime (DMTDSL_SHOWTIME) 

2. Capa ATM

Si la interfaz ATM está para arriba, utilice el comando debug atm packets de ver si cualquier cosa viene adentro del ISP.

Nota: No observará los paquetes salientes mediante este comando debido a la forma en que los paquetes son procesados.

Debería poder observar un resultado similar a éste, con los mismos campos de Type, SAP, CTL y OUI, que muestren que el paquete ATM entrante es AAL5SNAP.

debug atm packet 
03:21:32: ATM0(I): 
VCD:0x2 VPI:0x1 VCI:0x1 Type:0x0 SAP:AAAA CTL:03 OUI:0080C2 
TYPE:0007 Length:0x30 
03:21:32: 0000 0050 7359 35B7 0001 96A4 84AC 8864 1100 0001 
000E C021 09AB 000C 0235 
03:21:32: 279F 0000 0000 
03:21:32: 

3. Capa Ethernet

Las tramas Ethernet completas están en los paquetes del AAL5SNAP. No existe ningún comando debug Ethernet packet. Sin embargo, usted necesita realizar algunos debugs VPDN para ver las tramas PPPoE.

Para la referencia, una trama Ethernet que es una trama PPPoE contiene uno de dos Ethertypes:

  • 0x8863 Ethertype = paquete de control PPPoE (administra la sesión PPPoE)

  • 0x8864 Ethertype = Paquete de datos PPPoE (contiene paquetes PPP)

Es importante resaltar que hay dos sesiones en PPPoE. La sesión PPPoE, que es una sesión de tipo VPDN L2TP y la sesión PPP. Por lo tanto, para establecer el PPPoE, usted tiene fase de establecimiento de sesión PPPoE y una fase de establecimiento de la sesión PPP.

La terminación involucra una fase de terminación PPP y una fase de terminación PPPoE.

La fase de establecimiento de PPPoE consiste en la identificación del Cliente de PPPoE y del servidor (las direcciones MAC), y la asignación de un ID de sesión. Después de que esto sea completo, el establecimiento normal PPP ocurre apenas como cualquier otra conexión PPP.

Para hacer el debug de, utilizar los debugs del pppoe VPDN para ayudarle a determinar si la fase de conexión del pppoe es acertada.

#debug vpdn pppoe-events 

06:17:58: Sending PADI: vc=1/1

!--- A broadcast Ethernet frame (in  this case encapsulated in ATM) 
!--- that requests  a PPPoE server, "Are there any PPPoE servers out there?" 


06:18:00:  PPPOE: we've got our pado and the pado timer went off 

!--- This is a unicast reply from a PPPoE server 
!--- (very similar to a DHCP offer).


06:18:00: OUT PADR from PPPoE tunnel

!--- This is a unicast reply that accepts the offer.


06:18:00: IN PADS from PPPoE tunnel

!--- This is a confirmation and the establishment completes.

El establecimiento PPP comienza como en cualquier otra iniciación de PPP. Después de que establezcan a la sesión PPPoE, utilice los comandos show vpdn para conseguir el estatus.

#show vpdn
%No active L2TP tunnels 
%No active L2F tunnels 

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1

PPPoE Session Information
SID  RemMAC           LocMAC      Intf  VASt  OIntf   VC 
1  0050.7359.35b7  0001.96a4.84ac  Vi1  UP     AT0    1   1

Usted puede conseguir la información de cuenta de paquetes usando el comando show vpdn session all.

show vpdn session all
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1

session id: 1
local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7 
virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1 
    1656 packets sent, 1655 received, 24516 bytes sent, 24486 received

Otros comandos de depuración:

  • debug vpdn pppoe-data

  • debug pppoe-errors

  • debug pppoe-packets

Capa PPP

Después de que hayan establecido a la sesión PPPoE, los debugs PPP son lo mismo que para cualquier otro establecimiento PPP.

Se utilizan los mismos comandos debug ppp negotiation y debug ppp authentication Ésta es una salida de ejemplo.

Nota: En esta muestra, el nombre de host es el "client1" y el nombre del Cisco 6400 remoto NRP es “Nrp-b”.

06:36:03: Vi1 PPP: Treating connection as a callout
06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
06:36:03: Vi1 PPP: No remote authentication for call-out
06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: State is Open
06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b" 
06:36:05: Vi1 CHAP: Using alternate hostname client1
06:36:05: Vi1 CHAP: Username nrp-b not found
06:36:05: Vi1 CHAP: Using default password
06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"
06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4
06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]
06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
06:36:05: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4
06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
06:36:05: Vi1 CDPCP: State is Closed
06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: State is Open
06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2
06:36:05: Di1 IPCP: Install route to 8.8.8.1
06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, 
changed state to up

Haga el debug de al servidor PPPoE

Para hacer el debug del Cisco 6400 (el servidor PPPoE), utilice el mismo procedimiento ascendente usado para el Cisco 827 Router (el cliente). La diferencia está en la Capa física DSL, donde usted necesita marcar el Multiplexor de acceso DSL. (DSLAM).

1. Capa física DSL

Para marcar la Capa física DSL, usted necesita ver las estadísticas DSL en el DSLAM. Para Cisco DSLAM, utilice el comando show dsl interface.

2. Capa ATM

En el lado del Cisco 6400, usted puede también utilizar un comando debug atm packet y habilitar el Cisco 6400 para un circuito virtual permanente (PVC) específico.

debug atm packet interface atm 0/0/0.182 vc 1/82

Debería poder observar un resultado similar a éste, con los mismos campos de Type, SAP, CTL y OUI, que muestren que el paquete ATM entrante es AAL5SNAP.

4d04h: ATM0/0/0.182(I):
VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3
4d04h: 15E5 0000 0000

Nota: No observará los paquetes salientes mediante este comando debido a la forma en que los paquetes son procesados.

3. Capa Ethernet

Los mismos comandos vpdn show y debugs usados en el Cisco 827 Router pueden ser utilizados en el Cisco 6400 NRP para mirar al establecimiento de PPPoE.

#debug vpdn pppoe-events

4d04h: IN PADI from PPPoE tunnel

4d04h: OUT PADO from PPPoE tunnel

4d04h: IN PADR from PPPoE tunnel

4d04h: PPPoE: Create session
4d04h: PPPoE: VPN session created.

4d04h: OUT PADS from PPPoE tunnel
#show vpdn
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1
PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC
1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1    82
nrp-b#show vpdn session all
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1
 
session id: 1
local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac
virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82
    30 packets sent, 28 received, 422 bytes sent, 395 received

Otros comandos de depuración:

  • debug vpdn pppoe-data

  • debug pppoe-errors

  • debug pppoe-packets

4. Capa PPP

Ésta es la salida de los debugs PPP del Cisco 6400 NRP que corresponde al debug anterior del Cisco 827 Router.

debug ppp negotiation and debug ppp authentication
4d04h: Vi2 PPP: Treating connection as a dedicated line 
4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load] 
4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000 
4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6 
4d04h: Vi2 LCP: TIMEout: State ACKsent 
4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: State is Open 
4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load] 
4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b" 
4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1" 
4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load] 
4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load] 
4d04h: Vi2 CHAP: O SUCCESS id 10 len 4 
4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load] 
4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10 
4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 0.0.0.0 (0x030600000000) 
4d04h: Vi2 IPCP: Pool returned 9.9.9.2 
4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4 
4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: State is Open 
4d04h: Vi2 IPCP: Install route to 9.9.9.2 
4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, 
changed state to up 

Información Relacionada


Document ID: 8514