Banda ancha por cable : Sistemas de terminación de cable módems (CMTS)

Cómo descargar un archivo de configuración IOS a los cables módem de Cisco usando el CMTS CLI de Cisco

31 Julio 2013 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (11 Enero 2006) | Comentarios


Contenido


Introducción

Los archivos de configuración del software de Cisco IOS® son los archivos de texto que contienen la configuración que se enviará al Routers. En el caso de los cablemódems, la configuración que se envía contiene normalmente listas de acceso, nombres de host, identificaciones de comunidad SNMP, contraseñas o configuración de ruteo que difiere de la configuración predeterminada de conexión en puente. Para enviar un archivo de configuración del IOS de Cisco se le debe incrustar en el archivo de configuración de los Data-over-Cable Service Interface Specifications (DOCSIS) que los cablemódems usan en la porción TFTP de su proceso de inicialización.

Hay dos maneras de descargar un archivo de configuración del Cisco IOS a los cables módem de Cisco.

El primero, y más usual, consiste en utilizar la herramienta Configurador DOCSIS CPE. Consulte el Configurador CPE de DOCSIS de Cisco (sólo para clientes registrados). Los archivos de configuración del DOCSIS 1.0 del edificio del documento usando el Cisco DOCSIS Configurator (clientes registrados solamente) contienen una explicación detallada en cómo hacer esto.

La segunda manera de realizar la misma tarea es utilizando la Interfaz de línea de comandos (CLI) en el IOS de Cisco del Sistema de terminación de cablemódem (CMTS).

Este documento explica en detalle la otra manera de descargar un archivo de configuración del IOS a los cablemódems de Cisco sin necesidad de utilizar una herramienta del Configurador de DOCSIS. Para esto utilizamos una versión mejorada de la configuración integral que permite que Cisco CMTS sea configurado como el DHCP, el ToD, y servidores TFTP, así como configurar un archivo de configuración de DOCSIS en el CMTS sí mismo.

Cuando queremos enviar un archivo de configuración al Cable módems usando el CLI para configurar el archivo de configuración de DOCSIS, necesitamos agregar una opción DHCP llamada Vendor Specific Information Option de DHCP, también conocido como opción 43.

La ventaja principal de configurar cablemódems de esta manera es que todo puede ser realizado desde el CMTS de Cisco y ningún otro servidor (como DHCP, TFTP, o ToD) o software (como la herramienta de configuración CPE de DOCSIS) es requerido para enviar exitosamente configuraciones de Cisco IOS a cablemódems de Cisco y hacer que éstos funcionen con una configuración personalizada.

Antes de comenzar

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Prerrequisitos

El lector debería tener conocimientos básicos sobre:

  • El protocolo DOCSIS

  • La interfaz de línea de comando (CLI) del IOS de Cisco en los routers de la serie uBR

  • UNIX

  • Dynamic Host Configuration Protocol (DHCP, Protocolo de configuración dinámica de hosts)

Componentes Utilizados

Consulte la sección Configuración integral con la opción DHCP 43 a continuación.

Información específica de vendedores (Opción 43) Opción DHCP

La opción 43 es una opción DHCP que utilizan los clientes y servidores para intercambiar información específica del proveedor.

Esta opción se formata típicamente en un estilo del “Tipo - longitud - valor” donde diversa información se puede representar por diversos tipos del submarino option. El significado del campo "Value" (Valor) está definido por el fabricante del dispositivo extremo. La figura 1 proporciona una representación gráfica de la Opción 43.

Tipo Longitud Valor Tipo Longitud Valor
C1 n d1 d2 ......... T2 n D1 D2 ........

Cuadro 1 - La estructura del Tipo - longitud - valor de los datos enviados dentro de la opción 43.

Para descargar los archivos de configuración de Cisco IOS para los cablemódems Cisco, utilizamos dos sub-opciones, es decir Vendor ID y Vendor Specific Information Option (VSIF).

El submarino option del Vendor ID tiene el tipo 8. El Organization Unique Identifier del tres-byte (OUI) para el vendedor es generalmente los primeros tres bytes de la dirección MAC del módem de cable. Este valor generalmente se expresa como un número hexadecimal. Este campo debe ser 00:00:0C (en el hex.) para el equipo de Cisco Systems. El cuadro 2 abajo da los números hexadecimales para el submarino option del Vendor ID.

Tipo Longitud Valor
08 03 00:00:0C

Cuadro 2 - Vendor ID del submarino option (en el valor hexadecimal)

La segunda sub-opción que se utiliza es el Campo de información específica del proveedor (VSIF) Este submarino option tiene el tipo 128 y contiene cualquier valor arbitrario que sea definido por el fabricante del módem de cable. El cablemódem de Cisco usa este campo para identificar el nombre de archivo de la configuración del IOS de Cisco que debería descargarse (si es necesario) a un router.

Los comandos arbitrarios del IOS de Cisco también pueden ser especificados en este campo. Este campo es representado usualmente en dígitos decimales punteados. El dotted decimal notation es la representación decimal de las cartas según el ASCII en el cual cada carta tiene un valor decimal. Los “puntos” se utilizan entre la representación decimal para hacerlo más fácil entender.

En este documento, le enseñaremos a descargar un archivo de configuración del IOS de Cisco llamado ios.cf. El nombre de este archivo se convierte de ASCII a punto decimal.

Para saber cuál es la traducción entre ASCII y punto decimal, puede utilizarse el comando UNIX man ascii, tal como se muestra a continuación. Este comando proporciona varias tablas de conversión. Necesitamos buscar el decimal - Tabla del carácter.

sj-cse-494% man ascii
Reformatting page.  Wait... done

ASCII(5)           Headers, Tables, and Macros           ASCII(5)

NAME
     ASCII - map of ASCII character set
.... (skip the beginning)

 	 Decimal - Character

     |  0 NUL|  1 SOH|  2 STX|  3 ETX|  4 EOT|  5 ENQ|  6 ACK|  7 BEL|
     |  8 BS |  9 HT | 10 NL | 11 VT | 12 NP | 13 CR | 14 SO | 15 SI |
     | 16 DLE| 17 DC1| 18 DC2| 19 DC3| 20 DC4| 21 NAK| 22 SYN| 23 ETB|
     | 24 CAN| 25 EM | 26 SUB| 27 ESC| 28 FS | 29 GS | 30 RS | 31 US |
     | 32 SP | 33  ! | 34  " | 35  # | 36  $ | 37  % | 38  & | 39  ' |
     | 40  ( | 41  ) | 42  * | 43  + | 44  , | 45  - | 46  . | 47  / |
     | 48  0 | 49  1 | 50  2 | 51  3 | 52  4 | 53  5 | 54  6 | 55  7 |
     | 56  8 | 57  9 | 58  : | 59  ; | 60  < | 61  = | 62  > | 63  ? |
     | 64  @ | 65  A | 66  B | 67  C | 68  D | 69  E | 70  F | 71  G |
     | 72  H | 73  I | 74  J | 75  K | 76  L | 77  M | 78  N | 79  O |
     | 80  P | 81  Q | 82  R | 83  S | 84  T | 85  U | 86  V | 87  W |
     | 88  X | 89  Y | 90  Z | 91  [ | 92  \ | 93  ] | 94  ^ | 95  _ |
     | 96  ` | 97  a | 98  b | 99  c |100  d |101  e |102  f |103  g |
     |104  h |105  i |106  j |107  k |108  l |109  m |110  n |111  o |
     |112  p |113  q |114  r |115  s |116  t |117  u |118  v |119  w |
     |120  x |121  y |122  z |123  { |124  | |125  } |126  ~ |127 DEL|

Por lo tanto, la representación con punto decimal del ios.cf es 105.111.115.46.99.102as mostrado abajo en el cuadro 3.

i o s . c f
105 111 115 46 99 192

Cuadro 3 - Representación con punto decimal del ios.cf del nombre de fichero.

Dado que VSIF tiene un formato Tipo-Longitud-Valor, la representación de punto decimal completa del archivo de configuración de Cisco IOS denominado ios.cf es 128.6.105.111.115.46.99.192. Como usted puede ver, 128,6 se ha agregado a la representación con punto decimal de ios.cfshown en el cuadro 3. recuerdan que el "128" es el tipo y el "6" es la longitud.

128.6.105.111.115.46.99.192 es el valor ingresado en el campo VSIF de la ficha Vendor Info (Información del proveedor) de la herramienta Configurador DOCSIS CPE V3.2, tal como se muestra en la figura 4 a continuación.

iosconfig_option43.jpg

Figura 4 - Campo de información del proveedor de la herramienta del configurador CPE de DOCSIS.

Configure el servidor de la terminal de modo que sea accesible desde cualquier lugar dándole una dirección pública de Internet registrada, y localizándola fuera del escudo de protección, de modo que los problemas del escudo de protección no interrumpan su conexión. Este documento se concentra en esta expresión hexadecimal.

Para conocer la representación hexadecimal de los caracteres ASCII, podemos utilizar el comando Unix:

echo -n "ios.cf" | od -t x1 | cut -s -d' ' -f2- | tr ' ' ':'

sj-cse-494% echo -n "ios.cf" | OD -t x1 | cut -s -d' ' -f2- | tr ' ' ':'
69:6f:73:2e:63:66

O bien, también puede utilizar el comando anterior de UNIX man ASCII y buscar la tabla "Hexadecimal: Character" (hexadecimal: carácter).

sj-cse-494% man ASCII
Reformatting page.  Wait... done

ASCII(5)           Headers, Tables, and Macros           ASCII(5)

NAME
     ASCII - map of ASCII character set
.... (skip the beginning)


     Hexadecimal - Character

     | 00 NUL| 01 SOH| 02 STX| 03 ETX| 04 EOT| 05 ENQ| 06 ACK| 07 BEL|
     | 08 BS | 09 HT | 0A NL | 0B VT | 0C NP | 0D CR | 0E SO | 0F SI |
     | 10 DLE| 11 DC1| 12 DC2| 13 DC3| 14 DC4| 15 NAK| 16 SYN| 17 ETB|
     | 18 CAN| 19 EM | 1A SUB| 1B ESC| 1C FS | 1D GS | 1E RS | 1F US |
     | 20 SP | 21  ! | 22  " | 23  # | 24  $ | 25  % | 26  & | 27  ' |
     | 28  ( | 29  ) | 2A  * | 2B  + | 2C  , | 2D  - | 2E  . | 2F  / |
     | 30  0 | 31  1 | 32  2 | 33  3 | 34  4 | 35  5 | 36  6 | 37  7 |
     | 38  8 | 39  9 | 3A  : | 3B  ; | 3C  < | 3D  = | 3E  > | 3F  ? |
     | 40  @ | 41  A | 42  B | 43  C | 44  D | 45  E | 46  F | 47  G |
     | 48  H | 49  I | 4A  J | 4B  K | 4C  L | 4D  M | 4E  N | 4F  O |
     | 50  P | 51  Q | 52  R | 53  S | 54  T | 55  U | 56  V | 57  W |
     | 58  X | 59  Y | 5A  Z | 5B  [ | 5C  \ | 5D  ] | 5E  ^ | 5F  _ |
     | 60  ` | 61  a | 62  b | 63  c | 64  d | 65  e | 66  f | 67  g |
     | 68  h | 69  i | 6A  j | 6B  k | 6C  l | 6D  m | 6E  n | 6F  o |
     | 70  p | 71  q | 72  r | 73  s | 74  t | 75  u | 76  v | 77  w |
     | 78  x | 79  y | 7A  z | 7B  { | 7C  | | 7D  } | 7E  ~ | 7F DEL|

La figura 5 que aparece debajo resume tanto la representación decimal de punto como la representación hexadecimal del Campo de información específica del proveedor (VSIF).

Tipo Longitud Valor
punto decimal 128 6 105.111.115.46.99.102
Hexadecimal 80 06 69:6F:73:2E:63:66

Figura 5 – Subopción VSIF en puntos decimales y en formato hexadecimal.

Configuración integral con la opción DHCP 43

Esta configuración fue desarrollada y probada utilizando las versiones de software y hardware indicadas a continuación.

  • uBR10012 de Cisco que ejecuta 12.2(2)XF

  • Cisco CVA120 que ejecuta 12.2(2)XA

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si trabaja con una red en funcionamiento, asegúrese de comprender el impacto potencial que puede tener cualquier comando de Cisco IOS antes de ejecutarlo.

Primer paso: cree el archivo de configuración de DOCSIS con la cadena de opción 43 adecuada

El primer paso al configurar la opción 43 es saber el valor hexadecimal necesario de la ID del proveedor y el valor hexadecimal necesario de las subopciones VSIF de la opción 43 del DHCP.

La tabla que se encuentra a continuación resume estos valores que se discutieron en detalle en la sección Información específica del proveedor.

Subopción de la ID del proveedor Sub opción VSIF
TLV Tipo Longitud Valor Tipo Longitud Valor
Hexadecimal 08 03 00:00:0C 80 06 69:6F:73:2E:63:66
Significado Tipo de ID del proveedor Longitud de la Id. de proveedor ID de Cisco Tipo VSIF Longitud de VSIF (nombre de archivo) ios.cf

‘Figura 6’

Una vez que sabemos qué valor ingresaremos, necesitamos utilizar el CLI del CMTS del Cisco para generar todas las propiedades necesarias para el archivo de configuración de DOCSIS, incluyendo la opción DHCP 43.

Para crear el archivo de configuración de DOCSIS que necesitamos ingresar el Docsis-ARCHIVO-nombre del archivo de configuración del cable del comando global. La siguiente salida muestra la creación del archivo de configuración DOCSIS denominado platinum.cm. Las configuraciones de “platinum.cm” se explican a continuación

Note: 
!--- Comments are in blue.


cable config-file platinum.cm  
  
!---  Name of the DOCSIS config file is platinum.cm

  service-class 1 priority 2  
  
!---  The Upstream Channel priority is 2

  service-class 1 max-upstream 128 
  
!---  The Maximum upstream value is 128Kbps

  service-class 1 guaranteed-upstream 10
  
!---  The Guaranteed Upstream is 10 Kbps

  service-class 1 max-downstream 10000 
  
!---  The Maximum Downstream is 10Mbps

  service-class 1 max-burst 1600
  
!---  The Maximum Upstream Transmit burst is 1600 bytes

  cpe max 10 
  
!---  The Maximum number of CPE's is 10

  timestamp
  
!---  Enable timestamp generation

  option 43 hex 08:03:00:00:0C:80:06:69:6F:73:2E:63:66  
  
!---  Using option 43 to send the IOS Configuration file named "ios.cf" 
  !---  to cable modems.

precaución Precaución: El comando cable config-file se introdujo en la versión 12.1(2)EC1 de IOS de Cisco para uBR7200 y uBR7100 y en la versión 12.2(1)XF1 de IOS de Cisco para uBR10K.

Nota: Esté seguro que usted ha ingresado correctamente los datos de TLV al usar la opción hex. Los datos ingresados incorrectamente pueden provocar que CMs se reinicie, se desconecte o bloquee, lo que requiere aun ciclo de apagado y encendido antes de poder continuar.

Segundo paso - Crear el agrupamiento DHCP para la configuración del servidor DHCP

Una vez que hemos creado el archivo de configuración de DOCSIS platinum.cm, necesitamos configurar el CMTS para ser el servidor DHCP, y configuramos las opciones necesarias para la funcionalidad DHCP. Consulte el servicio de Protocolo de configuración de host dinámico (DHCP) de IOS de Cisco en CMTS, que explica el significado de cada uno de los comandos que se utilizan en la creación del agrupamiento DHCP. Aquí sólo resumiremos la configuración y haremos una breve descripción.

La configuración del grupo DHCP es:

ip dhcp pool surf
  
!---  name of the dhcp pool. This scope is for the cable modems attached 
  !---  to interface cable 5/0/0

  network 10.1.4.0 255.255.255.0
  
!---  pool of addresses for scope from interface c5/0/0

  bootfile platinum.cm
  
!---  DOCSIS config file name associated with this pool

  next-server 10.1.4.1
  
!---  IP address of TFTP server which sends bootfile

  default-router 10.1.4.1
  
!---  default gateway for cable modems, necessary to get DOCSIS files

  option 7 ip 10.1.4.1
  
!---  Log Server DHCP option

  option 4 ip 10.1.4.1
  
!---  ToD server IP address

  option 2 hex ffff.8f80
  
!---  Time offset for ToD, in seconds, HEX, from GMT, -28,000 = PST = ffff.8f80

  lease 7 0 10
  
!---  lease 7 days 0 hours 10 minutes

  ! 

Tercer paso - Configurar CMTS como servidor TFTP

El tercer paso es configurar el CMTS para que se convierta en un servidor TFTP. Para esto necesitará:

  1. Utilice el comando tftp-server

  2. Informar al servidor TFTP donde se encuentra ubicado el archivo ios.cf

Puede lograr esto con el comando tftp-server disk0:ios.cf alias ios.cf. Nótese que este comando ingresa el archivo ios.cf in disk0.

tftp-server server

!--- enable the cmts to act as a tftp server

tftp-server disk0:ios.cf alias ios.cf

!--- get the IOS config file called ios.cf that is pre-downloaded to disk0
!--- this IOS  config file was built with a text editor and tftp to disk0  


Para insertar el archivo ios.cf en su flash o disk0 (para Ubr10012) debe transferir vía tftp el archivo creado mediante un editor de archivos de texto. Para hacer este primer aseegurele puede hacer ping el servidor de tftp donde se localiza la configuración del Cisco IOS.

Luego, se debe ingresar el comando global tftp <device> para colocar el archivo en CMTS. El flash se utiliza generalmente para el ubr7200 o uBR7100 o uBR10K, sin embargo, las demostraciones de este ejemplo cómo utilizar el disk0 para el uBR10012.

schooner#copy tftp disk0
Address or name of remote host []? 172.16.30.2
Source filename []? ios.cf
Destination filename [ios.cf]? 

Accessing tftp://172.16.30.2/ios.cf...
Loading ios.cf from 172.16.30.2 (via FastEthernet0/0/0): !
[OK - 173/4096 bytes]

173 bytes copied in 0.152 secs

Para cerciorarse de que el archivo de configuración IOS está almacenado en CMTS, ejecute el comando dir.

schooner#dir
Directory of disk0:/
    3  -rw-    11606084   Sep 17 2001 13:31:38  ubr10k-k8p6-mz.122-2.XF.bin
 2839  -rw-         173   Oct 01 2001 23:29:44  ios.cf
47890432 bytes total (36274176 bytes free)

Para ver qué comandos se encuentran configurados en el archivo ios.cf, se puede utilizar, como se muestra a continuación, el comando more <nombre de archivo> en el CMTS.

schooner#more ios.cf
hostname SUCCEED
service linenumber
enable password cisco
interface ethernet 0
load 30
no shut
interface cable 0
load 30
no shut
line vty 0 4
password cisco
end

Cuarto paso - Configuración de CMTS como servidor ToD

Para configurar ToD en un CMTS de Cisco, sólo son necesarios los dos comandos globales siguientes: service udp-small-servers max-servers no-limit y cable time-server. La configuración luce de la siguiente manera:

service udp-small-servers max-servers no-limit

!---  supports a large number of modems / hosts attaching quickly

cable timeserver

!---  permits cable modems to obtain Time of Day (ToD) from uBR10012


La configuración del CMTS

A continuación encontrará la configuración completa de uBR10012. Todos los comandos en negrita son relevantes para los fines de este documento.

Schooner#show run
Building configuration...

Current configuration : 3522 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers max-servers no-limit
!
hostname schooner
!
logging rate-limit console all 10 except critical
enable secret 5 $1$cM7F$ryXH7z/Ly6QCnD2LQ.gZs/
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable timeserver
!
cable config-file platinum.cm
 service-class 1 priority 2
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 10
 timestamp
 option 43 hex 08:03:00:00:0C:80:06:69:6F:73:2E:63:66
!
redundancy
 main-cpu
  auto-sync standard
facility-alarm intake-temperature major 49
facility-alarm intake-temperature minor 40
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
card 1/0 1oc12pos-1
card 1/1 2cable-tccplus
card 2/0 1gigethernet-1
card 5/0 2cable-mc28
card 7/0 2cable-mc28
ip subnet-zero
no ip domain-lookup
!
ip dhcp pool surf
   network 10.1.4.0 255.255.255.0
   bootfile platinum.cm
   next-server 10.1.4.1 
   default-router 10.1.4.1 
   option 7 ip 10.1.4.1 
   option 4 ip 10.1.4.1 
   option 2 hex ffff.8f80
   lease 7 0 10
!
interface FastEthernet0/0/0
 ip address 172.16.30.50 255.255.255.192
!
interface POS1/0/0
 no ip address
 crc 32   
 pos report all
 POs flag j0 1
!
interface GigabitEthernet2/0/0
 no ip address
 negotiation auto
!
interface Cable5/0/0
 ip address 10.1.4.1 255.255.255.0
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 frequency 40000000
 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
no ip http server
!
no cdp run
snmp-server community public RO
snmp-server community private RW
snmp-server trap-source Cable5/0/0
snmp-server packetsize 2048
snmp-server enable traps cable
snmp-server host 172.16.30.8 public  cable snmp
snmp-server manager
tftp-server server
tftp-server ios.cf alias ios.cf
!
alias exec scm show cable modem
!
line con 0
line aux 0
line vty 0 4
!
end

schooner#

Otros proveedores CMTS pueden no tener la capacidad de configurar todos estos pedazos usando solamente sus comandos cmts mientras que puede ser lograda totalmente en el Cisco IOS.

Para lograr que los cablemódems tomen los comandos especificados en el archivo de configuración del IOS de Cisco llamado ios.cf, es necesario reiniciar los cablemódems en cuestión. Esto se puede hacer del del CLI CMTS usando la restauración clearcable de la dirección MAC del módem del comando < IP Address/>.

Schooner#clear cable modem 10.1.4.4 reset

precaución Precaución: Si usted tiene una Red grande y quiere enviar un diverso archivo de configuración a todo el Cable módems en su planta, se recomienda para hacer tan en las fases. Esto hará que se reduzca el impacto provocado por miles de cables módem que intentan pisarse mutuamente al intentar conectarse en línea al mismo tiempo.

Verifique la Configuración

Para comprobar la configuración, verifique el cable módem con el comando clear cable modem. Cuando el cable módem vuelva a conectarse, comuníquese vía telnet con éste para ver la configuración.

Schooner#show cable modem 
MAC Address    IP Address      I/F       MAC         Prim RxPwr Timing Num  BPI
                                         State       Sid  (db)  Offset CPEs Enbld
0004.27ca.0e9b 10.1.4.6        C5/0/0/U0 online      1  *0.00   2820   0    no 
0090.9600.703d 10.1.4.2        C5/0/0/U0 online      2   -0.75  2816   0    no 
0003.e38f.f9b5 10.1.4.3        C5/0/0/U0 online      3  *0.00   2822   0    no 
0001.64ff.e4b5 10.1.4.4        C5/0/0/U0 online      4  *0.00   2812   0    no

!--- CVA120
 
0020.4086.2704 10.1.4.5        C5/0/0/U0 online      5   -0.50  2808   0    no 
0020.4086.3324 10.1.4.7        C5/0/0/U0 online      6   -0.50  2808   0    no 
0020.4079.feb4 10.1.4.8        C5/0/0/U0 online      7   0.00   2805   0    no 
0020.4085.d06a 10.1.4.9        C5/0/0/U0 online      8   -0.50  2807   0    no 

Aviso en este ejemplo que los comandos ios cf file el Cable módems de tener un nombre de host SUCCEED, y éste es de hecho el nombre de fichero que se considera cuando nosotros telnet en el módem de cable.

Schooner#telnet 10.1.4.4
Trying 10.1.4.4 ... Open

SUCCEED line 1 


User Access Verification

Password: 
SUCCEED>en
Password: 
SUCCEED#

Para verificar que el archivo de configuración del Cisco IOS fuera descargado con éxito al uso del módem de cable el comando show version. El resultado a continuación muestra la información con respecto al archivo ios.cf resaltado en negrita.

SUCCEED#show  version
Cisco Internetwork Operating System Software 
IOS (tm) 120 Software (CVA120-K8V4Y5-M), Version 12.2(2)XA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
TAC:Home:SW:IOS:Specials for info
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Wed 27-Jun-01 02:02 by hwcheng
Image text-base: 0x800100A0, data-base: 0x80782844
ROM: System Bootstrap, Version 12.0(20001010:025045) [spaulsen-blue-3105 3108], DEVELOPMENT SOFTWARE
ROM: 120 Software (CVA120-K8V4Y5-M), Version 12.2(2)XA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

SUCCEED uptime is 3 days, 3 hours, 21 minutes
System returned to ROM by reload at 05:52:09 - Sat Jan 1 2000
System restarted at 05:58:30 - Sat Oct 6 2001
System image file is "flash:cva120-k8v4y5-mz.122-2.XA.bin"
Host configuration file is "tftp://10.1.4.1/ios.cf"

cisco CVA122 CM (MPC850) processor (revision 3.r) with 32256K/1024K bytes of memory.
Processor board ID SAD043708GK
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 Cable Modem network interface(s)
1 Universal Serial Bus (USB) interface(s)
8192K bytes of processor board System flash (Read/Write)
7296K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2

A continuación, se muestra se ilustra la configuración del CVA120. Tenga en cuenta que los comandos resaltados en negrita corresponden a las líneas en el archivo ios.cf.

SUCCEED#show run
Building configuration...

Current configuration : 1429 bytes
!
! Last configuration change at 11:22:22 - Tue Oct 9 2001
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service linenumber
service internal
!
hostname SUCCEED
!
no logging buffered
no logging buffered
logging rate-limit console 10 except errors
enable password cisco
!
clock timezone - -8
ip subnet-zero
no ip routing
no ip finger
!
interface Ethernet0
 ip address 10.1.4.11 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 ip address docsis
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 cable-modem boot admin 2
 cable-modem boot oper 5
 cable-modem downstream mode annex-b
 cable-modem Mac-timer t2 40000
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface USB0
 ip address 10.1.4.11 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 arp timeout 0
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip classless
no ip http server
no ip http cable-monitor
!
snmp-server packetsize 4096
snmp-server chassis-id 
snmp-server manager
!
voice-port 0
 input gain -2
!
voice-port 1
 input gain -2
!
mgcp modem passthrough voaal2 mode 
no mgcp timer receive-rtcp
!
mgcp profile default
!
line con 0
 transport input none
line vty 0 4
 password cisco
 login
!
end

Nota importante

Parece que el comando de opción para el archivo de configuración de cable está dañado porque podemos esperar que los comandos que figuran a continuación den una configuración válida.

option 43 instance 8 hex 00:00:0c
option 43 instance 128 ASCII ios.cf

Mientras que se validan estos comandos, no genera el archivo de configuración correcto del Cisco IOS. ¡Esto NO es un error! El problema aquí es cómo el término “caso” fue interpretado como “submarino option,” que nunca fue supuesto para ser.

¡La implementación del “caso” permite solamente la repetición de los mismos tiempos múltiples de la opción, como cuando usted tiene instancias múltiples de la opción 43 para los diversos vendedores! Aquí tiene un ejemplo:

option 43 instance 1 hex 08:03:00:00:0C:80:07:69:6F:73:2E:63:66:67

!--- Config file cisco CM

option 43 instance 2 hex 08:03:11:22:33:80:07:69:6F:73:2E:63:66:67

!--- Some option for other CM

Tenga en cuenta que 11:22:33 es una ID de proveedor aleatoria de una compañía ficticia. Cualquier coincidencia con la Id. de un proveedor real es pura casualidad.

Dado que se espera que el término "instancia" refleje campos con subopciones de TLV y usted realmente cuenta con campos con subopciones de TLV, deberá ingresar la cadena completa de caracteres en hexadecimales.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 8323