Seguridad : Dispositivos de seguridad Cisco PIX de la serie 500

Configuración de PIX Firewall con acceso a un servidor de correo en una red interna

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este ejemplo de configuración demuestra cómo configurar el firewall PIX para acceder a un servidor de correo ubicado en la red interna.

Nota: La inspección SMTP configurada en este documento no es compatible con las conexiones ESMTP a los servidores tales como Microsoft Exchange. No configure la inspección SMTP si usted utiliza un mail server que confíe en el ESMTP. Alternativamente, la versión de software PIX 7.0 y posterior soporta el S TP y el La inspección ESMTP.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Firewall PIX 10000

  • Versión de Software PIX Firewall 5.1(4)

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

Este documento utiliza esta configuración de red:

/image/gif/paws/8122/mailserver_in.gif

Configuraciones

Este documento usa estas configuraciones.

Firewall PIX
PIX Version 5.1(4)

 !--- These commands name and set the security level for each PIX interface.

 nameif ethernet0 outside security0
 nameif ethernet1 inside security100
 enable password 8Ry2YjIyt7RRXU24 encrypted
 passwd 2KFQnbNIdI.2KYOU encrypted
 hostname PIX_1
 domain-name noplace.com
 fixup protocol ftp 21
 fixup protocol http 80
 fixup protocol h323 1720
 fixup protocol rsh 514
 fixup protocol smtp 25
 fixup protocol sqlnet 1521
 no names

 !--- Create an access list that permits SMTP traffic from anywhere
 !--- to the host at 209.164.3.5 (our server).  The name of this list is 
 !--- smtp. Add additional lines to this access list as required.
 !--- Note: There is one and only one access list allowed per
 !--- interface per direction (for example, inbound on the outside interface).
 !--- Because of limitation, any additional lines that need placement in
 !--- the access list need to be specified here.  If the server
 !--- in question is not SMTP, replace the occurrences of SMTP with
 !--- www, DNS, POP3, or whatever else is required. The access-list
 !--- command was introduced in PIX Software Release 5.0; it is used
 !--- here instead of a conduit statement.

 access-list smtp permit tcp any host 209.164.3.5 eq smtp
 pager lines 24
 logging on
 logging timestamp
 no logging standby
 logging console debugging
 logging monitor debugging
 logging buffered debugging
 logging trap debugging
 no logging history
 logging facility 23
 logging queue 512

 !--- Set each Ethernet interface to auto-detect its media type.

 interface ethernet0 auto
 interface ethernet1 auto
 mtu outside 1500
 mtu inside 1500

 !--- Define the IP address for each interface.

 ip address inside 192.168.1.1 255.255.255.0
 ip address outside 209.164.3.1 255.255.255.252
 no failover
 arp timeout 14400

 !--- Specify that any traffic that originates inside from the
 !--- 192.168.2.x network NATs (PAT) to 209.164.3.129 if
 !--- such traffic passes through the outside interface.

 global (outside) 1 209.164.3.129
 nat (inside) 1 192.168.2.0 255.255.255.0

 !--- Define a static translation between 192.168.2.57 on the inside and
 !--- 209.164.3.5 on the outside.  These are the addresses to be used by
 !--- the server located inside the firewall.

 static (inside,outside) 209.164.3.5 192.168.2.57 netmask 255.255.255.255

 !--- Apply the access list named smtp inbound on the outside interface.

 access-group smtp in interface outside

 !--- Set the default route to  209.164.3.2. 
 !--- The PIX assumes that this address is that of a router.

 route outside 0.0.0.0 0.0.0.0 209.164.3.2 1
 
 !--- Instruct the PIX to hand any traffic destined for 192.168.x.x
 !--- to the router at 192.168.1.2.

 route inside 192.168.0.0 255.255.0.0 192.168.1.2 1
 timeout xlate 1:30:00 conn 1:00:00 half-closed 0:10:00 udp 0:00:00
 timeout rpc 0:10:00 h323 0:05:00
 timeout uauth 0:00:00 absolute
 aaa-server TACACS+ protocol tacacs+
 aaa-server RADIUS protocol radius
 no snmp-server location
 no snmp-server contact
 snmp-server community public
 no snmp-server enable traps
 floodguard enable
 terminal width 200
 Cryptochecksum:d66eb04bc477f21ffbd5baa21ce0f85a
 : end
 
 !--- Alternate command:
 !--- conduit permit tcp host 209.164.3.5 eq smtp any
 !--- The conduit command is equivalent to 
 !--- the access-list statements this configuration shows.
 !--- In this case a path known as a conduit is created in order to allow any SMTP 
 !--- traffic to host 209.164.3.5.  Use of this command replaces the 
 !--- access-list and access-group 
 !--- statements that this configuration presents.

Router
Current configuration:
 !
 version 12.0
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname 2522-R5
 !
 enable secret 5 $1$N0F3$XE2aJhJlCbLWYloDwNvcV.
 !
 ip subnet-zero
 !
 !
 !
 !
 !
 interface Ethernet0
 
 !--- Sets the IP address of the Ethernet interface to 209.164.3.2.

  ip address 209.164.3.2 255.255.255.252
 !
 interface Serial0

  !--- Instructs the serial interface to use 
  !--- the address of the Ethernet interface when the need arises.

  ip unnumbered ethernet 0 
 !
 interface Serial1
  no ip address
  no ip directed-broadcast
 !
 ip classless

 !--- Instructs the router to send all traffic 
 !--- destined for 209.164.3.x to 209.164.3.1.

 ip route 209.164.3.0 255.255.255.0 209.164.3.1

 !--- Instructs the router to send 
 !--- all other remote traffic out serial 0.

 ip route 0.0.0.0 0.0.0.0 serial 0
 !
 !
 line con 0
  transport input none
 line aux 0
  autoselect during-login
 line vty 0 4
  exec-timeout 5 0
  password ww
  login
 !
 end

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

El comando logging console debugging dirige los mensajes a la consola PIX. Si la Conectividad al mail server es un problema, examine los mensajes del debug de la consola para localizar los IP Addresses del envío y de las estaciones receptoras para determinar el problema.

Información que debe Obtener si Abre un Caso de Soporte Técnico

Si usted todavía necesita la ayuda después de que usted complete los pasos de Troubleshooting en este documento y quiera abrir un caso con el Soporte técnico de Cisco, esté seguro de incluir esta información para localizar averías su firewall PIX.
  • Descripción de problemas, que incluye la topología y los detalles de la dirección IP del mail server.
  • Complete cualquier troubleshooting antes de que usted abra el caso.
  • Salida del comando showtech-support.
  • Salida del comando show log después de que se ejecute con el comando logging buffered debugging, o capturas de consola que demuestran el problema (si está disponible)
Adjunte los datos recopilados para su caso en un texto sin formato (.txt), sin compactar. Usted puede adjuntar la información a su caso cargandolo con la herramienta de la solicitud de servicio de TAC (clientes registrados solamente). Si usted no puede acceder la herramienta de la solicitud de servicio de TAC, usted puede enviar la información en un correo electrónico a attach@cisco.com con su número de caso en los asuntos de su mensaje.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 8122