Switches : Cisco 6130 IP DSL Switch

Configure una interfaz ATM del Cisco 6400 con el RBE y el DHCP

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (11 Noviembre 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra para un router del Digital Subscriber Line (DSL) del Cisco 827 conectado con un Digital Subscriber Line Access Multiplexer del Cisco 6130 (DSLAM), eso termina en un Concentrador de acceso universal (UAC) del Cisco 6400.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Customer Premises Equipment del Cisco 827-4V (CPE) con el Software Release 12.1(1)XB IOS�.

  • Software Release 12.1(1)DC1 del Cisco 6400 UAC-NRP IOS (servidor DHCP externo) o 12.2(2)B (servidor DHCP IOS).

  • Software Release 12.0(4)DB del Cisco 6400 UAC-NSP IOS.

  • Versión de software IOS 12.1(1)DA del Cisco 6130 DSLAM-NI2.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Antecedentes

El Cisco 827 se configura con interligar y el Integrated Routing and Bridging (IRB) del RFC1483. El Cisco 827 permite que los PC en el segmento Ethernet obtengan los direccionamientos de un servidor DHCP detrás de los 6400, o del servidor DHCP IOS 6400. Además, el direccionamiento BVI también se ha configurado para obtener un direccionamiento y una ruta predeterminado del servidor DHCP. La interfaz de Asynchronous Transfer Mode (ATM) del Cisco 6400 se configura con el (RBE) de la encapsulación del Bridge ruteado, y se configura para actuar con un servidor DHCP externo o el servidor DHCP IOS en el NRP.

Para el Cisco 6400, la característica atmósfera RBE en el Cisco 6400 Node Route Processor (NRP) rutea el IP sobre el tráfico de Ethernet interligado del RFC1483 de un Stub-Bridged LAN. Los paquetes del IP interligados recibidos en una interfaz ATM configurada en el modo ruta-interligado se rutean a través del encabezado IP. Las interfaces se aprovechan de las características de una topología LAN del stub de uso general para el acceso DSL, y mayor rendimiento y flexibilidad de la oferta sobre el IRB.

También, las rutas del host para los clientes DHCP se agregan automáticamente a la tabla de ruteo 6400 mientras que se distribuyen los IP Addresses. Las rutas del host se quitan de la tabla de ruteo cuando se libera el DHCP Address.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la configuración de la red mostrada en los cuadros 1 y 2:

Cuadro 1 – Escenario 1

/image/gif/paws/7208/fig1_7208.gif

Cuadro 2 – Escenario 2

/image/gif/paws/7208/fig2_7208.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

  • Cisco 827

  • Cisco 6400 NRP

  • Debug 6400 (usando el RBE con el servidor DHCP externo)

  • Debug 6400 (usando el RBE con el servidor DHCP IOS)

Cisco 827
Current configuration: 
! 
version 12.0 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1
!
ip subnet-zero 
!
bridge irb 
! 
interface Ethernet0 
 no ip address
 bridge-group 1

!--- Because the Ethernet0 is bridged to the WAN interface,
!--- PCs behind the ethernet0 can be setup as DHCP clients.
!--- They get their addresses from the DHCP server behind the 6400,
!--- or from the IOS DHCP server on the 6400.

! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 4/100 
  encapsulation aal5snap 
 ! 
 bundle-enable 
 bridge-group 1 
 hold-queue 224 in 
! 
interface BVI1 
 ip address dhcp client-id Ethernet0

!--- This command tells the BVI interface to get the address
!--- from DHCP, and also to get the default route from DHCP.

! 
ip classless 

!--- Note: The default route will be inserted into
!--- the routing table automatically from the DHCP server, and
!--- no static routing statement is required.                         

no ip http server 
! 
bridge 1 protocol ieee 
 bridge 1 route ip 
! 
voice-port 1 
 timing hookflash-in 0 
! 
voice-port 2 
 timing hookflash-in 0 
! 
voice-port 3 
 timing hookflash-in 0 
! 
voice-port 4 
 timing hookflash-in 0 
!
end 

Cisco 6400 NRP
Current configuration: 
! 
version 12.1
no service pad 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NRP 

! 
redundancy 
 main-cpu 
 no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface Loopback1 
 ip address 198.1.1.1 255.255.255.0 
 no ip directed-broadcast

!--- This address and mask must match the intended
!--- scope and network configured on the external DHCP server.

! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no ATM ilmi-keepalive 
! 
interface ATM0/0/0.4 point-to-point

!--- The interface ATM0/0/0.4 point-to-point uses IP
!--- unnumbered Loopback1 for its IP address requirements.

 ip unnumbered Loopback1 
 ip helper-address <dhcp server ip address>
 atm route-bridged ip 
 PVC 4/100 
  encapsulation aal5snap 
 ! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
ip classless 

!--- Note: For every DHCP client that is relayed an address,
!--- a host route will be automatically inserted in the routing 
!--- table, and no host route statement for a DHCP client is required.

end 

Debug 6400 (usando el RBE con el servidor DHCP externo)
debug ip dhcp server events 

Looks for existing binding. . .

00:10:56:  find_or_create(): Look for existing binding for:
00:10:56:  find_or_create(): dhcp->chaddr = 616EF9BC
00:10:56:  find_or_create(): dhcp->hlen = 6
00:10:56:  find_or_create(): dhcp->htype = 1
00:10:56:  find_or_create: address = 124.124.124.1
00:10:56:  find_or_create(): Creating new binding with data
00:10:56:  find_or_create(): dhcp->chaddr = 616EF9BC
00:10:56:  find_or_create(): dhcp->hlen = 6
00:10:56:  find_or_create(): dhcp->htype = 1
00:10:56:  find_or_create: address = 124.124.124.1

!--- Forwards DHCP DISCOVER packet from the client to the
!--- external DHCP server.

00:10:56: DHCPD: Received DHCPDISCOVER on UNNUM-IF
00:10:56: DHCPD: Forwarding reply on un-numbered intf

!--- Forwards the DHCP OFFER packet from the external DHCP server 
!--- to the client.

00:10:56: DHCPD: Unnum: Received DHCPOFFER
00:10:56:  DHCPD: Server Address = 200.200.200.2
00:10:56:  DHCPD: Giaddr Address = 124.124.124.1
00:10:56:  find_or_create(): Look for existing binding for:
00:10:56:  find_or_create(): dhcp->chaddr = 616EF9BC
00:10:56:  find_or_create(): dhcp->hlen = 6
00:10:56:  find_or_create(): dhcp->htype = 1
00:10:56:  find_or_create: address = 124.124.124.1

!--- Forwards the DHCP REQUEST packet from the client to the external
!--- DHCP server.

00:10:56: DHCPD: Received DHCPREQUEST on UNNUM-IF
00:10:56:  DHCPD: request_on_unnumif ():Real Server = 200.200.200.2   
00:10:56: DHCPD: Forwarding reply on un-numbered intf

!--- Forwards the DHCP ACK packet from the DHCP server to the client.

00:10:56: DHCPD: Unnum: Received DHCPACK
00:10:56:  DHCPD: lease time = 86400

!--- Adds a dynamic host route to the client into the routing table.

00:10:56: DHCPD: dhcpd_lookup_route: host = 124.124.124.2
00:10:56: DHCPD: dhcpd_lookup_route: index = 126
00:10:56:  DHCPD: Adding new route to host 124.124.124.2
00:10:56: DHCPD: dhcpd_lookup_route: host = 124.124.124.2
00:10:56: DHCPD: dhcpd_lookup_route: index = 126
00:10:56: DHCPD: dhcpd_create_and_hash_route: host = 124.124.124.2
00:10:56: DHCPD: dhcpd_create_and_hash_route index = 126
00:10:56: DHCPD: dhcpd_add_route: lease = 86400 
00:10:56:  DHCPD: Server ID saved in Binding = 200.200.200.2
00:10:56:  DHCPD: Server ID saved in Route block = 200.200.200.2
00:10:56:  DHCPD: Giaddr Address = 124.124.124.1

Debug 6400 (usando el RBE con el servidor DHCP IOS)
debug ip dhcp server events 

Assigns an address to the client from the IOS DHCP server.

23:19:09: DHCPD: assigned IP address 124.124.124.3 to 
client 0063.6973.636f.2d30.3030.302e.3063.3036.2e32.3339.342d.4256.31.
23:19:10:  DHCPD: lease time = 86400

Adds a dynamic host route to the client into the routing table.

23:19:10: DHCPD: dhcpd_lookup_route: host = 124.124.124.3
23:19:10: DHCPD: dhcpd_lookup_route: index = 127
23:19:10:  DHCPD: Adding new route to host 124.124.124.3
23:19:10: DHCPD: dhcpd_lookup_route: host = 124.124.124.3
23:19:10: DHCPD: dhcpd_lookup_route: index = 127
23:19:10: DHCPD: dhcpd_create_and_hash_route: host = 124.124.124.3
23:19:10: DHCPD: dhcpd_create_and_hash_route index = 127
23:19:10: DHCPD: dhcpd_add_route: lease = 86400

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 7208