IP : Open Shortest Path First (OSPF)

¿Por qué hay algunas rutas OSPF en la base de datos pero no en la tabla de ruteo?

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Abril 2015) | Comentarios


Interactivo: Este documento ofrece un análisis personalizado de su dispositivo Cisco.


Contenido


Introducción

Un problema común al usar el Open Shortest Path First (OSPF) es rutas en la base de datos no aparece en la tabla de ruteo. En la mayoría de los casos el OSPF encuentra una discrepancia en la base de datos así que no instala la ruta en la tabla de ruteo. A menudo, usted puede ver que el router anunciante es el mensaje no-accesible (que significa que el router que hace publicidad del LSA no es OSPF directo accesible) encima del anuncio del estado del vínculo (LSA) en la base de datos cuando ocurre este problema. Aquí tiene un ejemplo:

Adv Router is not-reachable
LS age: 418
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 172.16.32.2
Advertising Router: 172.16.32.2
LS Seq Number: 80000002
Checksum: 0xFA63
Length: 60
 Number of Links: 3

Hay varias razones de este problema, la mayoría cuyo trato con mis configuration o de una topología quebrada. Cuando sale la configuración se corrige la discrepancia de las bases de datos OSPF y las rutas aparecen en la tabla de ruteo. Este documento explica algunas de las más razones comunes que pueden causar la discrepancia en la base de datos.

Algunos de los comandos usados en este documento para la verificación del comportamiento OSPF incluyen la interfaz OSPF del IP de la demostración, la database router OSPF del IP, el vecino OSPF del IP de la demostración y el externo de la base de datos OSPF del IP de la demostración. Si usted tiene la salida de ninguno de estos comandos de su dispositivo de Cisco, usted puede utilizar para visualizar los problemas potenciales y los arreglos. Para utilizar , usted debe ser un cliente registrado, se abra una sesión, y hace el Javascript habilitar.

prerrequisitos

Requisitos

Los Quien lea este documento deben tener conocimiento de estos temas

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • El Software Release 12.3 del � del Cisco IOS se ejecutaba en todo el Routers.

  • Esto se soporta en todas las plataformas del router de Cisco.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Razón 1: Discrepancia entre tipos de red

Utilicemos el siguiente diagram de red como un ejemplo:

/image/gif/paws/7112/26a.gif

R4-4K R1-7010
interface Loopback0
 ip address 172.16.33.1 255.255.255.255

interface Serial2
 ip address 172.16.32.1 255.255.255.0
 ip ospf network broadcast

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
interface Loopback0
 ip address 172.16.30.1 255.255.255.255
!
interface Serial1/0
 ip address 172.16.32.2 255.255.255.0
 clockrate 64000

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0

R4-4K(4)# show ip ospf interface serial 2
Serial2 is up, line protocol is up 
  Internet Address 172.16.32.1/24, Area 0 
  Process ID 20, Router ID 172.16.33.1, Network Type BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State DR, Priority 1 
  Designated Router (ID) 172.16.33.1, Interface address 172.16.32.1
  Backup Designated router (ID) 172.16.32.2, Interface address 172.16.32.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.16.32.2  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)

R1-7010(5)# show ip ospf interface serial 1/0
Serial1/0 is up, line protocol is up 
  Internet Address 172.16.32.2/24, Area 0 
  Process ID 20, Router ID 172.16.32.2, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.16.33.1
  Suppress hello for 0 neighbor(s)

Como usted puede ver arriba, configuran al router R4-4K para el broadcast, y configuran al router R1-7010 para el Punto a punto. Esta clase de discrepancia del tipo de red hace el router de anuncio inalcanzable.

R4-4K(4)# show ip ospf database router 172.16.32.2

  Adv Router is not-reachable
  LS age: 418
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 172.16.32.2
  Advertising Router: 172.16.32.2
  LS Seq Number: 80000002
  Checksum: 0xFA63
  Length: 60
   Number of Links: 3

    Link connected to: another Router (point-to-point)
    (Link ID) Neighboring Router ID: 172.16.33.1
    (Link Data) Router Interface address: 172.16.32.2
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 172.16.32.0
    (Link Data) Network Mask: 255.255.255.0
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

R1-7010(5)# show ip ospf database router 172.16.33.1

  Adv Router is not-reachable
  LS age: 357
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 172.16.33.1
  Advertising Router: 172.16.33.1
  LS Seq Number: 8000000A
  Checksum: 0xD4AA
  Length: 48
   Number of Links: 2

     Link connected to: a Transit Network
     (Link ID) Designated Router address: 172.16.32.1
     (Link Data) Router Interface address: 172.16.32.1
     Number of TOS metrics: 0
     TOS 0 Metrics: 64

Usted puede ver que para la subred 172.16.32.0/24, el router R1-7010 está generando un link punto a punto y el router R4-4K está generando un link de tránsito. Esto crea una discrepancia en la base de datos de estado de link, que significa que no se instala ningunas rutas en la tabla de ruteo.

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
C       172.16.30.1/32 is directly connected, Loopback0

Solución

Para solucionar este problema, configure a ambo Routers para el mismo tipo de red. Usted puede cambiar el tipo de red del router R1-7010 para transmitir, o para cambiar la interfaz serial del router R4-4K al Punto a punto.

Nota: Si usted tiene una situación donde está una interfaz multipunto un lado y el otro lado es una sub-interfaz después cambia el tipo de red para transmitir en los ambos lados.

En este ejemplo hemos quitado la declaración del “broadcast de tipo de red” sobre el R4-4K porque los ambos lados son interfaces encapsuladas de punto a punto del High-Level Data Link Control (HDLC).

R4-4K(4)# configure terminal 
R4-4K(4)(config)# interface serial 2 
R4-4K(4)(config-if)# no ip ospf network broadcast 
R4-4K(4)(config-if)# end

R4-4K(4)# show ip ospf interface serial 2
 Serial2 is up, line protocol is up 
  Internet Address 172.16.32.1/24, Area 0 
  Process ID 20, Router ID 172.16.33.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
   Hello due in 00:00:04
  Neighbor Count is 1, Adjacent neighbor count is 1 
  Adjacent with neighbor 172.16.32.2
  Suppress hello for 0 neighbor(s)

Razón 2: Asignación de dirección incorrecta en configuración del link serial DUAL

Considere este diagrama de la red como un ejemplo:

/image/gif/paws/7112/26b.gif

R4-4K R1-7010
interface loopback 0
 ip address 172.16.35.1 255.255.255.255

interface Serial2
 ip address 172.16.29.1 255.255.255.0
!
interface Serial3
 ip address 172.16.32.1 255.255.255.0

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
interface loopback 0
 ip address 172.16.30.1 255.255.255.255

interface Serial1/0
 ip address 172.16.32.2 255.255.255.0
 clockrate 64000
!
interface Serial1/1
 ip address 172.16.29.2 255.255.255.0
 clockrate 38400

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0

Usted puede ver que los IP Addresses están movidos de un tirón en las configuraciones antedichas, que causa una discrepancia en las bases de datos OSPF. Sin embargo, el Routers todavía forma a los vecinos en la versión deL Cisco IOS anterior de 12.1 porque en un link punto a punto, los routeres para OSPF no verifican que el router de la vencidad esté en la misma subred.

R4-4K(4)# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.32.2       1   FULL/  -        00:00:37    172.16.32.2     Serial2
172.16.32.2       1   FULL/  -        00:00:31    172.16.29.2     Serial3

De la salida antedicha, usted puede ver que el Serial2 está formando a los vecinos con la dirección IP 172.16.32.2, que no está en la misma subred. Aunque formen a los vecinos, no se instala ningunas rutas en la tabla de ruteo:

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
C       172.16.29.0/24 is directly connected, Serial1/1
C       172.16.30.1/32 is directly connected, Loopback0

Solución

Para solucionar este problema, asigna correctamente los IP Addresses o conmuta los cables seriales. Aquí hemos corregido los IP Addresses:

R4-4K R1-7010
interface loopback 0
 ip address 172.16.35.1 255.255.255.255

interface Serial2
 ip address 172.16.32.1 255.255.255.0
!
interface Serial3
 ip address 172.16.29.1 255.255.255.0

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
interface loopback 0
 ip address 172.16.30.1 255.255.255.255

interface Serial1/0
 ip address 172.16.32.2 255.255.255.0
 clockrate 64000
!
interface Serial1/1
 ip address 172.16.29.2 255.255.255.0
 clockrate 38400

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0

R4-4K(4)# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.32.2       1   FULL/  -        00:00:36    172.16.32.2     Serial2
172.16.32.2       1   FULL/  -        00:00:39    172.16.29.2     Serial3

Ahora muestra a la dirección de vecino correcta en la interfaz del Serial2. Las rutas están también en la tabla de ruteo:

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
O       172.16.35.1/32 [110/65] via 172.16.32.1, 00:03:12, Serial1/0
                       [110/65] via 172.16.29.1, 00:03:12, Serial1/1
C       172.16.29.0/24 is directly connected, Serial1/1
C       172.16.30.1/32 is directly connected, Loopback0

Razón 3: Una parte del link punto a punto incluido en Majornet o subred incorrectos

Considere este diagrama de la red como un ejemplo:

/image/gif/paws/7112/26c.gif

Esta situación crea exactamente el mismo comportamiento que la asignación de dirección incorrecta en configuración del link serial DUAL. Para solucionar el problema, asigne los IP Addresses en la misma subred en ambo Routers.

Razón 4: Un lado está sin numerar y el otro lado está numerado

Considere el siguiente diagram de red como un ejemplo:

/image/gif/paws/7112/unnum.gif

R4-4K R1-7010
interface Loopback0
 ip address 172.16.35.1 255.255.255.255

interface Serial2
 ip unnumbered Loopback0
 router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
interface Loopback0
 ip address 172.16.30.1 255.255.255.255
!
interface Serial1/0
 ip address 172.16.32.2 255.255.255.0
 clockrate 64000

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0

R4-4K(4)# show interface serial 2
Serial2 is up, line protocol is up 
  Hardware is cxBus Serial
  Interface is unnumbered.  Using address of Loopback0 (172.16.35.1)

R1-7010(5)# show interface serial 1/0
Serial1/0 is up, line protocol is up 
  Hardware is cxBus Serial
  Internet address is 172.16.32.2/24

La salida antedicha muestra que la interfaz del Serial2 R4-4K es innumerable al loopback0, mientras que el Serial1/0 R1-7010 es una interfaz numerada.

R4-4K(4)# show ip ospf interface serial 2
Serial2 is up, line protocol is up 
  Internet Address 0.0.0.0/24, Area 0 
  Process ID 20, Router ID 172.16.35.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.16.32.2
  Suppress hello for 0 neighbor(s)

R1-7010(5)# show ip ospf interface serial 1/0
Serial1/0 is up, line protocol is up 
  Internet Address 172.16.32.2/24, Area 0 
  Process ID 20, Router ID 172.16.32.2, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.16.33.1
  Suppress hello for 0 neighbor(s)

Como usted puede ver arriba, el tipo de red en ambos casos es de punto a punto. El problema es que un lado es innumerable y no es el otro lado, que crea una discrepancia en la base de datos como se muestra abajo.

R4-4K(4)# show ip ospf database router 172.16.30.1

  OSPF Router with ID (172.16.35.1) (Process ID 20)
 Router Link States (Area 0)
 LS age: 202
     Options: (No TOS-capability, DC)
     LS Type: Router Links
     Link State ID: 172.16.30.1
     Advertising Router: 172.16.30.1
     LS Seq Number: 80000002
     Checksum: 0xC899
     Length: 60
     Number of Links: 3
 Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 172.16.35.1
     (Link Data) Router Interface address: 172.16.32.2
     Number of TOS metrics: 0
     TOS 0 Metrics: 64
 Link connected to: a Stub Network
     (Link ID) Network/subnet number: 172.16.32.0
     (Link Data) Network Mask: 255.255.255.0
     Number of TOS metrics: 0
     TOS 0 Metrics: 64
 Link connected to: a Stub Network
     (Link ID) Network/subnet number: 172.16.30.1
     (Link Data) Network Mask: 255.255.255.255
     Number of TOS metrics: 0
     TOS 0 Metrics: 1

     R4-4k(4)#
    
R1-7010(5)# show ip ospf database router 172.16.35.1

OSPF Router with ID (172.16.30.1) (Process ID 20)
     Router Link States (Area 0)
 Adv Router is not-reachable
     LS age: 396
     Options: (No TOS-capability, DC)
     LS Type: Router Links
     Link State ID: 172.16.35.1
     Advertising Router: 172.16.35.1
     LS Seq Number: 80000003
     Checksum: 0xBEA1
     Length: 48
     Number of Links: 2
 Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 172.16.30.1
     (Link Data) Router Interface address: 0.0.0.3

          
!--- In case of an unnumbered link we use MIB 
          !--- II IfIndex value which usually starts with 0.

          
     Number of TOS metrics: 0
     TOS 0 Metrics: 64
 Link connected to: a Stub Network
     (Link ID) Network/subnet number: 172.16.35.1
     (Link Data) Network Mask: 255.255.255.255
     Number of TOS metrics: 0
     TOS 0 Metrics: 1

     R1-7010(5)#

Usted puede ver que el R1-7010 está generando un LSA para este link punto a punto con el campo de los datos de link que contiene su direccionamiento de la interfaz, mientras que el R4-4K está generando el LSA para el mismo link con el campo de los datos de link que contiene el valor del ifIndex MIBII. Esto crea una discrepancia en la base de datos de estado de link, que significa que no se instala ningunas rutas en la tabla de ruteo.

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
C       172.16.30.1/32 is directly connected, Loopback0

Solución

Para solucionar este problema, configure las interfaces seriales del Routers según lo o numerado o innumerable. En este ejemplo hemos numerado la interfaz del serial 2 del router R4-4K.

R4-4K(4)# configure terminal 
R4-4K(4)(config)# interface serial 2
R4-4K(4)(config-if)# no ip unnumbered loopback 0 
R4-4K(4)(config-if)# ip address 172.16.32.1 255.255.255.0

R4-4K(4))# show ip ospf interface serial 2
Serial2 is up, line protocol is up 
  Internet Address 172.16.32.1/24, Area 0 
  Process ID 20, Router ID 172.16.33.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.16.32.2
  Suppress hello for 0 neighbor(s)

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
O       172.16.33.1/32 [110/65] via 172.16.32.1, 00:03:08, Serial1/0
C       172.16.30.1/32 is directly connected, Loopback0

Razón 5: PVC quebrado en entorno de retransmisión de tramas completamente mallado

Considere este diagrama de la red como un ejemplo:

/image/gif/paws/7112/26d.gif

R9-2500
interface Loopback0
 ip address 50.50.50.50 255.255.255.255
 !
interface Serial0
 ip address 10.10.10.5 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast 
 frame-relay map ip 10.10.10.6 102 broadcast
 frame-relay map ip 10.10.10.7 101 broadcast

router ospf 10
 network 10.10.10.0 0.0.0.255 area 0
 network 50.50.50.0 0.0.0.255 area 0

R4-4K
interface Loopback0
 ip address 70.70.70.70 255.255.255.255
!
interface Serial0
 ip address 10.10.10.7 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 frame-relay map ip 10.10.10.5 101 broadcast
 frame-relay map ip 10.10.10.6 100 broadcast

router ospf 10
 network 10.10.10.0 0.0.0.255 area 0
 network 70.70.70.0 0.0.0.255 area 0

R3-4K
interface Loopback0
 ip address 60.60.60.60 255.255.255.255
 !
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.1 multipoint
 ip address 10.10.10.6 255.255.255.0
 ip ospf network broadcast
 frame-relay map ip 10.10.10.5 102 broadcast
 frame-relay map ip 10.10.10.7 100 broadcast
!
router ospf 10
 network 10.10.10.0 0.0.0.255 area 0
 network 60.60.60.0 0.0.0.255 area 0

El modelo de broadcast sobre el Frame Relay funciona correctamente mientras la nube de Frame Relay se enrede completamente. Si algunos circuitos virtuales permanentes (PVC) están quebrados, puede crear los problemas en las bases de datos OSPF, que a su vez presenta el mensaje alcanzable del router anunciante no.

En este ejemplo, el PVC entre el R9-2500 y el R4-4K está quebrados, y el link R9-2500 al router designado (DR) está quebrado. Como consecuencia, el R9-2500 declara todos los LSA del R3-4K (que no es un DR), como inalcanzable. Como usted puede ver, el R9-2500 no está generando un link de tránsito para la interfaz serial asociada al R3-4K; está generando un link del stub en lugar de otro porque por lo que el R9-2500 no hay DR en este link.

R9-2500(3)# show ip ospf database router

       OSPF Router with ID (50.50.50.50) (Process ID 10)
                Router Link States (Area 0)
  LS age: 148
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 50.50.50.50
  Advertising Router: 50.50.50.50
  LS Seq Number: 8000000B
  Checksum: 0x55A
  Length: 48
   Number of Links: 2

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.10.0
    (Link Data) Network Mask: 255.255.255.0
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 50.50.50.50
    (Link Data) Network Mask: 255.255.255.255
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

  Adv Router is not-reachable
  LS age: 1081
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 60.60.60.60
  Advertising Router: 60.60.60.60
  LS Seq Number: 80000006
  Checksum: 0x4F72
  Length: 48
   Number of Links: 2

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 60.60.60.60
    (Link Data) Network Mask: 255.255.255.255
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Transit Network
    (Link ID) Designated Router address: 10.10.10.7
    (Link Data) Router Interface address: 10.10.10.6
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

          
  Adv Router is not-reachable
  LS age: 306
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 70.70.70.70
  Advertising Router: 70.70.70.70
  LS Seq Number: 80000007
  Checksum: 0xC185
  Length: 48
   Number of Links: 2

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 70.70.70.70
    (Link Data) Network Mask: 255.255.255.255
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Transit Network
    (Link ID) Designated Router address: 10.10.10.7
    (Link Data) Router Interface address: 10.10.10.7
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

Refiera a los problemas con ejecutar el OSPF en el modo NBMA sobre el Frame Relay para información más detallada sobre este problema.

Razón 6: Dirección de reenvío que se conoce a través de una ruta externa

Considere este diagrama de la red como un ejemplo:

/image/gif/paws/7112/foradd.gif

R2507
interface Serial0
ip address 1.1.1.1 255.255.255.0
         
interface Serial1
ip address 7.7.7.1 255.255.255.0
         
router ospf 1
network 1.1.1.1 0.0.0.0 area 0
default- information originate metric 20
         
ip route 0.0.0.0 0.0.0.0 Serial1

R2504
interface Serial0
ip address 1.1.1.2 255.255.255.0
         
interface TokenRing0
ip address 3.3.4.2 255.255.255.0
         
router ospf 1
network 1.1.1.0 0.0.0.255 area 0
network 3.0.0.0 0.255.255.255 area 1
area 1 range 3.0.0.0 255.0.0.0

R2515
interface Serial1
ip address 4.4.4.3 255.255.255.0
       
interface TokenRing0
ip address 3.3.4.3 255.255.255.0
       
interface ethernet 0
ip address 3.44.66.3 255.255.255.0
       
interface ethernet 1
ip address 3.22.88.3 255.255.255.0
       
router ospf 1
redistribute rip metric 20 subnets
network 0.0.0.0 255.255.255.255 area 1
       
router rip
network 3.0.0.0

R2513
interface TokenRing0
ip address 3.3.4.4 255.255.255.0
       
interface ethernet 0
ip address 200.1.1.4 255.255.255.0
       
router rip
network 3.0.0.0
network 200.1.1.0

R2507# show ip ospf data external 200.1.1.0
       OSPF Router with ID (7.7.7.1) (Process ID 1)
       Type- 5 AS External Link States
       LS age: 72
       Options: (No TOS- capability, DC)
       LS Type: AS External Link
       Link State ID: 200.1.1.0 (External Network Number )
       Advertising Router: 3.44.66.3
       LS Seq Number: 80000001
       Checksum: 0xF161
       Length: 36
       Network Mask: /24
                   Metric Type: 2 (Larger than any link state path)
                   TOS: 0
                   Metric: 20
                   Forward Address: 3.3.4.4
                   External Route Tag: 0

El R2507 tiene 200.1.1.0/24 en su base de datos pero no la ha instalado en la tabla de ruteo porque 3.3.4.4 es docto vía una ruta externo OSPF.

R2507# show ip route 3.3.4.4
       Routing entry for 3.3.4.0/ 24
       Known via "ospf 1", distance 110, metric 20,type extern 2, forward metric 70
       Redistributing via ospf 1
       Last update from 1.1.1.2 on Serial0, 00: 00: 40 ago
       Routing Descriptor Blocks:
       * 1.1.1.2, from 3.44.66.3, 00: 00: 40 ago, via Serial0
          Route metric is 20, traffic share count is 1

Nota: Con el arreglo del CSCdp72526 del Id. de bug Cisco (clientes registrados solamente), el OSPF no genera un anuncio del estado del vínculo type-5 (LSA) de una red externa solapada; por lo tanto, el R2507 tendrá solamente una ruta dentro de una zona sumaria de 3.0.0.0/8. Entonces, el R2507 instalará 200.1.1.0/24 como la dirección de reenvío y él serán accesibles vía la ruta dentro de una zona 3.0.0.0/8, así de acuerdo con el RFC 2328leavingcisco.com .

Después de que el arreglo del bug antedicho, salida parezca el siguiente:

R2507# show ip route 3.3.4.4
      Routing entry for 3.0.0.0/8
      Known via "ospf 1", distance 110, metric 74, type inter area
      Last update from 1.1.1.2 on Serial0, 00:19:20 ago
      Routing Descriptor Blocks:
      * 1.1.1.2, from 3.3.4.2, 00:19:20 ago, via Serial0



R2507# show ip route  
      Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
    C 1.1.1.0 is directly connected, Serial0
    O IA 3.0.0.0/8 [110/74] via 1.1.1.2, 00:30:18, Serial0
    O E2 200.1.1.0/24 [110/20] via 1.1.1.2, 00:22:58, Serial0
    Route metric is 74, traffic share count is 1

R2507#

Si conocen a la dirección de reenvío también vía una ruta externo, el OSPF no instala esa ruta en la tabla de ruteo. Para información más detallada sobre este problema, vea el problema de Ruteo Común con el OSPF Forwarding Address.

Razón 7: Distribuir lista bloquea las rutas

Utilicemos el siguiente diagram de red como un ejemplo:

/image/gif/paws/7112/26a.gif

R4-4K R1-7010
interface Loopback0
 ip address 172.16.33.1 255.255.255.255

interface Serial2
 ip address 172.16.32.1 255.255.255.0

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
interface Loopback0
 ip address 172.16.30.1 255.255.255.255
!
interface Serial1/0
 ip address 172.16.32.2 255.255.255.0
 clockrate 64000

router ospf 20
 network 172.16.0.0 0.0.255.255 area 0
 distribute-list 1 in
!
access-list 1 permit 172.16.32.0. 0.0.0.255

Como usted puede ver arriba, el R1-7010 tiene el comando distribute-list configurado y solamente está permitiendo que a 172.16.32.0/24 el intervalo de direcciones fuera instalado en la tabla de ruteo. En los protocolos del link-state usted no puede filtrar realmente un LSA con el comando distribute-list. El LSA todavía estará en la base de datos; sin embargo el LSA no será instalado en la tabla de ruteo.

R1-7010(5)# show ip ospf database router 172.16.33.1

  LS age: 357
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 172.16.33.1
  Advertising Router: 172.16.33.1
  LS Seq Number: 8000000A
  Checksum: 0xD4AA
  Length: 48
   Number of Links: 3

 Link connected to: another Router (point-to-point)
    (Link ID) Neighboring Router ID: 172.16.32.2
    (Link Data) Router Interface address: 172.16.32.1
    Number of TOS metrics: 0
    TOS 0 Metrics: 64

El comando distribute-list configuration en el R1-7010 está filtrando la red 172.16.33.1/32 de ser instalado en la tabla de ruteo.

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
C       172.16.30.1/32 is directly connected, Loopback0

Solución

Para solucionar este problema, configuración R1-7010 y permitir 172.16.33.0/24 en el Access Control List (ACL) que esta red consigue tan instalado en la tabla de ruteo.

R1-7010(5)# configure terminal 
R1-7010(5)(config)# access-list 1 permit 172.16.33.0 0.0.0.255 
R1-7010(5)(config)# end

R1-7010(5)# show ip access-list 1
Standard IP access list 1
    permit 172.16.32.0, wildcard bits 0.0.0.255
    permit 172.16.33.0, wildcard bits 0.0.0.255

R1-7010(5)# show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.32.0/24 is directly connected, Serial1/0
O       172.16.33.1/32 [110/65] via 172.16.32.1, 00:00:08, Serial1/0
C       172.16.30.1/32 is directly connected, Loopback0

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 7112