Marcado y acceso remotos : Dial-on-Demand Routing (DDR)

Configuración de la marcación de entrada y de salida en los mismos circuitos T1/E1 PRI

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo configurar un Servidor de acceso para llamadas entrantes y salientes en el mismo T1 PRI. Todas las llamadas entrantes y salientes se basan en el tráfico y utilizan Dial-On-Demand Routing (DDR) pero no proporcionan respaldo para ningún otro router. Si desea configurar un Servidor de Acceso para las llamadas de marcado de entrada solamente, consulte el documento Configuración del Servidor de Acceso con PRI para las Llamadas ISDN y Asíncronas Entrantes. Para adaptar esta configuración de manera que incluya respaldo, consulte el documento Configuración y Troubleshooting de DDR Backup.

prerrequisitos

Requisitos

Paso 1 - Configure y verifique que ponen el dialin y a los Clientes de marcado de salida correctamente. Dado que esta configuración se centra en la configuración NAS del sitio central, no se incluye una configuración de muestra para clientes. A continuación se incluyen algunos ejemplos de configuraciones de cliente:

Cliente de marcación de entrada - Dispositivo ese diales en el NAS:

Cliente de marcado de salida - Dispositivo al cual este NAS marca hacia fuera:

Paso 2: verifique que los circuitos Telco funcionen correctamente. Usted puede utilizar el comando show isdn status de verificar que el circuito BRI o PRI functionting correctamente. Para obtener más información, consulte el documento Utilizar el comando show isdn status para la resolución de problemas de BRI. También debe habilitar el circuito PRI T1/E1 para llamadas salientes. Comuníquese con su compañía telefónica para corroborar esta información.

Componentes Utilizados

Esta configuración fue desarrollada y probada utilizando las versiones de software y hardware indicadas a continuación.

  • NAS : Cisco AS5300 con un circuito PRI T1. Este AS5300 está ejecutando la versión de software de IOS de Cisco 12.2(5).

  • Cliente: Cisco AS5300 con un circuito PRI T1. Esta configuración no está incluida.

  • Cliente: Cisco 1600 con un circuito BRI. Esta configuración no está incluida.

  • Cliente: Cisco 804 con un circuito BRI Esta configuración no está incluida.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Teoría Precedente

En muchas situaciones es posible que sea necesario usar el mismo circuito PRI T1/E1 para conexiones de marcación de entrada y de salida. El Network Access Sever (NAS) soportaría las llamadas entrantes de los usuarios del ISDN múltiple y lo podría también hacer las llamadas de salida en el mismo PRI a otro dispositivo. El marcado saliente también podría utilizarse en un escenario de copia de respaldo, donde NAS marcaría y se conectaría con un par que pierde el link WAN principal.

Productos Relacionados

Esta configuración puede utilizarse con cualquier router que tenga las tarjetas T1 o PRI. Por lo tanto, todo router serie AS5xxx con tarjeta T1 o PRI puede utilizar esta configuración. Los routers de las series 2600 y 3600 de Cisco pueden también configurarse para aceptar llamadas ISDN con una tarjeta de interfaz WAN T1/PRI o un módulo de red.

Esta configuración también puede ser modificada para ser utilizada con los puertos E1 o PRI. Configure el controlador E1 con la codificación de línea, la alineación de trama y otras características físicas provistas por la compañía de telecomunicaciones. La configuración del canal D (interfaz serial x:15 para E1) es similar a la que se muestra aquí.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la herramienta IOS Command Lookup

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

/image/gif/paws/6435/pri_dialin_6435.gif

Configuraciones

Hay dos métodos principales para configurar un servidor de acceso para poder hacer las llamadas salientes y validar las llamadas entrantes en el mismo T1/E1 PRI. Estos son Perfiles de marcador y Grupos rotativos de marcador. Cada uno tiene sus ventajas y desventajas, por ejemplo:

  • Los grupos rotativos de dialers son más simples configurar y manejar.

  • Los Perfiles de marcado necesitan una interfaz de dialer diferente para cada llamadas entrante y saliente. Si hay numerosos pares entrantes y salientes, entonces, será complicado crear y mantener la configuración.

  • Los perfiles del marcador permiten la configuración específica de clientes. Por ejemplo, usted puede especificar que asignarán cierto cliente una dirección IP de la agrupación de direcciones A mientras que asignarán otro cliente un direccionamiento del pool B.

  • Los grupos rotativos de dialers permiten que solamente los mismos parámetros sean aplicados a todos los usuarios. No es posible la personalización para cada usuario.

  • Los grupos rotativos de marcador permiten únicamente una sola definición de tráfico interesante para las llamadas entrantes y salientes. Por lo tanto, usted no puede configurar al router para utilizar una definición de tráfico interesante para las llamadas entrantes y otro para las llamadas salientes.

  • Los Perfiles de marcado permiten las definiciones de tráfico interesante separadas para cada par.

Este documento proporciona las muestras usando los Perfiles de marcado y los grupos rotativos de dialers en el NAS. Elija el método apropiado para la situación.

Servidor de acceso central con perfiles de marcador (AS5300)
maui-nas-03#show running-config 
Building configuration...

Current configuration : 3351 bytes
!
! Last configuration change at 07:25:39 CDT Wed Oct 24 2001
! NVRAM config last updated at 16:37:00 CDT Tue Oct 23 2001
!
version 12.2
service timestamps debug datetime msec show-timezone
service timestamps log datetime msec show-timezone
service password-encryption
!
hostname maui-nas-03
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local
aaa authorization network default local 
enable secret 5 <deleted>
!
username admin password 7 <deleted>
username 800-isdn-client password 7 <deleted>
username 1600-isdn-client password 7 <deleted>
username 5300-client password 7 <deleted>
username lanai-nas-01 password 7 <deleted>

! -- Usernames for local authentication of the call.
! -- The client presents the username/password 
! -- and the NAS authenticates the peer.

spe 2/0 2/7
 firmware location mica-modem-pw.2.7.3.0.bin
!
resource-pool disable
!
clock timezone CST -6
clock summer-time CDT recurring
ip subnet-zero
!
isdn switch-type primary-ni

! -- Switch-type for this NAS. Obtain this information from the Telco.

isdn voice-call-failure 0
!
controller T1 0

! -- T1 PRI physical controller configuration.

 framing esf

! -- Framing for this T1 is Extended Super Frame (ESF). 
! -- Obtain this information from the telco.

 clock source line primary

! -- T1 0 is the primary clock source for this NAS. 
! -- Clock source must be specified for the timing 
! -- and synchronization of the T1 carrier.

 linecode b8zs

! -- Linecoding for this T1. Obtain this information from the telco.

 pri-group timeslots 1-24

! -- For T1 PRI scenarios, all 24 T1 timeslots are assigned 
! -- as ISDN PRI channels. The router will now automatically create the 
! -- corresponding D-channel: interface Serial 0:23
!
! -- The configurations for unused T1 controllers are omitted to save space.
! -- Unused T1s can be shutdown.


!
interface Ethernet0
 ip address 172.22.53.150 255.255.255.0
!
interface Serial0:23

! -- D-channel configuration for T1 0.

 no ip address
 encapsulation ppp
 dialer pool-member 10

! -- Assign this D-channel as member of dialer pool 10.
! -- Dialer pool 10 is used by interface Dialer 1 and Dialer 2. 
! -- All Dialer Interfaces for incoming calls should be configured 
! -- to use this pool.

 dialer pool-member 50 max-link 10

! -- The D-channel is also a member of dialer pool 50.
! -- Dialer pool 50 is used by interface Dialer 100.
! -- The pool can use a maximum of 10 links and will be used for outgoing calls.
 
 isdn switch-type primary-ni
 isdn bchan-number-order ascending

! -- B Channel Outgoing Call Order is ascending.
! -- Contact the Telco to determine whether the ISDN outbound trunk 
! -- call selection is configured for ascending or descending on the switch.

 no cdp enable
 ppp authentication chap
 ppp multilink

! -- Allow multlink ppp on this interface.

!
interface FastEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Dialer1
 description For Dialin ISDN Client - austin-soho-01
 ip unnumbered Ethernet0

! -- The interface is unnumbered to conserve IP addresses.

 encapsulation ppp
 dialer pool 10

! -- Defines the pool of physical resources from which the Dialer 
! -- interface may draw B channels as needed. Interface Dialer 2 also 
! -- uses this pool. Serial 0:23 is a member of this pool.

 dialer remote-name 1600-isdn-client

! -- Specifies remote router authenticated name and must match that used by 
! -- the remote router to authenticate itself (which can be different from
! -- the router hostname). The router uses this remote-name to bind the 
! -- incoming call to this dialer. without this command calls from 
! -- 1600-isdn-client will fail after authentication.

 dialer idle-timeout 0

! -- Set an idle-timeout of infinity. 
! -- The "zero" option for dialer idle-timeout was introduced in 12.1(3)T.

 dialer-group 1

! -- Apply interesting traffic definition from dialer-list 1.


 peer default ip address pool DIALIN

! -- Clients are assigned addresses from the ip address pool named "DIALIN".

 no fair-queue
 ppp authentication chap callin
 ppp multilink
!
interface Dialer2
 description For Dialin ISDN Client - travis-soho-01
 ip unnumbered Ethernet0
 encapsulation ppp
 dialer pool 10

! -- Defines the pool of physical resources from which the Dialer 
! -- interface may draw B channels as needed. Interface Dialer 1 
! -- also uses this pool. Serial 0:23 is a member of this pool.

 dialer remote-name 800-isdn-client

! -- Binds incoming calls from  user "800-isdn-client" to this dialer.

 dialer-group 1

! -- Apply interesting traffic definition from dialer-list 1. 

 peer default ip address pool DIALIN
 pulse-time 0
 ppp authentication chap callin
 ppp multilink
!
interface Dialer100
 description For Dialout Client - lanai-nas-01
 ip unnumbered Ethernet0
 encapsulation ppp
 dialer pool 50

! -- This dialer will draw resources from dialer pool 50 
! -- in which int serial 0:23 is the sole member.
! -- Since this dialer is used for dialout, 
! -- the outgoing call will be sent to interface se 0:23.

 dialer remote-name lanai-nas-01

! -- Specifies remote router authenticated name and must match that used by 
! -- the remote router to authenticate itself 
! -- (which can be different from the router hostname).

 dialer idle-timeout 900

! -- Idle timeout for incoming calls is 900 seconds (15 mins).
! -- Users that are idle for more than 900 seconds will be dropped.

 dialer string 81690 class 56k

!--- Dial 81690 and use the map-class named "56k" (defined below).

 dialer load-threshold 1 outbound

! -- This sets the outbound load level for traffic at which
! -- additional connections will be added to the MP bundle load level.
! -- Values range from 1 (unloaded) to 255 (fully loaded). 
! -- With a threshold of 1, additional links will be immediately 
! -- brought up and added to the bundle.

 dialer-group 3

! -- Apply interesting traffic definition from dialer-list 3.
! -- Note: the interesting traffic definition for outbound 
! -- calls is different than for incoming calls.

 ppp authentication chap
 ppp multilink

! -- Allow multlink ppp.

!         
router eigrp 69
 network 172.22.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip local pool DIALIN 172.22.53.151 172.22.53.159

! -- IP address pools for dialin clients.

ip classless
ip route 172.16.0.0 255.255.0.0 Dialer100

! -- Static route for the 172.16.0.0/16 network. 
! -- Interesting Traffic for that network
! -- will be sent to interface Dialer100 and the router 
! -- will initiate the outbound call.

no ip http server
ip pim bidir-enable
!
!
map-class dialer 56k

!-- map-class named "56k" that was used with the dialer string in int Dialer100.

 dialer isdn speed 56

! -- Set the speed of the call to be 56k (default is 64k).
! -- This may not be neccessary for your connection. Consult your telco
! --  to find out if you need to configure the dial speed to 56k.

access-list 101 remark Interesting traffic definition for dialin clients
access-list 101 deny   eigrp any any
access-list 101 deny   udp any any eq ntp
access-list 101 permit ip any any

! -- EIGRP and  NTP traffic are tagged uninteresting for dialin clients.

access-list 103 remark Interesting traffic for link lanai-nas-01
access-list 103 deny   eigrp any any
access-list 103 deny   udp any any eq ntp
access-list 103 permit ip any any

! -- EIGRP and  NTP traffic are tagged uninteresting for the outbound dial.
! -- Eventhough the two interesting traffic definitions here are identical, 
! -- they can be changed depending on your traffic patterns.

dialer-list 1 protocol ip list 101

!--- Interesting traffic is defined by access-list 101.
!--- This is applied to interface Dialer 1 & 2 using the command dialer-group 1.
!--- Note: The specified dialer-list number must be the same 
!--- as the dialer-group number; in this example, defined to be "1".

dialer-list 3 protocol ip list 103
!
line con 0
 exec-timeout 0 0
 login authentication NO_AUTHEN
line 1 48
line aux 0
line vty 0 4
!
ntp clock-period 17180029
ntp server 172.22.53.1
end

La configuración del perfil de marcado antedicha tiene una interfaz de dialer diferente para cada llamadas entrante y saliente. Las interfaces de marcador para las llamadas entrantes son el Marcador 1 y el Marcador 2, mientras que la interfaz de marcador para las llamadas salientes es el Marcador100. Luego de autenticada la llamada entrante, el router vincula la llamada con la interfaz de marcador apropiada a partir del nombre remoto del marcador. Sólo la interfaz de marcador para la llamada saliente (Dialer100) tiene una cadena de marcado con el número al que se va a llamar. Solamente Dialer100 incluye el comando dialer load-threshold, puesto que puede marcar los links adicionales dependiendo del carga entrante o saliente (el valor por defecto es saliente).

La siguiente configuración utiliza grupos rotativos de marcadores para este escenario:

Servidor de acceso central con grupos rotativos
maui-nas-03#show running-config 
Building configuration...

Current configuration : 2436 bytes
!
! Last configuration change at 08:20:11 CDT Thu Oct 25 2001
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname maui-nas-03
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local
aaa authorization network default local 
enable secret 5 <deleted>
!
username admin password 7 <deleted>
username lanai-nas-01 password 7 <deleted>
username 800-isdn-client password 7 <deleted>
username 1600-isdn-client password 7 <deleted>
spe 2/0 2/7
 firmware location mica-modem-pw.2.7.3.0.bin
!
resource-pool disable
!
clock timezone CST -6
clock summer-time CDT recurring
ip subnet-zero
!
isdn switch-type primary-ni
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!

! -- The configuration for unused T1 controllers are omitted to save space.
! -- Unused T1s can be shutdown.

!
interface Ethernet0
 ip address 172.22.53.150 255.255.255.0
!
interface Serial0:23

! -- D-channel configuration for T1 0.

 no ip address
 encapsulation ppp
 dialer rotary-group 1

! -- T1 0 is a member of rotary group 1.
! -- The rotary group configuration is in interface Dialer 1.
! -- Note: this command was not included in the dialer profile configuration.

 isdn switch-type primary-ni
 isdn bchan-number-order ascending
 no peer default ip address
 no cdp enable
 ppp authentication chap
 ppp multilink
!
interface FastEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Dialer1

!--- Configuration for rotary group 1.
!--- The Dialer interface number (1) must exactly match rotary group number
!--- configured on the physical interfaces(interface Serial 0:23).

 ip unnumbered Ethernet0

! -- This dialer is unnumbered to ethernet 0.

 encapsulation ppp
 dialer in-band

! -- Enable this dialer interface to be a DDR interface.

 dialer idle-timeout 900

! -- Idle timeout for incoming calls is 900 seconds (15 mins).
! -- Users that are idle for more than 900 seconds will be dropped.
! -- If dialer in-band is used and a dialer idle-timeout is not defined, then 
! -- the default idle-timeout of 120 seconds (2min) will be applied.

 dialer map ip 172.16.1.1 name lanai-nas-01 speed 56 broadcast 81690

! -- Dialer map for the outbound dial. Add a dialer map for every router 
! -- that needs to be dialed. Inbound calls do not need dialer maps. 
! -- They will be dynmamically created.

 dialer load-threshold 1 outbound

! -- This sets the outbound load level for Multlink PPP at 1/255.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.
! -- Note: The specified dialer-group number must be the same as 
! -- the dialer-list number; in this example, defined to be "1". 

 peer default ip address pool DIALIN

! -- clients are assigned addresses from the ip address pool named "DIALIN".

 no cdp enable
 ppp authentication chap
 ppp multilink
 multilink max-links 5
!
router eigrp 69
 network 172.22.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip local pool DIALIN 172.22.53.151 172.22.53.159
ip classless
ip route 172.16.0.0 255.255.0.0 172.16.1.1
ip route 172.16.1.1 255.255.255.255 Dialer1
no ip http server
ip pim bidir-enable
!
!
access-list 101 remark Interesting traffic definition
access-list 101 deny   eigrp any any
access-list 101 deny   udp any any eq ntp
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

! -- Interesting traffic is defined by dialer-list 1.
! -- This is applied to interface Dialer 1 using dialer-group 1.
! -- The interesting traffic definition for inbound and outbound calls 
! -- is the same. If you want different interesting traffic definition 
! -- for inbound and outbound calls use dialer profiles.

!
line con 0
 login authentication NO_AUTHEN
line 1 48
line aux 0
line vty 0 4
!
ntp clock-period 17179882
ntp server 172.22.53.1
end

En la configuración de grupo rotativo del marcador, la interfaz de marcado tiene un solo mapa del marcador usado para realizar llamadas. Configure un mapa de marcado para cada par que hay que marcar.

Nota: Las llamadas entrantes no necesitan mapas del marcador porque son creadas dinámicamente. Esto puede verificarse mediante el comando show dialer map. Se presenta un ejemplo a continuación:

maui-nas-03#show dialer map
Dynamic dialer map ip 172.22.53.152 name 1600-isdn-client () on Di1

! -- Dynamic dialer map for 1600-isdn-cliet created from Dialer1
! -- (the rotary group interface).

Dynamic dialer map ip 172.22.53.151 name 800-isdn-client () on Di1

! -- Dynamic dialer map for 800-isdn-cliet created from Dialer1
! -- (the rotary group interface).

Static dialer map ip 172.16.1.1 name lanai-nas-01 (81690) on Di1

! -- Static map configured on Dialer 1 was applied to this link 
! -- connected to lanai-nas-01.


Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta del Output Interpreter soportan a los ciertos comandos show, que permite que usted vea una análisis de la salida del comando show.

  • show isdn status - Asegura que el router se comunique adecuadamente con el switch ISDN. Verifique en el resultado que el estado de la capa 1 sea ACTIVE (Activo) y que aparezca MULTIPLE_FRAME_ESTABLISHED en la capa 2. Este comando muestra también el número de llamadas activas.

  • show ppp multilink – Muestra información en agrupamientos de enlaces múltiples que se encuentran activos. Este comando debería utilizarse para verificar la conexión de links múltiples.

  • show dialer [número de tipo de la interfaz] – Muestra información general de diagnóstico para interfaces configuradas para DDR. Si el marcador apareció correctamente debe aparecer un mensaje que diga: Estado del marcador: capa del link de datos en funcionamiento. Si la capa física que está funcionando aparece, el protocolo de línea ha sido añadido, pero no así el Protocolo de control de red (NCP) Las direcciones de origen y destino del paquete que inició el marcado se ven en la línea de motivo del marcado. Este comando show también muestra la configuración del temporizador y el tiempo antes de que se termine el tiempo de espera de la conexión

  • show caller user username detail – Muestra parámetros específicos para un usuario en particular, como la dirección de IP asignada, los parámetros PPP y de agrupamiento PPP, etc. Si su versión del Cisco IOS Software no soporta este comando, utilice el comando show user.

  • show dialer map – Muestra mapas de marcado configurados, dinámicos y estáticos. Puede usar este comando para ver si el mapa del marcador dinámico ha sido creado. Sin un asignador de marcado no puede rutear paquetes.

A continuación, se ofrecen algunas salidas del comando show en llamadas exitosas. Preste atención a las secciones en negrita y a los comentarios proporcionados en los resultados. Compare el resultado obtenido con el resultado a continuación.

maui-nas-03#show isdn status
Global ISDN Switchtype = primary-ni
ISDN Serial0:23 interface
        dsl 0, interface ISDN Switchtype = primary-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

    ! -- Layer 1 is ACTIVE and Layer 2 is MULTIPLE FRAME ESTABLISHED.

    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x807FFFFF
    Number of L2 Discards = 0, L2 Session ID = 0
    Total Allocated ISDN CCBs = 0

maui-nas-03#show isdn service
PRI Channel Statistics:
ISDN Se0:23, Channel [1-24]
  Configured Isdn Interface (dsl) 0
   Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3 
   Service State (0=Inservice 1=Maint 2=Outofservice)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 

! -- All channels are Inservice.


maui-nas-03#show user
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00   

  Interface      User        Mode                     Idle     Peer Address
  Di100        lanai-nas- PPP   Bundle        00:00:35 172.16.1.1

  ! -- Connection to lanai-nas-01 uses int Dialer 100.

  Di2          800-isdn-c PPP   Bundle        00:00:22 172.22.53.154
  
! -- Connection to 800-isdn-client uses int Dialer 2.

  Di1          1600-isdn- PPP   Bundle        00:01:29 172.22.53.153
 
 ! --  Connection to 1600-isdn-client uses int Dialer 1.

  Se0:0        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:1        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:2        1600-isdn- Sync PPP                    -   Bundle: Di1
  Se0:3        1600-isdn- Sync PPP                    -   Bundle: Di1
  Se0:4        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:5        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:6        lanai-nas- Sync PPP                    -   Bundle: Di100
  Se0:7        800-isdn-c Sync PPP                    -   Bundle: Di2
  Se0:8        800-isdn-c Sync PPP                    -   Bundle: Di2

  ! -- Two B-channels are connected to 800-isdn-client (Se0:7-Se0:8) and 
  ! -- 1600-isdn-client (Se0:2-Se0:3). Five other B-channels 
  ! -- (Se0:0-Se0:1 and Se0:4-Se0:6) are connected to lanai-nas-01.


maui-nas-03#show ppp multilink 

Dialer2, bundle name is 800-isdn-client

  ! -- int Dialer 2 controls multilink bundle to 800-isdn-client.

  Bundle up for never
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x8 received sequence, 0xC sent sequence
  Member links: 2 (max not set, min not set)
    Serial0:7, since 00:00:16, last rcvd seq 000006
    Serial0:8, since 00:00:15, last rcvd seq 000007

  ! -- B-channels Se0:7 and Se0:8 are connected.


Dialer100, bundle name is lanai-nas-01

! -- int Dialer 100 controls multilink bundle to lanai-nas-01.

  Bundle up for never
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x33 received sequence, 0x33 sent sequence
  Member links: 5 (max not set, min not set)
    Serial0:0, since 00:02:08, last rcvd seq 000032
    Serial0:1, since 00:02:05, last rcvd seq 00002E
    Serial0:4, since 00:01:35, last rcvd seq 00002F
    Serial0:5, since 00:01:05, last rcvd seq 000030
    Serial0:6, since 00:00:35, last rcvd seq 000031

  ! -- B-channels Se0:0-Se0:1 and Se0:4-Se0:6 are connected.


Dialer1, bundle name is 1600-isdn-client

! -- int Dialer 100 controls multilink bundle to 1600-isdn-client.

  Bundle up for never
  0 lost fragments, 1 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x28 received sequence, 0x7B sent sequence
  Member links: 2 (max not set, min not set)
    Serial0:2, since 00:06:24, last rcvd seq 000026
    Serial0:3, since 00:06:22, last rcvd seq 000027

 ! -- B-channels Se0:2 and Se0:3 are connected.


Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Recursos de resolución de problemas

Use los siguientes recursos de resolución de problemas según lo necesite:

Comandos para resolución de problemas

La herramienta del Output Interpreter soportan a los ciertos comandos show, que permite que usted vea una análisis de la salida del comando show.

Nota: Antes de ejecutar un comando debug, consulte Información Importante sobre Comandos Debug.

  • debug dialer - Muestra la información de la depuración DDR acerca de los paquetes recibidos en una interfaz de marcado. Esta información lo ayuda a asegurarse de que hay tráfico interesante que puede usar la interfaz del dialer.

  • debug isdn q931 – Muestra la configuración de la llamada y cierra las conexiones de la red ISDN (Capa 3)

  • debug pp negotiation – Muestra información sobre el tráfico PPP e intercambios mientras negocia el Protocolo de control de link (LCP), la autenticación ysel Protocolo de control de red (NCP). Una negociación PPP exitosa abrirá primero el estado LCP, luego realizará la autenticación y por último negociará el NCP. Los parámetros de links múltiples como el Maximum Receive Reconstructed Unit (MRRU) se establecen durante la negociación LCP (protocolo de control de links)

  • debug ppp authentication – Muestra los mensajes del protocolo de autenticación PPP, entre ellos intercambios de paquetes CHAP (Protocolo de autenticación por desafío mutuo) e intercambios de protocolo de autenticación de contraseña (PAP).

  • debug ppp error - Los errores del protocolo y la estadística de errore de las visualizaciones se asociaron a la negociación y a la operación de la conexión PPP.

A continuación se encuentran las salidas de depuración para una llamada saliente satisfactoria. Preste atención a las secciones en negrita y a los comentarios proporcionados en los resultados. Compare el resultado obtenido con el resultado a continuación.

maui-nas-03#debug dialer
Dial on demand events debugging is on
maui-nas-03#debug ppp negotiation
PPP protocol negotiation debugging is on
maui-nas-03#debug ppp authentication
PPP authentication debugging is on
maui-nas-03#debug isdn q931
ISDN Q931 packets debugging is on

maui-nas-03#ping 172.16.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:

Oct 24 12:56:16.205 UTC: Se0:23 DDR: rotor dialout [priority]
Oct 24 12:56:16.205 UTC: Se0:23 DDR: Dialing cause ip 
(s=172.22.53.150, d=172.16.1.1)

! -- The dialing cause is a ping for 172.16.1.1. 
! -- ICMP is tagged as interesting.

Oct 24 12:56:16.205 UTC: Se0:23 DDR: Attempting to dial 81690
Oct 24 12:56:16.205 UTC: ISDN Se0:23: TX -> SETUP pd = 8  callref = 0x0063

! -- Outgoing ISDN Q.931 SETUP message.

Oct 24 12:56:16.205 UTC:         Bearer Capability i = 0x8890218F
Oct 24 12:56:16.205 UTC:         Channel ID i = 0xA98381
Oct 24 12:56:16.209 UTC:         Called Party Number i = 0x80, '81690', 
Plan:Unknown, Type:Unknown
Oct 24 12:56:16.241 UTC: ISDN Se0:23: RX <- CALL_PROC pd = 8  callref = 0x8063
Oct 24 12:56:16.241 UTC:         Channel ID i = 0xA98381
Oct 24 12:56:16.285 UTC: ISDN Se0:23: RX <- CONNECT pd = 8  callref = 0x8063

! -- Received Q.931 CONNECT message.

Oct 24 12:56:16.297 UTC: %LINK-3-UPDOWN: Interface Serial0:0, changed state to up
Oct 24 12:56:16.297 UTC: Se0:0: interface must be fifo queue, force fifo
Oct 24 12:56:16.297 UTC: %DIALER-6-BIND: Interface Se0:0 bound to profile Di100
Oct 24 12:56:16.297 UTC: Se0:0 PPP: Treating connection as a callout
Oct 24 12:56:16.297 UTC: Se0:0 PPP: Phase is ESTABLISHING, 
Active Open [0 sess, 1 load]
Oct 24 12:56:16.301 UTC: Se0:0 LCP: O CONFREQ [Closed] id 12 len 33
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    MagicNumber 0xE384A4CD (0x0506E384A4CD)
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.301 UTC: Se0:0 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:16.301 UTC: ISDN Se0:23: TX -> CONNECT_ACK pd = 8  callref = 0x0063
Oct 24 12:56:16.317 UTC: Se0:0 LCP: I CONFREQ [REQsent] id 10 len 34
Oct 24 12:56:16.317 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.317 UTC: Se0:0 LCP:    MagicNumber 0x54F49B93 (0x050654F49B93)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:16.321 UTC: Se0:0 LCP: O CONFACK [REQsent] id 10 len 34
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    MagicNumber 0x54F49B93 (0x050654F49B93)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.321 UTC: Se0:0 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:16.325 UTC: Se0:0 LCP: I CONFACK [ACKsent] id 12 len 33
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    MagicNumber 0xE384A4CD (0x0506E384A4CD)
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:16.325 UTC: Se0:0 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:16.325 UTC: Se0:0 LCP: State is Open

! -- LCP negotation is complete.

Oct 24 12:56:16.325 UTC: Se0:0 PPP: Phase is AUTHENTICATING, 
by both [0 sess, 1 load]
Oct 24 12:56:16.325 UTC: Se0:0 CHAP: O CHALLENGE id 8 len 32 from "maui-nas-03"
Oct 24 12:56:16.337 UTC: Se0:0 CHAP: I CHALLENGE id 10 len 33 from "lanai-nas-01"
Oct 24 12:56:16.341 UTC: Se0:0 CHAP: O RESPONSE id 10 len 32 from "maui-nas-03"
Oct 24 12:56:16.353 UTC: Se0:0 CHAP: I SUCCESS id 10 len 4
Oct 24 12:56:16.357 UTC: Se0:0 CHAP: I RESPONSE id 8 len 33 from "lanai-nas-01"
Oct 24 12:56:16.361 UTC: Se0:0 CHAP: O SUCCESS id 8 len 4

! -- Two-way CHAP authentication is successful.

Oct 24 12:56:16.361 UTC: Se0:0 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
Oct 24 12:56:16.361 UTC: Di100 DDR: Authenticated host lanai-nas-01 
with no matching dialer map
Oct 24 12:56:16.361 UTC: Di100 PPP: Phase is UP [0 sess, 1 load]
Oct 24 12:56:16.361 UTC: Di100 IPCP: O CONFREQ [Closed] id 6 len 10
Oct 24 12:56:16.361 UTC: Di100 IPCP:    Address 172.22.53.150 (0x0306AC163596)
Oct 24 12:56:16.361 UTC: Di100 CDPCP: O CONFREQ [Closed] id 6 len 4
Oct 24 12:56:16.365 UTC: Di100 MLP: Added first link Se0:0 to bundle lanai-nas-01
Oct 24 12:56:16.365 UTC: Di100 PPP: Treating connection as a callout
Oct 24 12:56:16.377 UTC: Di100 IPCP: I CONFREQ [REQsent] id 1 len 10
Oct 24 12:56:16.377 UTC: Di100 IPCP:    Address 172.16.1.1 (0x0306AC100101)
Oct 24 12:56:16.377 UTC: Di100 IPCP: O CONFACK [REQsent] id 1 len 10
Oct 24 12:56:16.377 UTC: Di100 IPCP:    Address 172.16.1.1 (0x0306AC100101)
Oct 24 12:56:16.381 UTC: Di100 IPCP: I CONFACK [ACKsent] id 6 len 10
Oct 24 12:56:16.381 UTC: Di100 IPCP:    Address 172.22.53.150 (0x0306AC163596)
Oct 24 12:56:16.381 UTC: Di100 IPCP: State is Open
Oct 24 12:56:16.381 UTC: Di100 DDR: dialer protocol up
Oct 24 12:56:16.381 UTC: Di100 IPCP: Install route to 172.16.1.1

! -- A route to the peer is installed.

Oct 24 12:56:17.361 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:0, 
changed state to up
Oct 24 12:56:19.113 UTC: Se0:23 DDR: rotor dialout [priority]

! -- Second call is being dialed.

Oct 24 12:56:19.113 UTC: Se0:23 DDR: Attempting to dial 81690
Oct 24 12:56:19.113 UTC: ISDN Se0:23: TX -> SETUP pd = 8  callref = 0x0064
Oct 24 12:56:19.113 UTC:         Bearer Capability i = 0x8890218F
Oct 24 12:56:19.113 UTC:         Channel ID i = 0xA98382
Oct 24 12:56:19.113 UTC:         Called Party Number i = 0x80, '81690', 
Plan:Unknown, Type:Unknown
Oct 24 12:56:19.141 UTC: ISDN Se0:23: RX <- CALL_PROC pd = 8  callref = 0x8064
Oct 24 12:56:19.141 UTC:         Channel ID i = 0xA98382
Oct 24 12:56:19.205 UTC: ISDN Se0:23: RX <- CONNECT pd = 8  callref = 0x8064
Oct 24 12:56:19.217 UTC: %LINK-3-UPDOWN: Interface Serial0:1, 
changed state to up
Oct 24 12:56:19.217 UTC: Se0:1: interface must be fifo queue, force fifo
Oct 24 12:56:19.217 UTC: %DIALER-6-BIND: Interface Se0:1 bound to profile Di100
Oct 24 12:56:19.217 UTC: %ISDN-6-CONNECT: 
Interface Serial0:0 is now connected to 81690 lanai-nas-01
Oct 24 12:56:19.221 UTC: Se0:1 PPP: Treating connection as a callout
Oct 24 12:56:19.221 UTC: Se0:1 PPP: Phase is ESTABLISHING, Active Open 
[0 sess, 1 load]
Oct 24 12:56:19.221 UTC: Se0:1 LCP: O CONFREQ [Closed] id 14 len 33
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    MagicNumber 0xE384B037 
(0x0506E384B037)
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.221 UTC: Se0:1 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:19.221 UTC: ISDN Se0:23: TX -> CONNECT_ACK pd = 8  
callref = 0x0064
Oct 24 12:56:19.241 UTC: Se0:1 LCP: I CONFREQ [REQsent] id 11 len 34
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MagicNumber 0x54F4A700 
(0x050654F4A700)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:19.241 UTC: Se0:1 LCP: O CONFACK [REQsent] id 11 len 34
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MagicNumber 0x54F4A700 
(0x050654F4A700)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.241 UTC: Se0:1 LCP:    EndpointDisc 1 lanai-nas-01 
(0x130F016C616E61692D6E61732D3031)
Oct 24 12:56:19.245 UTC: Se0:1 LCP: I CONFACK [ACKsent] id 14 len 33
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    AuthProto CHAP (0x0305C22305)
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    MagicNumber 0xE384B037 (0x0506E384B037)
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    MRRU 1524 (0x110405F4)
Oct 24 12:56:19.245 UTC: Se0:1 LCP:    EndpointDisc 1 maui-nas-03 
(0x130E016D6175692D6E61732D3033)
Oct 24 12:56:19.245 UTC: Se0:1 LCP: State is Open
Oct 24 12:56:19.245 UTC: Se0:1 PPP: Phase is AUTHENTICATING, by both 
[0 sess, 1 load]
Oct 24 12:56:19.245 UTC: Se0:1 CHAP: O CHALLENGE id 8 len 32 from "maui-nas-03"
Oct 24 12:56:19.257 UTC: Se0:1 CHAP: I CHALLENGE id 11 len 33 from "lanai-nas-01"
Oct 24 12:56:19.261 UTC: Se0:1 CHAP: O RESPONSE id 11 len 32 from "maui-nas-03"
Oct 24 12:56:19.273 UTC: Se0:1 CHAP: I SUCCESS id 11 len 4
Oct 24 12:56:19.281 UTC: Se0:1 CHAP: I RESPONSE id 8 len 33 from "lanai-nas-01"
Oct 24 12:56:19.281 UTC: Se0:1 CHAP: O SUCCESS id 8 len 4
! -- Authentication is successful.
Oct 24 12:56:19.281 UTC: Se0:1 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
Oct 24 12:56:19.281 UTC: Di100 MLP: Added link Se0:1 to bundle lanai-nas-01

! -- The link is added to the Multilink bundle.

Oct 24 12:56:20.281 UTC: %LINEPROTO-5-UPDOWN: Line protocol on 
Interface Serial0:1, changed state to up
Oct 24 12:56:25.221 UTC: %ISDN-6-CONNECT: Interface Serial0:1 
is now connected to 81690 lanai-nas-01
Oct 24 12:56:49.117 UTC: Se0:23 DDR: rotor dialout [priority]

! -- Third call is being dialed.

Oct 24 12:56:49.117 UTC: Se0:23 DDR: Attempting to dial 81690
Oct 24 12:56:49.117 UTC: ISDN Se0:23: TX -> SETUP pd = 8  callref = 0x0065
Oct 24 12:56:49.117 UTC:         Bearer Capability i = 0x8890218F
Oct 24 12:56:49.117 UTC:         Channel ID i = 0xA98385
Oct 24 12:56:49.117 UTC:         Called Party Number i = 0x80, '81690', 
Plan:Unknown, Type:Unknown
...
...

! -- Output Omitted.

...
Oct 24 12:56:49.261 UTC: Se0:4 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
Oct 24 12:56:49.261 UTC: Di100 MLP: Added link Se0:4 to bundle lanai-nas-01

! -- The 3rd link is added to the bundle.

Oct 24 12:56:50.261 UTC: %LINEPROTO-5-UPDOWN: Line protocol on 
Interface Serial0:4, changed state to up
Oct 24 12:56:55.198 UTC: %ISDN-6-CONNECT: Interface Serial0:4 
is now connected to 81690 lanai-nas-01  
...
...
...

Información Relacionada


Document ID: 6435