WAN : Protocolo punto a punto (PPP)

Configuración de la marcación de entrada IP/PPP del servidor de acceso con PPP V.120 dedicado

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra para el dial-in IP/PPP del servidor de acceso con V.120 dedicado PPP

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Software Release 11.2 o Posterior del ½ del ¿Â de Cisco IOSïÂ, para V.120 con las interfaces virtuales asíncronas.

  • Cisco IOS Software Release 11.3 o Posterior, para V.120 con las plantillas virtuales.

  • Imagen del Cisco IOS Enterprise para configurar más de cinco líneas del VTY.

Utilice la herramienta Software Advisor (clientes registrados solamente) para determinar que los conjuntos de la característica del Cisco IOS Software soportan las funciones de V.120. Dentro de la herramienta, seleccione las características siguientes: Soporte de V.120, Traducción de protocolo, y plantillas virtuales para la Traducción de protocolo. Si usted requiere las características adicionales, selecciónelas como sea necesario.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Antecedentes

La recomendación V.120 del sector de estandarización de telecomunicación de la unión internacional de telecomunicaciones (ITU-T), permite el transporte confiable de los datos transparentes síncronos, asíncronos, o mordidos sobre los canales B ISDN.

Una conexión de V.120 puede estar en el PPP o el modo no PPP. Esto es porque muchos adaptadores de terminal de V.120 son similares a los módems, y soporta alguno EN los comandos estableces. El modo no PPP se puede utilizar para verificar si la configuración de V.120 está correcta en el cliente y el router. El PPP se puede entonces configurar en ese link. Vea el verificar V.120 en la sección del modo no PPP para más información.

Hay dos métodos principales para implementar V.120:

  • Interfaces virtuales asíncronas

    Usando el Cisco IOS Software, usted puede configurar las características de protocolo asíncrono, tales como PPP y SLIP, en las líneas del VTY. El PPP y el SLIP funcionan normalmente solamente en las interfaces asincrónicas, no en las líneas del VTY. Cuando usted configura una línea del VTY para soportar las características de protocolo asíncrono, usted está creando las interfaces virtuales asíncronas en las líneas del VTY. Una interfaz virtual asíncrona (también conocida como vty-async) se crea a las llamadas al servicio técnico que ingresan al router a través de una interfaz no física. Por ejemplo, las llamadas de la secuencia del carácter asincrónico terminan, o pista en las interfaces no físicas. Las interfaces virtuales asíncronas no son usuario configurable; bastante, se crean dinámicamente, y se derriban a pedido.

  • Plantillas virtuales

    La implementación de la Virtual-plantilla soporta el Tunelización del PPP, usando una Traducción de protocolo de dos etapas. Cuando un usuario de V.120 marca adentro a través de una línea de terminal virtual, el router crea una interfaz de acceso virtual. La interfaz de acceso virtual es una interfaz temporal que soporta la configuración del protocolo asíncrono especificada en la plantilla de interfaz virtual. Esa interfaz es creada dinámicamente reproduciendo la interfaz de plantilla virtual en la configuración. Esta interfaz de acceso virtual se libera encima de tan pronto como la conexión caiga. La Virtual-plantilla es más flexible, porque da más opciones de configuración que la implementación Virtual-asíncrona limitada.

De qué manera V.120 afecta al rendimiento del router

Cisco no recomienda que usted ejecuta el PPP sobre V.120 en Micamodem, porque el proceso de V.120 es extremadamente Uso intensivo de la CPU. Un Cisco AS5200 no puede manejar muchas conexiones PPP en paralelo activas de V.120. El otro Routers del AS5xxx puede manejar más en paralelo las conexiones PPP activas de V.120. Como alternativa, Cisco recomienda el configurar del adaptador de terminal ISDN del cliente (TA) para hacer la “conversión PPP del sincronización-a-async” de modo que la conexión entre en al servidor de acceso a la red (NAS) como la sincronización normal PPP en vez de V.120.

Sin embargo, con los módems NextPort, una nueva función se ha agregado, para descargar las llamadas de V.120 al procesador de señales digitales del módem (DSP). Si usted utiliza el Cisco IOS Software Release 12.2 XB (y 12.2(11)T y posterior), es posible terminar las llamadas de V.120 en el DSP del NextPort en vez del CPU. Para más información, vea terminar las sesiones de V.120 sobre el DSP del NextPort.

Por qué implementar PPP sobre V.120

El PPP sobre V.120 es Uso intensivo de la CPU. Por lo tanto, Cisco desalienta una implementación amplia. Sin embargo usted puede querer ejecutar el PPP sobre V.120 por las razones siguientes:

  • Usted está utilizando un adaptador de terminal (TA) que se asocie a un equipo de terminal de los datos asincrónicos (DTE), y no puede hacer la conversión PPP del sincronización-a-async. En este caso, usted debe utilizar V.120.

  • La configuración predeterminada su TA es V.120, y usted no puede configurar de nuevo su TA sin la ayuda de su Proveedor de servicios de Internet (ISP).

  • La aplicación quiere tener la sesión PPP comenzar con un diálogo del terminal de la celda de caracteres (por ejemplo, un desafío de la contraseña de USO único y una respuesta especiales), así que usted no quiere a sesión PPP sólo de sincronización.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Esta sección también describe la implementación para el vty-async y las plantillas virtuales.

Nota: Estos pasos asumen que el NAS está configurado correctamente para el acceso básico ISDN o del marcado asíncrono, y que configuran al cliente correctamente para el PPP sobre V.120.

Interfaces Virtuales Asincrónicas (vty-async)

Para implementar el vty-async, complete estos pasos:

  1. Cree las interfaces virtuales asíncronas usando el comando global configuration del vty-async.

  2. Configure la autenticación para la conexión del vty-async. Utilice el vty-async ppp authen {grieta | comando pap}.

  3. Configure otros parámetros del vty-async por ejemplo, los temporizadores KEEPALIVE, tamaño MTU, compresión del encabezamiento, y así sucesivamente, como sea necesario, para su configuración. Refiera a la Traducción de protocolo y a los comandos virtual asynchronous device para más información.

  4. Configure la detección automática de encapsulación de V.120 usando el comando autodetect encapsulation v120 ppp. Este comando se debe aplicar a la interfaz física de la llamada entrante (por ejemplo, la interfaz BRI0, el serial 1:23 de la interfaz). Sin embargo, si V.120 de llamada TA señala correctamente V.120 en el campo de bajo nivel PUESTO q.931 de la compatibilidad, el Autodetect Encapsulation no es necesario. Desafortunadamente, muchos TA no pueden hacer esto.

  5. Inhabilite el prompt del nombre de usuario y contraseña bajo configuración de línea del VTY. Usted puede hacer esto no configurando ningún login y ninguna contraseña en el modo de configuración de línea del VTY. Si usted está utilizando el AAA, defina una lista que tenga el método ningunos y después apliqúela a la interfaz del VTY. Por ejemplo:

    maui-soho-01(config)#aaa new-model
    maui-soho-01(config)#aaa authentication login NO_AUTHEN none
    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login authentication NO_AUTHEN
    
  6. Configure el comando autocommand ppp default en el modo de configuración de línea del VTY. Sin la autenticación de inicio de sesión y el autocommand ppp, los iniciados PPP del VTY tan pronto como venga una conexión de V.120 adentro. Esto permite que el par de V.120 comience las negociaciones PPP inmediatamente, sin tener que ejecutar un script, o ingresa el nombre de usuario y contraseña en una ventana de terminal. No soportan al comando autoselect en el vtys.

    Nota: Puesto que el comienzo del vtys que ejecuta el PPP tan pronto como se establezca la conexión, usted no podrá publicar el comando telnet en el NAS para fines administrativos. Para conseguir alrededor de esta restricción, aplicar el comando transport input v120 en el vtys usado para las conexiones PPP de V.120, y aplicar el comando transport input telnet en ésos usados para la Telnet administrativa.

Plantillas virtuales

Para implementar las plantillas virtuales, complete estos pasos:

  1. Cree y configure una plantilla de interfaz virtual usando el comando interface virtual-template. Configure esta interfaz virtual apenas pues usted configuraría una interfaz serial asincrónica regular. Para hacer así pues, asigne a plantilla de interfaz virtual la dirección IP de una interfaz activa (usando el comando ip unnumbered interface), y configure la dirección, apenas pues usted la configuraría en una interfaz asincrónica. Usted puede también ingresar los comandos en el modo de configuración de la interfaz que comprimen los encabezados TCP o configuran la autenticación del protocolo de autenticación por desafío mutuo del desafío (GRIETA) para el PPP. Por ejemplo:

    interface Virtual-Template1
      ip unnumbered Ethernet0
      no ip directed-broadcast
      ip tcp header-compression passive
      peer default ip address pool IPaddressPool
      ppp authentication chap
  2. Cree las interfaces virtuales asíncronas usando el comando global configuration del vty-async.

  3. Configure las líneas de terminal virtual para soportar las funciones del protocolo asíncrono, sobre la base de la definición de una plantilla de interfaz virtual. Usted puede hacer esto usando el comando vty-async virtual-template number en el modo de configuración global. Por ejemplo:

    vty-async
    vty-async Virtual-Template 1
  4. Configure la detección automática de encapsulación de V.120 usando el comando autodetect encapsulation v120 ppp. Aplique este comando a la interfaz física de la llamada entrante (por ejemplo, la interfaz BRI0, el serial 1:23 de la interfaz). Sin embargo, si V.120 de llamada TA señala correctamente V.120 en el campo de bajo nivel PUESTO q.931 de la compatibilidad, el Autodetect Encapsulation no se requiere. Desafortunadamente, muchos TA no pueden hacer esto.

  5. Inhabilite el prompt del nombre de usuario y contraseña bajo configuración de línea del vty. Haga esto no configurando ningún login y ninguna contraseña en el modo de configuración de línea del vty. Si usted está utilizando el AAA, defina una lista que tenga el método ningunos y después apliqúela a la interfaz del vty. Por ejemplo:

    maui-soho-01(config)#aaa new-model
    maui-soho-01(config)#aaa authentication login NO_AUTHEN none
    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login authentication NO_AUTHEN
    
  6. Configure el comando autocommand ppp default en el modo de configuración de línea del vty. Sin la autenticación de inicio de sesión y el autocommand ppp, los iniciados PPP del VTY tan pronto como venga una conexión de V.120 adentro. Esto permitirá que el par de V.120 comience las negociaciones PPP inmediatamente, sin tener que ejecutar un script o ingresar el nombre de usuario y contraseña en una ventana de terminal. Observe que no soportan al comando autoselect en el vtys.

    Nota: Puesto que el comienzo del vtys que ejecuta el PPP tan pronto como se establezca la conexión, usted no podrá publicar el comando telnet en el NAS para fines administrativos. Para conseguir alrededor de esta restricción, aplicar el comando transport input v120 en el vtys usado para las conexiones PPP de V.120, y aplicar el comando transport input telnet en ésos usados para la Telnet administrativa.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/6306/28a.gif

Configuraciones

Este documento usa esta configuración:

  • Cisco AS5200 que apoya el IP del dial-in o a los clientes PPP para ISDN síncrono PPP (no el multilink), PPP asíncrono, y V.120 PPP.

Esta configuración utiliza el método de las interfaces virtuales asíncronas (vty-async) descrito arriba.

V.120 (PPP) con las interfaces virtuales asíncronas
aaa new-model
aaa authentication login default local
aaa authentication login NOAUTH none             

!--- The aaa list NOAUTH has no authentication.
!--- This list will be applied to the vty interface.

! 
username fred password FLINTSTONE
!
ip local pool default 10.1.1.2 10.1.1.47

!--- Define local IP address pool.


vty-async                                        

!--- Configures all virtual terminal lines on a router to 
!--- support asynchronous protocol features.
!--- The vty-async parameters are required for Async V.120. 

vty-async keepalive 0       

!--- Disable PPP keepalives.

vty-async ppp authen chap pap 

!--- Async  V.120 PPP authentication methods.

!
interface Ethernet0
  ip address 10.1.1.1 255.255.255.0
!
interface serial0:23

!--- ISDN D-channel configuration for T1 0.

  no ip address
  encapsulation ppp
  isdn incoming-voice modem

!--- Analog calls are forwarded to the internal digital modem.

  ppp authentication chap pap
  dialer rotary-group 1

!--- Member of rotary group 1. 


!--- The rotary group configuration is interface Dialer 1.

  autodetect encapsulation v120 ppp  

!--- Automatic detection of encapsulation type on the specified interface. 
!--- This interface will automatically detect whether the call is normal PPP or V.120
!--- If the calling V.120 TA correctly signals V.120 in the Q.931 
!--- SETUP low-level compatibility field, autodetect encapsulation is 
!--- not needed. Unfortunately, many TAs fail to do this.   
   
!
interface Dialer1

!--- Rotary group 1 logical interface.

  description Dialer interface for sync ISDN calls
  ip unnumbered Ethernet0
  encapsulation ppp
  peer default ip address pool
  dialer-group 1
  dialer idle-timeout 300                      
  no cdp enable
  ppp authentication chap pap 
!
interface Group-Async1
  description Interface for async modem calls
  async mode dedicated                           

!--- PPP only, no exec dial-ins (or Teminal window after dial).
 
  ip unnumbered Ethernet0
  encapsulation ppp
  ip tcp header-compression
  peer default ip address pool default
  dialer-group 1
  dialer idle-timeout 300                        
  no cdp enable
  ppp authentication chap pap
!
dialer-list 1 protocol ip permit
!
line con 0
  login authentication NOAUTH
line 1 48

!--- Modems used for normal async calls.

  no exec
  modem inout
!                                                
line vty 0 45

!--- V.120 call will be terminated on vty 0 45.
!--- If your router does not support more than five vtys refer 
!--- to the Components Used section.

  login authentication NOAUTH    

!--- Use the AAA list NOAUTH (which specified no authentication) 
!--- configured previously with this method. There will be no 
!--- Username/password exec prompt. Use the no login command
!--- if this NAS does not do AAA.

  autocommand ppp default

!--- This command is ONLY required for V.120 with PPP.

  session-timeout 5 output                       

!--- Timeout of 5 minutes.

  transport input v120                           

!--- Allow only V.120 connections into these VTYs.

line vty 46 50

!--- These vtys will be used for normal telnets into the router.

  login authentication default

!--- Use AAA list "default" for vty 46-50. 
!--- This method uses local authentication (configured previously).

  exec-timeout 30
  transport input telnet

!--- Permit only incoming telnet connections to use vty 46-50.


Verificación

En esta sección encontrará información que puede utilizar para confirmar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

  • ruta de IP de la demostración — visualiza las entradas de tabla de IP Routing.

  • usuarios de la demostración — información de las visualizaciones sobre las líneas activas del servidor de red, incluyendo el número de línea, los nombres de la conexión, y el ubicación de la terminal.

Verifique la conexión de V.120

Para verificar la conexión de V.120, complete estos pasos:

  1. Utilice el debug v120, y genere una llamada entrante de V.120. Usted debe ver esta salida de los debugs en el NAS:

    19:25:16: V120: Autodetect trying to detect V120 mode on Se0:18
    19:25:16: V120 sampled pkt:  3 bytes:  8 1 7F
    19:25:16: Se0:18-v120 started - Setting default V.120 parameters
    19:25:16: V120extablished handle = 4

    Si no aparece este mensaje, la llamada entrante no era probablemente V.120, y por lo tanto el router no lo detectó como tal.

  2. Verifique si suba la interfaz del vty-async. Si su configuración utiliza V.120 con las plantillas virtuales, marque si una interfaz de acceso virtual está creada. En la salida siguiente del registro de la consola, el interfaz del vty-async 32 está para arriba:

    19:25:17: %LINK-3-UPDOWN: Interface VTY-Async32, 
    changed state to up
  3. Utilice la negociación ppp del debug y haga el debug de la autenticación PPP. para asegurarse de que los parámetros PPP estén negociados correctamente. Para más información sobre el debugging de PPP, vea la tecnología de marcación manual: Técnicas de resolución de problemas.

  4. Realice una ruta de IP de la demostración y muestre a los usuarios para marcar que la llamada de V.120 está establecida correctamente.

Los siguientes ejemplos son salidas de una configuración donde no tenemos plantillas virtuales de V.120:

DSL4-5300A#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.68.0.0/32 is subnetted, 1 subnets
S       172.68.186.41 [1/0] via 172.18.120.1
     172.18.0.0/24 is subnetted, 1 subnets
S       172.18.120.0 [1/0] via 10.92.1.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.92.1.0 is directly connected, FastEthernet0
C    192.168.1.0/24 is directly connected, Loopback0
     172.0.0.0/32 is subnetted, 1 subnets
C       172.22.53.1 is directly connected, VTY-Async32

Nota: La llamada está conectada en el Vty-async 32 de la interfaz, y hay una ruta al cliente.

Nota: La dirección IP del lado NAS del link será la de los Ethernetes o de la interfaz Fast Ethernet en el NAS, al usar no la opción de configuración de plantilla virtual. Por lo tanto verifique si el Ethernet o la interfaz Fast Ethernet sea ascendente y pueda ser hecho ping.

DSL4-5300A#show users
  Line          User       Host(s)              Idle     Location
*0 con 0                   idle                 00:00:00
 32 vty 0     wan-2520-5  VTY-Async32           00:01:37 Serial0:18
Interface        User      Mode                 Idle     Peer Address
  VT32         wan-2520-5 Async PPP             00:01:14 172.22.53.1

Nota: La llamada está conectada en el Vty-async 32 de la interfaz, y se especifica el IP Address de Peer.

Si usted utiliza la opción de la Virtual-plantilla con V.120 la salida de la ruta de IP de la demostración y del usuario de la demostración aparece como esto:

DSL4-5300A#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     192.168.199.0/32 is subnetted, 1 subnets
C       192.168.199.5 is directly connected, Virtual-Access1
     172.22.0.0/32 is subnetted, 1 subnets
S       172.22.186.41 [1/0] via 172.18.120.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.20.20.0 is directly connected, Virtual-Access1
.........

Nota: La llamada está conectada en el acceso virtual 1 de la interfaz, y hay una ruta al cliente.

DSL4-5300A#show users
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00
  32 vty 0     wan-2520-5 Virtual-Access1      00:00:05 Serial0:18

Nota: La llamada está conectada en el acceso virtual 1. de la interfaz.

Verifique V.120 en el modo no PPP

Muchos adaptadores de terminal de V.120 son similares a los módems, y soportan alguno EN los comandos estableces. Por lo tanto, usted puede utilizar el modo no PPP para verificar si V.120 puesto en el cliente y el router están correctos. Usted puede entonces configurar el PPP en ese link. La prueba de V.120 en sí mismo permite que resolvamos problemas los problemas relacionados de V.120 sin agregar la complejidad del PPP.

Para probar la conexión de V.120 en el modo no PPP, complete estos pasos:

  1. Habilite el prompt del nombre de usuario y contraseña bajo configuración de línea del vty. Utilice el comando login de habilitar el login. Utilice el comando password password de fijar la contraseña de línea. Si usted está utilizando el AAA, quite el comando list de la autenticación de inicio de sesión bajo el vty.

  2. Quite el comando autocommand ppp default en el modo de configuración de línea del vty. Por ejemplo:

    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login
    maui-soho-01(config-line)#password letmein
    maui-soho-01(config-line)#no autocommand ppp default
    
  3. Gire el debug v120, e inicie una llamada del cliente. El router debe visualizar esto:

    19:25:16: V120: Autodetect trying to detect V120 mode on Se0:18
    19:25:16: V120 sampled pkt:  3 bytes:  8 1 7F
    19:25:16: Se0:18-v120 started - Setting default V.120 parameters
    19:25:16: V120extablished handle = 4       
  4. Continúe el resto de la configuración de V.120. Complete los pasos descritos en la sección de la configuración.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas (opcional)

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Nota: Antes de que usted publique los comandos debug, refiera a la información importante en los comandos Debug para más información.

  • el debug v120 — indica cuando se comienza o se termina el proceso de V.120, y la interfaz en las cuales él se está ejecutando.

  • negociación ppp del debug — información de las visualizaciones sobre el tráfico y los intercambios PPP, mientras que negocia los componentes PPP incluyendo el (LCP) del Link Control Protocol, la autenticación, y el NCP. Una negociación PPP exitosa abrirá primero el estado LCP, luego realizará la autenticación y por último negociará el NCP (generalmente IPCP).

  • autenticación PPP del debug — visualiza los mensajes de protocolo de la autenticación PPP, incluyendo los intercambios de paquetes de la GRIETA y los intercambios del protocolo password authentication (PAP).


Información Relacionada


Document ID: 6306