Marcado y acceso remotos : Conexiones asíncronas

Configuración de WINS, DNS y DHCP en servidores de acceso

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Ciertos clientes de marcación de entrada requieren la información del servidor de Windows Internet Naming Service (WINS), y/o de Domain Naming System (DNS) para conectar correctamente con la red. Existen diferentes mecanismos para entregar direcciones de IP a clientes de marcado en servidores de acceso.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Configure y verifique que el router puede validar la asíncrona entrante y las llamadas ISDN. Utilice el procedimiento de configuración especificado en la configuración del servidor de acceso con PRI para las llamadas entrantes asíncronas de enlaces múltiples y llamadas ISDN para obtener mayor información.

  • Verifique que los servidores DHCP, DNS y WINS estén bien configurados. Entre en contacto a su administrador de sistema para más información.

    Nota: Esta configuración asume que los TRIUNFOS, el DNS, y los servidores DHCP son diversos servidores. Pueden de hecho ser un servidor, o un servidor puede ejecutar los TRIUNFOS y el DNS con el DHCP en otro cuadro o cualquier otra combinación de los tres.

Componentes Utilizados

Esta configuración fue desarrollada y probada usando este equipo/dispositivos:

  • Cisco AS5200 con dos circuitos del T1 PRI

  • Servidor DNS

  • Servidor WINS

  • Servidor DHCP para asignar los IP Addresses al cliente

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Productos Relacionados

Estos comandos de configuración de DNS, DHS y WINS pueden usarse en cualquier router que admita llamadas PPP entrantes.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Teoría Precedente

Entre las opciones posibles para la asignación de direcciones de IP a clientes se incluyen:

  • Asignación de un direccionamiento de la agrupación IP local en el servidor de acceso.

  • Uso de un servidor externo de Protocolo de control de host dinámico (DHCP)

  • Utilización del Servicio de usuario de marcación de entrada de autenticación remota (RADIUS) o del Sistema de control de acceso del controlador de acceso a terminales (TACACS+).

Este documento describe el procedimiento para pasar la información del servidor WINS y DNS al cliente de marcado a través del servidor de acceso. El servidor de acceso también le pasará al cliente de marcado manual la dirección IP devuelta a éste por un servidor externo DHCP.

Para más información, refiera a los documentos en la sección de información relacionada de este documento

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en este diagrama:

/image/gif/paws/6303/winsdhcp.gif

Configuraciones

Este servidor de acceso AS5200 se configura con dos Interfaces de velocidad primaria (PRI) para permitir usuarios entrantes asíncronos y usuarios ISDN. Los mapas de marcado dinámico se crean para los usuarios ISDN. Sin TACACS+ o RADIUS configurados, se debe configurar un nombre de usuario y contraseña para cada usuario que necesite acceso de marcado. Todos los IP Addresses son dados al cliente por el servidor DHCP. El servidor de acceso pasa la dirección IP del DNS y GANA los servidores al cliente durante la negociación del protocolo ppp ip control (IPCP).

Servidor de acceso AS5200
version 11.1
!
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service udp-small-servers
no service tcp-small-servers
!
hostname as5200
!
enable password letmein
!
username Jason password foo
username Laura password bar
username Russ password fake
username Syed password pseudo
username Tito password knockknock
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
interface Loopback0
 ip address 172.16.209.65 255.255.255.192
!
interface Loopback1
 ip address 172.16.209.129 255.255.255.192
!
interface Ethernet0
 ip address 172.16.162.4 255.255.255.0

!
interface Serial0
 no ip address 
!
interface Serial1
 no ip address
!
interface Serial0:23
 no ip address
 isdn incoming-voice modem
 dialer rotary-group 1
 encapsulation ppp
 no fair-queue
!
interface Serial1:23
 no ip address
 encapsulation ppp
 dialer rotary-group 1
 isdn incoming-voice modem
 no fair-queue
!
interface Group-Async1
 ip unnumbered Ethernet0
 encapsulation ppp
 async mode interactive
 peer default ip address dhcp

! -- Async dialup users will be assigned ip addresses from 
! -- the dhcp server. The dhcp server is specified with the
! -- ip dhcp-server command shown below.
! -- Refer to the section Command Summary for more information.

 ip helper-address 172.16.162.10

! -- The ip helper address command enables BOOTP broadcast 
! -- forwarding for a set of clients. The helper address specifies
! -- the address of the DHCP server configured below.
! -- Refer to the section Command Summary for more information.

 ppp authentication chap
 group-range 1 48
!
interface Dialer1
 ip unnumbered Ethernet0
 encapsulation ppp
 peer default ip address dhcp

! -- ISDN dialup users will be assigned ip addresses from the dhcp server.
! -- The dhcp server specified with the ip dhcp-server command shown 
! -- below. Refer to the section Command Summary for more information.

 ip helper-address 172.16.162.10

! -- The ip helper address command enables BOOTP broadcast  
! -- forwarding for a set of clients. The helper address specifies
! -- the address of the DHCP server configured below. 
! -- Refer to the section Command Summary for more information.

 dialer in-band
 dialer idle-timeout 300
 dialer-group 1
 no fair-queue
 ppp multilink
 ppp authentication chap
!
router eigrp 222
 redistribute connected
 network 172.16.0.0
!
dialer-list 1 protocol ip permit
!
async-bootp dns-server 172.16.224.100 172.16.154.101

! -- Specifies the primary and secondary DNS servers.
! -- The first IP address belongs to the primary DNS server.
! -- If you only have one DNS server you do not need to specify 
! -- a secondary DNS server.
! -- Refer to the section Command Summary for more information.

async-bootp nbns-server 172.16.224.10 172.16.4.2 

! -- Specifies the primary and secondary WINS  servers.
! -- The first IP address belongs to the primary WINS server.
! -- If you only have one WINS server you do not need to specify 
! -- a secondary WINS server.
! -- Refer to the section Command Summary for more information.

ip dhcp-server 172.16.162.10

! -- Specifies the dhcp server ip address. This command is required
! -- if the IP address for dialin clients is obtained from the server.
! -- Note: The dhcp server need not be on the same subnet as the 
! -- Ethernet interface. 
! -- It can be more than one hop away as long has it is reachable.

!
line con 0
 login 
line 1 48
modem InOut
transport input telnet
 autoselect during-login
 autoselect ppp
 flowcontrol hardware
line aux 0
line vty 0 4
 password secret
 login 
!
end

Resumen de Comandos

Ésta es una descripción de los comandos relevant para el DHCP, el DNS y los TRIUNFOS en el Access Servers:

Verificación

Para verificar si el cliente ha recibido correctamente los parámetros correspondientes del servidor de acceso, debe realizar la comprobación desde el cliente.

Por ejemplo, del cliente, haga ping un direccionamiento resolvable DNS tal como www.cisco.com. Si el servidor DNS resuelve el direccionamiento, después la configuración está trabajando correctamente. Para probar los TRIUNFOS asignación de servidores, utilice el Windows Networking para hojear la red.

Utilice el comando show dialer map después de que se haga una conexión ISDN, de ver si un mapa de marcado dinámico fue creado. Sin éste, no puede rutear. Debería ver una dirección asignada al par (la dirección se obtuvo del servidor DHCP). Esto verifica que la asignación de dirección DHCP fue exitosa.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

Este documento supone que las capas ISDN 1, 2 y 3 están funcionando correctamente. Si usted tiene problemas con los problemas de capa inferior de ISDN. Para obtener más información, consulte el documento Utilizar el comando show isdn status para la resolución de problemas de BRI.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

  • debug ppp autentication – Para ver si un cliente se autentica correctamente. Si usted está utilizando una versión antes del Software Release 11.2 del ½ del ¿Â de Cisco IOSïÂ, utilice el comando debug ppp chap en lugar de otro.

  • haga el debug de la negociación ppp — Para ver si un cliente está pasando la negociación PPP; En este momento es cuando debe verificar la negociación de dirección La negociación IPCP muestra la información de los servidores DNS y WINS que se envía al cliente.

  • debug ppp error — Para mostrar los errores de protocolo y las estadísticas de error relacionadas con la negociación y operación de conexiones PPP.

La asignación de servidores DNS y WINS puede verse en la fase IPCP de la negociación PPP. Una salida de muestra se proporciona abajo.

Ejemplo de resultado del comando debug

Esta salida del comando debug ppp negotiation (para una llamada del marcado asíncrono) muestra la negociación IPCP para el cliente. En este ejemplo, solamente especificaron a un servidor DNS principal. El servidor WINS no se pasa al cliente.

Sep 26 12:50:47.227: As97 CHAP: O CHALLENGE id 1 len 32 
from "maui-nas-02"
Sep 26 12:50:47.355: As97 CHAP: I RESPONSE id 1 len 31 
from "async_user"
Sep 26 12:50:47.355: As97 AUTH: Started process 0 pid 56
Sep 26 12:50:47.355: As97 CHAP: O SUCCESS id 1 len 4
Sep 26 12:50:47.359: As97 PPP: Phase is UP [0 sess, 0 load]

! -- IPCP negotiation begins

Sep 26 12:50:47.359: As97 IPCP: O CONFREQ [Closed] id 1 len 10
Sep 26 12:50:47.359: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:47.467: As97 IPCP: I CONFREQ [REQsent] id 1 len 40
Sep 26 12:50:47.467: As97 IPCP:    CompressType VJ 15 slots 
CompressSlotID 
(0x0206002D0F01)
Sep 26 12:50:47.467: As97 IPCP:    Address 0.0.0.0 
(0x030600000000)
Sep 26 12:50:47.467: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:47.467: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:47.467: As97 AAA/AUTHOR/IPCP: Start.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:47.467: As97 AAA/AUTHOR/IPCP: Done.  
Her address 0.0.0.0, we want 172.22.60.2

! -- The IP address for the client is assigned.

Sep 26 12:50:47.467: As97 IPCP: O CONFREJ [REQsent] id 1 len 28
Sep 26 12:50:47.467: As97 IPCP:    CompressType VJ 15 slots 
CompressSlotID 
(0x0206002D0F01)
Sep 26 12:50:47.467: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:47.483: As97 CCP: I CONFREQ [Not negotiated] 
id 1 len 15
Sep 26 12:50:47.483: As97 CCP:    MS-PPC supported bits 
0x00000001 
(0x120600000001)
Sep 26 12:50:47.483: As97 CCP:    Stacker history 1 check mode 
EXTENDED 
(0x1105000104)
Sep 26 12:50:47.483: As97 LCP: O PROTREJ [Open] id 4 len 21 
protocol CCP
Sep 26 12:50:47.483: As97 LCP:  (0x80FD0101000F12060000000111050001)
Sep 26 12:50:47.483: As97 LCP:  (0x04)
Sep 26 12:50:47.499: As97 IPCP: I CONFACK [REQsent] id 1 len 10
Sep 26 12:50:47.499: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:49.359: As97 IPCP: TIMEout: State ACKrcvd
Sep 26 12:50:49.359: As97 IPCP: O CONFREQ [ACKrcvd] id 2 len 10
Sep 26 12:50:49.359: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:49.467: As97 IPCP: I CONFACK [REQsent] id 2 len 10
Sep 26 12:50:49.467: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:50.459: As97 IPCP: I CONFREQ [ACKrcvd] id 2 len 34
Sep 26 12:50:50.459: As97 IPCP:    Address 0.0.0.0 (0x030600000000)
Sep 26 12:50:50.459: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:50.459: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:50.459: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:50.459: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:50.459: As97 AAA/AUTHOR/IPCP: Start.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.463: As97 AAA/AUTHOR/IPCP: Done.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.463: As97 IPCP: O CONFREJ [ACKrcvd] id 2 len 22
Sep 26 12:50:50.463: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:50.463: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:50.463: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:50.571: As97 IPCP: I CONFREQ [ACKrcvd] id 3 len 16
Sep 26 12:50:50.571: As97 IPCP:    Address 0.0.0.0 
(0x030600000000)
Sep 26 12:50:50.571: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:50.571: As97 AAA/AUTHOR/IPCP: Start.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.571: As97 AAA/AUTHOR/IPCP: Done.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.571: As97 IPCP: O CONFNAK [ACKrcvd] id 3 len 10
Sep 26 12:50:50.571: As97 IPCP:    Address 172.22.60.2 
(0x0306AC163C02)
Sep 26 12:50:50.683: As97 IPCP: I CONFREQ [ACKrcvd] id 4 len 16
Sep 26 12:50:50.683: As97 IPCP:    Address 172.22.60.2 
(0x0306AC163C02)
Sep 26 12:50:50.683: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:50.683: As97 AAA/AUTHOR/IPCP: Start.  
Her address 172.22.60.2, we want 172.22.60.2
Sep 26 12:50:50.683: As97 AAA/AUTHOR/IPCP: Reject 172.22.60.2, 
using 172.22.60.2
Sep 26 12:50:50.687: As97 AAA/AUTHOR/IPCP: Done.  
Her address 172.22.60.2, we want 172.22.60.2
Sep 26 12:50:50.687: As97 IPCP: O CONFACK [ACKrcvd] id 4 len 16
Sep 26 12:50:50.687: As97 IPCP:    Address 172.22.60.2 
(0x0306AC163C02)
Sep 26 12:50:50.687: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)

! -- The IP address of the client and Primary DNS server's 
! -- IP address are negotiated.

Sep 26 12:50:50.687: As97 IPCP: State is Open

Información Relacionada


Document ID: 6303