Módulos e interfaces de Cisco : Adaptadores de servicios de Cisco

Configuración y descripción del módulo del router para la familia del Catalyst 4500/4000 (WS-X4232-L3)

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (7 Octubre 2015) | Comentarios


Contenido


Introducción

Este documento describe el módulo del router WS-X4232-L3 para los Cisco Catalyst 4500/4000 Series Switches. Además de una descripción de la arquitectura y de la configuración del WS-X4232-L3, este documento también provee una configuración de ejemplo que utiliza un Catalyst 4500/4000 Series Switch y el módulo del router.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Versión del Cisco Catalyst OS (CatOS) 5.5(1) o más adelante

  • Software Release 12.0(7)W5(15d) de Cisco IOS�

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

El nombre del archivo de la imagen del Cisco IOS Software para el WS-X4232-L3 comienza con el "cat4232-". Usted puede encontrar el archivo en el sección del Catalyst 4232 de la área de software de la descarga (clientes registrados solamente) para el LAN Switching Software.

Nota: Hay soporte para el módulo del router cuando usted lo utiliza conjuntamente con el Supervisor Engine 1 y el Supervisor Engine 2. Sin embargo, no hay soporte para el módulo del router cuando usted lo utiliza conjuntamente con el Supervisor Engine 2+, 3, 4, o 5.

Nota: Refiera a la sección de las características de la nota de instalación y configuración para el Módulo de servicios de la capa 3 del Catalyst 4000 para más información sobre las funciones del software que tienen soporte en el módulo del router (WS-X4232-L3).

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Descripción general de la arquitectura

El módulo WS-X4232-L3 tiene 32 puertos Fast Ethernet y dos puertos Gigabit Ethernet.

Estos dos puertos Gigabit Ethernet corresponden al gigabit 1 de las interfaces y al gigabit 2 en la configuración del router. Estos puertos Gigabit Ethernet son puertos enrutados.

Internamente, el módulo tiene dos interfaces de Ethernet Gigabite (gigabit 3 y gigabit 4) que conectan al router con el backplane del Switch. La placa de interconexiones del switch usa los dos primeros puertos en esa ranura para conectarse al módulo del router. Cuando usted inserta el módulo WS-X4232-L3 en el slot 3, las interfaces de Ethernet Gigabite 3 y 4 conectan con el backplane los puertos 3/1 y 3/2. Los puertos 3/1 y 3/2 son puertos de la capa 2 con la configuración en el Supervisor Engine del Switch. Las interfaces de Ethernet Gigabite 3 y 4 son puertos de la capa 3 con la configuración en el módulo del router.

Existen 32 puertos Fast Ethernet en el módulo del router. Estos puertos son puertos de la capa 2 y no realizan ningunas funciones de la capa 3. Aunque los puertos tengan una ubicación física en el módulo del router, usted debe configurar los puertos en el Supervisor Engine del Switch.

Este diagrama proporciona una explicación visual de la arquitectura. Para esta configuración, instale el módulo del router en el slot 2 del switch de Catalyst.

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-4000-series-switches/6198-28-a.gif

Configuración del WS-X4232-L3

Motor supervisor

El comando show port visualiza los dos puertos Gigabit y los 32 puertos del 10/100 Mbps con los números 1 a 34.

Nota: Los dos puertos Gigabit que usted ve del Supervisor Engine no son los dos puertos que usted ve en el panel frontal. Los puertos que usted ve del Supervisor Engine son los dos puertos conmutados que conectan con el motor de la ruta. Usted necesita configurar los puertos físicos como puertos del switch. Esta configuración es similar a la configuración del módulo multilayer switch (MS) en los Catalyst 6500/6000 Series Switch. Más la configuración común para estos puertos es fijarlos como el Gigabit EtherChannel (GEC) y enlace. Esta manera, usted puede rutear entre todos los VLA N en el router.

Nota: Usted puede acceder el módulo del router del Supervisor Engine si usted publica el comando session module-. Esta acción es similar acceder del (RSM) del Route Switch Module en un Series Switch del Catalyst 5500/5000.

Router

Si usted ve un prompt de router, busque cuatro interfaces de Ethernet Gigabite con los números a partir de la 1 a 4 (el gigabit 1, el gigabit 2, el gigabit 3, y el gigabit 4) y una interfaz fuera de banda de los fast ethernet.

Ésta es la configuración predeterminada:

Router#show run 
Building configuration...  

Current configuration:  
!  
version 12.0  
service config  
no service pad  
service timestamps debug uptime  
service timestamps log uptime  
no service password-encryption  
!  
hostname Router  
!  
!  
ip subnet-zero  
!  
!  
!  
interface FastEthernet1  
 no ip address  
 no ip directed-broadcast  
 shutdown  
!  
interface gigabitEthernet1  
 no ip address  
 no ip directed-broadcast 

!--- Output suppressed.

Nota: En esta configuración, el gigabit 3 y el gigabit 4 son las conexiones que va al backplane. El gigabit 1 y el gigabit 2 son los puertos de usuario en el panel frontal (puertos ruteados). La mayor parte del tiempo, como en un MS, usted configura el puerto 3 y el puerto 4 para ser parte de lo mismo Canal de puerto de la interfaz. También, usted configura las subinterfaces en ese canal (con el protocolo inter-switch link encapsulación [ISL] o del IEEE 802.1Q). Como en el MS, la configuración de gigabit 3 y el gigabit 4 en el módulo del router necesita ser constantes con la configuración de puerto slot/1 y el slot/2 en el lado del Switch. Usted puede marcar el tráfico entre el router y el Switch si usted publica los comandos show interface port-channel o show interface gigabitethernet.

Soporte de la lista de acceso en WS-X4232-L3

Hay soporte para el Listas de control de acceso (ACL) en el módulo del router WS-X4232-L3, pero la configuración de muestra que este documento discute no soporta los ACL. Refiera a configurar los ACL en el módulo del router WS-X4232-L3 para el Catalyst 4000 Family para más información sobre las configuraciones ACL con el soporte para el módulo WS-X4232-L3.

Configuraciones de Ejemplo

La configuración de muestra contiene los elementos en esta lista. (Véase el diagrama de la red.)

  • Explosión — Un Switch de las 4500/4000 Series del Catalyst con un módulo del router en el slot 3.

  • Liki — Un router que asocia a Gigabit Ethernet 1 en el módulo del router.

  • Donald — Un router que asocia en el VLAN2 en el puerto 3/3 de explosión. El puerto 3/3 es uno de los puertos de la capa 2 del módulo del router.

  • Daniella — Un router que asocia en el VLAN3 en el puerto 2/3 de explosión.

Esta configuración incluye una conexión GEC entre el módulo del router y el Switch de las 4500/4000 Series del Catalyst. Usted configura el enlace en el GEC para permitir que los VLAN múltiples pasen al router para el InterVLAN Routing. Esta configuración GEC es la configuración estándar. Todos los comandos específicos de esta configuración se trasladan a las subinterfaces de los canales de puertos.

Cuando usted utiliza el módulo de la capa 3, recuerde que todo el tráfico que alcanza al router en el VLAN nativo está ruteado en el software. Esta situación tiene un efecto adverso en el funcionamiento del Switch. El microcódigo en el WS-X4232-L3 no procesa los paquetes del 802.1Q que vienen adentro en el VLAN nativo sin las etiquetas. En lugar, los paquetes van al CPU, y el CPU procesa los paquetes. Este resultados del proceso en CPU elevada la utilización si el CPU recibe los paquetes sin las etiquetas a una alta velocidad en las subinterfaces del VLAN nativo. Por lo tanto, cree un VLA N simulado (que no contenga ningún tráfico de usuarios) como el VLAN nativo. En este ejemplo de configuración (el diagrama de la red), el VLAN99 sirve como el VLAN nativo. Configure solamente el VLAN nativo en el GEC entre el router y el Switch. No configure ninguna otra puertos en el Switch en este VLA N simulado.

Nota: Cree un VLA N simulado como el VLAN nativo en los links de troncal entre el router y el Switch. El CPU rutea en el software todo el tráfico que envía encendido el VLAN nativo, que tiene un efecto adverso en el funcionamiento del Switch. Cree un VLA N adicional que usted no utilice en cualquier parte en la red y haga este VLA N el VLAN nativo para los links de troncal entre el router y el Switch.

Diagrama de la red

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-4000-series-switches/6198-28-b.gif

Las secciones de la configuración y de configuración de módulo de router del Supervisor Engine del Switch de esto documentan las actuales configuraciones y salida de algunos comandos show. Las configuraciones están en el Supervisor Engine del Switch de las 4500/4000 Series del Catalyst y del módulo del router. Esto permite el rutear entre las tres subredes (VLAN1, VLAN2, y el router que asocia a Gigabit Ethernet 1).

Configuración del Supervisor Engine del Switch

La placa del switch del router muestra 34 puertos en el comando show module. Estos 34 puertos incluyen 32 puertos conmutados al panel frontal y a 2 puertos de switch Gigabit que conecten directamente con dos de los puertos de router. Aquí está una muestra:

bang> (enable) show module
Mod Slot Ports Module-Type                Model                Sub Status  
--- ---- ----- ------------------------- ------------------- ---  --------  
1   1    0     Switching  Supervisor      WS-X4012             no  ok  
2   2    34    10/100/1000  Ethernet      WS-X4232             no  ok  
3   3    34    Router Switch  Card        WS-X4232-L3          no  ok

Mod Module-Name         Serial-Num  
--- ------------------- --------------------  
1                        JAB02380AYG  
2                        JAB03210B6Y  
3                        JAB0417055S  

Mod MAC-Address(es)                         Hw     Fw          Sw  
--- -------------------------------------- ------ ---------- -----------------  
1   00-50-73-2a-f3-00 to 00-50-73-2a-f6-ff 1.0     4.5(1)     5.5(1)  
2   00-50-73-42-a9-68 to 00-50-73-42-a9-89 1.6  
3   00-01-42-06-73-a8 to 00-01-42-06-73-c9 1.0     12.0(7)W5( 12.0(7)W5(14.90

La única configuración agregada en el lado del Catalyst 4000 se relaciona con el tronco GEC con el módulo del router, pues esta muestra muestra:

bang> (enable) show config

# ***** NON-DEFAULT CONFIGURATION *****  
!  
! 
!  
!  
!  
set port channel all distribution mac both  
!  
#ip  
set interface sl0 down  
set interface me1 down  
!  
#set boot command  
set boot config-register 0x102  
set boot system flash bootflash:cat4000.5-5-1.bin  
!  
#port channel  
set port channel 3/1-2 156  
!  
#module 1 : 0-port Switching Supervisor  
!  
#module 2 : 34-port 10/100/1000 Ethernet  

set VLAN 3    2/3

!  
#module 3 : 34-port Router Switch Card  
set VLAN 2    3/3
set VLAN 99   3/1-2

!--- This interface has a configuration for 802.1Q routing. 
!--- The interface uses VLAN 99 as the native VLAN. The native VLAN on the 
!--- router switch must match the one that you have configured on the router.
!--- VLAN 99 is a dummy native VLAN. For more information, 
!--- see the note in the Sample Configurations section.


set trunk 3/1  nonegotiate dot1q 1-1005


!--- Note: Trunk mode needs to be in no-negotiate status
!--- because the router module does not support Dynamic Trunking Protocol (DTP).


set trunk 3/2  nonegotiate dot1q 1-1005
set port channel 3/1-2 mode on


!--- Note: You need to force the channel mode to on because
!--- the router module does not support Port Aggregation Protocol (PAgP).
  
end

En el Switch, el comando show cdp neighbor visualiza el módulo del router como si el módulo fuera un router externo que conecta por un tronco GEC en los puertos Gigabit 3/1 y 3/2. Aquí está una muestra:

bang> (enable) show cdp neighbor
* - indicates vlan mismatch.  
# - indicates duplex mismatch.  
Port     Device-ID                        Port-ID                    Platform  
-------- ------------------------------- -------------------------  ------------  
 2/3     daniella                         Ethernet0                  cisco 2500  
                                         
                                         
                                          
 3/3     donald                           Ethernet0                  cisco 2500

bang> (enable) show trunk 
* - indicates vtp domain mismatch  
Port      Mode          Encapsulation  Status        Native  vlan  
--------  -----------  -------------  ------------   -----------  
 3/1      nonegotiate  dot1q           trunking      99  
 3/2      nonegotiate  dot1q           trunking      99

Port      Vlans allowed on trunk  
--------  ---------------------------------------------------------------------  
 3/1      1-1005  
 3/2      1-1005

Port      Vlans allowed and active in management  domain  
--------  ---------------------------------------------------------------------  
 3/1      1-3, 99
 3/2      1-3, 99

Port      Vlans in spanning tree forwarding  state and not pruned  
--------  ---------------------------------------------------------------------  
 3/1      1-3, 99
 3/2      1-3, 99

Si usted tiene la salida de un comando show trunk de su dispositivo de Cisco, usted puede utilizar la herramienta del Output Interpreter (clientes registrados solamente) para visualizar los problemas potenciales y los arreglos.

bang> (enable) show port channel
Port  Status     Channel               Admin Ch  
                  Mode                  Group Id  
----- ---------- -------------------- ----- -----  
 3/1  connected  on                      156   833  
 3/2  connected  on                      156   833  
----- ---------- -------------------- ----- -----

Port  Device-ID                        Port-ID                    Platform  
----- ------------------------------- -------------------------  ----------------  
 3/1  bang-rp                          GigabitEthernet3           cisco Cat4232  
 3/2   Not directly connected to switch  
----- ------------------------------- -------------------------  ----------------

Si usted tiene la salida de un comando show port channel de su dispositivo de Cisco, usted puede utilizar la herramienta del Output Interpreter (clientes registrados solamente) para visualizar los problemas potenciales y los arreglos.

Configuración del módulo de router

bang-rp#show verify
Cisco Internetwork Operating System Software  
IOS (tm) L3 Switch/Router Software (CAT4232-IN-M), Version 12.0(7)W5(14.90)   INTERIM 
TEST SOFTWARE  
Copyright (c) 1986-2000 by cisco Systems, Inc.  
Compiled Fri 26-May-00 15:26 by integ  
Image text-base: 0x60010928, data-base: 0x605C8000  

ROM: System Bootstrap, Version 12.0(7)W5(15b) RELEASE SOFTWARE  

bang-rp uptime is 1 day, 22 hours, 7 minutes  
System restarted by power-on  
System image file is "bootflash:cat4232-in-mz.120-7.W5.14.90"  

cisco Cat4232 (R5000) processor with 57344K/8192K bytes of memory.  
R5000 processor, Implementation 35, Revision 2.1  
Last reset from power-on  
1 FastEthernet/IEEE 802.3 interface(s)  
4 Gigabit Ethernet/IEEE 802.3z interface(s)  
123K bytes of non-volatile configuration memory. 

16384K bytes of Flash internal SIMM (Sector size 256K).  
Configuration register is 0x1

bang-rp#show run
Building configuration...
Current Configuration:
!  
version 12.0  
no service pad  
service timestamps debug uptime  
service timestamps log uptime  
no service password-encryption  
!  
hostname bang-rp  
!  
!  
ip subnet-zero  
!  
!  
!  
interface Port-channel1                    
 no ip redirects  
 no ip directed-broadcast  
 hold-queue 300 in  
!  
interface Port-channel1.2 


!--- The configuration of this interface is for 802.1Q routing.
!--- The interface uses a VLAN 2 tag.


encapsulation dot1Q 2
ip address 2.2.2.2 255.255.255.0
no ip redirects
no ip directed-broadcast    
!  
interface Port-channel1.3

!--- The configuration of this interface is for 802.1Q routing.
!--- The interface uses a VLAN 3 tag.

encapsulation dot1Q 3  
ip address 1.1.1.2 255.255.255.0  
no ip redirects  
no ip directed-broadcast  
!
interface Port-channel1.99

!--- The configuration of this interface is for 802.1Q routing. 
!--- The interface uses VLAN 99 as the native VLAN. The native VLAN on the router 
!--- must match the one that you have configured on the switch. VLAN 99 is a dummy
!--- native VLAN. For more information, see the note
!--- in the Sample Configurations section.


encapsulation dot1Q 99 native
no ip address
no ip redirects
no ip directed-broadcast
!
interface FastEthernet1                  

!--- You can use this out-of-band interface for management.
  
 no ip address  
 no ip directed-broadcast  
 shutdown  
!  
interface GigabitEthernet1  
 ip address 3.3.3.2 255.255.255.0  
 no ip directed-broadcast  
!  
interface GigabitEthernet2  
 no ip address  
 no ip directed-broadcast  
 shutdown  
!  
interface GigabitEthernet3  
 no ip address  
 no ip directed-broadcast  
 no negotiation auto  
 channel-group 1                         

!--- Both  Gigabit Ethernet 3 and Gigabit Ethernet 4 
!--- are part of channel group 1.
  
!  
interface GigabitEthernet4  
 no ip address  
 no ip directed-broadcast  
 no negotiation auto  
 channel-group 1                          

!--- Both Gigabit Ethernet 3 and Gigabit Ethernet 4  
!--- are part of channel group 1.
  
!  
router eigrp 1  
 passive-interface FastEthernet1  
 network 1.0.0.0  
 network 2.0.0.0  
 network 3.0.0.0  
!  
ip classless  
!  
arp 127.0.0.2 0050.732a.f300 ARPA  
!  
line con 0  
 transport input none  
line aux 0  
line vty 0 4  
 login  
!  
end  
bang-rp#show cdp neighbor  
Capability Codes: R - Router, T - Trans Bridge, B - Source Route  Bridge  
                   S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce      Holdtme    Capability Platform  Port ID  
liki              Gig 1               
160         T S      
WS-C3508G-Gig 0/1                           

!--- Liki connects to gigabit 1 on the router. 
!--- You can only see Liki from the router; you cannot 
!--- see Liki from the Supervisor Engine.
  
JAB02380AYG(bang)Port-channel1      148          T S       WS-C4003  3/2  
JAB02380AYG(bang)Port-channel1      147          T S       WS-C4003  3/1

Troubleshooting

La sesión del supervisor al módulo 4232-L3 no trabaja después de que se ejecute para un rato

Después de que el Switch se ejecute para un rato, una sesión del supervisor al módulo 4232-L3 falla con este mensaje de error:

4006> (enable) session 2
Trying IntlgLineCard-2...
session: Unable to tunnel to IntlgLineCard-2 (57)

La mayoría de la causa probable para esto es debido a una adyacencia incorrecta formada en la tabla del Address Resolution Protocol (ARP) del módulo de Supervisor para la dirección MAC inband del módulo 4232-L3.

Este problema se puede resolver con una actualización del software del sistema a una versión CatOS no afectada por el Id. de bug Cisco CSCdx30617 (clientes registrados solamente).

Si una actualización del software del sistema no es posible, usted puede intentar estas soluciones alternativas:

  • En vez de sessioning al módulo, telnet a los IP Addresses uces de los configurados en ellos.

  • Una restauración del módulo 4232-L3 puede recuperar el problema temporalmente.

  • Un movimiento de la interfaz del sc0 en un diverso VLA N puede también resolver este problema.

Peticiones periódicas TFTP de 4232-L3

El módulo 4232-L3 intenta cargar una configuración de la red y visualiza continuamente este mensaje de error:

%Error opening tftp://255.255.255.255/network-config (Timed out)

El módulo L3 se puede configurar para descargar automáticamente el archivo de configuración de un servidor TFTP cuando usted publica el comando service config. Salve los archivos de configuración en un servidor TFTP y descarguelos mientras que inicia. Esto es útil cuando los tamaños del archivo de configuración son más grandes que los tamaños del NVRAM en el dispositivo.

Cuando el módulo L3 se configura con el comando service config, genera las peticiones TFTP de descargar su configuración de un servidor TFTP.

En un escenario donde se utiliza un IPS/IDS, usted puede ser que observe que el router envía continuamente el broadcast de tftp. Esto es confirmada por la dirección IP de la fuente y el destino es 255.255.255.255, tráfico es el UDP 69 (TFTP).

Para parar los mensajes del registro de la generación, publique estos comandos:

Router#config terminal
Router(config)#no service config
Router(config)#exit
Router#copy running-config startup-config

Conclusiones y consejos

Recuerde estos puntos claves cuando usted configura el módulo de ruteo en el Catalyst 4500/4000:

  • Las interfaces Gigabit que usted ve en el panel frontal no son lo mismo que las interfaces Gigabit que usted ve cuando usted publica el comando show port del Supervisor Engine. Las interfaces en el panel frontal son las interfaces con el gigabit 1 de los nombres y el gigabit 2 en el router.

  • Aseegurese que el VLAN nativo de los trunks entre el Switch y el router es un VLA N simulado. El CPU rutea en el software todo el tráfico que esté en el VLAN nativo. Por lo tanto, cree un VLA N adicional que usted no utilice a otra parte y haga ese VLA N el VLAN nativo en los links entre el Switch y el router.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 6198