Voz : H.323

Cómo configurar el video sobre IP para unidades de video de Polycom.

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe la configuración de red básica y la configuración de Polycom ViewStation128 (unidad de conferencia de video) con routers Cisco para aplicaciones de video sobre IP. También trata sobre la incorporación de QoS y sobre la solución de problemas de calidad de video en tiempo real a través de los medios LAN y WAN.

El Polycom Viewstation interconecta a un TV para mostrar el video capturado y a un audio; también tiene una conexión al LAN para pasar los paquetes del video comprimido sobre el IP. El Polycoms es los puntos finales H323 apenas como cualquier otro gateway. El vídeo sobre el IP utiliza los protocolos siguientes:

  • H.225 para mensajes sobre la señalización de control de llamadas.

  • H.245 para apertura y cierre de canales de secuencia de medios.

  • H.263 y H.261 para códec de video con formatos de imagen

  • G.723 para codecs de audio en los modos 5.3kpbs o 6.3kpbs

El software para Polycom ViewStation128 debe ser reciente y puede descargase del sitio Web de Polycom a través de LAN. La última versión de firmware disponible a la hora de la publicación de este documento era 7.0.1. http://www.polycom.com/home/ leavingcisco.com

ViewStation puede enviar una llamada de audio y video comprimidos a las velocidades 128k, 256k, 384k, 512k, 576k o 768k. Esta tasa de compresión no incluye los encabezados de IP y LAN/WAN agregados; por lo tanto, cuando reserve ancho de banda en QoS, recuerde tener en cuenta esta sobrecarga. Por ejemplo, Audio (64kbps)+ Video (704kbps)+IP(25% de tara)=960kbps.

El retardo óptimo para las aplicaciones de video es similar expresar: Round-Trip Time 125-150msec para los resultados óptimos. El tiempo de espera agregado es tolerable, pero señalado sobre el Polycom como error cuando usted telnet en él.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La configuración abajo fue probada en el laboratorio con el Software Release 12.1(5)T y 12.2(1a) de Cisco IOS� en los Cisco 7200 Router. Polycom ViewStation 128 tenía la versión de 7.0.1 del firmware.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de Consejos Técnicos de Cisco.

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama. Las conexiones Polycom están codificadas por software en semidúplex y a 10 Mbps. El 2900XL en este caso tiene todos los puertos puestos en hard-code a auto/al auto, así que no hay cambio necesario en el Cisco 7200 FE (interfaz Fast Ethernet), así que se fija a 100/Full. Si los Polycoms, en algunos casos, se conectan directamente al router o a los switches de Catalyst, los puertos deben configurarse para coincidir con dúplex y velocidad respectivamente.

/image/gif/paws/6172/polycom_video_over_ip1.gif

Configuración e instalación de Polycom ViewStation

Configuración de llamada H.323 para ViewStation

Siga estos pasos en System Info (Información del sistema) > Admin Setup (Configuración del administrador):

  1. En LAN/H.323 y LAN/Intranet, configure la dirección de IP del Polycom y de la puerta de enlace predeterminada.

  2. En LAN/H.323 y H323, configure el nombre H323 para esta ViewStation y cualquier identificación E164, si lo desea.

  3. (Opcional) Bajo LAN/H.323, y H323, QoS puede ser especificado para puertos específicos UDP o TCP. El rango de los puertos TCP fijos es 3230-3231 y los puertos fijos UDP son 3230 a 3235 para el tráfico de video. Aquí también puede configurar la precedencia IP como crítica en los paquetes.

  4. Bajo configuración general, configure la opción estándar tal como nombre del sistema, respuesta automática, marcado automático, lenguaje.

Realización de una llamada H.323 desde ViewStation

Todas las llamadas aquí se hacen usando el IP Address remoto; también puede usar números E.164 si utiliza un gatekeeper para realizar videollamadas. Bajo la pantalla principal, teclee adentro la dirección IP para el polycom remoto, después seleccione la velocidad de la compresión; esto debería coincidir con lo que configuró como predeterminado en el lado remoto.

Configuración de routers con QoS para video

Uno de los métodos QoS más efectivos usados para VideoOverIP sobre WAN es Low Latency Queuing (LLQ). El policymap se puede basar en algunos diversos parámetros, discutidos abajo. El ancho de banda necesario puede ser dedicado y se puede dar prioridad al video sobre otras aplicaciones IP con LLQ. Además, para una mejor calidad de video, el link ATM debería ser VBR-NRT o CBR.

Configuración de 7206VXR

Cisco 7206VXR
!
class-map match-all video
  match access-group 101

!--- Class map used to associate access-list 101 to the LLQ class video.

!
policy-map video-police

!--- Definition of the policy map for the LLQ Configuration
 
  class video
    priority 900

!--- This is the priority class/queue assigned for video traffic.
!--- It reserves 900 Kbps for video traffic
  
  class class-default
   fair-queue 64

!-- All other non-video traffic uses fair-queuing policing.
 
!
interface FastEthernet0/0
 description Polycom-192.168.3.90
 ip address 192.168.3.100 255.255.255.0
 duplex half
 no cdp enable

!--- This is the LAN interface that connects to the Polycom ViewStation
!--- No QoS (LLQ) was applied here.
 

!
interface ATM6/0
 no ip address
 load-interval 30
 no atm ilmi-keepalive
!
interface ATM6/0.1 point-to-point
 ip address 10.1.105.1 255.255.255.0
 pvc 1/138

!--- atm pvc defined 

  class-vc VBR-NRT
  encapsulation aal5snap

!--- Layer 2 encapsulation type for atm packets

  service-policy out video-police

!--- Applies LLQ (defined above) to the subinterface for 
!--- layer 3 (Video over IP)traffic shaping and priotization

!
vc-class atm VBR-NRT

!--- atm traffic shaping class defined

  vbr-nrt 1500 1400 100

!--- Maximum bandwidth at 1500Kbps and nominal at 1400Kbps with 100Kbps burst

!
access-list 101 permit tcp any any range 3230 3231
access-list 101 permit udp any any range 3230 3235

!--- These access-lists are used by the LLQ class-map.
!--- These access-lists are based on the fixed UDP (3230-3235) 
!--- and TCP (3230-3231) ports for the ViewStation VideoOverIP


Alternativamente, las configuraciones de la lista de acceso siguientes habrían podido ser utilizadas.

  • De acuerdo con el IP Address de origen/destino de las unidades ViewStationes:

    host 192.168.1.90 de 192.168.3.90 del host del IP del permiso del access-list 101

    host 192.168.3.90 de 192.168.1.90 del host del IP del permiso del access-list 101

  • De acuerdo con la Prioridad IP 5:

    precedencia 5 del access-list 101 permit ip any any

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Cuando se establece una llamada, el Polycom no pierde de vista todos los paquetes de video. Puede conectar telnet en el polycom y controlar esto de cerca. Polycom informa la latencia en los paquetes H323, los paquetes de audio o video perdidos. Los debugs del Polycom son legibles e indican los problemas cuando puede ser duro notarlos en una pantalla de vídeo.

Algunos de los problemas de video más comunes, como el congelamiento, resultan de una discordancia en el dúplex y/o velocidad Ethernet. Si los contadores de los Ethernetes indican el número grande de paquetes CRC/frame/deferred, la calidad del video degradará considerablemente, así que el primer punto de verificación está aseegurando todas las interfaces LAN ejecuta sin error.

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Puede controlar las configuraciones del polycom por medio de la información que se muestra al comienzo. Existen depuraciones informativas activadas para cada acción. Cuando usted tiene una llamada video, el Polycoms señala automáticamente el tiempo de espera calculado en los paquetes: todos los paquetes perdidos y aquellos con una nueva secuencia como resultado de los paquetes perdidos.

MS-7206VXR-12A#telnet 192.168.3.90

!--- Action: Telnetting to the Polycom ViewStation unit to capture information 
!--- and debug output. 
!--- When a call is established, the Polycom unit keeps track of video packets. 
!--- The Polycom reports h323 packet latency and lost video and voice packets.


Trying 10.122.3.90 ... Open

Hi, my name is :     Polycom166-regnl
Here is what I know about myself:
Serial Number:       011B12
Brand:               Polycom
Software Version:    Release 7.0.1 - 16 Jun 2001
Model:               VS
Network Interface:   ISDN_UNKNOWN
MP Enabled:          No
H323 Enabled:        Yes
IP Address:          192.168.3.90
Time In Last Call:   0:08:41
Total Time In Calls: 44:20:06
Total Calls:         171
Switch Type:         Nortel DMS-100
Country Code:        1
Area Code:           919
ISDN 1 a is:         9913293
ISDN 2 a is:         9913294

Antes de que QoS fuera aplicado, cuando el vídeo y los datos fueron funcionados con al mismo tiempo, el resultado telnet en el polycom señalaría el siguiente; esto es un claro indicador de que hay problemas en la red que afectan también la calidad de video.

RTP: Video Packet Lost
RTP: Reseting last_seq_num from 23397 to 23398
RTP: Send FastVideoPicture_MSG
RTP: last eBit 6 plus new sBit 0 not equal 8! (instance 0)
...VideoFastUpdatePictureHandler() time 469850
RTP: Max. video packets stored = 4
RTP: Minimum/MaximumThreshold = 4 0/256, 4 0/256
UI:UI msg from VidDec: S VD1 ReceivedFreezeRelease 0
Received a Picture Fast Update request from the other side
Audio Packet(s) lost - last_seq_num = 15147, new_seq_num = 15149
Transfer 1 duplicate packets
Received a Picture Fast Update request from the other side
RTP: Max. video packets stored = 1
RTP: Minimum/MaximumThreshold = 4 0/256, 4 255/256

Comandos para resolución de problemas

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

La siguiente salida se capturó en los routers de Cisco IOS. LLQ se aplicó en las interfaces ATM y luego se enviaron pings inundados para crear congestión durante la llamada de video. Cuando hay contención para ancho de banda, el LLQ da prioridad dinámicamente al tráfico de video.

MS-7206VXR-12A#show queue atm 6/0.1

  Interface ATM6/0.1 VC 1/138 
  Queuing strategy: weighted fair
  Total output drops per VC: 22863
  Output queue: 66/512/64/22863 (size/max total/threshold/drops)
     Conversations  3/4/64 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 0 kilobits/sec

  (depth/weight/total drops/no-buffer drops/interleaves) 1/4626/0/0/0
  Conversation 1, linktype: ip, length: 54
  source: 10.122.3.100, destination: 10.1.105.2, id: 0x002B, ttl: 255,
  TOS: 192 prot: 6, source port 23, destination port 11032

  (depth/weight/total drops/no-buffer drops/interleaves) 1/5397/0/0/0
  Conversation 51, linktype: ip, length: 308
  source: 10.122.3.90, destination: 10.122.1.90, id: 0x51AB, ttl: 59,
  TOS: 160 prot: 17, source port 49206, destination port 3232

Nótese que en la siguiente salida no se producen pérdidas de paquetes de la clase video.

MS-7206VXR-12A#show policy-map int atm 6/0.1
 ATM6/0.1: VC 1/138 -

  Service-policy output: video-police

    Class-map: video (match-all)
      0 packets, 0 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: access-group 101
      Weighted Fair Queueing
        Strict Priority
        Output Queue: Conversation 72 
       Bandwidth 900 (kbps) Burst 22500 (Bytes)
        (pkts matched/bytes matched) 0/0
        (total drops/bytes drops) 0/0

    Class-map: class-default (match-any)
      290307 packets, 252480609 bytes
      30 second offered rate 2951000 bps, drop rate 2341000 bps
      Match: any 
      Weighted Fair Queuing
        Flow Based Fair Queuing
        Maximum Number of Hashed Queues 64 
        (total queued/total drops/no-buffer drops) 67/35584/0

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 6172