Switching por etiquetas multiprotocolo (MPLS) : MPLS

Configuración de Inter-AS MPLS VPN con sesiones VPNv4 eBGP entre ASBR

16 Enero 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (10 Diciembre 2015) | Comentarios


Contenido


Introducción

Este documento muestra un ejemplo de configuración de una VPN básica de conmutación de etiquetas multiprotocolo (MPLS) entre sistemas autónomos (inter-AS).

prerrequisitos

Requisitos

Este documento asume un conocimiento sobre el funcionamiento del MPLS y del MPLS VPN. Vea por favor la sección de la “información relacionada” de este documento para los links a otros documentos del MPLS VPN.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software:’

  • Software Release 12.2 y 12.2T de Cisco IOS�

Nota: Porque esta configuración utiliza una mezcla de códigos, el (TDP) del Tag Distribution Protocol se utiliza bastante que el Protocolo de distribución de etiquetas (LDP). En una configuración LDP pura, la Base de información de reenvío de indicadores (TFIB) se reemplazar por la Base de información de reenvío de etiquetas (LFIB), el comando show tag forwarding se convertiría en el comando show mpls forwarding, y así sucesivamente.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones de Consejos Técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la Command Lookup Tool (solo para clientes registrados).

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

http://www.cisco.com/c/dam/en/us/support/docs/multiprotocol-label-switching-mpls/mpls/5811-interasvpn-01.gif

Configuraciones

Este documento utiliza las configuraciones mostradas abajo para el Routers en el diagrama de la red arriba.

Pulligny
version 12.2
!
hostname Pulligny
!
ip cef

!--- Cisco Express Forwarding (CEF) must be enabled for MPLS.

!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
 ip router isis
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 description to Paulliac
 ip address 10.1.1.2 255.255.255.252
 ip router isis
 tag-switching ip

!--- TDP or LDP needs to be enabled inside each AS.

 frame-relay interface-dlci 913
!
interface Serial0/0.2 point-to-point
 description to Pomerol
 ip address 10.1.1.10 255.255.255.252
 frame-relay interface-dlci 912

!--- No TDP, LDP, or routing protocols enabled on the inter-AS link.

!
router isis
 redistribute connected metric 20

!--- To get the host route created by the Border Gateway Protocol (BGP)
!--- into the Interior Gateway Protocol (IGP).

 net 47.0000.5555.5555.5555.00
 metric-style wide
!
router bgp 1
 no bgp default ipv4-unicast

!--- BGP is not used for IPv4 unicast.

 no bgp default route-target filter

!--- Needed to accept VPNv4 prefixes.

neighbor 10.1.1.9 remote-as 2

!--- External BGP (eBGP) to Pomerol.

 neighbor 10.10.10.4 remote-as 1
 neighbor 10.10.10.4 update-source Loopback0

!--- Internal BGP (iBGP) to PEscara.

 !
 address-family vpnv4
 neighbor 10.1.1.9 activate
 neighbor 10.1.1.9 send-community both
 neighbor 10.10.10.4 activate
 neighbor 10.10.10.4 send-community extended
 exit-address-family

!--- Address family to allow BGP to carry VPN-IPv4 protocols.

!
ip classless
!
end

Pescara
hostname PEscara
!
ip vrf one
 rd 1:1
 route-target export 1:1
 route-target import 1:1

!--- Create a virtual routing and forwarding (VRF) instance called one 
!--- with a route distinguished value of 1:1. Routes with route target
!--- values of 1:1 will be imported into the VRF and exported out
!--- of the VRF.

ip cef

!--- CEF must be enabled for MPLS.

!
interface Loopback0
 ip address 10.10.10.4 255.255.255.255
 ip router isis
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type cisco
!
interface Serial0/1.1 point-to-point
 description to Pauillac
 ip address 10.1.1.14 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 973
!
interface Serial0/1.2 point-to-point
 description to CEntrum
 ip vrf forwarding one

!--- Associates the interface with VRF one.

 ip address 120.0.0.1 255.255.255.0
 frame-relay interface-dlci 979
!
router isis
 net 47.0000.7777.7777.7777.00
 metric-style wide
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 10.10.10.2 remote-as 1
 neighbor 10.10.10.2 update-source Loopback0

!--- iBGP to Pulligny.

 !
 address-family ipv4 vrf one
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family

!--- Address family to allow BGP to carry IPv4 protocols for VRF one
!--- (each VRF that injects routes into BGP must be configured under
!--- the BGP process using its own address family).

 !
 address-family vpnv4
 neighbor 10.10.10.2 activate
 neighbor 10.10.10.2 send-community both
 exit-address-family

!--- Address family to allow BGP to carry VPN-IPv4 protocols.

!
ip classless
!
end

Pauillac

!--- The Pauillac router is a Provider router (p) and its configuration
!--- is quite simple. It is configured for Intermediate System-to-
!--- Intermediate System (IS-IS) and MPLS/Tag switching.

!
hostname Pauillac
!
ip cef
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
 ip router isis
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 description to Pulligny
 ip address 10.1.1.1 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 931
!
interface Serial0/0.3 point-to-point
 description to PEscara
 ip address 10.1.1.13 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 937
!
router isis
 net 47.0000.3333.3333.3333.00
 metric-style wide
!
ip classless
!
end

Pomerol

!--- The Pomerol router is an autonomous system boundary router (ASBR)
!--- like Pulligny and its configuration is very similar to Pomerol's. 

hostname Pomerol
!
ip cef
!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
 ip router isis
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 description to Pulligny
 ip address 10.1.1.9 255.255.255.252
 frame-relay interface-dlci 921
!
interface Serial0/0.3 point-to-point
 description to PEsaro
 ip address 10.1.1.21 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 925
!
router isis
 redistribute connected metric 20
 net 47.0000.2222.2222.2222.00
 metric-style wide
!
router bgp 2
 no bgp default ipv4-unicast
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor 10.1.1.10 remote-as 1
 neighbor 10.10.10.6 remote-as 2
 neighbor 10.10.10.6 update-source Loopback0
 !
 address-family vpnv4
 neighbor 10.1.1.10 activate
 neighbor 10.1.1.10 send-community both
 neighbor 10.10.10.6 activate
 neighbor 10.10.10.6 send-community extended
 exit-address-family
!
ip classless
!
end

Pesaro

!--- The PEsaro router is a PE router like the PEscara router, and its 
!--- configuration is very similar.

hostname PEsaro
!
ip vrf one
 rd 1:1
 route-target export 1:1
 route-target import 1:1
ip cef
!
interface Loopback0
 ip address 10.10.10.6 255.255.255.255
 ip router isis
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
!
interface Serial0/1.1 point-to-point
 description to Pomerol
 ip address 10.1.1.22 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 952
!
interface Serial0/1.2 point-to-point
 description to CErvela
 ip vrf forwarding one
 ip address 220.0.0.1 255.255.255.0
 frame-relay interface-dlci 958
!
router isis
 net 47.0000.5555.5555.5555.00
 metric-style wide
!
router bgp 2
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 redistribute connected
 neighbor 10.10.10.3 remote-as 2
 neighbor 10.10.10.3 update-source Loopback0
 no auto-summary
 !
 address-family ipv4 vrf one
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 10.10.10.3 activate
 neighbor 10.10.10.3 send-community both
 no auto-summary
 exit-address-family
!
ip classless
!
end

Notas de configuración

  • eBGP entre ambos AS no puede ser multisalto.

  • El LDP o el TDP no se requiere entre ambos AS.

  • No se necesita un IGP común entre los dos AS. Cada uno COMO puede utilizar su propio IGP distinto.

  • El BGP crea una ruta del host conectado para el par del eBGP en el telecontrol COMO una vez que la sesión que necesita ser inyectada en el IGP de cada uno COMO sube.

  • A menos que el ASBR sea un PE para cada VRF que desea intercambiar, necesitará configurar el comando no bgp default route-target filter para asegurarse de que el ASBR acepte los prefijos de VPNv4 BGP desde los otros routers PE dentro de AS. El comportamiento predeterminado es negar los prefijos VPNv4 entrantes que no son importados en cualquier local VRF.

Verificación e introducción a Inter-AS MPLS VPN

En esta sección encontrará información que puede utilizar para corroborar que su configuración esté funcionando correctamente.

La herramienta Output Interpreter (sólo para clientes registrados) permite utilizar algunos comandos “show” y ver un análisis del resultado de estos comandos.

Para más información sobre los comandos usados abajo, vea por favor cómo resolver problemas el MPLS VPN.

Los siguientes ejemplos muestran el flujo de paquetes a partir del 220.0.0.0/24 — cuál es un prefijo conectado VRF uno en el Pesaro — a 120.0.0.0/24 — cuál es un prefijo conectado VRF uno en el PEscara.

Router PEsaro

Abajo están las rutas para VFR uno en el router Pesaro.

PEsaro# show ip route vrf one
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    220.0.0.0/24 is directly connected, Serial0/1.2
     120.0.0.0/24 is subnetted, 1 subnets
B       120.0.0.0 [200/0] via 10.1.1.10, 00:26:49

PEsaro# show ip cef vrf one 120.0.0.1
120.0.0.0/24, version 10, cached adjacency to Serial0/1.1
0 packets, 0 bytes
  tag information set
    local tag: VPN-route-head
    fast tag rewrite with Se0/1.1, point2point, tags imposed: {17 22}
  via 10.1.1.10, 0 dependencies, recursive
    next hop 10.1.1.21, Serial0/1.1 via 10.1.1.10/32
    valid cached adjacency
    tag rewrite with Se0/1.1, point2point, tags imposed: {17 22}

En la salida antedicha, usted puede ver que el salto siguiente para 120.0.0.0/24 es 10.1.1.10. Usted puede también ver que las etiquetas impuestas son 17 y 22. El TFIB y la información sobre BGP (abajo) le muestra la fuente de estas etiquetas: la ruta BGP para 120.0.0.0/24 tiene una etiqueta de salida de 22 y el próximo salto asociado con 120.0.0.0/24 tiene una etiqueta de salida de 17.

PEsaro# show ip bgp vpnv4 vrf one tags
   Network          Next Hop      In tag/Out tag
Route Distinguisher: 1:1 (one)
   120.0.0.0/24     10.1.1.10       notag/22

!--- VPN label.

   220.0.0.0        0.0.0.0         18/aggregate(one)

PEsaro# show tag forwarding 10.1.1.10
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
17     17          10.1.1.10/32      0          Se0/1.1    point2point

PEsaro# show ip route 10.1.1.10
Routing entry for 10.1.1.10/32
  Known via "isis", distance 115, metric 30, type level-2
  Redistributing via isis
  Last update from 10.1.1.21 on Serial0/1.1, 00:30:39 ago
  Routing Descriptor Blocks:
  * 10.1.1.21, from 10.10.10.3, via Serial0/1.1
      Route metric is 30, traffic share count is 1

Pomerol anuncia 10.1.1.10. Es la ruta host creada por BGP, que es importante porque se muestra como el siguiente salto BGP para los prefijos remotos VPNv4, según se muestra en el resultado que figura anteriormente. El Pesaro envía un paquete con dos escrituras de la etiqueta al Pomerol; la etiqueta de “interna” o “IGP” es 17.

Router Pomerol

Pomerol# show tag forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     10.10.10.6/32     0          Se0/0.3    point2point
17     Pop tag     10.1.1.10/32      540        Se0/0.1    point2point
18     18          1:1:220.0.0.0/24  1704       Se0/0.3    point2point

Pomerol# show ip route 10.1.1.10
Routing entry for 10.1.1.10/32
  Known via "connected", distance 0, metric 0 (connected, via interface)
  Redistributing via isis
  Advertised by isis metric 20 metric-type internal level-2
  Routing Descriptor Blocks:
  * directly connected, via Serial0/0.1
      Route metric is 0, traffic share count is 1

Nota: La ruta /32 para 10.1.1.10 se crea apenas se activa eBPG.

En la salida antedicha, usted puede ver que el Pomerol quiere el “estallido” la escritura de la etiqueta superior si es 17; la escritura de la etiqueta del eBGP VPN será la única escritura de la etiqueta dejada en los paquetes enviados al Pulligny en el AS1.

Router Pulligny

Pulligny# show tag forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     10.1.1.9/32       540        Se0/0.2    point2point
17     Pop tag     10.1.1.12/30      0          Se0/0.1    point2point
18     Pop tag     10.10.10.1/32     0          Se0/0.1    point2point
19     16          10.10.10.4/32     0          Se0/0.1    point2point
21     Pop tag     10.1.1.4/30       0          Se0/0.1    point2point
22     16          1:1:120.0.0.0/24  1080       Se0/0.1    point2point

La salida antedicha muestra que el Pulligny tiene etiquetas locales y salientes para 120.0.0.0/24; considere, sin embargo, la siguiente entrada TFIB detallada:

Pulligny# show tag forwarding detail | begin 22
22     16          1:1:120.0.0.0/24  1080       Se0/0.1    point2point
        MAC/Encaps=4/12, MTU=1496, Tag Stack{16 23}
        E4118847 0001000000017000
        No output feature configured

La salida antedicha muestra que el Pulligny tiene una entrada del VPNv4 en su TFIB, que es necesario porque hay solamente una escritura de la etiqueta sobre link entre AS. Puesto que el Pomerol hizo estallar la escritura de la etiqueta 17 de la pila de etiquetas, el Pulligny recibe un paquete con la escritura de la etiqueta 22. Hará estallar la escritura de la etiqueta 22 y la escritura de la etiqueta 23 del empuje y la escritura de la etiqueta 16. Mirando el TFIB y la información sobre BGP (mostrados abajo) usted puede ver que 16 es la escritura de la etiqueta IGP a conseguir al PEscara, y 23 sea la escritura de la etiqueta VPN de que el PEscara hace publicidad para 1:1:120.0.0.0/24.

Pulligny# show ip bgp vpnv4 all tagging
   Network          Next Hop      In tag/Out tag
Route Distinguisher: 1:1
   120.0.0.0/24     10.10.10.4      22/23
   220.0.0.0        10.1.1.9        notag/18

Pulligny# show tagging for 10.10.10.4
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
19     16          10.10.10.4/32     0          Se0/0.1    point2point

Tenga en cuenta que Pulligny cambia la etiqueta VPN que obtiene de PEScara y anuncia una etiqueta diferente a Pomerol. De este modo, agrega una entrada para 1:1:120.0.0.0/24 a su TFIB. Este comportamiento es el valor por defecto porque la escritura de la etiqueta cambia siempre que el Next-Hop cambie (por ejemplo en las sesiones eBGP entre ambos AS); por lo tanto, el ASBR tendrá una entrada de TFIB para cada prefijo VPN dentro de su local COMO. El resultado que se detalla abajo muestra que Pauillac posee un cambio o salto de identificación simple porque el PE es el próximo salto (Cambio del penúltimo salto [PHP]).

Pauillac# show tag forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     10.10.10.4/32     111049     Se0/0.3    point2point
17     Pop tag     10.10.10.2/32     94769      Se0/0.1    point2point
18     Pop tag     10.1.1.8/30       0          Se0/0.1    point2point
19     16          10.1.1.9/32       560        Se0/0.1    point2point

Cuando PEscara recibe la etiqueta 23, la reconoce como parte de un VRF y realiza una consulta de IP para reenviarla a la interfaz correcta (como se ilustra en el siguiente resultado).

PEscara# show tag forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     10.1.1.0/30       0          Se0/1.1    point2point
17     Pop tag     10.1.1.4/30       0          Se0/1.1    point2point
18     Pop tag     10.10.10.1/32     0          Se0/1.1    point2point
19     17          10.10.10.2/32     0          Se0/1.1    point2point
21     18          10.1.1.8/30       0          Se0/1.1    point2point
22     19          10.1.1.9/32       0          Se0/1.1    point2point
23     Aggregate   120.0.0.0/24[V]   1040

PEscara# show tag forwarding detail | begin 23
23     Aggregate   120.0.0.0/24[V]   1040
        MAC/Encaps=0/0, MTU=0, Tag Stack{}
        VPN route: one
        Feature Quick flag set

La salida abajo es un ejemplo de un paquete que es enviado usando el flujo de paquetes explicado arriba.

Pomerol#
*Mar  1 19:49:59.103: TAG: Se0/0.3: recvd: CoS=0, TTL=255, Tag(s)=17/22
*Mar  1 19:49:59.103: TAG: Se0/0.1: xmit: CoS=0, TTL=254, Tag(s)=22

Pulligny#
*Mar  1 20:21:35: TAG: Se0/0.2: recvd: CoS=0, TTL=254, Tag(s)=22
*Mar  1 20:21:35: TAG: Se0/0.1: xmit: CoS=0, TTL=253, Tag(s)=16/23

Pauillac#
*Mar  1 19:56:39.627: TAG: Se0/0.1: recvd: CoS=0, TTL=253, Tag(s)=16/23
*Mar  1 19:56:39.627: TAG: Se0/0.3: xmit: CoS=0, TTL=252, Tag(s)=23

PEscara#
*Mar  1 19:57:00.463: TAG: Se0/1.1: recvd: CoS=0, TTL=252, Tag(s)=23

El comando next-hop-self en ASBR

Si usted elige configurar el comando next-hop-self hacia el iBGP mira en los ASBR, el ASBR hace publicidad de una diversa escritura de la etiqueta (porque se hace publicidad una nueva escritura de la etiqueta cuando los cambios del Next-Hop) a los pares del iBGP, agregando una entrada para el telecontrol COMO rutas del VPNv4 en su TFIB. Esto crea un estado adicional en ASBR. No es necesario redistribuir la ruta del host creada por BGP dentro del protocolo IGP. Como se muestra a continuación, el ASBR ahora permite el ingreso de prefijos de VPN tanto locales como remotas.

Pomerol# show tag forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     10.10.10.6/32     0          Se0/0.3    point2point
17     Pop tag     10.1.1.10/32      540        Se0/0.1    point2point
18     18          1:1:220.0.0.0/24  0          Se0/0.3    point2point
19     22          1:1:120.0.0.0/24  0          Se0/0.1    point2point

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 5811